1

r1 = 4 Ом E1= 10 В

r2 = 2 Ом E2 = 6 В

r3 = 2 Ом E3= 3 В

r4 = 5 Ом E4 = 8 В

r12 = 3 Ом

r14 = 2 Ом

r23 = 1 Ом

r34 = 6 Ом

1.Составляем уравнение для 1 контура (I11) по 2 закону Киргофа применяя правило знаков: Обход контура и ток или ЕДС совпадают +, не совпадают -

Обход самого контура: I11(r1 + r12 + r14)

От 2 контура: - I22r12

От 3 контура: влияние на 1 контур нет

От 4 контура: + I44r14

Уравнение: I11(r1 + r12 + r14) - I22r12 + I330 + I44r14 = E1

2. По такому же принципу составляем уравнения для 2, 3 и 4 контуров:

I22(r2 + r23 + r12) - I11r12 + I33 r23 + I440 = E2

I33(r3 + r34 + r23) + I110 + I22 r23 - I44 r34 = E2 – E3

I44(r34 + r14 + r4) + I11 r14 + I22 0 - I33 r34 = E4

3.Перегруперуем систему уравнений в каноническую форму для ввода данных в программу:

I11(r1 + r12 - r14) - I22r12 + I330 + I44r14 = E1

-I11r12 + I22(r2 + r23 + r12) + I33 r23 + I440 = E2

I110 + I22 r23 + I33(r3 + r34 + r23) - I44 r34 = E2 – E3

I11r14 + I22 0 - I33 r34 + I44 (r34 + r14 + r4) = E4

I11(4 + 3 + 2) - I223 + I330 + I442 = 10

-I113 + I22(2 + 1 + 3) + I33 1 + I440 = 6

I110 + I22 1 + I33(2 + 6 + 1) - I44 6 = 6 – 3

I112 + I22 0 - I33 6 + I44 (6 + 2 + 5) = 8

9 -3 0 2 10

-3 6 1 0 6

0 1 9 -6 3

2 0 -6 13 8

Устанавливаем переключатель на нужное количество контуров и вводим цифры (или загружаем раннее сохранение) в соответствующие текстовые поля. Желтые поля – поля собственных сопротивлений контуров (для I контура (r1 + r12 + r14)). Белые поля – сопротивления входящие в оба контура – общее сопротивление (для I и II контура r12; для I и IV - r14; для I и III общего сопротивления нет).

При вводе в текстовые поля используйте клавишу ENTER.

Нажимаем кнопку Расчет. В полях I11, I22….I99 определятся контурные токи, соответственно 1,2,3….9 контуров.

После определения контурных токов включаем калькулятор определения тока в ветвях и баланса мощности. В столбце тока I автоматически отобразятся ранее рассчитанные контурные токи. В столбце Заметки можно (не обязательно) сделать краткие записи. В соответствии с 1 законом Киргофа щелкаете по полям столбца I (I11 и I22 ; I12 = I11 – I22 производится запись в расчетном поле +1,52 - + 1,66, выбрав при этом, если необходимо знак «минус» , после 1,52 знак -, если идет сложение I14 = I1 + I4 то знак можете не выбирать: +1,52 + 1,66 ).

В поле результата будут отображаться рассчитанные токи в ветвях (-0,14 и 2,17).

После каждого расчета для запоминания тока нажимайте кнопки 1,2….20

После того как определили все токи устанавливаем переключатель в рамке Рассчитать на Баланс мощности.

Баланс основан на законе сохранения и превращения энергии: сколько энергии выработали источники, столько же ее нагрузки должны потребить. Вместо энергии в балансе можно использовать мощность. Выработанная мощность всеми источниками должна быть равна суммарной мощности, расходуемой в нагрузках.

Баланс мощностей можно сформулировать так: алгебраическая сумма мощностей источников, должна быть равна арифметической сумме мощностей нагрузок.

В столбцы сопротивлений R и ЭДС E заносим значения сопротивлений и ЭДС для каждой ветви ( Контурный ток I11 соответствует току в ветви I1 = 1,52, сопротивление обтекаемое этим током R1 = 4 Ом, ЭДС E1 = 10В). Внимание: Если направление ЭДС и направление тока ветви не совпадают, то составляющая мощности этого источника в балансе мощностей берется со знаком «минус». (например для Е2 вводим -3 В)

При вводе в текстовые поля используйте клавишу ENTER.