Soft School - Настройка Windows XP - Оптимизация и ускорение

Настройка Windows XP

Оптимизация и ускорение

Этот раздел не претендует на оригинальность. Я предложу вам лишь то, что использую сам, что, впрочем, делает работу в Windows XP достаточно комфортной. Для любителей оптимизировать, сокращать и укрощать XP, выпущены программы-твикеры, о которых мы поговорим позже и подробно.

Оптимизацию мы будем производить пошагово и начнем со свойств системы, для чего нажимаем кнопку Пуск выбираем команду Панель управления. Щелкаем категорию Производительность и обслуживание, затем выбираем значок Система. В открывшемся окне нажимаем вкладку Восстановление системы.

На этой вкладке мы отключаем восстановление системы на всех логических дисках. Для этого выделяем нужный нам диск и жмем на кнопку Параметры. В открывшемся окне ставим галочку "отключить восстановление системы на этом диске"

Аналогичную операцию производим со всеми остальными логическими дисками. Восстановление системы на системном диске С: целесообразно оставить.

Переходим на вкладку Автоматическое обновление.

Автоматическое обновление системы отключаем, поскольку хоть это вещь полезная и нужная, но имеет привычку включаться в самый неподходящий момент. О размерах загружаемых обновлений можно при этом только догадываться, а докачка файлов отсутствует. К тому же операцию обновления системы можно спокойно и выборочно произвести через Windows Update вручную.

Следующая вкладка, интересующая нас - Дополнительно

В разделе Быстродействие жмем Параметры и выбираем вкладку Визуальные эффекты, где снимаем галочки со следующих эффектов:

  • Анимация окон при свертывании и развертывании
  • Затухание меню после вызова команды
  • Отображать тени, отбрасываемые меню
  • Эффекты затухания или скольжения при обращении к меню
  • Эффекты затухания или скольжения при появлении подсказок

Можно, конечно поставить флажок на "Обеспечить наилучшее быстродействие", но в этом случае нас ожидает аскетичный вид Windows 2000. Мне хватило и вышеперечисленных настроек, поскольку они, не нарушая внешнего вида XP, ускоряют открытие и закрытие окон, меню и подсказок, чего и хотелось собственно.

Переходим на вкладку Дополнительно, где нас интересует раздел Виртуальная память.

По поводу размеров файла подкачки, то бишь виртуальной памяти, существует множество мнений и все они сводится к одному - он несоразмерно велик. По умолчанию Windows XP устанавливает размер файла подкачки равным 1,5 размера памяти оперативной, что само по себе не так уж и много учитывая размеры современных дисков. Проблема, на мой взгляд, в другом. Чем больше размер файла, тем чаще он фрагментируется, что в свою очередь приводит к фрагментации других файлов находящихся на диске. Происходит своего рода "цепная реакция", результат которой замедление работы системы. Дефрагментировать же файл подкачки средствами Windows XP невозможно.

Решать эту проблему мы будем следующим образом. В разделе Виртуальная память жмем Изменить и видим следующее:

В поле Исходный размер вводим значение равное размеру вашей оперативной памяти (в моем случае 256 MB). В поле Максимальный размер вводим удвоенное значение (у меня 512 MB). Жмем Задать и OK. После этого систему следует перезагрузить.

Размер файла подкачки и его расположение на жестком диске играет важное значение в быстродействии системы. И если вы настраиваете Windows XP сразу после установки, то теперь самое время произвести дефрагментацию диска (Чтобы запустить программу "Дефрагментация диска", нажмите кнопку Пуск, выберите команды Все программы, Стандартные, Служебные и Дефрагментация диска). В этом случае файл подкачки будет расположен в максимальной близости с файлами Системы, что нам и нужно. В противном случае вам придется регулярно производить дефрагментацию диска или воспользоваться программой Norton Speed Disk из комплекта Norton System Works: в настройках этого продукта имеется опция, позволяющая перемещать в начало диска файлы, указанные пользователем.
Раздел Загрузка и восстановление не доставит хлопот. Здесь можно снять галочку "Отображать список операционных систем" и этим ограничиться.
Отчет об ошибках, пожалуй, самая надоедливая вещь при работе в Windows XP. При малейшем сбое системы или программ нам предлагают отправить отчет об ошибках в компанию Майкрософт. Если вы согласны - пожалуйста! А я отключил и работаю спокойно.

Правда уведомления о критических ошибках я решил оставить. Так, на всякий случай :)

Пришла пора разобраться со свойствами Электопитания. Чтобы открыть компонент «Электропитание», нажмите кнопку Пуск, выберите команду Панель управления, щелкните категорию Производительность и обслуживание, затем щелкните значок Электропитание.
Если вы не планируете использовать Спящий режим, то эту функцию следует отключить, сняв галочку в соответствующем разделе. Как следствие на вкладке Дополнительно следует выставить следующие параметры:
Оставлять компьютер включенным надолго без присмотра хоть и можно, но стоит помнить о скачках напряжения и прочих радостях нашей действительности. А посему мы надеется на автоматическое отключение дисков не будем. Ресурсы монитора, наоборот, стоит поберечь. Исходя из сказанного, Схема управления питанием может выглядеть примерно так:
Следующие настройки касаются свойств Панели задач и меню Пуск. Делаем правый клик по кнопке Пуск и выбираем в контекстном меню Свойства.

Настройки вкладки Панели задач достаточно очевидны. Скажу лишь несколько слов о панели быстрого запуска. Туда можно помещать ярлыки программ (перетаскивая их из любого окна или рабочего стола), которые вы используете чаще всего. Программы запускаются одним кликом по ярлыку.

Можно настроить отображение (скрытие) значков в системном трее (рядом с часами). Жмем кнопку Настроить и в выпадающем меню выбираем нужное действие.
Любители классического меню могут переключиться на него выбрав соответствующий пункт, а мы кликаем по кнопке Настроить и выбираем вкладку Дополнительно.

Снимаем галочки с первых двух пунктов. Во-первых, очень часто меню открываются когда это совсем не нужно, и во-вторых мне до сих пор непонятно зачем выделять недавно установленные программы. Может кто объяснит-:)

Отображать список недавно использовавшихся документов или нет решать вам. Если вы используете один профиль, а доступ к компьютеру имеете не только вы, то вполне вероятно, что кто-нибудь откроет ваши документы и что-нибудь подправит в них. Я думаю, что в восторге от этого действа вы не будете.
Ну вот, собственно и все. Остается напомнить, что время от времени стоит производить профилактическую очистку системы, удаляя временные файлы, файлы установок, старые файлы восстановления системы и т.п. , а так же дефрагментацию диска. А при заметном "торможении" системы эти действия необходимо выполнить прежде всего и не откладывая.