Справочник по настройке Windows XP

Справочник по настройке системы

Windows XP с помощью реестра

Реестр один из основных компонентов операционной системы, хранящий всю информацию, необходимую для функционирования системы Windows XP

Ехешники системных утилит. Служебные программы для проверки и диагностики системы

Благодаря своей колоссальной базе всевозможных настроек, скрытых и открытых, документированных и недокументированных, Windows может быть настроен кем угодно и как угодно

Для работы с реестром используется утилита Regedit

ПРЕДУПРЕЖДЕНИЕ: НИКОГДА не удаляйте и не меняйте информацию в реестре, если Вы не уверены что это именно то, что нужно. В противном случае некорректное изменение данных может привести к сбоям в работе Windows

Вся ответственность за нарушение работоспособности компьютера лежит на Вас


Введение в реестр
Что такое реестр Windows XP ?

Для начала немного теории, а заодно определимся с терминологией. Эта важная часть нужна нам для того, чтобы лучше понимать друг друга.

Итак, реестр, или системный реестр — это база данных для хранения сведений о конфигурации компьютера и настроек операционной системы. Реестр содержит данные, к которым Windows XP постоянно обращается во время загрузки, работы и ее завершения, а именно:
— профили всех пользователей, то есть их настройки;
— конфигурация оборудования, установленного в операционной системе. Я не пишу "установленного в компьютере", поскольку железо может быть, как говорится, "на борту", но не быть установленным в ОС, например, из-за устаревших драйверов.

— данные об установленных программах и типах документов, создаваемых каждой программой;
— свойства папок и значков программ;
— данные об используемых портах.

Реестр имеет иерархическую древовидную структуру, состоящую из разделов, подразделов и ключей (параметров).

Для работы с реестром используется простая и понятная утилита Regedit, знакомая еще со времен Windows 3.1.

Разделы и подразделы — это, грубо говоря, папки в левом окне Regedit'а. Ключ реестра, или параметр — это некая переменная, которой присвоено определенное значение, проще говоря — это то, что мы видим в правом окне Regedit'а.

Куст (основной раздел, стандартный раздел, в английской документации — улей, от англ. hive) — это раздел реестра, отображаемый как файл на жестком диске. Куст является набором разделов, подчиненных разделов и параметров и имеет корни на верхнем уровне иерархии реестра. По умолчанию большинство файлов кустов (Default, SAM, Security и System) сохраняются в папке %SystemRoot%\System32\Config. Папка %SystemRoot%\Profiles содержит профили (настройки) для каждого пользователя компьютера. Поскольку куст представляет собой файл, его можно перемещать из одной системы в другую. Для редактирования этого файла необходимо использовать редактор реестра.

Важное замечание: Windows XP в отличие от своих предшественниц не имеет ограничения по размеру реестра.

Реестр Windows XP состоит из следующих основных разделов:
HKEY_CLASSES_ROOT — это ссылка на раздел HKEY_LOCAL_MACHINE\ Software\Classes. Хранящиеся здесь сведения обеспечивают запуск необходимой программы при открытии файла с помощью проводника. Этот раздел содержит связи между приложениями и типами файлов, а также информацию об OLE.

HKEY_CURRENT_USER — это ссылка на определенный подраздел HKEY_USERS. Настройки соответствуют текущему, активному пользователю, выполнившему вход в систему.

HKEY_LOCAL_MACHINE — раздел содержит настройки, относящиеся к вашему компьютеру и действительные для всех пользователей, а также информацию об аппаратной конфигурации и установленном программном обеспечении.

HKEY_USERS — этот раздел содержит настройки для всех пользователей компьютера.

HKEY_CURRENT_CONFIG — это ссылка на HKEY_LOCAL_MACHINE\ SYSTEM \CurrentControlSet\ Hardware Profiles\Current. Раздел содержит сведения о настройках оборудования, используемых локальным компьютером при запуске системы, т.е. информацию о текущей конфигурации.

Вышеуказанные основные стандартные разделы вы не сможете удалить или переименовать. Некоторые разделы реестра являются энергозависимыми (volatile) и не хранятся в каком-либо файле. Операционная система создает и управляет этими разделами полностью в памяти, поэтому они являются временными по своей природе. Система создает энергозависимые разделы каждый раз при начальной загрузке. Например, HKEY_LOCAL_MACHINE \HARDWARE — раздел реестра, который хранит информацию по физическим устройствам и назначенным им ресурсам. Назначение ресурса и аппаратное обнаружение происходят каждый раз при загрузке системы, поэтому логично, что эти данные не записываются на диск.

Сердце системного реестра — это раздел HKEY_LOCAL_MACHINE \SYSTEM.

Наибольший интерес для нас представляют ветви HKEY_CURRENT_USER и HKEY_LOCAL_MACHINE: именно там хранятся настройки, изменение которых способно облагородить нашу операционную систему.

Часто для обозначения основных разделов реестра пользуются сокращениями:
HKEY_CLASSES_ROOT — HKCR
HKEY_CURRENT_USER — HKCU
HKEY_LOCAL_MACHINE — HKLM
HKEY_USERS — HKU
HKEY_CURRENT_CONFIG — HKCC

Раздел HKEY_USERS содержит все активные загруженные параметры пользователя. Он имеет не менее трех ключей:
— Подраздел DEFAULT, где хранится используемая конфигурация, когда ни один из пользователей еще не вошел в компьютер. То есть мы еще видим приглашение на вход в систему.

— Дополнительный подраздел, который имеет имя в соответствии с security ID текущего пользователя (описание SID см. ниже). Этот подключ реестра содержит конфигурацию текущего пользователя. Если пользователь вошел удаленно, данные для конфигурации пользователя сохраняются в системном реестре местного компьютера. Данные из HKEY_USERS\%SID% также появляются в HKEY_CURRENT_USER.

— Дополнительный подраздел, который имеет имя в соответствии с SID текущего пользователя с суффиксом Classes. Этот раздел содержит классы текущего пользователя. Данные в HKEY_USERS\%SID%_Classes также содержатся в HKEY_CLASSES_ROOT.

В Windows XP конфигурация пользователя по умолчанию (default user profile) не хранится в системном реестре. Она находится на системном диске в файле \Documents and Settings\Default User\Ntuser.dat.

Отметим, и это важно, что куст HKEY_CURRENT_USER является ссылкой, линком на определенный подраздел куста HKEY_USERS. Это значит, что все изменения в разделах, подразделах и ключах куста HKEY_CURRENT_USER автоматически тут же отображаются в определенном подразделе HKEY_USERS, соответствующем активному пользователю. То есть пользователю, выполнившему процедуру входа.

В каком же именно разделе HKEY_USERS проводятся изменения? Для этого вы должны узнать свой SID. Тогда искомый раздел будет именоваться, например, так: HKEY_USERS\S-1-5-21-117609710 -1606980848-839522115-500. Где цифровая часть, вместе с буквой S, и есть SID.

Идентификатор безопасности (SID, security ID) — структура данных переменной длины, которая идентифицирует пользователя, группу или компьютер. Каждая учетная запись в сети имеет уникальный SID. Внутренние процессы в Windows обращаются к SID для получения учетной записи пользователя или имени группы.

Откройте редактор реестра HKLM\SOFTWARE\ Microsoft\Windows NT\CurrentVersion\ProfileList. Выберите SID и посмотрите ProfileImagePath. В конце строки найдете имя пользователя.

Увидеть все SID, относящиеся к пользователям компьютера, вы можете раскрыв раздел HKEY_USERS. Но в большинстве случаев знать SID не обязательно.

Отметим также, что HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet — это тоже ссылка, линк на один из пронумерованных подразделов с именами HKEY_LOCAL_MACHINE\ SYSTEM\ControlSet00n, где n — номер. Подразделы ControlSet00n представляют собой наборы настроек для операционнной системы Windows XP. Большинство систем имеют два пронумерованных управляющих набора: оригинал и резервную копию, которая использовалась при последнем успешном старте системы. Операционная система Windows XP может обслуживать несколько таких наборов. Windows XP обслуживает резервные копии так, чтобы вы могли отменить изменения конфигурации, которые в противном случае могли бы препятствовать загрузке операционной системы. Windows XP хранит последний набор настроек, который был использован успешно, и настройки по умолчанию. Эти значения сохранены в подключе Select. Имена параметров ключа Select соответственно: Current — текущие настройки и Default — настройки по умолчанию. Также обратите внимание на параметр LastKnownGood, расположенный там же. При загрузке Windows XP вы можете выбрать пункт меню "Загрузка последней удачной конфигурации", а действительный номер набора загружаемых настроек будет определен именно этим параметром реестра.

Все значения ключей реестра относятся к определенному типу. далее дадим описание типов данных, используемых в реестре Windows XP:
REG_BINARY — двоичные данные. Большинство сведений об аппаратных компонентах хранится в виде двоичных данных и выводится в редакторе реестра в шестнадцатеричном формате.

REG_DWORD — целые числа размером в 4 байта. Многие параметры служб и драйверов устройств имеют этот тип и отображаются в двоичном, шестнадцатеричном или десятичном форматах.

REG_EXPAND_SZ — строка данных переменной длины.

REG_MULTI_SZ — многострочный текст. Этот тип, как правило, имеют списки и другие записи в формате, удобном для чтения. Записи разделяются пробелами, запятыми или другими символами.

REG_SZ — текстовая строка фиксированной длины.

REG_FULL_RESOURCE_DESCRIPTOR — последовательность вложенных массивов, разработанная для хранения списка ресурсов железа или драйверов.
Из каких файлов состоит реестр Windows XP ?

Итак, повторим, куст — это раздел реестра, отображаемый как файл на жестком диске. Имя используется для указания на ветвящуюся структуру.

Однако не вся информация из некоторых подразделов кустов хранится на диске, но об этом немного ниже.

А сейчас — вот они, файлы реестра Windows XP:
(имени файла соответствует куст реестра Windows XP)

По умолчанию почти все файлы кустов: Default, SAM, Security, Software и System, — сохраняются в папке %SystemRoot%\System32\Config.

Папка %SystemRoot%\Profiles содержит настройки для каждого пользователя компьютера.

Если есть сомнения, то точный список файлов реестра Windows XP можно посмотреть здесь: HKEY_LOCAL_MACHINE\System \CotnrolSet\Control\HiveList\.

При начальной загрузке к этому разделу обращается Configuration Manager, чтобы проинициализировать все основные разделы реестра

Имя файла | Соответствующий раздел реестра Windows XP
SAM | HKEY_LOCAL_MACHINE\SAM
SECURITY | HKEY_LOCAL_MACHINE\Security
Software | HKEY_LOCAL_MACHINE\Software
System | HKEY_LOCAL_MACHINE\System HKEY_CURRENT_CONFIG
Default | HKEY_USERS\.DEFAULT
Файлы Ntuser.dat HKEY_CURRENT_USER
(эти файлы хранятся в С:\Documents and Settings\%UserName%)
Содержат конфигурацию для конкретного пользователя.


Меню Пуск и Панель задач
Содержание

Меню Пуск

Уменьшение задержки вывода меню

Сделать недоступными свойства Панели задач и меню Пуск

Запретить модификацию меню Пуск

Запретить переключать меню в стиль XP

Запретить пункт меню Поиск

Запретить пункт меню Выполнить

Запретить пункт меню Справка и поддержка

Запретить пункт меню Все программы (Стиль ХР)

Запретить пункт меню Недавние документы

Настройка меню классического типа

Запретить пункты меню Настройка

Панель задач

Запретить контекстное меню Панели задач

Меню Пуск

Уменьшение задержки вывода меню

Не секрет, что все меню Windows XP открываются с определенной задержкой, что иногда несколько раздражает. Для более быстрого открытия меню необходимо изменить значения ключа MenuShowDelay, расположенного в разделе HKEY_CURRENT_USER/Control Panel/Desktop. По умолчанию значение этого ключа равно 400. Если изменить это значение в 0, то Вы увидите значительное ускорение открытие меню.(советую 100, 0 слишком быстро)

Наверх
Сделать недоступными свойства Панели задач и меню Пуск

Запрещает изменение и настройку Панели задач. Требуется перезагрузка.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoSetTaskbar:DWORD значение 1 - свойства Панели задачи меню Пуск не доступны

Наверх
Запретить модификацию меню Пуск

Запрещает добавление и удаление новых пунктов в меню Пуск.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoChangeStartMenu:DWORD значение 1 - запрещает модификацию меню Пуск

Наверх
Запретить переключать меню в стиль XP

Прежде чем применить опцию, необходимо переключиться на классический вид меню. Требуется перезагрузка.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoSimpleStartMenu:DWORD значение 1 - запрещает переключать меню Пуск в стиль XP

Наверх
Запретить пункт меню Поиск

Требуется перезагрузка.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoFind:DWORD значение 1 - убирает пункт меню Поиск

Наверх
Запретить пункт меню Выполнить

Требуется перезагрузка.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoRun:DWORD значение 1 - убирает пункт меню Выполнить

Наверх
Запретить пункт меню Справка и поддержка

Запретить доступ к справочной информации, обновлении, восстановлению системы и т.д. Требуется перезагрузка.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoSMHelp:DWORD значение 1 - убирает пункт меню Справка и поддержка

Наверх
Запретить пункт меню Все программы (Стиль ХР)

Убирает подменю Все программы из меню Пуск. Требуется перезагрузка.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoStartMenuMorePrograms:DWORD значение 1 - убирает подменю Все программы

Наверх
Запретить пункт меню Недавние документы

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoRecentDocsMenu:DWORD значение 1 - убирает пункт меню Недавние документы

Наверх

Настройка меню классического типа

Запретить пункты меню Настройка

Данная настройка относится к меню классического вида и не влияет на вид меню в стиле XP . Данная опция убирает пункты "Панель управления", "Сетевые подключения", "Принтеры и факсы" из меню Настройка. Возможность настроить меню Пуск остается.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoSetFolders:DWORD значение 1 - запрещает пункты меню настройка.

Наверх

Панель задач

Запретить контекстное меню Панели задач

Запрещает контекстное меню Панели задач (контекстное меню программ, значки которых находятся в системном трее - доступно)

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoSetFolders:DWORD значение 1 - запрещает пункты меню настройка.

Наверх


Internet Explorer
Запретить доступ к свойствам Internet Explorer

Полностью запрещает доступ к настройкам Internet Explorer. Если данная опция включена, опции ниже игнорируются.

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions

NoBrowserOptions:DWORD значение 1 - доступ к настройкам запрещен
Скрыть вкладку "Общие" в свойствах обозревателя

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

GeneralTab:DWORD значение 1 - скрыть вкладку
Скрыть вкладку "Безопасность"

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

SecurityTab:DWORD значение 1 - скрыть вкладку
Скрыть вкладку "Конфиденциальность"

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

PrivacyTab:DWORD значение 1 - скрыть вкладку
Скрыть вкладку "Содержание"

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

ContentTab:DWORD значение 1 - скрыть вкладку
Скрыть вкладку "Подключения"

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

ConnectionsTab:DWORD значение 1 - скрыть вкладку
Скрыть вкладку "Программы"

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

ProgramsTab:DWORD значение 1 - скрыть вкладку
Скрыть вкладку "Дополнительно"

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

AdvancedTab:DWORD значение 1 - скрыть вкладку
Запретить изменения на вкладке "Дополнительно"

Вкладка "Дополнительно" доступна, но изменить на ней ничего нельзя.

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

Advanced:DWORD значение 1 - запретить изменения
Запретить доступ к настройке параметров временных файлов

Свойства обозревателя - вкладка Общие - раздел Временные файлы Интернета, становится недоступным.

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

Settings:DWORD значение 1 - запретить доступ к настройке параметров
Автоматически подгонять размеры рисунка

Internet Explorer автоматически подгоняет рисунки так, чтобы они полностью умещались на экране и полосы прокрутки не появлялись. При необходимости можно отключить данную возможность.

HKCU\Software\Microsoft\Internet Explorer\Main

STRING Enable AutoImageResize, значение "yes" - автоматическое изменение размера изображений включено
Запретить автоматические обновления IE

HKCU\Software\Microsoft\Internet Explorer\Main

NoUpdateCheck:DWORD значение 1 - запрещает автоматические обновления
Скрывать редко используемые пункты в Избранном

В меню показываются только часто вызываемые пункты меню, для доступа к редко вызываемым пунктам, необходимо нажать на специальную стрелочку. Чтобы изменения вступили в силу, необходимо перезапустить Internet Explorer

HKCU\Software\Microsoft\Internet Explorer\Main

STRING FavIntelliMenus: значение "yes" - скрывать редко используемые пункты
Удалить пароль на ограничение доступа к сайтам

Удаляет пароль на ограничение доступа к сайтам по содержанию. Данный пароль можно установить в Свойствах обозревателя, вкладка Содержание, раздел Ограничение доступа.

HKLM\Software\Microsoft\Windows\CurrentVersion\policies\Ratings

BINARY Key, значение - зашифрованный пароль и параметры ограничения. Удалите параметр, если хотите удалить пароль
Путь к папке закачек по умолчанию

Данная папка будет всегда появляться первой для сохранения загружаемых файлов.

HKCU\Software\Microsoft\Internet Explorer

STRING Download Directory, значение путь к папке закачек
Редактор для просмотра исходного кода HTML страниц

Редактор, вызываемый через пункт меню Вид -> Просмотр HTM- кода.

HKLM\SOFTWARE\Microsoft\Internet Explorer\View Source Editor\Editor Name

STRING по умолчанию путь к редактору.
Поиск из панели адресов

Параметр влияет на поведение Internet Explorer, если он не находит страницу.

HKCU\Software\Microsoft\Internet Explorer\Main

AutoSearch:DWORD Internet Explorer 6.0 использует следующие значения:

0 - Не выполнять поиск из адресной строки
6 - Показать результаты и перейти на самый похожий узел
5 - Только перейти на самый похожий узел
4 - Только показать результаты в главном окне

Автозаполнение

Веб-адресов

Включить/выключить автозаполнение в строке адреса.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\AutoComplete

STRING AutoSuggest, значение "yes" - автозаполнение веб-адресов используется
Автозаполнение форм

Включить/отключить автозаполнение форм. Internet Explorer выводит подсказки, в которых можно выбрать ранее введенные данные.

HKCU\Software\Microsoft\Internet Explorer\Main

STRING Use FormSuggest, значение "yes" - автозаполнение форм используется
Автозаполнение имен пользователей и паролей в формах

HKCU\Software\Microsoft\Internet Explorer\Main

STRING FormSuggest Passwords, значение "yes" - автозаполнение имен пользователей и паролей в формах используется
Запрос на сохранение пароля

HKCU\Software\Microsoft\Internet Explorer\Main

STRING FormSuggest PW Ask, значение "yes" - Internet Explorer выводит окно с сообщением сохранять пароль или нет


Рабочий стол
Запретить рабочий стол

Скрывает иконки с рабочего стола и делает не доступным контекстное меню.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoDesktop:DWORD = 1 - запрещает рабочий стол
Запретить Active Desktop

Запрещает установку рабочего стола в виде веб-страницы.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoActiveDesktop:DWORD = 1 - запрещает Active Desktop
Скрыть вкладки "Тема" и "Оформление" в свойствах экрана

Запретить изменение тем и оформления окон Windows XP

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

NoDispAppearancePage:DWORD = 1 - скрыть вкладки
Скрыть вкладку "Рабочий стол"

Скрывает вкладку Рабочий стол в свойствах экрана

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

NoDispBackgroundPage:DWORD = 1 - скрыть вкладку
Скрыть вкладку "Заставка"

Скрывает вкладку Заставка в свойствах экрана

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

NoDispScrSavPage:DWORD = 1 - скрыть вкладку
Скрыть вкладку "Параметры"

Скрывает вкладку Параметры в свойствах экрана

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

NoDispSettingsPage:DWORD = 1 - скрыть вкладку


Корзина
Название корзины

Изменяет имя корзины. Обновите рабочий стол, чтобы изменения вступили в силу.

HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}

STRING по умолчанию, значение - имя корзины
STRING LocalizedString, значение - имя корзины
Добавить значок корзины в Мой компьютер

В разделе
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ MyComputer\NameSpace, необходимо создать ключ {645FF040-5081-101B-9F08-00AA002F954E}, чтобы удалить значок корзины - удалите ключ

Обновите Проводник (нажмите F5), чтобы изменения вступили в силу.
Удаление и добавление новых пунктов в контекстное меню корзины.

Для удаления пункта меню, удалите соответствующий ключ в разделе:

HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\Shell

Чтобы добавить новое меню, создайте новый ключ. Значение STRING по умолчанию - название пункта меню. Далее создайте подключ Command, значение STRING по умолчанию которого - исполняемая строка.

Пример добавления блокнота в контекстное меню программы:

HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\Shell\MyNotepad

STRING по умолчанию = "Блокнот"

HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\Shell\MyNotepad

STRING по умолчанию = "notepad.exe" (или полный путь "c:\windows\notepad.exe", измените его, если каталог Windows отличается от приведенного)


Иконки

Иконки на Рабочем столе
Скрытие/Добавление иконок на Рабочем столе

Для скрытия/добавления иконок на рабочем столе, используется раздел реестра:

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\ ClassicStartMenu

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\ NewStartPanel

{208D2C60-3AEA-1069-A2D7-08002B30309D}:DWORD значение 1 - скрыть значок Сетевое окружение, 0 - показывать на рабочем столе

{871C5380-42A0-1069-A2EA-08002B30309D}:DWORD значение 1 - скрыть значок Internet Explorer, 0 - показывать на рабочем столе

{20D04FE0-3AEA-1069-A2D8-08002B30309D}:DWORD значение 1 - скрыть значок Мой компьютер, 0 - показывать на рабочем столе

{645FF040-5081-101B-9F08-00AA002F954E}:DWORD значение 1 - скрыть значок Корзины, 0 - показывать на рабочем столе

Примечание: если параметр не существует, значок Корзины показывается

{450D8FBA-AD25-11D0-98A8-0800361B1103}:DWORD значение 1 - скрыть значок Мои документы, 0 - показывать на рабочем столе


Настройка соединения

Настройка соединения TCP\IP
Максимальный размер передаваемого блока данных (Maximum Transmission Unit)

Определяет самое большое количество данных, которые могут быть переданы по сети в одном физическом фрейме. Если пакет IP большего размера чем MTU, то произойдет фрагментация, что может увеличить время, которое требуется, чтобы послать единственный пакет.

По-умолчанию Windows XP использует значение 1500.

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

MTU:DWORD значение - размер блока в байтах

Рекомендуемые значения:

Для модема: 576

Для DSL, кабельных модемов, T1 и выше: 1500
Максимальный размер окна для приёма TCP пакетов

Количество байтов, которые отправитель может передать, не получая подтверждения. Windows XP по-умолчанию использует значение 8760 (0x2238).

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

TCPWindowSize:DWORD значение - размер в байтах

Рекомендуемые значения:

Для модема - 8760 (0x2238) (используется Windows XP по умолчанию)

DSL, кабельный модем - 186880 (0x2DA00)

T1 и выше - 256960 (0x3EBC0)
Автоматически определять MTU

Автоматически определять максимальный размер передаваемого блока данных.

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

EnablePMTUDiscovery:DWORD = 1 - определять MTU автоматически
Включить поддержку TCP окон больше 64Кб

Рекомендуется для сетей с большой пропускной способностью.

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Tcp1323Opts:DWORD = 1 - поддержка включена
Максимальное время жизни пакета IP (Time to Live)

TTL определяет максимальное время, которое пакет IP может прожить в сети, не достигая адресата. Другими словами: использование этой опции определяет, как долго компьютер будет ждать, прежде чем решит, что запрашиваемый вебсайт не найден. Для плохих соединений имеет смысл увеличить данное значение.

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

DefaultTTL:DWORD = 80. Рекомендованное значение 128
Выборочная передача поврежденных данных

Данная опция включает поддержку Selective Acknowledgement (SACK). Если пакет или ряд пакетов TCP потеряны, то получатель может сообщить отправителю, какие данные были получены, а какие нет.

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

SackOpts:DWORD значение 1 - поддержка выборочной передачи включена


Раздел Uninstall

Удаление программ
Список установленных программ

Вся информация для удаления программы храниться в следующем разделе реестра:

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

Информация о каждой программе храниться в отдельном разделе. В каждом разделе обязательно должны присутствовать два параметра:

STRING DisplayName, значение - имя, которое отображается в списке удаляемых программ

STRING UninstallString, значение - путь к программе удаления

также могут присутствовать другие пункты, их обычно добавляют современные инсталляторы:

STRING DisplayIcon - иконка, соответствующая приложению в диалоге "Установка и удаление программ"
STRING ModifyPath - Путь инсталлятора для изменения установочных параметров программы. Еcли этот ключ установлен, то Кнопка "Заменить/Удалить" распадается на две - "Заменить" (выполняется ModifyPath) и "Удалить" (выполняется UninstallString)

Следующие параметры относятся к диалоговому окну Поддержка

STRING Publisher - Издатель продукта
STRING Readme - Путь к файлу Readme для данного продукта
STRING Comments - Комментарии к продукту
STRING Contact - Контактное лицо (e-mail и т.п.)
STRING DisplayVersion - Номер версии
STRING ProductID - Код продукта
STRING RegCompany - Зарегистрированная компания
STRING RegOwner - Зарегистрированный владелец
STRING URLInfoAbout - Домашняя страничка производителя (параметр Publisher становится ссылкой)
STRING URLUpdateInfo - URL обновления продукта
STRING HelpLink - URL сведений о поддержке


Безопасность
Запретить установку и удаление программ

Запрет запуска апплета Установка и удаление программ".

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

NoAddRemovePrograms:DWORD значение 1 - запрещает запуск апплета Установка и удаление программ
Cкрыть вкладку Изменение или удаление программ

Данный параметр скрывает вкладку Изменение или удаление программ" в апплете Установка и удаление программ.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

NoRemovePage:DWORD значение 1 - скрыть вкладку
Скрыть вкладку Установка программ

Скрывает вкладку Установка программ в апплете Установка и удаление программ.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

NoAddPage:DWORD значение 1 - скрыть вкладку
Скрыть вкладку Установка компонентов Windows

Скрывает вкладку Установка компонентов Windows.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

NoWindowsSetupPage:DWORD значение 1 - скрыть вкладку
Скрыть раздел Установка программы с CD-ROM или дискеты

Скрывает раздел Установка программы с CD-ROM или дискеты и кнопку CD или дискета на вкладке Установка программ.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

NoAddFromCDorFloppy:DWORD значение 1 - скрыть вкладку
Скрыть раздел Установка программ от Майкрософт

Скрывает раздел Установка программы от Майкрософт и кнопку Windows Update на вкладке Установка программ.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

NoAddFromInternet:DWORD значение 1 - скрыть вкладку
Скрыть раздел Установка программ из сети

Скрывает раздел Установка программ из сети.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

NoAddFromNetwork:DWORD значение 1 - скрыть вкладку
Скрыть сведения о поддержке

Скрывает ссылку Сведенья о поддержке

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

NoSupportInfo:DWORD значение 1 - скрыть сведенья о поддержке


Системные утилиты

eudcedit

regedit

sysedit

edit

shrpubw

progman

ntbackup

verifier

netsh

dxdiag

iexpress

cmd

winchat

taskmgr

packager

rasphone

watson

Сеть

Консоль

clipbrd

Названия говорят сами, всплывающие подсказки. При включении система спросит: открыть или сохранить? Жмите открыть.


Система
Содержание

Система

Очистка файла подкачки перед перезагрузкой системы

Отключить встроенный отладчик Dr. Watson

Отключить запись последнего доступа к файлам (только NTFS)

Отключить System Files Protection (SFC)

Включить поддержку UDMA-66 на чипсетах Intel

Включать Num Lock при загрузке

Автоматически выгружать не используемые библиотеки

Отключить слежение Windows XP за пользователем

Запускать 16-битные программы в отдельных процессах

Не отсылать в Microsoft отчеты об ошибках

Пароль при выходе из Ждущего режима

Оптимизировать системные файлы во время загрузки (boot defrag)

Сообщения об ошибках

Путь к дистрибутиву Windows

Запись консоли восстановления на жесткий диск

Автоматические обновления Windows

Windows Prefetcher сервис

Вход в систему

Автоматический вход в систему без ввода пароля

Показывать сообщение при входе в систему

Не показывать имя последнего пользователя

Использовать страницу приветствия

Использовать быстрое переключение пользователей

Работа Windows с zip-архивами

Отключить поддержку zip-архивов

Восстановление системы

Отключить восстановление системы

Время жизни точек восстановления

Отказ системы

Автоматически перезагрузить компьютер

Записать событие в системный журнал

Отправить административное оповещение

Запись отладочной информации

Параметры работы с памятью

Не использовать файл подкачки для хранения ядра системы

Большой системный кэш

Оптимизировать кэш диска

Пути к системным утилитам

Использовать свою программу дефрагментации диска

Использовать свою программу очистки системы

Использовать свою программу для архивации данных

Автозагрузка

Автозагрузка программ через реестр

Запретить автозапуск программ Local Machine Run

Запретить автозапуск программ Local Machine Run Once

Запретить автозапуск программ Current User Run

Запретить автозапуск программ Current User Run Once
Очистка файла подкачки перед перезагрузкой системы

Очищает файл pagefile.sys перед перезагрузкой системы. В данном файле может храниться конфиденциальная информация. Если данная опция включена, возможно значительное увеличение времени выключения компьютера.

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

ClearPageFileAtShutdown:DWORD =1 или 0

Наверх
Отключить встроенный отладчик Dr. Watson

Отключает встроенного отладчика Windows XP (программа обнаружения ошибок). Если текущим отладчиком не является Dr. Watson, он будет также отключен. Если опция выключена, то при ошибке в программе, будет выводиться соответствующее сообщение об ошибке с кнопками ОК и Отмена, при нажатии ОК - приложение завершается, а при нажатии на отмену запускается отладчик.

Примечание: можно отключить вывод окошка совсем. см. опцию Сообщения об ошибках

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug

Auto:DWORD = 1 или 0

Наверх
Не производить запись последнего доступа к файлам (только NTFS)

Ускоряет доступ к каталогам с большим количеством файлов. Данная опция работает только с дисками с файловой системой NTFS. На работу FAT32 никак не влияет. Чтобы узнать файловую систему диска, щелкните правой кнопкой на имени диска в Моем компьютере и выберите пункт меню свойства.

HKLM\SYSTEM\CurrentControlSet\Control\FileSystem

NtfsDisableLastAccessUpdate:DWORD = 1 или 0

Наверх
Отключить System Files Protection (SFC)

Отключает блокировку системных файлов Windows XP, будьте осторожны с этой опцией, т.к. системные файлы могут быть заменены старыми версиями.

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

SfcDisable:DWORD параметр может принимать различные значения, hex:ffffff9d (dec:4294967197) или 0 для включения

Наверх
Включить поддержку UDMA-66 на чипсетах Intel *

Необходимо перезагрузить компьютер, чтобы изменения вступили в силу.

HKLM\System\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0000

EnableUDMA66:DWORD = 1 или 0

Наверх
Включать Num Lock при загрузке

Определяет состояние кнопки Num Lock при вводе логина и пароля. Windows XP отключает Num Lock в любом случае, даже если в BIOS состояние Num Lock находится в положении включено.

HKEY_USERS\.DEFAULT\Control Panel\Keyboard

InitialKeyboardIndicators:DWORD =2 - Num Lock включен, значение 0 - выключен

Наверх
Автоматически выгружать не используемые библиотеки

Разрешает Windows XP выгружать не используемые библиотеки, тем самым, освобождая память. Если наблюдается нестабильная работа системы при включенной опции, отключите её.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer

AlwaysUnloadDLL:DWORD = 1 - выгружать библиотеки, значение 0 - не выгружать

Наверх
Отключить слежение Windows XP за пользователем

Windows XP постоянно записывает действия пользователя, какие программы он запускал, какие открывал документы и т.д. В целях безопасности данную опцию можно отключить.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoInstrumentation:DWORD = 1 - отключить слежение, значение 0 - включить

Примечание: НЕ БУДЕТ СОХРАНЯТЬСЯ список часто вызываемых программ, недавние документы и пр.

Наверх
Запускать 16-битные программы в отдельных процессах

Запускает приложения для MS-DOS и Windows 3.1 в отдельных процессах. При крахе одного процесса, работа других не нарушится. Включение данной опции потребует больше памяти под 16-битные программы.

HKLM\SYSTEM\CurrentControlSet\Control\WOW

STRING DefaultSeparateVDM, значение "yes" - запускать программы в отдельных процессах, другие игнорируются

Наверх
Не отсылать в Microsoft отчеты об ошибках

С помощью данной опции можно отключить отсылку сообщений об ошибках в Microsoft. Данную опцию, при необходимости, можно более подробно настроить в Свойствах системы, вкладка Дополнительно, кнопка отчет об ошибках.

HKLM\SOFTWARE\Microsoft\PCHealth\ErrorReporting

DoReport:DWORD= 0 - Отключить отчет об ошибках, 1 - включить
ShowUI:DWORD =0 - Отключить сообщения о критических ошибках, 1 - включить сообщения о критических ошибках, 2 - включить сообщения обо всех ошибках.

Вы также можете настроить некоторые другие опции (они будут работать, только если DoReport = 1 и ShowUI = 3)

IncludeKernelFaults :DWORD- Отчет об ошибках Windows XP (ошибки ядра), может принимать значения 1или 0 IncludeMicrosoftApps :DWORD- Отчет об ошибках программ от Майкрософт, может принимать значения 1 или 0
IncludeWindowsApps :DWORD- Отчет об ошибках компонентов Windows XP, может принимать значения 1 или 0

AllOrNone:DWORD - Дает возможность запрета отсылки сообщений об ошибках определенных приложений, значение 1 - отсылаются все, значение 0 - только выбранные приложения. Для того чтобы выбрать приложение, его необходимо добавить в
HKLM\SOFTWARE\Microsoft\PCHealth\ErrorReporting\InclusionList, а чтобы исключить в
HKLM\SOFTWARE\Microsoft\PCHealth\ErrorReporting\ExclusionList.

В данных разделах необходимо создать DWORD параметр с названием программы и значением 1, например:

HKLM\SOFTWARE\Microsoft\PCHealth\ErrorReporting\ExclusionList
"programm.exe"=dword:00000001

исключает отсылку сообщений об ошибках программы programm.exe

Наверх
Запрашивать пароль после выхода из Ждущего режима

HKCU\Software\Policies\Microsoft\Windows\System\Power

PromptPasswordOnResume:DWORD = 1 - запрашивать пароль

Наверх
Оптимизировать системные файлы во время загрузки (boot defrag)

Дефрагментация файлов, необходимых для старта операционной системы. Выключение этой функции позволит на некоторое время уменьшить время загрузки, но со временем она будет становиться все медленнее.

HKLM\SOFTWARE\Microsoft\Dfrg\BootOptimizeFunction

STRING Enable, значение "Y" - оптимизация включена, "N" - выключена

Наверх
Сообщения об ошибках

Данный параметр задает, какие сообщения об ошибках будут выводиться на экран

HKLM\SYSTEM\CurrentControlSet\Control\Windows

ErrorMode:DWORD может принимать следующие значения

    • 0 - Показывать все ошибки (По умолчанию)
    • 1 - Только ошибки приложений, системные отключены
    • 2 - Отключить все сообщения об ошибках

Наверх
Путь к дистрибутиву Windows

Windows не дает стандартными способами изменить путь к дистрибутиву, но вы можете изменить его с помощью данной опции.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup

STRING SourcePath, полный путь к дистрибутиву, например F:\ или C:\DISTRIB\WINXP\

Наверх
Переписать консоль восстановления на жесткий диск

Консоль восстановления Windows находится на CD-ROM с Windows XP, но имеется возможность переписать её на жесткий диск, и при загрузке вы сможете выбрать: загружать XP или консоль восстановления. Перед тем как щелкнуть по ОК, вставьте компакт-диск с дистрибутивом Windows XP.

Пуск- Выполнить= %путь к дистрибутиву%\i386\winnt32.exe /cmdcons

После установки консоли, на системном диске появится папка cmdcons размером 7-8 Мб, а в boot.ini появиться новая строка

...\CMDCONS\BOOTSECT.DAT="Microsoft Windows XP Recovery Console" /cmdcons

Выполните Пуск->Выполнить->msconfig перейдите на вкладку boot.ini и убедитесь, что появился новый пункт меню.

Наверх
Автоматические обновления Windows

Управление автоматическим обновлением Windows XP. Также данную опцию можно настроить следующим способом: Панель управления - Система - Автоматическое обновление.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update

AUOptions:DWORD
AUState :DWORD

Windows XP использует следующие значения:

Отключить автоматические обновления:

AUOptions = 1
AUState = 7

Уведомлять о возможности загрузки обновлений

AUOptions = 2
AUState = 2

Загружать обновления, затем уведомлять о готовности к установке

AUOptions = 3 и другие значения
AUState = 2

Наверх
Windows Prefetcher сервис

В Windows XP есть специальный Prefetcher Service, его задача уменьшить время запуска приложений и время загрузки системы. Файлы, используемые этим сервисом, находятся в папке %systemroot%\prefetch. C помощью данной опции Вы можете управлять данным сервисом.

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters

EnablePrefetcher:DWORD параметр может принимать следующие значения:

0 - отключить сервис

1 - упреждающая выборка приложений

2 - упреждающая выборка приложений, запускаемых во время загрузки системы

3 - включены обе упреждающие выборки (пп. 1 и 2) используется Windows XP по умолчанию

Перезагрузите компьютер, чтобы изменения вступили в силу.

Наверх

Вход в систему

Автоматический вход в систему без ввода пароля

Позволяет автоматически входить в систему без выбора имени и ввода пароля. Также автоматический вход в систему можно включить следующим способом: Пуск - Выполнить - набрать "control userpasswords2", в появившемся окне снять галочку с "Требовать ввод имени и пароля", после нажатия на ОК появится окно, где нужно указать пользователя и пароль. Если автоматический вход включен, то его можно обойти, удерживая клавишу SHIFT при загрузке компьютера.

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

STRING AutoAdminLogon, принимает значение "1" - Автоматический вход включен, "0" - выключен.

STRING DefaultUserName, имя пользователя, которое используется при автоматическом входе в систему
STRING DefaultUserPassword, пароль пользователя
STRING DefaultDomainName, домен по умолчанию, используется для компьютеров в сети

Примечание: пароль храниться в реестре в незашифрованном виде.

Если при загрузке компьютера отключен показ предыдущего имени (параметр DontDisplayLastUserName) автоматический вход в систему работать не будет!

Если опция сбрасывается после перезагрузки, создайте пароль для своей учетной записи (Панель управления - Учетные записи пользователей) или используйте апплет control userpasswords2 (см. выше)

Наверх
Показывать сообщение при входе в систему

Показывает сообщение перед вводом пароля для входа в систему. Чтобы войти в систему необходимо нажать на кнопку OK.

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

STRING LegalNoticeCaption, заголовок окна
STRING LegalNoticeText, текст сообщения

Наверх
Не показывать имя последнего пользователя

Windows XP по умолчанию подставляет имя последнего пользователя использующего компьютер. Чтобы это отменить, используйте данную опцию.

HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System

DontDisplayLastUserName:DWORD = 1 - убрать имя пользователя

Наверх
Использовать страницу приветствия

Экран приветствия обеспечивает наиболее быстрый и простой вход в систему. Если опция выключена, используется классический вход в систему (более безопасно).

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

LogonType:DWORD = 1 - используется страница приветствия, 0 - используется классический вход в систему

Наверх
Использовать быстрое переключение пользователей

Если опция включена, то при переключении на другого пользователя, программы текущего пользователя будут продолжать работать. Иначе, программы будут автоматически выключатся, когда пользователь выходит из системы, и со следующим пользователем компьютер будет работать быстрее.

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

AllowMultipleTSSessions:DWORD = 1 - использовать быстрое переключение пользователей

Наверх

Работа Windows с zip-архивами

Отключить поддержку Windows XP zip-архивов

По умолчанию Windows XP считает zip-файлы папками - это удобно, если у вас быстрый компьютер. На медленных компьютерах можно отключить эту возможность. Также Windows не будет искать файлы в архивах, что значительно ускорит поиск.

Пуск-Выполнить

regsvr32 /u /s zipfldr.dll, а для включения regsvr32 /s zipfldr.dll

Параметр /u отключает поддержку, /s не выдаются сообщения

Наверх

Восстановление системы

Полностью отключить восстановление системы

Для восстановления системы Windows XP тратит довольно много места, даже не смотря на то, что многие пользователи не пользуются данной возможность или даже не знают что это такое. Если вы не пользуетесь восстановлением системы, можете отключить её, также компьютер не будет тратить время на создание очередных "точек восстановления". Данную опцию также можно включить/отключить в Свойствах системы на вкладке "Восстановление системы".

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SystemRestore

DisableSR:DWORD = 1 восстановление системы отключено, 0 - включено

Наверх
Время жизни точек восстановления

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SystemRestore

RPLifeInterval:DWORD время жизни точек восстановления в секундах.

Вы можете задать количество мегабайт, которые использует восстановление системы на каждом диске через Свойства системы->Восстановление системы.

Наверх

Отказ системы

Автоматически перезагрузить компьютер

Майкрософт всегда думает о пользователях, не прошёл мимо и факт зависания компьютера. Теперь вам не надо тянуться к кнопке Reset, компьютер перезагрузиться самостоятельно, если произойдет непоправимая ошибка. Данную опцию можно настроить в Свойствах системы, вкладка Дополнительно, раздел Загрузка и восстановление.

HKLM\SYSTEM\CurrentControlSet\Control\CrashControl

AutoReboot: DWORD =1 - перезагружать компьютер, 0 - не перезагружать

Наверх
Записать событие в системный журнал

Производит запись в журнал об ошибке системы, если компьютером пользуется несколько человек и вам интересно, когда произошло зависание компьютера, включите данную опцию, иначе имеет смысл её отключить.

HKLM\SYSTEM\CurrentControlSet\Control\CrashControl

LogEvent:DWORD= 1 - вести запись журнала, 0 - не вести

Наверх
Отправить административное оповещение

Оповещение администраторов системы при возникновении ошибки.

HKLM\SYSTEM\CurrentControlSet\Control\CrashControl

SendAlert: DWORD = 1 - отправлять сообщение администраторам, 0 - не отправлять

Наверх
Запись отладочной информации

Данную опцию следует включать, если вы гений в двоичных кодах :) Для всех остальных рекомендуется отключить данную опцию, т.к. при непоправимой ошибке система может довольно долго записывать отладочную информацию и её размер может быть равен размеру оперативной памяти, в зависимости от выбранных деталей отчета.

HKLM\SYSTEM\CurrentControlSet\Control\CrashControl

CrashDumpEnabled:DWORD = 0 - запись не ведется, 1 - Малый дамп памяти (64КБ), 2 - Дамп памяти ядра, 3 - Полный дамп памяти (создание файла, равного размеру оперативной памяти)

Наверх

Параметры работы с памятью

Не использовать файл подкачки для хранения ядра системы

Если опция включена, то Windows XP для ускорения производительности оставляет исполняемый код ядра резидентным в памяти, вместо вытеснения его, по мере необходимости, в виртуальную память на диск. Используйте данную опцию при наличии не менее 256 МБ оперативной памяти. Рекомендуется 512 МБ и более.

Примечание: Не применять эту опцию, если используете "Ждущий" (standby) или "Спящий" (hibernate) режимы.

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

DisablePagingExecutive:DWORD= 1 - Не использовать файл подкачки для хранения ядра системы, 0 - использовать

Наверх
Большой системный кэш

Используйте данную опцию, если у вас 512 Мб памяти или больше. Данная опция увеличит производительность Windows XP.

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

LargeSystemCache:DWORD =1 - использовать, 0 - не использовать

Наверх
Оптимизировать кэш диска

Данная опция увеличит число страниц, которые система будет читать или писать на жесткий диск за один раз. Исходя из этого, должна вырасти производительность.

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

IOPageLockLimit:DWORD значение параметра задаётся в шестнадцатеричной системе от hex:1000 до hex:20000 килобайт, то есть от 4 Мб до 128 Мб. если параметр не существует или равен 0 (по умолчанию), то используется кэш равный 512 Кб. Рекомендуются следующие значения:

Объём RAM компьютера | Рекомендуемое значение параметра IOPageLockLimit
128 Мб и более | 16384 Кб
160 Мб и более | 32768 Кб
256 Мб и более | 65536 Кб
512 Мб и более | 131072 Кб

Наверх

Пути к системным утилитам

Использовать свою программу дефрагментации диска

Вы можете задать свою программу дефрагментации диска, она будет вызываться, если вы в свойствах диска, на вкладке Сервис нажмёте на кнопку "Выполнить дефрагментацию..."

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ MyComputer\DefragPath

EXPAND STRING (По умолчанию), система использует следующую командную строку "%systemroot%\system32\dfrg.msc %c:"
С помощью параметра %с передается имя диска.

Наверх
Использовать свою программу очистки системы

По умолчанию Windows XP использует утилиту для очистки системы - CleanUP, вы можете заменить её на свою.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ MyComputer\cleanuppath

EXPAND STRING (По умолчанию), система использует следующую командную строку "%SystemRoot%\system32\cleanmgr.exe /D %c"
С помощью параметра %с передается имя диска. Для CleanUp если не задан параметр /D, то параметр %с игнорируется и система предлагает пользователю выбрать диск самостоятельно.

Наверх
Использовать свою программу для архивации данных

По умолчанию Windows XP использует утилиту для архивации данных - BackUP, вы можете заменить её на свою.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ MyComputer\BackupPath

EXPAND STRING (По умолчанию), система использует следующую командную строку "%SystemRoot%\system32\ntbackup.exe"

Наверх

Автозагрузка

Автозагрузка программ через реестр

В этом разделе, вы можете удалить из реестра информацию об автоматически загружаемых программах при старте системы.

Список автоматически загружаемых программ разделен на два раздела:
программы, запускаемые только для текущего пользователя

HKCU\Software\Microsoft\Windows\CurrentVersion\Run

и программы, запускаемые для всех пользователей

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

Примечание: внизу списка программ есть ссылка, в которой указан полный путь к программе. Щелкнув по ней, вы откроете папку, в которой находится эта программа.

Наверх
Запретить автозапуск программ Local Machine Run

Программы, запускаемые для всех пользователей компьютера.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer

DisableLocalMachineRun:DWORD = 1 отключает автозапуск программ

Наверх
Запретить автозапуск программ Local Machine Run Once

Программы, запускаемые для всех пользователей компьютера один раз.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer

DisableLocalMachineRunOnce:DWORD = 1 отключает автозапуск программ

Наверх
Запретить автозапуск программ Current User Run

Программы, запускаемые для текущего пользователя компьютера.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer

DisableCurrentUserRun:DWORD = 1 отключает автозапуск программ

Наверх
Запретить автозапуск программ Current User Run Once

Программы, запускаемые для текущего пользователя компьютера один раз.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer

DisableCurrentUserRunOnce:DWORD = 1 отключает автозапуск программ

Наверх


Проводник
Содержание

Проводник

Отключить сообщение о недостатке свободного места на диске

Анимация при сворачивании и разворачивании окон

Запускать окна Проводника в отдельном процессе

Автоматически перезапускать Проводник при ошибках

Удалить стрелки у ярлыков

Не добавлять "Ярлык для..." для создаваемых ярлыков

Отключить автозапись состояния окон проводника

Не показывать папки документов в "Моем компьютере"

Отображать содержимое окна при перетаскивании

Размер кэша для хранения иконок

Количество цветов для отображения иконок

Сглаживать неровности экранных шрифтов

Частота мерцания курсора

Использовать свой редактор для открытия файлов неизвестного типа

Контекстное меню проводника

Добавить пункт меню "Копировать в папку..."

Добавить пункт меню "Переместить в папку..."

Пункт меню "Отправить"

Удалить пункт из контекстного меню папок

Добавить новый пункт в контекстное меню папок

Диалоговое окно открытия и сохранения файла

Изменить диалоговое окно

Защита проводника

Сделать недоступным контекстное меню Проводника

Запретить настройку панели инструментов (включая Internet Explorer)

Удалить меню Файл

Удалить кнопку Поиск с панели инструментов

Использовать классический вид Проводника

Отключить сообщение о недостатке свободного места на диске

Не выдавать сообщение о недостатке места на диске. Имеет смысл использовать данную опцию на дисках малого размера.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoLowDiskSpaceChecks:DWORD : 1 - сообщение отключено, 0 - включено

Наверх
Анимация при сворачивании и разворачивании окон

На медленном компьютере рекомендуется отключить данную опцию. Изменения вступят в силу после перезагрузки.

HKCU\Control Panel\Desktop\WindowMetrics

STRING MinAnimate, 1 - анимация включена, 0 - выключена.

Наверх
Запускать окна Проводника в отдельном процессе

Включение данной опции позволяет запускать окна Проводника в разных процессах, это увеличит стабильность системы, но требует больше памяти.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

SeparateProcess: DWORD: 1 - окна проводника запускаются в различных процессах, 0 - используется один процесс

Наверх
Автоматически перезапускать Проводник при ошибках

Удобная опция. При крахе Проводник будет сам перезапускаться и не надо вызывать диспетчер задач, чтобы его запустить.

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon

AutoRestartShell:DWORD: 1 - автоматически перезапускается, 0 - не перезапускается

Наверх
Удалить стрелки у ярлыков

Удаляет стрелки у ярлыков.

HKLM\SOFTWARE\Classes\lnkfile - ярлыки Windows XP
HKLM\SOFTWARE\Classes\piffile - ярлыки DOS программ

STRING IsShortcut, значение "1" - присутствуют стрелки, удаление параметра - отключает стрелки на ярлыках

Наверх
Не добавлять "Ярлык для..." для создаваемых ярлыков

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer

BINARY link, значение hex:00,00, 00,00 - не добавлять

Примечание: после включения опции не следует создавать ярлыки до перезагрузки компьютера, т.к. Windows изменит значение параметра.

Наверх
Отключить автозапись состояния окон проводника

Отключает запись положения и размеров окон проводника. Необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

BINARY NoSaveSettings, значение hex: 01,00,00,00 - отключить автозапись, удаление значения - включает автозапись

Наверх
Не показывать папки документов в "Моем компьютере"

Не показывать папки "Мои документы", "Общие документы" и т.д. Для удаления папок из "Моего компьютера" необходимо удалить ключ:

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\ NameSpace\DelegateFolders\{59031a47-3f72-44a7-89c5-5595fe6b30ee}

Чтобы вернуть папки на место, создайте этот ключ заново.

Наверх
Отображать содержимое окна при перетаскивании

Если данная опция отключена, то вместо самого окна передвигается только его контур. Отключите эту опцию, если это очень загружает систему. Необходимо перезагрузиться.

HKCU\Control Panel\Desktop

STRING DragFullWindows, значение "1" - отображать содержимое, "0" - отображать только контур.

Наверх
Размер кэша для хранения иконок

Windows XP кэширует иконки для быстрого показа, Вы можете изменить размер кэша.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer

STRING Max Cached Icons, значение - количество иконок в кэше. По умолчанию используется значение "512".

Наверх
Количество цветов для отображения иконок

HKCU\Control Panel\Desktop\WindowMetrics

STRING Shell Icon BPP значения

    • "16" - Среднее качество (16 бит)
    • "24" - Высокое качество (24 бит)
    • "32" - Самое высокое качество (32 бит)

Наверх
Сглаживать неровности экранных шрифтов

Улучшает отображение шрифтов на мониторе компьютера. Сглаживание Clear Type в основном используется для ЖК-дисплеев, т.к. на обыкновенных мониторах он будет смотреться размыто.

HKCU\Control Panel\Desktop

FontSmoothing: DWORD: 2 - использовать сглаживание шрифтов, 0 - не использовать
FontSmoothingType:DWORD может принимать следующие значения:

    • 0 - Не использовать сглаживание
    • 1 - Стандартное сглаживание
    • 2 - Сглаживание Clear Type

Наверх
Частота мерцания курсора

Частота мерцания курсора при вводе текста. Также эту возможность можно настроить в Панели управления->Клавиатура

HKCU\Control Panel\Desktop

STRING CursorBlinkRate, чем больше число, тем больше промежуток между мерцанием курсора, значение "-1" - курсор не мерцает. Можно выставить значения в диапазоне от 200 до 1200, если значение больше, то выставляется значение "-1".

Наверх
Использовать свой редактор для открытия файлов неизвестного типа

Открытие не зарегистрированных типов файлов с помощью своей программы. Используйте префикс "%1" для подстановки имени файла.

HKLM\SOFTWARE\Classes\Unknown\shell\%open%\command

значение по умолчанию - путь к файлу, например, D:\Мои документы\CBuilder\Notepad\Notepad.exe %1

SOFTWARE\Classes\Unknown\shell

значение по умолчанию - %open%

%open% - любое имя

Наверх

Контекстное меню проводника

Добавить пункт меню "Копировать в папку..."

С помощью данного меню можно быстро скопировать папку или файл в любое место.

HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers\Copy To

Для появления пункта меню, необходимо указать параметр по умолчанию {C2FBB630-2971-11D1-A18C-00C04FD75D13}, чтобы удалить пункт меню, удалите ключ.

Наверх
Добавить пункт меню "Переместить в папку..."

С помощью данного меню можно быстро переместить папку или файл в любое место.

HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers\Move To

Для появления пункта меню, необходимо указать параметр по умолчанию {C2FBB631-2971-11D1-A18C-00C04FD75D13}, чтобы удалить пункт меню, удалите ключ.

Наверх
Пункт меню "Отправить"

Позволяет быстро отправлять объекты проводника различным приложениям, например, почтовому клиенту или редактору текстовых файлов.

HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers\Send To

Для появления пункта меню, необходимо указать параметр по умолчанию {7BA4C740-9E81-11CF-99D3-00AA004AE837}, чтобы удалить пункт меню, удалите ключ.

Наверх
Удалить пункт из контекстного меню папок

Некоторые приложения без вашего желания добавляют свои пункты в контекстное меню папок, что делает меню большим и не удобными.

HKLM\SOFTWARE\Classes\Directory\shell - в данном разделе храниться информация о контекстном меню папок.

Наверх
Добавить новый пункт в контекстное меню папок

Добавляет новый пункт в контекстное меню папок.

HKLM\SOFTWARE\Classes\Directory\shell

В этом разделе необходимо создать новый ключ, например:

HKLM\SOFTWARE\Classes\Directory\shell\Far Manager

В значении по умолчанию укажите название программы, например "Far manager", далее необходимо создать подключ с названием "command", например:

HKLM\SOFTWARE\Classes\Directory\shell\Far Manager\command

В значении по умолчанию укажите путь к файлу с параметрами при необходимости, например:

c:\program files\far\far.exe %1

Наверх

Диалоговое окно открытия и сохранения файла

Изменить диалоговое окно

Изменение кнопок быстрого доступа к файлам. Максимум кнопок может быть 5.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\comdlg32\PlacesBar

Place0:DWORD или STRING
Place1:DWORD или STRING
Place2:DWORD или STRING
Place3:DWORD или STRING
Place4:DWORD или STRING

Если параметр имеет значение типа STRING, то в нем хранится путь к папке, а если DWORD, то Windows XP сама выбирает папку в зависимости от значения параметра.

0 - Рабочий стол
5 - Мои документы
6 - Избранное
8 - Недавние документы
13 - Моя музыка
14 - Мои видеозаписи
17 - Мой компьютер
18 - Сетевое окружение
36 - Windows
37 - System32
38 - Program files
39 - Мои рисунки
40 - Documents & Settings\UserName
46 - Общие документы

также есть возможность задавать любую папку, в этом случае используется значение типа STRING.

Наверх

Безопасность проводника

Сделать недоступным контекстное меню Проводника

При щелчке правой кнопкой мыши, а также при нажатии Shift + F10 контекстное меню проводника не будет появляться. Чтобы изменения вступили в силу, необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoViewContextMenu:DWORD : 1 - запрещает появление меню

Наверх
Запретить настройку панели инструментов (включая Internet Explorer)

Запрет на изменение панели инструментов проводника. Необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoToolbarCustomize:DWORD : 1 - запрещает изменение панели инструментов

Наверх
Удалить меню Файл

Удаляет меню Файл из проводника. Необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoFileMenu:DWORD : 1 - удаляет меню

Наверх
Удалить кнопку Поиск с панели инструментов

Удаляет кнопку Поиск с панели инструментов, но F3 продолжает действовать. Необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoShellSearchButton:DWORD : 1 - удаляет кнопку Поиск

Наверх
Использовать классический вид Проводника

Запрещает использовать веб вид папок, отображающий список типичных задач.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

ClassicShell:DWORD : 1 - использовать классический вид

Наверх


Панель задач
Содержание

Панель задач

Показывать всплывающие подсказки

Автоматически скрывать иконки в трее

Cкрыть все значки в трее

Группировать сходные кнопки на панели задач

Мигание кнопок на панели задач

Мигание кнопок на панели задач

Число миганий кнопки на панели задач
Показывать всплывающие подсказки

В Windows XP на панели задач существует два типа всплывающих подсказок - краткие и с дополнительными сведениями. В краткой показывается только название программы, а в "полной версии" некоторые дополнительные сведенья, их содержимое зависит от программы. Пример: при включенной опции монитор DrWeb'a (SpIDer Guard) показывает статистику проверок фалов, а при выключенной опции только название программы. Иногда "полные версии" всплывающих подсказок выводятся самостоятельно, без наведения мыши, чтобы сообщить пользователю, о каком либо событии. Значение отсутствует при установке Windows.

Примечание: Данная опция никак не влияет на всплывающую подсказку к кнопке Пуск.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

EnableBalloonTips:DWORD значение 1 (или удаление параметра) - показывать дополнительные сведенья, 0 - не показывать

Наверх
Автоматически скрывать иконки в трее

Очень удобная опция, если у вас постоянно находится много иконок программ в системном трее. Также эту опцию можно настроить, щелкнув правой кнопкой мыши на панели задач и выбрав в контекстном меню пункт Свойства. При установке Windows, параметр отсутствует.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer

EnableAutoTray:DWORD значение 1 (или удаление параметра) - скрывать иконки, 0 - все иконки отображаются

Наверх
Cкрыть все значки в трее

Убирает значки всех приложений в системном трее. Если опция включена, то в свойствах "Панели задач и меню Пуск" раздел "Область уведомлений" будет недоступен.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoTrayItemsDisplay:DWORD значение 1 - скрыть все значки

Наверх
Группировать сходные кнопки на панели задач

Признак группировки окон одинакового типа в одну кнопку. В дальнейшем при щелчке на эту кнопку появится меню, в котором можно выбрать программу. Также эту опцию можно настроить, щелкнув правой кнопкой мыши на панели задач и выбрав в контекстном меню пункт Свойства. Значение отсутствует при установке Windows.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

TaskbarGlomming:DWORD значение 1 (или удаление значения) - группировать окна, 0 - не группировать

Следующий параметр влияет на порядок группировки приложений:

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

TaskbarGroupSize:DWORD может принимать следующие значения:

    • 0 - группировать окна, начиная со "старых" окон, когда на панели задач мало места
    • 1 - группировать окна, начиная с "новых" окон, когда на панели задач мало места
    • 2 - группировать в любом случае, если есть не менее двух подобных окон
    • 3 - группировать в любом случае, если есть не менее трех подобных окон и т.д.

Примечание: значение 0 используется по умолчанию.

Наверх

Мигание кнопок на панели задач

Время задержки

Когда программа требует ввода данных, она может либо "выскочить" наверх, либо начать мигать иконкой в панели задач. Данный параметр регулирует время задержки до "перехвата" фокуса в миллисекундах.

HKCU\Control Panel\Desktop

ForegroundLockTimeout:DWORD значение 0 - немедленно, по умолчанию Windows XP использует 200 секунд (200000 миллисекунд)

Наверх
Число миганий кнопки на панели задач

HKCU\Control Panel\Desktop

ForegroundFlashCount:DWORD значение 0 - заставит мигать кнопку бесконечно, по умолчанию Windows XP использует значение 3

Наверх


Меню Пуск
Содержание

Меню Пуск

Убрать имя пользователя из меню Пуск

Удалить пункт меню Выход из системы (Logoff)

Удалить список часто используемых программ

Не вести историю открытия документов

Очистка списка недавно использовавшихся документов

Раскрывать меню при наведении и задержки указателя

Выделять недавно установленные программы

Не показывать общие ярлыки (All Users)

Количество ярлыков в меню "Пуск - Документы"

Элементы меню Пуск

Меню в стиле Windows XP

Администрирование

Использовать прокрутку для меню Программы

Команда "Выполнить"

Меню "Избранное"

Мои документы

Мой компьютер

Мои рисунки

Моя музыка

Панель управления

Поиск

Разрешить перетаскивание объектов

Сетевое окружение

Сетевые подключения

Справка и поддержка

Отображать пункт меню Недавние документы

Большие значки в главном меню

Классический вид меню

Классический вид меню

Использовать прокрутку для меню "Программы"

Использовать сокращенные меню

Мелкие значки в главном меню

Отображать команду "Выполнить"

Отображать команду "Завершение сеанса"

Отображать меню "Администрирование"

Отображать папку "Избранное"

Разрешить перетаскивание объектов

Раскрывать "Панель управления"

Раскрывать папку "Мои документы"

Раскрывать папку "Мои рисунки"

Раскрывать папку "Принтеры"

Раскрывать "Сетевые подключения"

Задержка выпадения меню

Задержка выпадения меню

Убрать имя пользователя из меню Пуск

Убирает имя пользователя из меню Пуск (только если меню в стиле XP). Чтобы изменения вступили в силу, необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoUserNameInStartMenu:DWORD значение 1 - убирает имя пользователя, 0 - показывать имя пользователя

Наверх
Удалить пункт меню Выход из системы (Logoff)

Запретить выход из системы из меню Пуск. Чтобы изменения вступили в силу, необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

StartMenuLogoff:DWORD значение 1 - удаляет кнопку из меню

Наверх
Удалить список часто используемых программ

Не путайте данный параметр с "Недавно использовавшимися документами". Данный параметр убирает часто использующиеся программы, которые появляются в меню пуск, в левом столбце (только в стиле Windows XP). Чтобы изменения вступили в силу, необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoStartMenuMFUprogramsList:DWORD значение 1 - удаляет список

Наверх
Не вести историю открытия документов

Не вести историю "Недавно использовавшихся документов". Windows XP создает в папке Documents and Settings\%USERNAME%\Recent ярлыки к запускаемым программам. Вы можете отключить данную возможность, если не пользуетесь ими.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoRecentDocsHistory:DWORD значение 1 - история открытия документов не ведется

Наверх
Очистка списка недавно использовавшихся документов

Очитка списка происходит во время выхода из системы (logout) или перезагрузки компьютера.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

ClearRecentDocsOnExit:DWORD значение 1 - список очищается

Наверх
Раскрывать меню при наведении и задержки указателя

Если опция включена, меню автоматически раскрывается при наведении и задержки указателя, иначе необходимо щелкнуть левой кнопкой мыши для его открытия.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_AutoCascade:DWORD значение 1 - раскрывать меню автоматически, 0 - только после щелчка мыши.

Наверх
Выделять недавно установленные программы

Подсвечивать недавно установленные программы. Чтобы изменения вступили в силу, необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_NotifyNewApps:DWORD значение 1 - раскрывать меню автоматически, 0 - только после щелчка мыши.

Наверх
Не показывать общие ярлыки (All Users)

Не добавлять в меню Пуск общие ярлыки. Папка с общими ярлыками находится Documents and Settings\All Users\Главное меню

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoCommonGroups:DWORD значение 1 - ярлыки из общего меню не добавляются

Наверх
Количество ярлыков в меню "Пуск - Документы"

Количество ярлыков, которое будет отображаться в папке "Недавно использовавшиеся документы". По умолчанию Windows XP использует 15 ярлыков.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

MaxRecentDocs:DWORD значение - количество ярлыков

Наверх

Элементы меню Пуск

Меню в стиле Windows XP

Примечание: переключатель "Меню в стиле XP" и "Классический вид меню" типа никак не влияет на меню. В зависимости от выбранного параметра вам будет предложено настроить опции для соответствующих меню. Оба меню используют различные параметры в реестре (см. ниже), исключением составляет параметр StartMenuAdminTools, он используется обоими типами меню, но меню в стиле XP использует тип DWORD, а классическое меню строковый тип. В зависимости от выбранного положения переключателя, параметр будет сохраняться, соответственно, с типом DWORD для меню в стиле XP и строковым типом для классического стиля.

Существует две возможности скрывать/показывать меню, а именно два ключа
HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced и
HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer или такой же ключ в HKEY_LOCAL_MACHINE
первый ключ просто скрывает/показывает пункты меню и их легко исправить стандартными средствами Windows XP, второй же ключ запрещает/разрешает показ меню, изменение параметров в этом ключе имеет больший приоритет и не изменяется стандартными средствами Windows XP

Наверх
Администрирование

Отображать в меню "Пуск"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_AdminToolsRoot: DWORD значение 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Отображать в меню "Все программы"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

StartMenuAdminTools: DWORD значение 0 - не отображать пункт меню, 1 - отображать

Примечание: Windows XP не позволяет выбрать значение так, чтобы пункт меню Администрирование отображался в главном меню и не отображался в меню "Все программы".

Наверх
Использовать прокрутку для меню Программы

Если прокрутка включена, то меню все программы будет в один столбец и для навигации по нему необходимо подвести курсор мыши к краю экрана. Иначе при большом количестве установленных программ может появиться два и более столбцов.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ScrollPrograms: DWORD

значение 0 - не использовать прокрутку меню, 1 - использовать

Наверх
Команда "Выполнить"

Отображать/скрыть пункт меню выполнить

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowRun:DWORD значение 0 -скрыть пункт меню, 1 - показывать

Наверх
Меню "Избранное"

Показывать/скрыть пункт меню избранного Internet Explorer. Его удобно использовать, если вы работаете с Internet Explorer, если вы работаете с другим браузером, который использует свою папку избранного, этот пункт меню зачастую теряет смысл. Пункт меню "Избранное" по умолчанию ссылается на папку Documents and Settings\%USERNAME%\Избранное.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

StartMenuFavorites:DWORD значение 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Наверх
Мои документы

Эта папка по умолчанию находится в Documents and Settings\%USERNAME%\Мои документы

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowMyDocs:DWORD значение 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Наверх
Мой компьютер

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowMyComputer:DWORD значение 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Наверх
Мои рисунки

Эта папка по умолчанию находится в Documents and Settings\%USERNAME%\Мои документы\Мои рисунки

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowMyPics:DWORD значение 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Наверх
Моя музыка

Эта папка по умолчанию находится в Documents and Settings\%USERNAME%\Моя музыка

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowMyMusic:DWORD значение 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Наверх
Панель управления

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowControlPanel:DWORD значение 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Наверх
Поиск

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowSearch:DWORD значение 0 - не отображать пункт меню, 1 - отображать

Наверх
Разрешить перетаскивание объектов

Разрешить перетаскивание объектов с помощью мышки.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_EnableDragDrop:DWORD значение 1 - разрешить перетаскивание объектов, 0 - запретить

Наверх
Сетевое окружение

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowNetPlaces:DWORD значение 0 - не отображать пункт меню, 1 - отображать

Наверх
Сетевые подключения

Ссылка на данную папку находится в Панели управления.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowNetConn:DWORD значение 0 - не отображать пункт меню, 1 - ссылка на папку сетевых подключений, 2 - отображать как меню "Подключение"

Наверх
Справка и поддержка

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowHelp:DWORD значение 0 - не отображать пункт меню, 1 - отображать

Наверх
Отображать пункт меню Недавние документы

Эта папка по умолчанию находится в Documents and Settings\%USERNAME%\Recent

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowRecentDocs:DWORD значение 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Наверх
Большие значки в главном меню

Вид отображения значков в главном меню. Этот параметр влияет только на левый столбец меню в стиле XP.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_LargeMFUIcons:DWORD значение 0 - в меню отображаются маленькие значки, 1 - большие

Наверх

Классический вид меню

Примечание

Параметры меню классического типа сохраняются в строковом виде. Значение "YES" означает, что опция включена. Другие значения игнорируются (т.е. считается, что опция выключена). Для выключения опции рекомендуется ставить параметр "NO".

значения параметров "YES", "Yes" и "yes" - разные, используйте только "YES" чтобы опция вступила в силу.

Наверх
Использовать прокрутку для меню "Программы"

Если прокрутка включена, то меню все программы будет в один столбец и для навигации по нему необходимо подвести курсор мыши к краю экрана. Иначе при большом количестве установленных программ может появиться два и более столбцов.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

STRING StartMenuScrollPrograms, значение "YES" - прокрутка меню используется

Наверх
Использовать сокращенные меню

Если опция включена, то сначала появляется меню, содержащее часто используемые пункты меню.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

IntelliMenus:DWORD значение 1 - использовать сокращенные меню, 0 - не использовать

Наверх
Мелкие значки в главном меню

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_LargeIcons:DWORD если параметр существует - используются большие иконки (Windows XP в качестве значения параметра использует 1), удалите параметр, чтобы использовать маленькие значки

Наверх
Отображать команду "Выполнить"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

StartMenuRun:DWORD значение 1 - отображать пункт меню, 0 - не отображать

Наверх
Отображать команду "Завершение сеанса"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

StartMenuLogoff:DWORD значение 1 - отображать пункт меню, 0 - не отображать

Наверх
Отображать меню "Администрирование"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

STRING StartMenuAdminTools, значение "YES" - отображать пункт меню

Наверх
Отображать папку "Избранное"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

StartMenuFavorites:DWORD значение 1 - отображать пункт меню, 0 - не отображать

Наверх
Разрешить перетаскивание объектов

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

StartMenuChange:DWORD значение 1 - разрешить перетаскивание

Наверх
Раскрывать "Панель управления"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

STRING CascadeControlPanel, значение "YES" - раскрывать меню

Наверх
Раскрывать папку "Мои документы"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

STRING CascadeMyDocuments, значение "YES" - раскрывать меню

Наверх
Раскрывать папку "Мои рисунки"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

STRING CascadeMyPictures, значение "YES" - раскрывать меню

Наверх
Раскрывать папку "Принтеры"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

STRING CascadePrinters, значение "YES" - раскрывать меню

Наверх
Раскрывать "Сетевые подключения"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

STRING CascadeNetworkConnections, значение "YES" - раскрывать меню

Наверх

Задержка выпадения меню

Задержка выпадения меню

Влияет на скорость показа меню Пуск и скорость выделения объектов в проводнике, если используется одинарный щелчок. По умолчанию задержка равна 400 миллисекунд. Чтобы изменения вступили в силу, необходимо перезагрузиться.

HKCU\Control Panel\Desktop

STRING MenuShowDelay, значение в миллисекундах, например "400"

Наверх


Разное
Содержание

Зависшие приложения

Время, по истечении которого не отвечающее приложение считается зависшим

Завершить зависшее приложение

Завершить зависший сервис

Автоматически завершать зависшие приложения

Проверка файлов

Проверка файлов

Запуск системы

Показывать выполняемые команды при запуске и выходе из системы

Путь к папке временных файлов

Путь к папке временных файлов

Компакт- диски

Отключить автозапуск Компакт- диски

Зависшие приложения

Интервал, по истечении которого не отвечающее приложение считается зависшим:

По истечении этого времени Windows XP считает, что приложение зависло. По умолчанию значение равно 5 000 миллисекунд.

HKCU\Control Panel\Desktop

HungAppTimeout:DWORD значение - время интервала в миллисекундах, значение в диапазоне от 1 до 20 секунд.

Наверх
Завершать зависшее приложение

Интервал, в течение которого Windows XP ожидает, перед закрытием приложения. Меньшее значение ускоряет процесс завершения работы, но это может привести к тому, что будут закрываться не зависшие приложения. По умолчанию интервал равен 20 000.

HKCU\Control Panel\Desktop

WaitToKillAppTimeout:DWORD значение - время интервала в миллисекундах, значения от 1 до 30 секунд

Наверх
Завершать зависший сервис

Интервал, в течение которого Windows XP ожидает, перед закрытием зависшего сервиса. Меньшее значение ускоряет процесс завершения работы, но это может привести к тому, что будут закрываться не зависшие приложения. По умолчанию интервал равен 20 000.

HKCU\Control Panel\Desktop

WaitToKillServiceTimeout:DWORD значение - время интервала в миллисекундах, значения от 1 до 60 секунд

Наверх
Автоматически завершать зависшие приложения

Эта опция используется для автоматического закрытия без всякого предупреждения всех зависших программ. Удобно при завершении работы компьютера, если приложение не отвечает, то не надо нажимать на кнопку, чтобы его завершить.

HKCU\Control Panel\Desktop

AutoEndTasks:DWORD значение 1 - автоматически завершать зависшие приложения, 0 - ждать команды пользователя

Наверх

Проверка файлов

Проверка файлов

Можно выполнить проверку и восстановление поврежденных системных файлов, возможно при этом потребуется компакт-диск с дистрибутивом Windows XP. Пуск- Выполнить- sfc.exe /scannow. Параметр /scannow - немедленная проверка без выдачи запроса, вы также можете использовать другие параметры, например, /scanonce - разовая проверка при следующей загрузке системы, для более подробной информации запустите в командной строке sfc без параметров. Если программа sfc находит, что защищенный файл был переопределен, подходящая версия файла восстанавливается из папки %SYSTEMROOT%\system32\dllcache или если таковой нет, с компакт-диска. Более подробную информацию о защите файлов Windows XP вы можете найти в справочной системе.

Наверх

Запуск системы

Показывать выполняемые команды при запуске и выходе из системы

Показывает информацию о выполняемых процессах во время загрузки системы. Поможет быстро выяснить, на запуск чего система тратит много времени и если возможно, отключить не нужные сервисы.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

verbosestatus:DWORD значение 1 - показывать, 0 - стандартная загрузка

Наверх

Путь к папке временных файлов

Путь к папке временных файлов

Некоторые старые программы не поддерживают длинные пути с пробелами. Рекомендуется использовать путь в стиле DOS 8.3, например, с:\windows\temp. Также этот параметр можно настроить в Свойствах системы - Дополнительно, кнопка Переменные среды.

HKCU\Environment

EXPAND STRING TMP, значение - путь к папке временных файлов
EXPAND STRING TEMP, значение - путь к папке временных файлов

Наверх

Компакт-диски

Отключить автозапуск компакт дисков

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom

AutoRun:DWORD = 0 - автозапуск отключен, 1 - включен


Messenger

MSN Messenger
Удалить встроенный Windows Messenger

Данная опция относится только к встроенному Windows Messenger, если вы ставили более новую версию, то для ее удаления используйте "Установку и удаление программ" в Панели управления. При открытии Outlook запускает встроенную версию Windows Messenger, даже если установлена более новая версия, используйте данную опцию чтобы удалить встроенный Windows Messenger из системы.

HKLM\SOFTWARE\Policies\Microsoft\Messenger\Client

PreventAutoRun:DWORD значение 1 - запрет автоматического запуска
PreventAutoUpdate:DWORD значение 1 - запрет обновлений
PreventBackgroundDownload:DWORD значение 1 - запрет загрузки файлов
PreventRun:DWORD значение 1 - запрет запуска

Данные значения никак не влияют на удаление, для удаления:

Пуск- Выполнить rundll32 advpack.dll,LaunchINFSection %SYSTEMROOT%\inf\msmsgs.inf,BLC.Remove

После перезагрузки Messenger не будет беспокоить


Windows Media Player
Изменить заголовок окна медиаплэера

Добавьте ключ в реестр, чтобы изменить заголовок окна медиаплэера:

HKEY_CURRENT_USER\Software\Policies\Microsoft\

WindowsMediaPlayer

TitleBar= "Ваш заголовок"
Включить DVD возможности медиаплэера

Измените значение ключа с "No" на "Yes", чтобы включить DVD возможности медиаплэера Windows:

HKEY_CURRENT_USER\Software\Microsoft\

MediaPlayer\Player\Settings

EnableDVDUI="Yes"
Очистки списка последних проигранных медиаплэером файлов

Для очистки списка последних проигранных медиаплэером файлов удалите или очистите следующие параметры:

HKEY_CURRENT_USER\Software\Microsoft\

MediaPlayer\Player\RecentFileList

"File0"=""
"File1"="" <и т.д.>
Включить MP3 кодирование

Включение встроенного кодека для копирования музыки с компакт диска в формате *.mp3 (MPEG-3)

HKLM\SOFTWARE\Microsoft\MediaPlayer\Settings\MP3Encoding

Максимальный битрейт:
HighRate:DWORD

Минимальный битрейт:
LowRate:DWORD = 56000, что равно 56 Кбит

Средний-высокий битрейт
MediumHighRate:DWORD = 128000, что равно 128 Кбит - оптимальное значение

Средний битрейт
MediumRate:DWORD = 64000, что равно 64 Кбит
Автоматически загружать кодеки из Интернета

Если на компьютере нет необходимого видео или аудио кодека, то Windows Media Player попытается найти его в Интернете и затем загрузить его. Если опция выключена, Media Player сначала спросит, загрузить кодек или нет, а если включена, кодек будет загружен и установлен без выдачи сообщения.

HKCU\SOFTWARE\Microsoft\MediaPlayer\Preferences

UpgradeCodecPrompt: DWORD значение 1 - выдавать сообщение перед загрузкой кодека, 0 - загружать автоматически

Примечание: WMP8 использует однобайтовый двоичный тип данных (hex:00 или hex:01), но вполне корректно работает с dword.

Автоматические обновления

HKCU\SOFTWARE\Microsoft\MediaPlayer\Preferences

UpgradeCheckFrequency: DWORD может принимать следующие значения:

    • 0 - Один раз день
    • 1 - Один раз в неделю
    • 2 - Один раз в месяц

Примечание: WMP8 использует двоичный тип данных, но вполне корректно работает с dword. (соответственно hex:00,00,00,00, hex:01,00,00,00, hex:02,00,00,00)


Защита системы
Полностью отключить общие ресурсы (ADMIN$, C$ и т.д.)

Эти ресурсы доступны Администратору, для отключения/включения требуется перезагрузка. Windows XP позволяет отключить эти ресурсы, но только до перезагрузки.

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

AutoShareWks:DWORD значение 0 - общие ресурсы отключены, 1 - включены
Запретить вызов диспетчера задач

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

DisableTaskMgr:DWORD значение 1 - запрещает вызов диспетчера задач
Запретить редактирование реестра

Данная опция не запрещает полностью редактирование реестра, а только не дает запустить regedit.exe, другие программы редактирующие реестр игнорируют этот параметр. Вы можете запретить редактирование реестра, выставив права определенным пользователю или группам пользователей.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

DisableRegistryTools:DWORD значение 1 - запрещает вызов редактора реестра
Запретить завершения сеанса

Запрещает завершение сеанса (logout). Необходимо перезагрузить компьютер, чтобы изменения вступили в силу.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoLogOff:DWORD значение 1 - запрещает завершение сеанса
Запретить завершение работы и убрать кнопку из меню Пуск

Запрещает завершение работы компьютера(logoff) стандартными методами, специальные программы при этом могут завершать работу системы. Кнопка из меню пуск уберется/появится только после перезагрузки.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoClose:DWORD значение 1 - запрещает завершение работы компьютера
Запретить запуск апплетов в Панели управления

Запрещает запуск всех апплетов в Панели управления. Также запрещает вызов апплетов из Windows и запуск *.cpl файлов.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoControlPanel:DWORD значение 1 - запрещает запуск апплетов в Панели управления
Запретить изменение свойств Экрана

Запрещает запуск апплета настройки экрана (настройка тем, обоев, разрешения экрана и др.)

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

NoDispCPL:DWORD значение 1 - запрещает изменение свойств экрана


 Центр справки и поддержки

Центр справки и поддержки

С помощью служебных программ можно проверить состояние системы: объем свободной памяти, версию операционной системы, скорости процессора и объема доступного дискового пространства, приложений и оборудование установленные на этом компьютере, а также просмотреть диагностическую информацию о состоянии компьютера.