Soft School - Установка Windows XP Pro

Установка Windows XP Pro
Все приемы, описанные в данной статье, окажутся, по меньшей мере, бесполезными в случаях, имеющих в основе своей недостаточные аппаратные ресурсы компьютера или огрехи сборщиков. Никоим образом не следует полагаться на указанные в некоторых источниках аппаратные требования - процессор с тактовой частотой 233 МГц и 64 Мб оперативной памяти. На сайте компании Microsoft (www.microsoft.com/rus/windowsxp/sys_reqs/) русским языком сказано о том, что означенные параметры являются минимально допустимыми, и (цитирую оригинал) "…при этом быстродействие и некоторые возможности операционной системы могут быть ограничены". Реальными параметрами, при которых можно говорить о мало-мальски возможной работе, является процессор с частотой не менее 300 Мгц и объем оперативной памяти не менее 128 мегабайт. О комфортной работе можно говорить при наличии не менее 256 мегабайт RAM, тем более что цена модуля памяти на 128 Мб не идет в сравнение со стоимостью нового процессора, который, зачастую, требует в качестве "супруги" новую материнскую плату. Вряд ли есть смысл напоминать о преимуществах современных жестких дисков со скоростью вращения пластин 7200 оборотов в минуту и высокой плотностью записи. Во всяком случае, если не предвидится покупка нового носителя, нелишним окажется проверка винчестера знакомым многим "Norton Disc Doctor" от Symantec: в случае наличия сбойных секторов (bad blocks) фатальные последствия не заставят себя долго ждать. Упоминавшиеся огрехи сборщиков ПК, к сожалению, не редкость даже в крупных компаниях. Мне не раз приходилось видеть машины, в которых жесткий диск и привод CD/DVD были подключены к одному IDE-каналу. Казалось бы, что ничего "криминального" в таком варианте подключения IDE-устройств нет. Увы, печальная практика говорит об обратном: масса проблем и тех самых "тормозов", от которых страдают пользователи, являются следствием либо безграмотности, либо патологической скаредности сборщиков, экономящих на лишнем IDE-шлейфе. Дело в том, что при подключении к одному IDE-контроллеру двух устройств (типичный случай см. выше) система не сможет полноценно использовать одно из них до той поры, пока другое не выполнило "приказ", отправленный первому устройству ранее. Так, например, если винчестер трудится в поте железного лица своего над какой-либо ресурсоемкой задачей, а мы в это время решим задействовать CD/DVD привод, произойдет резкое снижение скорости работы обоих устройств, поскольку оптический дисковод вынужден ожидать окончания работы жесткого диска. Если же наличествуют два жестких диска - быстрый новый и "ветеран-флегматик", используемый для хранения архивной информации, можно посоветовать подключить "старичка" вместе с устройством CD/DVD ко второму IDE-контроллеру: обращение к архивам происходит не так уж часто.

Перед началом установки следует взвесить преимущества и недостатки NTFS для обычного, "домашнего" пользователя и определиться с выбором. Безусловным преимуществом FAT32 является тот факт, что эта файловая система быстрее и требует меньше памяти для работы. Если система работает только с FAT32, то в память не грузятся драйверы и сервисы, потребные для NTFS. Еще одно важное преимущество FAT32 - доступ к диску посредством загрузочной дискеты, созданной средствами Windows 9x/ME.

Однако, по моему скромному разумению, главнейшим доводом в пользу NTFS является устойчивость этой файловой системы: NTFS содержит две копии аналога FAT, именуемые MFT (Master File Table). В отличие от FAT, MFT больше напоминает таблицу базы данных. Если оригинал MFT повреждён в случае аппаратной ошибки (всеми "любимый" bad-сектор), то система при следующей загрузке использует копию MFT, и автоматически создаёт новый оригинал, но уже с учётом повреждений. Помимо этого, NTFS обладает встроенными средствами шифрования файлов, что обеспечивает определённую уверенность в сохранности данных (разумеется, при том условии, что система не будет переустанавливаться).

Более того: в NTFS возможно сжатие отдельных каталогов и файлов, в отличие от DriveSpace, который позволял сжимать только диски целиком. Очень удобная возможность: компрессия "на лету", например, больших графических BMP-файлов, с целью экономии дискового пространства, причём для пользователя этот процесс будет абсолютно "прозрачным".

Установка

Не нужно бояться установки Windows XP: на деле все окажется гораздо проще, чем вы думаете. Ниже я приведу несколько скриншотов с пояснениями для тех, кто впервые устанавливает Windows XP.
Для начала следует задать в BIOS приоритет загрузки с CD-ROM и поместить диск с дистрибутивом ХР в лоток привода.

На первом этапе программа установки обрадует нас сообщением о начальном копировании необходимых файлов, причем, этот процесс может длиться довольно долго - несколько минут

по окончания загрузки файлов программа установки поприветствует вас

восстанавливать нам пока нечего (и не дай бог), выходить? - не за тем заходили, а потому жмем ENTER и следуем дальше...

Лицензионное соглашение принимаем (куда деваться-то). (F8)

О преимуществах файловых систем сообщалось выше. Мы же будем устанавливать Windows XP в NTFS. (Разделы, отображенные на скриншоте созданы предварительно с помощью PartitionMagic).

Программа установки начнет копирование файлов на ваш жесткий диск, после чего система будет перезагружена. Не забудьте вновь зайти в настройки BIOS и выбрать вариант загрузки компьютера с жесткого диска.

После перезагрузки "черно-белое кино" заканчивается, и нашему взору представляются первые радости графического оформления Windows XP.

Поскольку процесс установки длится более получаса, можно спокойно заниматься другими делами до тех пор, пока не вылетит окно, приглашающее определиться с региональными и языковыми настройками. В первой секции этого окна посредством кнопки Настроить выбираются необходимые региональные параметры, и, что немаловажно, язык для программ, не поддерживающих UNICODE - задав параметр РУССКИЙ, вы обеспечите себе спокойствие при работе с русским софтом в англоязычной системе. Впрочем, в большинстве случаев эти параметры устанавливаются по умолчанию и, к тому же, эту операцию можно выполнить позже, непосредственно из Windows XP.

Вторая секция (Языки ввода) позволяет выбрать необходимые языки для раскладки клавиатуры. Начинающие пользователи стараются русифицировать все и вся, опытные - наоборот. А посему выбор языка ввода по умолчанию остается за вами. Переключение же между языками стоит изменить: вместо предлагаемого Alt слева+Shift на Ctrl+Shift.

Придумайте своему компьютеру Имя и он ваш :)

Как же без ключа-то. Берите и вводите.

Пароль администратора можно установить, а может и не стоит (вдруг забудете, восстановление системы в безопасном режиме ставиться под угрозу).

Часовой пояс установите в соответствии с вашим регионом

Сетевые параметры пока не трогаем. Обычные и ладно (тем более что Особые - такие же).

система продолжит копирование файлов, а наше участие сведется к перезагрузке машины и заполнению полей учетной записи пользователя. Создаем таковую пока одну, чтобы каждый раз не спотыкаться об окно с выбором пользователя. Настройка Windows XP и установка программного обеспечения потребует перезагружать машину множество раз.

И, наконец, вот она - Безмятежность...