Лифт

Настройка
Установка Win XP
Введение в реестр
Движение реестра
Система
Меню Пуск
Explorer
IExplorer
QExpress
Интернет TCP\IP
Медиаплеер
Авто- запуск
Чистка реестра
Утилиты чистки
Разное
Советы
О системе
Настройка системы
Защита системы
Восстановление
Скорость системы
Безопасность
Анализ системы
Пользователи
Командная строка
Утилиты ком- строки
Ядро системы
Группировка окон
Системный шрифт
Системные службы
Дисковые утилиты
Диспетчер задач
Консоль управления
Настройка BIOS
Горячие клавиши
Удаление Mesenger
Статьи
Процессоры AMD
Локальные сети
Файловые системы
Что такое NTFS
Жесткий диск HDD

Центр Справки и настройки Windows XP http://reestr.hotmail.ru/
E@mail
2003 © 2004
Григорий Саитов.
Дамир Саитов.
г.Ульяновск


Центр Справки и настройки Windows XP

«WinXp speed» для настройки системы.
Проверка работы «Службы»

Описываются установка, методы конфигурирования и настройки системы Windows XP корректировкой параметров реестра. Описывается архитектура реестра, структура и типы данных. Методы резервного копирования и восстановления реестра. Рассматриваются методы настройки системы и сети, особенности подключения и конфигурирования аппаратных средств. Приводятся рекомендации по предотвращению сбоев системы и решению различных проблем путем редактирования реестра. Особое внимание уделяется вопросам безопасности и защиты реестра.

Требование! Для работы утилит.
Операционная система Windows XP.
Internet Explorer версии 5.0 и выше.
!!! В браузере должны быть включены: поддержка java-скрипт, показ рисунков и анимации.
ПРЕДУПРЕЖДЕНИЕ
 Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере. НИКОГДА не удаляйте и не меняйте информацию в реестре, если Вы не уверены что это именно то, что нужно
 Вся ответственность за нарушение работоспособности компьютера лежит на Вас.
 http://reestr.hotmail.ru * http://www.saitov.km.ru/


Справка и настройка Windows XP

WinXPspeed
Служебные программы * Наши продукты


MMC

Консоль управления Microsoft

Microsoft Management Console (MMC, консоль управления Microsoft). Что это такое? У администраторов системы и ее предшественников был целый набор административных инструментов, часть из которых была вынесена в панель управления, а другая часть находилась в меню Администрирование. Каждый инструмент представлял собой отдельное приложение пусть и с удобным, но своим интерфейсом. К тому же, приложение могло выполнять сразу несколько функций. По этим причинам начинающим администраторам (а данными утилитами пользуются, в основном, администраторы) было трудно управлять системой, часто они просто терялись в многообразии функций отдельного приложения, в то же время так и не находя нужного им параметра.

Для исправления сложившейся ситуации компания Microsoft решила создать новый универсальный продукт, удовлетворяющий следующим требованиям:

• Должна быть единая универсальная среда, в которой можно выполнять все задачи по управлению системой, используя однотипные приемы и стандартный интерфейс пользователя. Среда должна позволять выполнение нескольких задач одновременно.
• Набор задач должен быть настраиваемым и расширяться/сокращаться по желанию администратора.
• Доступ к инструментам должен выполняться как локально, так и удаленно с самых разнообразных клиентов.
• Инструменты должны обладать возможностью передачи их от одного администратора другому с минимальными затратами.
• API среды должен позволять создавать сторонним фирмам аналогичный инструментарий для своих приложений.

MMC является общей расширяемой средой для управляющих приложений, удовлетворяющей вышеперечисленным условиям. Реализована она в виде обычного MDI-приложения (многооконного), широко использующего интернет-технологии. Сама по себе MMC не представляет управляющих функций — это лишь среда для оснасток (snap-in). Оснастка — управляющий компонент, интегрирующийся в MMC. Одна оснастка представляет единицу управления, а их набор — управляющий инструмент. Оснастка может как посылать команды приложению, так и принимать их, а также выступать в качестве элементов интеграции различных приложений. Одновременно в системе можно использовать и MMC, и управляющие приложения других фирм, задействовав их отдельно либо создав ярлыки на них в MMC. Вырисовывается такая схема (см. рис. 1)

Архитектура MMC
Обратите внимание на рис. 2. Вы увидите модель консоли управления.

Диспетчер оснасток (Snap-in manager) — основа консоли управления — позволяет добавлять, удалять и модифицировать оснастки, а также разрешает указать, как будет работать данная оснастка: автономно или с дополнительными расширениями. Значения параметров хранятся в файлах с расширением .msc. Из нескольких загруженных оснасток администратор может создать инструмент управления. Этот инструмент сохраняется в MSC-файле для повторного использования и называется документом.
Монитор маршрутизации и Журнал событий на рисунке являются подгруженными оснастками, с которыми взаимодействует пользователь.
Объединяясь, оснастки создают пространство имен — упорядоченный набор узлов в виде древовидной структуры. Если дерево большое, можно воспользоваться страницей Избранное (интерфейс MMC в целом напоминает Проводник). Для каждого узла можно открывать дочерние окна.

Оснастки
Оснастка (snap-in) — это минимальная единица управления, реализованная в виде OLE Inproc-сервера, исполняемого в контексте MMC. Как уже говорилось, набор оснасток представляет собой инструмент управления. Оснастка способна вызывать другие поддерживаемые в системе элементы управления и DLL. Такая гибкость позволяет создавать инструменты по желанию администратора, заточенные под конкретные задачи. Оснастки бывают самостоятельными и оснастками-расширениями. Самостоятельные оснастки полностью самодостаточны, а оснастки-расширения обеспечивают нужной функциональностью оснастку-родителя. Многие оснастки обладают двойной функциональностью, являясь одновременно самостоятельными и расширяющими, как, например, оснастка Ведение журнала, расширяющая оснастку Управление компьютером. Оснасткам доступны следующие механизмы расширения консоли управления:

• Перечисление имен.
• Расширение контекстного меню.
• Расширение меню Новый (New).
• Расширение меню Задачи (Tasks).
• Расширение панели инструментов и кнопок на ней.
• Расширение страницы свойств.
• Расширение меню Вид (View).
• Организация последовательностей в программах-мастерах.
• Расширение справочной системы.
Думаю, с этим все ясно.

Работа с MMC
Консоль работает в двух основных режимах: авторском (author) и пользовательском (user). Пользовательский режим делится на 3 подрежима:

• полного доступа;
• ограниченного доступа с несколькими окнами;
• ограниченного доступа с одним окном.

Полное управление над инструментом и консолью в целом вы получаете только в режиме автора, в любом пользовательском вы можете лишь использовать его, причем с ограничениями. Для перехода в авторский режим следует загрузить консоль командой mmc, а затем добавить нужный инструмент. Также можно выделить нужный mmc-файл и в контекстном меню по правому щелчку мыши выбрать команду Автор (Author) либо запустить данный файл с ключом /a.

Добавить или удалить оснастку можно в авторском режиме из меню Консоль, Добавить или удалить оснастку (Console, Add/remove Snap-in). Кстати, на закладке Расширения (Extensions) можно отключить ненужные в данный момент оснастки-расширения для добавляемой оснастки.
Для изменения свойств созданного вами инструмента, сохраненного в файле .msc, служит пункт Параметры (Options) меню Консоль (Console), где можно указать необходимый режим доступа.

У MMC есть одно замечательное свойство — панели заданий (taskpads). Это окно с одной или несколькими вкладками, на которых может располагаться список параметров и произвольные задания в виде значка. Заданием может быть команда из меню текущей оснастки, ссылка на web-страницу или любая команда, вызывающая приложение или сценарий. Для создания такой панели необходимо щелкнуть правой кнопкой мыши на нужной вам ветке консоли и выбрать команду Новый вид панели задач (New Taskpad View). Запустится программа-мастер, которая сначала настроит вид этой панели, а потом запустит другой мастер, добавляющий задания на созданную панель. Надо признать, это очень удобная вещь.

Внешний вид оснастки позволяет настроить команда Настроить (Customize) меню Вид (View).

Управление доступом к оснасткам
В дополнение к вышесказанному отмечу возможность управления доступом к оснасткам с помощью групповой политики, которая позволяет разрешить/запретить:

• доступ ко всем оснасткам в авторском режиме;
• использование тех или иных оснасток.

Итак, открываем оснастку Групповая политика (Group Policy) для локального компьютера или любого другого. В ветви Конфигурация пользователя (User Configuration) находим ветвь Консоль управления Microsoft (Microsoft Management Console), где указываем нужные параметры. В списке запрещенных или разрешенных оснасток следует запретить оснастки, использование которых нежелательно. Если вы используете XP или Server 2003, то слева от параметров будете видеть исчерпывающие подсказки, посмотреть на которые можно также на закладке Объяснение.

заключение
Как видите, MMC — серьезная среда управления с множеством полезных свойств. К сожалению, не многие ею пользуются, так как не догадываются о ее существовании. С одной стороны, MMC — это инструмент администратора, предназначенный для удаленного и локального администрирования машин в сети, с другой же — данная возможность присутствует на всех версиях NT старше 4.0, так почему бы ею не воспользоваться. К тому же, это стандартное и удобное средство, позволяющее вытворять с вашей машиной множество вещей, недоступных другими способами.


MSCONFIG

В XP присутствует утилита "Настройки системы" (System Configuration Utility, SCU). Вы можете ее вызвать указав MSCONGIF в строке запуска программ Пуск->Выполнить или msconfig.exe. Утилита позволяет удобно управлять запускаемыми приложениями.
В утилите присутствует несколько закладок, позволяющих пользователям выборочно и временно изменять параметры запуска. Первые две закладки, SYSTEM.INI и WIN.INI добавлены из соображений совместимости с предыдущими версиями Windows, вряд ли они когда-нибудь вам вообще понадобятся.
Закладка BOOT.INI позволяет управлять загрузкой Windows XP. Сам файл BOOT.INI показывается в текстовом режиме, в нем вы можете указать конкретные строчки для изменения. Но вряд ли у вас получится здесь что-либо ускорить, не испортив систему.
Закладка Службы (Services) позволяет включать и отключать загрузку служб в XP, но для этого существует более подходящий путь, который мы обсудим далее.
В закладке Автозагрузка (Startup) вы найдете список всех программ, которые будут запускаться при загрузке Windows XP. Здесь вы можете отключить некоторые программы, если сочтете их не слишком нужными. К примеру, это Microsoft Office TSR, Quicken Agent, агенты RealPlayer и Winamp, да и прочая ерунда. Вся прелесть SCU состоит в том, что отключение загрузки какой-либо программы не удаляет код, вы можете отключить компонент, а затем перегрузиться и проверить работоспособность программ и железа. Если будут наблюдаться какие-либо неполадки, вы можете включить компонент обратно и перезагрузиться.
Экспериментируя с SCU, вы можете ощутимо увеличить производительность системы и убрать все лишнее. Как только вы найдете запускаемую при старте Windows программу бесполезной, вы можете удалить ее из списка загрузки в списке SCU. Некоторые программы можно также удалить через группу Пуск->Программы->Автозагрузка (Start Menu -> Startup).
Если программа загружается через реестр, ее можно убрать с помощью REGEDIT. Естественно, перед этим вам следует сделать резервную копию реестра. Чаще всего такие программы находятся в ветке HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run . Вы можете убрать программу из автозагрузки просто удалив соответствующую строчку


QExpress

Содержание

Пути к системным утилитам

Заставка Oulook Express

Заголовок окна Oulook Express

Почтовые фильтры Outlook Express

Сохранение писем
Заставка Oulook Express

Не показывать заставку при загрузке QE. Измените значение ключа с 0 на 1:
HKCU\Identities\{8D48CF80-251E-46D0-9EAF-6633E2DBD392}\Software\Microsoft\Outlook Express\5.0 NoSplash=DWORD

Наверх
Заголовок окна Oulook Express

Для изменения заголовка окна QE добавьте ключ :
HKCU\Identities\{8D48CF80-251E-46D0-9EAF-6633E2DBD392}\Software\Microsoft\Outlook Express\5.0 WindowTitle= ваш заголовок

Наверх
Почтовые фильтры Outlook Express

HKCU\Identities (весь раздел )
HKCU\Software\Microsoft\Internet Account Manager (весь раздел)
C:\Documents and Settings\Ваше имя\Local Settings\Application Data\Identities \{7923BFB0-1BA1-4B15-AC4C-BA27C909B5CB}\Microsoft\Outlook Express

Наверх
Сохранение писем

В Outlook Express можно сохранить выделенное письмо в виде eml-файла (меню "Файл" - "Сохранить как"). Сохранить таким способом сразу несколько писем не получится, так как при их выделении команда "Сохранить как" становится заблокированной. Есть другой путь. Надо выделить все нужные письма в Outlook Express и дать команду "Переслать" (Ctrl + F). Откроется окно нового письма, в которое все выделенные письма будут помещены как вложенные файлы с именами, соответствующими темам писем. Можно сохранить это письмо в eml-формате с помощью команды "Сохранить как", чтобы иметь все письма в одном файле или сохранить все вложенные письма в отдельных eml-файлах с помощью команды "Сохранить вложения"

Наверх


Средство «Восстановление системы»

Общие сведения о средстве «Восстановлении системы»

Средство «Восстановление системы» — компонент системы Windows XP Professional, с помощью которого при возникновении проблем можно восстановить предыдущее состояние компьютера без потери личных файлов (таких, как документы Microsoft Word, перечень просмотренных страниц, рисунки, избранные файлы и сообщения электронной почты). Программа «Восстановление системы» ведет наблюдение за изменениями системы и некоторыми файлами приложений и автоматически создает легко идентифицируемые точки восстановления. Эти точки восстановления позволяют вернуть систему к состоянию на данный момент времени. Они создаются ежедневно, а также во время существенных системных событий (таких, как установка приложения или драйвера). Пользователь также имеет возможность в любое время создавать именованные точки восстановления. «Восстановление Системы» производит "слепок" с системного реестра и создает резервные копии других необходимых для нормального функционирования операционной системы файлов, что дает возможность в случае необходимости произвести возврат системы к прошлому состоянию. Параметры системы восстановления задаются на вкладке System Restore раздел System Properties, до которого можно добраться так: Пуск- Программы- Стандартные- Служебные. По умолчанию System Restore включена не только для загрузочного, но и для всех остальных дисков, отключить System Restore штатными средствами ОС можно у всех дисков, кроме загрузочного.
С целью дополнительной защиты системы ,в Windows XP имеется система защиты файлов.
Если нет возможности запустить компьютер в стандартном режиме, можно использовать систему восстановления для возврата к моменту времени в Безопасном режиме, когда при запуске компьютера возникали ошибки.
Чтобы восстановить состояние на время, когда компьютер запускался без ошибок, выберите точку восстановления, максимально близкую к времени запуска компьютера без ошибок.

Примечания

  • Восстановление никак не влияет и не изменяет личные файлы данных.

    • Система восстановления файлов

    В действительности имеющийся в Windows XP модуль Windows File Protection и вправду восстанавливает файлы, но не все, а только те из исполняемых и системных файлов (*.exe, *.dll, *.ocx и некоторые другие), которые оказались без всякой на то необходимости замененными (например, в процессе инсталляции какой-либо программы), предотвращая тем самым возможные нарушения в работе операционной системы. Дело в том, что для защиты наиболее важных файлов Microsoft ввела их цифровую подпись, и в том случае, если обнаруживается, что происходит замена системного файла другим, не имеющим такой цифровой пописи, следует немедленное оповещение пользователя, а подмененный файл заменяется "правильным", до поры до времени находящемся в специально для этого созданном хранилище. Если же "правильного" файла по какой-то причине на жестком диске не оказывается, то следует предложение вставить в CD-привод компакт-диск, с которого устанавливалась Windows XP...

    Использование мастера восстановления системы

    Мастер восстановления системы дает пошаговые инструкции для каждой задачи системы восстановления.

    При запуске мастера для восстановления предыдущего состояния компьютера отображаются следующие экраны.

    Экран приветствия средства «Восстановление системы»

    На этом экране предлагается параметр для восстановления более раннего состояния компьютера.

    Выберите контрольную точку восстановления

    Этот экран позволяет выбрать в календаре дату, а затем выбрать точку для восстановления предыдущего состояния компьютера.

    Подтверждение выбора точки восстановления

    Этот экран дает возможность отказаться от операции, а также сохранить все файлы и закрыть программы перед запуском операции восстановления. После подтверждения сделанного выбора начнется процесс восстановления, компьютер перезапустится и появится экран входа пользователя.

    Восстановление завершено

    Этот экран показывает, что восстановление было выполнено успешно. Если восстановление выполнить не удастся, будет выведено экран Восстановление не завершено и состояние компьютера не изменяется.

    Средство «Восстановление системы»

    Сведения о восстановлении

    Изменить параметры средства «Восстановление системы»

    Вопросы дискового пространства

    Программа «Восстановление системы» позволяет выполнять перечисленные далее задачи.

    Восстановление предыдущего состояния компьютера

    Программа «Восстановление системы» постоянно автоматически отслеживает изменения, произошедшие на компьютере, и с указанными интервалами создает точки восстановления перед осуществлением изменений. Точки восстановления представляют сохраненные состояния компьютера.

    Также можно создать точки восстановления вручную перед внесением изменений в компьютер, чтобы сохранить состояние компьютера и параметров. Появляется возможность восстановить предыдущее состояние компьютера, выбирая по дате или времени точку восстановления, после которой были произведены изменения.

    Например, если случайно были удалены или повреждены наблюдаемые программные файлы (такие, как файлы с расширением .exe или .dll), то можно восстановить состояние компьютера, предшествующее внесению изменений.

    Программа «Восстановление системы» по умолчанию отслеживает и восстанавливает все разделы и диски на компьютере. Она также отслеживает настройку всех приложений и дисков, которые осуществляют пользователи с помощью CD-ROM или гибкого диска, сервера управления системой (SMS) или IntelliMirror.

    В некоторых случаях при восстановлении системы восстанавливается папка, имя которой совпадает с именем существующей папки. Чтобы не переписывать существующие файлы, программа «Восстановление системы» переименовывает папку, добавляя к ее имени числовой суффикс.

    Восстановление состояния компьютера без потери личных файлов

    Восстановление системы не приводит к потере личных файлов или пароля. Такие элементы, как документы, сообщения электронной почты, перечень просмотренных страниц и последний пароль, сохраняются при восстановлении системы до более раннего состояния.

    Программа «Восстановление системы» обеспечивает сохранение личных файлов, не выполняя восстановление файлов в папке Мои документы. Кроме того, данная программа не восстанавливает файлы данных с часто используемыми расширениями, такими как .doc и .xls. Если пользователь не уверен, что его личные файлы имеют часто используемые расширения имен файлов данных и необходимо их исключить из операции восстановления системы, то следует поместить их в папку «Мои документы».

    Если программа была установлена после создания точки восстановления, то в процессе восстановления эта программа может быть удалена. Файлы данных, созданные программой, не теряются. Однако для открытия этих файлов необходимо будет переустановить соответствующую программу.

    Сохранение прошлых точек восстановления с давностью от одной до трех недель

    Фактическое число сохраненных точек восстановления зависит от активности использования компьютера, размера жесткого диска (или размера раздела, содержащего каталог Windows XP Professional) и количества места на жестком диске, выделенного для хранения сведений программой «Восстановления системы». См. раздел Изменение параметров восстановления системы.

    Обнаружение дат, соответствующих точкам восстановления

    При запуске программы восстановления системы появляется календарь, позволяющий пользователю найти даты, соответствующие точкам восстановления. Если компьютер используется не каждый день, то в течение нескольких дней может существовать только одна точка восстановления. Если компьютер используется ежедневно, то точка восстановления будет приходиться почти на каждый день, а некоторым датам может соответствовать несколько точек восстановления.

    Убедитесь, что все восстановления обратимы

    Если пользователю не нравится состояние компьютера после его восстановления, то можно отменить восстановление или выбрать другую точку восстановления. Все удачные операции восстановления обратимы. Все неудачные операции обновления автоматически отменяются программой восстановления системы.

    Обеспечение несколько типов точек восстановления

    В следующем списке представлены все типы точек восстановления и работа программы восстановления системы с каждым типом точки.

    Контрольные точки исходной системы

    Такие контрольные точки создаются при первом запуске компьютера после обновления системы на Windows XP Professional или при первом запуске нового компьютера. Выбор этой точки возвратит Windows XP Professional и программы в начальное состояние. Все файлы данных с известными расширениями (такими как .doc, .htm, .xls и так далее) и файлы в папке «Мои документы» не будут восстановлены.

    Если средство восстановления системы должно удалить все старые точки восстановления, чтобы освободить место на диске для новых изменений, будет создана новая точка восстановления и далее создание этих точек будет идти в обычном порядке.

    Контрольные точки системы

    Средство восстановления системы регулярно создает точки восстановления, даже если в системе не было сделано никаких изменений. Средством «Восстановление системы» автоматически создаются следующие точки восстановления:

    • каждые 24 часа по календарному времени;

      или

    • каждые 24 часа при включенном компьютере.

    Если компьютер был выключен более 24 часов, средство восстановления системы создаст точку восстановления при следующем включении компьютера. Для создания точки восстановления по расписанию необходимо, чтобы компьютер находился в состоянии простоя несколько минут.

    Выбор этой точки возвратит Windows XP Professional и программы в начальное состояние. Все файлы данных с известными расширениями (такими как .doc, .htm, .xls и так далее) и файлы в папке «Мои документы» не будут восстановлены.

    Точки восстановления установки имени программы

    При установке программ с помощью последних программ установки, типа InstallShield и Windows XP Professional Installer, система восстановления создает точку восстановления. Такие точки восстановления используются для отслеживания изменений в системе или для восстановления состояния компьютера, в котором он находился до установки программы.

    При выборе такой точки восстановления все установленные файлы будут удалены и исходные параметры реестра, все программы и системные файлы будут восстановлены в том виде, в котором они были до установки. Все файлы данных с известными расширениями (такими как .doc, .htm, .xls и так далее) и файлы в папке «Мои документы» не будут восстановлены.

    Чтобы отменить изменения, внесенные программой, которая не использует один из указанных установщиков, выберите предшествующую точку восстановления, наиболее близкую к дате установки программы.

    Точки восстановления для автоматического обновления Windows XP Professional

    При использовании автоматического обновления Windows XP Professional для получения загруженных обновлений система восстановления создает точку восстановления до установки обновленного программного обеспечения. Если обновление загружено, но не установлено, то точка восстановления не создается. Точка восстановления создается только при начале установки компонентов. Эти точки используются для отслеживания изменений в системе и, в редких случаях, отслеживают конфликт этих обновлений с прочими программами, установленными на компьютере.

    Точки восстановления, созданные вручную

    Пользователь имеет возможность вручную создавать собственные точки восстановления с помощью мастера восстановления системы. Созданная точка восстановления отображается на экране Выберите контрольную точку восстановления с присвоенным ей именем и соответствующими значениями даты и времени ее создания. Точки восстановления можно создавать при настройке удачной конфигурации компьютера или перед внесением изменений, например перед установкой на компьютер программ, которые могут повлиять на его работу.

    Точки восстановления операции восстановления

    Каждый раз при выполнении восстановления в конфигурацию компьютера вносятся изменения. Для отслеживания этих изменений и обеспечения возможности их отмены средство восстановления создает точки восстановления операции восстановления. Чтобы отменить восстановление, выберите соответствующую точку восстановления операции восстановления на экране Выберите контрольную точку восстановления мастера восстановления системы.

    Точки восстановления неподписанных драйверов устройств

    Обнаружив установку нового драйвера, который не подписан и не сертифицирован организацией Windows Hardware Quality Labs (WHQL), система восстановления сразу же создает точку восстановления. Если установка драйвера привела к нежелательным изменениям, можно на экране мастера восстановления системы Выберите контрольную точку восстановления выбрать такую точку восстановления, чтобы отменить эти изменения и вернуть компьютер к состоянию до установки драйвера.

    Точки восстановления программы Microsoft Windows

    При выполнении восстановления с использованием программы Backup, программа «Восстановление системы» создает точки восстановления до начала архивации. Если после операции восстановления компьютер перешел в неверное состояние, можно на экране Выберите контрольную точку восстановления выбрать такие контрольные точки и вернуть компьютер к состоянию до выполнения восстановления по архивной копии.

    Примечания

    • Если выбранная точка восстановления была создана до установки программы, эта программа не будет работать после восстановления. При необходимости использовать данную программу установите ее заново.
    • Средство восстановления системы не заменяет процесс отмены установки программы. Для полного удаления файлов, установленных программой, необходимо удалить программу, используя компонент Установка и удаления программ на панели управления или используя собственную программу отмены установки.
    • Программа «Восстановление системы» не отслеживает и не восстанавливает перенаправленные папки и любые настройки, связанные с перемещаемыми профилями пользователей.
    • Программа «Восстановление системы» выполняет наблюдение и восстановление только дисков и разделов, указанных в ее конфигурации. Она не влияет на диски и разделы, которые были перенаправлены или исключены из наблюдения.
    • При наличии зашифрованных файлов (таких, которые имеют расширение .exe или .dll) они никогда не будут расшифрованы. Чтобы удостовериться в этом, выключите программу «Восстановления системы» до начала шифрования файлов или папок, а затем запустите ее снова, после окончания. Или, если зашифрованные файлы уже существуют, включите и выключите систему восстановления. При выключении программы «Восстановление системы» все точки восстановления удаляются. Точки восстановления, созданные после повторного запуска «Восстановления системы», не содержат сведения о времени расшифровки файлов. Как правило, шифруются только файлы данных, которые не могут быть изменены программой «Восстановление системы».


Автозагрузка

Автозапуск

Существует немало способов автозапуска программ. Ниже приведены варианты, если возникнет необходимость найти и удалить какую-либо программу из автозапуска.

Содержание

Способы автозапуска и отключение из автозапуска

Запретить автозапуск программ Local Machine Run

Запретить автозапуск программ Local Machine Run Once

Запретить автозапуск программ Current User Run

Запретить автозапуск программ Current User Run Once

Использование групповой политики для автозапуска

Автозапуск из особого списка

Не обрабатывать список автозапуска для старых версий

Игнорировать списки автозагрузки программ выполняемых однажды

Назначенные задания

Папка "Автозагрузка"

Смена папки автозагрузки

Подмена ярлыка для программы из списка автозагрузки

Добавление программы к программе запускаемой из списка автозагрузки

Программы стартующие вместе с системой

Способы автозапуска и отключение из автозапуска

автозапуск представлен в нескольких местах:

HKLM\ SOFTWARE\Microsoft\ Windows\CurrentVersion\ Run- программы, которые запускаются при входе в систему. Данный раздел отвечает за запуск программ для всех пользователей системы.

HKLM\ SOFTWARE\Microsoft\ Windows\CurrentVersion\ RunOnce - программы, которые запускаются только один раз при входе пользователя в систему. После этого ключи программ автоматически удаляются из данного раздела реестра. Данный раздел отвечает за запуск программ для всех пользователей системы.

HKLM\ SOFTWARE\Microsoft\ Windows\CurrentVersion\ RunOnceEx- программы, которые запускаются только один раз, когда загружается система. Этот раздел используется при инсталляции программ, например для запуска настроечных модулей. После этого ключи программ автоматически удаляются из данного раздела реестра. Данный раздел отвечает за запуск программ для всех пользователей системы.

HKCU\ Software\Microsoft\ Windows\CurrentVersion\ Run - программы, которые запускаются при входе текущего пользователя в систему

HKCU\ Software\Microsoft\Windows\ CurrentVersion\ RunOnce - программы, которые запускаются только один раз при входе текущего пользователя в систему. После этого ключи программ автоматически удаляются из данного раздела реестра.

HKLM\ SOFTWARE\Microsoft\ Windows\CurrentVersion\ RunServices - программы, которые загружаются при старте системы до входа пользователя в Windows.

HKLM\ SOFTWARE\Microsoft\ Windows\ CurrentVersion\ RunServicesOnce - программы отсюда загружаются только один раз, когда загружается система.

Например, чтобы автоматически запускать Блокнот при входе текущего пользователя, открываем Редактор реестра (regedit.exe), переходим в раздел
HKCU\ Software\ Microsoft\ Windows\ CurrentVersion\ Run и добавляем следующий ключ: NOTEPAD.EXE= C:\\WINDOWS\\System32\\ notepad.exe

Наверх
Запретить автозапуск программ Local Machine Run

Программы, запускаемые для всех пользователей компьютера.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer

DisableLocalMachineRun:DWORD = 1 отключает автозапуск программ

Наверх
Запретить автозапуск программ Local Machine Run Once

Программы, запускаемые для всех пользователей компьютера один раз.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer

DisableLocalMachineRunOnce:DWORD = 1 отключает автозапуск программ

Наверх
Запретить автозапуск программ Current User Run

Программы, запускаемые для текущего пользователя компьютера.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer

DisableCurrentUserRun:DWORD = 1 отключает автозапуск программ

Наверх
Запретить автозапуск программ Current User Run Once

Программы, запускаемые для текущего пользователя компьютера один раз.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer

DisableCurrentUserRunOnce:DWORD = 1 отключает автозапуск программ

Наверх
Использование групповой политики для автозапуска

Пуск-Выполнить (gpedit.msc), откройте оснастку Групповая политика, перейдите на вкладку Конфигурация компьютера - Административные шаблоны - Система. В правой части оснастки перейдите на пункт Запускать указанные программы при входе в систему. По умолчанию эта политика не задана, но вы можете добавить туда программу: включаем политику, нажимаем кнопку Показать - Добавить, указываем путь к программе, при этом если запускаемая программа находится в папке ..WINDOWS\System32\ то можно указать только название программы, иначе придется указать полный путь к программе. При этом в системном реестре в разделе HKLM\ SOFTWARE\Microsoft\ Windows\CurrentVersion\ policies создается подраздел \Explorer\Run с ключами добавленных программ. Пример:

HKLM\ SOFTWARE\Microsoft\ Windows\CurrentVersion\ policies\Explorer\Run
1= notepad.exe
2= iexplore.exe

В итоге получаем запуск Блокнота и Internet Explorer для всех пользователей. Аналогично задается автозапуск для текущих пользователей, в оснастке Групповая политика это путь Конфигурация пользователя - Административные шаблоны - Система, а в реестре раздел

HKCU\ Software\Microsoft\ Windows\CurrentVersion\ Policies\Explorer\Run

При этом программы из этого списка не отображаются в списке программ доступных для отключения в msconfig.exe, а также определяются не всеми менеджерами автозагрузки.

Наверх
Автозапуск из особого списка

Программы могут запускаться и из следующего раздела реестра:

HKCU\ Software\ Microsoft\Windows NT\ CurrentVersion\Windows

Параметры:

"load"="programma" - программы запускаемые до входа пользователя в систему:
"run"="programma" - программы запускаемые после входа пользователя в систему.

Эти параметры - аналог автозагрузки из Win.ini в Windows 9х. Пример: запускаем Internet Explorer до входа пользователя в систему и Блокнот после входа пользователя в систему:

HKLM\ SOFTWARE\Microsoft\ Windows NT\CurrentVersion\ Windows
load= iexplore.exe
run= notepad.exe

Наверх
Не обрабатывать список автозапуска для старых версий

Настраивается с помощью групповой политики: Конфигурация компьютера - Административные шаблоны - Система - Не обрабатывать список автозапуска для старых версий, если эту политику включить, то не будут запускаться программы из следующих разделов реестра:

HKLM\ Software\Microsoft\ Windows\CurrentVersion\ Run

При использовании этой политики в реестре создается следующий ключ:

HKLM\ SOFTWARE\Microsoft\ Windows\CurrentVersion\ policies\Explorer
DisableLocalMachineRun= dword:00000001

Аналогично устанавливается политика для текущих пользователей: "Конфигурация пользователя - Административные шаблоны - Система - Не обрабатывать список автозапуска для старых версий с тем отличием что в реестре эта опция включается в ином месте:

HKCU\ Software\Microsoft\ Windows\CurrentVersion\ Policies\Explorer
DisableLocalUserRun=dword:00000001

Наверх
Игнорировать списки автозагрузки программ выполняемых однажды

Настраивается с помощью групповой политики: "Конфигурация компьютера - Административные шаблоны - Система - Не обрабатывать список автозапуска программ, выполняемых однажды", если эту политику включить, то не будут запускаться программы запускаемые из списка

HKLM\ Software\ Microsoft\ Windows\CurrentVersion\ RunOnce

Если эта политика включена, в реестре создается следующий ключ:

HKLM\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ policies\Explorer
"DisableLocalMachineRunOnce"= dword:00000001

Так же настраивается политика для текущих пользователей: "Конфигурация пользователя - Административные шаблоны - Система - Не обрабатывать список автозапуска программ, выполняемых однажды" Параметры реестра:

HKCU\ SOFTWARE\Microsoft\ Windows\CurrentVersion\ policies\Explorer
"DisableLocalUserRunOnce"=dword:00000001

Наверх
Назначенные задания

программы могут запускаться с помощью "Мастера планирования заданий". Посмотреть список установленных заданий, а также добавить новое можно так: "Пуск - Все программы - Стандартные - Служебные - Назначенные задания" - при этом откроется папка ..\WINDOWS\Tasks, в которой отображены назначенные задания. Чтобы добавить новое задание, нужно дважды щелкнуть левой кнопкой мыши по значку "Добавить задание". Запуск программ с помощью этого мастера возможен однократно, при входе в Windows, при включении компьютера, а также по расписанию.

Наверх
Папка "Автозагрузка"

это папка, в которой хранятся ярлыки для программ запускаемых после входа пользователя в систему. Ярлыки в эту папку могут добавляться программами при их установке или пользователем самостоятельно. Существует две папки - общая для всех пользователей и индивидуальная для текущего пользователя. По умолчанию эти папки находятся здесь:

..\Documents and Settings\ All Users\Главное меню\ Программы\Автозагрузка - это папка, программы из которой будут запускаться для всех пользователей компьютера.

..\Documents and Settings\ Username\Главное меню\ Программы\Автозагрузка - это папка, программы из которой будут запускаться для текущего пользователя (здесь он назван Username).

Посмотреть какие программы у вас запускаются таким способом можно открыв меню "Пуск - Все программы - Автозагрузка". Если вы создадите в этой папке ярлык для какой-нибудь программы, она будет запускаться автоматически после входа пользователя в систему. Если при входе пользователя в систему удерживать нажатой клавишу "Shift", то программы из папок "Автозагрузка" запускаться не будут.

Наверх
Смена папки автозагрузки

Windows считывает данные о пути к папке "Автозагрузка" из реестра. Этот путь прописан в следующих разделах:

HKLM\ SOFTWARE\ Microsoft\Windows\ CurrentVersion\Explorer\ User Shell Folders
"Common Startup"= "%ALLUSERSPROFILE%\ Главное меню\Программы\ Автозагрузка" - для всех пользователей системы.

HKCU\ Software\Microsoft\ Windows\CurrentVersion\ Explorer\User Shell Folders
"Startup"= "%USERPROFILE%\ Главное меню\ Программы\Автозагрузка" - для текущего пользователя.

Сменив путь к папке мы получим автозагрузку всех программ из указанной папки. Например:
HKCU\ Software\Microsoft\ Windows\CurrentVersion\ Explorer\User Shell Folders
"Startup"="c:\mystartup" - система загрузит все программы, ярлыки которых находятся в папке c:\mystartup\, при этом папка "Автозагрузка" все так же будет отображаться в меню "Пуск", а если у пользователя в ней ничего не было, то он и не заметит подмены.

Наверх
Подмена ярлыка для программы из списка автозагрузки

допустим у вас установлен русскоязычный пакет Microsoft Office. Тогда в папке "Автозагрузка" у вас будет находиться ярлык "Быстрый запуск Microsoft Office" - этот ярлык устанавливается туда по умолчанию. Но вовсе необязательно этот ярлык ссылается именно на "Быстрый запуск Microsoft Office" - вместо него может быть запущена любая другая программа, тем более что на функциональности Office это не скажется.

Наверх
Добавление программы к программе запускаемой из списка автозагрузки

модификация предыдущего варианта - одновременно с загрузкой какой-либо программы из списка автозагрузки у вас будет стартовать другая программа - дело в том, что можно "склеить" два исполняемых файла в один и они будут запускаться одновременно. Существуют программы для такой "склейки". Или ярлык может ссылаться на командный файл, из которого и будут запускаться как оригинальная программа из списка, так и добавленные посторонние программы.

Посмотреть список автоматически загружаемых программ можно открыв программу Сведения о системе (откройте Пуск - Все программы - Стандартные - Служебные - Сведения о системе" или наберите msinfo32.exe в командной строке) и перейдя в пункт Программная среда - Автоматически загружаемые программы. Программа Свойства системы отображает группы автозагрузки из реестра и папок Автозагрузка.

Другая программа, позволяющая посмотреть список программ автозагрузки - " Настройка системы" ( наберите msconfig.exe в командной строке). Эта программа кроме просмотра списка автозагрузки предоставляет возможность отключения всех пунктов автозагрузки (вкладка Общие) выборочных программ (вкладка Автозагрузка).

Примечание: Вся информация, относится к опытным пользователям, способным восстановить систему после ошибочных изменений в реестре. Если вы не уверены, что в случае ошибочных действий сможете восстановить систему, не используйте приведенную информацию в практических целях, ошибочные действия при внесении изменений в реестр могут серьезно повредить систему и даже привести к переустановке системы. Начинающие пользователи для добавления программ в список автозагрузки должны использовать папку Автозагрузка или Мастер назначенных заданий.

Наверх
Программы стартующие вместе с системой

Часть этих программ можно отключить для экономии ресурсов. Совет - проверьте сначала к какой из установленных программ он относится, и сделать выводы- выполняет он какие-то полезные функции или от его запуска можно отказаться, и принимать решение. Часть программ из числа известных:

  • Access Ramp Monitor (armon32.exe) - отслеживает параметры интернет- соединения, запрещает запуск некоторых игр.
  • Album Fast Start (abmtsr.exe) - утилита для сканера, для его нормальной работы не требуется, доступна из меню "Пуск".
  • Alogserv (alogserv.exe) - утилита для ведения протокола работы McAfee VirusScan.
  • Bpcpost.exe - Microsoft TV Viewer Post Setup Program - часть Microsoft WebTV for Windows.
  • BrowserWebCheck (loadwc.exe) - проверяет, является ли Internet Explorer браузером, используемым по умолчанию. По желанию.
  • ConMgr.exe (conmgr.exe) - запускает WinFax Pro, нужна для ответа на входящие звонки.
  • CtfMon (ctfmon.exe) - прописывается в автозагрузку при каждом запуске Office XP, нужна для альтернативных способов ввода текста, раскладка клавиатуры.
  • CyDoor (CT_Load.exe) - spyware-утилита. Удалить вместе с программой-маткой. Поможет в этом утилита AD-aware.
  • EM_EXEC (em_exec.exe) - драйвер мыши Logitech. Нужен для поддержки дополнительных функций мыши или трекбола.
  • Fpx (mnmsrvc.exe) - служба Remote Desktop Sharing, часть Microsoft NetMeeting.
  • Gator (gator.exe) - шпионско-рекламная программа. Отключить.
  • HIDServ (hidserv.exe) - Human Interface Device Server, нужен если используется какое-то USB-аудиоустройство, например USB-клавиатура с регулятором громкости.
  • Internat (internat.exe) - индикатор раскладки клавиатуры в системной области панели задач. Для самого переключения не требуется.
  • LoadPowerProfile (powrprof.dll) - отвечает за управление питанием и загрузку соответствующих профилей. Грузится два раза, один можно отключить.
  • Machine Debug Manager (mdm.exe) - дебаггер, нужен разработчикам и тестерам ПО. Рекомендуется отключить.
  • MDAC_runonce (runonce.exe) - ассоциировано с Microsoft Data Access Components (MDAC). Автозагрузка не требуется, но наличие на диске самой системной утилиты runonce.exe необходимо. Microsoft Office Shortcut Bar (msoffice.exe) - панель быстрого запуска, входящая в состав Office.
  • MOSearch (mosearch.exe) - утилита Fast Search в Office XP, аналогична FindFast из Office 2000. Потребляет много ресурсов, отключить, если не работаете с многими документами.
  • MSBB (msbb.exe) - шпион, загружает рекламу на ПК и следит за пользователем. Отключить.
  • MSConfigReminder (msconfig.exe) - при загрузке ОС сообщает, если вы что-то отключили в программе "Настройка системы".
  • Netzip Smart Downloader (npnzdad.exe) - spyware-утилита, закачивает рекламу на ПК без ведома пользователя и отслеживает его действия.
  • New.net (rundll32.exe NewDotNetStartup) - шпионская программа. Отключить.
  • PWSTray (pwstray.exe) - Microsoft Personal Web Server, можно запустить вручную.
  • QuickSort (qsort.exe) - утилита для сортировки пунктов меню "Пуск" по алфавиту. По желанию.
  • RealDownload Express (npnzdad.exe) - загружает рекламу на ПК. Отключить
  • Resource Meter (rsrcmtr.exe) - индикатор ресурсов Windows, можно запускать вручную.
  • SaveNow (savenow.exe) - шпионская, загружает рекламу на ПК . Отключить.
  • ScanRegistry (scanregw.exe) - системный сканер реестра, и делает его резервные копии. Оставить.
  • SchedulingAgent (mstask.exe) - "Планировщик заданий". Если не используется - отключить.
  • Synchronization Manager (mobsync.exe) - Internet Explorer Synchronization Manager - для повседневной работы не нужен.
  • SystemTray (systray.exe) - System Tray Services, выводит в системной области панели задач значки Volume Control, PC Card Status и Power Management.
  • TaskMonitor (taskmon.exe) - отслеживает ход запуска программ и поставляет эти данные дефрагментатору для оптимизации расположения файлов на диске. Оставить.
  • TimeSink Add Client (tsadbot.exe) - шпион. Отключить.
  • W3KNetwork (rundll32.exe w3knet.dll,dllinitrun) - шпион. Отключить.
  • Winmodem (wmexe.exe) - нужен для функционирования некоторых вин-модемов.

Наверх


Анализ безопасности

Анализ безопасности системы

  1. Откройте оснастку «Анализ и настройка безопасности».
  2. Как? Нажмите кнопку Пуск, выберите команду Выполнить, введите mmc и нажмите кнопку OK. Что такое MMS?
  3. В дереве консоли щелкните правой кнопкой мыши узел Анализ и настройка безопасности и выберите команду Открыть базу данных.

    Расположение

  4. Корень консоли
  5. Анализ и настройка безопасности
  6. В диалоговом окне Открыть базу данных выполните одно из следующий действий:
    • чтобы создать новую базу данных, введите имя в поле Имя файла и нажмите кнопку Открыть;
    • чтобы открыть существующую базу данных, выберите базу данных и нажмите кнопку Открыть.
  7. Если создается новая база данных, в диалоговом окне Импорт шаблона выберите шаблон и нажмите кнопку Открыть.
  8. В области сведений щелкните правой кнопкой мыши узел Анализ и настройка безопасности и выберите команду Анализ компьютера.
  9. Выполните одно из следующих действий:
    • для использования стандартного журнала в группе Путь файла журнала ошибок нажмите кнопку OK;
    • для выбора другого журнала введите в поле Путь файла журнала ошибок допустимые путь и имя файла.

Примечания

  • Для выполнения этой процедуры необходимо войти в систему с учетной записью «Администратор» или члена группы «Администраторы». Если компьютер подключен к сети, то параметры сетевой политики могут запретить выполнение данной процедуры.
  • Чтобы открыть оснастку «Анализ и настройка безопасности», нажмите кнопку Пуск, выберите команду Выполнить, введите mmc и нажмите кнопку ОК. В меню Консоль выберите команду Открыть, щелкните необходимую консоль и нажмите кнопку Открыть. Затем в дереве консоли щелкните узел Анализ и настройка безопасности.
  • В оснастке «Настройка и анализ безопасности» области безопасности отображаются по мере их анализа. По завершении анализа можно просмотреть файл журнала или результаты анализа. Как получить сведения о просмотре результатов анализа щелкните ссылку «Результаты анализа безопасности».
  • Чтобы просмотреть файл журнала, щелкните правой кнопкой мыши раздел Анализ и настройка безопасности и выберите команду Просмотр файла журнала.
  • По умолчанию для файла журнала используется следующий путь:

    systemroot\Documents and Settings\UserAccount\My Documents\Security\Logs\имя_базы_данных.log


Безопасность

Безопасность\Параметры защиты

Запрет запуска апплета "Установка и удаление программ"

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

"NoAddRemovePrograms" dword= 1 - запрещает запуск апплета Установка и удаление программ

Наверх
Скрыть вкладку "Изменение или удаление программ" в апплете Установка и удаление программ.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

"NoRemovePage"dword= 1 - скрыть вкладку

Наверх
Скрыть вкладку "Установка программ" в апплете Установка и удаление программ.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

"NoAddPage" dword= 1 - скрыть вкладку

Наверх
Скрыть вкладку Установка компонентов Windows.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

"NoWindowsSetupPage" dword= 1 - скрыть вкладку

Наверх
Скрыть раздел Установка программы с CD-ROM или дискеты и кнопку CD или дискета на вкладке Установка программ.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

"NoAddFromCDorFloppy" dword= 1 - скрыть вкладку

Наверх
Скрыть раздел Установка программы от Майкрософт и кнопку Windows Update на вкладке Установка программ.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

"NoAddFromInternet" dword= 1 - скрыть вкладку

Наверх
Скрыть раздел Установка программ из сети.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

"NoAddFromNetwork" dword= 1 - скрыть вкладку

Наверх
Скрыть ссылку Сведенья о поддержке

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

"NoSupportInfo" dword= 1 - скрыть сведенья о поддержке

Наверх
Полностью отключить общие ресурсы (ADMIN$, C$ и т.д.)

Эти ресурсы доступны Администратору, для отключения/включения требуется перезагрузка. Windows XP позволяет отключить эти ресурсы, но только до перезагрузки.

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

"AutoShareWks"dword= 0 - общие ресурсы отключены, 1 - включены

Наверх
Запрет на доступ к содержимому выбранных дисков

Запретить пользователю доступ к файлам заданных дисков через Проводник, Мой компьютер, Выполнить. Создать параметр HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoViewOnDrive= dword: ? содержащий битовую маску для дисков. Пример, диск A имеет бит 1, диск С - 4, диск D - 8. Таким образом, чтобы скрыть диски A и D, нужно сложить их значения 1 (A) + 8 (D) и установить значение 9.
Список всех дисков:
A: 1, B: 2, C: 4, D: 8, E: 16, F: 32, G: 64, H: 128, I: 256, J: 512, K: 1024, L: 2048, M: 4096, N: 8192, O: 16384, P: 32768, Q: 65536, R: 131072, S: 262144, T: 524288, U: 1048576, V: 2097152, W: 4194304, X: 8388608, Y: 16777216, Z: 33554432, Все диски: 67108863

Наверх
Windows позволяет ограничить доступ к программам, кроме разрешенных в специальном списке

Раздел HKCU\SOFTWARE\Microsoft\ Windows\CurrentVerson\Policies\Explorer создать ключ RestrictRun = dword: 0х00000001. Затем тут же надо создать подраздел с аналогичным именем RestrictRun и в нем перечислить список РАЗРЕШЕННЫХ к запуску программ для текущего пользователя. Записи в этом подразделе пронумеровываются, начиная с 1, и содержат строки с путями (необязательно) и именами приложений. Файлы должны быть с расширением. Например, Word.exe, Excel.exe ...

Не забудьте указать файл Regedit.exe, иначе Вы сами не сможете больше запустить редактор реестра! Для сброса ограничения на запуск программ надо установить значение ключа RestrictRun в 0

Наверх
Пользовательский интерфейс настройки приложения "System Restore"

Можно отключить пользовательский интерфейс настройки приложения "System Restore", чтобы предотвратить изменение настройки этого приложения пользователем, а также отключение и включение этого свойства для системных и несистемных дисков. В разделе реестра HKLM\SOFTWARE \Policies \Microsoft \Windows NT создать подраздел "SystemRestore", в нём dword-параметр "DisableConfig" со значением 1

Наверх
Удалить пункт Управление из контекстного меню значка Мой компьютер

Удалить пункт Управление из контекстного меню значка Мой компьютер, создать параметр : dword NoManageMyComputerVerb со значением 1 в разделе
HKCU\Software\Microsoft\ Windows\CurrentVersion\Policies\Explorer

Примечание: Данный пункт запускает утилиту compmgmt.msc. Удаление пункта не удаляет программу

Наверх
Изменение параметров безопасности

Панель управления -> Администрирование -> Локальная политика безопасности -> Локальные политики -> Параметры безопасности. Установите параметры обеспечивающие максимальную безопасность вашего компьютера.

Наверх
Запрет доступа к всем ресурсам

Компьютер под управлением Windows XP необходимо сконфигурировать таким образом, чтобы предотвратить доступ анонимно регистрирующихся пользователей ко всем ресурсам. Это можно сделать в ветке:
HKLM\SYSTEM\CurrentControlSet\Control\Lsa параметр "restrictanonymous"=dword:00000000 на 00000001.

Наверх
Голубой экран

Голубой экран смерти - печально известная для пользователей Windows вещь. Но иногда даже она может определенным образом помочь. Можно вызвать этот пресловутый экран путем нажатия сочетания определенных клавиш, тем самым мгновенно уничтожив всю информацию в оперативной памяти, файле подкачки, во временных файлах. Эта функция может помочь, когда необходимо мгновенное стирание информации (Неожиданный визит специалистов из ФСБ :-), например). Чтобы осуществить это необходимо в ветке реестра:
HKLM\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters создать параметр CrashOnCtrlScroll : dword = 1
и теперь при двукратном нажатии Scroll Lock с удерживаемой правой клавишей Ctrl система впадет в глубокий даун.

Наверх


Быстродействие

Быстродействие системы

Операционная система Windows никогда не работает с максимальной скоростью при настройках по умолчанию. Частично это связано с большим количеством оборудования, на которое устанавливается данная система. Microsoft сбалансировала производительность с легкостью в использовании и совместимостью с любым оборудованием. Windows XP выдвигает несколько предположений о том, как она будет использоваться. Графический интерфейс системы обладает своеобразной теплотой и дружественностью, но эффекты типа теней и исчезающего меню замедляют систему. Инструменты по обеспечению отказоустойчивости типа "Восстановления системы" (System Restore) облегчают восстановление после аварий, но они также съедают дисковое пространство, а их работа в фоновом режиме потребляет часть мощности процессора. Windows XP запускает большое количество служб, которые могут понадобиться, и могут оказаться совершенно бесполезными, в зависимости от рода вашей деятельности на компьютере. Снятие лишних служб помогает ускорить запуск системы и немного разгрузить процессор для других приложений. К тому же многие приложения типа "Microsoft Office" загружают свои фоновые приложения, которые также съедают системную память и процессор. Если вы потратите несколько минут на снятие лишних фоновых приложений и служб, а также отключите некоторые графические украшательства, то вы сможете заметно улучшить игровую и офисную производительность вашей Windows XP. Даже сама XP помогает оптимизировать файловую систему в зависимости от ваших нужд, к тому же Microsoft поставляет несколько утилит для оптимизации системы. Большинство оптимизаций потребуют редактирование реестра или внесение изменений в жизненно важные части системы, так что вам потребуются административные привилегии. Перед работой вы должны отключить антивирусные средства и программы по обеспечению безопасности, а также выполнить резервирование всех жизненно важных данных. Windows XP прекрасно настраивается! Честно :-) И помните, что только эксперимент поможет вам выбрать оптимальное соотношение между графическими украшениями и производительностью. Поехали...

Отключить нажатие CTRL+ATL+DEL сразу после загрузки Windows. Панель управления -> Администрирование -> Локальная политика безопасности -> Локальные политики -> Параметры безопасности : пункт «Интерактивный вход в систему: не требовать нажатия CTRL + ALT + DELETE» щелкнуть на нем два раза и выбрать пункт «Включен».

Можно немного увеличить скорость работы, отключить систему POSIX (никогда не используется). HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Subsystems = удалить в нём строки Optional и POSIX.

Раскрытие меню. Заходим в HKCU\ControlPanel\Desktop] ключ "MenuShowDelay". Этот ключ устанавливает задержку раскрывающихся меню. По умолчанию она равна 400 миллесекундам. Можно уменьшить до 50-100.

Анимация окон. Заходим в HKCU\ControlPanel\Desktop\WindowsMetrics ключ "MinAnimate". Если поставить его в 1, то анимация окон исчезнет и они будут раскрываться мгновенно.

Утилита MSCongif. Пишем в командной строке "msconfig" В закладке Startup список автозагрузочных программ. В разделе Service список системных служб. Отредактировать по желанию, но не отключите нужные службы.

Убрать дебаггер. Заходим в HKLM\Software\Microsoft\WindowsNT\CurrentVersion\AeDebug ключ "Auto" меняем значение на 0. После в System Properties- Advanced. Жмем Error Reporting и выбираем Disable error reporting. Ставим галочку в But notify me, when critical errors.

Ускорить выключение Windows. Заходим в HKLM\System\CurrentControlSet\Control ключ "WaitToKillServiceTimeout". По умолчанию 20000. Значит, что система будет ожидать 20 секунд, перед тем, как признать зависшие программы зависшими. Ставим на 5000. Ниже ставить не советую, а то система начнет убивать работающие программы.

Для совместимости со старыми приложениями Windows XP создает в разделе с NTFS специальную таблицу, содержащую все имена файлов и папок в формате MS-DOS: 8 . 3.Для увеличения производительности такую функцию следует отключить. Делается это через реестр: HKLM\System\CurrentControlSet\Control\FileSystem, параметр NtfsDisable8dot3NameCreation = установить его значение в 1.

Встроенная оптимизация Windows XP
Самое интересное, что оптимизация в Windows XP производится постоянно. По мере того, как вы запускаете приложения, Windows наблюдает за вашим поведением и записывает динамический файл layout.ini. Каждые три дня, после того, как система сочтет компьютер бездействующим, она изменяет физическое местоположение некоторых программ на жестком диске для оптимизации их времени запуска и выполнения. XP также ускоряет процесс загрузки системы и оптимизирует запуск программ с помощью предсказаний. Windows наблюдает за кодом и программами, которые запускаются сразу после загрузки, и создает список, позволяющий предсказать запрашиваемые данные во время загрузки. Точно также при запуске отдельных программ, Windows следит за используемыми программой компонентами и файлами. В следующий запуск приложения Windows предсказывает список файлов, которые потребуются программе. Предсказания используются и в ядре Windows XP, и в планировщике задач. Ядро следит за страницами, к которым обращается данный процесс сразу же после его создания. Далее служба создает ряд инструкций предсказания. Когда процесс будет создан в следующий раз, ядро выполнит инструкции предсказания, ускорив выполнение процесса. Оптимизация диска и ускорение запуска приложений/загрузки тесно работают вместе. Списки, записанные при запуске приложения и при загрузке системы, используются при выполнении оптимизации файловой системы для более быстрого доступа к программам.

Ускорение графики, убрать иконки и обои, чистый рабочий стол - это самый лучший рабочий стол. Никогда не ставьте обои! Более странного поступка трудно себе представить. Системной памяти и процессору наверняка найдется лучшее применение, чем играться с красивым фоном и сортировать сотни иконок. Как и в предыдущих версиях Windows, чрезмерное количество иконок и обои поедают напрочь системную память. Особенно тяжелым бременем на систему ложится анимированный рабочий стол. С другой стороны, удар по производительности не слишком велик, если ваша система оснащена более 256 Мб памяти и нормальным процессором (где-то 1000 МГц или быстрее). Если же у вас 64 Мб памяти и Pentium 2, то здесь придется серьезно экономить отключая все, что только возможно. Снизьте количество эффектов Благодаря новому виду и GNOME-подобной поддержке скинов, Windows XP выглядит красивее любой предыдущей версии Windows. Переход между меню анимирован, диалоги и курсор имеют тень, экранные шрифты настраиваются под максимальную читаемость и т.д. Все эти визуальные утехи могут снижать реакцию интерфейса на пользователя. XP запускает несколько тестов для автоконфигурации своего пользовательского интерфейса чтобы сохранить как удобство, так и красоту, но вы легко можете все исправить. Если исчезающие меню вам больше досаждают, нежели нравятся, а тени под окнами диалогов вам безразличны, то вы можете убрать все лишнее. Некоторые настройки выполняются через закладку Оформление (Appearance) в свойствах дисплея, которые вы можете вызвать нажав правую клавишу мыши на любой свободной части экрана и выбрав Свойства (Properties). Нажмите клавишу Эффекты (Effects) и вы сможете настроить переходы в меню, тени и шрифт, включая новую технологию улучшения читаемости шрифта Microsoft ClearType. По нашему мнению, ClearType хорош для ноутбуков и ЖК мониторов, но на ЭЛТ текст выглядит слишком жирно и смазано. Учтите, что даже на ЖК мониторе не всем нравится ClearType, так что выбирайте по своему вкусу. Вы можете и дальше настраивать производительность графического интерфейса через Свойства системы (System Properties). Откройте свойства через Панель управления (Control Panel) или нажмите правой клавишей мыши на значок System и выберите там Properties (Свойства). Далее перейдите к закладке Дополнительно (Advanced) и нажмите Параметры (Settings) в панели Производительность (Performance). Здесь вы можете указать как максимальную производительность, так и максимальную красивость, равно как выбрать необходимые параметры самому.
Перейдите к закладке Дополнительно (Advanced) в Параметрах быстродействия (Performance Options) и убедитесь, что распределение ресурсов процессора и памяти выставлено на оптимизацию работы программ – вам нужно указывать приоритет фоновых служб и кэша если только ваш компьютер выполняет роль сервера.
Здесь вы также можете указать размер и местоположение файла подкачки. Но Windows XP обычно сама прекрасно выбирает этот размер. Мы попытались вручную изменять его, но прироста производительности в синтетических или игровых тестах это не дало.
Быстрое переключение между пользователями
Такая функция доступна в XP Home Edition и Professional, если компьютер не входит в домен. Быстрое переключение позволяет пользователям одного компьютера быстро переключаться между учетными записями без завершения сеанса. Прекрасная функция, если вашим компьютером пользуется мама, папа и всякие сестры-братья, однако такое переключение колоссально (!) отъедает доступную память.
Если в систему вошло более одного пользователя, то настройки каждого пользователя, равно как и запущенные программы сохраняются в памяти при переключении к другому пользователю.
Windows XP автоматически отключает быстрое переключение между пользователями, если компьютер оснащен 64 Мб памяти или меньше. Для максимальной производительности убедитесь, что в одно время в систему заходит только один пользователь. Вы также можете отключить эту функцию, зайдите в Панель управления\Учетные записи пользователей (Control Panel\User Accounts) нажмите кнопку "Change the way users log on or off": и уберите галочку с пункта "Use Fast User Switching".
Автоматическое обновление
Вы всегда должны ставить на Windows последние исправления, версии DirectX, патчи совместимости и другие обновления (!). Но по умолчанию XP будет сама делать это за вас, разве что для этого потребуется запуск небольшой программы в фоне, которая будет проверять обновления.
Если вы сами следите за обновлениями, то можете сказать XP более вас по этому вопросу не беспокоить. Перейдите в закладку Автоматическое обновление (Automatic Updates) в Свойствах системы (System Properties). Здесь вы можете указать Windows определять и скачивать обновления автоматически, или сообщать вам об этом, или вообще отключить определение.
Восстановление системных файлов
Полезная функция, если ваш компьютер не используется исключительно для ресурсоемких задач типа игр. Так что лучше оставить ее включенной. При этом компьютер периодически создает слепки критичных системных файлов (файлы реестра, COM+ база данных, профили пользователей и т.д.) и сохраняет их как "точку отката". Если какое-либо приложение "снесет" вашу систему, или что-то важное будет испорчено, вы можете обратить компьютер в предыдущее состояние - в точку отката.
Точки отката автоматически создаются службой "Восстановления системы" (System Restore) при возникновении некоторых ситуаций типа установки нового приложения, обновления Windows, установки неподписанного драйвера и т.д. Вы можете и вручную создавать точки отката через интерфейс Восстановления системы (System Restore), который можно вызвать пройдя путь: Пуск\Программы\Стандартные\Служебные\Восстановление системы (Start\Programs\Accessories\System Tools\System Restore).
Восстановление системных файлов опирается на фоновую службу, которая минимально сказывается на быстродействии и записывает снимки, отнимающие часть дискового пространства. Вы можете вручную отвести максимальный объем дискового пространства для данной службы. Вы также можете полностью отключить службу для всех дисков.
Отключить можно пометив бокс "Turn off System Restore"
Поскольку служба восстановления системных файлов может влиять на результаты тестовых программ, ее обычно отключают перед тестированием, что нам и приходится часто делать.
Регулярно производите дефрагментацию. DOS и не-NT версии Windows мало заботились об оптимизации своих файловых систем. Когда вы устанавливаете и удаляете программы, то в различных областях дискового пространства создаются "дыры". В результате свободное место представляет собой не сплошной блок, оно разбросанно по всему диску. При заполнении свободного пространства файлы также оказываются разбросанными по нескольким секторам, что сильно снижает производительность – при обращении к файлу диску приходится читать не один последовательный участок, а несколько произвольно разбросанных.
В NT-версиях Windows, использующих файловую систему NTFS, применяются особые меры для сохранения целостности дискового пространства – но фрагментация все равно происходит. Поэтому вы должны регулярно дефрагментировать ваш жесткий диск, причем регулярность зависит от характера вашей деятельности на компьютере.
Если вы часто устанавливаете и удаляете программы, или вы постоянно создаете, перемещаете или удаляете файлы, то вы должны выполнять дефрагментацию раз в неделю. Если же вы долгое время используете одни и те же приложения, при этом вы не слишком часто перемещаете файлы, то вы можете увеличить промежуток между дефрагментациями до одного месяца.
Если вы достаточно часто выполняете дефрагментацию, то вы не заметите ощутимого прироста в производительности после дефрагментации. Это совершенно нормально. Если же прирост явно ощутим, то вы слишком долго не выполняли дефрагментацию.
Снятие ненужных служб
В Windows XP фоновые программы снижают производительность пользовательских программ и игр. Поскольку для фоновых служб требуется память, то соответственно увеличиваются обращения к файлу подкачки, при этом процессор также не остается в стороне.
Вы можете посмотреть на список фоновых служб с помощью Диспетчера задач (Task Manager), который вызывается нажатием клавиш Ctrl+Alt+Delete. В отличие от Windows 9x, XP различает пользовательские приложения и системные службы. Нажмите на закладку Процессы (Processes) для просмотра системных служб и фоновых приложений. Отсюда вы также можете завершить работу каких-либо процессов, если они зависнут.
Вы сразу же можете узнать некоторые процессы по имени. Если у вас работает фоновая антивирусная программа, вы увидите ее в списке процессов. Здесь вы найдете различные процессы, от конфигурирующих вашу мышь (EM_EXEC.EXE) до оболочки Windows Explorer (EXPLORER.EXE). Если вы привыкли к 9x, то часть процессов будут вам незнакомы: SERVICES.EXE, WINLOGON.EXE, SYSTEM и т.д.

Список служб.


Введение в реестр

Содержание

Что такое реестр Windows XP

Из каких файлов состоит реестр Windows XP ?

Структура reg-файла
Что такое реестр Windows XP ?

Для начала определимся с терминологией. Эта важная часть нужна нам для того, чтобы лучше понимать друг друга. Реестр - это прежде всего основа операционной системы, огромная база данных настроек, хранящихся в папках %SystemRoot%\System32\Config и папке пользовательских профилей (Ntuser.dat). Без реестра Windows XP была бы просто набором программ, неспособных выполнить даже простейшие функции ОС. Все - даже мельчайшие детали конфигурационных данных - упаковано в реестре. Разобраться в реестре - задание не из легких, но это необходимо, если Вы желаете узнать ОС полностью, в большинстве случаев мало кто даже подозревает о существовании реестра. Итак, реестр или системный реестр - это база данных для хранения сведений о конфигурации компьютера и настроек операционной системы. Реестр содержит данные, к которым Windows XP постоянно обращается во время загрузки, работы и её завершения, а именно:

  • профили всех пользователей, то есть их настройки;
  • конфигурация оборудования, установленного в операционной системе. Я не пишу "установленного в компьютере", поскольку "железо" может быть, как говорится, "на борту", но не быть установленным в ОС, например, из-за устаревших драйверов.
  • данные об установленных программах и типах документов, создаваемых каждой программой;
  • свойства папок и значков программ;
  • данные об используемых портах.

Реестр имеет иерархическую древовидную структуру, состоящую из разделов, подразделов и ключей (параметров). Для работы с реестром используется простая и понятная утилита Regedit.
Запретить запуск Regedit В разделе HKCU\SOFTWARE\Microsoft\ Windows\CurrentVerson\Policies\System добавить ключ DisableRegistryTools :dword= 0х00000001. Запуск редактора реестра будет запрещен, однако останется возможность вносить изменения с помощью программного обеспечения сторонних разработчиков и с помощью REG-файла.
Разделы и подразделы - это, грубо говоря, папки в левом окне regedit'а.
Ключ реестра или параметр - это некая переменная, которой присвоено определённое значение, проще говоря - это то, что мы видим в правом окне regedit'а.
Куст (основной раздел, стандартный раздел, в английской документации - улей , от англ. "hive") - это раздел реестра, отображаемый как файл на жестком диске. Куст является набором разделов, подчиненных разделов и параметров и имеет корни на верхнем уровне иерархии реестра. По умолчанию большинство файлов кустов (Default, SAM, Security и System) сохраняются в папке %SystemRoot%\System32\Config.
Папка %SystemRoot%\Profiles содержит профили (настройки) для каждого пользователя компьютера. Поскольку куст представляет собой файл, его можно перемещать из одной системы в другую. Для редактирования этого файла необходимо использовать редактор реестра. Важное замечание : Windows XP в отличие от своих предшественниц не имеет ограничения по размеру реестра.
Реестр Windows XP состоит из следующих основных разделов :

Раздел реестра | Краткое описание
HKEY_CLASSES_ROOT | Это ссылка на раздел HKLM\Software\Classes. Хранящиеся здесь сведения обеспечивают запуск необходимой программы при открытии файла с помощью проводника. Этот раздел содержит связи между приложениями и типами файлов, а также информацию об OLE.
HKEY_CURRENT_USER | Это ссылка на определённый подраздел HKEY_USERS. Настройки соответствуют текущему, активному пользователю, выполнившему вход в систему.
HKEY_LOCAL_MACHINE | Раздел содержит настройки, относящиеся к вашему компьютеру и действительны для всех пользователей. Раздел содержит информацию об аппаратной конфигурации и установленном программном обеспечении.
HKEY_USERS | Этот раздел содержит настройки для всех пользователей компьютера.
HKEY_CURRENT_CONFIG | Это ссылка на: HKLM\SYSTEM\CurrentControlSet\Hardware Profiles\Current. Раздел содержит сведения о настройках оборудования, используемом локальным компьютером при запуске системы, т.е. содержит информацию о текущей конфигурации.
Вышеуказанные основные стандартные разделы вы не сможете удалить или переименовать. Некоторые разделы реестра являются энергозависимыми (volatile) и не хранятся в каком-либо файле. Операционная система создает и управляет этими разделами полностью в памяти, поэтому они являются временными по своей природе. Система создает энергозависимые разделы каждый раз при начальной загрузке. Например, HKLM \HARDWARE - раздел реестра, который хранит информацию по физическим устройствам и назначенным им ресурсам. Назначение ресурса и аппаратное обнаружение происходят каждый раз при загрузке системы, поэтому логично, что эти данные не записываются на диск. Сердце системного реестра - это раздел HKLM \SYSTEM. Наибольший интерес для нас представляют ветви HKCU и HKLM, именно там хранятся настройки, изменения которых способно облагородить нашу операционную систему. Часто для обозначения основных разделов реестра пользуются сокращениями:
Раздел реестра | Аббревиатура
HKEY_CLASSES_ROOT | HKCR
HKEY_CURRENT_USER | HKCU
HKEY_LOCAL_MACHINE | HKLM
HKEY_USERS | HKU
HKEY_CURRENT_CONFIG | HKCC
Раздел HKEY_USERS содержит все активные загруженные параметры пользователя. Он имеет не менее трёх ключей:
  • подраздел DEFAULT, где хранится используемая конфигурация, когда ни один из пользователей ещё не вошёл в компьютер. То есть мы ещё видим приглашение на вход в систему.
  • дополнительный подраздел, который имеет имя в соответствии с security ID> текущего пользователя (описание SID см. ниже). Этот подключ реестра содержит конфигурацию текущего пользователя. Если пользователь вошёл удалённо, данные для конфигурации пользователя сохраняются в системном реестре местного компьютера. Данные из HKEY_USERS\%SID% также появляются в HKCU.
  • дополнительный подраздел, который имеет имя в соответствии с SID текущего пользователя с суффиксом Classes. Этот раздел содержит классы текущего пользователя. Данные в HKEY_USERS\%SID%_Classes также содержатся в HKCR.
В Windows XP конфигурация пользователя по умолчанию (default user profile) не хранится в системном реестре. Она находится на системном диске в файле \Documents and Settings\Default User\Ntuser.dat. Отметим, и это важно, что куст HKCU является ссылкой, линком на определённый подраздел куста HKEY_USERS. Это значит, что все изменения в разделах, подразделах и ключах куста HKCU автоматически тут же отображаются в определённом подразделе HKEY_USERS соответствующем активному пользователю. То есть пользователю, выполнившему процедуру входа.
В каком же именно разделе HKEY_USERS проводятся изменения? Для этого вы должны узнать свой SID. Тогда искомый раздел будет именоваться, например, так : HKEY_USERS\S-1-5-21-117609710-1606980848-839522115-500. Где цифровая часть, вместе с буквой "S", и есть SID.
Идентификатор безопасности (SID, security ID) - структура данных переменной длины, которая идентифицирует пользователя, группу или компьютер. Каждая учётная запись в сети имеет уникальный SID. Внутренние процессы в Windows обращаются к SID для получения учётной записи пользователя или имени группы. Откройте реестр HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList. Выберите SID и посмотрите ProfileImagePath. В конце строки найдете имя пользователя. Увидеть все SID, относящиеся к пользователям компьютера, вы можете раскрыв раздел HKEY_USERS. Но, в большинстве случаев, знать SID не обязательно. Отметим также, что HKLM\SYSTEM\CurrentControlSet это тоже ссылка, линк на один из пронумерованных подразделов с именами HKLM\SYSTEM\ControlSet00n, где n - номер. Подразделы ControlSet00n представляют собой наборы настроек для операционной системы Windows XP. Большинство систем имеет два пронумерованных управляющих набора, оригинал и резервную копию, которая использовалась при последнем успешном старте системы.
Операционная система Windows XP может обслуживать несколько таких наборов. Windows XP обслуживает резервные копии так, чтобы вы могли отменить изменения конфигурации, которые в противном случае могли бы препятствовать загрузке операционной системы. Windows XP хранит последний набор настроек, который был использован успешно, и настройки по умолчанию. Эти значения сохранены в подключе >Select. Имена параметров ключа Select соответственно: Current - текущие настройки и Default - настройки по умолчанию. Также обратите внимание на параметр LastKnownGood расположенный там же. При загрузке Windows XP вы можете выбрать пункт меню "Загрузка последней удачной конфигурации", а действительный номер набора загружаемых настроек будет определён именно этим параметром реестра. Все значения ключей реестра относятся к определённому типу.
Следующая таблица содержит типы данных, используемых в реестре Windows XP:
Тип данных | Краткое описание
REG_BINARY | Двоичные данные. Большинство сведений об аппаратных компонентах хранится в виде двоичных данных и выводится в редакторе реестра в шестнадцатеричном формате.
REG_DWORD | Целые числа размером в 4 байта. Многие параметры служб и драйверов устройств имеют этот тип и отображаются в двоичном, шестнадцатеричном или десятичном форматах.
REG_EXPAND_SZ | Строка данных переменной длины.
REG_MULTI_SZ | Многострочный текст. Этот тип, как правило, имеют списки и другие записи в формате, удобном для чтения. Записи разделяются пробелами, запятыми или другими символами.
REG_SZ | Текстовая строка фиксированной длины.
REG_FULL_ RESOURCE_DESCRIPTOR | Последовательность вложенных массивов, разработанная для хранения списка ресурсов железа или драйверов.
Хранение реестра.
Элементы реестра хранятся в виде атомарной структуры. Реестр разделяется на составные части, называемые ульями (hives), или кустами. Ульи хранятся на диске в виде файлов. Некоторые ульи, такие, как HKLM\HARDWARE, не сохраняются в файлах, а создаются при каждой загрузке, то есть являются изменяемыми (vola-tile). При запуске системы реестр собирается из ульев в единую древовидную структуру с корневыми разделами. Перечислим ульи реестра и их местоположение на диске (для NT старше версии 4.0).
Улей | Расположение
HKLM\SYSTEM | %SystemRoot%\system32\config\system
HKLM\SAM | %SystemRoot%\system32\config\SAM
HKLM\SECURITY | %SystemRoot%\system32\config\SECURITY
HKLM\SOFTWARE | %SystemRoot%\system32\config\software
HKLM\HARDWARE | Изменяемый улей
HKLM\SYSTEM\Clone | Изменяемый улей
HKU\<SID_пользователя> | %USERPROFILE%\ntuser.dat
HKU\<SID пользователя>Classes | %USERPROFILE%\Local Settings\Application Data\Microsoft\Windows\UsrClass.dat
HKU\.DEFAULT | %SystemRoot%\system32\config\default
Кроме этих файлов, есть ряд вспомогательных, со следующими расширениями:
• LOG — журнал транзакций, в котором регистрируются все изменения реестра.
• SAV — копии ульев в том виде, в котором они были после завершения текстовой фазы установки. Реестр является настоящей базой данных, поэтому в нем используется технология восстановления, похожая как в NTFS. Уже упомянутые LOG-файлы содержат журнал транзакций, который хранит все изменения. Благодаря этому реализуется атомарность реестра — то есть в данный момент времени в реестре могут быть либо старые значения, либо новые, даже после сбоя. Как видим, в отличие от NTFS, здесь обеспечивается сохранность не только структуры реестра, но и данных. К тому же, реестр поддерживает такие параметры NTFS, как управление избирательным доступом и аудит событий — система безопасности пронизывает всю NT.

ОС Windows XP и приложения помещают информацию в реестр ОС, что хорошо и плохо одновременно. Хорошо - потому что реестр представляет собой общую память для эффективного хранения информации. Плохо - потому что размеры реестра увеличиваются по мере того, как приложения и система сохраняют в системе все новую информацию. По мере этого процесса в реестре появляется огромное количество мусора, который необходимо и нелегко удалить.

Из каких файлов состоит реестр Windows XP ?

Итак, повторим, куст — это раздел реестра, отображаемый как файл на жестком диске. Имя используется для указания на ветвящуюся структуру.

Однако не вся информация из некоторых подразделов кустов хранится на диске, но об этом немного ниже.

А сейчас — вот они, файлы реестра Windows XP:
(имени файла соответствует куст реестра Windows XP)

По умолчанию почти все файлы кустов: Default, SAM, Security, Software и System, — сохраняются в папке %SystemRoot%\System32\Config.

Папка %SystemRoot%\Profiles содержит настройки для каждого пользователя компьютера.

Если есть сомнения, то точный список файлов реестра Windows XP можно посмотреть здесь: HKLM\System \CotnrolSet\Control\HiveList\.

При начальной загрузке к этому разделу обращается Configuration Manager, чтобы проинициализировать все основные разделы реестра.

Имя файла | Соответствующий раздел реестра Windows XP
SAM | HKEY_LOCAL_MACHINE\SAM
SECURITY | HKEY_LOCAL_MACHINE\Security
Software | HKEY_LOCAL_MACHINE\Software
System | HKEY_LOCAL_MACHINE\System HKEY_CURRENT_CONFIG
Default | HKEY_USERS\.DEFAULT
Файлы Ntuser.dat | HKEY_CURRENT_USER (эти файлы хранятся в С:\Documents and Settings\%UserName%) Содержат конфигурацию для конкретного пользователя.

Структура reg-файла

Знание реестра Windows XP будет неполным без умения написать reg-файл.

REG-файл — это файл, имеющий определенную структуру и содержащий информацию, которая импортируется в реестр.

Для чего нужно это знать и уметь? Например, если была заблокирована работа с редактором реестра, а это можно сделать с помощью изменения ключей реестра, то наиболее легким способом исправить установки в реестре будет создание и импортирование reg-файла.

Первая строка reg-файла для Windows XP обязательно должна быть такой:
Windows Registry Editor Version 5.00

однако REGEDIT от Windows XP понимает и такое:
REGEDIT4

сохраняя тем самым совместимость снизу вверх. Обратите внимание на регистр букв. Кроме этого, в первой строке ничего быть не должно. После текста обязательно должна быть пустая строка.

Затем указывается раздел реестра, в котором надо прописать или изменить какие-то параметры. Название раздела должно быть заключено в квадратные скобки. Затем ниже прописываются параметры и значения по одному параметру в строке. Когда вы закончили описание параметров и их значений, то оставьте пустую строку и либо закончите файл, либо, если нужно, начинайте описание для следующего раздела.

Вот пример reg-файла:

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\ SYSTEM\ Setup]
"SetupType"=dword:0
"SystemSetupInProgress"=dword:0
"CmdLine"=""
"SystemPrefix"=hex:cc,1b,00,00,00,40,3d,68
"SystemPartition"="\ \ Device\ \ HarddiskVo-lume1"
"OsLoaderPath"="\ \ "uniqueid"="C:\ \ WINDOWS\ \ LPM"
[HKEY_LOCAL_MACHINE\ SYSTEM\ Setup\ AllowStart]
{...описание параметров...}
Последнюю строку в файле сделайте пустой.

Как видим, строковые параметры заключаются в кавычки. Перед числами ставятся указатели на их тип. Например, dword — указывает на тип этого параметра, буквы должны быть обязательно маленькие. После двоеточия следует значение из восьми цифр в шестнадцатеричном формате. Однако большинство параметров dword имеют значение либо 0, либо 1. Пробелы в строке не допускаются.

В реестре существуют параметры "По умолчанию" (Default). Чтобы присвоить им какое-то значение через REG-файл, надо добавить такую строку:
@="какое-либо значение"
Regedit имеет некоторое множество опций командной строки, чтобы автоматизировать его использование в пакетных файлах. Ниже указаны некоторые из вариантов.

regedit.exe [options] [filename]
filename — импортируемый в реестр.reg файл
/s — подавлять запрос на подтверждение при импорте файла
/e — экспорт раздела реестра в файл.

Пример:
regedit /e file.reg HKEY_CURRENT_USER\ Software\ Microsoft
Довольно убого, не так ли? Но не все так плохо. Наберите в командной строке:
REG /?
и изучайте "Программу редактирования системного реестра из командной строки, версия 3.0". Я думаю, она вам понравится.

Удаление разделов и ключей реестра при помощи .reg-файла

Вы можете удалять разделы реестра и значения в разделах, не используя REGEDIT. Для удаления раздела используйте тот же самый формат reg-файла, только перед наименованием раздела поставьте знак "минус" ("-"). Например:
REGEDIT5
[-HKEY_LOCAL_MACHINE\ SYSTEM\ Test]
Этот же формат используйте для удаления отдельных параметров в выбранных разделах, поставив знак "минус" ("-") после знака "равно" ("="):
REGEDIT5
[HKEY_LOCAL_MACHINE\ SYSTEM\ Test]
"TestValue" =-
Помните, что прежде, чем проводить какие-либо манипуляции с реестром вручную, рекомендуется сделать резервную копию.


Горячие клавиши

Общие сведения о сочетаниях клавиш Windows
При работе с Windows используйте сочетания клавиш вместо мыши. Используя сочетания клавиш можно открывать, закрывать, перемещаться по меню «Пуск», рабочему столу, различным меню и диалоговым окнам, а также по веб-страницам. Использование сочетаний клавиш облегчит взаимодействие с компьютером.
Щелкните [image] для развертывания.
Вы можете назначить горячие клавиши для любой программы. Откройте Свойства значка и в "Быстрый вызов" назначить сочетание клавиш для вызова программы.

Сочетания клавиш

Нажмите | Действие
CTRL + C | Копирование
CTRL + X | Вырезание
CTRL + V | Вставка
CTRL + Z | Отмена
DELETE | Удаление
SHIFT + DELETE | Удаление элемента без помещения его в корзину и возможности восстановления
Удерживание нажатой клавиши CTRL при перетаскивании элемента | Копирование выбранного элемента
Удерживание нажатыми клавиш CTRL + SHIFT при перетаскивании элемента | Создание ярлыка для выбранного элемента
F2 | Переименование выбранного элемента
CTRL + СТРЕЛКА ВПРАВО | Перемещение курсора в начало следующего слова
CTRL + СТРЕЛКА ВЛЕВО | Перемещение курсора в начало предыдущего слова
CTRL + СТРЕЛКА ВНИЗ | Перемещение курсора в начало следующего абзаца
CTRL + СТРЕЛКА ВВЕРХ | Перемещение курсора в начало предыдущего абзаца
CTRL + SHIFT с любой стрелкой | Выделение абзаца
SHIFT с любой стрелкой | Выделите нескольких элементов в окне или на рабочем столе, а также выделение текста в документе
CTRL + A | Выделение всего
CTRL + ALT + DELETE | Открывает "Диспетчер задач"
F3 | Поиск файла или папки
PRINT SCREEN | Помещает в буфер изображение Вашего экрана
ALT + PRINT SCREEN | Помещает в буфер изображение активного окна
ALT + ENTER | Просмотр свойств выбранного объекта
ALT + F4 | Закрытие текущего элемента или выход из активной программы
ALT + ПРОБЕЛ | Отображение системного меню активного окна
ALT + ПРОБЕЛ + Й | Открывает окно "Свойства: Командная строка"
CTRL + F4 | Закрытие активного документа в программах, допускающих одновременное открытие нескольких документов
ALT + TAB | Переход от одного открытого элемента к другому
ALT + ESC | Переключение между элементами в том порядке, в котором они были открыты
F6 | Переключение между элементами экрана в окне или на рабочем столе
F4 | Отображение списка строки адреса в окне «Mой компьютер» или в окне проводника Windows
SHIFT+F10 | Открытие контекстного меню для выделенного элемента
CTRL + ESC | Открытие меню Пуск
ALT + подчеркнутая буква в названии меню | Отображение соответствующего меню
Подчеркнутая буква в имени команды открытого меню | Выполнение соответствующей команды
F10 | Активизация строки меню текущей программы
СТРЕЛКА ВПРАВО | Открытие следующего меню справа или открытие подменю
СТРЕЛКА ВЛЕВО | Открытие следующего меню слева или закрытие подменю
F5 | Обновление активного окна
BACKSPACE | Просмотр папки на уровень выше в окне «Мой компьютер» или в окне проводника Windows
ESC | Отмена текущего задания
SHIFT при вставка компакт-диска в дисковод | Предотвращает автоматическое воспроизведение компакт-диска

Сочетания клавиш диалогового окна

Нажмите | Действие
CTRL+TAB | Переход вперед по вкладкам
CTRL+SHIFT+TAB | Переход назад по вкладкам
TAB | Переход вперед по параметрам
SHIFT + TAB | Переход назад по параметрам
ALT + подчеркнутая буква | Выполнение соответствующей команды или выбор соответствующего параметра
ENTER | Выполнение команды активного режима или кнопки
ПРОБЕЛ | Установка или снятие флажка
Клавиши со стрелками | Выбор кнопки, если активна группа кнопок
F1 | Вывод справки
F4 | Отображение элементов активного списка
BACKSPACE | Открытие папки на одном уровне вверх от папки, выделенной в окне Сохранить как или Открыть

Сочетания клавиш клавиатуры Майкрософт. Следующие сочетания клавиш можно использовать, если у вас имеется клавиатура Microsoft или совместимая с ней клавиатура с клавишей Windows ( [image] ) и клавиша «Kонтекст» ( [image] )

Нажмите | Действие
 | Открытие или свертывание меню Пуск
+ BREAK | Открытие диалогового окна Свойства системы
+ D | Свертывание всех окон
+ М | Свертывание всех окон
+ SHIFT + M | Восстановление свернутых окон
+ Е | Открытие окна «Мой компьютер».
+ F | Поиск файла или папки
CTRL+ [image] + F | Поиск компьютеров
+ F1 | Вывод справки Windows
+ L | Блокировка компьютера при подключении к домену или переключение пользователей, если компьютер не подключен к домену
+ R | Открытие диалогового окна Выполнить
 | Открытие контекстного меню для выделенного элемента
+ U | Открытие Диспетчера служебных программ

Сочетания клавиш специальных возможностей

Нажмите | Действие
Удерживать нажатой правую клавишу SHIFT восемь секунд | Включение и отключение фильтрации ввода
Левые клавиши ALT и SHIFT + клавиша PRINT SCREEN | Включение и отключение высокой контрастности
Левые клавиши ALT и SHIFT + клавиша NUM LOCK | Включение и отключение управления указателем с клавиатуры
Нажмите клавишу SHIFT пять раз | Включение и отключение залипания клавиш
Удерживайте нажатой клавишу NUM LOCK пять секунд | Включение и отключение озвучивания переключения
+U | Открытие диалогового окна «Диспетчер служебных программ»

Сочетания клавиш проводника Windows

Нажмите | Действие
+ E | Вызывает Проводник с открытием папки "Мой компьютер"
END | Переход к нижней позиции активного окна
HOME | Переход к верхней позиции активного окна
NUM LOCK + * (звездочка) на цифровой клавиатуре | Отображение всех папок, вложенных в выбранную папку
NUM LOCK + знак плюса (+) на цифровой клавиатуре | Отображение содержимого выбранной папки
NUM LOCK + знак минуса (-) на цифровой клавиатуре | Свертывание выделенной папки
СТРЕЛКА ВЛЕВО | Свертывание выделенного элемента, если он развернут, или выбор родительской папки
СТРЕЛКА ВПРАВО | Отображение выделенного элемента, если он свернут, или выделение первой подпапки

Примечания

  • Необходимо сопоставить пароль с учетной записью пользователя для защиты от несанкционированного доступа. Если пароль не соответствует вашей учетной записи пользователя, нажатие [image] + L не предотвратит попытки доступа других пользователей к сведениям об учетной записи.
  • Некоторые сочетания клавиш могут не работать, если в компоненте «Специальные возможности» включен режим залипания клавиш.


Группировка окон

Группировка открытых окон

Как изменить число открытых окон программы, при достижении которого на панели задач включается режим их группировки в одну кнопку?

Режим группирования нескольких открытых окон в одну кнопку - одно из многочисленных не сразу заметных, но очень удобных нововведений. Смысл его заключается в том, что при достижении числа открытых окон определенного значения они группируются и отображаются на панели задач в виде одной кнопки, щелчок по которой вызывает ниспадающее меню со всеми открытыми окнами этой программы. Очень удобная функция, например, при прогулках по Сети с помощью Internet Explorer - уже первый десяток открытых страниц без использования режима группировки донельзя захламляет панель задач. Для изменения числа открытых окон программы, которое приводит к включению режима их группировки, нужно запустить Regedit, найти в реестре ключ
HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ CurrentVersion \ Explorer \ Advanced
и изменить параметр TaskbarGroupSize. Если такого параметра нет, то нужно его создать (в виде DWORD) и настроить: щелкаем по параметру правой кнопкой мыши и выбираем в контекстном меню пункт Modify (установка значения 5 заставит Windows включать режим группировки при пяти открытых однотипных окнах) Как включить этот режим группировки? Просто щелкаем правой кнопкой по панели задач, выбираем пункт Свойства и на вкладке Панель задач ставим галку напротив "Сгруппировать похожие кнопки..."


Дисковые утилиты

Мой компьютер -Выбранный диск- Свойства- Сервис

Запуск дисковых утилит. Можно прописать туда свои программы вместо установленных по умолчанию. Раздел:
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer. В разделе находятся некоторые подразделы, отвечающие за дисковые утилиты. Если их нет, создайте сами и в значениях по умолчанию задайте путь к вашему приложению.
Очистка диска подраздел CleanupPath
По умолчанию используется
NT/2000/XP: "%SystemRoot%\system32\cleanmgr.exe /D %c"

Проверка диска - подраздел ChkDskPath
По умолчанию используется
NT/2000/XP: "%SystemRoot%\system32\chkdsk.exe %c:"

Дефрагментация диска - подраздел DefragPath
По умолчанию используется
NT/2000/XP: "%SystemRoot%\system32\dfrg.msc %c:"


Диспетчер задач

Диспетчер задач (Task Manager) (CTRL+ALT+DEL) позволяет не только наблюдать за потреблением памяти и снимать зависшие приложения. Перейдите в закладку Процессы (Processes) и нажмите правой клавишей на любом процессе.
В появившемся меню будет опция Приоритет (Set Priority). Благодаря ей вы можете выставить приоритет на получение процессорного времени практически у всех приложений и служб. К примеру, если вы работаете в Photoshop и вдруг решите проверить почту или покопаться в Интернете, вы можете вручную распределить вычислительную мощность вашего процессора. Или если вы запустили достаточно "тяжелое" приложение типа записи CD, компиляцию кода в Visual C++ или рендеринг объектов в 3D Studio Max, вы можете установить этим процессам высокий приоритет, чтобы другие приложения не мешали их работе.
Уберите "скрытые" компоненты Windows. К сожалению, Microsoft не разрешает вам убрать всякую чушь типа Windows Messenger обычным способом. Messenger устанавливается по умолчанию и он не появляется в диалоге Установка и удаление программ (Add/Remove Program) в Панели управления (Control Panel).
Вы можете обмануть Microsoft, отредактировав файл SYSOC.INF в каталоге C:\WINDOWS\INF (или где у вас там располагается Windows XP) с помощью Блокнота (Notepad).
Найдите там заголовок [Components], за ним вы увидите кучу параметров для различных приложений Windows. Некоторые из них содержат слово "hide". Среди них Windows Messenger, Terminal Server и другие, которые установлены на вашей Windows XP, но они убраны из диалога Установка и удаление (Add/Remove).
К примеру, для удаления Windows Messenger уберите hide из строчки msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,hide,7 после чего она будет выглядеть следующим образом msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,7
Запишите файл после редактирования и перейдите в диалог "Установки и удаления программ" (Add/Remove Program). Нажмите там Установка компонентов (Windows Components), и вы увидите в списке Windows Messenger, уберите от него галочку и нажмите Далее (Next) чтобы завершить удаление.
Вы можете свободно убрать hide во всех местах SYSOC.INF, а затем убрать все ненужное с вашей системы.
Включайте DMA на всех ATAPI дисках. По умолчанию вторые диски (slave) на ATAPI интерфейсах часто устанавливаются в режим обмена PIO, даже если они способны на работу в более эффективном режиме UltraATA (или DMA). Режим PIO заметно снижает производительность записывающих CD-ROM приводов, проигрывание DVD и другие дисковые функции. Кроме того, режим DMA намного меньше загружает процессор, нежели PIO.
Вы можете устранить данный недостаток через Диспетчер устройств (Device Manager). Откройте диалог Управление компьютером (System Properties) (правой клавишей выбираем Свойства (Properties) на значке Мой компьютер (My Computer) и выберите закладку Оборудование (Hardware). Далее нажмите клавишу Диспетчер устройств (Device Manager). Откройте плюсик слева от IDE ATA/ATAPI контроллеры (IDE/ATAPI controllers), выберите Первичный канал IDE (Primary IDE channel) и нажмите Свойства (Properties). Далее выберите закладку Дополнительные параметры (Advanced Settings). У каждого устройства установите режим передачи в DMA, если доступно (DMA if possible). Не опасайтесь, если устройство не поддерживает DMA, оно будет работать в PIO. Выполните то же самое и для Вторичного канала IDE (Secondary IDE channel)


Дополнение по сетям

Передающая среда

Передающая среда— это то понятие, на котором основывается весь процесс передачи данных, и обойти этот пункт вниманием просто невозможно:-). Ведь процесс передачи данных заключается в пространственном перемещении энергии, несущей полезный сигнал. К примеру, когда вы говорите с кем-то, то передаете энергию от голосовых связок частицам воздуха, и эта энергия распространяется от одного слоя воздуха к другому в виде волны, пока не достигает барабанной перепонки уха собеседника. Там она превращается в колебания, которые распознаются человеческим мозгом как звуки и слова. В рассмотренном примере передающей средой выступал газ, а энергией— кинетическая энергия движения его частиц. Подобным же образом действуют и интересующие нас системы передачи данных, только используют они электромагнитные волны, а распознаются полученные сигналы электронными устройствами.

Итак, медный кабель. Медь была избрана для передачи данных как металл с оптимальным соотношением сопротивления и стоимости применения. Тут стоит пояснить, почему так важен показатель сопротивления. Из школы нам известно, что при прохождении тока через проводник часть электрической энергии превращается в тепловую. Чем большее сопротивление имеет металл, тем больше тепла выделяется и тем быстрее затухает сигнал, который мы передаем. То есть наш полезный сигнал может весь превратиться в тепло, согревающее окружающее пространство, но никак не способствовать получению информации. На пассивном уровне противостоять переходу электрических сигналов в тепло можно лишь избирая в качестве передающей среды металл с как можно меньшим сопротивлением. По этому показателю нам лучше всего подойдет серебро или золото. Но лишь представьте себе сотни тысяч километров золотых кабелей, и вы поймете, почему так важен фактор цены :-). Именно исходя из этих соображений, в качестве среды передачи и была выбрана медь.

Сейчас распространено две разновидности медных кабелей: коаксиальный и витая пара. Их целевое использование предопределило необходимость минимизации возникающих в них помех. Чтобы понять механизм возникновения помех, давайте представим два параллельных провода, близко расположенных друг к другу. Если в одном из них начнет проходить высокочастотный электрический сигнал, то он будет излучать электромагнитные волны, которые индуцируют во втором проводнике электрический ток. Если второй проводник используется для передачи информации, то она может быть при этом существенно искажена. Поэтому так много усилий было приложено конструкторами для преодоления этого негативного эффекта.

Коаксиальный кабель (от латинского co— «совместно» и axis— «ось») представляет собой центральный провод, находящийся в толстой и равномерной изоляционной оболочке. Вокруг изоляции кабеля располагается сплошной цилиндрический экран, который представляет собой плетеную оболочку или фольгу, либо их комбинацию. Этот экран используется как второй контакт. Сверху кабель покрывается еще одним слоем изоляции. Такая конструкция позволяет минимизировать распространение электромагнитного излучения от кабеля извне, а также уменьшить наводки на сам провод.

Существует несколько разновидностей коаксиала. Во-первых, это, так называемый, «толстый» кабель RG-8 или RG-11 (RG — сокращение Radio Grade, т.е волновод), на базе которого на заре развития локальных сетей создавались сети Ethernet. Но на сегодняшний день его почти вытеснила другая разновидность — «тонкий» коаксиальный кабель RG-58, который дешевле, а сети на его основе ничуть не уступают по производительности вышеупомянутым «толстым» собратьям.

Витая пара (twisted pair) представляет собой два медных провода в изоляции, скрученных между собой. Этим достигается уменьшение электромагнитного излучения, так как электромагнитные поля, возникающие вокруг каждого из проводников, индуцируют одинаковые по амплитуде сигналы, находящиеся в противофазе. Таким образом, в идеальном варианте излучение пары равно нулю.

Обычно в кабеле, используемом для передачи данных в сети, объединяется несколько витых пар. Так, в кабеле UTP (Unshielded Twisted Pair — незащищенная витая пара) пятой категории, который является одним из наиболее широко используемых при прокладке сетей, их четыре. Для исключения взаимных наводок соседних пар их скручивают с различным шагом.

Кабель «витая пара» может быть как экранированным (ScTP — Screened Twisted Pair), так и неэкранированным (UTP — Unscreened Twisted Pair). Именно последние чаще всего и используются в сетях. Но если кабелю предстоит проходить неподалеку от сильных источников электромагнитного излучения (электродвигатель, кондиционер, мощное передающее оборудование) или параллельно с кабелем питания, то имеет смысл воспользоваться экранированным кабелем, например фольгированным FTP (Foiled Twisted Pair). Еще более радикальным и дорогим решением является использование кабелей с индивидуальным экранированием каждой витой пары — STP (Shielded Twisted Pair).

Оптоволоконный кабель представляет собой тонкое стеклянное волокно, покрытое слоем с меньшим коэффициентом преломления и заключенное в пластмассовую оболочку. Свет, попадая в один из концов оптоволоконного кабеля, практически беспрепятственно проходит через весь кабель, отражаясь от границы раздела сред с разными коэффициентами преломления. При этом происходит так называемое полное внутреннее отражение луча. Лучше всего меня поймет тот, кто хоть раз, плавая в водоеме, наблюдал, каким получается отражение от поверхности, если смотреть на нее из-под воды под маленьким углом.

Обычно оптоволоконный кабель состоит из нескольких волокон, расположенных по кругу или в одной плоскости. В одной из возможных схем отдельные оптические волокна расположены симметрично по кругу, в центре кабеля проходит стальной или кевларовый трос. Снаружи кабель защищен стальной оплеткой и эластическим покрытием, а внутренняя полость заполняется гидрофобным гелем.

Различают два вида оптоволокна: одномодовое и многомодовое. Одномодовое волокно от многомодового конструктивно отличается лишь намного меньшим диаметром. Это позволяет уменьшить так называемую модовую дисперсию и соответственно увеличить пропускную способность и расстояние передачи. Однако одномодовое оптоволокно гораздо дороже и менее удобно при прокладке (только представьте себе, насколько трудно совместить ось одномодового волокна толщиной 8–9 микрометров с осью приемника или передатчика).

Кроме модовой дисперсии, ограничения на оптоволокно накладываются материальной дисперсией, вызванной разным углом отражения света различных длин волн. Так, длинноволновые красные лучи отклоняются меньше, чем коротковолновые синие. Применяемые же для передачи данных по оптоволокну источники света не способны излучать свет конкретной длины, а лишь выдают определенный диапазон волн. Даже полупроводниковый лазер излучает свет в интервале длин волн в несколько нанометров, более же дешевые светодиоды и вовсе имеют полосу шириной в 30–40 нм.

Еще одним негативным фактором оптоволокна является неидеальная поверхность волокна и загрязнение его различными примесями, что соответственно приводит к искажению световых импульсов и поглощению света.

Оптоволокно имеет ряд преимуществ перед обычным медным кабелем: оно не восприимчиво к электромагнитным помехам и само не является их источником. Теоретически подсчитано, что пропускная способность оптоволокна может достигать 100 Тбит/сек, а это делает данную технологию весьма перспективной.

Но, к сожалению, такой тип кабеля не лишен и ряда недостатков. Первым из них является его дороговизна, которая отобьет желание у любого пользователя «тянуть оптоволокно» для домашней сети. Далее следует отметить, что немало хлопот вас ждет в процессе прокладки и эксплуатации. Концы оптоволокна во время установки необходимо отполировать при помощи специального оборудования. Если же достаточно хрупкие оптоволоконные кабели будут сломаны в результате изгиба, то место поломки будет определить чрезвычайно трудно, а устранять ее придется опять-таки с помощью специального оборудования. Небольшой комплект последнего стоит порядка одного-двух новых компьютеров.

Учитывая все преимущества и недостатки оптоволокна, можно сказать, что такой тип кабеля является идеальным вариантом для соединения двух локальных сетей, находящихся в разных зданиях. Рекомендуется он для решений, требующих повышенной информационной безопасности и конфиденциальности, так как сделать «отвод» от оптоволокна практически невозможно. Применяется оно и в некоторых сетевых технологиях, требующих высокой скорости передачи данных. К примеру, в 10 Gigabit Ethernet без оптоволокна уже просто не обойтись.

По радио

В наше время все большее значение приобретают системы беспроводной радиосвязи. Согласно концепции «беспроводного будущего», в скором времени они захватят значительную долю рынка коммуникаций, отобрав ее у решений на базе проводников. По оценкам аналитиков, на 2003 год оборот рынка беспроводных сетей составит около $2 млрд.

Так давайте разберемся, чем же так привлекает человечество радиоволна в качестве носителя цифровой информации. Первая и, наверно, главная причина — это мобильность. Та самая настоящая мобильность, которая наконец дала человеку возможность оторваться от кабеля и жить самостоятельной информационной жизнью. И уже на втором месте находятся другие преимущества. Такие как гибкость и быстрое развертывание систем, построенных на основе радиосвязи. А также организация связи в ранее недоступных для этого местах, таких как малозаселенная местность, океан, космос. В некоторых случаях добавляется еще и такой фактор, как дешевизна, тоже связанный с мобильностью. Ведь зачастую куда дешевле наладить радиосвязь между двумя домами, чем прокладывать весьма дорогостоящий кабель. А в условиях города радиосвязь часто просто незаменима.

Но у радиометода существует и ряд существенных недостатков. Первым из них является очень маленькая скорость, особенно в сравнении с высокоскоростными кабельными соединениями. Конечно же, эта проблема легко решается увеличением используемой полосы частот, но тут проявляется еще один недостаток — чрезвычайно высокая конкуренция за радиочастоты со всеми вытекающими отсюда последствиями.

Существует множество вариантов, которые позволяют в полной мере насладиться всеми преимуществами беспроводного обмена данными. Пожалуй, самым экзотическим из них является использование маломощных радиопередатчиков для обмена данными между устройствами, находящимися в одном системном блоке. На таких небольших расстояниях и при широкополосной передаче достигается большая скорость, достаточная для большинства компонентов современного компьютера. А вот зачем это необходимо нам, видимо, объяснят попозже :-). Также радиосвязь можно использовать на немного большие расстояния, такие, например, как от вашего системного блока до принтера, клавиатуры, мыши или мобильного телефона, что куда более актуально.

Но, пожалуй, наибольший интерес, сообразно теме статьи, представляют локальные сети, построенные на основе радиотехнологий (того же RadioEthernet, к примеру). В таких сетях уже используются более мощные передатчики, работающие в основном на частотах, свободных от лицензирования. При этом они также обеспечивают вполне приличную скорость, исчисляемую десятками мегабит в секунду.

Также радиосвязь служит для обеспечения дальней связи, начиная от нескольких тысяч метров и кончая десятками километров. Но и этот вариант сейчас скорее экзотика и применяется чаще всего для систем типа точка-точка или точка-многоточка. Это технологии, которые работают на максимальном расстоянии без использования ретрансляторов.

Так как наша планета, грубо говоря, круглая, а радиоволны коротковолнового диапазона не обладают способностью огибать поверхность, то существует предел, которым определяется максимальное расстояние для радиосвязи. Для того чтобы обойти это ограничение, можно использовать ретрансляторные вышки или более высокотехнологичное достижение науки — ретрансляционные спутники. Наиболее удобными для этих целей являются спутники с геостационарной орбитой, то есть неподвижно висящие над одной точкой земной поверхности. Для этого они должны по законам физики находиться на расстоянии 35785 км от Земли, откуда открывается чудесный вид :-) и большие возможности по увеличению площади приема сигнала. Сигнал, посланный с Земли, принимается ретранслятором спутника, усиливается и отправляется назад под другим углом.

Но существует одна проблема — количество геостационарных спутников ограничено, ведь чтобы не создавать взаимных помех они должны находиться на определенном расстоянии друг от друга (это обычно угловое расстояние в 4–8 градусов). Поэтому в системах радиосвязи также широко используются низкоорбитальные спутники. Такой спутник облетает Землю приблизительно за 1.5 часа, и естественно, ни о какой постоянной передаче данных с помощью одного такого спутника и речи быть не может.

Для обеспечения постоянной связи используются целые комплексы низкоорбитальных спутников, которые имеют довольно сложную систему пространственной навигации и взаимодействия. В таких системах данные передаются через тот спутник, который в данный момент находится в наиболее подходящем положении, затем очередь переходит к следующему и т.д. Если же необходимо передать информацию, к примеру, на другую сторону Земли, то происходит обмен данными между спутниками. Тогда сеть спутников начинает напоминать Интернет :-), где существует своя система адресации и маршрутизации.

Для охвата всей земной поверхности сетью низкоорбитальных спутников их понадобиться от тридцати до семидесяти штук (в зависимости от высоты), и тогда над каждой точкой земного шара будет постоянно «виден» хотя бы один из них. Удовольствие, конечно, не из дешевых, и именно поэтому спутниковая связь все еще остается такой дорогой. И это несмотря на большое количество ретрансляторов, находящихся на каждом из спутников, и разделяемость ресурсов каждого из ретрансляторов (сейчас любой спутников может одновременно вести несколько тысяч сеансов связи).

Существуют другие, более дешевые способы расширения зоны покрытия. К примеру, использование микроволнового излучения, знакомого нам по сотовой связи и по ретрансляционным вышкам, возвышающимся вдоль дорог и в городах. Именно его иногда применяют для передачи данных, хотя системы, созданные на его основе, довольно редкое явление. Более известной любому из нас является передача цифровых данных с использованием систем сотовой телефонной связи. В последнее время данная услуга все чаще стоит в отдельной графе телефонных счетов.

Недостатком решений на микроволнах является обязательное условие прямой видимости и необходимость установки множества вышек с весьма дорогим оборудованием.

В процессе борьбы за частотный диапазон появилось еще несколько эффективных решений. Одно из них — использование для передачи информации инфракрасного излучения (наподобие того, как устроены пульты дистанционного управления телевизора). Чаще всего такой подход применяется для создания сети между компьютерами в одной комнате, или обмена данными компьютера с беспроводными устройствами (например, клавиатурой или мышью). При этом должно соблюдаться условие строгой взаимной ориентации приемника и передатчика.

Второе решение — использование лазера. И если раньше лазер у нас упоминался в связи с необходимостью передачи данных через оптоволокно, то сегодня он применяется для передачи данных через открытое пространство. Стоит ли говорить, что взаимное положение приемника и передатчика должно быть весьма строгим. Но результат кропотливой установки и настройки вполне оправдывается скоростью передачи в сотни мегабит в секунду при максимуме расстояния порядка трех километров. Правда, если данная технология применяется на улице, то достаточно пойти небольшому дождику, и вы сможете оценить все недостатки такого решения, а именно — полную неработоспособность системы в плохих погодных условиях.


Защита компьютера
Для обеспечения безопасности компьютера необходимо организовать защиту отдельных файлов и папок и принять меры к физической защите самого компьютера. Если на компьютере имеются конфиденциальные сведения, они должны храниться в безопасном месте.

Другими способами защиты компьютера являются его блокировка на время отсутствия пользователя на рабочем месте и настройка экранной заставки, защищенной паролем. Нажав одновременно клавиши CTRL, ALT и DEL, а затем кнопку Блокировка, можно предотвратить несанкционированный доступ пользователей к компьютеру. Разблокировать его сможет только владелец и члены группы администраторов компьютера. (Для разблокирования компьютера нужно нажать одновременно клавиши CTRL, ALT и DEL, ввести пароль, а затем нажать кнопку ОК.) Можно также настроить заставку таким образом, чтобы она открывалась и автоматически блокировала компьютер после того, как он простаивал в течение определенного времени.

Защита файлов с помощью пароля экранной заставки

  1. На панели управления откройте компонент Экран.
  2. На вкладке Заставка в списке Заставка выберите нужную экранную заставку.
  3. Установите флажок Защита паролем.

    Если включено быстрое переключение пользователей, установите флажок При продолжении открыть окно приветствия.

Примечания

  • Чтобы открыть компонент «Экран», нажмите кнопку Пуск, выберите команду Панель управления, щелкните категорию Оформление и темы, затем щелкните значок Экран.
  • Если установить флажок Защита паролем, то при активизации экранной заставки компьютер будет блокироваться. Чтобы разблокировать компьютер и продолжить работу, необходимо ввести пароль.
  • Пароль заставки совпадает с паролем пользователя, вошедшего в систему на данном компьютере. Если при входе в систему пароль не использовался, пароль заставки установить нельзя.

    Экранная заставка

    Изменить заставку на входе в систему

    Отменить экран заставки при загрузке

    Защита паролем экранной заставки

Экранная заставка

Изменить заставку на входе в систему

Выбираем Пуск/Выполнить, набираем "regedt32" и нажимаем "OK". Находим в системном реестре следующий ключ: HKEY_USERS\DEFAULT\ Control Panel\Desktop. И меняем строковый параметр "SCRNSAVE.EXE" с "logon.scr" на путь и имя к той заставке, которая вам больше по вкусу. Главное, чтобы путь был указан правильно, а если файл заставки находится в каталоге %SystemRoot%\System32, то путь можно вообще не указывать, достаточно одного имени файла. (сам еще не пробовал)

Наверх
Отменить экран заставки при загрузке

Данное действие поможет, правда совсем немного уменьшить время загрузки вашей ОС. Не забывайте только, что в результате вы также не будете видеть и всякие сообщения системы о процессе загрузки (chkdsk, convert ... ), хотя, если проблем у вас нет, можно проделывать это смело. Все, что нам нужно, это отредактировать файл BOOT.INI, добавив в него параметр "/noguiboot" сразу после "/fastdetect".

После рестарта системы заставка возникать больше не будет, и на медленных компьютерах это может сэкономить вам несколько секунд. Соответственно, чтобы вернуть все на свои места, надо в том же BOOT.INI удалить вышеуказанный параметр. Или в разделе
HKCU\Software\Policies\Microsoft\Windows\Control Panel\Desktop присвойте параметру "ScreenSaveActive" =dword:0

Наверх
Защита паролем экранной заставки

Настроить политику паролей для экранных заставок. В разделе
HKCU\Software\Policies\Microsoft\Windows\Control Panel\Desktop параметр "ScreenSaverIsSecure"=dword:?

Состояние параметров:

  • Параметр ScreenSaverIsSecure отсутствует в реестре. Обычное поведение экранной заставки - пароли можно изменять, применять или отменять их использование через окно "защита паролем".
  • Параметр хранит значение "0". Использование паролей к заставкам недоступно.
  • Параметр хранит значение "1", пароли к экранным заставкам принудительно включены.

Описанная выше политика "Отменить экран заставки" имеет приоритет над этой политикой. Если политика "Отменить экран заставки" находится в активном состоянии, система игнорирует состояние политики "Защита паролем экранной заставки".

Наверх


Меню Пуск

Инсталляция Win XP

Содержание

Как установить XP?

Автономная установка

Создание мультизагрузочной системы

Как выбрать нужную версию ядра и HAL при инсталляции?

Windows Components

Стоит ли переходить с FAT32 на NTFS?

Что такое NTFS, и как она работает?

Что нового в файловой системе NTFS5, и в чем её отличия от NTFS4?

Что такое кластер, и какого размера он должен быть?

Как уменьшить занимаемый объем установленной XP?

Можно ли конвертировать диск FAT32 в NTFS без потеpи данных?

Установка SP1 , SP2 и активация Windows

Различия систем XP и Home
Как установить XP?

Есть несколько способов. Первое, ваш CD должен быть загрузочным. Чтобы загрузиться с него надо в BIOS параметр "Boot sequence" установить равным CD-ROM, вставить CD и перезагрузиться. После старта компьютера запустится программа установки. Дальше - следовать инструкции.
Это метод загрузки прямо в программу - установщик, имея только CD.
Второе, можно загрузиться с DOS системной дискеты с драйвером CD-ROM и запустить программу "winnt.exe" в директории i386 на диске с дистрибутивом. Примечание: если ваш винчестер подключен к внешнему контроллеру (SCSI или IDE), не забудьте скачать новый (XP или W2k) драйвер для него и скинуть его на дискету. Он понадобится, если программа инсталляции не сможет правильно определить и установить устройство. В этом случае необходимо нажать на F6, когда будет производиться поиск таких устройств. И, наконец, можно из под W9x, NT4 или W2k запустить программу "setup.exe" из корневого каталога СD диска, или winnt32.exe из директории i386, и обновить систему на XP. Делается это корректно, и перед перезагрузкой система выдаёт список программ и драйверов, несовместимых с XP.
Последний способ не является самым оптимальным. Хотя XP пытается самостоятельно определить список программ и драйверов, несовместимых с ней , она не в состоянии сделать это правильно во всех случаях. Поэтому, во избежание проблем с совместимостью, мы бы рекомендовали вам ставить систему заново.
При инсталляции поверх существующей ОС, у вас будет возможность выбора ОС (Dual boot).
Пример boot.ini, если в системе два физических диска и на каждом из них стоит операционка, должен иметь вид
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP
Professional RU" /fastdetect
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP
Professional RU""NEW"-" /fastdetect,

Параметры Boot.ini отвечают за порядок загрузки ОС установленных в системе, и позволяют задать некоторые параметры загрузки этих систем. Начинается этот файл разделом [boot loader] В этом разделе два параметра: Timeout, определяет время в секундах, которое ждёт система прежде чем начать загружать ОС по умолчанию, если в системе установлено несколько ОС. Default, определяет систему по умолчанию. Второй раздел [operating system], в котором находится список возможных к загрузке ОС. Для каждой ОС указывается её местоположение с использованием имен ARC (Advanced RISC Computer): scsi(*) или multi(*) - элемент scsi(*) используется в случае контроллера SCSI с отключенным BIOS. Элемент multi(*) используется для дисков остальных типов, включая IDE, EIDE, ESDI и SCSI с включенным BIOS. (*) - номер адаптера, с которого осуществляется загрузка. Адаптеры нумеруются с нуля, начиная с контроллера, расположенного ближе к слоту 0 на мат. плате. disk(*) - если (1) = scsi(*), то равен логическому номеру устройства (LUN), установленному для диска. Если (1) = multi(*), то всегда равен нулю. rdisk(*) - если (1) = multi(*), то равен номеру диска в цепочке, счет дисков начинается с 0. Если (1) = multi(*), то всегда равен нулю. partition(*) - определяет дисковый раздел, содержащий файлы ОС. В отличие от всех остальных элементов имен ARC нумерация разделов начинается с 1, т.е. первый раздел обозначается partition(1), второй - partition(2) и т.д. \path - определяет каталог (или подкаталог) раздела, в котором находятся файлы ОС. По умолчанию в XP используется путь \windows. В кавычках прописывается текст, он будет виден в пункте выбора ОС в стартовом меню. После этого текста могут быть ключи влияющие на элементы загрузки ОС. Для XP возможны следующие ключи:
/basevideo - система будет использовать только стандартный VGA драйвер.
/fastdetect - ставится автоматически при инсталляции системы. При установке этого ключа система не определяет Plug and Play устройства в процессе загрузки.
/maxmem - определяет максимальный размер RAM, который может использоваться системой.
/noguiboot - отсутствие заставки и BSOD при загрузки,: /noserialmice=[com 1,2,3] - не будет определяться мышь подключенная к COM порту для портов перечисленных в скобках. Если номера портов не указывать, то мышь не будет определяться на всех портах.
/bootlog - система будет писать лог загрузки в %SystemRoot%\Nbtlog.txt Параметр можно использовать для поиска причины, почему система загрузится только в safe mode.
/safeboot - система загрузится в Safe mode, или нажать F8 в начале загрузки системы. Через двоеточие можно задать несколько параметров для /safeboot.
Minimal - минимальная конфигурация.
Network - с поддержкой сети.
Dsrepair - доступна только в NET Server и позволяет восстановить Active Directory с резервной копии.
Alternateshell - позволяет использовать альтернативные графические оболочки. По умолчанию с системой ставится Explorer (стандартная оболочка) и Progman.
/sos - отображает на экране список загружаемых драйверов.
/baudrate - параметр указывает скорость работы COM порта для отладки системы. Если не указать скорость, будет 9600 для модема и 19200 для нуль-модемного кабеля. При включении этого параметра автоматически ставится параметр /debug.
/crashdebug - с этим флагом загружается отладчик, но остаётся в неактивном состоянии до возникновения ошибка ядра. Может использоваться разработчиками программного обеспечения.
/debugport=com* - указывает номер COM порта (* должен быть номером порта) используемого отладчиком. Автоматически включает ключ /debug.
/debug - загружается отладчик, может быть активизирован другим компьютером через подключенный COM порт. Может использоваться разработчиками ПО.
/nodebug - на экран не выводится отладочная информация.
/hal - указывает имя файла использующийся как hal.dll после загрузки.
/kernel - указывает имя файла использующийся как ntoskrnl.dll после загрузки.

Примечание: после установки XP как отдельной ОС, будет невозможна нормальная работа Outlook Express и Internet Explorer в Windows 9x, т.к. XP заменит последние. Это верно только в случае установки обеих ОС на один и тот же раздел диска. Но эту проблему можно решить путём копирования некоторых DLL из WinXP\System32 в Windows\System. Для определения нужных библиотек можно воспользоваться программой ShowDep (www.showdep.com) или аналогичные сведения показывает Outlook Express в окне "О программе".
Кроме этого, многие программы придётся устанавливать по два раза, отдельно для XP и для W9x. Иногда можно в один и тот же каталог, например Office 2000 уже при установке способен понять, что он уже установлен, и в итоге устанавливает всего около 18 мегабайт.

Наверх
Автономная установка

Если вы не хотите наблюдать за процессом установки и предпочитаете провести это время с большей пользой, создайте файл ответов, и инсталляция пройдет без вас. Этот файл можно создать с помощью программы SETUPMGR. Найдите на диске с дистрибутивом файл SUP-PORT\TOOLS\DEPLOY.CAB, из него распакуйте SETUPMGR.EXE. Это и есть нужная утилита. Она представляет собой обычный мастер. При создании файла отвечать придется на все те же вопросы, что и при инсталляции, и займет эта процедура 5-10 минут, а не 60-90, как весь процесс инсталляции. В итоге программа создаст два файла: скрипт сценария UNATTEN.BAT для запуска программы установки и непосредственно файл ответов UNATTEN.TXT. Все это будет помещено в отдельную папку вместе с файлами дистрибутива на том диске, который вы сами определите. Для варианта установки с CD файл ответов должен называться WINNT.SIF. Информацию об использовании этой утилиты и о необходимых ключах можно прочесть, запустив файл DEPLOY.CHM, который находится в DEPLOY.CAB.

Наверх
Создание мультизагрузочной системы

Рассмотрим возможность создания мультизагрузочных систем. По умолчанию ХР ставится как дополнительная ОС, а основной останется ваша прежняя. Такой вариант приемлем в том случае, если вы установили ХР временно, к примеру для изучения, а работать продолжаете в Windows 9x. Если же возврат в Win 9x не предвидится, советую установить первой Windows ХР, а все остальные ОС как дополнительные. В этом случае необходимо помнить, что при обычной инсталляции любая из Windows 9х непременно затрет загрузчик ХР. Чтобы предотвратить это, инсталляцию нужно производить с использованием файла конфигурации установки МSBАТСН. INF. В файле обязательно должны присутствовать следующие строки: [Setup] CleanBoot=0. Запускать программу установки нужно командной строкой следующего содержания: «Диск:\путь_к_дистрибутиву\setup.ехе диск:\путь_к_файлу_msbatch\МSВАТСН.INF». Предварительно необходимо принять все меры, чтобы в будущем восстановить загрузчик, если он по каким-то причинам все же будет затерт. Не менее важным является тот факт, что при параллельном использовании нескольких операционных систем файловая система должна оставаться той, которая поддерживается каждой из них, то есть FAT или FAT32. Кроме того, если ОС установлены в один раздел, будет невозможна корректная работа некоторых программ, так как папка Program Files, куда по умолчанию устанавливается подавляющее большинство софта, будет использоваться обеими операционными системами. К тому же возникнет серьезная зависимость от расположения системных файлов. Если программа устанавливалась под ХР, то системные файлы были записаны инсталлятором в папку этой ОС и для Windows 9x попросту недоступны. Для того чтобы иметь две операционные системы и одну программу, работающую под каждой из них, нужно скопировать файлы программы в системные каталоги обеих ОС. Возможно нормальной установки «копированием» может и не произойти: не забывайте, что существует реестр, и системные файлы, которые изменяются при установке софта. В выборе ОС лучше всего остановиться на чем-то конкретном. Так надежнее!

Наверх
Как выбрать нужную версию ядра и HAL ещё при инсталляции?

В самом начале текстового этапа установки XP при появлении сообщения "Setup is inspecting your computer's hardware configuration" нажмите и удерживайте клавишу "F5". В появившемся на экране списке версий библиотек HAL выберите версию, соответствующую вашему компьютеру, или выберите позицию "Other" для того, чтобы указать файл библиотеки от производителя оборудования. Затем продолжите установку Windows. В поставку XP включены следующие версии библиотеки HAL:

  • ACPI Multiprocessor PC - для ACPI-систем с несколькими процессорами.
  • ACPI Uniprocessor PC - используется для ACPI-систем с многопроцессорной системной платой и одним установленным процессором.
  • Advanced Configuration and Power Interface (ACPI) PC - используется для однопроцессорных ACPI-систем.
  • MPS Uniprocessor PC - для систем без поддержки ACPI, с многопроцессорной системной платой и одним установленным процессором.
  • MPS Multiprocessor PC - для многопроцессорных систем без поддержки.
  • ACPI Compaq SystemPro Multiprocessor or 100% compatible - для компьютеров Compaq SystemPro или полностью совместимых с ними.
  • Standard PC - используется для любого стандартного компьютера, не многопроцессорного и без поддержки ACPI.
  • Standart PC with C-Step i486 - используется для компьютеров с поддержкой этой технологии.

Наверх
Windows Components

При инсталляции система не даёт выбрать компоненты, да и после инсталляции в Add/Remove programs – Windows Components почти ничего нет.
Во время установки ничего выбрать вам, к сожалению, не удастся. Но, после инсталляции, в Windows/inf найдите файл sysoc.inf и удалите в нём слово hide или HIDE везде, где найдёте. В Add/Remove Windows components появятся новые пункты. К сожалению, всё из появившихся пунктов удалить нельзя, но кое-что можно.

Наверх
Стоит ли переходить с FAT32 на NTFS?

Что такое NTFS
Всё зависит от того, с какой целью вы используете компьютер, и сколько у вас оперативной памяти. Следует учесть, что NTFS работает несколько медленнее чем FAT, из-за дополнительно загружаемых сервисов и её системы безопасности. Если у вас мало оперативной памяти, и вы решили поставить себе XP, то вам однозначно нельзя ставить себе NTFS. Если у вас 128MB или больше, то можно уже подумать об NTFS. Следует взвесить преимущества и недостатки NTFS для простого пользователя и решить, что вам нужно. К преимуществам FAT32 можно отнести то, что она быстрее и требует меньше памяти для работы. Если система работает только с FAT32, то в память не грузятся драйвера и сервисы, необходимые NTFS. Кроме этого, при использовании FAT32 имеется возможность доступа к диску при загрузке с загрузочного флоппи W9x. Преимущества NTFS для простого пользователя можно описать одним ёмким словом: indestructible. На полном серьёзе, вышибить NTFS чрезвычайно сложно, хоть и возможно. Для опыта запускалась куча различных приложений, оптимизаторы диска, и в самые неподходящие моменты жалась кнопка reset. Повторение этого садизма добрый десяток раз никакого впечатления на систему не произвело, она продолжала работать без ошибок. Кроме этого, NTFS обладает встроенными средствами шифрования файлов, что обеспечивает определённую уверенность в сохранности данных. Конечно, при условии что система не будет переустанавливаться.

Наверх
Что такое NTFS, и как она работает?

Файловые системы
NTFS выросла из файловой системы HPFS, разрабатываемой совместно IBM и Microsoft для проекта OS/2. Она начала использоваться вместе с Windows NT 3.1 в 1993 году. Windows NT 3.1 должна была составить конкуренцию серверам на базе NetWare и Unix, поэтому NTFS вобрала в себя все тогдашние технологические достижения. Вот основные из них:
1. Работа с большими дисками. NTFS имеет размер кластера 512 байт, что в принципе оптимально, но его можно менять до 64К. Более важно то, что NTFS способна теоретически работать с томами размером в 16,777,216 терабайт. Теоретически, потому что таких жестких дисков пока просто не существует, и появятся они весьма не скоро.
2. Устойчивость. NTFS содержит две копии аналога FAT, которые называются MFT (Master File Table). В отличие от FAT MSDOS, MFT больше напоминает таблицу базы данных. Если оригинал MFT повреждён в случае аппаратной ошибки (например, появления bad-сектора), то система при следующей загрузке использует копию MFT, и автоматически создаёт новый оригинал, уже с учётом повреждений. Но это не самое главное. Главное, что NTFS использует систему транзакций при записи файлов на диск. Эта система пришла из СУБД, где защита целостности данных - жизненно важное дело. Уже это говорит о её эффективности. В упрощённом виде она работает так:

  • Драйвер ввода/вывода NTFS инициирует процесс записи, одновременно сообщая сервису Log File Service вести лог всего происходящего.
  • Данные пишутся в кэш, под управлением сервиса Cache Manager.
  • Cache Manager посылает данные Virtual Memory Manager-у (менеджеру виртуальной памяти), для записи на диск в фоновом режиме.
  • Virtual Memory Manager посылает данные драйверу диска, пропустив их через Fault Tolerant Driver (если у вас массив дисков RAID).
  • Драйвер диска шлёт их контроллеру, который уже пишет их либо в кэш, либо прямо на диск.
  • Если эта операция проходит без ошибок, запись лога удаляется.
  • Если происходит сбой, запись лога остается в таблице транзакций, и при следующем доступе к диску Log File Service обнаруживает эту запись, и просто восстанавливает всё как было до этой операции.

Такая система гарантирует абсолютную сохранность данных в случае копирования, перемещения и удаления файлов или директорий. При внесении изменений в файл, вы теряете те изменения, которые находились в момент сбоя в памяти или в кэше контроллера, и не успели записаться на диск.
3. Защищенность. NTFS рассматривает файлы, как объекты. Каждый файловый объект обладает свойствами, такими как его имя, дата создания, дата последнего обновления, архивный статус, и дескриптор безопасности. Файловый объект также содержит набор методов, которые позволяют с ним работать, такие как open, close, read и write. Пользователи, включая сетевых, для обращения к файлу вызывают эти методы, а Security Reference Monitor определяет, имеет ли пользователь необходимые права для вызова какого-либо из этих методов. Кроме этого, файлы можно шифровать. Правда, с шифрованием стоит быть осторожнее. Если у вас рухнет система, или вы её переустановите то вы не сможете прочитать зашифрованные файлы, если не имеете ERD.
4. Компрессия данных. NTFS позволяет компрессировать отдельные каталоги и файлы, в отличие от DriveSpace, который позволял сжимать только диски целиком. Это очень удобно, для экономии пространства на диске, например можно сжимать "на лету" большие графические файлы формата BMP, или текстовые файлы, причём для пользователя всё это будет прозрачно.
5. Поддержка формата ISO Unicode. Формат Unicode использует 16bit для кодировки каждого символа, в отличие от ASCII, который использовал 8bit, или ещё хуже - 7bit. Для простого пользователя это означает то, что теперь он может называть файлы на любом языке, хоть на китайском - система это будет поддерживать, не требуя изменить кодовую страницу, как это делал DOS и W9x.

Наверх
Что нового в файловой системе NTFS5, и в чем её отличия от NTFS4?

Самое главное, в чём она уступала NetWare, это за отсутствие квот. Квоты - это ограничение максимального объёма дискового пространства для пользователя, которое он сможет использовать. Зачем это нужно? На компьютерах, работающих в больших сетях, в фирмах и организациях понятно зачем, жесткие диски не резиновые. На домашнем компьютере, можно например, выделить пользователю "жена" или "младший брат" не более 50МБ на винчестере, чтобы они не захламляли диск чем попало. Причём, вовсе не обязательно, чтобы все файлы пользователя хранились в одном месте, они могут быть разбросаны по всем дискам. Устанавливаются квоты через Properties NTFS раздела, закладка Quota. Через Quota Entries... можно разрешать квоты для каждого отдельного пользователя. Второе, достаточно важное отличие NTFS5 от старой версии - возможность поиска файла, по имени его владельца. Зачем это нужно? Вот зачем: например, вам нужно найти все файлы созданные в Word одним пользователем, на диске где много файлов. В NT4 это было проблемой. С помощью Access Control List, можно легко проверить, какие файлы доступны пользователю, и установить права доступа к отдельным файлам или каталогам. Кроме непосредственного изменения самой структуры NTFS, в XP добавлен Microsoft Index Server, который значительно ускоряет поиск файлов, особенно по их содержимому, за счёт индексации содержимого дисков. Управляется эта служба через раздел Indexing Service окна Computer Management. В этом разделе можно просмотреть, какие директории индексируются, и, при желании, добавить новые или удалить старые. Работает это c любыми разделами, не только NTFS. В NTFS5 добавлена функция точки монтирования или, по-другому, точки соединения (junction point). Функция знакома пользователям различных вариантов Unix/Linux, но в продуктах Microsoft она появилась впервые недавно (только с W2k). С помощью этой технологии можно присоединить любой дисковый ресурс в любое место файловой системы. Например, можно присоединить жёсткий диск D:\ в любой из каталогов на диске C:\, например, в C:\games . Теперь, входишь в директорию C:\games, можно будет увидеть содержимое корневого каталога диска D:\. Все изменения, которые будут произведены в этой директории, будут произведены на диске D:\. После этого, можно в окне Computer management -> Disk Management убрать букву, присвоенную этому диску (Change disk letter and path), и пользователь не будет знать, что на компьютере установлено два диска! Он будет работать с одним диском C:\ и директория C:\games для него ничем не будет отличаться от других. Смонтировать диск или раздел в директорию на NTFS разделе или диске, можно из меню Change disk letter and path, выбором пункта Add.. -> Mount in this Ntfs folder -> Browse... Управлять этой функцией можно и через командную строку, командой "mountvol". Сразу после изменения диска, директория в которую он установлен, будет показываться другим значком, но стоит переименовать её, как она примет такой же вид, как и все остальные. Для изменения диска, используйте Disk Management, меню Change disk letter and path, выбором пункта Remove. Если просто удалите папку с диском в Explorer, то вместе с папкой вы удалите ВСЁ содержимое диска. Нужно быть внимательным. Есть возможность создавать отдельные директории, но для этого придётся воспользоваться сторонней утилитой. Взять её можно здесь. Зайдите в консоль, запустите её, и ознакомитесь с её операндами.

Наверх
Что такое кластер, и какого размера он должен быть?

Кластер - минимальный размер места на диске, которое может быть выделено файловой системой для хранения одного файла. Определяется он, как правило, автоматически, при форматировании винчестера, по зависимости указанной в таблице:

Размер раздела | Секторов в кластере | Размер кластера
512mб | 1 | 512 байт
1024mб | 2 | 1K
2048mб | 4 | 2K
4096mб | 8 | 4K
8192mб | 16 | 8K
16384mб | 32 | 16K
32768mб | 64 | 32K
32768 MБ | 128 | 64K

Небольшое исключение для системного раздела: если он меньше 2048МБ, то размер кластера, при использовании NTFS, всегда 512 байт.
Кроме этого, при конвертации Fat32 раздела в NTFS встроенной в XP утилиткой convert, размер кластера всегда будет 512 байт. Что бы избежать, придётся воспользоваться внешними программами, например Partition Magic. Узнать размер кластера в XP можно несколькими способами. Во первых, можно зайти в Administrative Tools -> Computer Management -> Storage -> Disk Defragmenter. Выбрать нужный диск и нажать на Analyze. Через несколько секунд появится табличка, где есть три кнопки. Нажатие на View Report запускает окошко, в котором море информации про выбранный диск, в том числе и Cluster size.
Есть ещё один метод, который подходит не только для XP. Создаётся, или берётся готовый, маленький файлик размером от 1 байта до 500 байт. Нажимается на нём правая кнопка мыши, выбирается Properties. Смотрим на два пункта, Size и Size on disk. Size должен быть чем-то вроде 10 байт (или какой там размер он реально имеет), а Size on disk будет, к примеру, 4096 байт, что соответствует размеру кластера, т.е. 4K.
Размер кластера можно выбрать и самому, вручную, правда, только при форматировании. Делается это так: "format d: /A:size", где size это размер кластера в байтах. Однако существуют некоторые правила, которых следует придерживаться: во-первых, размер кластера должен быть кратен размеру физического сектора, то есть 512 байтам в подавляющем большинстве случаев; во-вторых, есть ограничения по количеству кластеров на разделе.
Кроме всего вышеперечисленного следует учитывать, что при размере кластера выше 4 килобайт на NTFS разделе не будут работать функции сжатия, встроенные в файловую систему.

Наверх
Как уменьшить занимаемый объем установленной XP?

Можно удалить директории: * %SystemRoot%\Driver Cache\i386\ Это можно сделать в том случае, если всё оборудование уже стоит и работает. При добавлении нового оборудования система будет запрашивать дистрибутив. * %SystemRoot%\system32\dllcache\ Это кэш защищенных системных файлов, используемый для их автоматического восстановления в случае повреждения. Размер по умолчанию этой папки 400 Мб, и определяется он параметром SFCQuota (0xFFFFFFFF) в ключе реестра HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows NT \ CurrentVersion \ Winlogon Изменить размер кэша системных файлов можно помощью команды sfc: sfc /cachesize=0 (можно ввести другое значение, например, 3 Мб), а потом вручную удалить все файлы в указанной директории. Если не задать /cachesize=0, то при следующей проверке защищенных системных файлов система снова наполнит свой кэш до заданного объема. * Выключить System Restore. Сделать это можно здесь: System Properties -> System Restore -> Turn off System Restore for all drives. Этим вы сотрёте всю информацию, которая записана System Restore, и хранится в папке System Volume Informatiоn. * Отключить Hibernate. Так называется технология, которая позволяет быстро выключать и включать компьютер. Основана она на сохранении содержимого оперативной памяти в виде файла на жёстком диске. Поэтому при её использовании в корне системного диска всегда присутствует файл под названием hiberfil.sys объёмом равным оперативной памяти. Стирать его вручную бесполезно, во первых сделать это можно только под другой ОС, во вторых при загрузке он будет создан заново, даже если компьютер не уходил в хибернейт. Сделано это для того, чтобы не было ситуации, когда машина не может уйти в хибернейт только из за того, что на диске не хватает места для этого. Для того чтобы убрать этот файл навсегда, требуется отключить хибернейт, что можно сделать в Control Panel – Power Options, закладка Hibernate, снять галочку с чекбокса Enable Hibernate.
* Уменьшить размер Swap файла. По умолчанию XP создаёт файл подкачки размером в полтора раза больше чем объём оперативной памяти. С современными объёмами RAM, которые даже в домашних машинах могут доходить до гигабайта, и файл подкачки того размера, что XP выставит для такой машину по умолчанию, большинству пользователей не нужен. Поменять размер файла подкачки можно через System Properties – закладка Advanced, кнопка Settings раздела Performance. В открывшемся окне переходим на закладку Advanced и нажимаем на кнопку Change раздела Virtual Memory. В открывшемся окне выбираем диск или раздел, на котором требуется изменить размер файла подкачки, вводим нужные значения, и нажимаем на кнопку Set. Остаётся только перезагрузиться.

Наверх
Можно ли конвеpтировать диск FAT32 в NTFS без потеpи данных?

1. Можно воспользоваться командой CONVERT том: /FS:NTFS [/V] Преобразование произойдет при следующей перезагрузке. Потери информации не при этом не будет, но нужно иметь в виду, что размер кластера после конвертации составит 512 байт, что не очень хорошо на больших разделах, кроме того, диск после конвертации будет сильно фрагментирован. Обратное преобразование (NTFS -> FAT) без потери данных средствами XP невозможно, потребуется отформатировать раздел заново.
2. Выполнить конвертацию также сможет программа Partition Magic. C NTFS 5 нормально работает, начиная с версии 6.0, но если использовать только загрузочную дискету, то подойдет и версия 5.01. Данная программа также позволяет выполнять обратное преобразование без потери данных и даже может менять размер кластера (к сожалению, только на FAT16 и FAT32). Partition Magic не работает с динамическими дисками, только с основными. Если кого-то не устраивает, что Windows XP занимает слишком много места и восстанавливает удалённые из его директории файлы, то может удалить папку dllcache, но после следующей проверки системных файлов Windows снова заполнит эту папку. Для устранения этого "греха", после удаления или до удаления файлов (но не папки), нужно запустить команду sfc /cachesize=число. Числом будет количество мегабайт которое должно резервироваться для папки windows\system32\dllcache. Можно поставить = 0.

Наверх
Установка SP1 и активация Windows

Инструментом для успешного проведения активации является генератор ключей установки Windows XP (имеется ввиду ключ, который необходимо вводить при установке системы). Называется этот генератор так: XPKeyOEM v5.24H и XP KeY OEMSE EdiTion v5.12
После его запуска нужно выбрать:

Software:
для Windows XP Pro OEM - WiN XP REAL OEM (именно REAL OEM!)
для Windows XP Home OEM - WiN XP HOME OEM

Mode: FIND KEY
Num. of Searches: 100
Max. Keys to find: 2

И нажать на кнопку "PROCESS"

После того, как ключи будут найдены, нажмите "SHOW LOG", и результаты работы генератора окажутся перед Вами.

Теперь установите Windows XP при помощи одного из сгенерированных ключей, либо, если система уже установлена смените ключ установки: Запустите программу Активации, выберите Активация по телефону->Сменить Ключ Продукта и забейте новый сгенерированный ключ.

Настало время активировать Вашу Windows XP через Интернет (удобнее) или по телефону.

После того, как Вам сообщат, что Ваша копия Windows успешно активирована, можете устанавливать Service Pack ( SP2 - деактивирует:)

Есть мнение, что Service Pack, способен убить активацию Windows XP если ему что-то не понравится. Заявляю: если Windows XP активирована по нормальному (без изменения системных файлов и прочих краков), то никакой SP не в праве деактивировать Вашу систему! .
Активация будет отменена, если активировали через F8- runme. Выход один - восстановить оригинальные файлы!

Их имена: winlogon.exe_ licdll.dll_

Распакуйте их в папку I386 дистрибутива и Вы получите нормальную рабочую копию Windows XP. Не копируйте их в случае, если в Ваш дистрибутив !УЖЕ! интегрирован Service Pack!! Результат будет быть плачевным!!

Прежде чем начать установку SP, запустите System Restore и создайте новую контрольную точку (Create New Restore Point).

Предупреждение: При работе с редактором реестра будьте внимательны, иначе потребуется переустановка операционной системы.

1. Нажмите Пуск, а затем Выполнить.

2. Пишем regedit и жмите OK.

3. Находим ключ:
HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\Current Version\WPAEvents.

4. На параметре OOBETimer нажать правой кнопкой и выбрать Modify. Необходимо изменить одну цифру в этом параметре, чтобы дезактивировать Windows.

5. Нажать Пуск, а затем Выполнить.

6. Ввести команду:
%systemroot%\system32\oobe\msoobe.exe /a
и нажать OK- это каталог, в котором установлена Windows.

7. В открывшемся окне нажать Yes, I want to telephone a customer service representative to activate Windows, и затем OK.

8. Нажать Change Product Key.

9. Напечатать новый код в окошке New Key и OK. (Список кодов активации внизу).

Если происходит возврат к предыдущему окну, жмите Remind me later, и перезагрузите компьютер.

Повторите пункты 5 и 6, и убедитесь, что Windows активирована. Должно появиться следующее сообщение: Windows is already activated. Жмите OK.

После этого надо инсталлировать SP1 Windows.

Если Windows не запускается после установки SP1, нажать F8 во время перезагрузки и выбрать Last Known Good Configuration, и повторить процедуру.

Коды активации Windows XP:
82VJ3-PB4JR-QPDXV-77VRC-8WRFX
DCJM2-4FJQ8-FH46R-WMPDF-4MJ64
YXPGY-FQHT2-7MHPD-FJ3R3-8PPKB
GXYXB-M46X6-BCVJ3-3RR7K-F6TTM
M8W23-CM7TD-DJWV4-KTTB2-99B7K
8GKGV-B6FKM-2JVM3-KJ842-TP7QY
DPQFT-GYD77-X72G7-KFCP6-K9P4T
HY2DM-YFFDH-M7P8R-XGG4J-63W3Y
WHBV2-GQC8P-3CC4G-GYWPK-G7PRT
G6QBR-P3DDJ-7MDJ7-7X8FT-F2CH6
MWB32-G7RB6-4QWH3-GP2V2-BJB83
VJKTC-33Q7W-VMXPR-2JDTK-867CQ

Наверх


Командная строка

Рано или поздно каждый пользователь сталкивается с необходимостью использования командной строки. Более того, в некоторых случаях решить задачу оказывается гораздо проще и удобнее с помощью текстовых инструкций, а для определенных команд вообще не существует эквивалента в графическом интерфейсе. Команды и параметры командной строки в "Справочник параметров командной строки"
Так что чем раньше вы овладеете освоитесь с командной строкой, тем для вас же и лучше. А теперь нажимайте Пуск- Выполнить, вводите текст cmd и жмите Enter.

Настройка

Внешний вид командной строки можно изменять. Щелкните правой кнопкой мыши по строке заголовка окна и выберите пункт Properties (это окно можно также запустить нажатием Alt + «Пробел» + P). Откроется окно с четырьмя вкладками, на которых будут доступны опции изменения настроек программы. Если вам не нравится стандартный черный экран командной строки, то на вкладке Color вам предлагается выбрать цвет экрана и текста либо из 16 стандартных цветов, для которых имеется соответствующие образцы, либо задав числовое значение цвета в формате RGB. На вкладке Layout настраивается размер окна и экранного буфера. Если в ранних ОС MS-DOS и Windows размер экрана оставался неизменным — 25 строк в высоту и 80 символов в длину, и для вывода большего количества строк приходилось добавлять команду |more, то в системах NT и более поздних можно просто задать достаточно большой размер буфера экрана и пользоваться полосой прокрутки, что гораздо удобнее.
Текст в окне командной строки

Для копирования и вставки текста в окно командной строки обычные для Windows комбинации клавиш, такие как Ctrl+C, Ctrl+V, работать не будут. Для извлечения текста из буфера обмена вам придется вызвать меню, щелкнув правой кнопкой мыши по заголовку окна, и выбрать подменю Edit. Или же просто щелкните правой кнопкой по окну. Для копирования текста из окна выберите пункт Mark и мышью выделите нужный текст. Затем либо нажмите Enter, либо в том же меню выберите Copy. Если надо вставить какой-то текст в окно командной строки, обратитесь к команде Paste. Для повторного выполнения команды воспользуйтесь стрелками «вверх» и «вниз», позволяющими перемещаться по списку выполненных команд. Для очистки экрана от текста служит директива cls. Для того чтобы просмотреть все открытые в системе файлы, предлагаю воспользоваться командой openfiles /query. Она позволит определить все файлы, открытые как локально, так и удаленно, а также покажет имя процесса, использующего их. Команда openfiles /disconnect отключает удаленных пользователей от общих файлов на вашем компьютере. Напоследок рассмотрим еще одну очень интересную команду — Fsutil hardlink. Она принимает всего один параметр — create. Эта команда позволяет создавать жесткие ссылки на файлы. Жесткие ссылки позволяют одному файлу иметь несколько разных имен. Один и тот же файл может появляться в разных директориях или даже в одной директории с различными именами. И данные этого файла не могут быть удалены, пока счетчик имен файлов не будет равен нулю. Так как все ссылки указывают на один и тот же файл, программы могут открывать любую из них и изменять исходный файл. Приведем пример использования этой команды. Допустим, имеется файл d:\1.avi, занимающий 600 Мб. Воспользовавшись командой fsutil hardlink create d:\2.avi d:\1.avi, вы создаете жесткую ссылку на этот файл. В результате вы получите два файла, но объем занимаемого дискового пространства не изменится. Хотя если Вы выделите эти два файла, Вам будет показано, что они занимают 1200 мегабайт. Таким образом Вы можете создать неограниченное число копий какого-либо файла, при том что на занятом пространстве диска это никак не отразится. Причем если удалить один из таких клонов, все остальные останутся без изменений. Для того чтобы уничтожить исходный файл придется удалить все жесткие ссылки на него. Но у этой команды есть ограничения: все файлы должны быть в пределах одного тома, и файловая система — только NTFS (NT File System).

Наверх
Изменение вида приглашения (Windows NT/2000/XP)

Вы можете изменить вид приглашения для командной строки. Как правило используется формат типа C:\> (текущий диск и угловая скобка). Откройте раздел
HKLM\SYSTEM\ CurrentControlSet\Control\Session Manager\Environment и создайте параметр PROMPT типа REG_EXPAND_SZ, которому нужно присвоить одно из следующих значений:

  • $B - | (вертикальная черта)

  • $D - текущая дата

  • $G - > (знак больше)

  • $L - < (знак меньше)

  • $N - текущий диск

  • $P - текущий диск и путь

  • $Q - = (знак равно)

  • $T - текущее время

  • $V - версия Windows

  • $$ - $ (знак доллара)

Изменения вступят после перезагрузки

Наверх
Запрет на режим командной строки и обработки bat-файлов (Windows 2000/XP)

Существует возможность запрета на режим командной строки (cmd.exe) и обработки bat-файлов. Для этого найдите или создайте параметр типа DWORD DisableCMD в разделе HKCU\Software\Policies\Microsoft\Windows\System.

Данный параметр может принимать следующие значения

0 (или отсутствие записи в реестре | Система может использовать режим командной строки и обрабатывать bat-файлы
1 | Система не может использовать режим командной строки, но может обрабатывать bat-файлы
2 | Система не может использовать режим командной строки и обрабатывать bat-файлы

Сделанные изменения вступают в силу немедленно

Наверх
Запрет на расширенный режим командного процессора (cmd.exe)

Существует возможность запрета на расширенный режим командного процессора (cmd.exe). Например, в расширенном режиме существуют такие команды как del, erase, chdir, goto. Для запрета найдите или создайте в разделе HKCU\Software\Microsoft\Command Processor параметр EnableExtensions :dword= 0. Для включения режима используйте значение 1 Также имеется аналогичная запись в разделе HKLM\Software\Microsoft\Command Processor
Изменение заданного по умолчанию цвета командной строки Windows NT/2000/XP
Раздел реестра:
HKCU\Software\Microsoft\Command Processor "DefaultColor":dword =0
управляет активным и фоновым цветами, используемыми в окне командой строки. Значение по умолчанию равное 0 для стандартного белого текста на чёрном фоне. Вы можете заменить это значение шестнадцатеричным числом с двумя цифрами, в котором первая цифра определяет цвет фона, а вторая цвет символов. Пример, значение F0 установит чёрный текст на белом фоне, а 1E жёлтый текст на синем фоне.

Наверх
Изменение заданного по умолчанию цвета командной строки Windows NT/2000/XP

Раздел реестра:
HKCU\Software\Microsoft\Command Processor "DefaultColor":dword =0
управляет активным и фоновым цветами, используемыми в окне командой строки. Значение по умолчанию равное 0 для стандартного белого текста на чёрном фоне. Вы можете заменить это значение шестнадцатеричным числом с двумя цифрами, в котором первая цифра определяет цвет фона, а вторая цвет символов. Пример, значение F0 установит чёрный текст на белом фоне, а 1E жёлтый текст на синем фоне.

Таблица цвета текста и фона окна консоли

0 - черный | 1 - синий | 2 - зеленый | 3 - голубой
4 - красный | 5 - лиловый | 6 - желтый | 7 - белый
8 - серый | 9 - светло-синий | A - светло-зеленый | B - светло-голубой
C - светло-красный | D - светло-лиловый | E - светло-желтый | F - ярко-белый

Наверх
Возможность завершения командной строки Windows NT/2000/XP

Завершение команды позволяет Вам напечатать только часть имени файла, затем система закончит оставшуюся часть за Вас после нажатия клавиши "Tab". Это свойство подобно особенности завершения команды в оболочке UNIX. Для включения этой возможности:
1. Откройте раздел реестра:
HKCU\Software\Microsoft\Command Processor
и установите значение dword-параметра "CompletionChar" равным 9 для клавиши "Tab".
2. Выйдите из редактора реестра и перезагрузите Ваш компьютер. Теперь, когда Вы напечатаете первую часть имени файла и нажмёте клавишу "Tab", Windows завершит имя файла за Вас.
Обратите внимание: значение параметра "CompletionChar" определяет, какая клавиша выполняет завершение команды, то есть 9 соответствует клавише "Tab".

Наверх


Политики учетных записей

Все политики безопасности являются политиками безопасности для компьютера. Политики учетных записей определяются на компьютерах и определяют взаимодействие учетных записей с компьютером и доменом. Существуют три политики учетных записей.

  • Политика паролей. Используется для учетных записей доменов и локальных компьютеров. Определяет параметры паролей, такие как соответствие обязательным условиям и срок действия.
  • Политика блокировки учетной записи. Используется для учетных записей доменов и локальных компьютеров. Определяет условия и период времени блокировки учетной записи.
  • Политика Kerberos. Используется для учетных записей пользователей домена. Определяет параметры Kerberos, такие как срок жизни билета и соответствие обязательным условиям. Политики Kerberos не входят в состав политики локального компьютера.

Для учетных записей доменов допускается использование только одной политики учетных записей. Политика учетных записей должна быть определена в политике домена по умолчанию и реализовываться контроллерами домена, образующими этот домен. Контроллер домена всегда получает политику учетных записей от объекта групповой политики «Политика по умолчанию для домена», даже если имеется другая политика учетных записей, примененная к организационному подразделению, которое содержит контроллер домена. Присоединенные к домену рабочие станции и серверы (такие как компьютеры-участники) по умолчанию также получают эту же политику учетных записей для локальный учетных записей. Однако локальные политики учетных записей могут отличаться от политики учетных записей домена, например когда политика учетных записей определяется непосредственно для локальных учетных записей.

В окне «Параметры безопасности» доступны две политики, имеющие с политиками учетных записей похожую функциональность. Далее представлены эти политики.

  • Network Access: Allow anonymous SID/NAME translation
  • Сетевая безопасность: Принудительный выход из системы по истечении допустимых часов работы

Локальные политики

Эта группа политик применяется на компьютерах. В ее состав входят три представленные далее политики.

  • Политики аудита. Определяет, какие события безопасности заносятся в журнал безопасности данного компьютера. Также определяет, заносить ли в журнал безопасности успешные попытки, неудачные попытки или и те, и другие. (Журнал безопасности является частью оснастки «Просмотр событий».)
  • Назначение прав пользователя. Определяет, какие пользователи и группы обладают правами на вход в систему и выполнение различных задач.
  • Параметры безопасности. Включение или отключение параметров безопасности, таких как цифровая подпись данных, имена учетных записей администратора и гостя, доступ к дисководам гибких и компакт-дисков, установка драйверов и приглашения на вход в систему.

Поскольку возможно применение к компьютеру несколько политик, может возникнуть конфликт между параметрами безопасности. Приоритет имеют политики следующих объектов в указанном порядке: подразделение, домен, локальный компьютер.


Востановление реестра

Манипулирование реестром

Общие вопросы

Как мы уже знаем, в операционной системе Windows XP сведения о конфигурации системы централизованно размещены в реестре. Это упрощает администрирование компьютера или сети, но, вместе с тем, одно неправильное изменение в реестре может вывести операционную систему из строя. Приведенный ниже список содержит советы и рекомендации по аккуратному использованию реестра и редактора реестра.
— Перед внесением изменений в реестр делайте резервную копию.
— Не заменяйте реестр Windows XP реестром другой версии операционных систем Windows или Windows NT.
— Не оставляйте редактор реестра работающим без присмотра.
— Для редактирования реестра используйте редактор реестра или другие программы, которые обеспечивают безопасные методы работы с реестром.

Кроме того, вы можете ограничить доступ к реестру различным пользователям. Для этого в левом окне Regedit'а кликните правой кнопкой мыши на выбранном разделе реестра и выберите пункт Разрешения.

Для некоторых операций с реестром нам пригодится Recovery Console. Загрузиться в нее можно с CD-ROM, на котором находится Windows XP, нажимая клавишу R, но для удобства использования можно установить ее и на жесткий диск.

Для этого вставьте установочный CD-ROM с Windows XP и выполните команду:
[буква CD-ROM]:\i386\winnt32.exe /cmdcons
и далее следуйте инструкциям.

После установки консоль восстановления появится в виде варианта загрузки.Все ее содержимое находится в отдельной скрытой папке Cmdcons в корне загрузочного диска с Windows XP. Объем папки около 8 Мб, и изменение настроек Windows XP не повлияет на консоль восстановления.

Еще один важный для нас вопрос: как в Recovery Console получить доступ в папки, отличные от \WINDOWS? Возможно, нам это понадобится, поэтому позаботьтесь об этом заранее. Под аккаунтом администратора заходим в <Панель управления — Администрирование>. Включаем программу Локальная политика безопасности — Локальные политики — Параметры безопасности, опция Консоль восстановления: >Разрешить копирование дискет и доступ ко всем папкам : Включен. Когда вы будете находиться в режиме Recovery Console, дайте команду SET AllowAllPaths = TRUE.

Если вам что-то не нравится или нужно освободить место на жестком диске (около 8 Мб), можете удалить консоль восстановления :
— Удалите из корня диска скрытую папку \Cmdcons.
— Удалите из корня диска скрытый файл Cmldr.
— Откройте файл Boot.ini и удалите строку, похожую на это:
C:\cmdcons\bootsect.dat="Microsoft Windows Recovery Console" /cmdcons

Резервное копирование реестра в Windows XP и его последующее восстановление

Резервное копирование реестра

Способ 1

Примечание. Не используйте этот способ для экспорта всего реестра или его основных разделов (ульев, hive), таких как HKEY_CURRENT_USER и т.п.

Прежде, чем начать редактирование реестра с помощью REGEDIT, или REG-файла, сохраните ту часть реестра — раздел или подраздел, — которую вы будете изменять. Для этого:
— Запустите REGEDIT. можно "Пуск-Выполнить-REGEDIT".
— Найдите ветвь реестра, содержащую ключ, значение которого вы будете редактировать, клик на ней в левой части окна REGEDIT.
— В главном меню выбрать "Файл-Экспорт" и указать имя файла. Или клик правой кнопкой и указать "Экспортировать".

Альтернативный способ , можно выполнить команду или командный файл определенного содержания. Пример, сохраним настройки программы

The Bat!:
regedit /e thebat1.reg HKEY_CURRENT_USER\Soft-ware\RIT
regedit /e thebat2.reg HKEY_LOCAL_MACHINE\Software\RIT

Вся необходимая информация будет помещена в файлы THEBAT1.REG и THEBAT2.REG

Способ 2

Для резервного копирования всего реестра используйте программу архивации данных "Программы- Стандартные- Служебные- Архивация данных" или %SystemRoot%\system32\ntbackup.exe

Программа архивации позволяет архивировать и восстанавливать данные состояния системы, что включает в себя следующие системные компоненты:
— реестр;
— базу данных регистрации классов COM+;
— загрузочные файлы: Ntldr и Ntdetect.com;
— системные файлы.

Пошаговые инструкции для архивации реестра Windows XP :
— Войдите в систему с необходимыми правами, как администратор.
— Запустите NTbackup ( Архивация данных ).
— Перейдите в "Расширенный режим".
— Выбрать закладку "Архивация".
— В левом окне найдите и пометьте строку "System State".
— Нажать кнопку "Архивировать" и выбрать "Дополнительно".
— Снять "галочку" с пункта "Автоматически архивировать защищенные системные файлы вместе с состоянием системы". Таким образом мы архивируем только файлы реестра, произойдет быстро и займет места на диске примерно 17-20 Мб.
— На вкладке "Тип архива" установить "Обычный".
— "ОК" и нажмите "Архивировать". После архивации вы можете просмотреть отчет.
— Отчеты об архивации накапливаются в папке x:\Documents and Settings\%User%\Local Settings\Ap-plication Data\Microsoft\Windows NT\NTBackup\data\ в пронумерованных файлах backup01.log, back up02.log и т.д.

NTbackup можно использовать и из командной строки, но мы не будем рассматривать этот способ, так как восстановить данные с командной строки не удастся и, при архивации вместе с реестром будут архивированы и системные файлы, необходимые для загрузки Windows XP. Это потребует больше времени и займет больше места на жестком диске.

Способ 3

Полностью системный реестр можно архивировать вручную с помощью консоли восстановления (Recovery Console). Для этого:
— Загружаемся в Recovery Console.
— В командной строке Recovery Console выполняем следующие команды:
md tmp
copy c:\windows\system32\config\system c:\windows\tmp\system.bak
copy c:\windows\system32\config\software c:\windows\tmp\software.bak
copy c:\windows\system32\config\sam c:\windows\tmp\sam.bak
copy c:\windows\system32\config\security c:\windows\tmp\security.bak
copy c:\windows\system32\config\default c:\windows\tmp\default.bak

Обратите внимание: вам придется копировать сразу все пять файлов системного реестра.

Чтобы сэкономить время, вы можете оформить все вышеприведенные команды в отдельный файл, например, arcregistry.txt, предварительно подготовить его, и выполнить одной командой:
batch arcregistry.txt

Примечания

Примечание 1. В общем случае не рекомендуется перемещать сохраненные файлы реестра за пределы папки C:\Windows, так как в Recovery Console они могут быть недоступны даже если вы — администратор. Это верно, если не предпринять особых мер, описанных выше в разделе "Общие вопросы".

Примечание 2. Я бы рекомендовал вышеописанные способы №2 и №3 только если вы ожидаете полного краха системы. Обычно всегда удается загрузить последнюю удачную конфигурацию.

Примечание 3. Какой из способов: №2 или №3 — выбрать? Способ №2 прост , он не требует перезагрузки в режиме Recovery Console для сохранения файлов реестра, но гораздо сложнее для восстановления, если самое большое горе все-таки случится — ваша любимая Windows XP перестанет загружаться. Способ №3 самый простой в плане восстановления, для его выполнения требуется перезагрузка (еще до момента, как вы начнете курочить реестр) в режим Recovery Console. Можно выбрать и оба способа.

Восстановление реестра

В данном разделе мы практически повторим предыдущий, но восстановление реестра.

Способ 1

При архивации части реестра мы с помощью REGEDIT экспортировали данные в REG-файл. Теперь, чтобы извлечь их и восстановить исходный вид части реестра, выполним следующие шаги:
— Запустите REGEDIT.
— В главном меню выберать "Файл - Импорт" и указать имя файла.

Или выполнить команду или командный файл определенного содержания. Пример, восстановим настройки программы The Bat!:
regedit -s thebat1.reg
regedit -s thebat2.reg

Вся необходимая информация будет взята из файлов THEBAT1.REG и THEBAT2.REG.

Способ 2

Пошаговые инструкции для полного восстановления реестра Windows XP:
— Войдите в систему с правами администратор.
— Запустить NTbackup.
— Если NTbackup запустилась в режиме мастера, нажмите кнопку "Расширенный" в окне мастера архивации.
— Перейдите на вкладку "Восстановление и управление носителем".
— Установите в списке "Установите флажки для всех объектов, которые вы хотите восстановить" флажок для объекта "Состояние системы". Это позволит восстановить данные состояния системы


Удаление Мессенгер

Удаляем Windows Messenger

Данная опция относится только к встроенному Windows Messenger, если вы ставили более новую версию, то для ее удаления используйте Установку и удаление программ в Панели управления. Каждый раз при загрузке системы Messenger тоже стартует, замедляет процесс запуска, пожирает системные ресурсы. При открытии Outlook запускает встроенную версию Windows Messenger, даже если установлена более новая версия, используйте данную опцию чтобы удалить встроенный Windows Messenger из системы.

Если опция включена, измените следующие параметры в реестре:

HKLM\SOFTWARE\Policies\Microsoft\Messenger\Client

PreventAutoRun DWORD=1 - запрет автоматического запуска
PreventAutoUpdate DWORD= 1 - запрет обновлений
PreventBackgroundDownload DWORD= 1 - запрет загрузки файлов
PreventRun DWORD= 1 - запрет запуска

Данные значения не влияют на удаление, удаление происходит так:

Меню /Пуск/Выполнить напечатать следующее:" RunDll32 advpack.dll,LaunchINFSection %windir%\INF\msmsgs.inf,BLC.Remove " и нажать OK.

Перезагрузится.


Оптимизация по Биос

Биос

В базовой системе ввода/вывода скрыты многие настройки компьютера, которые позволят оптимизировать его работу. С помощью BIOS возможен разгон и оптимизация, то есть повышение производительности компьютера. Сейчас мы займёмся тонкой оптимизацией с помощью BIOS. Полное описание параметров и настроек BIOS в справочнике Registry Guide v1.2

Процессор.
CPU Mstr post WR Burst mode
Опция включает пакетный режим передачи данных но, ЦП должен быть в режиме Bus-master. Значительно повышает производительность.
Значение опции:
*Enabled- включено;
*Disabled- отключено.

CPU Priority
Устанавливает приоритет ЦП над другими устройствами, работающими в режиме master.
Значение опции:
*Always Last- приоритет ПЦ над другими устройствами;
*CPU 2nd- ПЦ по приоритету на втором месте;
*CPU 3nd- ПЦ по приоритету на третьем месте;
*CPU 4nd- ПЦ по приоритету на четвёртом месте.

Cache Timing Control
Данная функция контролирует скорость чтения/записи данных кэш-памяти второго уровня.
Значение опции:
*Fast (Turbo) - быстрый режим, высокая производительность;
*Medium - средняя скорость;
*Normal - Нормальная скорость, низкая производительность, устанавливается по умолчанию.

Видео карта.
Display Cache Window Size
Функция устанавливает размер кэшируемой системой памяти, которая используется для видеосистемы.
Значение опции:
*32MB - размер кэшируемой памяти составляет 32 Мбайт;
*64MB - размер кэшируемой памяти составляет 64 Мбайт.

AGP Capability
Позволит выбрать режим работы видеокарты. Оказывает прямое значение на производительность.
Значение опции:
*1X Mode - стандартный режим работы, данный режим устарел.
*2X Mode - удвоенный режим передачи данных.
*4X Mode - утроенный режим передачи данных. Самый быстрый.
Возможно, на самых новых видеокартах есть режим *8X Mode - самый быстрый из всех предыдущих.

AGP Master 1WS Read;
AGP Master 1WS Write
Количество тактов чтения/записи данных с шины AGP.
Значение опции:
*Enabled- включено, количество тактов равно 1. Производительность максимальная, но есть шанс не стабильной работы.
*Disabled- отключено. Количество тактов равно 2. Работа - стабильна.

VGA 128K Range Attribute
Между видеопамятью и ЦП включает буфер, увеличивается производительность.
Значение опции:
*Enabled- включено;
*Disabled- отключено.

Оперативная память.
FSB/SDRAM/PCI Freq. (MHz)
Функция позволит выбрать значение частот FSB, SDRAM и PCI.

Memory Hole At 15-16M
Копирует медленную память устройств ISA в оперативную память.
Значение опции:
*Disabled- отключено, используется, если в системе нет ISA - устройств;
*Enabled- включено, используется, если в системе есть ISA - устройства.

Memory Read Wait State
Функция контролирует задержку при чтение данных из оперативной памяти. Маленькая задержка - большая производительность, но есть шанс не стабильной работы.
Значение опции:
*0, 1, 2, 3 - задержка в тактах системной шины.

Optimization Method
Функция увеличивает скорость обмена данными с оперативной памятью. Повышает производительность.
Значение опции:
*Normal - стандартные параметры обмена;
*Turbo 1 - ускоренные параметры обмена;
*Turbo 2 - максимально быстрые параметры обмена.

SDRAM CAS Latency Time;
SDRAM RAS-to-CAS Delay;
SDRAM RAS Precharge
Данные опции оказывают прямое значение на производительность. Чем меньше значение - тем больше производительность, но есть шанс не стабильной работы.

Жёсткий диск.
HDD SMART Capability
Опция включает SMART. При этом понижается общая производительность системы.
Значение опции:
*Enabled- включено;
*Disabled- отключено.

IDE Burst Mode
Опция включает буфер данных, имеющийся на любом современном HDD интерфейса IDE. Значительно повышает производительность.
Значение опции:
*Enabled- включено;
*Disabled- отключено.

IDE Burst for DOS & Windows
Опция включает буфер для интерфейса IDE упреждающего чтения и отложенной записи.
Повышается пропускная способность канала IDE. Повышает общая производительность.
Значение опции:
*Enabled- включено;
*Disabled- отключено.

IDE HDD Block Mode Sectors
Режим поблочной многосекторной передачи данных с HDD. Значительно повышает производительность.
Значение опции:
* HDD MAX - авто определение;
*Своё значение - обратитесь к инструкции HDD.

Несколько интересных опций.
Automatic Power Up
Включить компьютер в определённое время.
Значение опции:
*Everyday - каждый день в определённое время;
*By date - в определённую дату, время, месяц, и другое.
*Disabled- отключено.

Wake On PS/2 KB/Mouse
Включает компьютер при нажатие на <пробел> или ЛКМ.
Значение опции:
*Enabled- включено;
*Disabled- отключено.


Меню Пуск

Предварительно несколько слов о настройке меню Пуск. По умолчанию большинство нижеописанных ключей не содержатся в реестре, поэтому, если не сказано обратное, их нужно будет добавить. Для отмены действия ключа, если нет специальных оговорок, будет необходимо изменить его значение на обратное — чаще с 1 на 0 — либо просто удалить ключ из реестра.
Большинство изменений, описанных в этом разделе, могут использоваться как для отдельного пользователя, так и в более широком масштабе — для всего компьютера. В этом случае проведите идентичные изменения в разделе HKLM

Содержание

Меню Пуск

Удалить команду Найти из меню Пуск

Скрыть Свойства Панели задач

Скрыть дополнительные папки в Меню Пуск

Удалить меню Панель управления, Принтеры и факсы

Контекстное меню

Всплывающие подсказки

Настройка уведомлений

Убрать имя пользователя из меню Пуск

Удалить пункт меню Выход из системы (Logoff)

Удалить список часто используемых программ

Не вести историю открытия документов

Очистка списка недавно использовавшихся документов

Раскрывать меню при наведении и задержки указателя

Выделять недавно установленные программы

Не показывать общие ярлыки (All Users)

Количество ярлыков в меню "Пуск - Документы"

Элементы меню Пуск

Меню в стиле Windows XP

Администрирование

Прокрутка для меню Программы

Команда "Выполнить"

Меню "Избранное"

Мои документы

Мой компьютер

Мои рисунки

Моя музыка

Панель управления

Поиск

Разрешить перетаскивание объектов

Сетевое окружение

Сетевые подключения

Справка и поддержка

Отображать пункт меню Недавние документы

Большие значки в главном меню

Классический вид меню

Классический вид меню

Использовать прокрутку для меню "Программы"

Использовать сокращенные меню

Мелкие значки в главном меню

Отображать команду "Выполнить"

Отображать команду "Завершение сеанса"

Отображать меню "Администрирование"

Отображать папку "Избранное"

Разрешить перетаскивание объектов

Раскрывать "Панель управления"

Раскрывать папку "Мои документы"

Раскрывать папку "Мои рисунки"

Раскрывать папку "Принтеры"

Раскрывать "Сетевые подключения"

Задержка выпадения меню

Удалить команду Найти из меню Пуск

Удалить команду Найти из меню кнопки Пуск и контекстно - зависимых меню:
HKCU\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\Explorer

NoFind=DWORD:1

Наверх
Скрыть Свойства Панели задач

Сделать недоступными свойства панели задач и меню Пуск :

HKCU\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explorer

NoSetTaskbar =DWORD:1

Наверх
Скрыть дополнительные папки в меню "Пуск"
которые находятся в каталоге "C:\WINDOWS\Главное меню"

HKCU \Software \Microsoft \Windows \CurrentVersion \Policies \Explorer

NoStartMenuSubFolders=DWORD:1

Наверх
Удалить меню Панель управления , Принтеры и факсы

Удаляет меню Панель управления и Принтеры и факсы.

HKCU\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explorer

NoSetFolders=DWORD:1

Наверх
Контекстное меню

Исключает возможность модификации меню Пуск. Обычно пользователь по правому клику мышки на меню Пуск вызывает контекстное меню для изменения его свойств. Данная опция может включить или выключить такую возможность.

HKCU\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\Explorer

NoChangeStartMenu = DWORD:1

Наверх
Всплывающие подсказки

Обычно Windows XP показывает всплывающие подсказки и дает советы начинающим пользователям. Измените значение ключа с 1 на 0 для того, чтобы исключить эту возможность:
HKCU\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\Advanced

EnableBalloonTips = DWORD:0

Наверх
Настройка уведомлений

Если окно Настройка уведомлений (Панель управления - Панель задач и меню "Пуск" - вкладка Панель задач - кнопка Настроить) забито значками ненужных программ, значит пришло время почистить список. Открываем раздел:

HKCU\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ TrayNotify

и удалить параметры :
IconStreams и PastIconsStream.
Затем откройте Диспетчер задач Windows (Task Manager), выберите вкладку Процессы, выделите Explorer.exe и нажмите кнопку Завершить процесс. Затем в меню Файл выберите Новая задача (Выполнить...) и напечатайте explorer. OK.

Terminator II (http://winchanger.narod.ru/)

Наверх
Убрать имя пользователя из меню Пуск

Убирает имя пользователя из меню Пуск (только если меню в стиле XP). Чтобы изменения вступили в силу, необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoUserNameInStartMenu:DWORD = 1 - убирает имя пользователя, 0 - показывать имя пользователя

Наверх
Удалить пункт меню Выход из системы (Logoff)

Запретить выход из системы из меню Пуск. Чтобы изменения вступили в силу, необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

StartMenuLogoff:DWORD = 1 - удаляет кнопку из меню

Наверх
Удалить список часто используемых программ

Не путайте данный параметр с "Недавно использовавшимися документами". Данный параметр убирает часто использующиеся программы, которые появляются в меню пуск, в левом столбце (только в стиле Windows XP). Чтобы изменения вступили в силу, необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\

Explorer NoStartMenuMFUprogramsList:DWORD = 1 - удаляет список

Наверх
Не вести историю открытия документов

Предотвращает создание списка недавно использовавшихся документов:

HKLM\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ policies\explorer

NoRecentDocsHistory=DWORD:1

Наверх
Очистка списка недавно использовавшихся документов
Очистка списка недавно использовавшихся документов при завершении сеанса работы на компьютере :

HKLM\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ policies\explorer

ClearRecentDocsOnExit=DWORD:1

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

ClearRecentDocsOnExit =REG_DWORD: 01000000

Ярлыки меню "Документы" хранятся на жёстком диске в папке %WinDir%\Recent, где %WinDir% ≈ папка, в которую установлена Windows

Наверх
Раскрывать меню при наведении и задержки указателя

Если опция включена, меню автоматически раскрывается при наведении и задержки указателя, иначе необходимо щелкнуть левой кнопкой мыши для его открытия.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_AutoCascade:DWORD = 1 - раскрывать меню автоматически, 0 - только после щелчка мыши.

Наверх
Выделять недавно установленные программы

Подсвечивать недавно установленные программы. Чтобы изменения вступили в силу, необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_NotifyNewApps:DWORD = 1 - раскрывать меню автоматически, 0 - только после щелчка мыши.

Наверх
Не показывать общие ярлыки (All Users)

Не добавлять в меню Пуск общие ярлыки. Папка с общими ярлыками находится Documents and Settings\All Users\Главное меню

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoCommonGroups:DWORD = 1 - ярлыки из общего меню не добавляются

Наверх
Количество ярлыков в меню "Пуск - Документы"

А теперь небольшая добавка к полученным умениям:

1. Определим, сколько ярлыков может быть создано в меню Пуск — Документы. По умолчанию их 15, но вы можете изменить это значение на свое. Добавьте или измените ключ

HKCU\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explorer

MaxRecentDocs:DWORD= ?

Наверх

Элементы меню Пуск

Меню в стиле Windows XP

В зависимости от выбранного положения переключателя, параметр будет сохраняться, соответственно, с типом DWORD для меню в стиле XP и строковым типом для классического стиля.

Существует две возможности скрывать/показывать меню, а именно два ключа

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

и

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

или такой же ключ в HKLM
первый ключ скрывает/показывает пункты меню и их можно исправить стандартными средствами Windows XP, второй ключ запрещает/разрешает показ меню, изменение параметров в этом ключе имеет больший приоритет и не изменяется стандартными средствами Windows XP

Наверх
Администрирование

Отображать в меню "Пуск"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_AdminToolsRoot: DWORD = 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Отображать в меню "Все программы"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

StartMenuAdminTools: DWORD = 0 - не отображать пункт меню, 1 - отображать

Примечание: Windows XP не позволяет выбрать значение так, чтобы пункт меню Администрирование отображался в главном меню и не отображался в меню "Все программы".

Наверх
Использовать прокрутку для меню Программы

Смысл этой опции в том что, когда ваше меню Программы разрастется до таких размеров, что не будет помещаться на экране в высоту, то Windows XP по умолчанию создаст второй столбец с теми пунктами меню, которым не нашлось места в первом столбце. Однако данная опция позволяет вам использовать один-единственный столбец с кнопкой прокрутки вместо того, чтобы отображать второй столбец. Добавьте в реестр ключ следующего содержания

HKCU\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

StartMenuScrollPrograms="Yes"

Наверх
Команда "Выполнить"

Отображать/скрыть пункт меню выполнить

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowRun:DWORD = 0 -скрыть пункт меню, 1 - показывать

Наверх
Меню "Избранное"

Показывать/скрыть пункт меню избранного Internet Explorer. Его удобно использовать, если вы работаете с Internet Explorer, если вы работаете с другим браузером, который использует свою папку избранного, этот пункт меню не работает. Пункт меню "Избранное" по умолчанию ссылается на папку Documents and Settings\%USERNAME%\Избранное.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

StartMenuFavorites:DWORD = 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Наверх
Мои документы

Эта папка по умолчанию находится в Documents and Settings\%USERNAME%\Мои документы

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowMyDocs:DWORD = 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Наверх
Мой компьютер

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowMyComputer:DWORD = 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Наверх
Мои рисунки

Эта папка по умолчанию находится в Documents and Settings\%USERNAME%\Мои документы\Мои рисунки

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowMyPics:DWORD = 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Наверх
Моя музыка

Эта папка по умолчанию находится в Documents and Settings\%USERNAME%\Моя музыка

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowMyMusic:DWORD = 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Наверх
Панель управления

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowControlPanel:DWORD = 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Наверх
Поиск

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowSearch:DWORD = 0 - не отображать пункт меню, 1 - отображать

Наверх
Разрешить перетаскивание объектов

Разрешить перетаскивание объектов с помощью мышки.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_EnableDragDrop:DWORD = 1 - разрешить перетаскивание объектов, 0 - запретить

Наверх
Сетевое окружение

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowNetPlaces:DWORD = 0 - не отображать пункт меню, 1 - отображать

Наверх
Сетевые подключения

Ссылка на данную папку находится в Панели управления.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowNetConn:DWORD= 0 - не отображать пункт меню, 1 - ссылка на папку сетевых подключений, 2 - отображать как меню "Подключение"

Наверх
Справка и поддержка

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowHelp:DWORD = 0 - не отображать пункт меню, 1 - отображать

Наверх
Отображать пункт меню Недавние документы

Эта папка по умолчанию находится в Documents and Settings\%USERNAME%\Recent

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_ShowRecentDocs:DWORD = 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Наверх
Большие значки в главном меню

Вид отображения значков в главном меню. Этот параметр влияет только на левый столбец меню в стиле XP.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_LargeMFUIcons:DWORD = 0 - маленькие значки, 1 - большие

Наверх

Классический вид меню

Примечание

Параметры меню классического типа сохраняются в строковом виде. Значение "YES" опция включена. Для выключения "NO".

Наверх
Использовать прокрутку для меню "Программы"

Если прокрутка включена, то меню все программы будет в один столбец и для навигации по нему необходимо подвести курсор мыши к краю экрана. Иначе при большом количестве установленных программ может появиться два и более столбцов.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

STRING StartMenuScrollPrograms, значение "YES" - прокрутка меню используется

Наверх
Использовать сокращенные меню

Если опция включена, то сначала появляется меню, содержащее часто используемые пункты меню.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

IntelliMenus:DWORD = 1 - использовать сокращенные меню, 0 - не использовать

Наверх
Мелкие значки в главном меню

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Start_LargeIcons:DWORD = 1 - используются большие иконки, удалите параметр, чтобы использовать маленькие значки

Наверх
Отображать команду "Выполнить"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

StartMenuRun:DWORD = 1 - отображать пункт меню, 0 - не отображать

Наверх
Отображать команду "Завершение сеанса"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

StartMenuLogoff:DWORD = 1 - отображать пункт меню, 0 - не отображать

Наверх
Отображать меню "Администрирование"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

STRING StartMenuAdminTools, значение "YES" - отображать пункт меню

Наверх
Отображать папку "Избранное"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

StartMenuFavorites:DWORD = 1 - отображать пункт меню, 0 - не отображать

Наверх
Разрешить перетаскивание объектов

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

StartMenuChange:DWORD = 1 - разрешить перетаскивание

Наверх
Раскрывать "Панель управления"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

STRING CascadeControlPanel, значение "YES" - раскрывать меню

Наверх
Раскрывать папку "Мои документы"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

STRING CascadeMyDocuments, значение "YES" - раскрывать меню

Наверх
Раскрывать папку "Мои рисунки"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

STRING CascadeMyPictures, значение "YES" - раскрывать меню

Наверх
Раскрывать папку "Принтеры"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

STRING CascadePrinters, значение "YES" - раскрывать меню

Наверх
Раскрывать "Сетевые подключения"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

STRING CascadeNetworkConnections, значение "YES" - раскрывать меню

Наверх
Задержка выпадения меню

Опция определяет задержку отображения меню. Измените значение ключа. По умолчанию это "400". Рекомендуется значение 10 или 0 мгновенно.

HKCU\ Control Panel\ Desktop MenuShowDelay = "10"

Наверх


Система

System

Содержание

System

Очистка файла подкачки перед перезагрузкой системы

Отключить встроенный отладчик Dr. Watson

Отключить запись последнего доступа к файлам (NTFS)

Отключить System Files Protection (SFC)

Включить поддержку UDMA-66 на чипсетах Intel

Включать Num Lock при загрузке

Автоматически выгружать не используемые библиотеки

Отключить слежение Windows XP за пользователем

Запускать 16-битные программы в отдельных процессах

Не отсылать в Microsoft отчеты об ошибках

Пароль при выходе из Ждущего режима

Оптимизировать системные файлы во время загрузки (boot defrag)

Сообщения об ошибках

Путь к дистрибутиву Windows

Запись консоли восстановления на жесткий диск

Автоматические обновления Windows

Windows Prefetcher сервис

Вход в систему

Показывать выполняемые команды при запуске и выходе из системы

Автоматический вход в систему без ввода пароля

Показывать сообщение при входе в систему

Не показывать имя последнего пользователя

Использовать страницу приветствия

Использовать быстрое переключение пользователей

Ускорение системы

Отключить неиспользуемые устройства в Device Manager

Отключаем индексирование

Увеличиваем производительность NTFS

Ускорить действие файловой системы

Отключить Universal Plug and Play

Office XP - отключаем посылку ошибок

Изменяем приоритет запросов на прерывание (IRQ)

Работа Windows с zip-архивами

Отключить поддержку zip-архивов

Восстановление системы

Отключить восстановление системы

Время жизни точек восстановления

Отказ системы

Автоматически перезагрузить компьютер

Записать событие в системный журнал

Отправить административное оповещение

Запись отладочной информации

Параметры работы с памятью

Не использовать файл подкачки для хранения ядра системы

Большой системный кэш

Пути к системным утилитам

Использовать свою программу дефрагментации диска

Использовать свою программу очистки системы

Использовать свою программу для архивации данных
Очистка файла подкачки перед перезагрузкой системы

Очищает файл pagefile.sys перед перезагрузкой системы. В данном файле может храниться конфиденциальная информация. Если данная опция включена, возможно значительное увеличение времени выключения компьютера.

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

ClearPageFileAtShutdown:DWORD =1 или 0

Наверх
Отключить встроенный отладчик Dr. Watson

Отключает встроенного отладчика Windows XP (программа обнаружения ошибок). Если текущим отладчиком не является Dr. Watson, он будет также отключен. Если опция выключена, то при ошибке в программе, будет выводиться соответствующее сообщение об ошибке с кнопками ОК и Отмена, при нажатии ОК - приложение завершается, а при нажатии на отмену запускается отладчик.

Примечание: можно отключить вывод окошка совсем. см. опцию Сообщения об ошибках

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug

Auto:DWORD = 1 или 0

Наверх
Не производить запись последнего доступа к файлам (только NTFS)

Ускоряет доступ к каталогам с большим количеством файлов. Данная опция работает только с дисками с файловой системой NTFS. На работу FAT32 никак не влияет. Чтобы узнать файловую систему диска, щелкните правой кнопкой на имени диска в Моем компьютере и выберите пункт меню свойства.

HKLM\SYSTEM\CurrentControlSet\Control\FileSystem

NtfsDisableLastAccessUpdate:DWORD = 1 или 0

Наверх
Отключить System Files Protection (SFC)

Отключает блокировку системных файлов Windows XP, будьте осторожны с этой опцией, т.к. системные файлы могут быть заменены старыми версиями.

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

SfcDisable:DWORD параметр может принимать различные значения= hex:ffffff9d (dec:4294967197) или 0 для включения

Наверх
Включить поддержку UDMA-66 на чипсетах Intel

HKLM\System\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0000

EnableUDMA66:DWORD = 1 или 0

Перезагрузить компьютер, чтобы изменения вступили в силу.

Наверх
Включать Num Lock при загрузке

Определяет состояние кнопки Num Lock при вводе логина и пароля. Windows XP отключает Num Lock в любом случае, даже если в BIOS состояние Num Lock находится в положении включено.

HKEY_USERS\.DEFAULT\Control Panel\Keyboard

InitialKeyboardIndicators:DWORD =2 - Num Lock включен, 0 - выключен

Наверх
Автоматически выгружать не используемые библиотеки

Разрешает Windows XP выгружать не используемые библиотеки, тем самым, освобождая память. Если наблюдается нестабильная работа системы при включенной опции, отключите её.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer

AlwaysUnloadDLL:DWORD = 1 - выгружать библиотеки, 0 - не выгружать

Наверх
Отключить слежение Windows XP за пользователем

Windows XP постоянно записывает действия пользователя, какие программы он запускал, какие открывал документы и т.д. В целях безопасности данную опцию можно отключить.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoInstrumentation:DWORD = 1 - отключить слежение, 0 - включить

Примечание: НЕ БУДЕТ СОХРАНЯТЬСЯ список часто вызываемых программ, недавние документы и пр.

Наверх
Запускать 16-битные программы в отдельных процессах

Запускает приложения для MS-DOS и Windows 3.1 в отдельных процессах. При крахе одного процесса, работа других не нарушится. Включение данной опции потребует больше памяти под 16-битные программы.

HKLM\SYSTEM\CurrentControlSet\Control\WOW

STRING DefaultSeparateVDM, значение "yes" - запускать программы в отдельных процессах, другие игнорируются

Наверх
Не отсылать в Microsoft отчеты об ошибках

С помощью данной опции можно отключить отсылку сообщений об ошибках в Microsoft. Данную опцию, при необходимости, можно более подробно настроить в Свойствах системы, вкладка Дополнительно, кнопка отчет об ошибках.

HKLM\SOFTWARE\Microsoft\PCHealth\ErrorReporting

DoReport:DWORD= 0 - Отключить отчет об ошибках, 1 - включить
ShowUI:DWORD =0 - отключить сообщения об ошибках, 1 - включить сообщения об ошибках, 2 - включить сообщения обо всех ошибках.

Вы также можете настроить некоторые другие опции (они будут работать, только если DoReport = 1 и ShowUI = 3)

IncludeKernelFaults :DWORD- Отчет об ошибках Windows XP (ошибки ядра), может принимать значения 1или 0 IncludeMicrosoftApps :DWORD- Отчет об ошибках программ от Майкрософт, может принимать значения 1 или 0
IncludeWindowsApps :DWORD- Отчет об ошибках компонентов Windows XP, может принимать значения 1 или 0

AllOrNone:DWORD - Возможность запрета отсылки сообщений об ошибках определенных приложений, значение 1 - отсылаются все, значение 0 - только выбранные приложения. Для того чтобы выбрать приложение, его необходимо добавить в
HKLM\SOFTWARE\Microsoft\PCHealth\ErrorReporting\InclusionList, а чтобы исключить в
HKLM\SOFTWARE\Microsoft\PCHealth\ErrorReporting\ExclusionList.

В данных разделах необходимо создать DWORD параметр с названием программы и значением 1, например:

HKLM\SOFTWARE\Microsoft\PCHealth\ErrorReporting\ExclusionList
"programm.exe"=dword:00000001

исключает отсылку сообщений об ошибках программы programm.exe

Наверх
Запрашивать пароль после выхода из Ждущего режима

HKCU\Software\Policies\Microsoft\Windows\System\Power

PromptPasswordOnResume:DWORD = 1 - запрашивать пароль

Наверх
Оптимизировать системные файлы во время загрузки (boot defrag)
В Windows XP есть функция BootDefrag (или BootOptimize), суть которой заключается в следующем. Поскольку дефрагментация и оптимизация расположения на диске файлов, нужных системе во время загрузки, решающим образом влияет на весь процесс загрузки ОС, а пользователю часто лениво самому запускать дефрагментатор (не то чтобы даже часто, а почти всегда), то система теперь умеет сама - без участия оператора - оптимизировать эти файлы, причем не как ей вздумается, а основываясь на данных все тех же файлов notosboot-B00DFAAD.pf и layout.ini. Правда, происходит автоматическая дефрагментация при простое системы - если пользователь 10-30 минут после загрузки ОС не производил никаких операций. А потому может случиться так, что на вашей интенсивно используемой системе файлы окажутся не оптимизированы. Проверить, произошла ли оптимизация, можно, заглянув в реестр - если в разделе
HKLM\ SOFTWARE\Microsoft\ Dfrg\BootOptimizeFunction стоит параметр "OptimizeComplete"="Yes",
то дефрагментация была произведена. Если же этого пока не случилось, то просто перегрузите ПК и оставьте его минут на тридцать в одиночестве - Windows сама все сделает, и ускорение следующей загрузки будет заметно даже на глаз.

Только запомните, что перед оптимизацией ПК со свежеустановленной ОС должен иметь в своем багаже хотя бы три перезагрузки для накопления нужных данных. Штатный дефрагментатор Windows XP не отменяет эту оптимизацию.

Если же вы сомневаетесь, работает ли вообще у вас эта функция, или хотите ее отключить, то проверьте в реестре наличие параметра, включающего BootDefrag: HKLM\SOFTWARE\Microsoft\Dfrg\BootOptimizeFunction

STRING Enable, значение "Y" - оптимизация включена, "N" - выключена

Наверх
Сообщения об ошибках

Данный параметр задает, какие сообщения об ошибках будут выводиться на экран

HKLM\SYSTEM\CurrentControlSet\Control\Windows

ErrorMode:DWORD может принимать следующие значения

    • 0 - Показывать все ошибки (По умолчанию)
    • 1 - Только ошибки приложений, системные отключены
    • 2 - Отключить все сообщения об ошибках

Наверх
Путь к дистрибутиву Windows

Windows не дает стандартными способами изменить путь к дистрибутиву, вы можете изменить.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup

STRING SourcePath, полный путь к дистрибутиву, например F:\ или C:\DISTRIB\WINXP\

Наверх
Переписать консоль восстановления на жесткий диск

Консоль восстановления Windows находится на CD-ROM с Windows XP, имеется возможность переписать её на жесткий диск, и при загрузке вы сможете выбрать: загружать XP или консоль восстановления. Перед тем как щелкнуть по ОК, вставьте компакт-диск с дистрибутивом Windows XP.

Пуск- Выполнить= %путь к дистрибутиву%\i386\winnt32.exe /cmdcons

После установки консоли, на системном диске появится папка cmdcons размером 7-8 Мб, а в boot.ini появиться новая строка

...\CMDCONS\BOOTSECT.DAT="Microsoft Windows XP Recovery Console" /cmdcons

Выполните Пуск->Выполнить->msconfig перейдите на вкладку boot.ini и убедитесь, что появился новый пункт меню.

Наверх
Автоматические обновления Windows

Управление автоматическим обновлением Windows XP. Также данную опцию можно настроить следующим способом: Панель управления - Система - Автоматическое обновление.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update

AUOptions:DWORD
AUState :DWORD

Windows XP использует следующие значения:

Отключить автоматические обновления

AUOptions = 1
AUState = 7

Уведомлять о возможности загрузки обновлений

AUOptions = 2
AUState = 2

Загружать обновления, затем уведомлять о готовности к установке

AUOptions = 3 и другие значения
AUState = 2

Наверх
Windows Prefetcher сервис

В Windows XP есть специальный Prefetcher Service, его задача уменьшить время запуска приложений и время загрузки системы. Файлы, используемые этим сервисом, находятся в папке %systemroot%\prefetch. В ней же находится информация о запускаемых программах. Если Вы хотите узнать какие программы запускаются на Вашем компьютере, очистите указанную папку и перезагрузите систему. Вы увидите какие программы оставили там свои файлы. Если там появились файлы не знакомых Вам программ, значит у Вас домовые. C помощью данной опции Вы можете управлять этим сервисом.

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters

EnablePrefetcher:DWORD= параметр может принимать следующие значения:

0 - отключить сервис

1 - упреждающая выборка приложений

2 - упреждающая выборка приложений, запускаемых во время загрузки системы

3 - включены обе упреждающие выборки (пп. 1 и 2) используется Windows XP по умолчанию

Ускорить загрузку приложений без реестра. Для этого достаточно добавить в свойствах программы ключ «/prefetch:1». Правой клавишей мыши нажмите на ярлыке нужной программы и выберите пункт «Свойства». В строке «Объект» после указания пути к файлу добавить «/prefetch:1» (пробел перед ключом обязателен).

Перезагрузите компьютер.

Наверх

Вход в систему

Показывать выполняемые команды при запуске и выходе из системы

Показывает информацию о выполняемых процессах во время загрузки системы. Поможет быстро выяснить, на запуск чего система тратит много времени и если возможно, отключить не нужные сервисы.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

verbosestatus:DWORD значение 1 - показывать, 0 - стандартная загрузка

Наверх
Автоматический вход в систему без ввода пароля

Позволяет автоматически входить в систему без выбора имени и ввода пароля. Также автоматический вход в систему можно включить следующим способом: Пуск - Выполнить - набрать "control userpasswords2", в появившемся окне снять галочку с "Требовать ввод имени и пароля", после нажатия на ОК появится окно, где нужно указать пользователя и пароль. Если автоматический вход включен, то его можно обойти, удерживая клавишу SHIFT при загрузке компьютера.

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

STRING AutoAdminLogon, принимает значение "1" - Автоматический вход включен, "0" - выключен.

STRING DefaultUserName, имя пользователя, которое используется при автоматическом входе в систему
STRING DefaultUserPassword, пароль пользователя
STRING DefaultDomainName, домен по умолчанию, используется для компьютеров в сети

Примечание: пароль храниться в реестре в незашифрованном виде.

Если при загрузке компьютера отключен показ предыдущего имени (параметр DontDisplayLastUserName) автоматический вход в систему работать не будет!

Если опция сбрасывается после перезагрузки, создайте пароль для своей учетной записи (Панель управления - Учетные записи пользователей) или используйте апплет control userpasswords2 (см. выше)

Наверх
Показывать сообщение при входе в систему

Показывает сообщение перед вводом пароля для входа в систему. Чтобы войти в систему необходимо нажать на кнопку OK.

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

STRING LegalNoticeCaption, заголовок окна
STRING LegalNoticeText, текст сообщения

Наверх
Не показывать имя последнего пользователя

Windows XP по умолчанию подставляет имя последнего пользователя использующего компьютер. Чтобы это отменить, используйте данную опцию.

HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System

DontDisplayLastUserName:DWORD = 1 - убрать имя пользователя

Наверх
Использовать страницу приветствия

Экран приветствия обеспечивает наиболее быстрый и простой вход в систему. Если опция выключена, используется классический вход в систему (более безопасно).

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

LogonType:DWORD = 1 - используется страница приветствия, 0 - используется классический вход в систему

Наверх
Использовать быстрое переключение пользователей

Если опция включена, то при переключении на другого пользователя, программы текущего пользователя будут продолжать работать. Иначе, программы будут автоматически выключатся, когда пользователь выходит из системы, и со следующим пользователем компьютер будет работать быстрее.

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

AllowMultipleTSSessions:DWORD = 1 - использовать быстрое переключение пользователей

Наверх

Ускорение системы

Отключить неиспользуемые устройства в Device Manager

Например, если Вы не имеете периферийных устройств, подключенных к внешним портам компьютера (USB или COM), Вы можете заблокировать их, что заметно повлияет на скорость загрузки.

Control Panel -> System -> Hardware tab -> device manager

Наверх
Отключаем индексирование

Делается это следующим образом. Открываете "Мой компьютер", клик правой клавишей мыши на иконке жесткого диска и выбираете "Свойства". В самом низу открывшегося окна вы увидите галочку напротив пункта "Разрешить индексирование диска для быстрого поиска". Вот эту самую галочку и следует убрать. После нажатия кнопок "Применить" или "ОК" появится новое окно, в котором вам будет задан вопрос, применить ли выбранные атрибуты только к текущему диску или и ко вложенным файлам и папкам тоже. Окончательное исполнение данной процедуры может занять пару минут (смотря сколько у вас файлов на диске), но в результате вы сможете наслаждаться немного более быстрой работой ОС. Естественно, что работает это только для дисков с файловой системой NTFS.

Наверх
Увеличиваем производительность NTFS

Первое, отключим создание коротких имен. По-умолчанию NTFS генерирует имена согласно старому правилу 8.3 для совместимости с MS-DOS и Windows 3.x клиентами. Если в вашей сети таких клиентов не наблюдается, эту функцию можно отключить, поменять значение ключа в разделе:
HKLM\ SYSTEM\CurrentControlSet\ Control\Filesystem
NtfsDisable8dot3NameCreation на 1.

Вторым шагом мы отключим запись даты последнего обновления файла. По-умолчанию NTFS каждый раз при изменении любого файла записывает дату и время его последнего обновления. На больших разделах NTFS это может очень существенно влиять на производительность файловой системы. В разделе:
HKLM\SYSTEM\CurrentContolSet\Control\Filesystem
NtfsDisableLastAccessUpdate :REG_DWORD= 1.

Если ключ не существует, его надо создать.

Теперь отведем достаточно места для главной файловой таблицы. Добавить в системный раздел реестра:
HKLM\ SYSTEM\CurrentControlSet\ Control\FileSystem
ключ NtfsMftZoneReservation типа REG_DWORD.
Когда вы это сделаете, система зарезервирует место на диске для главной таблицы размещения файлов. Для чего это нужно? Да для того, чтобы взять под контроль процесс роста этой таблицы. Если на ваших разделах NTFS мало файлов, но они большого размера, то наилучшим значением созданного параметра будет 1 (по-умолчанию). Обычно оптимальным значением является 2 или 3. А 4 (максимальное значение) следует использовать только в случае, если у вас на диске количество файлов огромно (десятки тысяч). Тем не менее, со значениями больше 2 следует экспериментировать осторожно, так как в этом случае система может отхватить для таблицы размещения файлов немаленький кусок дискового пространства.

Наверх
Ускорить действие файловой системы

(если позволяет оперативная память) можно увеличив параметр типа DWORD IoPageLockLimit в разделе
HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management от заданных по умолчанию 512 КБ до 4 МБ и более.

Этот параметр представляет максимальное число байт, которые могут быть блокированы для операций I/O. Когда значение параметра равно 0, то система использует встроенный алгоритм определения необходимой памяти и использует объем 512 КБ. Установка максимального значения должна основываться на объеме памяти в Вашей системе. Так, если Вы имеете 128Mb памяти, установите шестнадцатеричное значение 4000, если 256Mb – 10000, и если 512Mb – 40000.

Установки вступят в силу после перезагрузки системы

Наверх
Отключить Universal Plug and Play

Эта брешь в безопасности всем известна. Чтобы отключить Universal Plug and Play, зайдите в Панель управления- Установка и удаление программ- Установка компонентов Windows. В окошке выберите Сетевые службы, далее внизу Состав, в окошке снимите галочку с Универсальный Plug and Play .

Наверх
Office XP - отключаем посылку ошибок

Office XP имеет невероятно нужную функцию - при возникновении ошибки, он пытается отправить отчет о ней в Microsoft. Если вам это надоело, то функцию эту можно отключить. Ниже я привожу текст REG-файла, который вам в этом поможет:

Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\ Policies\Microsoft\Office\10.0\Common]
"DWNeverUpload"=dword:00000001
"DWNoExternalURL"=dword:00000001
"DWNoFileCollection"=dword:00000001
"DWNoSecondLevelCollection"=dword:00000001
[HKEY_USERS\.Default\Software\ Policies\Microsoft\Office\10.0\Common]
"DWNeverUpload"=dword:00000001
"DWNoExternalURL"=dword:00000001
"DWNoFileCollection"=dword:00000001
"DWNoSecondLevelCollection"=dword:00000001

Наверх
Изменяем приоритет запросов на прерывание (IRQ) - сделать просто необходимо.

Итак, последний совет по увеличению производительности– изменение приоритета запросов на прерывание. Для тех, кто не знаком с этим понятием, напомним, что каждому компоненту Вашего компьютера назначается номер прерывания IRQ для доступа к системной шине. Если увеличить приоритет CMOS памяти и часов реального времени, то можно увеличить производительность всех элементов системной платы. Для начала необходимо определить, для какого устройства Вы хотите увеличить производительность. Затем, Вы должны определить, какой запрос на прерывание использует это устройство. Для этого необходимо открыть Control Panel a System (Вы так же можете воспользоваться комбинацией клавиш Windows+Break). Нажмите на закладку ’Hardware’ и нажмите кнопку ’Device Manager’. Теперь правой кнопкой мышки войдите в свойства выбранного устройства, и выберите закладку ’Resources’.

Здесь Вы можете увидеть, какой номер IRQ используется выбранным устройством. Запомните номер прерывания и закройте все окна. Теперь запустите RegEdit. Найдите раздел HKLM/ System/CurrentControlSet/ Control/PriorityControl. Создайте новый DWORD ключ IRQ#Priority (где ’#’ номер IRQ), и установите его в 1. Например, в нашем случае IRQ нашего System CMOS равен 08. Поэтому мы создали ключ

IRQ8Priority.

Теперь, после перезагрузки, Вы должны обратить внимание на увеличение производительности выбранного компонента. Мы рекомендовали бы Вам именно CMOS, поскольку он увеличивает производительность все системной платы. Так же Вы можете создать множественные приоритеты IRQ, однако это не очень эффективно и может привести к неустойчивой работе. Для удаления настройки, просто удалите созданный ключ.

Наверх

Работа Windows с zip-архивами

Отключить поддержку Windows XP zip-архивов

По умолчанию Windows XP считает zip-файлы папками - это удобно, если у вас быстрый компьютер. На медленных компьютерах можно отключить эту возможность. Также Windows не будет искать файлы в архивах, что значительно ускорит поиск.

Пуск- Выполнить

regsvr32 /u /s zipfldr.dll, а для включения regsvr32 /s zipfldr.dll

Параметр /u отключает поддержку, /s не выдаются сообщения

Наверх

Восстановление системы

Полностью отключить восстановление системы

Для восстановления системы Windows XP тратит довольно много места, даже не смотря на то, что многие пользователи не пользуются данной возможность или даже не знают что это такое. Если вы не пользуетесь восстановлением системы, можете отключить её, также компьютер не будет тратить время на создание очередных "точек восстановления". Данную опцию также можно включить/отключить в Свойствах системы на вкладке "Восстановление системы".

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SystemRestore

DisableSR:DWORD = 1 восстановление системы отключено, 0 - включено

Наверх
Время жизни точек восстановления

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SystemRestore

RPLifeInterval:DWORD время жизни точек восстановления в секундах.

Вы можете задать количество мегабайт, которые использует восстановление системы на каждом диске через Свойства системы->Восстановление системы.

Наверх

Отказ системы

Автоматически перезагрузить компьютер

Майкрософт всегда думает о пользователях, не прошёл мимо и факт зависания компьютера. Теперь вам не надо тянуться к кнопке Reset, компьютер перезагрузиться самостоятельно, если произойдет непоправимая ошибка. Данную опцию можно настроить в Свойствах системы, вкладка Дополнительно, раздел Загрузка и восстановление.

HKLM\SYSTEM\CurrentControlSet\Control\CrashControl

AutoReboot: DWORD =1 - перезагружать компьютер, 0 - не перезагружать

Наверх
Записать событие в системный журнал

Производит запись в журнал об ошибке системы, если компьютером пользуется несколько человек и вам интересно, когда произошло зависание компьютера, включите данную опцию, иначе имеет смысл её отключить.

HKLM\SYSTEM\CurrentControlSet\Control\CrashControl

LogEvent:DWORD= 1 - вести запись журнала, 0 - не вести

Наверх
Отправить административное оповещение

Оповещение администраторов системы при возникновении ошибки.

HKLM\SYSTEM\CurrentControlSet\Control\CrashControl

SendAlert: DWORD = 1 - отправлять сообщение администраторам, 0 - не отправлять

Наверх
Запись отладочной информации

Данную опцию следует включать, если вы гений в двоичных кодах :) Для всех остальных рекомендуется отключить данную опцию, т.к. при непоправимой ошибке система может довольно долго записывать отладочную информацию и её размер может быть равен размеру оперативной памяти, в зависимости от выбранных деталей отчета.

HKLM\SYSTEM\CurrentControlSet\Control\CrashControl

CrashDumpEnabled:DWORD = 0 - запись не ведется, 1 - Малый дамп памяти (64КБ), 2 - Дамп памяти ядра, 3 - Полный дамп памяти (создание файла, равного размеру оперативной памяти)

Наверх

Параметры работы с памятью

Не использовать файл подкачки для хранения ядра системы

Если опция включена, то Windows XP для ускорения производительности оставляет исполняемый код ядра резидентным в памяти, вместо вытеснения его, по мере необходимости, в виртуальную память на диск. Используйте данную опцию при наличии не менее 256 МБ оперативной памяти. Рекомендуется 512 МБ и более.

Примечание: Не применять эту опцию, если используете "Ждущий" (standby) или "Спящий" (hibernate) режимы.

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

DisablePagingExecutive:DWORD= 1 - Не использовать файл подкачки для хранения ядра системы, 0 - использовать

Наверх
Большой системный кэш

Используйте данную опцию, если у вас 512 Мб памяти или больше. Данная опция увеличит производительность Windows XP.

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

LargeSystemCache:DWORD =1 - использовать, 0 - не использовать

Наверх

Пути к системным утилитам

Использовать свою программу дефрагментации диска

Вы можете задать свою программу дефрагментации диска, она будет вызываться, если вы в свойствах диска, на вкладке Сервис нажмёте на кнопку "Выполнить дефрагментацию...

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ MyComputer\DefragPath

EXPAND STRING (По умолчанию), система использует следующую командную строку %systemroot%\system32\dfrg.msc %c:
С помощью параметра %с передается имя диска.

Наверх
Использовать свою программу очистки системы

По умолчанию Windows XP использует утилиту для очистки системы - CleanUP, вы можете заменить её на свою.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ MyComputer\cleanuppath

EXPAND STRING (По умолчанию), система использует следующую командную строку %SystemRoot%\system32\cleanmgr.exe /D %c
С помощью параметра %с передается имя диска. Для CleanUp если не задан параметр /D, то параметр %с игнорируется и система предлагает пользователю выбрать диск самостоятельно.

Наверх
Использовать свою программу для архивации данных

По умолчанию Windows XP использует утилиту для архивации данных - BackUP, вы можете заменить её на свою.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ MyComputer\BackupPath

EXPAND STRING (По умолчанию), система использует следующую командную строку %SystemRoot%\system32\ntbackup.exe

Наверх


Explorer

Настройка Explorer

Содержание

Проводник

Горячие клавиши

Отключить сообщение о недостатке свободного места на диске

Анимация при сворачивании и разворачивании окон

Запускать окна Проводника в отдельном процессе

Автоматически перезапускать Проводник при ошибках

Удалить стрелки у ярлыков

Не добавлять "Ярлык для..." для создаваемых ярлыков

Отключить автозапись состояния окон проводника

Не показывать папки документов в "Моем компьютере"

Отображать содержимое окна при перетаскивании

Размер кэша для хранения иконок

Количество цветов для отображения иконок

Сглаживать неровности экранных шрифтов

Частота мерцания курсора

Использовать свой редактор для открытия файлов неизвестного типа

Контекстное меню проводника

Добавить пункт меню "Копировать в папку..."

Добавить пункт меню "Переместить в папку..."

Пункт меню "Отправить"

Удалить пункт из контекстного меню папок

Добавить новый пункт в контекстное меню папок

Добавить командную строку в контекстное меню папок

Изменить диалоговое окно

Рабочий стол

Запретить рабочий стол

Запретить Active Desktop

Скрыть вкладки "Тема" и "Оформление" в свойствах экрана

Скрыть вкладку Рабочий стол

Скрыть вкладку Заставка

Скрыть вкладку Параметры

Номер версии

Восстановление окон по завершению работы

Изменение обоев

Панель задач

Показывать всплывающие подсказки

Автоматически скрывать иконки в трее

Скрыть все значки в трее

Группировать сходные кнопки на панели задач

Мигание кнопок на панели задач

Число миганий кнопки на панели задач
Горячие клавиши
Работу на < дереве > Проводника можно ускорить, используя клавиатуру.
Если в Проводнике (а также большинстве подобных программ) на < дереве > нажать клавишу <Стрелка═вправо> ≈ развернётся свёрнутая ветвь подкаталогов текущего каталога. При этом перемещения на подкаталоги не происходит, для этого нужно нажать <Стрелка═вниз>, либо снова <Стрелка═вправо>. <Стрелка═влево> сворачивает развёрнутую ветвь. А если подкаталогов нет, то отправляет на уровень вверх. Очень удобно, когда каталогов много, и мышью до предыдущего уровня без прокрутки не достать.
При нажатии символьной клавиши выполняется быстрый переход к папке, название которой начинается с этого символа. Если таких папок несколько, то происходит последовательный переход от одной к другой. Правило действует в обоих (ENG/РУС) регистрах.
Если во время перетаскивания файла в мусорную корзину (или выбора пункта меню "удалить") Вы будете держать нажатой клавишу <Shift>, то файл будет удалён, а не помещён в корзину.
Нужно иногда скопировать всю информацию с одной дискеты на другую. А дисковод-то обычно один... Чтобы не записывать файлы на винчестер, которые затем надо с него удалять, можно использовать такую возможность как "Копирование дискеты" (вызывается, например, нажатием правой кнопки мыши на иконку дисковода в Проводнике).
Если Вам требуется открыть файл с помощью программы, отличной от той, которая сопоставлена данному типу файлов, то щёлкните по нему правой кнопкой мыши, удерживая нажатой клавишу <Shift>. В появившемся контекстном меню Вы увидите пункт "Открыть с помощью..." ("Open with...").
Double-click по активной панели окна (синяя полоска сверху) меняет его режим с полноэкранного на окно и наоборот.
Если дважды щёлкнуть по файлу, удерживая нажатой клавишу <Shift>, то программа запустится минимизированной.
Чтобы быстро получить доступ к свойствам объекта, нажмите клавишу <Alt> и сделайте двойной щелчок кнопки мыши на значке объекта.

Наверх
Отключить сообщение о недостатке свободного места на диске

Не выдавать сообщение о недостатке места на диске. Имеет смысл использовать данную опцию на дисках малого размера.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoLowDiskSpaceChecks:DWORD = 1 - сообщение отключено, 0 - включено

Наверх
Анимация при сворачивании и разворачивании окон

На медленном компьютере рекомендуется отключить данную опцию. Изменения вступят в силу только после перезагрузки.

HKCU\Control Panel\Desktop\WindowMetrics

STRING MinAnimate= 1 - анимация включена, 0 - выключена.

Наверх
Запускать окна Проводника в отдельном процессе

Включение данной опции позволяет запускать окна Проводника в разных процессах, это увеличит стабильность системы, но требует больше памяти.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

SeparateProcess: DWORD =1 - окна проводника запускаются в различных процессах, 0 - используется один процесс

Наверх
Автоматически перезапускать Проводник при ошибках

Очень удобная опция. При крахе Проводник будет сам перезапускаться и не надо вызывать диспетчер задач, чтобы его запустить.

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon

AutoRestartShell:DWORD= 1 - Проводник автоматически перезапускается, 0 - не перезапускается

Наверх
Удалить стрелки у ярлыков

Удаляет стрелки в левом нижнем углу у ярлыков.

HKLM\SOFTWARE\Classes\lnkfile - ярлыки Windows XP
HKLM\SOFTWARE\Classes\piffile - ярлыки DOS программ

STRING IsShortcut, значение "1" - На ярлыке присутствуют стрелки, удаление этого параметра - отключает стрелки на ярлыках

Наверх
Не добавлять "Ярлык для..." для создаваемых ярлыков

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer

BINARY link, значение hex:00,00, 00,00 - не добавлять

Примечание: после включения опции не следует создавать ярлыки до перезагрузки компьютера, иначе Windows изменит значение параметра.

Наверх
Отключить автозапись состояния окон проводника

Отключает запись положения и размеров окон проводника. Чтобы изменения вступили в силу необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

BINARY NoSaveSettings, значение hex: 01,00,00,00 - отключить автозапись, удаление значения - включить

Наверх
Не показывать папки документов в "Моем компьютере"

Не показывать папки "Мои документы", "Общие документы" и т.д. Для удаления папок из "Моего компьютера" необходимо удалить ключ:

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\ NameSpace\DelegateFolders\{59031a47-3f72-44a7-89c5-5595fe6b30ee}

Чтобы вернуть папки на место, создайте этот ключ заново.

Наверх
Отображать содержимое окна при перетаскивании

Если данная опция отключена, то вместо самого окна передвигается только его контур. Отключите эту опцию, если это очень загружает систему. Чтобы изменения вступили в силу необходимо перезагрузиться.

HKCU\Control Panel\Desktop

STRING DragFullWindows, значение "1" - отображать содержимое, "0" - отображать только контур.

Наверх
Размер кэша для хранения иконок

Windows XP кэширует иконки для быстрого показа, Вы можете изменить размер кэша.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer

STRING Max Cached Icons, значение - количество иконок в кэше. По умолчанию используется значение "512".

Наверх
Количество цветов для отображения иконок

HKCU\Control Panel\Desktop\WindowMetrics

STRING Shell Icon BPP значения

    • "16" - Среднее качество (16 бит)

    • "24" - Высокое качество (24 бит)

    • "32" - Самое высокое качество (32 бит)

Наверх
Сглаживать неровности экранных шрифтов

Эта установка делает экранные шрифты более читабельными. Есть два режима сглаживания шрифтов.

    • 0 - Не использовать сглаживание

    • 1 - Стандартное сглаживание

    • 2 - Сглаживание Clear Type

Первый из них называется Standard. Для того, чтобы его использовать, сделайте два изменения в реестре. Строковое значение ключа измените с 0 на 2:
HKCU\ Control Panel\ Desktop
FontSmoothing="2"
числовое значение ключа с 0 на 1:
HKCU\ Control Panel\ Desktop
FontSmoothingType=DWORD:1
Стандартный режим сглаживания рекомендован для обычных ЭЛТ-экранов настольных мониторов. Режим Clear Type предназначен для ноутбуков.

Для режима сглаживания, который называется Clear Type, значение последнего ключа установите равным 2:
HKCU\ Control Panel\ Desktop
FontSmoothingType=DWORD:2

Наверх
Частота мерцания курсора

Частота мерцания курсора при вводе текста. Также эту возможность можно настроить в Панели управления->Клавиатура

HKCU\Control Panel\Desktop

STRING CursorBlinkRate, чем больше число, тем больше промежуток между мерцанием курсора, значение "-1" - курсор не мерцает. Можно выставить значения в диапазоне от 200 до 1200, если значение больше, то выставляется значение "-1".

Наверх
Использовать свой редактор для открытия файлов неизвестного типа

Используйте эту опцию, чтобы добавить блокнот в контекстное меню для того, чтобы открывать в нем файлы неизвестных системе типов.

Для этого добавьте в ветку HKEY_LOCAL_MA-CHINE\ SOFTWARE\ Classes\ Unknown\ shell\ подраздел Notepad, создайте в нем подраздел Command и присвойте ему следующее значение по умолчанию:
[HKEY_LOCAL_MACHINE\ SOFTWARE\ Classes\ Unknown\ shell\ Notepad\ Command]
@="notepad.exe %1"
А также измените указанное значение по умолчанию с "openas" на "Notepad":
[HKEY_LOCAL_MACHINE\ SOFTWARE\ Classes\ Unknown\ shell]
@="Notepad"

Наверх

Контекстное меню проводника

Добавить пункт меню "Копировать в папку..."

С помощью данного меню можно быстро скопировать папку или файл в любое место.

HKCR\AllFilesystemObjects\shellex\ContextMenuHandlers\Copy To

Для появления пункта меню, необходимо указать параметр по умолчанию
{C2FBB630-2971-11D1-A18C-00C04FD75D13},

чтобы удалить пункт меню, удалите ключ.

Наверх
Добавить пункт меню "Переместить в папку..."

С помощью данного меню можно быстро переместить папку или файл в любое место.

HKCR\AllFilesystemObjects\shellex\ContextMenuHandlers\Move To

Для появления пункта меню, необходимо указать параметр по умолчанию
 {C2FBB631-2971-11D1-A18C-00C04FD75D13}, чтобы удалить пункт меню, удалите ключ.

Наверх
Пункт меню "Отправить"

Позволяет быстро отправлять объекты проводника различным приложениям, например, почтовому клиенту или редактору текстовых файлов.

HKCR\AllFilesystemObjects\shellex\ContextMenuHandlers\Send To

Для появления пункта меню, необходимо указать параметр по умолчанию
 {7BA4C740-9E81-11CF-99D3-00AA004AE837}, чтобы удалить пункт меню, удалите ключ.

Наверх
Удалить пункт из контекстного меню папок

Некоторые приложения без вашего желания добавляют свои пункты в контекстное меню папок, что делает меню большим и не удобными.

HKLM\SOFTWARE\Classes\Directory\shell - в данном разделе храниться информация о контекстном меню папок.

Наверх
Добавить новый пункт в контекстное меню папок

Добавляет новый пункт в контекстное меню папок.

HKLM\SOFTWARE\Classes\Directory\shell

В этом разделе необходимо создать новый ключ, например:

HKLM\SOFTWARE\Classes\Directory\shell\Far Manager

В значении по умолчанию укажите название программы, например "Far manager", далее необходимо создать подключ с названием "command", например:

HKLM\SOFTWARE\Classes\Directory\shell\Far Manager\command

В значении по умолчанию укажите путь к файлу с параметрами при необходимости, например:

c:\program files\far\far.exe %1

Наверх
Добавить командную строку в контекстное меню папок

Эта опция используется, чтобы добавить командную строку в контекстные меню всех папок. Для этого в ветку HKEY_LOCAL_MACHINE\ SOFTWARE\ Classes\ Directory\ shell добавьте подраздел Command Prompt, в нем же создайте еще один подраздел Command и присвойте ему следующее значение по умолчанию:
HKEY_LOCAL_MACHINE\ SOFTWARE\ Classes\ Directory\ shell\ Command Prompt\ Command
@="Cmd.exe /k cd "%1""

Наверх
Изменить диалоговое окно

Изменение кнопок быстрого доступа к файлам. Максимум кнопок может быть 5.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\comdlg32\PlacesBar

Place0:DWORD или STRING
Place1:DWORD или STRING
Place2:DWORD или STRING
Place3:DWORD или STRING
Place4:DWORD или STRING

Если параметр имеет значение типа STRING, то в нем хранится путь к папке, а если DWORD, то Windows XP сама выбирает папку в зависимости от значения параметра.

0 - Рабочий стол
5 - Мои документы
6 - Избранное
8 - Недавние документы
13 - Моя музыка
14 - Мои видеозаписи
17 - Мой компьютер
18 - Сетевое окружение
36 - Windows
37 - System32
38 - Program files
39 - Мои рисунки
40 - Documents & Settings\UserName
46 - Общие документы

также есть возможность задавать любую папку, в этом случае используется значение типа STRING.

Наверх

Рабочий стол

Запретить рабочий стол

Скрывает иконки с рабочего стола и делает не доступным контекстное меню.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoDesktop:DWORD = 1 - запрещает рабочий стол

Наверх
Запретить Active Desktop

Запрещает установку рабочего стола в виде веб-страницы.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoActiveDesktop:DWORD = 1 - запрещает Active Desktop

Наверх
Скрыть вкладки "Тема" и "Оформление" в свойствах экрана

Запретить изменение тем и оформления окон Windows XP

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

NoDispAppearancePage:DWORD = 1 - скрыть вкладки

Наверх
Скрыть вкладку "Рабочий стол"

Скрывает вкладку Рабочий стол в свойствах экрана

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

NoDispBackgroundPage:DWORD = 1 - скрыть вкладку

Наверх
Скрыть вкладку "Заставка"

Скрывает вкладку Заставка в свойствах экрана

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

NoDispScrSavPage:DWORD = 1 - скрыть вкладку

Наверх
Скрыть вкладку "Параметры"

Скрывает вкладку Параметры в свойствах экрана

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

NoDispSettingsPage:DWORD = 1 - скрыть вкладку

Наверх
Номер версии

Измените значение этого ключа с 0 на 1, и в правом нижнем углу экрана будет показываться версия
HKEY_CURRENT_USER\ Control Panel\ Desktop
PaintDesktopVersion=DWORD:1

Наверх
Восстановление окон по завершению работы

Опция определяет, восстановит Explorer или нет окна, которые были открыты, когда работа с Windows была завершена. Если вы хотите, чтобы он этого не делал, добавьте следующий ключ:
HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explorer
NoSaveSettings=hex:01,00,00,00

Наверх
Изменение обоев

Это возможность для любителей различных украшательств изменить обои, показываемые до того, как какой-нибудь пользователь войдет в систему. Измените строковое значение с "(None)" на путь и имя графического файла:HKEY_USERS\ .DEFAULT\ Control Panel\ Desktop
Wallpaper="c:\ my_wallpaper.bmp"

Наверх

Панель задач

Показывать всплывающие подсказки

В Windows XP на панели задач существует два типа всплывающих подсказок - краткие и с дополнительными сведениями. В краткой показывается только название программы, а в "полной версии" некоторые дополнительные сведенья, их содержимое зависит от программы. Пример: при включенной опции монитор DrWeb'a (SpIDer Guard) показывает статистику проверок фалов, а при выключенной опции только название программы. Иногда "полные версии" всплывающих подсказок выводятся самостоятельно, без наведения мыши, чтобы сообщить пользователю, о каком либо событии. Значение отсутствует при установке Windows.

Примечание: Данная опция никак не влияет на всплывающую подсказку к кнопке Пуск.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

EnableBalloonTips:DWORD = 1 (или удаление параметра) - показывать дополнительные сведенья, 0 - не показывать

Наверх
Автоматически скрывать иконки в трее

Очень удобная опция, если у вас постоянно находится много иконок программ в системном трее. Также эту опцию можно настроить, щелкнув правой кнопкой мыши на панели задач и выбрав в контекстном меню пункт Свойства. При установке Windows, параметр отсутствует.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer

EnableAutoTray:DWORD = 1 (или удаление параметра) - скрывать иконки, 0 - отображать

Наверх
Cкрыть все значки в трее

Убирает значки всех приложений в системном трее. Если опция включена, то в свойствах "Панели задач и меню Пуск" раздел "Область уведомлений" будет недоступен.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoTrayItemsDisplay:DWORD = 1 - скрыть все значки

Наверх
Группировать сходные кнопки на панели задач

По умолчанию Windows XP группирует подобные кнопки на панели задач. При щелчке на эту кнопку появится меню, в котором можно выбрать программу. Также эту опцию можно настроить, щелкнув правой кнопкой мыши на панели задач и выбрав в контекстном меню пункт Свойства. Значение отсутствует при установке Windows.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

TaskbarGlomming:DWORD = 1 (или удаление значения) - группировать окна, 0 - не группировать

Следующий параметр влияет на порядок группировки приложений:

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

TaskbarGroupSize:DWORD может принимать следующие значения:

    • 0 - группировать окна, начиная со "старых" окон, когда на панели задач мало места

    • 1 - группировать окна, начиная с "новых" окон, когда на панели задач мало места

    • 2 - группировать в любом случае, если есть не менее двух подобных окон

    • 3 - группировать в любом случае, если есть не менее трех подобных окон и т.д.

Примечание: значение 0 используется по умолчанию.

Наверх
Время задержки

Когда программа требует ввода данных, она может либо "выскочить" наверх, либо мигать иконкой в панели задач. Данный параметр регулирует время задержки до "перехвата" фокуса в миллисекундах.

HKCU\Control Panel\Desktop

ForegroundLockTimeout:DWORD = 0 - немедленно, по умолчанию Windows XP использует 200 секунд (200000 миллисекунд)

Наверх
Число миганий кнопки на панели задач

HKCU\Control Panel\Desktop

ForegroundFlashCount:DWORD = 0 - заставит мигать кнопку бесконечно, по умолчанию Windows XP использует значение 3

Наверх


Настройка Интернет

В задании большинства параметров, освещаемых в данном разделе, возможны варианты : ваше значение; значение, рекомендованное для DialUp, то есть модемных соединений; для соединений с помощью DSL\Cable модемов; и для линий типа T1 и выше.
Когда у вас появится выделенная линия типа T1, то будете ли вы копаться в реестре? По той же причине пропущено рассмотрение некоторых параметров. По умолчанию большинство нижеописанных ключей не содержатся в реестре, поэтому их нужно будет добавить. Для отмены действия ключа, если нет специальных оговорок, будет необходимо изменить его значение на обратное — чаще с 1 на 0 — либо просто удалить ключ из реестра.

Настройка Интернет

Максимальный размер передаваемого блока данных Maximum Transmission Unit Size

Здесь нам предоставляется возможность задать наибольший размер передаваемого блока данных - Maximum Transmission Unit. MTU - это самое большое количество данных, которые могут быть переданы по сети в одном физическом фрейме. Если пакет IP большего чем MTU, то произойдет фрагментация. Эта фрагментация может удвоить время, которое требуется, чтобы послать единственный пакет.

Для изменения размера MTU следует добавить новый параметр и установить желаемое значение. По-умолчанию оно равно 1500 в десятичной системе или 0x5DC в шестнадцатеричной. Для модемных соединений рекомендовано значение 0x240. Однако это ещё не всё, смотрите параметр "Enable MTU Auto Discovery" описанный немного ниже.

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
MTU =dword:576

Для DSL, кабельных модемов, T1 и выше: 1500
Максимальный размер окна для приёма пакетов Windows TCP/IP Window Size

Этот параметр определяет максимальный размер окна для приёма TCP пакетов, предлагаемый операционной системой. Окно приёма определяет количество байтов, которые отправитель может передать, не получая подтверждения. Вообще, чем больше окно, тем лучше работа в сетях с высокой пропускной способностью. Однако, не всё так просто. Но выходить за рамки статьи и углубляться в дебри TCP/IP, мы не будем. Достаточно сказать, что для того, чтобы точно определить значение окна, необходимо будет добавить раздел и параметр в реестре. Значение по- умолчанию 0x2238, а для модемных соединений устанавливать и изменять его не рекомендуется. Коротко и ясно.

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
TCPWindowSize =dword:2238

DSL, кабельный модем - 186880 (0x2DA00)
T1 и выше - 256960 (0x3EBC0)
Включение этой опции заставляет TCP автоматически определять MTU Auto Discovery

Включение этой опции заставляет TCP автоматически определять MTU.

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
PMTUDiscovery =dword:1
Максимальное время Default Time to Live Setting

TTL определяет максимальное время, которое пакет IP может прожить в сети, не достигая адресата. Поэтому использование этой опции определяет, как долго компьютер будет ждать, прежде чем решит, что запрашиваемый вебсайт не найден.

Рекомендованное значение равно 128. Добавьте следующий ключ :

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
"DefaultTTL"=dword:80
Повторная передача данных Selective Acknowledgement Support

Не углубляясь далеко в теорию, отметим, что когда поддержка Selective Acknowledgement (SACK)включена, и пакет или ряд пакетов TCP потеряны, то получатель может сообщить отправителю точно, какие данные были получены, и где находится "дыра" в данных. Тогда отправитель может выборочно повторить передачу только недостающих данных, и не будет повторно передавать блоки данных, которые уже были успешно получены. Особенно это важно для больших TCP окон, см. описание следующей опции.

Для включения возможности SACK нужно добавить в реестр такой ключ :

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
SackOpts =dword:1
Включить поддержку больших TCP окон TCP Window Support

Совместно с опцией TCP/IP Window Size , описанной выше, дает возможность включить поддержку больших TCP окон TCP Window Support, это особенно актуально в сетях с большой пропускной способностью (я думаю, что модемное соединение к ним не относится). Если вам так нужно, то измените значение ключа с 0 на 3 :

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
Tcp1323Opts =dword:3
Нахождение черных дыр DeadGWDetectDefault

Если этот параметр поставить в (1), то перед началом соединения будет происходить проверка на мертвые маршрутизаторы по пути до сервера. Этот параметр сильно тормозит протокол за счет лишних затрат на поиск.

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
DeadGWDetectDefault =dword:0

Ваш модем и список АТ- команд
(Меню «Пуск» —> Настройка —> Панель управления —> Модемы —> Свойства —> Подключение —> Дополнительно).
В документации на Ваш модем есть список АТ- команд, которые указываются в строке инициализации. С их помощью можно управлять режимами работы модема.
Команда «ATZLP» для принудительного соединения на максимально возможной для него скорости («115200 B/sec»).
Команда «AT+MS=V34,1», для принудительного соединения по протоколу «V34» и отменяющая автоматический выбор протокола, что увеличивает стабильность и среднюю скорость соединения, если у Вас нецифровая АТС.
Команда «AT+MS=V90,1», для принудительного соединения по протоколу «V90» и отменяющая автоматический выбор протокола.

В этом же диалоговом окне проверьте, включена ли опция «Контроль передачи» и выбран режим «Аппаратный (RTS/CTS)».

служба QoS (Quality of Service)
По умолчанию служба QoS (Quality of Service) в Windows XP резервирует для своих нужд 20% от пропускной способности канала (любого, хоть модем на 14400, хоть гигабитный Ethernet). Причём, даже если удалить службу QoS Packet Scheduler в свойствах соединения, этот канал не освобождается. Освободить канал, или просто настроить QoS, можно так. Запускаем апплет Group Policy (gpedit.msc). В Group Policy находим "Localcomputer policy" и нажимаем на "Administrative template". Выбираем пункт "Network" – "QoS Packet Sheduler". Включаем "Limit reservable bandwidth". Теперь снижаем "Bandwidth limit" с 20% до 0. При желании здесь же можно настроить и другие параметры QoS. Далее отправляйтесь в сетевую конфигурацию (иконка Network Connections в Контрольной панели).
- Выделите свое соединение и из контекстного меню запустите Properties.
- В закладке Networking убедитесь, что протокол QoS Packet Scheduler подключен (enabled). Если его нет, добавить из списка (через кнопку Добавить).
- Перегрузите компьютер.

Выше написанное действительно для нормальных линий, то есть стандарты.

Заключение

Данные настройки могут увеличить скорость от 10 до 40 %. Эти настройки являются индивидуальными для каждого в зависимости от качества вашей связи. Для автоматической настройки можно воспользоваться специальной программой Win Speed v1.2 http://www.saitov.km.ru/program/Win_speed.exe. Другие программы не рекомендую.


Internet Explorer

Содержание

Internet Explorer

Запретить доступ к свойствам Internet Explorer

Скрыть вкладку "Общие" в свойствах обозревателя

Скрыть вкладку "Безопасность"

Скрыть вкладку "Конфиденциальность"

Скрыть вкладку "Содержание"

Скрыть вкладку "Подключения"

Скрыть вкладку "Программы"

Скрыть вкладку "Дополнительно"

Запретить изменения на вкладке "Дополнительно"

Запретить доступ к настройке параметров временных файлов

Автоматически подгонять размеры рисунка

Запретить автоматические обновления IE

Скрывать редко используемые пункты в Избранном

Удалить пароль на ограничение доступа к сайтам

Путь к папке закачек по умолчанию

Редактор для просмотра исходного кода HTML страниц

Поиск из панели адресов

Эмблемы IExplorer

Ваш текст к стандартному заголовку IExplorer

Запрет возможности изменения панели инструментов IExplorer

Горячие клавиши для просмотра и навигации

Автозаполнение

Веб-адресов

Автозаполнение форм

Автозаполнение имен пользователей и паролей в формах

Запрос на сохранение пароля

Internet Explorer

Запретить доступ к свойствам Internet Explorer

Полностью запрещает доступ к настройкам Internet Explorer. Если данная опция включена, опции ниже игнорируются.

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions

NoBrowserOptions:DWORD = 1 - доступ к настройкам запрещен

Наверх
Скрыть вкладку "Общие" в свойствах обозревателя

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

GeneralTab:DWORD = 1 - скрыть вкладку

Наверх
Скрыть вкладку "Безопасность"

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

SecurityTab:DWORD = 1 - скрыть вкладку

Наверх
Скрыть вкладку "Конфиденциальность"

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

PrivacyTab:DWORD = 1 - скрыть вкладку

Наверх
Скрыть вкладку "Содержание"

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

ContentTab:DWORD = 1 - скрыть вкладку

Наверх
Скрыть вкладку "Подключения"

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

ConnectionsTab:DWORD = 1 - скрыть вкладку

Наверх
Скрыть вкладку "Программы"

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

ProgramsTab:DWORD = 1 - скрыть вкладку

Наверх
Скрыть вкладку "Дополнительно"

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

AdvancedTab:DWORD = 1 - скрыть вкладку

Наверх
Запретить изменения на вкладке "Дополнительно"

Вкладка "Дополнительно" доступна, но изменить на ней ничего нельзя.

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

Advanced:DWORD = 1 - запретить изменения

Наверх
Запретить доступ к настройке параметров временных файлов

Свойства обозревателя - вкладка Общие - раздел Временные файлы Интернета, становится недоступным.

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

Settings:DWORD = 1 - запретить доступ к настройке параметров

Наверх
Автоматически подгонять размеры рисунка

Internet Explorer автоматически подгоняет рисунки так, чтобы они полностью умещались на экране и полосы прокрутки не появлялись. При необходимости можно отключить данную возможность.

HKCU\Software\Microsoft\Internet Explorer\Main

STRING Enable AutoImageResize, значение "yes" - автоматическое изменение размера изображений включено

Наверх
Запретить автоматические обновления IE

HKCU\Software\Microsoft\Internet Explorer\Main

NoUpdateCheck:DWORD = 1 - запрещает автоматические обновления

Наверх
Скрывать редко используемые пункты в Избранном

В меню показываются только часто вызываемые пункты меню, для доступа к редко вызываемым пунктам, необходимо нажать на специальную стрелочку. Чтобы изменения вступили в силу, необходимо перезапустить Internet Explorer

HKCU\Software\Microsoft\Internet Explorer\Main

STRING FavIntelliMenus: значение "yes" - скрывать редко используемые пункты

Наверх
Удалить пароль на ограничение доступа к сайтам

Удаляет пароль на ограничение доступа к сайтам по содержанию. Данный пароль можно установить в Свойствах обозревателя, вкладка Содержание, раздел Ограничение доступа.

HKLM\Software\Microsoft\Windows\CurrentVersion\policies\Ratings

BINARY Key, значение - зашифрованный пароль и параметры ограничения. Удалить параметр для удаления пароля

Наверх
Путь к папке закачек по умолчанию

Данная папка будет всегда появляться первой для сохранения загружаемых файлов.

HKCU\Software\Microsoft\Internet Explorer

STRING Download Directory, значение путь к папке закачек

Наверх
Редактор для просмотра исходного кода HTML страниц

Редактор, вызываемый через пункт меню Вид -> Просмотр HTM- кода.

HKLM\SOFTWARE\Microsoft\Internet Explorer\View Source Editor\Editor Name

STRING по умолчанию путь к редактору.

Наверх
Поиск из панели адресов

Параметр влияет на поведение Internet Explorer, если он не находит страницу.

HKCU\Software\Microsoft\Internet Explorer\Main

AutoSearch:DWORD =

Internet Explorer 6.0 использует следующие значения:

0 - Не выполнять поиск из адресной строки
6 - Показать результаты и перейти на самый похожий узел
5 - Только перейти на самый похожий узел
4 - Только показать результаты в главном окне

Наверх
Эмблемы IExplorer

Для замены эмблемы IE необходимо два изображения. Первое размером 38х38 пикселей, а второе 22х22. Если захотите вернуться к значениям по умолчанию, то либо удалите ключи, либо присвойте им пустые значения.

Добавляем ключ :

HKCU\Software\Microsoft\Internet Explorer\Toolbar

BrandBitmap= c:\папка\имя_файла_1

И добавляем ещё:

HKCU\Software\Microsoft\Internet Explorer\Toolbar

SmBrandBitmap= c:\папка\имя_файла_2

Наверх
Ваш текст к стандартному заголовку IExplorer

Чтобы добавить ваш текст к стандартному заголовку IE, добавьте в реестр ключ :

HKCU\Software\Microsoft\Internet Explorer\Main

Window Title="ваш заголовок"

Наверх
Запрет возможности изменения панели инструментов IExplorer

Для запрета возможности изменения панели инструментов IE, измените значение ключа с 0 на 1 :

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoToolbarCustomize=DWORD:1

Наверх
Горячие клавиши для просмотра и навигации IExplorer
Нажать | Действие
F1 | Справка IE
F5 | Обновить страницу
F11 | Полноэкранный режим и обратно
ENTER | Переход по выбранной ссылке
SHIFT + F10 | Контекстное меню для ссылки или страницы
BACKSPACE | Переход на предыдущую страницу
ALT + Стрелка влево | Переход на предыдущую страницу (Аналог BACKSPACE)
ALT + Стрелка вправо | Переход на следующую страницу
ALT + Home | Переход на домашнюю страницу
Стрелка вверх | Скроллинг вверх
Стрелка вниз | Скроллинг вниз
PAGE UP или SHIFT+Пробел | Скроллинг вверх на одну страницу
PAGE DOWN или Пробел | Скроллинг вниз на одну страницу
HOME | В начало документа
END | В конец документа
ESC | Прервать загрузку страницы
CTRL+E | Открыть окно Поиск
CTRL+F | Открыть диалоговое окно Найти на этой странице
CTRL+H | Открыть Журнал
CTRL+I | Открыть Избранное
CTRL+L или CTRL+O | Открыть диалоговое окно Открыть
CTRL+N | Открыть новое окно
CTRL+P | Печать текущего документа
CTRL+R | Обновить страницу (аналог F5)
CTRL+S | Сохранить текущую страницу
CTRL+W | Закрыть окно

Горячие клавиши для Адресной строки

Нажать | Действие
F4 | Показать список записей Адресной строки
CTRL + Стрелка ← | В Адресной строке курсор перемещается к следующему логическому символу прерывания (. или /)
CTRL + Стрелка → | В Адресной строке курсор перемещается к следующему логическому символу прерывания (. или /)
CTRL + ENTER | Добавляет http://www. в начало и .com в конец текста, напечатанного в Адресной строке. Пример, если вам надо набрать "http://www.google.com", введите "google" и нажмите Ctrl+Enter.

Горячие клавиши для работы с Избранным

Нажать | Действие
CTRL+D | Добавить текущую страницу в Избранное
CTRL+B | Открывает диалоговое окно Упорядочить Избранное

Наверх

Автозаполнение

Веб-адресов

Включить/выключить автозаполнение в строке адреса.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\AutoComplete

STRING AutoSuggest, значение "yes" - автозаполнение веб-адресов используется

Наверх
Автозаполнение форм

Включить/отключить автозаполнение форм. Internet Explorer выводит подсказки, в которых можно выбрать ранее введенные данные.

HKCU\Software\Microsoft\Internet Explorer\Main

STRING Use FormSuggest, значение "yes" - автозаполнение форм используется

Наверх
Автозаполнение имен пользователей и паролей в формах

HKCU\Software\Microsoft\Internet Explorer\Main

STRING FormSuggest Passwords, значение "yes" - автозаполнение имен пользователей и паролей в формах используется

Наверх
Запрос на сохранение пароля

HKCU\Software\Microsoft\Internet Explorer\Main

STRING FormSuggest PW Ask, значение "yes" - Internet Explorer выводит окно с сообщением сохранять пароль или нет

Наверх


Windows Media Player
Изменить заголовок окна медиаплэера

Добавьте ключ в реестр, чтобы изменить заголовок окна медиаплэера:

HKCU\Software\Policies\Microsoft\WindowsMediaPlayer

TitleBar= Ваш заголовок
Включить DVD возможности медиаплэера

Измените значение ключа с No на Yes, чтобы включить DVD возможности медиаплэера:

HKCU\Software\Microsoft\MediaPlayer\Player\Settings

EnableDVDUI="Yes"
Очистки списка последних проигранных медиаплэером файлов

Для очистки списка последних проигранных медиаплэером файлов удалите или очистите следующие параметры:

HKCU\Software\Microsoft\MediaPlayer\Player\RecentFileList

File0=
File1=
<и т.д.>
Включить MP3 кодирование

Включение встроенного кодека в формате mp3 (MPEG-3)

HKLM\SOFTWARE\Microsoft\MediaPlayer\Settings\MP3Encoding

Минимальный битрейт:
LowRate:DWORD = 56000, равно 56 Кбит

Средний-высокий битрейт
MediumHighRate:DWORD = 128000, равно 128 Кбит

Средний битрейт
MediumRate:DWORD = 64000, равно 64 Кбит

Максимальный битрейт:
HighRate:DWORD = 192000, равно 192 Кбит

Или создайте reg-файл следующего содержания:

Regedit 4
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\Settings]
[HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\MediaPlayer\Settings\MP3Encoding]
"LowRate"=dword:0000dac0
"MediumRate"=dword:0000fa00
"MediumHighRate"=dword:0001f400
"HighRate"=dword:0002ee00

и импортируйте его в реестр (щелчок по файлу - установить). В реестре включится встроенный MP3 кодек, максимальный битрейт 192 килобит.
Автоматически загружать кодеки из Интернета

Если на компьютере нет необходимого видео или аудио кодека, то Windows Media Player попытается найти его в Интернете и затем загрузить его. Если опция выключена, Media Player сначала спросит, загрузить кодек или нет, а если включена, кодек будет загружен и установлен без выдачи сообщения.

HKCU\SOFTWARE\Microsoft\MediaPlayer\Preferences

UpgradeCodecPrompt:DWORD = 1 - выдавать сообщение перед загрузкой кодека, 0 - загружать автоматически

Примечание: WMP8 использует однобайтовый двоичный тип данных (hex:00 или hex:01), но вполне корректно работает с dword.

Автоматические обновления

HKCU\SOFTWARE\Microsoft\MediaPlayer\Preferences

UpgradeCheckFrequency:DWORD может принимать следующие значения:

    • 0 - Один раз день
    • 1 - Один раз в неделю
    • 2 - Один раз в месяц

Примечание: WMP8 использует двоичный тип данных, но вполне корректно работает с dword. (соответственно hex:00,00,00,00, hex:01,00,00,00, hex:02,00,00,00)


Очистка реестра

Утилита полностью не очистит вам реестр. Вам придется лезть в реестр и вручную удалять остатки софта. Наведываться в Реестр лучше всего сразу после деинсталляции практически любых программ для того, что бы удалить следы их пребывания в системе. И каждый раз Вы будете удивлены, как много мусора даже лучшие их них оставляют после себя. Очень полезно регулярно инспектировать Реестр с целью выявления и удаления ключей отдельных излишне рьяных приложений, без угрызения совести прописывающих себя в тех ветвях Реестра, которые отвечают за различные виды автоматического запуска программ при старте системы. Поэтому вы хорошо должны знать что удалили, а что у вас еще установлено.
В основном софт оставляет папки программ в разделе:
HKLM\Software и HKCU\Software, HKLM\Software\Microsoft\Windows\SurrentVersion\Explorer\MenuOrder\StartMenu2\Programs
За автозапуск программ в Windows отвечают ключи, находящиеся в ветке:
HKLM\Software\ Microsoft\Windows\CurrentVersion.
Подразделы: Run, RunOnce, RunOnceEx, Run Services, RunServicesOnce. В них и содержатся ключи, отвечающие за запуск программ. Название ключа может быть произвольным, а в качестве его значения указывается запускаемая программа. В разделе Run по умолчанию система устанавливает следующие ключи: internat.exe, LoaderPowerProfile, ScanRegistry, SystemTray, TaskMonitor, а в разделе RunServices повторно дублируется ключ LoadPowerProfile. В разделах, в которых присутствует слово Once, прописывают свои значения программы, запуск которых надо произвести один раз, например при установке, или наоборот, при удалении программы. Поэтому в нормальных условиях они должны быть пусты. Все остальные ключи, присутствующие в любом из этих разделов Реестра, добавлены установленными программами и подлежат придирчивой инспекции на предмет их лояльности. Здесь же, в папке CurrentVersion проверьте папку Uninstall, и удалите все что у Вас не установлено. По желанию можете изменить параметры Установки и удаления программ, это уже относится к разделу Безопасность

Вся информация для удаления программ храниться в разделе реестра: HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

Информация о каждой программе храниться в отдельном разделе. В каждом разделе обязательно должны присутствовать два параметра:

STRING DisplayName, значение - имя, которое отображается в списке удаляемых программ

STRING UninstallString, значение - путь к программе удаления

также могут присутствовать другие пункты, их обычно добавляют современные инсталляторы:

STRING DisplayIcon - иконка, соответствующая приложению в диалоге Установка и удаление программ
STRING ModifyPath - Путь инсталлятора для изменения установочных параметров программы. Еcли этот ключ установлен, то Кнопка Заменить/Удалить распадается на две - Заменить (выполняется ModifyPath) и Удалить(выполняется UninstallString)

Следующие параметры относятся к диалоговому окну Поддержка

STRING Publisher - Издатель продукта
STRING Readme - Путь к файлу Readme для данного продукта
STRING Comments - Комментарии к продукту
STRING Contact - Контактное лицо (e-mail и т.п.)
STRING DisplayVersion - Номер версии
STRING ProductID - Код продукта
STRING RegCompany - Зарегистрированная компания
STRING RegOwner - Зарегистрированный владелец
STRING URLInfoAbout - Домашняя страничка производителя (параметр Publisher становится ссылкой)
STRING URLUpdateInfo - URL обновления продукта
STRING HelpLink - URL сведений о поддержке

Открываем RegEdit, нажимаем комбинацию клавиш Ctrl-F - и в появившемся окошке вводим название того, что мы хотим найти. Естественно, это будет название удаленной программы, или его варианты. Так, например, иногда стоит поискать и по имени фирмы - разработчика. И ищем, ищем, ищем... Да, это долго и нудно (ведь после каждого найденного значения необходимо еще раз нажать F3, и так до конца, особенно если ключей очень много, но никуда не денешься. Конечно, существует большое количество специализированных утилит для поиска и удаления дохлых ссылок реестра, способные существенно облегчить ваш труд ассенизатора, мы дальше будем рассматривать некоторые из них, однако правда жизни такова, что на все 100 % гарантировать успешный результат ни одна из них не в состоянии. Ведь структура Реестра настолько гибка, что позволяет вносить в него все, что заблагорассудится. И поверьте, иногда может такое заблагорассудиться, что систему сразу парализует . Так что ручками, ручками...и головой тоже. А дальше - оптимизация Реестра, которая является логическим продолжением операции чистки. Ведь при удалении ссылок из Реестра они оттуда физически не удаляются, а только помечаются, как удаленные, что, конечно, обеспечивает определенное увеличение скорости работы с Реестром.


Пользователи

Управление пользователями

Как управлять пользователями, которым можно заходить на компьютер.
Как любая NT, XP имеет механизм идентификации пользователей, и каждого пользователя можно ограничить в правах. На этих пользователях и их правах строится вся модель безопасности XP, как на локальной машине, так и в сети. Нельзя защитить что-либо паролем, можно определить какие пользователи имеют право использовать тот или иной ресурс. Пользователей на одной машине может быть множество, и чтобы было проще ими управлять, пользователи разбиты на группы. Управление пользователями и группами осуществляется с помощью апплета Users Accounts в Control Panel или «Пуск — Выполнить» запустить команду control userpasswords. После установки системы образуется только два пользователя, один с правами администратора, который вы создали в процессе установки XP, и Guest, которые показаны в окне (на самом деле есть ещё несколько пользователей, например пользователь Administrator, но его не показывает в списке, и чтобы залогиниться им придётся идти на некоторые ухищрения). Если вы обладаете правами администратора, то можете добавить или удалить пользователя в этом окне, можете поменять пароль пользователя или пиктограмму соответствующую пользователю, поменять метод, который используется для входа в систему. Для этого надо выбрать пункт Change the way users log on and off. По умолчанию стоит Use the Welcome screen что означает, что для входа кликнуть по иконке из списка и ввести пароль. Если убрать галочку с этого пункта, то будет использоваться метод входа с окном, в котором предлагается ввести имя пользователя и пароль. Вы не можете использовать Welcome Screen если компьютер входит в домейн. Классический вход может быть двух видов, с требованием нажать Crtl+Alt+Del, и без него. Чтобы это изменить, наберите в командной строке control userapasswords2. Откроется окно, на второй закладке этого окна, Advanced, ставим или снимаем галочку в чекбоксе Require Users To Press Ctrl+Alt+Delete check box, расположенном в разделе Secure Logon. На той же закладке можно нажать кнопку Advanced в разделе Advanced User Management, и запустить апплет Local Users and Groups (ещё его можно запустить через Control Panel - Administrative Tools - Computer Management - Local Users and Groups ). Вы апплете, в котором сможете добавить или удалить пользователей, отредактировать уже существующих, поменять им группу, и т.д... Кроме этого, некоторые настройки для пользователей, такие как время жизни пароля, конкретные права для различных групп, и некоторые другие настраиваются из апплета Local Security Setings из Administrative Tools.
Есть возможность отключить необходимость в вводе пароля. Для этого запускаем control userpasswords2, и снимаем галочку c users must enter a user name and password to use this computer. После этого пользователь выбранный в разделе Users for this computer: будет логиниться на компьютер сразу.

Наверх
Как выставить права пользователям, работающим на компьютере?
В Windows XP каждому пользователю можно выставить определенные права - что делать разрешается, а что - нет, причем, если пользователей много, их можно распределить по группам, присвоив каждой группе определенные права. Управление пользователями и группами производится через апплет Users Accounts, находящийся в Контрольной панели. Сразу после инсталляции WinXP в этом апплете можно будет увидеть двух пользователей - того, кто был создан в процессе установки (с правами администратора) и второго - гостя (Guest), по умолчанию отключенного. Вообще-то сразу же после установки появляются еще несколько пользователей (например, знакомый еще со времен NT пользователь по имени Administrator), но они не показаны в списке - таков общий принцип построения Windows XP: операционная система предназначена для всех, другими словами - и для чайников тоже, поэтому до "лишнего" можно добраться только после некоторых дополнительных манипуляций. В общем-то, это правильно - меньше дров будет наломано... В случае, если вы обладаете правами администратора, апплет Users Accounts даст возможность добавлять или удалять пользователей, менять пользователю пароль или соответствующую ему картинку-пиктограмму, а также изменять метод входа в систему. По умолчанию при входе в систему показывается экран Welcome screen с пиктограммами и именами пользователей, но, если выбрать пункт "Change the way users log on and off" и убрать в появившемся окне галку с пункта "Use the Welcome screen", вход в систему будет происходить по NT-шному - через окно, в котором предлагается ввести имя пользователя и пароль.

Наверх
Возможность редактирования уже существующих пользователей

Чтобы получить доступ к контролю над пользователями, который можно назвать "полным", придется заглянуть в апплет Computer Management (Start /Administrative Tools /Computer Management) и кликнуть по плюсику, раскрывающему Local Users and Groups...

Но и это не все хитрости: есть еще апплет Local Security Setings (он там же, в Administrative Tools), с помощью которого можно, например, изменить время жизни паролей и выставить конкретные права каждой имеющейся группе пользователей.

Наверх
Вход в систему администатором (пользователь Administrator)

Самый простой способ - отключить режим Welcome screen . Кроме этого, залогиниться как Administrator можно, если начать загрузку системы в режиме Safe mode. Наконец, есть и третий, самый хитрый способ: после появления экрана "Welcome screen" дважды нажмите Ctrl+Alt+Del

Наверх
Переименовать папку аккаунта Administrator

Сначала входим в систему под аккаунтом Administrator и создаем в директории Documents and Settings папку с нужным именем. Затем через контекстное меню My computer / Properties / Advanced добираемся до User Profiles, где копируем профиль администратора в созданную папку. После этого открываем в реестре ключ HKLM\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ ProfileList и находим там ветвь, соответствующую профилю администратора (по значению ключа ProfileImagePath) и исправляем в ней этот параметр на нужный. Теперь можно перелогиниться...

Наверх


Программы

Наши работы

Registry Guide v 1.4 . 2

1.30 Mb

Изменение параметров реестра из разделов программы, возможность отката.

EXEшники системных утилит(33) быстрый доступ к многим параметрам.
Модуль «Общие сведения о компьютере» для проверки приложений и оборудования установленных на этом компьютере, а также просмотр диагностической информации о состоянии компьютера. Сведения по системе Службы , Сведения по системе "Политика , Состояние жестких дисков , Состояние этого компьютера , Оборудование установленное на этом компьютере , Программное обеспечение , Журнал ошибок , Просмотр удаленного компьютера.
Модуль «Диагностика сети» используется для сбора и отображения информации об оборудовании и операционной системе, о настройке Интернета, модема и сетевого адаптера.
Модуль проверки режима работы «Службы».
Сведения о средстве «Восстановлении системы».
Описывается установка системы, архитектура реестра, структура и типы данных. Методы резервного копирования и восстановления реестра. Рассматриваются методы настройки системы и сети, особенности подключения и конфигурирования аппаратных средств. Приводятся рекомендации по предотвращению сбоев системы и решению различных проблем путем редактирования реестра. Полностью интерактивный.

Справочник параметров командной строки формат CHM

408кб

Можно использовать для ознакомления с средствами командной строки, настройки командной строки, получения сведений о командной оболочке и для автоматизации заданий с помощью пакетных файлов или средств создания сценариев, таких как CScript и WMIC.

  • Сведения об изменениях в функциональных возможностях и о возможностях, более не доступных в Windows XP.

  • Сведения о новых средствах командной строки

  • Полный список средств командной строки

  • Сведения по выполнению конкретных задач

Справочник средств администрирования и терминов формат CHM

186кб

В справочнике описаны средства администрирования, их назначение и выполняемая работа, место расположения и включение. Расшифровка компьютерных терминов, употребляемых для определения системных событий, комплектующих, процессов в системе и тгд. Поиск по первой букве и названию компонента, удобная навигация.

Справочник "Диспетчер устройств" формат CHM

18 кб

Диспетчер устройств используют для обновления драйверов (или программного обеспечения) оборудования, изменения настройки оборудования, а также для устранения неполадок. Свойства и методы работы с диспетчером устройств.

Справочник "Сетевые подключения" формат CHM

351 кб

Компонент «Сетевые подключения» обеспечивает связь локального компьютера с Интернетом, локальной сетью или другим компьютером. Это средство позволяет получать доступ к ресурсам и функциональным возможностям сети независимо от того, как пользователь подключен к сети — напрямую или с помощью служб удаленного доступа. Операции создания, настройки, сохранения подключений и наблюдения за ними выполняются в папке «Сетевые подключения».

Модуль "Сети и Интернет" формат CHM

19.3 кб

Диагностика сети позволяет выполнить различные тесты и собрать различную информацию о сети. В зависимости от выбранных параметров, диагностика сети тестирует сетевое взаимодействие и проверяет доступность некоторых сетевых служб и программ. Также, производится сбор основной информации о компьютере. Это средство предоставляет вам или специалисту службы технической поддержки информацию, необходимую для поиска причин, вызвавших проблемы с сетью.

WinXP speed v1.5.3

377кб

Специализированная утилита по оптимизации системы Windows XP.Эти опции описаны в программе Registry Guide v1.4.1
Уменьшиться время открытия меню Пуск, работа с проводником, включение и выключение системы, ускорение Интернет соединения, меняет приоритеты системных процессов.
Добавляет в контекстное меню проводника пункты Отправить в папку и Копировать в папку.
Проверка и замена стартовой страницы Internet Explorer, устранение не корректного отображения шрифта в программах.
Полное удаление Messenger.
Отключение встроенного отладчика Windows XP (программа обнаружения ошибок).
Включение встроенного кодека в формате mp3 (MPEG-3).
Системные утилиты (33) для диагностики и настройки.
Скрытые настройки и возможности, предоставляемые драйвером NVIDIA ForceWare.Вы сможете быстро и легко настроить карту на оптимальную производительность.
Справка по параметрам.


Процессоры AMD

На этот раз речь пойдет об усмирении знойного характера процессоров компании AMD. Среди ряда пользователей ПК и тех, кто только собирается таковым стать, бытует мнение, что эти процессоры выделяют очень много тепла и для их устойчивой работы необходимы едва ли не пятикилограммовые медные радиаторы и подобающие высокооборотистые вентиляторы. Если к данному вопросу подойти с холодным умом и здравым рассудком (чем мы сейчас и займемся), то описанная ситуация видится совершенно в ином свете. Энергопотребление, равно как и тепловыделение процессоров Intel Pentium 4 ничуть не меньше этих же показателей для процессоров AMD Athlon XP. Более того, у старших моделей P4 рассеиваемая мощность даже выше, чем у «камней» от AMD. Но почему же тогда клеймо «горячих» получили именно последние?

Дело в том, что системы на P4 и процессорах от AMD имеют различную архитектуру. Поэтому если в «разгрузочное время» для перехода P4 в режим энергосбережения необходимо подавать на процессор команду Halt, то для Athlon XP это недостаточное условие. Чтобы дать отдохнуть процессору Athlon XP (равно как и Duron’у), необходимо произвести «отключение» процессора от системной шины (режим Bus Disconnect), иначе он будет молотить пустые циклы с довольно низким КПД. Реализация функции отключения процессора от системной шины, в общем-то, не представляет особых трудностей, по счастливой случайности все чипсеты, когда-либо выпускавшиеся под платформу Socket A, поддерживают режим Bus Disconnect. Вот только по умолчанию он деактивирован. Что ж, будем активировать.
Для этого нам понадобятся две небольшие программы :
WPCREdit (http://download.viahardware.com/ wpcredit/wpcre12a.exe, 64.9 Кб) и
WPCRSet (http://download.viahardware.com/ wpcredit/wpcrs120.exe, 59.6 Кб).
Программа WPCREdit потребуется всего единожды. После того, как вы ее скачаете, лучше сохранить файл в отдельную папку, так как это самораспаковывающийся архив, и его активация приводит к разархивации содержимого без предварительного указания пути. Утилита не требует инсталляции и предназначена для просмотра и редактирования управляющих регистров шины PCI. Программа WPCRSet отвечает за автоматическую установку запрограммированных значений в процессе запуска операционной системы. Ее нужно проинсталлировать, запустив файл instdd.exe. После всех этих перипетий не помешало бы вспомнить, на каком чипсете основана ваша материнская плата (для этого проще всего заглянуть в руководство к плате). Итак, вы знаете, какой чипсет установлен на вашей плате и полны решимости сделать свой вклад в борьбу с глобальным потеплением на планете.
Запустите программу WPCREdit (wpcredit.exe). Перед вами таблица регистров нулевого PCI-устройства — системного контроллера. Все, что нужно сделать,— установить в 1 (единицу) один из битов в одном из байтов :-). Какой именно — зависит от чипсета и отчасти от BIOS материнской платы. Непосредственно процессор переводится в режим энергосбережения подпрограммами интерфейса ACPI, код которого содержится в BIOS. Последний может переводить процессор в режим энергосбережения либо командой Halt, либо командой чтения из специального ACPI-порта.
Замечено, что AMI BIOS обычно использует Halt, а AWARD — команду чтения ACPI-порта.
В зависимости от этого нужно редактировать регистры. Для чипсетов VIA KT133, KT133A, KT133E и, возможно, серий КМ133 и KLE133 (для последних — не проверялось) нужно редактировать 7-ой (старший) бит регистра 52 в случае ACPI-охлаждения. И 1-ый бит (напоминаем — биты считаются с нулевого, справа налево) 55-го регистра, если охлаждение происходит через Halt. Кстати, особо ленивые могут поставить сразу оба варианта — это ничему не помешает.
Регистры для других чипсетов:
КТ266, КТ266А, КТ333CE (и, возможно, КМ266)— регистр 92 бит 7 и регистр 95 бит 1 соответственно;
КТ333CF, KT400 — регистр D2 бит 7 и регистр D5 бит 1 соответственно;
AMD760— регистр 62 бит 1 и регистр 62 бит 1 соответственно;
SiS735— регистр 6А, биты 0–1. Какой именно отвечает за охлаждение посредством Halt, а какой ACPI, точно сказать не можем, так как у нас отсутствуют платы на этом чипсете. Проверьте оба— это не опасно.
Для чипсета NVIDIA nForce 2— регистр 6F, бит 4— охлаждение ACPI. Какой бит отвечает за охлаждение посредством Halt— нам не известно, так как экземпляры плат на nForce2 с BIOS, использующим Halt, еще не попадались.
Еще— как отличить КТ333CE от KT333CF? Посмотрите (все в том же WPCREdit), в каком из регистров— 92 или D2— находится значение 69 или 6B. Это и будет нужный регистр. Установите его старший бит в 1— полученное значение окажется, соответственно, E9 или EB.

Рис. 1. Давайте рассмотрим процесс редактирования значения регистра на примере платы с чипсетом nForce2.Регистр 6F имеет значение 0F (или в бинарном коде 00001111) (рис.1). Биты с нулевого по третий установлены в 1. Теперь нужно поменять четвертый бит с 0 на 1. Для этого просто выбираем его курсором и меняем значение на 1. Теперь жмем Enter для подтверждения изменения. Все, значение регистра изменилось на 1F.
Отредактируйте, согласно вышеописанной технологии, соответствующие биты для вашей платы и понаблюдайте за температурой процессора— она должна довольно быстро начать снижаться (особенно если плата производит мониторинг температуры по внутреннему термодатчику процессора). Запомните или запишите значения, которые появились в исправленных регистрах после редактирования нужных битов.
Итак, нужный бит найден и установлен. Теперь неплох было бы закрепить успех, для чего потребуется программа WPCRSet. Запустите файл wpcrset.exe и выставите переключатель Startup в положение Start. Нажмите кнопку Add. Введите номер нужного регистра и значение, которое у вас получилось при редактировании этого регистра. Нажмите OK, чтобы добавить значение, и еще раз OK, чтобы сохранить его и выйти. Программа попросит перезагрузиться — этого можно не делать, ведь мы и так выставили нужные показатели в регистре при помощи WPCREdit.
Или с помощью утилиты Vcool http://vcool.occludo.net температура процессора в простое поддерживается на уровне 35 градусов. Утилита совершенно замечательная. Весит она всего около 40 Кб и однозначно должна присутствовать у любого владельца компьютера на базе процессора AMD. Принцип ее работы довольно прост. Процессоры AMD имеют несколько другой алгоритм входа в режим простоя, чем процессоры Intel. Современные операционные системы, к которым относятся не только все версии Windows, но и Линукс, замечательно умеют охлаждать процессоры Intel, но не додают одну команду процессорам AMD. В результате этот вид процессоров отдыхает как бы наполовину. VCool ставится как драйвер и додает процессорам AMD ту самую недостающую команду. После этого система на AMD у вас перестанет исполнять роль вспомогательного обогревателя квартиры. Работает программа под всеми версиями Windows, у автора также имеется версия и для Линукс.
Вот тебе первая выгода…
Каких же результатов на практике можно достичь при включении режима Bus Disconnect? Чтобы продемонстрировать реальную пользу от этого, мы представляем вам диаграмму рабочих температур в различных режимах работы процессора. Для эксперимента использовалась материнская плата Soltek SL-75DRV5 и процессор Athlon XP с частотой 2250 МГц (ну, разогнан слегка, не без этого:-)). Нужно заметить, что значения температуры получены по внутреннему датчику процессора. Поэтому если ваша плата измеряет ее по внешнему датчику, не пытайтесь воспроизвести такую же (то есть максимальную). Ну как? Нам кажется, что цифры говорят сами за себя.

Вот тебе вторая выгода…
Существенно снизив температуру процессора, можно браться за утихомиривание вентилятора — будем двух зайцев одним выстрелом бить. Ну, в самом деле, зачем ему вертеться на полных оборотах, если температуры процессора и помещения практически совпадают.

Рис. 2. Схема Схему, представленную на рисунке 2 отличают максимальная простота и надежность. Аналогичная система уже долгое время работает в домашнем компьютере у одного из авторов данной статьи.
Полевой транзистор, указанный в схеме, при желании может быть заменен практически любым другим силовым MOSFET’ом. Автор использовал имевшийся в наличии SST60N06, но покупать специально именно такой же мы не рекомендуем. Ведь его цена гораздо выше, чем у менее мощных транзисторов, которые, тем не менее, сгодятся для этой цели. Терморезистор RT1 также может быть подобран в зависимости от объемов закромов Родины:-). Вполне подойдет деталь с номинальным сопротивлением от пары кОм до нескольких десятков кОм. Сопротивление подстроечного резистора R1 подбирается в зависимости от резистора RT1— номинал R1 должен быть примерно в 2 раза меньше номинала RT1.
Настройка схемы сводится к регулировке порога запуска вентилятора. Для этого подключите схему к блоку питания (если вы используете для настройки БП вашего компьютера— не забудьте установить кулер на процессор). Далее, подстраивая резистор R1, найдите положение, в котором вентилятор не будет крутиться при комнатной температуре терморезистора RT1, но начнет запускаться при нагревании RT1 теплом руки. После настройки схемы терморезистор крепится к радиатору процессора. На этом самострой заканчивается.
Если вы работаете в текстовом редакторе, при этом слушая любимые MP3-шки, а вентилятор на процессоре вовсе не вращается,— не пугайтесь, теперь это для него лишнее. С увеличением температуры сопротивление терморезистора начнет плавно уменьшаться, и вентилятор будет постепенно набирать обороты, достигая предельных значений в игровых баталиях. Но перед тем как закрыть корпус, проконтролируйте работу системы. Вентилятор в обязательном порядке должен запускаться и увеличивать обороты при повышении температуры, иначе последствия могут оказаться довольно неприятными.
Возможные поблемы
Замечено несколько возможных проблем, связанных с арбитражем шины PCI при включенном режиме Bus Disconnect. Иногда могут возникать трудности с неправильным воспроизведением звуков (хрипца) sound-картами (в основном фирмы Creative). Такие проблемы практически всегда решаются увеличением значения PCI Latency Timer для звуковой карты. Для того чтобы это сделать, необходимо вновь запустить wpcredit.exe, нажать кнопку Select Device..., выбрать устройство Audio Controller и изменить значение его регистра 0D на максимально возможное (все биты установить в 1). Если после ввода некоторые биты снова сбросились в 0— не пугайтесь, это означает, что максимальное значение регистра меньше FF. Если такое вмешательство помогло— снова запускайте WPCRSet и добавляйте соответствующую строку, не забыв ввести номер нужного устройства (Device).
На чипсетах производства VIA с видеокартами фирмы NVIDIA иногда наблюдается проблема, выражающаяся в замедлении программ, работающих с 2D-графикой. Разрешить ее можно установкой драйверов Detonator 28.32 или более ранних.
При использовании низкокачественного блока питания или звуковой карты возможно появление в колонках негромких шумов, изменяющихся в зависимости от загруженности процессора. Проблема решается только заменой комплектующих на более качественные или установкой дополнительных конденсаторов в цепи питания, но это уже тема для отдельной статьи.


Работа HDD

Принцип работы жестких дисков

Содержание

Как работает жесткий диск

Физическое построение жесткого диска

Скорость вращения диска

Количество секторов на дорожке

Время поиска/время переключения головок/время переключения между цилиндрами

Задержка позиционирования

Кэш-память на жестком диске

Размещение данных на диске

Скорость обмена между процессором и диском

Интерфейс (IDE или SCSI)

Производительность

Файловые системы

S.M.A.R.T.

Функция Bus Master

Драйвера поддержки Bus Master

Тестируем диск
Как работает жесткий диск?
Как правило, всех пользователей интересует один вопрос: быстрый ли диск? Ответ на него неоднозначен и требует рассказа о следующих характеристиках:
  • Скорость вращения диска
  • Количество секторов на дорожке
  • Время поиска/время переключения головок/время переключения между цилиндрами
  • Задержка позиционирования
  • Время доступа к данным
  • Кэш-память на жестком диске
  • Размещение данных на диске
  • Скорость обмена между процессором и диском
  • Интерфейс (IDE или SCSI)

Наверх
Физическое построение жесткого диска
На жестком диске данные хранятся на магнитной поверхности диска. Информация записывается и снимается с помощью магнитных головок (все почти как в магнитофоне). Внутри жесткого диска может быть установлено несколько пластин (дисков), в просторечье именуемые "блинами". Двигатель, вращающий диск, включается при подаче питания на диск и остается включенным до снятия питания.
ПРИМЕЧАНИЕ: Если в разделе Power Management программы Setup из BIOS установлен параметр выключения жесткого диска при отсутствии обращения к нему, то двигатель может быть выключен программой BIOS. Двигатель вращается с постоянной скоростью, измеряемой в оборотах в минуту (rpm). Данные организованы на диске в цилиндрах, дорожках и секторах. Цилиндры - концентрические дорожки на дисках, расположенные одна над другой. Дорожка затем разделяется на сектора. Диск имеет магнитный слой на каждой своей стороне. Каждая пара головок одета как бы на "вилку", обхватывающую каждый диск. Эта "вилка" перемещается над поверхностью диска с помощью отдельного серводвигателя (а не шагового, как часто ошибочно думают - шаговый двигатель не позволяет быстро перемещаться над поверхностью). Все жесткие диски имеют резервные сектора, которые используются его схемой управления, если на диске обнаружены дефектные сектора.

Наверх
Скорость вращения диска
Обычно современные жесткие диски имеют скорость вращения от 5400 до 7200 об/м. Чем выше скорость вращения, тем выше скорость обмена данными. Следует только учесть, что при возрастании скорости вращения увеличивается температура корпуса жесткого диска и диски со скоростью 7200 об/мин требуют либо применения корпуса с продуманной для целей отвода тепла конструкцией, либо дополнительного охлаждения внешним вентилятором собственно диска. Вентилятора блока питания для этого недостаточно. Еще более высокооборотные диски со скоростью вращения 10000 об/мин, которые сейчас выпускают все без исключения фирмы-производители, требуют как хорошей вентиляции внутри корпуса, так и "правильного" корпуса, хорошо отводящего тепло. Жесткие диски на 15000 об/мин без принудительного обдува просто не рекомендуется использовать.

Наверх
Количество секторов на дорожке
Современные жесткие диски имеют различное количество секторов на дорожке в зависимости от того, внешняя ли это дорожка или внутренняя. Внешняя дорожка длиннее и на ней можно разместить больше секторов, чем на более короткой внутренней дорожке. Данные на чистый диск начинают записываться также с внешней дорожки.

Наверх
Время поиска/время переключения головок/время переключения между цилиндрами
Время поиска (seek time) минимально только в случае необходимости операции с дорожкой, которая является соседней с той, над которой в данный момент находится головка. Наибольшее время поиска соответственно при переходе с первой дорожки на последнюю. Как правило, в паспортных данных на жесткий диск указывается среднее время поиска (average seek time).
Все магнитные головки диска находятся в каждый момент времени над одним и тем же цилиндром, и время переключения определяется тем, насколько быстро выполняется переключение между головками при чтении или записи. Время переключения между цилиндрами - это время, требуемое для перемещения головок на один цилиндр вперед или назад. Все времена указываются в документации на жесткие диски в миллисекундах (ms).

Наверх
Задержка позиционирования

После того, как головка оказывается над желаемой дорожкой, она ждет появления требуемого сектора на этой дорожке. Это время называется задержкой позиционирования и также измеряется в миллисекундах (ms). Среднее время задержки позиционирования считается как время поворота диска на 180 градусов и, поэтому зависит только от скорости вращения шпинделя диска. Конкретные данные по величине задержки сведены в таблицу.

Скорость вращения,
об/мин 		Задержка,
миллисекунды

3600

8.3

4500

6.7

5400

5.7

7200

4.2

10000

3.3

Наверх
Время доступа к данным
Время доступа к данным по сути - это комбинация из времени поиска, времени переключения головок и задержки позиционирования, измеряется также в миллисекундах (ms). Время поиска, как вам уже известно, это только показатель того, как быстро головка оказывается над нужным цилиндром. До тех пор, пока данные не записаны или считаны, следует добавить время на переключение головок и на ожидание необходимого сектора.

Наверх
Кэш-память на жестком диске
Как правило, на всех современных жестких дисках есть собственная оперативная память, называемая кэш-памятью (cache memory) или просто кэшем. Производители жестких дисков часто называют эту память буферной. Размер и структура кэша у фирм-производителей и для различных моделей жестких дисков существенно отличаются. Обычно кэш память используется как для записи данных так и для чтения, но на SCSI дисках иногда требуется принудительное разрешение кэширования записи, так обычно по умолчанию кэширование записи на диск для SCSI запрещено. Есть программы, позволяющие, определить, как установлены параметры кэш-памяти, например ASPIID от фирмы Seagate. Как это многим не покажется странным, размер кэша не является определяющим для оценки эффективности его работы. Организация обмена данными с кэшем более важна для повышения быстродействия диска в целом.
Некоторые производители жестких дисков, такие как Quantum, используют часть кэша под свое программное обеспечение (для модели Quantum Fireball 1.3 Gb, например, под firmware занято 48 Kb из 128). Как нам кажется, более предпочтителен способ, используемый фирмой Western Digital. Для хранения firmware используются специально отведенные сектора на диске, невидимые для любых операционных систем. По включению питания эта программа загружается в обычную дешевую DRAM на диске и при этом отпадают затраты на микросхему флэш-памяти для хранения firmware. Такой способ позволяет легко исправлять встроенное программное обеспечение жесткого диска, что часто фирма Western Digital и делает.

Наверх
Размещение данных на диске
О том, что конфигурация диска задается через количество цилиндров, головок и секторов на дорожке, все знают с начала эпохи PC. Хотя еще несколько лет тому назад точное указание в программе SETUP всех этих параметров диска было обязательным, сейчас это не так. Строго говоря, те параметры диска, которые вы видите в разделе SETUP Standard CMOS Setup, как правило, ничего общего не имеют с реальными параметрами диска, причем вы можете заметить, что эти параметры меняются в зависимости от вида трансляции геометрии диска - Normal, LBA и Large. Normal - геометрия в соответствии с данной производителем в документации на диск и не позволяет DOS увидеть более чем 504 Mb (1 Mb - 1048576 байт). LBA - Logical Block Address - эта установка позволяет видеть DOS диски объемом до 4 Gb. Large используется такой операционной системой, как Unix. Параметры, установленные в SETUP, преобразуются в реальные логикой управления жестким диском. Многие современные операционные системы работают с диском через LBA, минуя BIOS.

Наверх
Скорость обмена между процессором и диском
Существует несколько способов физического сохранения данных на жестком диске. Определить способ отображения данных на диске можно, только используя различные программы определения быстродействия диска (benchmark). В программу Winbench 98/99 включен High-end тест жесткого диска, где оцениваются не достаточно отвлеченные в настоящее время 2 параметра - скорость передачи данных и время доступа, а проверяется, для каких задач и для каких наиболее популярных программ, активно работающих с диском, диск наиболее пригоден. Этот тест можно получить на сервере фирмы Ziff-Davis.
" Вертикальное отображение"

Обычные жесткие диски используют вертикальное отображение. Данные записываются сначала на одном цилиндре сверху вниз, затем головки переходят на другой цилиндр и т.д.

"Горизонтальное отображение"

При горизонтальном отображении сначала данные записываются последовательно от цилиндра к цилиндру на поверхности одного диска, затем также на поверхности следующего диска и т.д. Такой способ лучше подходит для записи непрерывного высокоскоростного потока данных, например, при записи живого видео.

"Комбинированный"

Комбинированный способ отображения, использующий как вертикальный так и горизонтальный способ.
При тестировании таких дисков видно, что чем дальше от начальных цилиндров, тем хуже параметры диска. Это связано с тем, что на внешних дорожках размещается больше секторов и считывание/запись выполняется быстрее.
В справедливости этого легко убедиться, запустив Winbench 97/98/99, выбрав сначала диск C для теста диска, а затем последний логический диск (желателен диск объемом не менее 2.5 Gb). Разница в оценке быстродействия диска для модели WD AC32500 составила 15%!
Реально диск разделен на зоны, в каждую из которых входит обычно от 20 до 30 цилиндров с одинаковым количеством секторов. Эти зоны также называются "notches".
Чем выше плотность записи на диск, тем выше будет скорость считывания с него. Именно поэтому при оценке параметров диска следует внимательно смотреть на внутреннюю скорость передачи данных. Внутренняя скорость передачи данных прямо пропорциональна плотности записи на диск и скорости вращения шпинделя. Так как увеличивать скорость вращения диска достаточно сложно - увеличивается энергопотребление, шум, возникают проблемы с теплоотводом, то наиболее оптимальный путь повышения производительности - это увеличение плотности записи на диск. Именно поэтому современный жесткий диск со скоростью вращения 5400 об/мин легко опережает по производительности диск с 7200 об/мин, выпущенный двумя годами ранее. Все производители жестких дисков в первую очередь и заняты проблемой повышения плотности записи. При прочих равных условиях, из двух накопителей равной емкости быстрее будет работать накопитель с меньшим количеством дисков, т.е. с большей плотностью записи.

Наверх
Интерфейс (IDE или SCSI)
Сейчас фактически осталось только два действующих интерфейса: IDE (распространенный сейчас в варианте Enhanced IDE - EIDE) и SCSI. На любой материнской плате, выпущенной после 1996 года, можно обнаружить контроллер EIDE. Это, а также существенно более низкая стоимость IDE дисков по сравнению со SCSI объясняет значительное превосходство IDE дисков в количественном выражении над SCSI.

Каждый контроллер EIDE имеет два канала (primary - первичный и secondary - вторичный), к каждому из которых можно подключить до двух устройств (всего четыре). С интерфейсом IDE в настоящее время, кроме жестких дисков, выпускаются также приводы CD-ROM, накопители Iomega Zip, накопители на магнитной ленте. Интерфейс SCSI, как правило, требует отдельного контроллера, так как пока очень незначительное количество материнских плат выпускаются с контроллером SCSI. Сканеры, магнитооптические накопители, устройства записи для CD и т.п. выпускаются как с интерфейсом SCSI, так и с IDE. При принятии решения о покупке жесткого диска с тем или иным интерфейсом, следует учесть главное - если вам не требуется подключение нескольких жестких дисков, ваш компьютер не является сервером или мощной рабочей станцией, ресурсы которой доступны другим пользователям, SCSI диск НЕ ДАСТ НИКАКИХ ОЩУТИМЫХ ПРЕИМУЩЕСТВ по сравнению с EIDE диском. Это правило, естественно, справедливо для одинаковых по физическим характеристикам дисков. Выигрыш будет только в снижении нагрузки на центральный процессор за счет использования процессора SCSI контроллера. Интерфейс SCSI позволяет подключать до 7 устройств, а Wide SCSI до 14 устройств. Существуют также многоканальные SCSI контроллеры, позволяющие подключить и большее количество устройств.
Основной недостаток интерфейса EIDE - отсутствие "интеллекта". Если на одном канале подключены жесткий диск и накопитель CD-ROM, то в случае обращения к CD-ROM процессор будет ожидать завершения операций с CD-ROM, прежде чем сможет обратиться к жесткому диску. Поэтому очевидно, что нельзя к одному каналу EIDE подключать быстрое и медленное устройство одновременно. CD-ROM всегда следует подключать только ко второму каналу. Каналы EIDE в современных контроллерах EIDE, как правило, достаточно независимы друг от друга. Для повышения производительности EIDE были разработаны и стандартизованы режимы PIO (Programming Input Output - программируемый ввод/вывод), single word DMA (обмен одиночными словами в режиме DMA - Direct Memory Access - прямого доступа к памяти) и multi word DMA (обмен несколькими словами в режиме DMA).
SCSI интерфейс имеет несколько разновидностей, которые совместимы друг с другом (достаточно иметь пассивные переходники). 8 бит (50-ти контактный разъем) или 16 бит (68-и контактный разъем для Wide SCSI). Частота шины может быть 5 MHz (SCSI 1), 10 MHz (Fast SCSI), 20 MHz (Fast-20 or Ultra SCSI) or 40 MHz (Ultra-2 SCSI).
Сейчас стал активно внедряться стандарт Ultra2 SCSI LVD, являющийся разновидностью Ultra2 SCSI. Полное название стандарта - Ultra2 SCSI (LVD) Low Voltage Differential Parallel SCSI Interface, т.е. низковольтный дифференциальный параллельный SCSI интерфейс. Этот вариант SCSI существенно отличается от всех своих предшественников по двум параметрам:
Скорость передачи увеличена до 80 MB/s
Максимальная длина соединительного кабеля может достигать 12 метров
Кроме этого, к одному шлейфу можно подключить до 15 устройств. Обратная совместимость, как это принято для SCSI устройств, также выдерживается и устройство с Ultra2 SCSI LVD можно подключить к обычному контроллеру SCSI. С этим интерфейсом выпускаются только жесткие диски в вариантах с 68-контактным разъемом (Wide) и SCA.
Но и скорость в 80 MB/s, как оказалось, не является предельной на сегодняшний день. Уже начинает внедряться производителями как контроллеров, так и жестких дисков следующий вариант SCSI, называемый официально как SPI-3 (SCSI Parallel Interface - 3), неофициально Ultra160/m SCSI. Он разработан на базе Ultra2 SCSI LVD и отличается удвоенной скоростью передачи данных. Каким образом это достигнуто, видно из схематичной временной диаграммы.

ultra160diag.gif (1001 bytes)
По диаграмме ясно, что передача данных синхронизируется как по заднему, так и по переднему фронту сигнала ACK и, тем самым, скорость передачи удваивается по сравнению с Ultra2 SCSI LVD. На обычном SCSI (Ultra2) тактовая частота составляла 40 MHz, частота для данных 20 MHz и можно таким образом передать до 40 MBytes/s (так как за один цикл передается 2 байта), на Ultra2 SCSI LVD частота передачи данных была увеличена до 40 MHz и тем самым скорость обмена возросла до 80 MBytes/s.
Существенным отличием нового стандарта является только 32-х разрядный алгоритм CRC контроля передаваемых/принимаемых данных. Ранее в SCSI использовался только контроль по четности, да и его можно было легко отключить (что часто и делали) в BIOS SCSI контроллера. Новый алгоритм контроля позволяет обнаруживать ошибки в пакетах данных до 32-х бит длиной.
С более подробным разъяснением терминологии SCSI можно ознакомиться в "SCSI Глоссарии".

Максимально возможная скорость передачи данных для интерфейса SCSI и максимально допустимые длины кабелей

Частота шины SCSI

8 бит
(50-ти контактный разъем)

16 бит
(68-и контактный разъем, Wide SCSI)

Макс.
скорость
обмена

Макс.
длина
кабеля

Макс.
скорость
обмена 		Макс.
длина
кабеля

5 MHz (SCSI 1)

5 MB/s

6 m

N/A*

-

10 MHz (Fast SCSI,
SCSI II)

10 MB/s

3 m

20 MBytes/s

3 m

20 MHz (Fast-20,
Ultra SCSI)

20 MB/s

1.5 m

40 MBytes/s

1.5 m

40 MHz (Ultra-2 SCSI) LVD

N/A

N/A

80 MBytes/s

12 m

40 MHz (Ultra3 SCSI) LVD

N/A N/A 160 MBytes/s 12 m

*Примечание: N/A - режим отсутствует
С массово выпускаемыми в настоящее время жесткими дисками EIDE максимально возможная скорость обмена данными составляет 66.6 MByte/s для режима multi DMA mode 2. Поскольку собственно скорость обмена повышена за счет добавления возможности передачи данных как по переднему, так и по заднему фронту сигнала записи или чтения, совместимость как жестких дисков с UltraDMA/66 с обычным контроллером, так и контроллера UltraDMA/66 с обычным EIDE диском есть без каких-либо проблем.
Стандарты UltraDMA/33 и UltraDMA/66 отличается от предыдущих улучшений IDE не только скоростью обмена. Впервые в них используется механизм обнаружения ошибок с помощью CRC (циклический контрольный код). Это позволяет избежать ошибок при приеме/передаче данных, так как при получении данных с ошибкой пересылка данных повторяется снова.
Первой диски в стандарте UltraDMA/33 выпустила фирма Quantum - Fireball ST (это не удивительно, поскольку она вместе с Intel и явилась автором стандарта). При установке нового диска на компьютер, в случае появления сбоев в работе, следует понизить скорость работы жесткого диска, принудительно установив в SETUP меньший режим PIO. Мы сталкивались с таким явлением на дисках, выпущенных до 1997 года - хотя жесткий диск согласно его документации в mode 4 работать должен, но не работает устойчиво!
Все вновь выпускаемые жесткие диски с 1999 года поддерживают стандарт UltraDMA/66, который уже стал фактически новым стандартом на интерфейс IDE жестких дисков.

Максимально возможная скорость передачи данных для интерфейса IDE
(он же ATA)

single word DMA 0

2.1 MByte/s

PIO mode 0

3.3 Mbyte/s

single word DMA 1, multi word DMA 0

4.2 MByte/s

PIO mode 1

5.2 MByte/s

PIO mode 2, single word DMA 2

8.3 MByte/s

Максимально возможная скорость передачи данных для интерфейса EIDE
(он же ATA-2)

PIO mode 3

11.1 MB/s

multi word DMA 1

13.3 MB/s

PIO mode 4, multi word DMA 2

16.6 MB/s

Максимально возможная скорость передачи данных для интерфейса Ultra-ATA (он же ATA-3)
(он же Ultra DMA/33)

multi word DMA 2

33.3 MB/s

Максимально возможная скорость передачи данных для интерфейса Ultra-ATA/66 (он же ATA-4)
(он же UltraDMA/66)

multi word DMA 2

66.6 MB/s

Реально максимальная скорость передачи данных для любого диска не превышает 10 MB/s, так как механические характеристики диска обойти невозможно. Большие значения скоростей относятся к работе с внутренним кэшем жесткого диска. Так как объем кэш-памяти для IDE дисков не превышает 2 MBytes, а объем кэш-памяти для SCSI дисков в большинстве случаев не более 4 MBytes, то скорость обмена данными не является определяющей при оценке производительности жестких дисков.
Интерфейс SCSI дает ощутимый выигрыш в основном только в многозадачной среде, когда несколько программ одновременно добиваются доступа к дискам и в случае необходимости достижения максимальной производительности дисковой подсистемы, так как пока только диски SCSI имеют скорость вращения 10000 и 15000 об/мин и время доступа 5-6 ms.
Применение SCSI также еще оправдано при решениях задач, связанных как с высокой нагрузкой на диск так и с существенной загрузкой процессора, например, при обработки больших (по объему) изображений в Adobe Photoshop, хотя необходимость в SCSI дисках в связи с ростом производительности процессоров в подобных случаях становится все меньшей.
Стоимость высокоскоростных SCSI дисков в 2-3 раза выше лучших дисков IDE такой же емкости. По планам производителей жестких дисков различия в физических параметрах жестких дисков IDE и SCSI будут уменьшаться и SCSI диски будут все более уходить в сферу специальных задач - на сервера и мощные рабочие станции. Уже начиная с середины 1999 года отпала необходимость в применении SCSI дисков для работы с видеопотоками, хотя несколькими годами ранее использование IDE дисков для записи видео даже не обсуждалась.

Наверх
Производительность
Оценка производительности диска - это достаточно сложная задача. Существуют десятки различных тестов, оценивающих тем или иным способом производительность дисковой подсистемы. В связи с тем, что наибольшую популярность сейчас получили многозадачные операционные системы, такие как Windows 95/98, Windows NT/2000, OS/2, Lunix, SCO UNIX и т.п., старые тесты под MS-DOS (Norton Sysinfo, VSeek, Checkit, PC Bench...) уже не дают реального представления о качестве работы диска в многозадачных средах. Для оценки работы жесткого диска под Windows 95 или Windows NT/2000, с нашей точки зрения, лучшим является Winbench 97/98/99 и аналогичные тесты тех же авторов, посколько с диском выполняются действия, максимально приближенные к реальным.

Наверх
Файловые системы
Как уже сообщалось ранее, жесткие диски поступают с завода-изготовителя уже отформатированными. Все программы так называемого низкоуровнего форматирования на самом деле не выполняют физического форматирования жесткого диска, а только полностью уничтожают содержимое диска (что часто тоже требуется). Различные операционные системы же своими программами форматирования создают лишь ЛОГИЧЕСКУЮ структуру диска. В настоящее время наиболее распространены 4 файловые системы - FAT (MS-DOS, Windows 3.X, Windows 95/98), NTFS (Windows NT/2000), FAT32 (Windows 95/98) и HPFS (OS/2).
FAT16
DOS, DOS 7.0 из Windows95 использует FAT для сохранения данных как на жестких дисках, так и гибких. В качестве одного элемента адресации на диске используется кластер, объединяющий несколько секторов. FAT исторически сама старая файловая система с 16-ти разрядной адресацией и максимально возможное количество кластеров на одном логическом диске не превышает 65536. Соответственно максимальный размер одного кластера 32 Kb, так как максимальный размер логического диска 2 Gb. Поэтому один из главных недостатков FAT - большой размер кластера. Дело в том, что при кластере 32 Kb файл с информацией в 1 байт займет на диске 32 Kb. Теоретически можно заполнить логический диск в 2 Gb 65536 файлами по 1 байту, хотя физически диск будет практически пустой. Поэтому при работе с DOS, Windows 95 или Windows NT под FAT рекомендуется разбивать диск на разделы, не превышающие 1 GBytes. Для разбиения/переразбиения диска можно воспользоваться известной программой Partition Magic.

Соотношение между размером раздела диска и размером кластера на диске

Размер раздела

Размер кластера

2 GByte

32 KByte

<1 GByte

16 KByte

<512 MByte

8 KByte

<256 MByte

4 KByte

<128 MByte

2 KByte

FAT32
Попытка отказаться от ограничений классической FAT и видоизменить ее была тихо предпринята фирмой Microsoft в версии Windows 95 OEM service Release 2 (v.4.00.1111&DOS 7.1 - также 950b). В этом варианте Windows 95 FAT стала 32-х разрядной. Из 32 бит 4 были зарезервированы. Таким образом, максимальный размер раздела в этом варианте становится 2 Tb (2048 Gb), а раздел в 8 Gb получает кластер размером всего 4 Kb. Кроме этого, корневая директория диска не имеет фиксированного размера, что снимает ограничения на количество файлов и директорий в корневом каталоге. При этом приложения DOS не могут работать с файлами более 2 Gb, а 32-x разрядные приложения Windows могут работать с файлами до 4 Gb.
Все это было бы замечательно, если бы не некоторые но, существенные на момент появления FAT32:
кроме как DOS 7.1 и Windows 95 v.950b или Windows 98 (даже NT 4.0!) эту прекрасную систему никто не видит;
любые дисковые утилиты, не написанные специально под FAT32, будут "творить чудеса" с ней;
попытка работы с FAT32 программами, которые ее не понимают, может привести к гибели данных на диске;
утилиты для работы со SCSI дисками также должны быть разработаны под FAT32;
производительность дисковой подсистемы по Winbench 97 чуть меньше с FAT32 по сравнению с FAT16.
Но те преимущества, которые дает FAT32, как правило, перевешивают недостатки. В команде format OSR2 есть недокументированный ключ z, с помощью которого можно создать логический диск с кластером от 1024 байт. Синтаксис команды: размер кластера 512 format диск: /z:n, где n - множитель для 512 (собственно 512 байт и параметр n=1 запрещены), поэтому n может быть равен 2, 4, 6 и т.д. Желательно только понимать, что при кластере в 1 Kb на диске объемом 3000 Mb будет 3 миллиона кластеров и процесс, скажем, дефрагментации диска может занять часы... Разумно уменьшить размер кластера на том логическом диске, который используется для хранения программ и оставить его 4 Kb (размер кластера по умолчанию для Windows 95 OSR2) на остальных.
В Windows 98 появилась возможность конвертировать разделы FAT16 в FAT32. С появлением Windows NT 5.0 (или Windows NT 2000, как ее теперь называют) FAT32 стала новым фактическим стандартом файловой системы для приложений, не требующих высокой степени защиты информации, а FAT16 уйдет с рынка за ненадобностью.

NTFS (NT File System)
После выхода Windows 2000 NTFS постепенно становится все более и более популярной. Основные отличия от FAT32 - неограниченный размер файлов (до 12 TBytes) и возможность управлять правами доступа к файлам и каталогам.

Наверх
S.M.A.R.T.
Эта аббревиатура все чаще встречается при указании технических характеристик жестких дисков. Что она означает?
Идея S.M.A.R.T. (Self-Monitoring Analysis and Reporting Technolodgy - технология самоанализа и информирования) технологии заключается в создании механизма предсказания возможного выхода из строя жесткого диска и предотвращения тем самым потери данных. S.M.A.R.T. была предложена фирмами COMPAQ и IBM несколько лет тому назад и сейчас включена в версию стандарта ANSI X3T10. Сейчас S.M.A.R.T. технология используется в программе BIOS от фирмы AWARD Software и в ряде программ под Windows 95 (например, S.M.A.R.T. Vision от ACE Laboratory).
Для анализа надежности жесткого диска используются две группы параметров (здесь и далее подразумевается жесткий диск, поддерживающий S.M.A.R.T. технологию). Первая характеризует параметры естественного старения жесткого диска:
  • количество циклов включения/выключения (старт/стоп)
  • количество оборотов двигателя за время работы
  • количество перемещений головок

Вторая группа параметров уже информирует о текущем состоянии качества накопителя. К этим параметрам относятся:

  • высота головки над поверхностью диска
  • скорость обмена данными между дисками и кэш-памятью на диске
  • количество переназначений плохих секторов (когда вместо испорченного сектора подставляется свободный исправный)
  • количество ошибок поиска
  • количество операций перекалибровки
  • скорость поиска данных на диске
Данные о типичных дефектах жесткого диска и способах их предсказания сведены в таблицу:
Вид дефекта | Симптом/Чем вызвано | Что предсказывает
Большое количество плохих секторов | Физические дефекты поверхности, повреждения при транспортировке | Количество дефектов поверхности, скорость их роста
Чрезмерный шум | Дефект мотора, повреждения при транспортировке | Диагностика
Значительное количество нерегулярных ошибок | Повреждение головки или ее загрязнение | Частые повторы при обращении к диску, срабатывание схемы ECC контроля
Отказ мотора | Не вырабатывается сигнал готовности, нет шума вращения дисков/ Дефект мотора, повреждения при транспортировке | Повторы включения, увеличение времени набора номинальной скорости вращения
Диск не отвечает (эффект такой же, как при отсутствии диска) | Дефект электроники диска | Ничто не может предсказать катастрофу в данном случае (к сожалению)
Ошибки позиционирования серводвигателя | Большое количество ошибок перемещения головок/ повреждения при транспортировке | Ошибки позиционирования, частые повторы калибровки
Сбой работы головки, резонанс при ее перемещении | Значительное количество нерегулярных ошибок | Рост ошибок при чтении, а также ошибок позиционирования

Значения всех параметров (как и собственное программное обеспечение накопителя), как правило, хранятся на специальных дорожках диска, не видимых со стороны компьютера или, что бывает значительно реже, в энергонезависимой памяти.
У производителей жестких дисков достаточно много степеней свободы, так как именно они присваивают граничные значения (thresholds) всем параметрам. Если хотя бы один параметр ушел за граничные значения, то накопитель желательно заменить. Конечно, пока механизм наблюдения за накопителем не будет встроен в операционную систему, трудно ожидать массового использования технологии S.M.A.R.T. Подробнее об этом (и обо всем, что связано с IDE) можно узнать из соответствующих документов на посвященном IDE стандартам сайте.

В силу некоторой ограниченности технологии S.M.A.R.T (пользователь ставится перед свершившимся фактом - диск как-то почти сломался, его осталось только заменить), появились расширения способов предотвращения потери данных, разработанных отдельными фирмами-производителями жестких дисков.
Для примера можно рассмотреть технологию Data LifeguardTM фирмы Western Digital. Основная ее идея - проверка через каждые восемь часов работы поверхности всего диска, выявление секторов, которые могут стать плохими и перенос информации на резервные нормальные области диска. Понятно, что все эти операции выполняются в паузах (которые составляют до 90% времени работы диска) и никак не снижают производительность компьютера. Совместимость с S.M.A.R.T тем не менее полностью сохраняется. Впервые Data LifeguardTM была применена в накопителе AC310100.
Фирма Quantum, начиная с серии жестких дисков Fireball Plus KA применила свою фирменную технологию Data Protection System (DPS), которая отличается от Data LifeguardTM доступной на WEB программой диагностики, позволяющей выявить возможные дефекты и во многих случаях устранить их. Quantum утверждает, что ее диагностическая программа способна "лечить" все диски, выпущенные этой компанией с июня 1996 года.

Наверх
Функция Bus Master
Функция Bus Master (дословно Хозяин Шины, ранее по ГОСТ в нашей стране - задатчик на шине) введена в контроллеры EIDE с приходом процессоров Pentium. Что это такое? Классический способ приема данных от какого-либо устройства следующий - процессор выполняет команду чтения порта, считывает байт или слово данных в свой регистр, после чего переписывает этот байт или слово в память, затем повторяет эту процедуру до тех пор, пока вся необходимая информация не будет считана из устройства в память. Если бы процессору больше нечего было делать, то этот способ всех бы устраивал. Но с появлением многозадачных операционных систем стало слишком накладно использовать процессор для операций ввода/вывода. Поэтому контроллеры внешних устройств (EIDE в частности) стали оборудоваться как бы собственными процессорами ввода/вывода. С появлением шины PCI, первой реально многопользовательской шины в архитектуре IBM PC реализация этой идеи стала совсем простой.
Что происходит в этом случае? Процессор программирует контроллер EIDE на шине PCI, указывая ему, откуда он должен взять данные и куда в память их положить. После получения этих указаний контроллер захватывает управление шиной PCI, а драйвер Bus Master управляет шиной доступа к памяти и совместно с контроллером выполняет операции по считыванию данных с жесткого диска или CD-ROM непосредственно в память с помощью контроллера прямого доступа в память (DMA - Direct Memory Access). При таком способе обмена данных процессор свободен после выдачи команд контроллеру EIDE и может заниматься любыми другими делами. Надо только понимать, что процессор может в это время не получить доступ к шине PCI и основной памяти.
Функция Bus Master делает интерфейс EIDE SCSI-подобным (хотя это только подобие - современные контроллеры SCSI на шине PCI также могут работать в режиме Bus Master и, кроме этого, "интеллектуально" управлять своей периферией). Если доступ к диску выполняет только одна, запущенная в данный момент программа, то значительного выигрыша в производительности не будет. Но достаточно запустить несколько приложений, работающих с диском, как заметное повышение производительности будет очевидным. Это легко проверить, запустив одновременно, например, два Winbench 99 с тестом диска с Bus Master драйверами или без оных. В контроллерах IDE из наборов микросхем фирмы Intel, ранее называемых Triton, встроена функция Bus Master. Intel называет эти контроллеры PIIX (Pci Isa Ide aXcelerator). Пока Intel выпустил 4 таких контроллера 80371FB (PIIX), 82371SB (PIIX3), 82371AB и 82371EB (PIIX4). Предпоследний из них входит в набор Intel 430TX - это первый Intel контроллер IDE с поддержкой режима Ultra DMA/33. Сейчас, в основном, используется 82371AB&EB, включая и материнские платы на Pentium II/III. На платах с набором 80440BX применяется микросхема 82371EB, функционально ничем не отличающаяся от 82371AB, но допускающая обращение к ней со стороны процессора с частотой 100 MHz. В наборах i810, i810e, i820, i840 поддерживается стандарт UltraDMA/66, а в наборах i815E, i815EP и далее поддерживается UltraATA100.
Следует заметить, что Windows 95 OSR2 не совсем корректно работала с парой "UltraDMA жесткий диск - UltraDMA контроллер". Фирма Western Digital отмечает высокую вероятность ошибок при работе в этом случае и настоятельно рекомендует использовать драйвера Bus Master от Intel, поскольку в их работе ошибок нет. Сама Microsoft также подтверждает существование проблемы.
В Windows 98 драйвера IDE работают корректно. Intel прекратила разработку отдельных драйверов Bus Master для Windows 98 до выхода наборов i8xx. В Windows NT функция Bus Master может быть включена с как с помощью специальной программы , так и драйверов от Intel.

Наверх
Драйвера поддержки Bus Master
Функция Bus Master включается только специальными драйверами под соответствующую операционную систему. Для примера мы предлагаем ссылки на драйверы для Windows 95, OS/2 и Windows NT. Windows 98 не требует установки драйверов Bus Master от третьих фирм, так встроенные в систему драйвера работают вполне удовлетворительно. С нашей точки зрения, наилучшими драйверами Bus Master являлись в свое время драйверы, разработанные фирмой Triones (последняя версия 3.70). Эти драйверы разработаны не только для Windows 95/NT и OS/2, но и для Novell, SCO Unix, MS-DOS. К сожалению, продукт Triones не является freeware или shareware. Комплект драйверов Triones поставлялся вместе с некоторыми материнскими платами, например, фирм Gigabyte, DataExpert, Acer.
* Intel Bus Master Driver (оригинал от Intel)
* VIA Bus Master Driver
* Драйвера Bus Master под все наборы микросхем
В OEM service release 2 Windows 95 подобный драйвер встроен в систему (у него осталось старое имя ESDI_506.pdr). Режим перекачки данных, использующий DMA, может быть отключен в System Manager из Control Panel/System. К своим последним драйверам Intel стал прилагать диагностическую программу Intel Companion, которая сообщает подробную информацию обо всех устройствах, подключенных к IDE интерфейсу и о режимах их работы.
Проблемы, возникающие при работе с драйверами Bus Master
 Проблемы, описанные ниже, возникали в таком виде не так давно, сейчас большинство этих проблем устранено, но тем не менее, они представляют некий исторический интерес.
Большинство проблем возникает с накопителями CD-ROM и старыми жесткими дисками. Поэтому после установки драйверов проверьте функционирование системы (сохраните в какой-либо программе файлы, перепишите файлы с диска на диск и т.д.). Рекомендуется также проверить CD-ROM на чтение CD-ROM дисков и воспроизведение аудио дисков. CD-ROM рекомендуется всегда устанавливать как master на втором IDE канале.
Мы столкнулись с тем, что в случае использования материнской платы на наборе 430TX и установкой под Windows NT 4.0 соответствующих драйверов происходил crash системы при использовании CD-ROM приводов Samsung (12-24x), неустойчивая работа с CD-ROM Panasonic модели CR-583 (8-ми скоростной) и т.д. Мы не можем утверждать, что виноваты накопители - может быть, виноваты драйверы (мы тестировали на драйверах от Intel и Triones - результаты были одинаковы), мы просто констатируем факт. 24-х скоростные и выше CD-ROM уже не имеют проблем с драйверами Bus Master.
Если вы обнаружили неприятные эффекты, например "зависание" компьютера при попытке сохранить файл, невозможность проигрывания аудио дисков и т.п., то следует удалить драйвера Bus Master или, что то же самое, очистить поле DMA в свойствах IDE контроллера. В Windows 95 это также делается повторным запуском программы Setup установки драйверов Bus Master и последующего выбора Uninstall.
Из известных нам общих проблем - невозможно проиграть аудио диск в Windows NT 4.0, невозможность просмотра некоторых видов видеодисков в Windows 95 (с драйверами от Triones все в порядке), несколько неустойчивая работа с диском у драйверов Intel.
Множество проблем обсуждаются на сайте BMdrivers.com. Особенно актуальны эти проблемы для пользователей Windows 95 OSR2, в которую Microsoft встроила поддержку Bus Master, но как это часто бывает, с многочисленными ошибками. Ссылки на "заплатки" к Windows 95 OSR2 также есть на этом сайте.
Надо также понимать, что нормальное функционирование режима Bus Master и DMA возможно ТОЛЬКО на правильно спроектированных материнских платах и IDE кабелях. В противном случае операционная система снимет режим DMA, не уведомляя при этом пользователя. Производительность жесткого диска, CD-ROM и других IDE устройств существенно понизится, не говоря уже о возрастании в несколько раз нагрузки на центральный процессор.
Дополнительные материалы:
Критерии отбора HDD

SMART - технология внутренней оценки состояния HDD

SMART технологии: Data Lifeguard, MaxSafe, Drive Fitness Teсhnologies, Data Protection System

Наверх
Тестируем HDD

Инструмент
Как и для любой работы, так и для нашей нужен инструмент. В нашем случае это программа. Ёе можно скачать по адресу mhdd.net, её название mhdd, есть инструкция на русском языке и вес около сотни килобайт. Работает программа не только под MS-Dos, но и под Win 9x.

Возможности: тестировать винчестер на наличие ошибок - сканирование поверхности вызывается клавишей F4, лечить его (вызывается через F4, ERASE WAITs, и предназначена для удаления софт-бэдов), увеличивать скорость работы винчестера. Вот что можно узнать с помощью этой программы: название винта, версия микропрограммы, размер, количество головок и секторов, серийный номер ,изменять параметры накопителя , все можно в любое время и без перезагрузки, а также завершать работу программы без различных последствий. и многое другое. Я назвал лишь основные функции, а полное описание можно найти на сайте, а сейчас перейдём к самому главному.

Функции: показывает состояние винчестера (в верхней части экрана):

DREQ - ждёт поступление команд;
WRFT - ошибка возникшая при записи;
BUSY - винт не реагирует на команды;
ABRT - команда не принята;
TONF - не найден 0-й трек;
AMNF - нельзя обратится к заданному сектору.

Команды
~ Что бы изменить скорость/уровень шума надо ввести aam далее:
*M - минимальный шум/производительность;
*L - средний шум/производительность;
*P - максимальный шум/производительность;
*D- выключает AAM; самая большая производительность/шум из всех опций.
~ SMART-тесты запускаются командой smart test.
~ Также возможна установка пароля на винт, если вы забудете пароль, то потеряете винчестер как устройство! Если пароль не установлен, есть надпись Security: high OFF, а установлен, то Security: high ON.

Для установки пароля:
1) Выбрать винчестер, на который нужно установить пароль (Shift + F3);
2) Нажать F2;
3) Набрать pwd;
4) Набрать пароль (не более 32 символов) Внимание: запомнить пароль!
5) Нажать Enter
6) Всё! Пароль установлен.

Для снятия пароля:
1) Выбрать винчестер, с который нужно снять пароль (Shift + F3);
2) Нажать F2;
3) Набрать unlock;
4) Ввести пароль;
5) Набрать dispwd;
4) Ввести пароль;
5) Нажать F2;
6) Если всё набрано правильно, то надпись PWD исчезнет.

Данную программу можно посоветовать, как универсальную для ухода за винчестером.

Наверх


Чем отличаются Windows XP Professional и Windows XP Home?

Обе эти системы имеют очень много общего, XP Pro и XP Home построены на одном и том же ядре, NT 5.1. Разница между ними заключается только в том, что XP Home не поддерживает несколько функций, работающих в XP Pro. В XP Home не поддерживаются следующие функции:
  • Remote Desktop – позволяет удалённую работу на компьютере.
  • Offline Files and Folders – позволяет иметь доступ к сетевым ресурсам когда отключены от сервера.
  • Scalable processor support – поддержка многопроцессорных систем.
  • Encrypting File System – шифрование файлов на средствами файловой системы.
  • Access Control – ограничение доступа к файлам, программам и другим ресурсам
  • Centralized administration – централизованое администрирование системы в рамках домена.
  • Group Policy – облегчает администрирование групп пользователей на компьютере.
  • Software Installation and Maintenance – автоматически инсталлирует, конфигурирует, ремонтирует и удаляет программное обеспечение.
  • Roaming User Profiles – доступ к вашим документам и настройкам из любого места, где Вы подсоединились в домен.
  • Remote Installation Service (RIS) – поддержка удалённой инсталляции операционной системы по сети.
  • Multi-lingual User Interface (MUI) add-on – поддержка изменения языков интерфейса различных пользователей.
Кроме этого, есть незначительная разница в интерфейсах, например в XP Home нельзя выключить Simple File Sharing и включить нормальный.


Разное

Теперь рассмотрим дополнительные опции не вошедшие в предыдущие разделы.

Содержание

Корзина

Название корзины

Добавить или удалить значок корзины в Мой компьютер

Ввод данных

Требование программы о вводе данных

Разное

Системное время

Раскладка клавиатуры

Очистка списка последних редактированных в MS Paint файлов

Очистка списка последних редактированных в MS Word Pad файлов

Отключить автозапуск Компакт- диски

Проверка файлов

Корзина

Название корзины

Обновите рабочий стол, чтобы изменения вступили в силу.

HKCR\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}LocalizedString, значение - имя корзины
HKCR\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder Attributes Значение 40 01 00 20 меняем 40 на 70.
Клик правой кнопкой мыши на ярлыке "Корзины" и видим пункт "Переименовать".

Наверх
Добавить или удалить значок корзины в Мой компьютер

В разделе
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ MyComputer\NameSpace, создать ключ
{645FF040-5081-101B-9F08-00AA002F954E}, удалить значок корзины - удалите ключ

(нажмите F5), чтобы изменения вступили в силу.

Наверх

Ввод данных

Требование программы о вводе данных

Когда программа требует ввода данных, она может либо выскочить наверх, либо начать мигать иконкой в панели задач. Вы можете выбрать то поведение, которое вам больше нравится. Для этого нужно:
Найти в реестре ключ HKCU\ Control Panel\ Desktop.

Создать или изменить параметр ForegroundLockTimeout, тип DWORD и установить его значение на время задержки до "перехвата" фокуса: 0 — немедленно, а 200 000 (0x00030d40 hex) — значение по умолчанию.

А также создать или изменить DWORD-параметр ForegroundFlashCount и установить его значение на нужное число миганий для привлечения вашего внимания. Значения устанавливаются в десятичной системе: 0 заставит иконку мигать бесконечно, по умолчанию значение равно 3.

Наверх

Разное

Cистемное время

Windows XP умеет подстраивать системное время, сверяясь со специальными серверами в Интернете. Можно изменить адреса используемых серверов.

Без использования реестра: Щелкните правой кнопкой мыши на значке часов в системной области панели задач, выберите команду "Adjust Date/Time" и на странице "Internet Time" установите нужный сервер

При помощи реестра: Откройте раздел
HKLM\SOFTWARE\Microsoft\ Windows\CurrentVersion\DateTime\Servers
внесите свой собственный список серверов, использующихся для синхронизации времени.

Наверх
Раскладка клавиатуры

Рядом с часиками находится значок раскладки, позволяющий переключать языки при набивке текста (В России обычно используют два языка - Русский и английский). Чтобы изменить всплывающий текст при подведении мыши, идем в раздел
HKLM\System\CurrentControlSet\Сontrol\Nls\Locale. Там нужно изменить значение соответствующего параметра. Параметр русского языка — 00000419, английского — 00000409 и т.п. Например, вместо слова "Русский" пишем "Все пропало"

Данные изменения вступят после перезагрузки

Наверх
Очистка списка последних редактированных в MS Paint файлов

Для очистки списка последних редактированных в MS Paint файлов удалите или очистите следующие параметры:

HKCU\Software\Microsoft\Windows\CurrentVersion\Applets\Paint\Recent File List
File1=
File2= и т.д.

Наверх
Очистка списка последних редактированных в MS Word Pad файлов

Для очистки списка последних редактированных в MS Word Pad файлов удалите или очистите следующие параметры:

HKCU\Software\Microsoft\Windows\CurrentVersion\Applets\Wordpad\Recent File List
File1=
File2= и т.д.

Наверх

Отключить автозапуск компакт дисков

HKLM\SYSTEM\CurrentControlSet\Services\Cdrom

AutoRun:DWORD = 0 - автозапуск отключен, 1 - включен

Наверх
Проверка файлов

Можно выполнить проверку и восстановление поврежденных системных файлов, возможно при этом потребуется компакт-диск с дистрибутивом Windows XP. Пуск- Выполнить- sfc.exe /scannow. Параметр /scannow - немедленная проверка без выдачи запроса, вы также можете использовать другие параметры, например, /scanonce - разовая проверка при следующей загрузке системы, для более подробной информации запустите в командной строке sfc без параметров. Если программа sfc находит, что защищенный файл был переопределен, подходящая версия файла восстанавливается из папки %SYSTEMROOT%\system32\dllcache или если таковой нет, с компакт-диска. Более подробную информацию о защите файлов Windows XP вы можете найти в справочной системе.

Наверх


Просмотр результатов безопасности

Просмотр результатов, параметры, устранение несоответствий безопасности.
При использовании оснастки «Анализ и настройка безопасности» анализ безопасности выполняется путем сравнения текущего состояния системы с базой данных анализа. При создании в базе данных анализа используется, по крайней мере, один шаблон безопасности. Если импортируется несколько шаблонов, в базе данных выполняется слияние шаблонов и создание одного сборного шаблона. Таким образом устраняются конфликты в порядке импорта; приоритет имеет последний импортируемый шаблон.
Просмотр результатов анализа безопасности
Результаты анализа в оснастке «Анализ и настройка безопасности» упорядочены по областям безопасности и помечены значками, означающими неполадки. Для каждого атрибута безопасности областей безопасности отображаются текущие параметры системы и параметры основной конфигурации. Для изменения параметров базы данных анализа щелкните правой кнопкой мыши запись и выберите команду Свойства.
Значок | Описание
Красный X | Элемент определен в базе данных анализа и в системе, однако значения параметров безопасности не совпадают.
Зеленая отметка | Элемент определен в базе данных анализа и в системе; значения параметров безопасности совпадают.
Вопросительный знак | Элемент не определен в базе данных анализа и, следовательно, не анализировался. Если элемент не анализируется, возможно, он не был определен в базе данных анализа или пользователь, выполняющий анализ, не имеет достаточных разрешений на анализ данного объекта или области.
Восклицательный знак | Элемент определен в базе данных анализа, однако, не существует в текущей конфигурации системы. Например, может существовать группа с ограниченным доступом, определенная в базе данных анализа и не существующая в анализируемой системе.
Выделение отсутствует | Элемент не определен в базе данных анализа или в системе.

При принятии текущих параметров соответствующие значения в основной конфигурации будут исправлены на текущие. При изменении параметров системы в соответствии с параметрами из основной конфигурации изменения будут отражены при настройке системы из оснастки «Анализ и настройка безопасности».

Чтобы предотвратить дальнейшее выделение настроек, рассмотренных и признанных обоснованными, следует изменить основную конфигурацию. Изменения будут внесены в копию шаблона.

Сведения см. в разделах Выполнение анализа безопасности системы, Устранение несоответствий системы безопасности и Описания параметров безопасности.

Описания параметров безопасности
Конфигурация компьютера\Конфигурация Windows\Параметры безопасности
Область безопасности | Описание
Политики учетных записей | Политика паролей, политика блокировки учетной записи и политика Kerberos
Локальные политики | Политика аудита, назначение прав пользователя и параметры безопасности
Журнал событий | Параметры журналов событий приложений, системных событий и событий безопасности
Группы с ограниченным доступом | Состав групп с особыми требованиями к безопасности
Системные службы | Параметры запуска и разрешения для системных служб
Реестр | Разрешения для разделов реестра
Файловая система | Разрешения для файлов и папок

Параметры безопасности, описываемые в этом разделе, можно настраивать для одного компьютера или сразу для нескольких, используя средства диспетчера настройки безопасности. К этим средствам относятся:

  • Шаблоны безопасности
  • Анализ и настройка безопасности
  • Программа командной строки Secedit.exe
  • Локальная политика безопасности
  • Расширение «Параметры безопасности» для групповой политики

Чтобы установить или изменить отдельные параметры безопасности на отдельных компьютерах, используйте средство «Локальная политика безопасности». Чтобы определить параметры безопасности для нескольких компьютеров, используйте расширение «Параметры безопасности» для групповой политики. Чтобы применить несколько параметров в составе пакета, определите их с помощью шаблонов безопасности и затем примените с помощью средства «Анализ и настройка безопасности» или программы Secedit.exe, или импортируйте шаблон, содержащий нужные параметры, в соответствующую локальную или групповую политику.
Устранение несоответствий системы безопасности
Несоответствия базы данных анализа и параметров системы могут быть устранены следующими способами:
  • принятие или изменение некоторых или всех отмеченных или не включенных в конфигурацию значений , если определено, что уровни безопасности локальной системы допустимы для контекста (роли) данного компьютера. Значения этих атрибутов обновляются в базе и применяются к системе при выборе команды Настроить компьютер.
  • настройка системы в соответствии со значениями базы данных анализа, если установлено, что система не соответствует допустимым уровням безопасности.
  • импорт соответствующего роли компьютера шаблона в базу данных в виде новой конфигурации базы и применение его к системе.

  • Чтобы импортировать шаблон безопасности

    1. Откройте оснастку «Анализ и настройка безопасности».
    2. В дереве консоли щелкните правой кнопкой мыши узел Анализ и настройка безопасности и выберите команду Импорт шаблона.

Изменения вносятся в шаблон, хранящийся в базе данных, а не в файл шаблона безопасности. Файл шаблона безопасности будет изменен только при изменении параметров в оснастке «Шаблоны безопасности» и экспорте сохраненной конфигурации в тот же файл шаблона.

Команда Настроить компьютер служит только для изменения областей безопасности, не являющихся параметрами групповой политики, такими как безопасность локальных файлов и папок, разделов реестра и системных служб. В противном случае применяемые параметры групповой политики будут заменять локальные параметры (такие как политики учетных записей). Обычно при анализе безопасности клиентов домена команда Настроить компьютер не используется, так как необходимо отдельно настраивать каждого клиента. В этом случае следует вернуться к оснастке «Шаблоны безопасности», изменить шаблон и повторно применить его к соответствующему объекту групповой политики

Советы и рекомендации

Правильное использование шаблонов

  • Не следует изменять шаблон Setup security.inf, поскольку он позволяет восстановить параметры безопасности, используемые по умолчанию.
  • Шаблон Setup security.inf не должен быть использован при помощи групповой политики. Шаблон Setup security.inf должен применяться только на локальном компьютере при помощи средства «Анализ и настройка безопасности». Шаблон Setup security.inf изменяется во время установки и является уникальным для каждого компьютера. Шаблон содержит большое количество данных и может снизить производительность, если он применяется при помощи групповой политики, поскольку параметры этой политики периодически обновляются.
  • Совместимый шаблон не следует применять к компьютерам, которые являются контроллерами домена. Например, не следует импортировать совместимый шаблон в объект домена по умолчанию или в объект групповой политики стандартного контролера домена.

Соблюдение осторожности при изменении готовых шаблонов

  • Вместо изменения готового шаблона рекомендуется настроить такой шаблон и сохранить изменения под другим именем шаблона.
  • Готовые или только что созданные шаблоны безопасности не должны применяться на компьютере или в сети без предварительной проверки, в ходе которой должно подтверждаться наличие заданного уровня функциональности приложения.

Выбор уровня доступа к компьютеру, используемого по умолчанию

  • При определении уровня доступа к компьютеру конечных пользователей, используемого по умолчанию, решающее значение имеет установленная база приложений, которую требуется поддерживать. Дополнительные сведения см. в разделе Параметры безопасности.
  • Всегда проверяйте созданную политику на тестовом компьютере перед применением этой политики к сети.

    Параметры безопасности обновляются каждые 90 минут на рабочей станции или сервере и каждые 5 минут на контроллере домена. Кроме того, независимо от наличия изменений эти параметры обновляются каждые 16 часов.

  • Необходимо помнить, что к компьютеру могут быть применены несколько политик.

    Вследствие этого могут возникнуть конфликты в настройке политики безопасности. Порядок приоритета политик от более высокого к более низкому определяется следующим образом: подразделение, домен, локальный компьютер.

    Используйте средство «Результирующая политика», чтобы выяснить какие политики применены к компьютеру и какой и у них порядок приоритета.

  • Помните, что в домене может быть только одна политика учетных записей — «Политика по умолчанию для домена». Дополнительные сведения содержатся в разделе Учетные записи и локальные политики.
  • При импортировании шаблонов с помощью оснастки «Групповая политика» выполните следующие условия.
    • Не применяйте совместимый шаблон к компьютерам, которые являются контроллерами домена. Например, не импортируйте совместимый шаблон в политики «Политика по умолчанию для домена» и «Политика по умолчанию для контроллеров домена».
    • Не применяйте шаблон «Setup security» с помощью оснастки «Групповая политика».
  • Для локальной политики безопасности используйте ярлык Локальная политика безопасности для редактирования и настройки политики безопасности. Используйте оснастку «Шаблоны безопасности» для создания локальной политики, затем для ее применения используйте оснастку «Анализ и настройка безопасности».


Сеть

Локальные сети Диагностика сети

Итак, сети бывают локальные и глобальные. Локальные сети объединяют некоторое количество компьютеров в пределах одного или нескольких зданий. Такие сети иногда называют интранет. Глобальные сети подразумевают соединение различных локальных сетей в одну общую сеть, называемую Интернет.

Физическая установка сети

Предположим, что мы используем в сети три компьютера – два “клиентских компьютера” и один «сервера». Для организации, даже такой маленькой сети нам понадобятся сетевые карты, которые устанавливаются в каждый компьютер, свич или хаб, а так же специальный сетевой кабель, называемый витая пара. Какие использовать кабели, описание

Выбор сетевой карты

Сегодня сетевая карта стала настолько доступной, что частенько ее интегрируют на системную плату. В случае, если Ваша плата не имеет интегрированного сетевого контроллера, то Вам придется воспользоваться внешней PCI платой. Карта должна соответствовать стандарту Realtek 10/100. Она стоит около 10$. Более дорогие карточки имеют множество дополнительных функций, обеспечивающих большую стабильность при передаче данных. Ниже на фотографии показан внешний вид типичной сетевой карты.

При выборе сетевой карты, необходимо обратить внимание на максимальную поддерживаемую скорость передачи 10/100. Это означает, что карта может передавать данные на скорости 10mbps и 100mbps в зависимости от сетевой архитектуры. Дополнительно необходимо, что бы карточка имела разъем RJ-45 (современный стандарт CAT5), поддерживающий скорость передачи 100mbps и обратно совместимый с 10mbps стандартом (именно такой разъем показан на фотографии). Самый последний стандарт “CAT6”, (пока находится в разработке) будет поддерживать скорости от 300mbps до 1gbps. Это означает, что Вы сможете копировать файлы в сети со скоростью 125 мегабайт в секунду. Это быстрее скорости современных жестких дисков. CAT5-E или категория 5 UTP Enhanced так же обратно совместима с 10, 100 и 1000Mbit Ethernet. Использование RJ-45 предпочтительнее, чем RJ-58, или больше известные как BNC. Этот разъем предназначен для подключения на более низких скоростях (ограничена 10mbps) коаксиальным кабелем.

Хаб или Свич

Для управления всеми транзакциями (передача блоков информации) в сети используется устройство называемой хаб или свич. В чем отличие между этими двумя устройствами?. Во время передачи пакета данных хаб отправляет их сразу на все компьютеры, что значительно уменьшает пропускную способность канала. Свич, имеет встроенную память, в которой храниться информация о том, к какому порту подключен какой компьютер. Поэтому во время передачи пакета, он отправляется на определенный порт. Кроме того, свич позволяет использовать в сети контроллеры с разной скоростью передачи, при этом общая пропускная способность не будет опускаться до уровня контроллера с минимальной скоростью. Учитывая незначительное ценовое отличие мы настоятельно рекомендуем приобрести именно свич. На сегодняшний день впускаются свичи с 5, 8, 16, 24 или 32 портами. Цена устройства зависит от количества портов.

Говоря об организации сети, необходимо затронуть вопрос беспроводных сетей, т.е. передающих информацию по радиоканалу. Такие сети становятся все популярнее, т.к. позволяют сделать размещение компьютеров более гибким, а пользователям использующим мобильные компьютеры или ноутбуки, получить доступ к сети в любой точке офиса и даже за пределами. На сегодняшний день существует два стандарта 802.11a и 802.11b. Для реализации такого подключения необходимо использовать специальные хабы и сетевые карточки.

Конфигурация сети в Windows XP

Установить сетевые параметры в Windows XP Вы можете несколькими способами. Во-первых, вручную. Этот метода предпочтительнее, т.к. позволяет контролировать все настройки. Во-вторых, для тех, кто ничего не понимает в сетевых терминах, Microsoft включила мастер установки сети (Network Setup Wizard). Для запуска мастера, необходимо войти в "My Network Places"Сетевое окружение" и нажать на “set up a home or small office network”мастер настройки сети". Нажмите Next, на втором экране будут описаны некоторые рекомендации по правильной установке. Фактически здесь Вы найдете полное руководство к действию. Нажимаем Next-Далее. Теперь для всех клиентских компьютеров Вы должны выбрать третью опцию (Другое) и нажмите Next-Далее. На следующем экране Вы можете ввести или изменить имя компьютера. Теперь переходим к следующему окну, где мы сможем изменить название рабочей группе. Следующий экран резюмирует сделанные изменения и применяет их. На следующем экране Вам будет предложено создать диск установки сети. Так как мы делаем меленькую домашнюю сеть этот диск можно не создавать. Просто нажмите {{Wizard and then Finish}}-{{Выход}}.

Мастер сетевой идентификации

Теперь необходимо установить имя Вашего компьютера в рабочей группе, к которой он принадлежит. Для этого нажмите Start -> Settings -> Control Panel -> System -> и выберите закладку Computer Name. Сначала нажмите “Network ID”, что позволит активизировать мастер сетевой идентификации (Network Identification Wizard). На первом экране просто нажмите Next. На следующем экране нужно выбрать первую опцию (This computer is part of a business network, and I use it to connect to other computers at work), на следующем экране выберете вторую опцию (My company uses a network without a domain). Здесь Вы должны установить название рабочей группы. Эти действия Вы должны повторить на всех компьютерах Вашей сети.

IP адресация

Прежде всего вы должны идентифицировать каждый компьютер в сети. Для этого служит так называемая IP (Internet Protocol) адресация. IP адрес – это уникальный номер Вашего компьютера в Вашей сети. IP адрес может быть “статическим” или “динамическим”. В своей внутренней сети Вы можете использовать IP адреса класса C, т.е. в диапазоне 192.168.0.1 до 192.168.0.254. В одной рабочей группе может работать до 254 компьютеров. Обычно серверу назначают адрес 192.168.0.1. Когда Вы активизируете совместный доступ к сети (Internet Connection Sharing) по умолчанию Вашему серверу будет автоматически назначен этот адрес.
При установке постоянного IP-адреса, вместо динамически выделяемого, время загрузки сократиться более чем в 5 раз. Делается так: открывается Панель управления, в ней заходим в свойства Сети, там открываем свойства TCP/IP (внимание, имеется в виду настройки ЛОКАЛЬНОЙ сети, пожалуйста, не гробьте свой Internet прописанием не тех IP-адресов). А в свойствах протокола прямо на первой вкладке меняем "получение IP адреса автоматически" на постоянный адрес из 4 чисел. Пример 192.168.0.1 для первой машины, 192.168.0.2 для второй машины и т.д.

Конфигурация сервера

Для установки сетевых параметров Вы должны войти с правами администратора. Вам необходимо назначить каждому компьютеру IP адрес. Для этого нажмите Start - Settings - Network Connections. Теперь кликните правой кнопкой мышки на “Local Area Connection” и выберите меню Properties. Затем укажите на протокол TCP/IP и нажмите Properties. Перед Вами откроется окно, позволяющее установить все необходимые сетевые параметры.

В случае если доступа к сети нет, попробуйте сначала проверить правильность подключения всех кабелей, и включение концентратора или свича. Если все сделано правильно то при подключении сетевого кабеля к Вашей сетевой карте, на экране в tray области (рядом с часами, появиться сообщение о сетевом подключении на скорости 100 или 10Mb). В случае если этого не происходит, необходимо проверить включение опции отображения индикатора в сетевых настройках и проверить правильность и целостность кабеля. Далее надо пингануть серверное подключение. Для этого мы используем сетевые утилиты.

Если пинг не прошел, необходимо проверить работоспособность и настройку сетевых карт и свича. Кроме того, одной из причин имеющихся проблем может быть установка Windows XP поверх другой операционной системы имеющей настроенную сеть, либо компьютер использовал собственное подключение к Интернет. После неоднократной установки мы пришли к выводу, что для полной работоспособности необходимо устанавливать новую ОС на чистый диск, или раздел.

Статус Интернет соединения

Теперь необходимо коснуться вопроса контроля состояние подключения к Интернет. Особенно это касается случая использования операционных систем отличных от Windows XP. Для доступа к этой опции нажмите Start - Network Connections. Как Вы можете видеть Windows XP достаточно подробно показывает параметры соединения, такие как скорость соединения и трафик на Вашей клиентской машине. Кроме того, здесь Вы можете отключить Интернет соединение.

Совместное использование и доступ к файлам

Переходим к последнему параметру, совместному использования файлов и папок. Эта особенность позволит создавать в компании библиотеку документов, шаблонов и т.д. Открывать и ограничивать доступ к документам неугодных вам сетевиков. В общем, полностью организовать документооборот в сети. Для того, что бы разрешить сетевой доступ к файлам и папкам нужно в My Computer выбрать диск или папку, к которому нужно открыть доступ, и правой кнопкой войти в свойства диска или папки, где выберите закладку Sharing и ставите галочку.

Разное
Установка способа доступа к расшаренным ресурсам компьютера из сети.
Раздел: HKLM\System\CurrentControlSet\Control\Lsa
Параметр: restrictanonymous
Тип: DWORD
Если значение равно 1 - запрещает анонимным юзерам просматривать удаленно учетные записи и расшаренные ресурсы. 2 - отказывает любой неявный доступ к системе (в сетевом окружении компьютер не будет виден, однако, доступ к нему можно будет получить, обратившись к нему по его IP).

Если Вы работаете в сети, то можете "зашарить" какие-либо ресурсы, поставив символ " $ " в конце имени "шары". Такая "шара" не видна при просмотре, и подключиться к ней сможет только человек, который точно знает её имя.

Управление общедоступными (shared) каталогами на удалённой машине в Windows NT 4.0.
Есть несколько очень простых способов делать это (пример — создание shared folder):
1. Запустите Server Manager. Щёлкните мышью на имени нужного компьютера. Computer – Shared Directories – New Share...
2. Можно использовать утилиту RMTSHARE из Resource Kit.
3. Ещё один способ — через File Manager (Winfile.exe — наследство предыдущих версий Windows NT). Сначала подключаемся к тому дисководу на удалённой машине, где лежит нужная папка (например, net use x: \\<remote computer name>\C$). Затем запускаем File Manager –> Х: –> Disk –> Share As.

Александр Зорич http://www.orc.ru/~zalex

Если необходимо обеспечить автоматический вход в домен MS Windows NT или LAN Manager при старте операционной системы MS Windows 9x без участия пользователя, то можно воспользоваться любым из приведённых ниже способов:
С помощью кэширования пароля.
Данный способ позволяет избежать появления диалогового окна ввода имени пользователя, пароля и имени домена и установить автоматический вход в сеть при условии, что на рабочей станции используются единые пользовательские настройки и параметры Рабочего стола.

– Войдите в Панель управления, откройте значок "Сеть".
– На вкладке "Конфигурация" выберите способ входа в сеть "Обычный вход в Windows".
– В ответ на запрос Windows перезагрузить компьютер нажмите кнопку "Нет".
– Откройте значок Панели управления "Пароли".
– На вкладке "Смена паролей" нажмите кнопку "Сменить пароль Windows".
– В диалоговом окне "Изменение пароля Windows" введите действующий сетевой пароль в поле "Старый пароль", поля "Новый пароль" и "Подтверждение пароля" оставьте пустыми.

– Перейдите на вкладку "Конфигурация", проверьте, что установлен параметр "Все пользователи работают с едиными глобальными настройками и параметрами рабочего стола".
– Перезапустите Windows.
– При появлении диалогового окна "Ввод сетевого пароля" во время загрузки Windows введите пользовательский пароль для входа в сеть в поле "Пароль", установите флажок "Сохранить пароль в списке паролей" и нажмите кнопку "OK".
При следующих загрузках операционной системы диалоговое окно "Ввод сетевого пароля" появляться не будет, регистрация пользователя в сети будет происходить автоматически.

XP во время подключения к другому компьютеру проверяет запуск плановых задач на соседнем компьютере, что может занять до 30 секунд. Отключить можно здесь: HKLM/Software/Microsoft/Windows/CurrentVersion/Explorer/RemoteComputer/NameSpace. Удалить ключ {D6277990-4C6A-11CF-8D87-00AA0060F5BF} и перегрузить систему.

*

Вы можете улучшить сетевую производительность, проверив список сервисов своей рабочей станции Windows NT и удалив необязательные сервисы, расходующие важные системные ресурсы. Деинсталлируйте сервисы в апплете Services в Control Panel. Выберите сервис, который вы хотите удалить, затем укажите на Startup и выберите опцию Disable в диалоговом окне Startup Type.
*
Потенциально необязательные сервисы Windows NT Workstation:
Computer Browser — Позволяет системе использоваться в качестве основного браузера и участвовать в выборах браузеров. Отключайте, если вы не хотите, чтобы машина рассматривалась в качестве потенциального основного браузера в сетевом сегменте.
Server — Реализует серверный компонент SMB (или иначе CIFS) в системе NT. Отключайте, если вы не хотите совместно использовать ресурсы печати и файлы на машине и нет необходимости поддерживать удалённый доступ к Registry.

Alerter — Посылает административные предупреждения получателям, указанным в диалоговом окне Alerts апплета Server на Control Panel. Если вам не нужна эта машина для пересылки административных уведомлений, то этот сервис можно отключить.
Messenger — Посылает и получает сообщения, которые появляются на консоли получателя. Если вам не нужна эта машина для рассылки или получения сообщений, появляющихся на консоли, то отключите этот сервис.
Remote Access Autodial Manager — Уведомляет систему об использовании DUN удаленных сетях. Если вы не заинтересованы в установке коммутируемых соединений и хотите, чтобы пользователи вручную инициировали соединения DUN, то отключите этот сервис.
*
Выполнение в Windows NT операций на всех имеющихся в сети машинах.
Сначала получаем файл List.txt со списком всех имеющихся на данный момент в сети машин с помощью команды:
net view > list.txt
Затем, чтобы выполнить, например, копирование файла quaropts.dat на каждую машину в сети, дайте команду:
FOR /F " tokens=1 " %i in (list.txt) do copy quaropts.dat "%i\C$\program files\navnt"

Если команду надо давать из bat-файла, то требуется вместо % вводить %%.
*
Удалённое выключение нескольких компьютеров одновременно.
Если у Вас в конторе множество машин и Вам надоело каждый раз после рабочего дня ходить и выключать их, используйте утилиту shutdown.exe из Windows NT Resource Kit и bat-файл (компьютеры PDC и BDC выключаются через 2 секунды, локальные — через 5):

========
shutdown \\pdc /t:2 /y /c
shutdown \\bdc /t:2 /y /c
shutdown /l /t:5 /y /c
========
Создайте на рабочем столе ярлык для этого командного файла и выключайте все компьютеры нажатием на этот ярлык.

*

Для соединения двух компьютеров в локальную сеть на витой паре не обязательно использовать хаб. Можно сделать "нуль-хабный" ("cros s-over") кабель, который отличается от обычного только разводкой проводов в разъёмах:
1 3 бело-зелёный провод
2 6 зелёный
3 1 бело-оранжевый
4 4 синий
5 5 бело-синий
6 2 оранжевый
7 7 бело-коричневый
8 8 коричневый
Ограничение на длину кабеля сохраняется равным 100 метрам.

Очень дешёвый и простой в настройке способ подключения 3-х компьютеров. Нужно только 4 сетевые карточки и два cross-over провода.
Машину с двумя сетевухами XP автоматически переводит в режим network bridge. Получается одна простая сеть. До XP ни один Виндоус не поддерживал этот режим. Alex Angan <scelsior@yahoo.co.uk>

В заключении, я советую вам заглянуть на сайт www.homenetworks.ru, полностью посвященный домашним локальным сетям. Здесь вы почерпнете немало полезной информации, узнаете, чего не надо делать при прокладке сети, а на что следует обратить внимание. Там же найдете массу ссылок на другие ресурсы аналогичной тематики.

Для настройки безопасности пользуйтесь Брандмауэром, как его настроить читайте на сайте

Для детального ознакомления с сетевыми подключениями скачайте справочник "Сетевые подключения


Система

Система не загружается... восстановление

Сбои могут быть самыми различными: точечными и обширными, серьезными и просто неприятными, но наиболее опасными из них являются те, которые не дают системе загрузиться — для их ликвидации нужно заблаговременно позаботиться о восстановление системы после возможного отказа , нужно будет заранее предпринять некоторые шаги. Список наиболее часто встречающихся причин сбоев в работе ОС.

• Повреждение, удаление, замена на несовместимые версии важных системных файлов, в т.ч. и кустов реестра. Большая часть таких файлов находится в папке %SystemRoot%\system32, реестр в %SystemRoot%\system32\config.
• Установка несовместимых служб и драйверов. Это один из бичей всех NT-систем. Для уменьшения этой проблемы ввели цифровую подпись драйверов, подтверждающую, что они прошли тестирование в WHQL (Windows Hardware Quality Lab) на корректность работы и совместимость с ОС.
• Изменение критических для работоспособности системы параметров на недопустимые значения. Основная часть таких данных хранится в ветви HKLM\SYSTEM\Current-ControlSet. Для повышения отказоустойчивости они дублируются — ключи HKLM\SYSTEM\ControlSetnnn, где nnn — номер. CurrentControlSet является лишь ссылкой на один из этих ключей.
• Повреждения файловой системы: разрушение структуры каталогов, главной загрузочной записи (MBR), загрузочного сектора (Boot Sector) и т.д. NTFS очень чувствительна к подобным сбоям: если есть неисправимая ошибка, ОС просто не загрузится и покажет "синий экран смерти". С другой стороны, NTFS — журналируемая, самовосстанавливающаяся ФС.
• Физическое повреждение жесткого диска. Это аппаратная проблема— его нужно просто заменить.
• Неверно установленные права на системные папки: %SystemRoot%, %UserProfile%, %ProgramFiles%. В случае неправильно заданных прав на каталог %SystemRoot% система вообще может не загрузиться.

Теперь посмотрим, какие средства нам предоставляет ОС для защиты от этих напастей и ликвидации их последствий. Эти средства делятся на две категории: автоматически используемые ОС и нуждающиеся в ручном управлении.

1.1 Способ состоит в резервном копировании всех основных системных файлов: в Properties системного жёсткого диска, открываем вкладку Tools и нажимаем на кнопку Backup now... (это же можно проделать через Start -> Programs -> Accessories -> System Tools -> Backup). В открывшемся окне выбираем вкладку Backup и отмечаем галочкой System state, после чего нажимаем кнопку "Start Backup".
Способ этот хорош всем, кроме одного - созданный "резервирующий" файл (*.bkf) будет иметь размер примерно 200 MB, да и восстановить (вернее, исправить возникшие в ее работе ошибки) можно только при работающей системе, так этот способ всего лишь позволяет, восстанавливая системные файлы, не потерять все свои настройки, а значит, кроме прочего, и не переустанавливать заново инсталлирование программы.

Для уменьшения размера создаваемого при резервировании файла до 15-30 MB можно сохранить только содержимое папки \ system32\ config (полный список файлов реестра можно узнать, если заглянуть реестр: HKEY_LOCAL_MACHINE\ System\ CotnrolSet\ Control\ HiveList\ ), причем для этой цели совсем не обязательно проводить все те манипуляции, о которых рассказывалось выше - можно просто скопировать требующиеся для восстановления файлы в другое место, а при возникновении проблем с реестром загрузиться с любой загрузочной дискеты (хотя бы для DOS) и перезаписать сбойный реестр его резервной копией.

Всё это, конечно, прекрасно, но Windows XP может быть установлена не только на FAT, но и NTFS-раздел, и в этом случае обычная дискета не поможет - NTFS-раздел из DOS не виден. Естественно, и в этом случае выход есть, но для решения этой проблемы нужно будет воспользоваться утилитами сторонних разработчиков - например, воспользоваться программой NTFSDOS Pro, позволяющей производить чтение/запись файлов, размещенных на NTFS-разделе, из-под DOS. Кстати, на сайте разработчика NTFSDOS Pro есть подобная утилита и для работы с NTFS-разделами из-под Windows 9*.

А если NFSDOS (или какой-нибудь другой подобной утилиты) нет? - Сама Microsoft предусмотрела лишь один способ - загрузку с загрузочного компакт-диска Windows XP: в процессе загрузки системы будет предложено два варианта - установить систему заново или восстановить ее с помощью Recovery Сonsole. В случае, если выбрать Recovery Сonsole, поступит предложение ввести пароль Администратора, после чего - если введенный пароль окажется правильным - загрузится интерфейс командной строки. Список всех допустимых команд выводится командой "help", а наиболее важные для них следующие:
перезапись реестра - copy
вывод на экран списка системных служб и драйверов - listsvc
отключение определенной службы - disable (включение - "enable"),
восстановление загрузочных файлов - fixboot
восстановление Master Boot Record - fixmbr

Кстати, загрузить Recovery Соnsole совсем необязательно с CD - ее можно установить на жёсткий диск, и тогда при загрузке можно будет выбирать, загружать ли систему полностью или загружаться в Recovery Console.

Для установки Recovery Console нужно из командной строки в директории i386 дистрибутива Windows XP набрать - >winnt32.exe /cmdcons

Учитывая, что набор команд в Recovery Соnsole является очень ограниченным, имеет смысл поставить жесткий диск с неработающей системой на другой компьютер, работающий под управлением Windows XP или 2000, и попытаться спокойно разобраться в причинах краха системы - если и не разберетесь, то уж все данные с NTFS-разделов сможете перенести без проблем.

1.2 Системная дискета
Если вы думаете, что здесь речь пойдет о системной дискете MS-DOS, то ошибаетесь — подобная дискета бесполезна при использовании NTFS, так как нужен специальный драйвер NTFSDOS. Нет, я говорю о другом. Дело в том, что есть небольшая хитрость, которая позволяет делать интересные вещи.

Когда вы форматируете дискету в NT, то на ней создается загрузочный сектор, причем не стандартный для DOS, который загружает файл io.sys, а NT-шный, загружающий ntldr. Что это нам дает? А то, что мы вправе скопировать на дискету системные файлы (которые нужны для загрузки ОС) из корня системного диска: ntldr, NTDETECT.COM, boot.ini, а также Bootfont.bin (для русской версии NT) и (если захотите) bootsect.dos и подобные ему (загрузочные сектора других ОС). В результате при загрузке с дискеты мы запустим любую ОС, находящуюся на винчестере, прописанную в boot.ini на дискете и имеющую файл с загрузочным сектором на винчестере или дискете (если это не NT). Нюанс: если вы не копировали на дискету файлы с загрузочными секторами, то будут использоваться файлы с жесткого диска, если же вы их собираетесь использовать с дискеты, то в boot.ini дискеты нужно будет заменить в соответствующих строках букву диска (как правило C:) на букву дискеты (А: в большинстве случаев).

Зачем нам это нужно? Затем, что подобная дискета спасает от ряда проблем с MBR, загрузочным сектором и системными файлами — все это используется с дискеты.

1.3 Верификация драйверов
Это средство программиста/сисадмина. Если вы имеете неподписанный драйвер, в корректности работы которого сомневаетесь, или сами создали драйвер, то лучше всего будет запустить утилиту verifier.exe . Диспетчер проверки драйверов позволяет тестировать драйверы на типичные ошибки, а также выделять им отдельный пул памяти и следить за ним, что уменьшает вероятность сбоя при небольшом понижении быстродействия.

Работать с этой программой несложно, но нужны знания аппаратной части компьютера, архитектуры ОС и опыт системного программирования, иначе названия параметров вам ничего не будут говорить. Думаю, вы редко будете пользоваться данным средством, однако знайте, что оно есть.

1.4 Настройка системы

Если в сообщении об ошибке упоминается файл или служба, то файл или служба может отображаться на одной из вкладок утилиты "Настройка системы". Если такие файлы или службы отображаются, отключите их.

Чтобы отключить файл или службу с помощью утилиты "Настройка системы"

  1. Нажмите кнопку Пуск и выберите команду Выполнить.
  2. В поле Открыть введите msconfig
  3. Нажмите кнопку OK.
  4. Попытайтесь найти упоминавшиеся в сообщении об ошибке файл или службу в окне утилиты "Настройка системы".
    1. Выберите вкладку SYSTEM.INI, WIN.INI, Автозагрузка или Службы и, если требуется, разверните категорию (например, [386enh] на вкладке SYSTEM.INI).
    2. Если имеется элемент со ссылкой на упоминавшиеся в сообщении об ошибке файл или службу, снимите флажок этого элемента.
  5. Нажмите кнопку OK и в ответ на приглашение перезагрузите компьютер.

После отключения элемента в утилите "Настройка системы" неполадки устранены?

Если после изменения оборудования, программного обеспечения или параметров настройки компьютер остался в нерабочем состоянии, можно с помощью программы "Восстановление системы" отменить все внесенные изменения. Это может привести к устранению неполадок.


Службы

Службы – важный элемент операционной системы, они обеспечивают функциональность аппаратного и программного обеспечения, заданий и т.д. Конечно, лучше даже и не пытаться отключить ключевые процессы ядра операционной системы и связанные с ними службы, которые управляют распределением процессов, обработкой прерываний, операциями с файлами, с виртуальной памятью и т.д. Но в системе устанавливается большое число не критичных служб, которые работают по умолчанию и находятся на более высоком уровне абстракции по отношению к службам операционной системы. Эти службы вы можете отключить или изменить для увеличения времени реакции или производительности системы без серьезных побочных эффектов.
Вы можете запустить оснастку ( Открыть панель управления Службы "Services" ) через Панель управления/Администрирование/Службы (Control Panel/Administrative Tools/Services) или Пуск-Выполнить = Services.MSC.
После запуска оснастки вы увидите таблицу служб, которые доступны для модификации в вашей конфигурации Windows XP. В каждой строчке содержится описание службы (более подробный вариант можно получить в Справке), ее состояние (работает или нет), тип запуска (авто, вручную или отключено) и имя пользователя, под которым будет запущена служба. Проверить режим работы служб.
Если тип запуска установлен "авто", то служба будет автоматически запускаться при старте Windows. Службы с типом запуска "вручную" можно соответственно запустить вручную, или они могут быть запущены другими зависимыми службами (зависимыми называются службы, которые не могут работать без данной). Если служба отключена, она не будет запускаться.
Для получения максимальной производительности вы можете остановить некоторые службы и/или поставить их в тип запуска "вручную". Не устанавливайте тип запуска в "отключено", если вы не абсолютно уверены, что служба не понадобится вам, другим службами или "железу".

При рекомендации отключить ту или иную службу я исхожу из предпосылки, что настройка проводится на обычном домашнем компьютере. В противном случае вам надо исходить из реальных условий эксплуатации компьютера. Подробно описывать службы не буду, только комментарии.

Имя

Служба

Процесс

Настройка

Умолчание
Prof

Умолчание
Home

Windows Installer

MSIServer

msiexes.exe

Устанавливает, удаляет или восстанавливает программное обеспечение в соответствии с инструкциями файлов MSI- Вручную

Вручную

Вручную

Автоматическое обновление (Updates)

wuauserv

svchost.exe

Вручную

Авто

Авто

Адаптер производительности WMI (WMI Performance Adapter)

WmiApSrv

wmiapsrv.exe

Предоставляет информацию о библиотеках производительности от поставщиков WMI HiPerf - Вручную

Вручную

Вручную

Брандмауэр Интернета (ICF)

SharedAccess

svchost.exe

Предотвращает вторжение служб в домашней сети или сети небольшого офиса. При наличии сети и Интернет Авто, иначе Отключен

Авто

Вручную

Беспроводная настройка (Wireless Zero Configuration)

WZCSVC

svchost.exe

Предоставляет автоматическую настройку 802.11 адаптеров. Отключен

Авто

Авто

Веб-клиент (WebClient)

WebClient

svchost.exe

Позволяет Windows-программам создавать, получать доступ и изменять файлы, хранящиеся в Интернете. Авто

Авто

Авто

Вторичный вход в систему (Secondary Logon)

seclogon

svchost.exe

Позволяет запускать процессы от имени другого пользователя. Отключено

Авто

Авто

DHCP-клиент (DHCP Client)

Dhcp

svchost.exe

Если у вас в настройках сетевых подключений (Интернет) нет упоминаний о DHCP-сервере, можно поставить запуск - Вручную

Авто

Авто

DNS-клиент (DNS Client)

Dnscache

svchost.exe

Если компьютер не подключен к Интернет - Вручную

Авто

Авто

NetMeeting Remote Desktop Sharing

mnmsrvc

mnmsrvc.exe

разрешает проверенным пользователям доступ к рабочему столу - Отключить

Вручную

Вручную

Plug and Play

PlugPlay

services.exe

Желательно отключить. У меня отключен

Авто

Авто

QoS RSVP

RSVP

rsvp.exe

Для локальной машины вряд ли понадобится - Отключить

Вручную

Вручную

Telnet

TlntSvr

tlntsvr.exe

Удаленно запускают на вашей машине программы из консоли,- Отключить

Вручную

Не доступна

Диспетчер авто-подключений удаленного доступа (Remote Access Auto Connection Manager)

RasAuto

svchost.exe

Можно Отключить

Вручную

Вручную

Диспетчер подключений удаленного доступа (Remote Access Connection Manager)

RasMan

svchost.exe

Для локальных компьютеров выставить - Вручную, если вы подключены к сети- Авто

Вручную

Вручную

Диспетчер сетевого DDE (Network DDE DSDM)

NetDDE dsdm

netdde.exe

Вручную

Вручную

Вручную

Диспетчер логических дисков (Logical Disk Manager)

dmserver

svchost.exe

Вручную

Авто

Вручную

Диспетчер очереди печати (Print Spooler)

Spooler

spoolsv.exe

Если у вас нет принтеров (в том числе сетевых)- Отключить

Авто

Авто

Диспетчер служебных программ (Utility Manager)

Специальные возможности. Отключено

Авто

Авто

Диспетчер учетных записей безопасности (Security Accounts Manager)

SamSs

sass.exe

Для локальных компьютеров и сетевых машин, для получения информации о безопасности локальных пользователей - Авто

Авто

Авто

Журнал событий (Event Log)

Eventlog

services.exe

Если вы не заглядываете в лог-файл работы системы и не знаете, где он находится, то отключите службу. Если заглядываете, оставить Авто.

Авто

Авто

Защищенное хранилище (Protected Storage)

Protected
Storage

lsass.exe

Служба хранит пароли к вашему почтовому ящику, и не только к нему. Переключить на режим Вручную, если компьютер не подключен ни к Интернет, ни к локальной сети

Авто

Авто

Инструментарий управления Windows (Windows Management Instrumentation)

Winmgmt

svchost.exe

Авто

Авто

Авто

Источник бесперебойного питания (Uninterruptible Power Supply)

UPS

ups.exe

Если у вас есть ИБП, то ставьте Авто, иначе - Отключено

Вручную

Вручную

Клиент отслеживания изменившихся связей (Distributed Link Tracking Client)

TrkWks

svchost.exe

Поддерживает связи NTFS-файлов, перемещаемых в пределах компьютера или между компьютерами в домене. Если у вас NTFS - Авто

Авто

Авто

Координатор распределенных транзакций (Distributed Transaction Coordinator)

MSDTC

msdtc.exe

Вручную

Вручную

Вручную

Локатор удаленного вызова процедур (RPC) (Remote Procedure Call (RPC) Locator)

RpcLocator

locator.exe

Управляет базой данных службы имен RPC - Вручную

Вручную

Вручную

Маршрутизация и удаленный доступ (Routing & Remote Access)

Remote
Access

svchost.exe

Предлагает услуги маршрутизации организациям в локальной и глобальной сетях, - на несетевых компьютерах ставьте Отключено, если компьютер в локальной сети - Авто

Вручную

Откл

Модуль поддержки смарт-карт (Smart Card Helper)

SCardDrv

svchost.exe

Сомневаюсь, что у вас есть устройство чтения смарт-карт- Отключено

Авто

Авто

Обозреватель компьютеров (Computer Browser)

Browser

svchost.exe

Если компьютер не подключен в локальную сеть- Отключено

Авто

Вручную

Общий доступ к подключению Интернета (Internet Connection Sharing)

Shared
Access

svchost.exe

Если компьютер не подключен к сети - Отключено

Авто

Вручную

Оповещатель (Alerter)
Оповещения и журналы производительности (Performance Logs & Alerts)

SysmonLog

smlogsvc.exe

Вручную

Вручную

Вручную

Планировщик заданий (Task Scheduler)

Schedule

svchost.exe

Если вы пользуетесь планировщиком, то- Авто, в противном случае - Отключено

Авто

Авто

Поставщик поддержки безопасности NT LM (NT LM Security Support Provider)

NtLmSsp

lsass.exe

Обеспечивает безопасность программам, использующим удаленные вызовы процедур (RPC) через транспорты, отличные от именованных каналов- Вручную.

Вручную

Вручную

Рабочая станция (Workstation)

lanmanworkstation

svchost.exe

Нужна для других служб- Авто

Авто

Авто

Расширения драйвера оснастки управления Windows (Windows Management Instrumentation Driver Extensions)

Wmi

svchost.exe

Вручную

Вручную

Не доступна

Сервер (Server)

lanmanserver

svchost.exe

Для компьютеров, не подключенных к локальной сети - Отключить

Авто

Авто

Сервер папки обмена (ClipBook)

ClipSrv

clipsrv.exe

Вручную. Для несетевых компьютеров можно отключить

Вручную

Вручную

Сетевой вход в систему (Net Logon)

Netlogon

lsass.exe

Вручную

Авто

Вручную

Сетевые подключения (Network Connections)

Netman

svchost.exe

Управляет объектами папки ''Сеть и удаленный доступ к сети'', отображающей свойства локальной сети и подключений удаленного доступа- Вручную. Если вы не подключены к локальной сети и не выходите с этого компьютера в Интернет- Отключено

Вручную

Вручную

Система событий COM+ (COM+ Event System)

EventSystem

svchost.exe

Вручную

Вручную

Вручную

Служба администрирования диспетчера логических дисков (Logical Disk Manager Administrative Service)

dmadmin

dmadmin.exe

Вручную

Вручную

Вручную

Служба шлюза уровня приложения

ALG

alg.exe

Оказывает поддержку протоколов третьей стороны протоколов PnP для общего доступа к подключению к Интернету и подключений к Интернету с использованием брандмауэра. При наличии подключения к Интернет и Сети- Авто

Вручную

Вручную

Службы криптографии (Cryptographic Services)

CryptSvc

svchost.exe

Если у вас NTFS и вы шифруете файлы и тд то Авто, иначе Отключено

Авто

Авто

Служба времени Windows (Windows Time)

W32Time

svchost.exe

Устанавливает показания часов компьютера- Вручную

Авто

Авто

Служба индексирования (Indexing Service)

cisvc

cisvc.exe

Индексирует содержимое и свойство файлов на компьютере, для обеспечения быстрого их поиска- Отключено

Вручную

Вручную

Служба поддержки TCP/IP NetBIOS (TCP/IP NetBIOS Helper Service)

LmHosts

svchost.exe

Авто

Авто

Авто

Служба сетевого DDE (Network DDE)

NetDDE

netdde.exe

Обеспечивает сетевой транспорт и безопасность для динамического обмена данными (DDE) для программ, выполняющихся на одном или на различных компьютерах. Вручную

Вручную

Вручную

Службы терминалов (Terminal Services)

TermService

svchost.exe

Предоставляет возможность нескольким пользователям интерактивно подключаться к компьютеру и отображает рабочий стол и приложения на удаленных компьютерах. Вам это надо? Отключено

Вручную

Вручную

Служба удаленного управления реестром (Remote Registry Service)

RemoteRegistry

svchost.exe

Я думаю вам это не надо. Отключено

Авто

Не доступна

Служба факсов (Fax Service)

FAX

fxssvc.exe

Если у вас нет подключенного факс-модема или вы не пользуетесь им для приема факсимильных сообщений - Отключено

Не установлена

Не установлена

Съемные ЗУ (Removable Storage)

NtmsSvc

svchost.exe

Если у вас нет съемных носителей типа ZIP, LS-120- Отключено. Иначе - Авто

Вручную

Вручную

Телефония (Telephony)

TapiSrv

svchost.exe

Обеспечивает поддержку Telephony API (TAPI) для программ, управляющих телефонным оборудованием и голосовыми IP-подключениями на этом компьютере, а также через ЛВС - на серверах, где запущена соответствующая служба- Вручную

Вручную

Вручную

Уведомление о системных событиях (System Event Notification)

SENS

svchost.exe

Для сетевых компьютеров надо выставлять Авто, для домашних - Вручную или Отключено.

Авто

Авто

Удаленный вызов процедур (RPC) (Remote Procedure Call (RPC)

RpcSs

svchost.exe

Эту службу не трогать. Авто

Авто

Авто

Управление приложениями (Application Management)

AppMgmt

svchost.exe

Вручную

Вручную

Вручную

Фоновая интеллектуальная служба передачи (Background Intelligent Transfer Service)

BITS

svchost.exe

Вручную

Вручную

Вручную


Советы

Рекомендации

Если приходится часто переустанавливать Windows, распакуйте содержимое deploy.cab из каталога установочного диска XP и запустите setupmgr.exe. Эта программа позволяет полностью автоматизировать процесс установки (перед использованием обязательно читаем файл справки - есть много тонкостей).

Свойства Дата и время

В процессе инсталляции предлагается выбрать региональные установки (а позже это можно сделать через «Панель управления — Язык и стандарты»), выберите для русского языка кнопку «Настройка», перейдите к вкладке «Дата» и в строке «Полный формат» исправьте на dddd d MMMM yyyy ‘г.’. Кроме даты, у вас будет отображаться и день недели.

Диспетчер устройств

Иногда с помощью Диспетчера устройств [>Пуск- Выполнить-devmgmt.msc] решаются и некоторые малопонятные глюки. Например, если у вас будут проблемы c выключением компьютера или с пропадающим приводом флоппи-дисков, то иногда помогает такой трюк: выберите в Device Manager команду "View"> "Show hidden devices" - список имеющихся устройств несколько расширится, в том числе в нем появится и группа устройств "Non-Plug-and-Play Drivers". Делать там особенно нечего, но если в этом списке вы обнаружите устройство TPkd, то попробуйте удалить его, а также переместить файл TPkd.vxd из папки Winnt\System32 в другое место, где система его не сможет отыскать. После такой манипуляции проблемы с Windows XP у многих пользователей пропадают.

Если в Диспетчере устройств установить флажок "Вид" > "Показать скрытые устройства", то список этих самых устройств в его окне заметно возрастет, и вы увидите то, что Windows от вас так тщательно скрывала.

Отложенное расширение переменных среды

Отложенное расширение переменных среды по умолчанию не включено. Для включения используйте в разделе HKCU\Software\Microsoft\Command Processor параметр DelayedExpansion : dword= 1 (Аналогичная запись в ветви HKLM)

Бывают ситуации, когда надо запустить на компьютере пользователя программу в скрытом виде чтобы не было кнопки программы на панели задач и иконки в трее, а также чтобы не было видно окна программы, однако программистами в программе не предусмотрен такой режим запуска. Примеров можно привести массу, например, запуск какого-то монитора работы пользователя или клавиатурного шпиона... В этом случае можно воспользоваться средствами WSH для скрытого запуска таких программ. Вот пример JS-скрипта, запускающего в таком режиме обычный блокнот:

var WSHShell = WScript.CreateObject("WScript.Shell");
WSHShell.Run("notepad",0);

Второй параметр во второй строке, а именно - 0, указывает, что надо запустить файл в невидимом режиме. Создайте файл с расширением *.js и пропишите его в автозагрузку. Теперь работа вашей программы практически незаметна. Окно у нее невидимо, кнопки на панели задач нет, в диспетчере задач на вкладке "Приложения" она тоже не светится. Только в списке процессов возможно найти notepad.exe и снять его. Но если изменить имя файла, например, nvidia32.exe или volsnd32.exe, то далеко не каждый пользователь найдет эту подделку. Да и потом, часто ли вы лазите в диспетчер задач с целью поиска "непонятных" процессов?

Убрать значки с "Рабочего стола" и создать быструю панель можно нажав на "трэе" (где часы) правую кнопку мыши. В меню выбрать "Панели инструментов" - поставить галочку "Рабочий стол" (если там такового нет - нажать "создать" и там выбрать "Рабочий стол"). При этом слева от трэя появится перемещаемая панелька со стрелкой, разворачивающей всё содержимое "Стола". После этого зайти в свойства экрана, вкладка "Эффекты" и там установить галку "Прятать содержимое стола".
Всё!

Для работы с Интернетом можно пользовать Proxomiton. Это фильтр для входящего html кода. Настраивается всё, есть внутренний язык. Богатые возможности. От обрезания самораскрывающихся окон и ява-скриптов, до изменения самих приходящих страничек.
ссылки :
Для Proxomitron Naoko 4.0
http://proxomitron.hoha.ru/files/help/rus_help_n4.zip
http://www.proxomitron.nm.ru/files/help/rus_help_n4.zip
Для Proxomitron Naoko 3
http://proxomitron.hoha.ru/files/help/rus_html_help_n3.zip
http://proxomitron.hoha.ru/files/help/rus_win_help_n3.zip
http://proxomitron.nm.ru/files/help/rus_html_help_n3.zip
http://proxomitron.nm.ru/files/help/rus_win_help_n3.zip
Если нужны другие файлы (русификаторы и т.д.) - зайдите на сайт, на страницу загрузки:
http://proxomitron.hoha.ru/download.htm
http://proxomitron.nm.ru/download.htm
Там все ссылки должны работать.
Есть и конференция, в которой на ваши вопросы ответят, за что модератору большое спасибо!
РАБОТА С КОНФЕРЕНЦИЕЙ: http://groups.yahoo.com/group/prox-ru/

Если вдруг заголовок окна оказался за пределами вашего монитора, вы не можете перетащить окно в другое место. Но вы можете воспользоваться горячими клавишами. Нажмите ALT+SPACE а затем нажмите П (в русской версии) или M (в английской). Теперь вы может с помощью клавиш со стрелками перемещать окно в любое место.

В Windows XP можно переименовать сразу несколько файлов. Для этого выделяем файлы, щелкаем по любому из них правой кнопкой и переименовываем.
Все выделенные файлы получат имя указанного файла с индивидуальным номером в скобках

Terminator II (http://winchanger.narod.ru/)


Утилиты командной строки

Утилиты запускаются= Пуск- Программы- Стандартные- Командная строка или Пуск- Выполнить- cmd.exe

Утилита Systeminfo.exe предоставляет детальную информацию о конфигурации компьютера и его операционной системе: имя ПК, тип установленной ОС, ее версию, количество процессоров, их тактовую частоту и многое другое. Кроме всего прочего, с помощью этой утилиты вы сможете отследить, сколько времени операционная система работает без перезагрузки.

Утилита Shutdown.exe выключает или перезагружает локальный или удаленный компьютер. Ее параметры позволяют задать время, через которое произойдет действие, пользователь получит сообщение, а также объяснение причины завершения работы.

В Windows XP появилась возможность завершать задачи из командной строки. Это можно сделать с помощью утилиты taskkill . Итак, для того чтобы завершить какую-то задачу, нужно сначала узнать ее номер, воспользовавшись утилитой tasklist. Обе упомянутые утилиты позволяют создавать фильтры для обрабатываемых задач. Например, команда tasklist /fi "status eq not responding" выведет на экран список всех зависших задач, а команда taskkill /f /fi "username eq Guest" завершит все задания, запущенные пользователем Guest.

Утилита bootcfg.exe поможет в конфигурировании файла настроек boot.ini.

Утилита schtask.exe позволяет создавать расписание для запуска задач периодически или в заданное время.

Утилита Nslookup.exe служебная программа командной строки, предназначенная для диагностики инфраструктуры DNS.

Утилита cipher.exe система шифрования файлов.

Утилита secedit.exe настраивает и анализирует безопасность системы, сравнивая текущую конфигурацию с шаблоном.


Утилиты очистки реестра

Здесь мы рассмотрим утилиты очистки реестра NGBCleanRR Утилита для поиска и удаления неправильных ссылок в реестре и в ярлыках Windows® 95/98/NT/2000/ME. NBG Clean Registry является одной из самых мощных программ, ориентированных исключительно на очистку реестра. Она состоит из трех основных частей - сканера реестра, анализатора корректности ссылок и блока принятия решения, позволяет включать и отключать режим создания резервных копий, звуковые оповещения, а также выборочную проверку отдельных секций реестра, уменьшая, таким образом, суммарное время поиска. Кроме этого, весьма полезным является отображение в главном окне индикаторов загрузки оперативной памяти компьютера. И второй представитель чистильщиков jv16PowerTools, прекрасный менеджер для работы с реестром, zip- архивами, файлами. Среди всех программ, призванных облегчить процесс поддержания Реестра Windows в надлежащим состоянии, самой популярной, без сомнения, является программа jv16 Power Tools финского программиста Jouni Vuorio. Эта программа, являющаяся логическим продолжением и развитием другой, не менее популярной утилиты этого же автора, RegCleaner, способна удовлетворить большинство запросов всех категорий компьютерщиков - как зеленых новичков, так и прожженных профессионалов. Кроме того, из jv16 можно корректировать меню Windows "Найти" и "Открыть с помощью", деинсталлировать любую установленную ранее программу. Наконец, если пользователю вдруг понадобится сделать в реестре что-то, что выходит за пределы возможностей jv16, он может одним щелчком мыши вызвать стандартный редактор Реестра RegEdit. Почему эти утилиты, а не другие? Потому что эти утилиты более корректно и основательно чистят реестр. Мы перебрали практически все утилиты, и оставили у себя только эти утилиты. И ещё один нюанс, только одна из них должна стоять в системе, и ей делать чистку реестра. Почему? Когда будут две утилиты чистить, то какая из них, что и откуда удалит, знать не будете не вы, ни утилиты. Поэтому откат реестра будет не полным. После очистки системы двумя утилитами в течении недели, система начала зависать. Мы чистили сначала jv16pt , она почистила хорошо, мы перезагрузили систему и проверили, все нормально. Запустили утилиту NGBCleanRR , она нашла еще 59 ошибок. Получается что NGBCleanRR чистит глубже и основательней. Но с ней надо быть осторожней, ей не знакома Win XP. Перезагрузили систему и проверили работу, всё нормально. И так в течении недели. Результат плохой, система стала подвисать, некоторые проги начали зависать сразу при пуске. Проверили реестр, много бесхозных ключей, нужные исчезли. Удалили jv16pt , и запустили NGBCleanRR на восстановление реестра. После перезагрузки проверили ещё раз, результат 365 ошибок. Удалили их без лечения. NGBCleanRR имеет возможность лечить ошибки которые нашел. После перезагрузки проверили систему, она работала отлично. Исходя из выше рассказанного, jv16pt чистит реестр не до полной очистки, работает скажем так, мягко. NGBCleanRR чистит реестр основательно и поэтому его не рекомендуем новичкам. Для начинающих будет в самый раз jv16pt , или если уверены NGBCleanRR. Каждый волен выбирать то, что он сочтет нужным для себя. Важно , чтобы после чистки реестра система работала устойчиво. Будьте внимательны при работе с реестром.

RegScrubXP http://home.carolina.rr.com/lexunfreeware Загрузить с http://wotias.newmail.ru. Есть русификатор.

Знакомьтесь - сканер реестра Windows XP - RegScrubXP (581 кб), который ищет ненужные ключи уже деинсталлированных приложений и удаляет их. Утилита оснащена опцией отката, так что вы всегда сможете вернуться к исходному положению записей в реестре, а также имеет специальный лист исключений, куда пользователь может вносить определенные ключи.
RegScrubXP ведет также сортировку по расширениям файлов, производителям, автозапускаемым приложениям, истории посещений страниц в Интернете, оснащена подробной справочной системой и основными XP- твикерами.

Перед использованием программы, как водится, неплохо сделать резервную копию реестра, для чего необходимо проследовать в папку, куда была инсталлирована RegScrubXP, найти там hklm.cmd и hkcu.cmd, два раза кликнуть мышкой на первом и втором объекте, а созданные после этого файлы hklm.reg и hkcu.reg сохранить в безопасное место. Если когда-либо вам понадобится полностью восстановить реестр, вернуть его к изначальному положению, просто запустите эти файлы, реестр будет восстановлен и предстанет перед вами в первозданном виде, таким, каким он был до использования RegScrubXP.

Интерфейс сканера очень простой, после его запуска не составляет труда найти кнопку RegScrubXP Finds Problems и осознать ее предназначение. Прогулявшись по всему реестру, программа выводит список потенциальных проблемных ключей, далее у вас есть выбор - просмотреть список и отметить только некоторые ключи для исправления / удаления или, доверившись программе, удалить все, что она смогла найти. Нажав на кнопку Restore, вы увидите бэкап тех исправлений, которые вы только что внесли. Чтобы восстановить реестр, выделите файл бэкапа и нажмите кнопку Restore Selected Backups.

Реестр восстановлен. Но, в принципе, проблем возникнуть не должно. Обратите внимание также на кнопку User Determines Problems. Список, который вы увидите, нажав на нее, - не проблемные ключи, которые обнаружила RegScrubXP, а области реестра, где именно вы можете найти эти самые проблемные ключи. Простой пример: вы только что деинсталлировали какую-нибудь программу и, ориентируясь по ее названию, можете скомандовать RegScrubXP удалить ее следы в реестре.

Осталось рассказать про твикеры, которыми комплектована программка. Здесь есть и синхронизация системного времени через интернет, и отмена создания коротких имен в NTFS, и ускорение отображения меню, и ускорение выключения компьютера, и укрощение автозапуска CD-ROM, и изменение системного шрифта, и отображение версии XP на десктопе, и прочие глупости. В общем, попробуйте - вам понравится.


Файловые системы

Обзор файловых систем, которые стандартно поддерживаются этими ОС (а нестандартно, с помощью сторонних драйверов можно обеспечить работу с любой файловой системой). Следует учесть, что NTFS (New Technology File System) существует в виде нескольких версий, совпадающих с номером NT (5.1 для XP, например; наличие Service Pack эту закономерность может нарушить), соответственно нововведения ФС (Файловой Системы) не будут поддерживаться старой версией NT, поэтому использовать с ОС родную версию ФС. Список файловых систем, поддержка которых стандартно включена в Windows 2000/XP:
• NTFS — NT-системы.
• FAT12 — поддержка дискет.
• FAT16 — совместимость с MS-DOS.
• FAT32 — Windows 95 и 98.
• CDFS — файловая система компакт-дисков.
• UDF — универсальный формат дисков.

Поддерживается распределенная файловая система (Distributed File System — DFS) и файловая система с шифрованием (Encrypted File System — EFS). DFS представляет собой расширение сетевого сервиса и позволяет объединять в единый логический том сетевые ресурсы, а EFS — надстройка над NTFS, обеспечивающая функции шифрования.

CDFS
CDFS (Compact Disk File System), используемая в Windows 2000 (вроде, и в XP) выполнена по стандарту ISO 9660, согласно которому к именам файлов предъявляются следующие требования:
• Имя не превышает 32 символа.
• Все буквы строчные.
• Глубина вложения каталогов — не более 8 уровней.
Опытные пользователи заметят, что эти ограничения в большинстве случаев обходятся без проблем. В XP встроены средства для записи дисков с этой ФС.

UDF
UDF (Universal Disk Format) — файловая система, соответствующая стандарту ISO 13346, предназначенная для доступа в режиме чтения к DVD-ROM- и CD-ROM-дискам. В будущем планируется обеспечить доступ и на запись.

загрузочный сектор

FAT 2 (копия)

корневой каталог

область файлов

FAT12
ФС FAT (File Allocation Table) получила свое название по способу организации данных — таблицы размещения файлов. Она ориентирована на небольшие диски и простые структуры каталога. FAT12 является 12-битной верcией FAT, соответственно она может адресовывать 212 кластеров (минимальных логически адресуемых единиц данных на диске). Это ограничение и небольшое количество вхождений в корневой каталог определяет использование этой ФС. Сейчас она применяется на дискетах, раньше ее использовали на винчестерах, эта ФС была вытеснена улучшенной версией — FAT16. Диск с использованием любой FAT имеет следующую структуру (см. рис).
Корневой каталог имеет фиксированный размер. Каталоги — специальные файлы с элементами для каждого файла, содержащегося в этом каталоге. Эти элементы включают:
• Имя файла (8+3 символа).
• Байт атрибута (8 бит).
• Время модификации (16 бит).
• Дату модификации (16 бит).
• Первый размещаемый блок (12 бит для FAT12).
• Размер файла (32 бита).

Специальная надстройка над FAT, называемая VFAT (Virtual FAT), обеспечивает поддержку длинных имен файлов. Это следует учесть, так как некоторые старые DOS-утилиты могут запороть диск с длинными именами файлов, считая поврежденной структуру FAT. Все версии FAT не обладают функциями защиты данных и автоматического восстановления, посему я рекомендую их применять только для обеспечения совместимости.

FAT16
Улучшенная версия FAT. Максимальный размер тома равен 4095 Мб, размер кластера определяется размером тома и находится в диапазоне от 512 байт до 64 Кб. Число кластеров не превышает 216.

FAT32
Модифицированная версия FAT. Размер тома увеличен до 127 Гб, число кластеров — до 232. Позволяет использовать при одинаковых размерах томов кластеры меньшего размера, чем FAT16, что увеличивает эффективность организации данных. Впервые поддержка этой ФС появилась в Windows 95 OSR2. Все версии NT до 4.0 включительно ее не поддерживают (для поддержки в NT 4.0 нужен соответствующий Service Pack).

NTFS
Ну вот и дошли до самого интересного. Данная ФС является основной для NT. Без нее Windows NT уже и не NT (с этим трудно поспорить ввиду отсутствия в других ФС поддержки управления избирательным доступом и аудита). Эта файловая система обеспечивает эффективность, надежность и совместимость, невозможные в других поддерживаемых файловых системах, способна адресовать до 264 кластеров (в текущей реализации — до 232) и работать с кластерами оптимальных размеров. NTFS — самовостанавливаемая, основанная на транзакциях ФС, обладающая функциями самовосстановления. Здесь необходимы небольшие пояснения.

Все операции с метаданными в NTFS разбиваются на неделимые блоки — транзакции. Каждая транзакция может быть выполнена успешно, либо, в случае сбоя, откачана назад. Незавершенные транзакции не допускаются. Все транзакции регистрируются в файле журнала. Такой механизм обеспечивает абсолютную целостность структуры ФС, но допускает потерю пользовательских данных. В случае сбоя системы, в результате потери питания, при загрузке запускается программа AUTOCHK, проверяющая флаг "Грязный" тома. Если он установлен, запускается утилита CHKDSK, выполняющая 3 прохода: анализа, повторов и откатов. Таким образом обеспечивается выполнение, либо откат всех незавершенных транзакций. Это очень упрощенная схема, но она позволяет понять преимущества этой ФС над другими.

Структура NTFS довольно проста, хотя и сложнее, чем в FAT. Каждый распределенный на томе сектор принадлежит некоторому файлу, даже метаданные — информация, описывающая саму ФС. NTFS основана на атрибутах и обрабатывает все файлы как объекты с набором атрибутов, определенных как системой, так и пользователем. Каждый файл на томе с NTFS представлен записью в главной файловой таблице (MFT — Master File Table), аналоге FAT. Записи в MFT сортируются по алфавиту, что позволяет использовать двоичный поиск, существенно ускоряющий работу ФС. Для еще большей оптимизации диспетчером кэша используется алгоритм отложенной (lazy — ленивый) записи, когда данные не пишутся сразу на диск, а хранятся в памяти до тех пор, пока нагрузка на процессор не уменьшиться, а затем сбрасываются на диск фоновым процессом. Однако подобная практика чревата нехорошими последствиями в случае отказа питания. Самовосстановление не спасет пользовательских данных, хотя и обеспечит целостность структуры ФС. Вот почему любой уважающий себя администратор не ставит сервер без ИБП (Источник Бесперебойного Питания). В итоге, согласно авторитетным тестам, по быстродействию FAT выигрывает только на небольших томах с небольшим количеством файлов, в остальных случаях пальма лидерства остается за NTFS. Если вы хотите еще больше ускорить работу NTFS, воспользуйтесь следующим советом: отключите автоматическое обновление времени последнего доступа к файлу. Для этого в реестр по адресу HKLM\SYSTEM\CurrentControlSet\Control\FileSystem добавьте параметр NtfsDisableLastAccessUpdate типа REG_DWORD и установите его в 1. Существуют и другие способы оптимизации работы ФС, однако о них как-нибудь в другой раз. Ну, а сейчас я перечислю те функции, которые поддерживает ФС.

• Разреженные файлы. Это файлы, очень большие логически, но занимающие на диске только необходимый объем. Эта технология используется самой NT и СУБД (Системами Управления Базами Данных).

• Журнал изменений. Служит для регистрации всех изменений файлов на томе. Используется службой каталогов Active Directory и службой индексирования. Находится в папке System Volume Informa-tion в корне диска.

• Поддержка коротких имен. Это необходимо для совместимости с MS-DOS-программами. Каждый раз при создании файла NTFS делает дополнительную запись в MFT, содержащую короткий эквивалент имени. Эту опцию можно отключить, воспользовавшись ключом реестра Ntfs Disable8 dot3NameCreation в папке HKLM\SYSTEM\Current Control Set\Control\FileSystem, установив его в 1.

• Компрессия файлов и каталогов. NTFS обеспечивает динамическое, прозрачное для приложений сжатие файлов и каталогов на манер MS-DOS-утилит DriveSpace и Stack. Атрибут Сжатый можно установить как для всего тома, так и для отдельных файлов и каталогов. Сжатие возможно на разделах с кластером, не превышающим 4 Кб. Степень сжатия варьируется в зависимости от типа данных и максимальна для текстовых документов и файлов, созданных с помощью MS Office. Советую попробовать поэкспериментировать с утилитой COMPACT.

• Многопоточные файлы. Один и тот же файл может содержать несколько именованных потоков, содержащих разную информацию, причем размер файла высчитывается согласно содержимого главного, безымянного потока. Ради шутки можно создать файл, занимающий все место на диске, но обладающий нулевой длиной с точки зрения ПО. Писать в потоки можно с помощью перенаправления ввода-вывода: Echo Бла-бла-бла! > File.txt:First. Аналогично читаем: More < File.txt:First. Внимание! Данная функция поддерживается только в NTFS, и при копировании на тома с другой ФС информация в именованных потоках пропадет.

• Жесткие связи. Для одного и того же файла можно создать несколько имен внутри тома. При этом мы не увеличиваем количество файлов, а лишь делаем своеобразный ярлык. Файл остается на диске до тех пор, пока не удалят последнюю жесткую связь на него. Эта и 2 последующие технологии давно используются в UNIX-системах.

• Точки переопределения. Любой файл или каталог может быть точкой переопределения. Это способ представления имен системой ввода/вывода. Простейший пример: Диск D: монтируется в каталог C:\Disks\ D\. В итоге, зайдя в этот каталог, мы попадем на диск D:, хотя путь не изменится.

• Переходы NTFS. Позволяют спроецировать каталог-адресат в другой подкаталог. Т.е., зайдя в такой каталог, мы попадем в совсем другое место ФС. Чем-то напоминает предыдущий пункт, не правда ли? Доступны только на NTFS 5.0 и 5.1.

• Динамическое отслеживание ярлыков. Отслеживает перемещение файлов, на которые указывают ярлыки, соответственно изменяя ссылку на эти файлы в ярлыках. Работает только на локальных дисках с NTFS 5.0 и 5.1.

• Управление избирательным доступом. С помощью таблиц управления доступом (Access Control List — ACL) можно гибко разграничивать доступ к файлам и папкам. Можно работать как с отдельными пользователями, так и с группами, одновременно используя наследование прав доступа.

• Аудит доступа. Данная функция обеспечивает запись в журнал аудита все действия пользователя или группы аудита, предпринятые к указанному файловому объекту.

• Квотирование дискового пространства. Чтобы пользователи не захламляли диски своими файлами, для каждого из них можно создать квоту на используемое пространство диска. В итоге пользователь не сможет бездумно тащить на компьютер все, что под руку попадет: квота не резиновая, ее не превысишь. Данная функция появилась в Windows 2000.

В дополнение ко всему вышесказанному: существующий том с FAT можно преобразовать в NTFS без потери данных с помощью команды CONVERT, однако эффективность такого решения не очень высокая из-за особенностей процесса преобразования.
P.S.: Надеюсь, убедил использовать NTFS везде, где это возможно. При грамотной настройке и обслуживании NT + NTFS показывают чудеса производительности и устойчивости.


ntfs

Что такое NTFS

При установке Windows XP вам будет предложено отформатировать существующий раздел, на который устанавливается ОС, в файловую систему NTFS. Так что же это такое?

Файловая система NTFS обеспечивает такое сочетание производительности, надежности и эффективности, которое невозможно получить с помощью FAT. Основными целями разработки NTFS являлись обеспечение скоростного выполнения стандартных операций над файлами, таких как чтение, запись, поиск, и предоставления дополнительных возможностей, включая восстановление поврежденной файловой системы на чрезвычайно больших дисках.

Файловая система NTFS является "своей" файловой системой для Windows NT, а как известно WinXP, является своеобразным продолжением этой линейки ОС. Но если вы собираетесь использовать на одном компьютере несколько операционных систем таких, как Windows 9x и Windows XP, то загрузочный том нельзя форматировать в NTFS, так как линейки Windows 95(98) "понимают" только FAT, и дисков, отформатированных в NTFS для этих ОС просто не существует. Файлы находящиеся на дисках NTFS можно увидеть только используя программы сторонних производителей. Если же во время установки вы не отформатировали раздел в NTFS, то это можно сделать и после неё. В командной строке WindowsXP необходимо набрать "Convert (имя диска)/FS:NTFS" без кавычек.

Ниже приводится сравнительная таблица файловых систем FAT и NTFS

Ограничения | NTFS | FAT и FAT 32
Размеры тома | Минимальный размер тома составляет приблизительно 10 Мб. | FAT поддерживает различные размеры томов - от объема дискет и до 4 Гб.
 | На практике рекомендуется создавать тома, размеры которых не превышают 2 Тб. | FAT 32 поддерживает тома объемом от 2 гб. до 2 Тб. Работая под управлением Windows XP для Fat 32 можно отформатировать тома, размер которых не превышает 32 Гб.
 | С помощью NTFS нельзя форматировать дискеты. | Не поддерживаются диски размеры которых меньше 512 Мб.
Размеры файлов | Теоритически размер файла может составлять 16 экзабайт. | FAT поддерживает файлы размером не более 2 Гб. FAT 32 подерживает файлы размером не более 4 Гб.

NTFS обладает характеристиками защищенности, поддерживая контроль доступа к данным и привилегии владельца, играющие исключительно важную роль в обеспечении целостности важных данных. Папки и файлы NTFS могут иметь назначенные им права доступа вне зависимости от того, являютя ли они разделяемыми или нет.
NTFS - единственная файловая система в Windows, которая позволяет назначать права доступа к различным файлам. Устанавливая пользователям определенные разрешения для файлов и каталогов, пользователь может защищать конфиденциальную информацию от несанкционированного доступа. Разрешения пользователя на доступ к объектам файловой системы работают по принципу дополнения. Это значит, что действующие разрешения, то есть те разрешения, которые пользователь реально имеет в отношении конкретного каталога или файла, образуются из всех прямых или косвенных разрешений, назначенных пользователю для данного объекта с помощью логической функции "Или". Например, если пользователь имеет право назначить разрешение для каталога на чтение, а косвенно через членство в группах ему дано право на запись, то в результате пользователь сможет читать информацию в файлах каталога и записывать в них данные.
Для назначения пользователю или группе разрешения на доступ к определенному файлу необходимо: 1. Указать файл мышью и нажать правую кнопку. Выбрать пункт Properties (Свойства) контекстного меню. В появившемся окне свойств файла перейти на вкладку Security (Безопасность). По умолчанию данной вкладки там нет, чтобы она появилась необходимо в свойствах папки убрать галочку Simple File Sharing (использовать простой общий доступ к файлам).
2. В группе Name (Имя) показан список пользователей и групп, которым уже предоставлены разрешения для этого файла. Для того, чтобы добавить или удалить пользователей или новые группы, нажать кнопку Add/Remove (Добавить/Удалить) Появится окно диалога Select Users, Groups (Выбрать пользователей, группы).В поле Enter the object names to select (Введите имена выбираемых объектов) написать имя пользователя, кнопка Check Names (Проверить имена) позволяет проверить правильность написания имени.
3. В группе Permissions (Разрешения) устанавливаются разрешения. Присутствуют указатели Deny (запретить) и Allow (Разрешить). Устанавливаются флажки для следующих параметров: Full Control (полный контроль) - пользователь получает неограниченный доступ к файлу, Modify (Изменение) - пользователь может изменять файл, Read & execute (Чтение и выполнение), Read (Чтение) - пользователь может только читать файл, Write (Запись) - пользователь может записывать в файл.

Для более тонкой настройки разрешений необходимо нажать кнопку Advanced. Появляется диалоговое окно Advanced Security Settings for (Дополнительные параметры безопасности). Здесь можно дополнительно указать дополнительные разрешения, настроить политику аудита, изменить (просмотреть) информацию о владельце файла и добавить / удалить пользователей, могущих получить доступ к файлу.
Следующее, очень полезное свойство файловой системы NTFS - это возможность введения квот. Это свойство, как правило необходимо системным администраторам, больших компаний, где работают большое количество пользователей, у которых нет привычки следить за актуальностью информации, и которые хранят ненужные файлы, тем самым занимая дисковое пространство. Так как администратор не может проследить за всем этим, он может ввести квоту на использование диска определенному пользователю. После установки квот пользователь может хранить на томе ограниченный объем данных, в то время как на этом диске может оставаться свободное пространство. Если пользователь превысит выданную ему квоту, в журнал событий будет внесена соответствующая запись. Чтобы включить квоты на диске нужно прежде всего, чтобы он был в формате NTFS, затем в свойствах папки Tools-Folder Options-View убрать флажок Simple File Sharing. Это нужно для того, чтобы в свойствах диска появилась вкладка Quota. В ней необходимо установить флажок на Enable quota managment (Активизировать управление квотами). Это будет установлена мягкое квотирование, которое выдаст предупреждение, что пользователь, если так случится, превысил квоту, но право на запись у него будет. Чтобы в случае превышения квоты пользователю было отказано в доступе к этому тому, необходимо установить флажок на Deny disk space to users exceeding quota limit (Запретить запись на диск пользователям, превысившим размер дискового пространства). На этой же вкладке можно установить размер выделяемой квоты (Limit disk space to) и порог, превышение которого вызывает запись предупреждения в журнале событий (Set Warning level to) - Установить порог выдачи сообщения. Эти параметры устанавливаются по умолчанию для всех пользователей. В окне же Quota Entries можно изменить параметры квоты, задаваемой для конкретного пользователя. Для этого следует выделить конфигурируемую учетную запись, с помощью контекстного меню выбрать свойства и сконфигурировать квоту.
И ещё одно нововведение NTFS 5 - точки монтирования. Пользователь может определить различные, не связанные с собой папки и даже диски в системе как один диск или папка. Это имеет большую важность для определения в одном месте разнородной информации, находящейся в системе. Файлы и папки таким образом созданные имеют уникальный идентификационный номер, что гарантирует их правильное нахождение в системе, даже если папка или файл был перенесен.


Шрифты

В окне "Welcome" изменить шрифты на сглаженные (cleartype)

Открываем реестр, ключ HKEY_USERS \.DEFAULT \Control Panel\Desktop, параметр FontSmoothingType и изменить его значение на 2. При следующей перезагрузке системы ждем появления экрана "Welkome", наслаждаемся полученным эффектом..

Оформление: шрифт которым отображаются меню программ.

Программа не использует системные настройки для своего интерфейса, или иероглифы отображаются в каком-то другом элементе, не в меню, то идем в реестр. В ряде случаев помогает изменение параметров в реестре, относящихся к настройкам ОС в целом.

Раздел реестра HKLM\System\CurrentControlSet\Control\Nls\Codepage
изменить параметры:
"1250" = "c_1251.nls"
"1252" = "c_1251.nls"

Если же кракозябры все равно не исчезли, следует проверить правильность установки Languadge Options: запускаем апплет Regional and Languadge Options (он в Контрольной панели) и открываем закладку Regional Options. В разделе Standart and formats имеет смысл выставить "russian", в разделе Location, отвечающем в том числе за системные шрифты - обязательно указать "Russia". Необходимо проверить вкладку Advanced: Language for non- Unicode programs должен быть выставлен в "Russian". Для решения проблемы в Фотошопе следует воспользоваться этим ( ps601patch110.zip) патчем, обновить до версии 6.01. Еще одним решением, является использование Photoshop 7 версии, в нём нет проблем с национальными раскладками.

Пропадают системные шрифты

Проверяем наличие системных файлов с помощью команды: sfc.exe /scannow
Windows проверит их (шрифты - тоже системные файлы) и при необходимости переустановит недостающие или поврежденные. Если не помогло - запускаем установочный диск Windows XP и выбираем пункт Upgrade to Windows XP (делать это надо из Windows XP).

DOS: русские буквы видны, а раскладка не переключается

Открываем реестр, находим ключ HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Control \KeyboardLayout \DosKeybCodes и изменяем значение 00000409 на "ru". После этого открываем файл autoexec.nt (он находится в папке %SystemRoot%\system32) и добавляем строку->
lh %SystemRoot%\system32\kb16.com ru
Перегружаем компьютер и убеждаемся, что теперь в DOS-приложениях переключение на русскую раскладку происходит по нажатию Ctrl+Right Shift, на английскую - Ctrl+Left Shift.


ядро системы

Как поменять ядро системы?
Ядро меняется в Device Manager -> Computer, как и любой другой драйвер.

Это ИСКЛЮЧИТЕЛЬНО важно, НЕ СТАВЬТЕ ядро, которое не держится железом. Если не уверены, то лучше ничего не трогать, потому что последствия установки неправильного ядра непредсказуемы. Скорее всего машина просто перестанет загружаться, во всех режимах. Предотвратить подобное можно подредактировав boot.ini. Нужно всего лишь продублировать рабочий пункт меню выбора ОС, например,

multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Professional" /fastdetect

и приписать после /fastdetect следующие опции: /kernel=ntoskchk.exe /hal=halchk.dll,

а также в директории WINDOWS\System32 сделать копии вашего ядра и HAL-а. Назвать их, конечно же, надо ntoskrnl.exe -> ntoskchk.exe и hal.dll -> halchk.dll.

Кроме этого, необходимо учитывать одну тонкость. Видимо из за того, что при установке неправильного ядра XP просто виснет, теперь весь список доступных ядер не выводиться в окне смены драйвера. Таким образом, возможна ситуация, когда точно знаете, что ядро поддерживается системой, но система не даёт его установить. В этом случае, придётся делать это вручную. Для начала найдите в windows\inf файл под названием hal.inf. После этого, изучите его, чтобы выяснить, какие файлы и куда переписываются при смене ядра. Обычно перезаписывается только hal.dll, названия какого hal какому ядру соответствуют, можно узнать из списка:

Standard PC - hal.dll
Advanced Configuration and Power Interface (ACPI) PC -halacpi.dll
ACPI Uniprocessor PC - halaacpi.dll ACPI Multiprocessor PC -halmacpi.dll
Compaq SystemPro Multiprocessor or 100% Compatible - halsp.dll
MPS Uniprocessor PC -halapic.dll
MPS Multiprocessor PC -halmps

После этого "выдрать" соответствующий файл из Windows\Driver Cache\i386\driver.cab, скопировать его с Windows\system32, и сослаться на него в boot.ini. После загрузки (если повезёт :-)), можно переставить его по нормальному, в списке это ядро появится.


Общие сведения о средстве «Восстановление системы»

Общие сведения о восстановлении

В Windows XP включено несколько средств, обеспечивающих правильность установки и работы компьютера, приложений и устройств. Эти средства помогают пользователям устранять неполадки, возникающие в результате добавления, удаления или замены файлов, необходимых для работы операционной системы, приложений и устройств. Большинство этих средств доступно во всех трех версиях Windows XP: Windows XP Home Edition, Windows XP Professional и Windows XP 64-Bit Edition.

Выбор средства или средств восстановления зависит от типа возникшей неполадки или сбоя. Следующий список помогает выбрать средства для устранения конкретных неполадок.

Личные файлы данных отсутствуют или повреждены, либо требуется вернуться к предыдущей версии файла.

Если копия нужного файла данных была сохранена в другом расположении, файл можно скопировать обратно на жесткий диск. Резервную копию можно создать в любое время, скопировав файл в другую папку на используемом компьютере, на внешний носитель (такой как съемный диск) или на другой компьютер.
Программа архивации
Использование: при необходимости восстановления версии файла данных, сохраненной с помощью программы архивации.
Выполняемые действия: восстановление файлов из архивов.
Доступность: во всех версиях Windows XP. По умолчанию данное средство в Windows XP Home Edition не устанавливается. Однако его можно установить с компакт-диска Windows XP Home Edition.

После обновления драйвера вход в систему возможен, но система нестабильна.

Откат драйверов устройств
Использование: когда требуется только отменить обновление драйвера устройства (кроме драйвера принтера). Необходимо войти в систему в качестве администратора.
Выполняемые действия: повторная установка драйвера, использовавшегося ранее, и восстановление всех параметров драйвера, измененных при добавлении нового драйвера. Другие файлы или параметры не затрагиваются. Откат драйверов принтера невозможен.
Доступность: Windows XP Home Edition и Windows XP Professional.
Восстановление системы
Использование: в случаях, когда после обновления драйвера устройства не удается восстановить стабильность системы с помощью средства отката драйверов. Для использования данного средства необходимо войти в систему в качестве администратора.
Выполняемые действия: восстановление параметров системы и приложений, действовавших на указанный момент времени. Отмена изменений ключевых файлов приложений, драйверов и операционной системы, сделанных с указанного момента времени. Файлы данных не затрагиваются.
Доступность: Windows XP Home Edition и Windows XP Professional.

После установки нового устройства система работает нестабильно.

Отключение устройства
Использование: при подозрении о том, что причиной неполадки является одно или несколько устройств. Необходимо войти в систему в качестве администратора.
Выполняемые действия: отключение устройства и его драйверов.
Доступность: Windows XP Home Edition и Windows XP Professional.
Восстановление системы
Использование: если при подозрении о том, что причиной неполадки является одно или несколько устройств, отключение или удаление устройства не привело к устранению неполадки. Необходимо войти в систему в качестве администратора.
Выполняемые действия: восстановление параметров системы и приложений, действовавших на указанный момент времени. Восстановление ключевых файлов приложений, драйверов и операционной системы, измененных с указанного момента времени. Файлы данных не затрагиваются.
Доступность: Windows XP Home Edition и Windows XP Professional.

Изменение параметров системы или приложения привело к ухудшению работы компьютера, а способ восстановления предыдущих параметров неизвестен.

Откат драйверов устройств
Использование: когда требуется только отменить обновление драйвера устройства (кроме драйвера принтера). Необходимо войти в систему в качестве администратора.
Выполняемые действия: повторная установка использовавшегося ранее драйвера устройства и восстановление всех параметров драйвера, измененных при добавлении нового драйвера. Другие файлы или параметры не затрагиваются. Откат драйверов принтера невозможен.
Доступность: Windows XP Home Edition и Windows XP Professional.
Восстановление системы
Использование: при подозрении о внесении любого из следующих изменений:
  • изменение параметров системы или приложения, в том числе с помощью диалоговых окон свойств или системного реестра;
  • установка, обновление или удаление приложений;
  • добавление или удаление файлов, кроме файлов данных.

При подозрении о том, что причиной неполадки является установка приложения, сначала попробуйте удалить это приложение. Если это не устранит неполадку, воспользуйтесь средством восстановления системы. Для использования средства восстановления системы необходимо войти в систему в качестве администратора.

Выполняемые действия: восстановление параметров системы и приложений, действовавших на указанный момент времени. Восстановление ключевых файлов приложений, драйверов и операционной системы, измененных с указанного момента времени. Файлы данных не затрагиваются.
Доступность: Windows XP Home Edition и Windows XP Professional.

После установки приложения система работает нестабильно или приложение работает неправильно.

В некоторых случаях система предлагает восстановить или переустановить приложение из сетевого ресурса или с исходного установочного носителя (например, с компакт-диска). В этих случаях следуйте инструкциям на экране по восстановлению программы. При выводе такого предложения для восстановления программы можно воспользоваться одним из следующих средств.
Установка и удаление программ
Использование: при подозрении о том, что причиной неполадки является одна или несколько программ.
Выполняемые действия: удаление указанных программ.
Доступность: во всех версиях Windows XP.
Восстановление системы
Использование: когда устранить неполадку с помощью средства «Установка и удаление программ» не удается. Необходимо войти в систему в качестве администратора.
Выполняемые действия: восстановление всех параметров системы и приложений, действовавших на указанный момент времени. Восстановление ключевых файлов приложений, драйверов и операционной системы, измененных с указанного момента времени. В результате отменяются все изменения, внесенные в систему данной программой. Файлы данных не затрагиваются.
Доступность: Windows XP Home Edition и Windows XP Professional.

Операционная система не загружается (экран входа в систему не выводится)

Загрузка последней удачной конфигурации
Использование: при подозрении о том, что причиной сбоя является изменение, внесенное в систему перед перезагрузкой.
Выполняемые действия: восстановление параметров реестра и драйверов, действовавших при последней успешной загрузке компьютера.
Доступность: Windows XP Home Edition и Windows XP Professional.
Загрузка в безопасном режиме и восстановление системы
Использование: если после загрузки с использованием последней удачной конфигурации система по-прежнему не работает.
Выполняемые действия: загрузка с использованием только основных файлов и драйверов (драйвер мыши, кроме драйвера мыши для последовательного порта; монитор; клавиатура; диски; видеоадаптер; стандартные системные службы; отсутствие сетевых подключений). Если удалось загрузить систему в безопасном режиме, воспользуйтесь средством восстановления системы для восстановления всех параметров системы и приложений, действовавших на тот момент времени, когда система работала оптимально.
Доступность: Windows XP Home Edition и Windows XP Professional.
Консоль восстановления
Использование: в случае сбоя загрузки с использованием последней удачной конфигурации и загрузки в безопасном режиме. Данный способ рекомендуется только для опытных пользователей, которые могут воспользоваться основными командами для определения драйверов и файлов, вызвавших неполадку. Для использования консоли восстановления перезагрузите компьютер, вставив в устройство чтения компакт-дисков установочный компакт-диск операционной системы. При появлении соответствующего приглашения на текстовом этапе процесса установки нажмите клавишу R для запуска консоли восстановления.
Выполняемые действия: с помощью консоли восстановления можно выполнять доступ к дискам компьютера. После этого можно вносить любые из следующих изменений для обеспечения возможности загрузки компьютера:
  • включать и отключать драйверы устройств или службы;
  • копировать файлы с установочного компакт-диска операционной системы или других съемных носителей (например, можно скопировать необходимый файл, который был удален);
  • создать новый загрузочный сектор и новую основную загрузочную запись (MBR). Это может потребоваться при сбое загрузки с существующего загрузочного сектора.
Доступность: во всех версиях Windows XP.
Аварийное восстановление системы
Использование: в случае неудачи всех попыток восстановления или после замены поврежденного системного жесткого диска. Предварительно необходимо создать набор аварийного восстановления системы с помощью программы архивации.
Выполняемые действия: восстановление всех подписей дисков, томов и разделов на дисках, необходимых для загрузки компьютера. Затем система аварийного восстановления системы выполняет простую установку Windows и автоматически запускает процесс восстановления с использованием архива, созданного мастером аварийного восстановления системы.
Доступность: Windows XP Professional. В Windows XP Home Edition средство аварийного восстановления системы недоступно.
Установочный компакт-диск Windows
Использование: При отсутствии архива для использования средством аварийного восстановления системы, если не удалось загрузить компьютер в безопасном режиме, с использованием последней удачной конфигурации или консоли восстановления.
Выполняемые действия: переустановка операционной системы. После этого необходимо переустановить приложения и восстановить файлы данных из архива.
Доступность: во всех версиях Windows XP.

назад


Выделение большего места на диске для архивирования точек восстановления

Чтобы выделить больше места на диске для архивирования точек восстановления

  1. Откройте компонент Система.
  2. Выберите диск из поля Доступные диски и затем нажмите кнопку Настройка. Если имеется только один диск или раздел, этот шаг можно пропустить.
  3. В окне Параметры диска <буква:> сдвиньте ползунок регулятора в группе Использование дискового пространства, чтобы изменить объем, выделяемый для восстановления системы. Следует отметить, что нельзя выделить более 12 процентов доступного места на диске.

Примечания

  • В диалоговом окне Свойства системы выберите команду Восстановление системы.

  • Для восстановления системы нужно не меньше 200 Мбайт дискового пространства (или места в разделе, содержащем папку Windows System). Наилучшую производительность и надежность обеспечивает выделение максимально возможного объема.

  • При установке средства «Восстановление системы» для архивирования точек восстановления по умолчанию выделяется 12 процентов доступного пространства жесткого диска.

назад


Создать точку восстановления

  1. Пуск - Программы - Стандартные - Служебные - Восстановление системы.
  2. Выберите Создание точки восстановления и нажмите кнопку Далее.
  3. В поле Описание точки восстановления введите имя этой точки. Мастер восстановления системы автоматически добавит к имени точки восстановления дату и время ее создания.
    • Для завершения создания данной точки восстановления нажмите кнопку Создать.
    • Для отмены создания точки восстановления и возврата на экран приветствия средства Восстановление системы нажмите кнопку Назад.
    • Для отмены создания точки восстановления и выхода из программы «Мастер восстановления системы» нажмите кнопку Отмена.

Примечания

  • Создание собственной точки восстановления может оказаться полезным при внесении изменений, которые могут привести к нестабильной работе компьютера.
  • Для просмотра или возврата к точке восстановления из окна Восстановление системы мастера восстановления системы выберите Восстановление более раннего состояния системы. Далее укажите дату создания точки восстановления в календаре из окна Выберите точку восстановления. Все точки восстановления соответствующей даты создания отображаются в поле со списком в алфавитном порядке справа от календаря.

См. также


Дисковое пространства

Разное

Вопросы дискового пространства

Для запуска программы восстановления системы нужно не меньше 200 Мбайт дискового пространства (или места в разделе, содержащем папку Windows System). Если отсутствует достаточное свободное место на диске, то при установке операционной системы программа восстановления системы устанавливается, но не запускается. Если на диске нет как минимум 200 Мбайт свободного дискового пространства, то данную программу запустить невозможно.

Когда программе «Восстановление системы» не хватает места на диске, наблюдение за всеми дисками будет приостановлено. Для всех дисков будет отображено состояние Отключено в столбце Состояние в группе «Параметры дисков» в окне Свойства системы. При остановке работы системы восстановления невозможно запустить программу «Мастер восстановления системы». При попытке запуска мастера появится диалоговое окно с сообщением об остановке работы средства «Восстановление системы». Наблюдение автоматически будет возобновлено после выделения на диске минимального необходимого объема в 200 Мбайт.

Чтобы освободить дисковое пространство выполните следующие действия.

  • Запустите программу Очистка диска. Программа «Очистка диска» используется для удаления ненужных файлов.
  • Откройте компонент Установка и удаление программ. С его помощью можно удалить ненужные программы и компоненты операционной системы.

Доступ к средству «Восстановление системы»

Чтобы запустить программу «Мастер восстановления системы» и изменить параметры восстановления системы, необходимо быть членом группы администраторов.

Если при наличии прав администратора невозможно запустить программу «Мастер восстановления системы» или просмотреть Параметры восстановления системы, возможно, администратор домена выключил систему восстановления, используя групповую политику системы. Для получения дополнительных сведений обратитесь к системному администратору.

Существует три способа доступа к возможностям средства «Восстановление системы».

  • Запустить программу «Мастер восстановления системы» с помощью кнопки Пуск.
  • Получить доступ к средству Восстановление системы через панель управления.
  • Получить доступ к средству Восстановление системы через центр справки и поддержки.

Восстановление системы.

Создать точку восстановления

  1. Пуск - Программы - Стандартные - Служебные - Восстановление системы.
  2. Выберите Создание точки восстановления и нажмите кнопку Далее.
  3. В поле Описание точки восстановления введите имя этой точки. Мастер восстановления системы автоматически добавит к имени точки восстановления дату и время ее создания.
    • Для завершения создания данной точки восстановления нажмите кнопку Создать.
    • Для отмены создания точки восстановления и возврата на экран приветствия средства Восстановление системы нажмите кнопку Назад.
    • Для отмены создания точки восстановления и выхода из программы «Мастер восстановления системы» нажмите кнопку Отмена.

Примечания

  • Создание собственной точки восстановления может оказаться полезным при внесении изменений, которые могут привести к нестабильной работе компьютера.
  • Для просмотра или возврата к точке восстановления из окна Восстановление системы мастера восстановления системы выберите Восстановление более раннего состояния системы. Далее укажите дату создания точки восстановления в календаре из окна Выберите точку восстановления. Все точки восстановления соответствующей даты создания отображаются в поле со списком в алфавитном порядке справа от календаря.

Чтобы запустить средство «Восстановление системы» в безопасном режиме

  1. Включите Восстановление системы
  2. Следуйте инструкциям, появляющимся на экране.

Примечания

  • При загрузке в безопасном режиме средство «Восстановление системы» не создает точки восстановления. Таким образом, невозможно отменить восстановление, выполненное, когда компьютер был в безопасном режиме.
  • В безопасном режиме можно выполнить восстановление системы по любой точке восстановления. Если нет возможности запустить компьютер в стандартном режиме, можно использовать систему восстановления для возврата к моменту времени, когда при запуске компьютера возникали ошибки.
  • Чтобы восстановить состояние на время, когда компьютер запускался без ошибок, выберите точку восстановления, максимально близкую к времени запуска компьютера без ошибок.
  • Если средство «Восстановление системы» приостановлена из-за отсутствия свободного места на диске, то, находясь в безопасном режиме, невозможно включить ее, освободив дополнительное дисковое пространство. Необходимо перезапустить компьютер в стандартном режиме и освободить больше дискового пространства.

Отменить последнее восстановление

  1. Откройте средство Восстановление системы.
  2. Выберите Отменить последнее восстановление. Сохраните все файлы и программы и нажмите кнопку Далее.

Примечания

  • Если необходимо отменить последнее восстановление, установите переключатель в положение Восстановление более раннего состояния компьютера в окне Восстановление системы, а затем выберите подобную операцию восстановления контрольной точки, указанную в мастере восстановления системы.

Восстановление системы


Исключение диска или раздела, не являющегося системным

Чтобы исключить диск или раздел, не являющийся системным

  1. Откройте компонент Система.
  2. Убедитесь, что флажок Отключить восстановление системы на этом диске в состоянии отключен.
  3. В поле со списком Параметры диска выберите несистемный диск, который необходимо исключить, и нажмите кнопку Настройки.
  4. Убедитесь, что флажок Отключить восстановление системы на этом диске снят. Невозможно выполнить это действие, если был выбран системный диск или раздел.

Примечания

  • В диалоговом окне Свойства системы выберите команду Восстановление системы.
  • Можно исключить наблюдение и восстановление для несистемного диска или раздела. Изменения, выполненные для исключенного диска или раздела, не будут отменены при восстановлении системы.

назад


Отключение средства «Восстановление системы»

Чтобы отключить средство «Восстановление системы»

  1. Откройте компонент Свойства системы. Win + Pause Break
  2. Убедитесь, что флажок Отключить восстановление системы на этом диске установлен.

Примечания

  • В диалоговом окне Свойства системы выберите команду Восстановление системы.
  • Если не удается отключить восстановление системы, это может означать, что администратор домена включил восстановление системы в групповую политику административной системы. Обратитесь к системному администратору.

См. также

назад


Включение средства «Восстановление системы»

Чтобы включить средство «Восстановление системы»

  1. Откройте компонент Система.
  2. Убедитесь, что флажок Отключить восстановление системы на этом диске в состоянии отключен.

Примечание

  • В диалоговом окне Свойства системы выберите команду Восстановление системы.

См. также

назад


Возобновление наблюдения средства «Восстановление системы»

Чтобы возобновить наблюдение средства «Восстановление системы»

  1. Откройте компонент Система.
  2. Убедитесь, что флажок Отключить восстановление системы на этом диске в состоянии отключен.
  3. В группе Параметры дисков выберите несистемный диск или раздел и нажмите кнопку Параметры.
  4. Убедитесь, что флажок Отключить восстановление системы на этом диске снят.

Примечание

  • В диалоговом окне Свойства системы выберите вкладку Восстановление системы.

назад


Запуск средства «Восстановление системы» в безопасном режиме

Чтобы запустить средство «Восстановление системы» в безопасном режиме

  1. Включить Восстановление системы
  2. Следуйте инструкциям, появляющимся на экране.

Примечания

  • При загрузке в безопасном режиме средство «Восстановление системы» не создает точки восстановления. Таким образом, невозможно отменить восстановление, выполненное, когда компьютер был в безопасном режиме.
  • В безопасном режиме можно выполнить восстановление системы по любой точке восстановления. Если нет возможности запустить компьютер в стандартном режиме, можно использовать систему восстановления для возврата к моменту времени, когда при запуске компьютера возникали ошибки.
  • Чтобы восстановить состояние на время, когда компьютер запускался без ошибок, выберите точку восстановления, максимально близкую к времени запуска компьютера без ошибок.
  • Если средство «Восстановление системы» приостановлена из-за отсутствия свободного места на диске, то, находясь в безопасном режиме, невозможно включить ее, освободив дополнительное дисковое пространство. Необходимо перезапустить компьютер в стандартном режиме и освободить больше дискового пространства.

См. также


Изменение параметров средства «Восстановление системы»

Изменить параметры средства «Восстановление системы»

Возможны следующие изменения параметров средства «Восстановления системы».

    Исключение наблюдения и восстановления для несистемного диска
    Возобновление наблюдения средства «Восстановление системы»
    Выделение большего объема на диске для восстановления системы
    Отключение средства «Восстановление системы»
    Включение средства «Восстановление системы»

Примечания

  • Восстановление системы начинает работу при первом запуске нового компьютера или после завершения установки операционной системы, вне зависимости от наличия 200 Мбайт свободного пространства на жестком диске (или в разделе, где находится каталог Windows System).

    При отсутствии достаточного свободного места на диске при установке Windows можно включить восстановление системы (используя вышеописанные действия) после освобождения достаточного дискового пространства.

  • При отсутствии свободного места на диске программа восстановления системы становится неактивной. При выделении достаточного места на диске программа восстановления системы будет автоматически запущена, но все точки восстановления будут утеряны.

  • Когда программа «Восстановление системы» отключается для диска или раздела, все точки восстановления, сохраненные для этого диска или раздела, будут удалены. Изменения, выполненные для исключенного диска или раздела, не будут отменены при восстановлении системы.

назад