Вступление

Мысль сделать справочный файл по собранным советам витала в воздухе уже давно. Наконец, она нашла воплощение в жизнь. Обусловлено это прежде всего удобством для посетителей сайта: нет необходимости лишний раз обращаться к интернету за поиском нужной информации, тем более не всегда есть доступ к нему в данный момент, а сведения понадобились срочно, да и поиск нужных данных по такому файлу гораздо удобнее.

Частично, на создание такого файла нас подтолкнула замечательная идея Александра Рыжова (http://www.sovety.net), примерную структуру которого мы также слегка заимствовали (да не сочтет он нас плагиатором, просто такая великолепная идея пришла ему в голову первому).

Хотелось бы поблагодарить всех, присылавших свои советы (Список наиболее активных приведен в разделе Авторы). Без вас эта подборка не была бы такой интересной и объемной!


Новые советы

http://www.whatis.ru/

"Народная мудрость" - новые советы

КомпьютерПресс

Windows Vista: UAC (User Account Control) - это функция контроля прав пользователя, ориентированная на неподготовленного пользователя...Подробнее >>

Terminator II

Если вы хотите узнать, когда вы устанавливали свою операционную систему, то воспользуйтесь программой...Подробнее >>

babaj

Чтобы не вводить серийный номер под Windows XP каждый раз при установке ХР "с нуля", то ...Подробнее >>

Terminator II

По умолчанию, учетная запись Гость не имеет пароля, что позволят любому войти в систему. Чтобы установить пароль на эту учетную запись, нужно войти в систему ...Подробнее >>

С.Трошин

Существует способ запретить использование USB-накопителей в Windows XP без установки дополнительных программ...Подробнее >>

Terminator II

Если вы хотите сменить учетную запись, то при использовании апплета Панели управления Учетные записи пользователей имя, отображающееся при входе в систему (логин), не изменится...Подробнее >>


Windows: Общие советы

Windows Vista: UAC (User Account Control) - это функция контроля прав пользователя, ориентированная на неподготовленного пользователя. Опытного пользователя данная функция раздражает. Для отключения функции UAC в диалоговом окне Выполнить наберите команду msconfig. В открывшемся окне System Configuration (Конфигурация системы) перейдите на вкладку Tools (Сервис) и выберите пункт Disable UAC (Отключить учет контрольных записей (UAC)). При нажатии на кнопку Launch (Запуск) появляется консоль с уведомлением об успешном выполнении команды. Изменения вступят в силу после перезагрузки системы.

Если вы хотите узнать, когда вы устанавливали свою операционную систему, то воспользуйтесь программой systeminfo (Выполнить | cmd | systeminfo). В числе прочей информации есть строка Дата установки (Original Install Data)

По умолчанию, учетная запись Гость не имеет пароля, что позволят любому войти в систему. Чтобы установить пароль на эту учетную запись, нужно войти в систему с правами администратора. Запустить программу CMD.EXE и набрать команду:

net user guest YourPASSWORD
где YourPASSWORD - ваш пароль для учетной записи Гость

Если вы хотите сменить учетную запись, то при использовании апплета Панели управления Учетные записи пользователей имя, отображающееся при входе в систему (логин), не изменится. Дело в том, что этот апплет меняет полное имя учетной записи, но не имя, под которым вы входите в систему. Для смены логина запустите оснастку Computer Management и откройте раздел Пользователи (Служебные программы | Локальные пользователи и группы | Пользователи) и выберите нужную учетную запись. Щелкнув по ней правой кнопкой мыши, вы можете выбрать команду Переименовать. Если в запланированных заданиях или в службах что-то выполняется под старым логином, то необходимо и там внести соответствующие изменения

У вас установлено более двух десятков языков MUI? Возможно, система перестала корректно работать с сайтом обновлений Windows. Подобная ситуация может возникнуть, если вы установите более 22 языков MUI (Multilingual User Interface). Попробуйте удалить ненужные языки. Для этого запустите апплет Панели управления Язык и региональные стандарты (intl.cpl), на вкладке Языки нажмите кнопку Подробнее, далее на странице Установленные службы выберите языки, которые хотите удалить, и нажмите Удалить

Если значки заполонили ваш Рабочий стол, то вы можете временно отключить показ этих значков. Щелкните правой кнопкой мыши на Рабочем столе и выберите пункт Упорядочить значки. Снимите галочку напротив пункта Отображать значки рабочего стола

Windows XP сама создает свои подпапки в папке Мои документы (My Pictures, My Video и др.). При удалении этих папок они создаются заново! Если вам не нравится подобное поведение, то надо лишь выполнить команду
regsvr32 /u mydocs.dll
и подпапки создаваться не будут. А если захотите вернуть все обратно, то введите в командной строке следующее:
regsvr32 mydocs.dll

Можно сделать так, чтобы при загрузке Windows XP система запрашивала ключевую дискету с паролем и лишь после ее установки можно было бы вводить имя пользователя. Для этого используется утилита syskey, которая дополнительно шифрует базы данных учетных записей, требует ввода пароля при загрузке системы (еще до logon). По умолчанию такой пароль не требуется, так как он хранится на жестком диске. Если же вы хотите максимально ужесточить политику защиты учетных записей, то в строке "Выполнить" меню кнопки Пуск введите Syskey, в появившемся диалоговом окне нажмите кнопку "Обновить" и в разделе "Генерируемый системой пароль" вы получите возможность выбора места хранения пароля - на локальном диске (используется по умолчанию) или на дискете. Здесь же можно выбрать пункт "Пароль запуска", и тогда при загрузке системы придется вводить ключевое слово вручную - в этом случае пароль должен храниться в памяти пользователя. Учтите только, что такую операцию лучше все же проводить на чистой, только что установленной системе, потому как в этом случае вероятность появления каких-либо сбоев минимальна

Чтобы переназначить диски в Windows XP нужно проделать несколько операций. Для начала о причине, по которой может понадобиться переименовывать диск. Дело в том, что при установке Windows XP присваивает буквы дискам по порядку обнаружения и после они уже не меняются. Может случиться такая ситуация, что загрузочному присваивается C, далее D, последняя буква присваивается приводу CD, (например, Е). При подключении нового винчестера систем присвоит ему букву, следующей за Е. В результате пользователи немного путаются, привыкнув по предыдущим версиям, что CD-ROM всегда последний. Итак, вызываем "Управление компьютером" (Пуск-Выполнить-compmgmt.msc). В появившемся окне выбираем пункт "Управление дисками" и щелкаем правой кнопкой - Выбираем пункт Изменить букву диска (можно также вызвать diskmgmt.msc)

Знаете ли вы, что в Windows XP можно создать загрузочную дискету MS-DOS? В контекстном меню флоппи-диска выберите команду Форматировать, а затем - Создание загрузочного диска MS-DOS

Если вы привыкли удалять файлы путем переноса их мышкой в корзину, то вам, вероятно, неудобно, что корзина, находящаяся на рабочем столе, скрыта под окнами открытых приложений. Но, достаточно взять мышкой удаляемые файлы и задержать на мгновение курсор в свободном месте панели задач, и все окна сворнутся, открывая доступ к корзине и другим элементам Рабочего стола

Для того чтобы просмотреть свойства сразу нескольких дисков (например, чтобы определить, где больше места), откройте Мой компьютер, выделите несколько дисков, свойства которых вы хотите просмотреть, щелкните правой кнопкой мыши и выберите Свойства из контекстного меню. В появившемся окне каждая вкладка будет соответствовать одному диску.

Если вам нужно получить копию дискеты, есть очень простой способ, предоставляемый системой Windows. Вставьте диск в дисковод, откройте Мой компьютер, щелкните правой кнопкой на значке гибкого диска. Из контекстного меню выберите команду Копировать диск, в диалоговом окне нажмите кнопку Начать. После того, как Windows считает данные, система попросит другую. Вставьте другую дискету и нажмите кнопку OK

Иногда возникает проблема, когда вы пытаетесь удалить со своего винчестера какой-нибудь файл большого объема (например, фильм), а он не удаляется, хотя в данный момент файл не запущен, да и никакая программа его не использует. Попробуете в этом случае сделать следующее. Создайте пустой файл с тем же именем и расширением, что и у того, который необходимо удалить. После создания замените большой файл маленьким. А теперь просто удалите и его

Если у вас в сети на всех компьютерах стоят Win XP, и нужно послать сообщение какому-либо пользователю в локальной сети, то просто заходим в Пуск - Выполнить и набираем команду типа
net send <имя или ip адрес компьютера> <сообщение>.
Чтоб было понятнее, вот пример:
net send 192.168.0.1.2 Как дела?

Если в диалоге "Выключить компьютер" (Пуск-Выключение компьютера) нажать клавишу Shift, то кнопка "Ждущий режим" преобразуется в "Спящий режим"

Чтобы при выходе из спящего (hibernate) режима и режима ожидания (standby) Windows XP не требовала ввести пароль, нужно в апплете Электропитание в закладке "Дополнительно" убрать флажок "Запрашивать пароль при выходе из спящего режима"

Для Windows 9x существуют различные программы, позволяющие задавать прозрачный фон для значков на Рабочем столе. В Windows XP подобная надобность в программах отпала: щелкните на Рабочем столе правой кнопкой мыши и в появившемся контекстном меню снимите флажок "Упорядочить значки" - "Закрепить веб-элементы на Рабочем столе". Фон под названиями иконок станет прозрачным.

Для того, чтобы ускорить доступ к часто используемым папкам, можно один раз войти в них и в меню "Избранное" выбрать пункт "Добавить в избранное". После этого можно из любой папки нажав "Избранное" и выбрав название папки попасть в это папку

Можно ли отключить работу с zip-архивами как с папками в Windows Me/XP? Вообще-то работа с zip-архивами, как с обычными папками - это очень удобно, и есть, как мне кажется, только одна причина для отключения этой возможности - слабая и тормозящая машина. Отключается эта опция очень просто - набором в командной строке (или можно создать ярлык)
regsvr32 /u zipfldr.dll
Обратное включение - regsvr32 zipfldr.dll

Как автоматизировать вход в систему - без ввода логина и пароля? Пуск - Выполнить, вводим команду control userpasswords2 После открытия апплета, служащего для управления учетными записями пользователей, снимаем на вкладке Пользователи флажок напротив "Требовать ввод имени пользователя и пароля". После нажатия на кнопку ОК появится диалоговое окно "Автоматический вход в систему", где нужно будет указать имя пользователя и пароль.

Для особо забывчивых: создание дискеты для сброса пароля (Password Reset Disk)
С помощью этой дискеты можно будет зарегистрироваться на компьютере даже в том случае, если пароль забыт. Для создания Password Reset Disk следует выбрать Пуск-Панель управления-Учетные записи, щелкнуть по своей учетной записи. В появившемся окошке в левой колонке (где Родственные задачи) есть пункт Подсказка о пароле - после щелчка по нему запустится мастер создания "спасительной" дискеты. Эта дискета создается один раз - ее не нужно переделывать при каждой смене пароля, поэтому особое внимание следует обратить на порядок ее хранения: дискета должна храниться в укромном месте, потому что тот, кто найдет и воспользуется ей, сможет войти в систему под вашим именем

Если вдруг заголовок окна оказался за пределами вашего примера, вы не можете перетащить окно в другое место. Но вы можете воспользоваться горячими клавишами. Нажмите ALT+SPACE а затем нажмите Е (в русской версии) или M (в английской). Теперь вы может с помощью клавиш со стрелками перемещать окно в любое место

В Windows XP появился новый способ упорядочивания значков (если используется вид Значки): Вид -> Упорядочить значки -> по группам. После этого значки будут упорядочены по группам в алфавитном порядке

В Windows XP можно переименовать сразу несколько файлов. Для этого выделяем несколько файлов, щелкаем по любому из них правой кнопкой и переименовываем. Все выделенные файлы получат имя указанного файла с индивидуальным номером в скобках.

В Windows XP существует особый режим выключения компьютера - Спящий режим. Это режим "засыпания" операционной системы, при этом все содержимое оперативной памяти сохраняется на жестком диске, монитор и жесткие диски отключаются, после чего компьютер выключается. И при перезапуске компьютера состояние рабочего стола полностью восстанавливается, т.е. система полностью восстанавливает свое состояние, имевшееся на момент "засыпания". Проще говоря, на чем вы остановились, выключив компьютер его переводом в спящий режим, с того же самого места и сможете продолжить свою работу: все приложения будут работать точно также, как и до "спячки" - будто ее и не было вовсе.

Бывают ситуации, когда надо запустить на компьютере пользователя программу в скрытом виде (чтобы не было кнопки программы на панели задач и иконки в трее, а также чтобы не было видно окна программы), однако программистами в программе не предусмотрен такой режим запуска. Примеров можно привести массу, например, запуск какого-то монитора работы пользователя или клавиатурного шпиона... В этом случае можно воспользоваться средствами WSH для скрытого запуска таких программ. Вот пример JS-скрипта, запускающего в таком режиме обычный виндовый блокнот:

var WSHShell = WScript.CreateObject("WScript.Shell");
WSHShell.Run("notepad",0);

Второй параметр во второй строке, а именно - 0, указывает, что надо запустить файл в невидимом режиме. Создайте файл с расширением *.js и пропишите его в автозагрузку. Теперь работа вашей программы практически незаметна. Окно у нее невидимо, кнопки на панели задач нет, в диспетчере задач на вкладке "Приложения" она тоже не светится. Только в списке процессов возможно найти notepad.exe и снять его. Но если обозвать запускаемый файл по-заковыристей, например, nvidia32.exe или volsnd32.exe, то далеко не каждый пользователь найдет эту подделку. Да и потом, часто ли вы лазите в диспетчер задач с целью поиска "непонятных" процессов?

Восстановление ярлыка "Свернуть все окна".
Если вы случайно удалили значок "Свернуть все окна" на панели быстрого запуска, есть возможность востановить его. Для этого откройте папку C:\Documents and Settings\ВашаУчетная запись\Application Data\Microsoft\Internet Explorer\Quick Launch и создайте там текстовой файл с таким содержанием:
[Shell]
Command=2
IconFile=explorer.exe,3
[Taskbar]
Command=ToggleDesktop
Сохраните получившийся файл как "Свернуть все окна.SCF". На панели быстрого запуска должен появиться новый значок

Встречал такие программы, которые переводят текст в рисунок для того, чтобы не подбирать кодировки, да они еще и триальные. Все делается очень просто: пишем текст в блокноте, копируем и вставляем в подготовленное для текста место в программе Paint, сохраняем рисунком.

Если у вас Windows 2000, то есть возможность ускорить ее загрузку. Попробуйте отказаться от традиционного "shutdown" и выбрать "hibernate" в меню выключения. Грузится будет в два раза быстрее, правда, при это все содержимое памяти сохранится и после включения музыка как ни в чем не бывало продолжит играть.
Включить эту опцию можно в настройках "Power management" панели управления.

Как защититься от администратора в Windows 2000?
Одно из преимуществ NTFS, состоит в том, что можно создать разграничение доступа к файлам и каталогам. Пользователь не сможет посмотреть папку Мои документы другого пользователя, если этот пользователь не является администратором. Как же защититься в таком случае? Запретить доступ к своим данным нельзя, а вот узнать, копался ли администратор по личным папкам и документам можно.
Допустим, вы решили закрыть папку для всех и разрешить доступ только себе. Щелкните правой кнопкой мыши по файлу/папке, выберите из меню команду Свойства, на вкладке Безопасность удалите всех, кроме себя.
Теперь система не позволит администратору посмотреть этот файл/папку. Так как он администратор, ему не составит особого труда проделать то же самое что и вы и добавить для себя разрешение на полный доступ к этому файлу/папке, а затем удалить себя, дабы никто не узнал. Но текущим владельцем этого файла/папки на века теперь станет администратор, в чем вы сможете убедиться, нажав на вкладке Безопасность кнопку Дополнительно, в новом диалоговом окне перейти на вкладку Владелец и посмотреть на поле "Текущий владелец для этого элемента". До этого им были вы.

Если в Windows создать пустой файл с расширением *.fnd , то при запуске этого файла откроется окно "Найти: Все файлы"

В Виндах можно "ужать-раздвинуть" все ячейки таблички по их содержимому нажатием "CTRL"+"+". Например, зайти в Винде в любой лог (не обязательно лог - любая таблица), если там все записи в своих ячейках умещаются, то изменить их размер так, чтобы не умещались (ну это для примера, конечно :), а потом нажать "Ctrl"+"Grey+".

Если требуется открыть сразу несколько файлов в одной папке, следует выделить одновременно их значки (например, щёлкнув по первому и последнему при нажатой клавише SHIFT), а затем нажать ENTER.

Если дважды щелкнуть по активной панели окна (синяя полоска вверху окна) то программа переключится из оконного в полноэкранный режим и наоборот.

Создаём текстовый файл (в "Мои документы"), как-нибуть "обзываем" (у меня, например - @@@). Далее создаём ярлык этого файла в Windows\Application Data\Microsoft\Internet Explorer\Quick Launch. И теперь всегда под рукой блокнотик. Нужный адрес - скопировал, текст - без проблем. Вобщем - весьма удобно.

Бывают ситуации, когда надо представить какой-то каталог в качестве отдельного логического диска (например, при большой вложенности до него очень долго добираться, а пользоваться им приходится часто, или программы настроены на работу с определенного диска и т.п.). В этой ситуации на помощь придет команда:
subst d: c:\kakoyto\dalekiy\katalog
Эта команда создаст виртуальный диск D:, который ничем не будет отличаться от логического. В качестве такого диска будет использоваться каталог, указанный вторым параметром команды. Отменить выделение виртуального диска можно командой
subst d: /D
Если вы хотите, чтобы виртуальный диск у вас был постоянно, просто добавьте эту команду в autoexec.bat.
Примечание: В Windows 2000/ХР файл AUTOEXEC.BAT не обрабатывается, лучше написать файл BAT и прописать его в реестре в автозагрузку:
1. Создаем файл, например wertdisk.bat, в теле пишем subst d: c:\kakoyto\dalekiy\katalog
2. Создаем строковый параметр, например Baton, в ключе [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run] и указываем в этом строковом параметре путь до файла wertdisk.bat, например c:\katalog\wertdisk.bat. Или создать к этому файлу BAT ярлык и поместить его в папку Автозагрузка

Иногда, некоторые старые программы не хотят устанавливаться, указывая нехватку места на винте, несмотря на то что места более чем достаточно (например Paradox 7), дело в том что инсталлятор просто не может прочитать число байт более 2 миллиардов. Для установки таких программ, потратьте свободное место на винте (копируя какие-нибудь файлы), чтоб осталось меньше 2G, установите программу, затем удалите ненужные файлы, восстановив свободное место на диске.

ОЧЕНЬ не советую уменьшать размер раздела (partition), несущего сжатые диски Drivespace. Потеря данных - гарантирована! (1%-5% кластеров по всему диску). Увеличивать - можно.
P.S. Если ошибка уже сделана - часть данных (9% или 99%) можно спасти Diskeditor-ом (запись обьекта (битого файла) в файл на другом диске).

Чтобы в Photoshop'е вывести диалог открытия файла вовсе не обязательно лезть в меню "Файл" или нажимать "горячие клавиши". Достаточно дважды щелкнуть по свободной (серой) области в окне программы.

Винт любого размера лучше разделить на несколько маленьких. Так на основной раздел можно оставить гига три-четыре, на дополнительные остальное. Зачем? Оптимизация диска идёт быстрее, скандиск летит быстрее после сбоя, переносить систему значительно легче, дерево каталогов получается меньше - соответственно на поиск файлов винда тратит меньше времени.
Рекомендую на c: только ставить программы, на d: держать те проги, которые идут без установки и игры, на остальных - по желанию...

Переразбивку жесткого диска без потери данных достаточно легко сделать с помощью Partition Magic. Я им давно уже пользуюсь и ни разу еще, слава Богу, проблем не было. Единственная настоятельная рекомендация - за один раз только одно изменение, затем перезагрузка.

Расширения ненужных файлов
*.tmp; *.~mp; *.gid; *.fts; *.chk; *.00*; *.---; *.$$$; *.*$; ~*.*; *.~*; *.??_; *.??~; *.^*; *.syd; *.prv; *.old; *.bak; mscreate.dir
Выбрав эти файлы в окне поиска, например Windows Commander, вы можете удалить их, тем самым освободив диск на несколько мегабайт. Но есть одна неприятность:
У многих пользователей жесткий диск не разбит на разделы, и дистрибутивы хранятся вместе с системными файлами, т.е. на одном диске с C:\WINDOWS\. В таком случае Вы можете потерять важные файлы. Поэтому, всегда разбивайте жесткий диск минимум на два раздела, и храните дистрибутивы на втором, не на загрузочном диске, в отдельной папке.

Если есть желание, чтобы все временные (tmp) файлы удалялись после запуска компьютера (а они не нужны), следует в файл autoexec.bat ввести следующие строки:
set tmp=c:\tmp
set temp=c:\tmp
set pktmp=c:\tmp
del c:\tmp\*.tmp > nul

Еще один способ удалять все временные (tmp) файлы после запуска компьютера (а они не нужны). Следует в файл autoexec.bat добавить следующие строки:
@ECHO Cleaning of a temporary folder...
DELTREE /Y C:\TEMP > NUL
MD C:\TEMP
SET TMP=C:\TEMP
SET TEMP=C:\TEMP
SET PKTMP=C:\TEMP
@ECHO Temporary folder is clean


Установка Windows

Чтобы не вводить серийный номер под Windows XP каждый раз при установке ХР "с нуля", то создайте в дистрибутиве в папке i386 текстовый файл winnt.sif такого содержания:

[UserData]
ProductKey=VP3WH-BJVP8-HRY4Y-T7YFJ-G3XQY
В ProductKey впишите свой серийный номер

Существуют ключи для фоновой установки сервис-паков и патчей от Microsoft. Использование этих ключей может съэкономить время, отключая все эти "Далее, Принимаю условия, OK".

-F
принудительное закрытие всех приложений при перезагрузке
-N
не создавать папку для хранения файлов, необходимых для деинсталяции SP
-O
перезаписывать OEM-файлы без потверждения
-Q
устанавливать без участия пользователя
-U
запустить в необслуживающем режиме
-Z
не перезагружать компьютер после завершения установки

Пример

C:\Temp\winXP-KB3444.exe -F -Q -U

В отличие от W2k, где всё необходимое шло вместе с дистрибутивом, для создания загрузочных дисков XP вам придётся скачать пакет из http://support.microsoft.com/support/kb/articles/q310/9/94.asp?ID=310994
Для создания комплекта загрузочных дискет вам понадобится 6 флоппи-дисков. При загрузке с них вы окажитесь в той же программе установки, что и при загрузке с компакт-диска с XP, так что если у вас есть возможность грузиться с такого диска, эти дискеты вам не нужны.

Где хранится код активации Windows XP? Как известно, лицензионная Windows XP при переустановке системы требует повторной активации. Чтобы этого избежать, достаточно перед переустановкой системы скопировать файл wpa.dbl, например, на дискету - именно в этом файле хранится код активации. После переустановки системы, естественно, нужно будет заменить файл wpa.dbl на тот, что записали на дискету.

При установке Win2k если идти по загрузке из-под "чистого" DOS, то предварительное копирование файлов может занять до 1,5 часов. Все дело здесь в том, что не установлено предварительное кэширование дисков. Кэширование выполняется командой smartdrv (находится в каталоге Windows на любой машине, на которой установлены Windows 98). После этого предварительное копирование файлов занимает около 20 - 30 минут.

Если при установке новой версии Windows поверх старой вам заявляют, что не хватает места на диске С:, попробуйте задать в командной строке программы инсталляции ключ /id, который отключает проверку доступного на диске места: setup.exe /id.

Некоторые программы в Windows 2000 отказываются устанавливаться без видимой на то причины (возможно эта проблема есть и в ХР). Это может происходить из-за того, что пользователь, под которым производится установка, содержит в своем имени русские буквы. Просто создайте нового пользователя с правами администратора, в имени которого будут только латинские буквы, и попробуйте запустить установку под ним.
Дополнение к совету: Тут дело не совсем в имени - дело в том, что по умолчанию каталоги временных файлов - TEMP и TMP, а именно в ТЕМР установщик как раз временные файлы и копирует - располагаются в папке Documents and Settings/<Имя пользователя>/TEMP, и вот как раз русскую часть имени этой папки установщики и не понимают. Еще возможен вариант еще более старого :))) установщика, не понимающего и длинные имена файлов - тогда и переименование не поможет. Проблема может быть решена проще: щелкнуть правой клавишей на "Мой компьютер" - Свойства - Дополнительно - Переменные среды. Там в верхнем окне - переменные среды для <Имя пользователя> как раз эти пути и задаются. Проще всего создать специальную папочку типа TEMP недалеко от корня диска, чтобы если что далеко не лазить, и прописать в качестве этих переменных среды ее. После этого все становится нормально (возможно потребуется перезагрузка, чтобы изменения вступили в силу - точно сказать не могу)

Возникающие проблемы часто пытаются решить переустановкой Windows. При переустановке Windows без предварительного удаления её каталогов проблемы, однако, могут сохраняться, так как неприятности могут быть связаны с тем, что что-то неверно записалось в реестре, а при переустановке "поверх" в реестре почти всё остаётся по-старому. Поэтому обычно эффективна только переустановка с предварительным удалением каталогов Windows и Program Files. Но после этого приходится инсталлировать и настраивать почти все программы по новой. Чтобы не тратить на это время и обеспечить возможность анализа причин неприятностей, в Windows периодически сохраняйте в каталоге С:\WINDOWS\SYSBCKUP\ (этот каталог скрытый) копии файлов реестра system.dat и user.dat (а также заодно system.ini и win.ini). В Windows 98 это автоматически ежедневно при первом запуске системы делает утилита SCANREG, которая также занимается чисткой реестра. Эта утилита сжимает вышеуказанные четыре файла и сохраняет их в каталоге (С:\WINDOWS\SYSBCKUP\) в cab-архиве под именем rbxxx.cab, где xxx - номер резервной копии. По умолчанию сохраняются 5 последовательных копий, а затем каждая новая замещает самую старую. Можно заставить SCANREG сохранять до 99 резервных копий, присвоив нужное число параметру MaxBackupCopies в файле scanreg.ini. Также можно дополнительно сохранять в этих cab-архивах копии других файлов (например autoexec.bat и config.sys), указав в параметре Files их полные имена с путём.
Для восстановления реестра нужно перезапустится в DOS и в командной строке набрать scanreg /restore далее выберите архив и дату сохраненного реестра и нажмите восстановить.


Меню кнопки "Пуск"

Если вы хотите избавиться от больших значков в меню Пуск, заменив их на маленькие, то щелкните правой кнопкой на кнопке Пуск (или на Панели задач) и выберите пункт Свойства. В появившемся окне выбираем вкладку Меню "Пуск" и щелкаем на кнопке Настроить. Теперь можете выбрать размер значков для программ

Если перетащить ярлык на кнопку "Пуск", то он добавится в меню над пунктом "Программы". Однако, сильно увлекаться не стоит, т.к. большое количество ярлыков приведет к существенному замедлению появления этого меню на экран (так, я наблюдал на ноутбуке Р2-350 почти секундную задержку при наличии около 10 дополнительных ярлыков в меню).

Если нажать кнопку "Пуск", выбрать пункт "Выполнить" (Run) и напечатать в строке точку, то откроется папка C:\Documents and Settings\имя пользователя. А если напечатать две точки, то откроется папка C:\Documents and Settings


Проводник

Если в Проводнике вы используете стиль показа эскизов страниц (Вид-Эскизы страниц), то можно разместить еще больше эскизов, скрыв указываемые под ними имена файлов. Для этого перед тем как щелкнуть на папке с картинками в левой части Проводника, нажмите клавишу Shift. И папка откроется уже без подписей к картинкам.

Чтобы изменить заданный по умолчанию порядок столбцов Имя, Тип, Размер, Изменен при выборе Вид-Таблица, просто перетащите мышкой заголовок колонки влево или вправо

Продолжение предыдущего совета. Можно изменить колонки, которые представлены по умолчанию, добавив или удалив некоторые пункты. Щелкните правой кнопкой на заголовке колонки и выберите из списка нужные пункты

По умолчанию Проводник открывается на диске C:, но вы можете изменить это поведение, заставляя его, к примеру, открывать при запуске папку D:\MyDownload. Для этого, найдите ярлык к Проводнику, щелкните правой кнопкой и выберите свойства. Выберите вкладку Ярлык. Отредактируйте строчку Объект - C:\WINDOWS\EXPLORER.EXE /n,/e,D:\MyDownload.

Если создать ярлык и указать в качестве командной строки "C:\WINDOWS\EXPLORER.EXE /ROOT," (без кавычек, но с запятой в конце), то этот ярлык будет открывать рабочий стол (desktop). Причем, в проводнике будут показаны и системные иконки (сетевое окружение, outlook и т.д.).

Если в проводнике посмотреть на аудио CD, то Вы увидите, что дорожки представлены как файлы. Вы можете создать ярлык к такому файлу, например, перетащив его на рабочий стол, что даст Вам возможность играть любимую песню просто щелкнув по этому ярлыку.

Смотри также

Справочник по программам Windows


Панель задач

Если у вас открыто несколько программ, вы вероятно закрываете их один за другим. Но есть более удобный способ. Нажмите и удерживайте клавишу [Ctrl] и кликайте на на тех кнопках на панели задач, чьи программы вы хотите закрыть (вы заметите, что выбранные кнопки будут вдавлены). Теперь можете кликнуть правой кнопкой на одной из этих выбранных кнопок и выбрать команду Закрыть (или любую другую). Попробуйте, вам понравится.

Проще и эффективнее можно организовать каскадное меню в панели задач, щёлкнув по ней правой кнопкой мыши и поставив галочку в контекстном меню: Панели инструментов - Рабочий стол. После чего необходимо мышью сузить полученную панель до того, что на ней не останется ничего, кроме слова "Рабочий стол" и маленькой двойной стрелочки в правом углу. Именно после щелчка по этой стрелочке открывается удобнейшее каскадное меню с содержимым ВСЕГО, что находится на Рабочем столе (Все папки, Мой компьютер, Сетевое окружение, Корзина и пр.).
Попробуйте один раз - оставите навсегда.

Если Вы хотите перетащить какой-нибудь объект (например файл) в окно программы, которая минимизирована или закрыта другим окном, то просто перетащите этот объект на кнопку программы на таскбаре и задержите на секунду...

Очень удобно разместить панель задач (TaskBar) не внизу экрана, как это сделано по умолчанию, а вдоль его левой стороны. Это дает несколько плюсов: кнопки программ на панели будут постоянного размера, даже если у вас открыто одновременно десяток задач; иконки в трее и панели быстрого запуска располагаются в несколько рядов, освобождая место под кнопки программ; приходится меньше бегать мышкой при перемещении в меню кнопки "Пуск". В свойствах панели задач лучше указать "Автоматически убирать с экрана", чтобы не занимать лишнее место на Рабочем столе. Размещать панель справа неудобно, т.к. там находятся кнопки управления размерами окон программ и полосы вертикальной прокрутки, так что при неосторожном движении панель может выскочить из-за края экрана и перекрыть те элементы окна до которых вы хотели добраться.

Вам когда-нибудь приходилось открывать одни и те же папки много раз в день? А если одна из папок находится, например, в C:\Program Files\Borland\Delphi5\Projects\Ball, то каждый раз вам приходилось открывать сначала 'Мой компьютер', потом папку Program Files, потом Borland и т.д. Правда, неудобно? Так вот суть совета состоит в создании специальной панели на панели задач Windows'98, где и находятся ярлыки к наиболее часто используемым папкам.
Что делать?
Создаёте папку где хотите, но я советую в папке Windows, и называете её так чтобы было потом понятней, например 'сюда', или 'ссылки', или 'links'.
Теперь у вас есть папка, где будут хранится ярлыки к наиболее часто используемым папкам.
Затем создаете ярлык к новосозданной папке, украшаете его (переименовываете, меняете иконку) и помещаете в папку C:\Windows\SendTo.
Кликаете правой кнопкой мыши на пустом месте панели задач и выбираете пункт 'Панели инструментов' и в подменю пункт 'Создать панель инструментов...'
В открывшемся окошке выбираете ту папку, которую вы создали.
Всё! Панель готова!


Системные иконки

Давайте добавим папку "Принтеры" в меню Пуск, причем все значки в ней превратятся в пункты подменю. Это поможет облегчить и ускорить доступ к этим элементам. Для этого надо зайти в настройку Панели задач и меню "Пуск", перейти на вкладку "Настройка меню" и выбрать кнопку "Дополнительно". В правой части открывшегося окна надо создать папку Принтеры.{2227A280-3AEA-1069-A2DE-08002B30309D} где значение до точки - имя папки, а после точки - ее расширение (фигурные скобки нужны обязательно!).
Вот еще имена для стандартных элементов:
для папки Удаленный доступ к сети - Имя.{992CFFA0-F557-101A-88EC-00DD010CCC48}
для Корзины - Имя.{645FF040-5081-101B-9F08-00AA002F954E}
для папки Подписка - Имя.{F5175861-2688-11d0-9C5E-00AA00A45957}
для папки Шрифты - Имя.{BD84B380-8CA2-1069-AB1D-08000948F534}
для папки History - Имя.{FF393560-C2A7-11CF-BFF4-444553540000}
для папки Назначенные задания: Name.{D6277990-4C6A-11CF-8D87-00AA0060F5BF}
для папки Web Folders: Name.{BDEADF00-C265-11d0-BCED-00A0C90AB50F}
Причем имя может быть любым. Такие папки можно добавить в любой каталог на жестком диске.

Стандартные значки Windows 9x. В разделе реестра [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Current Version\explorer\Shell Icons] содержится множество строковых параметров с именем в виде числа. Каждый из них отвечает за значок какого-либо объекта:
0 Стандартный значок
1 Исполняемый файл
2 Избранное
3 Папка
4 Открытая папка
5 Дискета 5.25"
6 Дискета 3.5"
8 Жесткий диск
9 Сетевой диск
10 Недоступный сетевой диск
11 CD-ROM
12 Ram Drive
13 Вся сеть
15 Мой компьютер
16 Принтер
17 Сетевое окружение
18 Файл с конфигурациями
19 Программы
20 Документы
21 Настройка
22 Поиск
23 Справка
24 Выполнить
27 Завершение работы
28 Зашарить (ну не знаю я, как это по-русски сказать)
29 Ярлык
31 Пустая корзина
32 Полная корзина
33 Удаленный доступ к сети
34 Рабочий стол
35 Панель управления
36 Программы
37 Принтеры
38 Шрифты
40 Музыкальный CD
Установите значением параметра путь к значку (если значок хранится в библиотеке, то после пути к ней, через запятую, нужно указать номер значка, начиная с нуля), и он изменится.


Ярлыки

У вас, вероятно, есть две-три программы, которые вы запускаете ежедневно, а то и по много раз в день. И, скорее всего, вы вынесли ярлыки этих программ в наиболее удобное место на "Рабочем столе", чтобы запускать их как можно быстрее. Можно еще больше ускорить запуск этих программ, если задать "горячие" клавиши для их вызова. Для этого щелкните правой кнопкой мыши по ярлыку нужной программы, выбирите пункт "Свойства" и на вкладке "Ярлык" установите курсор мыши в поле "Быстрый вызов". Затем нажмите комбинацию клавишь для вызова этой программы (Ctrl+Alt+буква, Ctrl+Shift+буква, Alt+Shift+буква или Ctrl+Alt+Shift+буква). Привыкнуть к такому способу открытия программ очень просто, даже удивляешься, как раньше обходился без этого.

Для многих команд Windows можно сделать ярлыки. Сделать это очень просто: в контекстном меню выберите Создать -> Ярлык и укажите необходимую командную строку, например:
rundll32 shell32,SHExitWindowsEx -1 Перегрузить Explorer.
rundll32 shell32,Control_RunDLL Открыть "Панель управления".
Полный список команд можете посмотреть здесь

Если вам надо постоянно обращаться к какому-то элементу Панели управления, то можно создать ярлык на "Рабочем столе" с такой командной строкой: "CONTROL.EXE desk.cpl,,3". Desk.cpl указывает вызываемую функцию "Панели управления". Например, appwiz.cpl откроет окно "Установка и удаление программ", а цифра следующая после двух запятых - номер нужной вкладки, начиная с нуля.


Настройка оболочки

В папке Windows\Web можно найти несколько интересных файлов. В этой папке надодится скрытый файл webview.css, в котором определены настройки стилей отображения тех папок, для которых выбран вид "Как web-страница". Изменяя прописанные в нем классы, вы можете менять свойства шрифта, фона заголовок, списка файлов. Например, прописав в body вместо color: windowtext другой цвет, скажем, green, вы увидите зеленый текст в левой части странички

Убрать значки с "Рабочего стола" и создать ОЧЕНЬ быструю панель можно нажав на "трэе" (там, где часы) правую кнопку мыши. В меню выбрать "Панели инструментов" - поставить галочку "Рабочий стол" (если там такового нет - нажать "создать" и там выбрать "Рабочий стол"). При этом слева от трэя появится оная перемещаемая панелька со стрелкой, разворачивающей всё содержимое "Стола". После этого зайти в свойства экрана, вкладка "Эффекты" и там установить галку "Прятать содержимое стола, если...".
Всё! Вся фишка в том, что:
1. не захламляются ваши обои и
2. (самое главное!) через эту менюшку можно практически мгновенно добраться до ЛЮБОЙ точки вашего компа НЕ ЗАПУСКАЯ ПРИ ЭТОМ ВСЯКИХ "ПРОВОДНИКОВ", "КОММАНДЕРОВ" и т.д., (заодно и ресурсы экономятся!) Попробуйте, не пожалеете!
З.Ы. Для 98 Выньды. Для остальных - не знаю, есть ли там такое... ;)

Для того, чтобы вставить любое слово рядом с часами нужно сделать следующее:
1. Зайти на "Панель управления", затем "Язык и стандарты"
2. Перейти на вкладку "Время"
3. В поле "Формат времени" измените формат на "ЧЧ:мм:сс оо" (оо набирать русскими), в полях обозначения времени до и после полудня введите ваше слово.


Контекстное меню файлов и папок

Когда вы запускаете файл, ассоциированный с каким-то приложением в Windows, то файл открывается именно в этом приложении. А как быть, если вам надо открыть этот файл в другом приложении? С WinNT/2000/XP все понятно: там в контекстном меню файлов всегда присутствует пункт "Открыть с помощью...". В Win9х этого пункта изначально нет, но если выделить нужный файл и, удерживая Shift, щелкнуть правой кнопкой мыши по нему, то в контекстном меню появится дополнительный пункт "Открыть с помощью...". Таким образом удобно как переассоциировать открытие файлов на другое приложение (без копания в реестре и разных диалогах), так и использовать это для какого-то конкретного случая.

Как связать несколько приложений с одним расширением файла.
Например, документ в формате Microsoft Word for Windows (расширение .doc) можно открывать как с помощью MS Word, так и с WordPad. Для этого:
1. Откройте окно "Мой компьютер".
2. В меню "Вид" выберите пункт "Свойства папки".
3. Выберите закладку "Типы файлов".
4. В списке "Зарегистрированные типы файлов" выберите "Документ Microsoft Word".
5. Нажмите на кнопку "Изменить".
6. Нажмите на кнопку "Добавить".
7. В строке "Действие" введите:
Открыть в WordPad
8. В строке "Приложение, исполняющее действие" введите:
"{path}\wordpad.exe" "%1"
где {path} - полный путь к файлу Wordpad.exe. В этой строке кавычки обязательны.
9. Нажмите кнопку "OK".
Если после этого вы дважды щёлкните левой кнопкой мыши на файле с расширением .doc, то документ откроется программой Microsoft Word. Если вы щёлкните правой кнопкой мыши на файле такого типа, то из появившегося меню сможете выбрать пункт "Открыть в WordPad".

Запуск программы из меню корзины
Для добавления программы в меню корзины(щелкните правой кнопкой мыши по иконке корзины) нужно сделать следующие:
- Откройте ветвь реестра "HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\Shell"
- Создайте в ней раздел с вашем именем
- В новом разделе создайте еще один с названием "Command"
- В параметре по умолчанию задайте путь к файлу который вы хотите открыть.


Иконки

Системные иконки находятся в файлах типа *.ICO (одна иконка, возможно в нескольких режимах), *.EXE (приложение), *.DLL (динамическая библиотека). Для указания иконки в приложении или в библиотеке нужно в пути после имени файла через запятую указать номер значка в файле. Пример: explorer.exe,0.
Где находятся иконки???
Иконки можно найти во многих системных файлах:
\Windows\System\Pifmgr.dll - мастер создания ярлыков
\Windows\System\Shell32.dll - оформление системы
\Windows\System\User.exe - иконки системных сообщений
\Windows\System\Cool.dll - иконки пакета MS Plus!
\Windows\Progman.exe - диспетчер программ
\Windows\Moricons.dll
\Windows\*.CPL - компоненты Панели Управления.

Переименовав .bmp файл в .ico, Вы получите "полнофункциональную" иконку. Только размер файла не изменится... Обратное "преобразование" тоже работает. Также можно переименовывать эти файлы в .cur и изменять вид курсора.


Ускорение ОС

При открытии папки "Мой компьютер", если в приводе CDROM имеется диск, он начинает раскручиваться и открытие папки существенно замедляется. Чтобы заставить систему раскручивать диск только когда к нему обращаешься непосредственно, надо создать DWORD параметр Autorun со значением 0 в разделе HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CDRom

Ускорить запуск Windows XP, и освободить память можно путем отключения системных Служб. Отключить их можно разными путями: в командную строку ввести команду services.msc или в меню "Администрирование" в разделе "Службы" выбрать свойство нужной службы. Второй путь более рационален, т.к. вы не забудете, что отключали и в любое время можете восстановить - "Настройка системы" (msconfig.exe). При отключении служб нужно быть аккуратным, т.к. отключение чего-то лишнего может привести к нестабильной работе системы, поэтому, перед отключении нужно экспортировать ветвь служб реестра (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Serviсes), и сохранить на диске, чтобы в любой момент, можно было восстановить. Еще один совет, перед отключением какой-либо службы, посмотрите "Зависимости" в свойстве этой службы, какие компоненты зависят от отключаемой вами службы.

Windows XP создает и поддерживает индекс всех файлов на дисках для того, чтобы ускорять их поиск. Обратная сторона медали - замедляется выполнение остальных команд типа открыть, закрыть и т.п. Мне лично компромисс показался неудачным:
- Открываем My Computer.
- Из контекстного меню иконки жесткого диска выбираем Properties.
- Снимаем галочку на опции Allow indexing service to index this disk for faster searches.
- В появившемся окне выбираем опцию Apply to all folders and subfolders.
- Повторяем процедуру для всех оставшихся жестких дисков компьютера.

Ускорение работы Windows 9x
- Не пользуйтесь Wallpapers: чем больше размер картинки и количество цветов в ней - тем сильней ее использование в качестве wallpaper замедлит работу компьютера.
- Не используйте больше цветов, чем вам надо. Если вы не занимаетесь профессионально графикой - то 256 цветов вполне достаточно. (Хотя конечно все зависит от того, какой Video card у вас установлен и сколько Mb видеопамяти у вас есть).
- Не используйте анимационные курсоры. Они, конечно, влияют не так, как wallpaper, но все же отказ от них может немного ускорить ваш компьютер.
- Установите размер кэша для CD-ROMа в соответствии с вашими потребностями. Если вы не пользуетесь CD-ROMом для просмотра видеофильмов и редко запускаете тяжелые мультимедийные игры - то 256 Кб. кэша хватит выше крыши. Чтобы изменить настройки кэша для CDROMа - откройте My computer/Control Panel/System, выберите закладку Perfomance и нажмите на кнопку File system. Там выберите закладку CD-ROM и установите желаемый размер кэша.
- Старайтесь не использовать звуковые эффекты, которые поставляются вместе с Windows.
- Внимательно изучите autoexec.bat, config.sys, win.ini и system.ini. Из autoexec.bat можете удалить драйвера мышки, CD-ROMa, Soundblastera, smartdrive (windows все равно использует свои драйвера и свое дисковое кэширование). Из config.sys можно удалить строчки с загрузкой himem.sys - windows загружает его автоматически. В win.ini проверьте строчки run= и load= в самом начале файла и удалите то, что вам не нужно.
- Проверьте папку Start-up в вашем меню Programs. Некоторые программы (например, Microsoft office) очень любят записывать туда разнообразные программы, которые в принципе никому не нужны, а ресурсы забирают. Удалите все, что вам не нужно.


Программы в автозагрузке

Существуют сайты, на который выложены целые списки программ, стартующих вместе с системой. Часть этих программ вполне можно отключить для экономии ресурсов. Для начала небольшой совет - найдите на своем диске файл, который прописан у вас в автозагрузке и загляните в его свойства - исходя из его названия, расположения на диске или имени разработчика можно определить хотя бы примерно, к какой из установленных программ он относится, и сделать выводы
- выполняет он какие-то полезные функции или от его запуска вполне можно отказаться. Так, например, понятно, что утилита Corel Registration Reminder (remind32.exe) предназначена для еженедельного донимания пользователя с просьбой зарегистрироваться и ее отключение не только полезно для нервной системы, но и не повлияет на функциональность других приложений. А вот отключив утилиту CPUcool (cpucool.exe), вы перестанете использовать программное охлаждение процессора до тех пор, пока не запустите ее вручную. Так что в каждом случае принимать решение пользователю приходится самолично. Мы приведем только малую часть программ из числа наиболее известных

  • Access Ramp Monitor (armon32.exe) - отслеживает параметры интернет-соединения, запрещает запуск некоторых игр.
  • Album Fast Start (abmtsr.exe) - утилита для сканера, для его нормальной работы не требуется, доступна из меню "Пуск".
  • Alogserv (alogserv.exe) - утилита для ведения протокола работы McAfee VirusScan.
  • Bpcpost.exe - Microsoft TV Viewer Post Setup Program - часть Microsoft WebTV for Windows.
  • BrowserWebCheck (loadwc.exe) - проверяет, является ли Internet Explorer браузером, используемым по умолчанию. Не требуется.
  • ConMgr.exe (conmgr.exe) - запускает WinFax Pro, нужна для ответа на входящие звонки.
  • CtfMon (ctfmon.exe) - прописывается в автозагрузку при каждом запуске Office XP, нужна для альтернативных способов ввода текста, поэтому если диктовка не используется, то лучше отключить через апплет Text Services and Speech в Панели управления.
  • CyDoor (CT_Load.exe) - засасывающая рекламу spyware-утилита. Желательно удалить вместе с программой-маткой. Поможет в этом утилита AD-aware (www.lavasoft.de/aaw).
  • EM_EXEC (em_exec.exe) - драйвер мыши Logitech. Нужен для поддержки дополнительных функций мыши или трекбола.
  • Fpx (mnmsrvc.exe) - служба Remote Desktop Sharing, часть Microsoft NetMeeting.
  • Gator (gator.exe) - еще одна шпионско-рекламная программа.
  • HIDServ (hidserv.exe) - Human Interface Device Server, нужен, только если используется какое-то USB-аудиоустройство, например мультимедийная USB-клавиатура с регулятором громкости.
  • Internat (internat.exe) - индикатор раскладки клавиатуры в системной области панели задач. Для самого переключения не требуется.
  • LoadPowerProfile (powrprof.dll) - отвечает за управление питанием и загрузку соответствующих профилей. Обычно грузится два раза, и один из экземпляров можно отключить.
  • Machine Debug Manager (mdm.exe) - дебаггер, нужен разработчикам и тестерам ПО. Крайне рекомендуется отключить.
  • MDAC_runonce (runonce.exe) - ассоциировано с Microsoft Data Access Components (MDAC). Автозагрузка не требуется, но наличие на диске самой системной утилиты runonce.exe необходимо. Microsoft Office Shortcut Bar (msoffice.exe) - панель быстрого запуска, входящая в состав Office.
  • MOSearch (mosearch.exe) - утилита Fast Search в Office XP, аналогична FindFast из Office 2000. Потребляет много ресурсов, лучше отключить, если не работаете с тысячами документов.
  • MSBB (msbb.exe) - очередная шпионская программа, загружает рекламу на ПК и шпионит за пользователем. Отключайте.
  • MSConfigReminder (msconfig.exe) - при загрузке ОС сообщает, что вы что-то отключили в программе "Настройка системы".
  • Netzip Smart Downloader (npnzdad.exe) - spyware-утилита, закачивает рекламу на ПК без ведома пользователя и отслеживает его действия.
  • New.net (rundll32.exe NewDotNetStartup) - опять шпион.
  • PCHealth (pchschd.exe) - в Windows Me планировщик системы PC Health, при отмене его загрузки PC Health не отключается.
  • PWSTray (pwstray.exe) - Microsoft Personal Web Server, можно запустить и вручную.
  • QuickSort (qsort.exe) - утилита для сортировки пунктов меню "Пуск" по алфавиту - не требуется.
  • RealDownload Express (npnzdad.exe) - снова любитель качать рекламу на компьютер.
  • Resource Meter (rsrcmtr.exe) - индикатор ресурсов Windows, можно запускать вручную.
  • SaveNow (savenow.exe) - опять рекламный шпион.
  • ScanRegistry (scanregw.exe) - системный сканер реестра, делает также его резервные копии. Очень ценная вещь, в памяти не остается.
  • SchedulingAgent (mstask.exe) - "Планировщик заданий". Если не используется - отключить.
  • StateMgr (statemgr.exe) - отвечает в Windows Me за службы System Restore и System File Protection - если они не требуются, то можно отключить.
  • Synchronization Manager (mobsync.exe) - Internet Explorer Synchronization Manager - для повседневной работы не нужен.
  • SystemTray (systray.exe) - System Tray Services, выводит в системной области панели задач значки Volume Control, PC Card Status и Power Management.
  • TaskMonitor (taskmon.exe) - отслеживает ход запуска программ и поставляет эти данные дефрагментатору для оптимизации расположения файлов на диске. Полезная вещь.
  • TimeSink Add Client (tsadbot.exe) - один из самых распространенных шпионов.
  • W3KNetwork (rundll32.exe w3knet.dll,dllinitrun) - очередное spyware.
  • Winmodem (wmexe.exe) - нужен для функционирования некоторых вин-модемов.


Перезагрузка, выключение компьютера

Windows перезагрузится быстрее, если, при выбранном "Перезагрузить компьютер", удерживая Shift нажать ОК.

Если Вы хотите, чтобы после выбора меню "Перезагрузить в режиме эмуляции MS-DOS" у Вас, после завершения работы Windows автоматически запустилась какая-то программа (например, Нортон командир), то впишите необходимые команды в файл dosstart.bat, который находится в папке Windows.

Чтобы обновить изменения в реестре без перезагрузки компьютера нажмите Ctrl+Alt+Del, выберите из списка explorer и нажмите "Снять задачу". Откажитесь от выключения компьютера, в появившемся через несколько секунд окне нажмите "Снять задачу" и через еще несколько секунд оболочка Windows перезагрузится с новыми параметрами.


BSOD

Раскраска Синего экрана смерти

В случае возникновения системной ошибки диагностическое сообщение о ней выводится в текстовом режиме белым цветом на синем фоне - это так называемый Синий Экран Смерти (Blue Screen of Death или сокр. BSOD). При желании этот экран можно "перекрасить", скажем, в красный цвет с белыми буквами. Для этого нужно добавить в файле SYSTEM.INI в секции [386Enh] две строки MessageBackColor=4 и MessageTextColor=7, где цифры задают стандартные ASCII-цвета. После перезагрузки они вступят в силу, что можно проверить, не дожидаясь ошибки, - вставьте чистый диск в 3,5" дисковод, найдите какой-нибудь файл длиной около 1 МБ и в окне MS DOS выдайте команду его копирования на дискету. Когда файл начнет записываться, извлеките дискету (прямо во время записи). Через несколько секунд Windows выдаст сообщение о невозможности записи файла, расцвеченное новыми цветами.
Замечание: Таким способом можно и повредить дисковод. А вот с CD такого нет! Нужно просто задать команду скопировать что-нибудь с CD-ROMa и нажать кнопку выброса диска. Результат будет тот же.

STOP-сообщения Windows

При появлении BSOD на экран выводится определенное STOP-сообщение, которое сигнализирует, что ядро операционной системы выявило ошибку, из которого оно не может выйти самостоятельно. Каждое такое сообщение определяется уникальным шестнадцатеричным числом, идентифицирующим возникшую ошибку, и символьной строкой. За шестнадцатеричным числом следуют заключенные в круглые скобки шестнадцатеричные числа, каждое из которых указывает один из параметров возникшей ошибки. По символьной строке, идентифицирующей ошибку, можно предположительно определить, какой из компонентов системы был затронут ошибкой, после которой ядро не смогло восстановиться. STOP-сообщение состоит из трех основных частей: информация кода ошибки, рекомендации пользователю и информация отладчика.

Если STOP-сообщение не отображается, а компьютер сразу уходит в перезагрузку, то, следует изменить ключ реестра HKEY_LOCAL_MACHINE\ SYSTEM\ControlSetxxx\Control\CrashControl\AutoReboot на 0 (смотри справочник по реестру).

Если система не грузится и отображает STOP-сообщение снова и снова, попробуйте загрузить Windows в безопасном режиме, удерживая клавишу F8 при загрузке и выбрав Safe Mode. К положительному результату может также привести выбор параметра загрузки Last known good configuration (загрузка последней удачной конфигурации), особенно если проблема связана с недавно установленными драйверами. Если же Windows не грузится даже в безопасном режиме, можно воспользоваться установочным компакт-диском Windows для запуска консоли аварийного восстановления (recovery console).

Чтобы узнать подробнее о коде ошибки, то используйте ссылку search.support.microsoft.com/search/?adv=1, в которой введите свой код ошибки. И получите небольшую информацию от Microsoft

Вот несколько видов сообщений:

  • STOP 0х0000000А — IRQL_NOT_LESS_OR_EQUAL - Это сообщение, известное также под названием STOP OxOA, указывает на то, что процесс режима ядра пытался получить доступ к участку памяти на слишком высоком уровне запроса прерывания (Interrupt Request Level — IRQL), в то время как такие процессы могут получать доступ только к процессам с IRQL, не более высоким, чем их собственный. Чаще всего эта ошибка вызвана ошибкой в драйверах. Если вы недавно установили новый драйвер, то следует откатиться до предыдущей версии драйвера, благо в Windows XP и 2003 функция отката драйверов является встроенной. Часто вместе с кодом ошибки выводится и имя сбойного файла драйвера. Прежде чем откатывать драйвер, попробуйте перезаписать этот файл его копией из дистрибутива драйвера — иногда это помогает.
  • STOP 0x000000IE — KMODE_EXCEPTION_NOT_HANDLED< - Это сообщение, известное также как STOP 0xlE, указывает на то, что процесс режима ядра пытался выполнить недопустимую инструкцию. Эта ошибка также часто связана с драйверами, но может проявиться в результате изменения настроек BIOS, особенно связанных с оперативной памятью (к примеру, включения функции кэширования памяти).
  • STOP 0x00000024 — NTFS_FILE_SYSTEM - Это сообщение, известное также как STOP 0x24, указывает на проблему с драйвером Ntfs.sys, позволяющим системе выполнять чтение информации с томов NTFS и запись на такие тома. Чаще всего связано с ошибками на жестком диске. Рекомендую выполнить проверку диска с помощью консоли аварийного восстановления. Также не помешает переписать файл Ntfs.sys. Дело в том, что некоторые нехорошие программы (особенно связанные с прозрачной архивацией и т.п.) могут перезаписать этот файл своей кривой версией. В таком случае из-под консоли аварийного восстановления выполните команду COPY (буква привода компакт-дисков):\i386\ntfs.sy_\%SystemRoot^\system32\ntfs.sys, на вопрос о перезаписи ответить Y (да). Использованием команды COPY можно восстановить практически любой файл системы из дистрибутива Windows.
  • STOP 0х0000002Е — DATA_BUS_ERROR - Появление сообщения 0x2E обычно указывает на ошибку четности в системной памяти. Эта ошибка всегда вызывается проблемами с аппаратными средствами, ошибками, допущенными при их конфигурировании, а также несовместимыми или дефектными аппаратными средствами. Эта ошибка часто может указать на сбойную оперативную память, а также на проблемы с материнской платой.
  • STOP 0x00000050 — PAGE_FAULT_IN_NONPAGED_AREA - Эти сообщения появляются, когда запрошенные данные не найдены в памяти. Система при этом генерирует так называемую страничную ошибку, или страничное прерывание (page fault), которое при обычных условиях означает, что система ищет данные в файле подкачки (paging file). В этом случае, однако, искомые данные идентифицируются системой как находящиеся в резидентном пуле (nonpaged pool), а это значит, что они ни при каких обстоятельствах не могли быть сброшены на диск. Таким образом, система не может найти требуемые данные и, следовательно, не может продолжать работу. Этот тип ошибки может быть вызван дефектными аппаратными средствами, некорректно работающим системным сервисом, резидентным антивирусным программным обеспечением, несовместимым с операционной системой, и повреждениями файловой системы NTFS.
  • STOP 0x00000077 — KERNEL_STACK_INPAGE_ERROR - Сообщения (STOP 0x77) указывают, что ядро не может прочесть запрошенную страницу из файла подкачки. Эта ошибка указывает на проблемы с жестким диском или его контроллером. Еще она может быть связана с проблемным драйвером SCSI-адаптера в случае, если вы используете SCSI-диск для хранения файла подкачки, а кроме того — с проблемами прерываний.
  • STOP 0x00000079 — MISMATCHED_HAL - Эти сообщения (STOP 0x79) появляются при несовпадении уровня аппаратных абстракций (HAL) и ядра или типа компьютера, в основном, при смешении конфигурационных файлов однопроцессорной и многопроцессорных систем в пределах одной системы. Очень редкая ошибка, но последнее время я сталкиваюсь с ней очень часто. Некоторые программы для модификации boot-screen могут изменить версию файла ядра системы, в результате чего и возникает эта ошибка. Если вы увидели эту ошибку, восстановите файл ntoskrnl.exe из дистрибутива Windows.
  • STOP 0x00000078 — INACCESSIBLE_BOOT_DEVICE - Это сообщение (STOP 0x7B) появляется в процессе запуска системы и указывает на то, что в процессе загрузки система потеряла доступ к загрузочному диску. Кроме поврежденных драйверов жесткого диска и ошибок на нем, это STOP-сообщение может быть вызвано некорректной работой режима Serial ATA, а также проблемами с RAID.
  • STOP 0X0000007F — UNEXPECTED_KERNEL_MODE_TRAP - Сообщения STOP 0x7F указывают на фатальную ошибку, вызванную программным прерыванием. Практически всегда она вызвана аппаратным сбоем. Если эта ошибка стала возникать достаточно часто, следует внимательно протестировать все аппаратное обеспечение — какая-то деталь нуждается в замене! Кроме того, она может указать на неудачный разгон процессора — понизьте тактовую частоту до номинала.
  • STOP 0x0000021 А — STA TUS_SYSTEM_PROCESS_ TERMINA TED - Редкий случай, когда сообщение STOP вызвано сбоем сервиса, работающего не в режиме ядра, а в режиме пользователя. Это сообщение (STOP OxC2lA) появляется, когда одна из подсистем (например, Winlogon или CSRSS) настолько повреждена, что операционная система не может гарантировать безопасности и переключается в режим ядра с генерацией этой ошибки. Если вы недавно устанавливали какое-либо программное обеспечение, то, скорее всего, оно не полностью совместимо с вашей версией Windows. Возможно, ПО появилось на компьютере без вашего ведома — проверьте диски на предмет вирусов и spyware.
  • STOP 0x00000221 — STATUS_IMAGE_CHECKSUM_MISMATCH - Это сообщение (STOP 0xC221) указывает на повреждение драйвера или системного файла DLL. Как правило, в сообщении STOP указывается имя файла, вызвавшего проблему. Восстановите поврежденный файл из дистрибутива, и все будет ОК.

    • Получить информацию по конкретной ошибке всегда можно в Microsoft Knowledge Database (База знаний "Майкрософт").


"Обрезание" виндов

В том случае, если уже установлено все оборудование, можно удалить папку %SystemRoot%\Driver Cache\i386\ (т.е. по умолчанию C:\Windows\Driver Cache\i386\). Правда, в этом случае при добавлении любого нового оборудования Windows будет запрашивать установочный CD

И еще одну папку можно удалить - %SystemRoot%\system32\dllcache\ (в ней хранятся защищенные системные файлы, используемые для автоматического восстановления оригиналов в случае их повреждения). Кстати, по умолчанию размер этой папки - 400 мб (он задается в реестре параметром SFCQuota (0xFFFFFFFF), находящемся в ключе HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon, но его можно изменить до нуля программой sfc: sfc /cachesize=0 (если поставить, например, 10, то размер папки уменьшится до 10 мб)


Сеть

Освобождение канала (bandwidth), зарезервированного за сервисом QoS.
Это такая хитрющая штука, о которой я бы вжись не догадался, если бы не прочитал на сайте улучшалок ХР. Как оказалось, Windows XP по умолчанию выделяет часть интернет-канала для очень полезной штуки, которая называется Quality of Service (QoS). Назначение QoS - улучшать распределение трафика программ, написанных с учетом QoS API. Другое дело, что этих программ днем с огнем не сыскать (вернее, у меня лично они не стоят), поэтому резервирование канала под ненужный сервис - непозволительная роскошь. Вот что нужно проделать для того, чтобы освободить и без того узкий канал отечественного соединения с интернетом:
- В меню Start - Run запустите редактор групповых полисов: gpedit.msc. Имейте ввиду, что для выполнения всех этих процедур вам необходимо войти в систему как Администратор.
- В разделе Computer Configuration (в левом окне) выберите Administrative Templates.
- Далее Network и затем в правой панели выберите QoS Packet Scheduler и кликните на нем два раза.
- Выберите опцию limit reservable bandwidth и опять-таки кликните на ней два раза.
- В открывшемся окне включите Enabled, а затем укажите лимит канала в процентах равный нулю.
- ОК и выйдите из программы. Но это еще не все.
- Отправляйтесь в сетевую конфигурацию (иконка Network Connections в Контрольной панели).
- Выделите свое соединение и из контекстного меню запустите Properties.
- В закладке Networking убедитесь, что протокол QoS Packet Scheduler подключен (enabled). Если его там нет, то добавьте из списка (через кнопку Install).
- Перегрузите компьютер.
Все эти сложные пассы с насильственным включением сервиса и последующим выделением под него нулевого канала вызваны тем, что если просто отключить Quality of Service, то, как это часто бывает у наших антипятов, система все равно будет резервировать под него 20 % канала.

Если набрать
net send "имя компьютера" message
в пункте меню "Пуск"->Выполнить, то на компьютере "имя компьютера" появится окно c сообщением. Очень удобно переговариваться в сети. Вместо "имя компьютера" можно использовать ip-адрес.
Работает на NT, 2000. Чтобы работало в Win9x надо запустить winpopup.

Если в конце имени расшаренного ресурса поставить символ "$" (без ковычек), то этот ресурс будет не виден в сети. Доступ к нему можно будет получить, только обратившись к нему напрямую.


Файл подкачки

Windows 9x/Me активно использует файл подкачки, значительно разгружая оперативную память компьютера. По неизвестным причинам Microsoft сделала файл подкачки динамическим, т.е. размер файла изменяется в зависимости от нужд Windows, хотя наилучшая производительность системы достигается при статическом файле. Причин для этого множество - Windows не требуется каждый раз изменять размер файла подкачки, исчезает фрагментация и т.д. Для того чтобы изменить параметры файла подкачки, щелкните правой кнопкой мыши на значке "Мой компьютер" и выберите Свойства. Перейдите на вкладку Производительность и щелкните кнопку Виртуальная память (Properties->Performance->Virtual Memory). В появившемся окне выберите "Параметры виртуальной памяти устанавливаются вручную" (Let me specify my own virtual memory settings). Если у вас установлено более одного жесткого диска, рекомендуется перенести файл подкачки с диска, где у вас установлена Windows на другой жесткий диск, более быстрый. Это должно значительно увеличить производительность системы. Теперь установите размер файла виртуальной памяти. Рекомендуемый размер - хотя бы в 2,5 раза больше, чем объем оперативной памяти. Перезагрузите систему и запустите утилиту дефрагментации для того, чтобы быть уверенным, что файл подкачки не фрагментирован. А если вы пользуетесь дефрагментатором сторонних производителей, в опциях укажите, чтобы файл подкачки располагался в начале диска.

Для компьютеров, оснащённых более чем 64 MB оперативной памяти, можно порекомендовать следующий "трюк": в файле system.ini, который находится в каталоге C:\Windows, в разделе [386Enh], необходимо дописать строку ConservativeSwapfileUsage=1
Это позволит системе не создавать файл подкачки без необходимости. Например, со 128 MB оперативной памяти можно будет открыть до трёх офисных приложений, таких, как Word, Excel и Internet Explorer, притом, что размер файла подкачки останется равным нулю. То же самое произойдёт при запуске Quake 3.

Если файл подкачки не "консервировать", то приложений открыть можно будет гораздо больше, а игр запустить хоть две, одновременно. Надо бы, авторам советов, не забывать, как мне кажется, что читают их в том числе и чайники, и для них они достаточно авторитетны, а по сему стараться быть объективней или хотя бы давать советы более корректные.
Небольшой комментарий от ведущего: в принципе, верное замечание. Однако, в большинстве случаев "консервировать" файл подкачки можно, т.к. сейчас средний компьютер имеет 128 Мб оперативной памяти, плюс около 300 Мб виртуальной памяти (при коэффициенте 2,5), что дает более 400 Мб суммарно. В 99% случаев этого хватает с избытком. Но бывают и исключения, поэтому не стоит слепо следовать советам, а немного подстраивать их под свои условия. Ведь можно установить размер виртуальной памяти и в 4-5 раз больше. Экспериментируйте. Это не "убьет" Windows.

Как оптимально настроить файл подкачки - несколько советов.
Если у Вас несколько винчестеров (не разделов, а именно винчестеров), то установка файла подкачки на другой винт, чем установлена операционная система, обычно значительно ускоряет быстродействие.
Если у Вас несколько винчестеров - то файл подкачки ставится на самый быстрый из них.
Если у Вас несколько разделов на винте, то файл подкачки надо ставить на самый первый из них - физически расположенный самым первым, так как доступ к этим областям винта наиболее быстрый.
Целесообразно ограничить минимальный объем файла подкачки, чтоб предотвратить излишнюю его фрагментацию примерно объемом 1-1.5 объема вашей оперативной памяти (впрочем если Вы пользуете графику или напрягаете компьютер серверами баз данных то можно поставить размером 2-3 объема RAM).
Практически не имеет резона ограничивать максимальный объем, так как это может привести к сбою программ из-за нехватки памяти, а если уж и ограничивать, то никак не меньше чем 4 объема RAM.
После этих настроек комп надо перезагрузить и запустить какой-нибудь дефрагментатор (типа Norton Speed Disk) чтоб полностью дефрагментировать файл подкачки и поместить его в начало раздела.
И последнее, помните, что после выключения компьютера файл подкачки может содержать Ваши пароли, логины, остатки Вашей конфиденциальной информации и т.п., так что достаточно "образованные дяди" из числа Ваших доброжелателей или компетентных органов, загрузившись в ДОС и покопавшись в объедках Ваших программ в файле подкачки могут найти очень интересные вещи...


Autorun

Все, наверное, видели, как при установке компакта с игрушкой иконка сидюка менялась на иконку игрушки, и многие знают, как это делалось. А если кто не знает - скажу. Всё дело в файле AUTORUN.INF, который лежит в корне сидюка. Он примерно такой:
[Autorun]
icon=icon.ico
Если же такие файлы переписать на винт, то поменяется иконка харда.

Расширенное описание файла Autorun.inf

[Autorun]
Open=Autorun.exe
Icon=Autorun.exe ,0
Shell\About=About CD
Shell\About\Command=Notepad.exe About.txt

 Перед параметрами Open, Icon, Shell\..., Shell\...\Command обязательно должна быть строка [Autorun] (в INI и INF файлах в квадратные скобки заключаются имена разделов).

Описание параметров:
Open | Командная строка, автоматически выполняемая при вставке диска или при выборе в контекстном меню диска пункта Автозапуск. Например: Open=Autorun.exe или Open=Notepad.exe List.txt
Icon | Полные путь имя файла со значком и номер значка в нем. Формат: Icon=File.exe ,n File.exe - полные путь и имя файла со значком n - номер (отсчет начинается с нуля) значка в файле
Shell\name | Описание дополнительного пункта контекстного меню диска. Формат: Shell\mname=mtext Shell\mname\Command=cmdline mname - имя пункта меню mtext - текст пункта меню cmdline - командная строка, выполняющаяся при выборе этого пункта меню.

Примечание:
Если параметр Shell\...\Command указан без параметра Shell\..., то в меню будет выведено либо системный текст, либо имя пункта меню.
Примечание:
Файлы Autorun.inf могут работать не только на жестких дисках и CD, они могут работать и на съемных дисках. Для этого надо с помощью программ тонкой настройки Windows включить автозапуск со съемных дисков. Например, в программе XQXSetup эта настройка находится по адресу: System\File System\CD Autostart\Autostart Data CD


BAT-файлы

Если Вам требуется последовательно запускать несколько программ Windows, то Вы можете написать для этого .bat файл. Используйте команду START с ключом /W. Например создайте текстовый файл со следующим текстом:

@START /W /MAX "C:\WINDOWS\SCANDSKW.EXE /A /N"
@START /W /MAX "C:\WINDOWS\DEFRAG.EXE /ALL /F /NOPROMPT"

И сохраните его как 1.bat (обратите внимание на кавычки!). Кроме /W, Вы можете использовать следующие ключи:
/M Запускает программу минимизированно
/MAX Запускает программу, развернув на весь экран
/R Запускает программу в окне (используется по умолчанию)

Передача параметров в bat-файл.
Для того чтобы bat-файл можно было запускать с какими-то параметрами надо в том месте файла, куда вы хотите добавить параметр, набрать %1 - для первого параметра, %2 - для второго и т.д.
Например (файл test.bat):

/тут идут какие-то
/.....
/подготовительные работы
rar m file%1

Теперь если вы запустите этот файл командой "test.bat 0001", то у вас будет создан файл с именем file0001.rar


desktop.ini

Содержимое файлов desktop.ini

[.ShellClassInfo]
CLSID={...}
InfoTip=YOUR TIP
IconFile=C:\Windows\System\Shell32.dll
IconIndex=0
CLSID - имя папки для регистрации в раделе реестра HKEY_CLASSES_ROOT\CLSID
InfoTip - комментарий к папке
IconFile - имя файла со значком для папки
IconIndex - номер значка в файле, указанном в параметре IconFile(нумерация начинается с нуля)

Каждый независимый параметр можно использовать отдельно от других.
Указав CLSID в файле desktop.ini, можно создав соответствующий ему раздел в реестре, оперировать с папкой, содержащей desktop.ini, как с типом файлов.
Параметры InfoTip, IconFile, IconIndex возможно работают только на Windows ME или Windows 2000.
Чтобы применить настройки файла desktop.ini надо:
* Если файл существовал до внеснения изменений, то обновить содержимое папки.
* Если файл был создан Вами или первый способ не помог, то
1.Выбрать Настроить вид папки в меню проводника Вид.
2.Выбрать настройку фона папки и шрифта.
3.Не изменяя текущих настроек, нажимать кнопку Далее.
4.Нажать кнопку Готово.

Папки, которые содержат desktop.ini со следующим содержимым:
CLSID={...}
или
UICLSID={...}
можно добавить в любую папку, создав в ней папку с именем ИМЯ.{...}, где {...} - значение ключа CLSID (UICLSID) из файла desktop.ini .
Примечание:
Не гарантируется, что в созданных папках будет повторятся содержимое папок с desktop.ini, но на системные папки, зарегистрированные в CLSID, это скорее всего подействует.
Некоторые не существующие физически папки, зарегестрированные в разделе реестра HKEY_CLASSES_ROOT\CLSID можно добавить таким же образом.


О Виндах и двух винтах

Винду, как один большой глюк можно исследовать бесконечно. Но, в процессе изучения, винда часто падает и очень серьёзно. В конце концов мне надоело её ставить (или обновлять). Помните как в ДОСе: sys c:, а затем переносится папочка ДОС... Так вот с тех пор произошли существенные изменения. Исчезла необходимость команды sys с:! Для такого изврата необходимо только одно условие - два винчестера. Думаю это уже не проблема, так как винты дешевеют быстрее чем ломаются и найти маленький винт на пару гиг ещё можно. (У меня маленькая дискетка на 8 гб :)

Зачем это надо?
1. Мне лень переустанавливать винды. Сам процесс занимает немного времени, но установка остальных программ является настоящим адом.
2. Люблю брать различные компашки с различным софтом и смотреть как он работает. После софта в реестре остаётся много различного мусора, который очень сильно влияет на размер реестра, и в конце концов, на скорость машины.
3. На работе часто приходится устанавливать винды на новые машины, а кому понравится когда его отвлекают.
4. Дома стоит Миллениум, из которого убраны руками множество ненужных на мой взгляд функций. Второй раз повторить это будет сложно.

Вроде указал большинство причин. Итак:
Берем работающую винду, запускаем под ней виндовс коммандер (можно воспользоваться любым файл-менеджером, главное что бы он понимал длинные имена). Устанавливаем в обоих окошках командира: "Показывать скрытые/системные файлы", вид - "все файлы", "без сортировки". В виндовс командире я убираю ещё птичку с "в обратном порядке". То есть мы готовимся копировать все файлы в том порядке, каком они идут на жёстком диске. Берём с диска с: папки "виндовс", "программные файлы" и файлы в корневой директории (это обязательный список) и копируем на другой винт, предварительно отформатированный (или по крайней мере ПОЛНОСТЬЮ очищенный от всех файлов). Можно не обязательно на чистый диск, можно сделать резервную копию - просто скопировать на какой-нибудь диск, но тогда этот диск НЕЛЬЗЯ оптимизировать никаким дефрагментатором. На ругань виндозы, типа не вижу файл Win386.swp сказать - пофигу.
Итак, скопировали.
Перегружаем машину, устанавливаем в БИОСе загрузку с этого винта. Оппа! Поехала! Значит всё сделано правильно.
Я так устанавливаю виндозы на новые тачки: лежит у меня на винте копия только что установленной винды (+оффис, инсталляция, работающая сетка). Винт с новой тачки снимаю и цепляю к себе. Копирую копию винды на винт. Запускаю его на новой машине. ВСЁ! 5 минут, а уже имеем работающий компьютер с установленным оффисом!!! (Сборщикам компов - всем поднять за моё здоровье ;) Остаётся настроить сеть, поменять драйвера и нервы ваши опять гладкие и шелковистые...
Дома я так делаю когда у меня накопятся всякие программы или захочется покопаться мне в реестре и покастрировать винду. Запускаюсь с копии и работаю. Если понравилась прога, то и на основном винте ставлю.
Кстати, в таком использовании двух винтов есть ещё очень большой плюс. Большинство устанавливаемых программ можно ставить только один раз в жизни, на копию винды. Если потом перегрузиться на основной винт и попробовать её запустить, то в 80-90% она работает без ущерба для здоровья. Исключение составляют здоровые пакеты чего-нибудь, которые пишут свои ДЛЛки в System, или ещё куда-нибудь. И те проги, которые итегрируются в системы (оффис). Их придётся ставить каждый раз. Все остальные можно смело копировать на какой-то выделенный диск и пользоваться независимо от количества установок виндозы. Зачем каждый раз повторять инсталляцию?

Некоторые проги (Нортона утилиты, Nuts&Bolts, VisualRoute) несмотря на то что и пишут куда-то свои ДЛЛки, но позволяют скопировать эту ДЛЛку к себе в каталог и запускаются без проблем. Вообще, чтобы скопировать такой пакет утилит надо посмотреть у него в папке uninstall файл, там часто в некодированном виде расписано где что положено и откуда всё брать.


Игры

Пасьянс "Косынка"
При сдаче по три карты удерживая одновременно Ctrl, Alt и Shift, можно снимать с колоды по одной карте

Пасьянс "Солитер"
Нажмите одновременно Shift, Ctrl и F10. Теперь Вы можете выбрать, получится разложить Вам этот расклад, или нет. Нажмите F3 для выбора расклада, выберите расклад -1 или -2. Перед Вами появится очень необычный расклад.

Логическая игра "Сапер"
Щелкните по полю, чтобы началась игра. Одновременно нажмите обе кнопки мыши. На экране должен появиться квадрат 3х3. Нажмите Esc. Теперь часы в игре остановились. Для возвращения в обычный режим нужно свернуть и развернуть обратно окно игры.


Стандартные программы

Планировщик заданий

Вы пользуетесь планировщиком заданий? Если нет, то лучше отключите его: он только "отъедает" лишнюю оперативную память, замедляет загрузку компьютера и занимает место в трее. Сделать это не просто, а очень просто. Для Win9x запустите редактор реестра и в разделе HKEY_LOCAL_MACHINE\Software\ Microsoft\Windows\Current Version\RunServices\ удалите параметр "SchedulingAgent". Для Win NT/2000 надо зайти в Панель управления - Администрирование - Службы и остановить "Планировщик заданий".
Замечание:
Совсем не обязательно буждать по реестру для отключения планировщика в win9x. Для этого кликаем по иконке планеровщика с трэе (он запускается), выбираем в меню "Дополнительно" пункт "остановить планировщик". Всего то.

Блокнот

Блокнот можно очень удобно использовать для ежедневных заметок. Если в первой строке написать .LOG (буквы должны быть большими), то каждый раз при его открытии курсор будет устанавливаться на конец файла, а перед ним будет автоматически вводиться текущая дата и время.

Редактор реестра (Regedit.exe)

Для того, чтобы импортировать в реестр данные из reg файла без запросов, запустите его с ключом /s. Например:
regedit /s test.reg

Есть простой способ отследить изменения, которые происходят в реестре Windows. Запустите Regedit и экспортируйте файл реестра ("Файл" > "Экспорт файла реестра"), сохранив его под любым именем, например, before.reg. В момент, когда захотите проверить изменения в реестре, совершите ту же операцию (сохранив файл, например, after.reg). Теперь активируйте строку MS-DOS и в директории, где находятся эти два файла, наберите:

FC before.reg after.reg > diff.txt
Открыв файл diff.txt в любом текстовом редакторе, вы увидите все изменения, которые произошли в реестре.
Кстати, FC - это внешняя команда DOS для сравнения файлов и выведения различий в них.

drwatson.exe

Для запуска вводим "drwatson" без кавычек в Пуск => Выполнить. После этого кликаем дважды по новой иконке в Области уведомлений ("где часы") и выбираем Вид => Полный режим.
Программа умеет вот что:
- Анализ программных модулей которые могут (не факт, что вызовут) вызывать сбои определенного рода.
- Чуток информации о системе.
- Полный список текущих задач + показ пути к екзешникам.
- Список программ, запускающихся при включении компьютера.
- Инфа о том, какие "системные модули были изменены в памяти".
- Какие модули и приложения перехватывают нажатия клавиш клавиатуры (т.н. "Hook'и").
- Список установленных драйверов ядра системы.
- Аналогичный список драйверов пользователя.
- И драйверов MS-DOS.
- Список 16-разрядных модулей, которые были задействованы при возникновении ошибок.
Часть этой информации получается путем дизассемблирования чего-то. Программа поодерживает печать, сохранение копий данных на диск.
Не думаю, что это может как-то пригодиться новичкам, но функция отлова программ, хукающих клаву мне очень понравилась. Удивительно, почему о ней никто не знает.


Антивирусные программы

Для тех, кто отдает предпочтение Norton AntiVirus: При установке NAV в Windows XP не отключайте службу "Планировщик заданий" иначе после установки, при инициализации конфигурации произойдет внутренняя ошибка NAV, причем не понятно из-за чего. Методом "тыка" было обнаружено, что эта ошибка происходит при выключенной службе "Планировщика заданий". Совет: Не отключайте эту службу. Сначала установите NAV, при установке отмените проверку каждую пятницу, перегрузите компьютер и затем отключайте службу "Планировщик заданий".

Рекомендуется переименовать антивирусную программу DRWEB.EXE (для маскировки запуска Doctor Web от резидентных вирусов, контролирующих работу DRWEB.EXE). При этом необходимо также переименовать файлы DRWEB.INI, DRWEB.HL1 и DRWEB.HL2 (сохраняя расширения имён).


Печать

Если вам надо что-то печатать на сетевом принтере из ДОСовской программы, которая может выводить данные только в локальный порт LPT1, вам надо перед запуском этой программы в bat-файле дать команду: net use LPT1 \\Computer\Printer где Computer - имя сетевого компьютера, а Printer - имя расшаренного принтера. Это позволит подключить сетевой принтер к порту на вашем компьютере. Команда net use LPT1 /d отключит подключенный ранее сетевой принтер.

О файлах печати.
При установке принтера, можно в качестве порта вывода указать файл. В этом случае всякий раз при попытке распечатать документ на такой принтер, Windows, будет выводить окно с запросом на указание имени создаваемого файла (это окно можно отключить - об этом сказано в одном из предыдущих выпусков "премудрости"). Обычно эти файлы имеют расширение prn.
Зачем могут потребоваться такие файлы?
Если такой виртуальный принтер, печатающий в файл - это PostScript устройство, то далее этот файл можно обработать при помощи Acrobat Distiller и получить в результате документ PDF. Кстати, таким образом можно экспортировать в PDF документы из любой программы, в принципе способной печатать на принтер.
Если на виртуальном PostScript принтере в настройках поставить генерацию кода Eps (encapsulated PostScript), и печатать на нём документы по одной странице, то в результате мы получим файлы encapsulated postscript, расширение у которых можно для удобства переименовать с prn на eps. Такие файлы, кроме уже упомянутой конвертации в PDF, могут использоваться также и для импорта в качестве картинок в другие программы, например, в тот же Word. Только для этого желательно создать в файле миниатюру изображения, иначе он скорее всего будет отображаться в виде серой плашки. Сделать это можно в Adobe Illustrator, в Alladin GhostScript или практически в любом векторном редакторе.
Наконец, файлы prn можно использовать и по прямому назначению. Допустим, у вашего друга стоит принтер, а у вас - нет. И вам надо распечатать документ. Проблема в том, что друг не может распечатать ваш документ, потому что у него нет программы, в котором он создан, да и вообще - друг работает в Linux и слышать не хочет про Windows... Тут-то и выручит файл prn. Вам нужно установить у себя драйвер того самого принтера, который стоит у друга (или, скажем, на работе), только в качестве порта вывода указать файл. Затем - печатаем наш документ, а полученный файл prn несём к другу. Если вы печатали текст, то файл получится небольшим. Далее - на компьютере, к которому непосредственно подключен принтер - копируем этот файл в двоичном режиме прямо на порт принтера. Под Windows для этого вызываем командную строку - выбрав мышью "пуск - выполнить" (или нажав на клавиатуре сочетание Win+R), и вводим "command", если вы делаете это в windows 9x или ME, или "cmd" для windows nt/2k/xp. В командной строке набираем "copy /b файл.prn lpt1", где файл.prn - ваш файл печати с путём к нему (например, a:\myfile.prn), а lpt1 (он же PRN) - порт, к которому подключен принтер. В linux всё делается аналогично - вызываем консоль и набираем команду копирования. Ваш документ будет распечатан.

О файлах PDF.
При распечатке таких файлов на лазерных принтерах без PostScript иногда возникают проблемы с неверной пропечаткой шрифтов (вместо символов печатаются кракозяки). Особенно часто это происходит при распечатке из Adobe Acrobat 5.x
Самое простое - поставить галочку "Print as image". Но при этом скорость печати упадёт примерно в 2-3 раза, а вместе с ним - и качество, поскольку на печать будет выводиться растровая картинка с разрешением 300 DPI.
Другой вариант - воспользоваться гораздо более древним Adobe Acrobat Reader версии 3.x. Он печатает гораздо быстрее и проблем возникает гораздо меньше.
Наконец, на мой взгляд, самый лучший вариант - вообще не пользоваться Acrobat-ом! Скачайте Alladin GhostScript версии не ниже 4.2 и Gsview для него, и забудьте вообще о проблемах с печатью PDF! Эта программа хорошо известна пользователям unix-систем, она быстро запускается, довольно неприхотлива к ресурсам компьютера, и кроме просмотра и распечатки PDF, PS и EPS файлов, включает множество других полезных функций для работы с PostScript документами.

Если Вам часто приходится печатать документы с разными настройками (например, landscape и portrait; чёрно-белые и цветные; высокое и низкое качество печати) на одном принтере, то Вы можете добавить новый логический принтер и установить для него альтернативные настройки.

Поместите на Рабочий стол ярлычок принтера и чтобы распечатать какой-то документ, просто перетащие файл этого документа на созданный ярлычок. Причем, печать будет осуществляться с помощью того приложения, которое зарегистрировано в разделе print в HKEY_CLASSES_ROOT для соответствующего расширения файла.

Как заставить печатать принтер в файл без перезапроса имени файла, т.е. установить файл по умолчанию?
Надо создать файл-порт в Win.ini:
в секции "[Ports]" написать что-то типа
c:\windows\temp\temp.ps=
Обратить внимание что строка заканчивается "=" после которого ничего нет. После перезагрузки для любого принтера в системе будет доступен этот порт. Это работает только в Win95/98/ME, в операционках на базе NT порт берется где-то из реестра, я не копался, пока не надо было.

При отправке заданий на печать на сетевой принтер из приложений MS-DOS может происходить задержка в 60-90 секунд до начала печати, что вызывает остановку работы MS-DOS-приложения в течение этого времени. При завершении работы приложения печать начинается сразу после его закрытия. Такое же поведение может наблюдаться при нажатии клавиши в приложении MS-DOS. Проблема обусловлена тем, что приложение MS-DOS при печати не закрывает принтерный порт. По умолчанию, MS Windows 95 ожидает поступления новых данных в течение 45 секунд, после чего начинает печать документа. Для решения проблемы необходимо отредактировать файл System.ini на том компьютере, где выполняется приложение MS-DOS.
Добавьте в раздел [Network] файла System.ini следующую строку:
PrintBufTime=10
А в раздел [IFSMGR] следующую строку:
PrintBufTime=10
Примечание: Если данные разделы отсутствуют в файле System.ini, то добавьте их после раздела [386Enh].
Значение параметра "PrintBufTime" устанавливает время задержки в секундах до начала печати. Чем меньшее значение используется, тем быстрее начинается печать документа. Однако слишком маленькое значение "PrintBufTime" может приводить к некорректной печати, либо к прекращению вывода задания на печать. В этом случае увеличивайте значение "PrintBufTime" до тех пор, пока не будет достигнута корректная печать.
Параметр, заданный в разделе [Network], управляет задержкой при сетевой печати с использованием редиректора реального режима; параметр, заданный в разделе [IFSMGR], устанавливает задержку при сетевой печати с использованием редиректора защищённого режима. Данные настройки также могут оказывать влияние и на локальную печать.


Панель управления

Совет админам, желающим оградить настройки операционной системы Win9x от слишком любопытных пользователей.
В каталоге Windows есть файл control.ini. С его помощью вы можете настроить какие элементы в Панели управления надо скрыть. Для этого надо в разделе [don't load] добавть название файла элемента, поставить знак "=", а после него "no". Например:

[don't load]
snd.cpl=no

snd.cpl - файл элемента в Панели управления. Эти файлы лежат в каталоге windows\system с расширением cpl. Думаю, по названию файла можно понять, каким элементом он управляет.


Панель управления: Система

Система

Изменим вкладку Система на Панели управления.
Создадим два файла - oeminfo.ini и oemlogo.bmp. Файл oemlogo.bmp создается в любом графическом редакторе с размером 160 на 120 пикселов (размеры задаются не жестко, можете немного поэкспериментировать). Файл oeminfo.ini создается в обычном блокноте (Notepad) с таким содержанием:
[General]
Manufacturer=Народные советы
Model=И. Чеботарев, А.Климов

[Support Information]
Line1=За поддержкой обращайтесь по телефону 03
Line2=
Line3=Часы работы:
Line4=Понедельник-Пятница 08.00-16.00
Line5=Суббота-Воскресенье 11.00-12.00!
Line6=

Скопируйте полученные файлы в Windows\System, вызовите вкладку Система на Панели управления и получите удовольствие. Если вы используете секцию [Support Information], появится кнопка Поддержка, в котором будут использованы ваши данные


Панель управления: Язык и стандарты

Язык и стандарты

Для Windows 95/98/Me

Для тех кто забывает какой день недели: "Панель управления" - "Язык и стандарты" - перейти на вкладку "Дата" и в поле "Полный формат" даты добавить дддд в начало или в конец имеющейся записи (получится что-то типа: д MMMM гггг 'г.' дддд). Теперь, если подвести курсор мыши к часам на системной панели, то во всплывающей подсказке увидите день недели и дату. Если у вас используются английские символы, то формат соответственно d MMMM yyyy 'г' dddd

Для Windows XP

Название апплета немного изменилось - "Язык и региональные стандарты". На вкладке Региональные параметры выбираете кнопку Настройка и на появившейся странице Настройка региональных параметров выбираете вкладку Дата. Далее следуйте советам, описанным выше. Имейте в виду, что здесь используются только английские символы. Кстати, если вы будет использовать ddd, то день недели будет в укороченном варианте из двух букв.


"Горячие" клавиши, комбинации клавиш

"Горячие" клавиши команд в Windows

Нажать | Действие
F1 | Вывести окно помощи
F10 | Активировать меню
ALT+ подчеркнутая буква | Выполнить команду меню
CTRL+F4 | Закрыть текущее окно в программе
ALT+F4 | Закрыть окно или выйти из программы
CTRL+C | Копировать
CTRL+X | Вырезать
CTRL+V | Вставить
CTRL+Z | Отменить
DELETE | Удалить
ALT+Пробел | Вывести системное меню для текущего окна
SHIFT+F10 | Вызов контекстно-зависимого меню
CTRL+ESC | Открыть меню "Пуск"
ALT+TAB | Переключение между задачами
SHIFT+СТРЕЛКА | Выделить символ
SHIFT+CTRL+СТРЕЛКА | Выделить слово
SHIFT+DEL | Вырезать в буфер обмена
CTRL+INS | Скопировать в буфер обмена
SHIFT+INS | Вставить из буфера обмена
PrintScreen | Делает снимок всего экрана и помещает в буфер
ALT+PrintScreen | Делает снимок активного окна и помещает в буфер
CTRL+ALT+DEL | Вызов диспетчера приложений (при двойном нажатии - горячая перезагрузка ПК
Мой компьютер и Проводник
Нажать | Действие
ALT+Стрелка влево | Вернуться назад
ALT+Стрелка вправо | Вернуться вперед
BACKSPACE | Посмотреть папку на уровень выше
CTRL+E или CTRL+F | Открыть окно Поиск
CTRL+H | Открыть окно Журнал
CTRL+I | Открыть окно Избранное
CTRL+R | Обновить окно
F4 | Выпадающий список в адресной строке
Рабочий стол, Мой Компьютер, Проводник
Нажать | Действие
Удерживать CTRL во время перемещения файла | Копировать файл
Удерживать CTRL +SHIFT во время перемещения файла | Создать ярлык
SHIFT+DELETE | Удалить не помещая в корзину
SHIFT+F10 | Контекстное меню выбранного элемента
F2 | Переименовать
F3 | Найти файлы или папку
F5 | Обновить
CTRL + A | Выделить все
ALT+ENTER или ALT+ Двойной щелчок | Посмотреть свойства
Ctrl+D | Удалить выбранный объект
Проводник
Нажать | Действие
Стрелка влево | Прикрыть выделенную папку
Стрелка вправо | Открыть выделенную папку
- (NUM LOCK) | Прикрыть выделенную папку
* (NUM LOCK) | Открыть все подкаталоги в папке
+ (NUM LOCK) | Раскрыть выделенную папку
F6 | Переключение между панелями
Диалоговые окна
Действие | Нажать
Завершить текущее задание | ESC
Нажать на выбранную кнопку или поставить флажок | SPACEBAR
Нажать соответствующую кнопку | ALT+ подчеркнутая буква
Нажать на выбранную кнопку | ENTER
Движение назад по опциям | SHIFT+TAB
Движение назад по закладкам | CTRL+SHIFT+TAB
Движение вперед по опциям | TAB
Движение вперед по закладкам | CTRL+TAB
На уровень выше ( в окнах Открыть и Сохранить Как) | BACKSPACE
Обновить окно загрузки или сохранения | F5
Клавиша WINKEY ( со значком Windows: обычно между Ctrl и Alt)
Нажать | Действие
WIN+TAB | Переключение между кнопками на панели задач
WIN+F | Отобразить поиск файлов
WIN+Ctrl+F | Отобразить поиск компьютеров
WIN+F1 | Вывести помощь по WINDOWS
WIN+R | Отобразить "Выполнить"
WIN | Открыть меню "Пуск"
WIN+BREAK/PAUSE | Вывести апплет "Система"
WIN+E | Открыть "Проводник"
WIN+D | Свернуть или восстановить все окна
Win+L | Быстрая смена сеанса работы пользователя (Windows XP)
Win+U | Вызов Диспетчера служебных программ
В диалогах Открыть или Сохранить как:

F4 - Открыть выпадающий список с деревом папок и устройств (когда выделен какой-либо объект).

При работе с текстом
Нажать | Действие
Ctrl + стрелка вправо | Перемещение курсора на начало следующего слова
Ctrl + стрелка влево | Перемещение курсора на начало предыдущего слова
Ctrl + стрелка вниз | Перемещение курсора на начало следующего параграфа
Ctrl + стрелка вверх | Перемещение курсора на начало предыдущего параграфа
Ctrl + Shift + любая стрелка | Выделение текста
Shift + End | Выделение всей строки с выбранной позиции
Shift + Home | Выделение всей строки до выбранной позиции
Смотри также
Internet Explorer: Комбинации клавиш


Клавиша SHIFT

Acrobat Reader 6 очень долго загружается. Происходит это, в основном, из-за обилия установленных в нее надстроек. Для избавления от этого достаточно держать нажатой клавишу Shift во время запуска Acrobat Reader. Практически на любом компьютере можно будет заметить ускорение загрузки программы

Если во время перетаскивания файла в мусорную корзину, нажатия на Del или выбора пункта меню "удалить" Вы будете держать нажатой кнопку SHIFT, то файл будет удален, а не помещен в корзину.

Если у вас на компьютере стоит автоматическое распознавание диска CD-ROM, то можно временно его отключить для отдельных дисков. Для этого нажмите и удерживайте клавишу SHIFT при загрузке CD-ROM.

Удерживая клавишу SHIFT при загрузке Windows, вы можете пропустить обработку файлов из Автозагрузки (быстрый перезапуск)

Если у вас в свойствах папки не установлено "Открывать папки в одном и том же окне", то при большой вложенности каталогов у вас может быть открыто очень много окон. Закрывать каждое по-отдельности долго и неинтересно. Если вы хотите закрыть их сразу все, то достаточно, удерживая Shift, закрыть последнее открытое окно с помощью "Х" в верхней правой части окна. Тогда закроются все окна каталогов входящих в путь этой папки.


Раскладка клавиатуры

Если у вас пропал значок раскладки клавиатуры в трее, возможно вы установили Офис ХР. Он имеет свой переключатель раскладок клавиатуры: ctfmon. Чтобы вернуть все как было возможно пойти несколькими путями: - удалить "Альтернативный ввод данных" ("Alternative User Input"). Как это сделать, можно прочитать здесь: http://support.microsoft.com/default.aspx?scid=kb;EN-US;q282599. Затем прописать internat.exe в автозагрузку. - переименовать файл internat.exe в какой-либо другой и прописать его в автозагрузку. - установить, например, программу Punto Switcher который добавляет свою иконку в трей для изменения раскладки клавиатуры. - а проще всего вообще не устанавливать "Альтернативный ввод данных" ("Alternative User Input") при установке Офиса.

Быстрый доступ к меню (в любой программе) - нажимаем "Alt". После этого перемещаемся по меню при помощи клавиш курсора. Указанное свойство может выполнять и "медвежью" услугу, например, если вы пользуетесь для смены языка клавиатуры сочетанием Alt+Shift. Обычно именно такое сочетание стоит по умолчанию при установке Windows. В этом случае, если вы случайно не дожмёте Shift при смене языка, вы попадёте в меню программы, и дальнейшие нажатия клавиш на клавиатуре будут осуществлять навигацию по меню, а не набор текста, как вы, возможно, ожидаете. Зачастую эта навигация может привести в замешательство, и даже повредить документ. Например, если вы нажмёте последовательность клавиш Alt - ф - а (если до этого, скажем, печатали что-то в латинском регистре, а затем захотели допечатать по-русски слово, например, "фазан", но при этом недожали Shift), то Word перейдёт к меню создания нового документа. Комбинация же ф - з после нажатия на "Alt" приведёт вообще к закрытию документа. К счастью, при этом Word спросит у вас о необходимости сохранить изменения...
Выход? Воспользоваться другим сочетанием для смены языка - Ctrl+Shift. Нажатие Ctrl или Shift по отдельности не вызывает в Windows никаких действий. К тому же это удобно при слепом наборе - мизинцем одной руки нажимаем Shift, а другой - одновременно - Ctrl.

Утверждение, что "Нажатие Ctrl или Shift по отдельности не вызывает в Windows никаких действий". То есть да, по отдельности не вызывает, но для переключения языка нужно ведь нажать одновременно, разве нет? И как раз нажимать одновременно Ctrl и Shift плюс стрелки вправо-влево очень часто требуется при редактировании текста в Word, да и вообще в любом текстовом редакторе или процессоре, для выделения фрагментов по словам. Казалось бы, и так плохо, и эдак нехорошо, в обоих случаях есть конфликты с заданными горячими клавишами. Однако ж есть маленький нюанс: в первом случае, страшное может случиться "если вы случайно не дожмёте Shift при смене языка", то есть в случае, если сам юзер немного ошибется. Во втором же случае ошибка, т.е. непреднамеренное переключение раскладки, происходит гарантированно.
Какой из этого вывод? А такой, что сочетание Alt-Shift, при условии, что юзер нажимает его достаточно быстро, ошибок при работе в Windows почти не вызывает. У меня например, за пять лет, что я интенсивно работаю на компьютере, случайный выход в меню программы из-за того, что я пользуюсь Alt-Shift был раза три-четыре всего. В то же время работать с текстами на машинах с установленным сочетанием Ctrl-Shift лично мне становится невозможно, пока я не поменяю его на Alt-Shift. Ну да, конечно, большинство выделяет слова мышью и перетаскивает мышью, для них эта разница незаметна...

Вообще то переключение раскладки клавиатуры (я имею конечно в виду тот случай когда для перключения используется CTRL+SHIFT) не происходит в том случае если вы нажали CTRL+SHIFT и еще какую нибудь стрелочку, так что никаких проблем править текст с помощью клавиатуры нет. Я сам не любитель работать с мышью, но проблем с тем что постоянно происходит переключение языков при правке текста у меня нет.
Но вообще, конечно, тут не о чем спорить, тот кто привык переключать с помощью CTRL+SHIFT не станет переучиваться на ALT+SHIFT (ну и наоборот соответственно), так как в данном случае очень велика сила привычки.
А вообще, я бы рекомендовал пользоваться автоматическими переключателями - очень удобно имеется масса настроек и дополнительных вещей. Хотя опять же надо привыкнуть.

Столкнулся с проблемой: Windows не хочет менять используемую по умолчанию раскладку клавиатуры с помощью диалога "Свойства: Клавиатура".
Способ борьбы: надо поменять в реестре в разделе HKEY_CURRENT_USER\Keyboard Layout\Preload местами значения в строках "1" и "2", должно быть
"1" 00000409
"2" 00000419
Тогда первой будет английская раскладка.


Windows Media Player

Копирование музыки с компакт диска в стандартном проигрывателе WinXP.
Создать .reg файл, скопировать туда следующие строки:

========================================
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\Settings]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\Settings\MP3Encoding]
"LowRate"=dword:0000dac0
"MediumRate"=dword:0000fa00
"MediumHighRate"=dword:0001f400
"HighRate"=dword:0002ee00

========================================
и запустить.
В настройках Windows Media player, установить, в параметрах настройки копирования формат файла MP3.
Только нужен нормальный mp3 кодер, установленный в системе. Без него проигрыватель писать ни чего не будет.


Приколы и "пасхальные яйца" в программах

WinRAR

Пара пасхальных яиц в WinRar. Зайдите в меню Справка, выберите пункт О программе и щелкните на стопке книг. Они начнут падать и подпрыгивать. Также щелкните на море - появится парусник и волны начнут шевелиться.

Nero Burning ROM

Выберите в меню Help пункт About Nero Burning ROM. Сделайте двойной щелчок по появившемуся окну - появится список разработчиков. Снова сделайте двойной щелчок - режим вывода списка разработчиков изменится. И еще раз щелкните (всего четыре режима). При просмотре имен можете нажать комбинацию клавиш Ctrl+Shif

Антивирус Касперского 5

Выбрать пункт О программе и нажать, удерживая, клавиши Ctrl+Alt+Shift. Вы увидите список разработчиков продукта


Вредоносные программы

Одной из причин Ваших проблем с ПК и ПО может быть действие вредоносных программ (далее просто вирусов). Надо защищать свой компьютер, если он подключен (или временно подключается) к Internet (если не подключен, то надо следить за тем, что Вы устанавливаете на свой компьютер)! Казалось бы, кому я это говорю?! - все и так это знают!

И все же остаются еще такие беспечные люди (и их немало!), которые не заботятся о своей безопастности: не используют антивирусных программ и файерволлов! Причем, причины этому самые разные: например, мало места на диске, загруженность процессора, незнание того, что такое файерволл, и просто наивность.

Настоятельно рекомендуем в ближайшее время (если Вы еще этого не сделали) установить хороший антивирус с последними базами данных и фаерволл (если Вы выходите в сеть)!

Какой антивирус выбрать? Решайте сами. В принципе, все равно, т.к. вирусы они знают одни и те же. Однако, следует обращать внимание на следующие вещи:

  • Главным критерием качественного антивирусного ПО является постоянное обновление базы. Ведь по большому счету антивирус лишь сравнивает проверяемый файл со своей базой, содержащей примеры кода уже известных компании вирусов. Если фрагмент кода совпадает, то программа выдает сообщение о том, что файл инфицирован. Что из этого следует? Да то, что даже небольшие изменения в коде вируса помешают антивирусной программе его найти, естественно, до тех пор, пока антивирусная база не пополнится. Именно поэтому каждый, хоть сколько-нибудь оригинальный вирус, сопровождает масса модификаций, например, помимо известного Nimda, существует множество его разновидностей: Nimda.b, Nimda.c и т. д. Многие вирмейкеры, не имея способности написать что-либо оригинальное самостоятельно, берут за основу уже «хорошо» себя зарекомендовавшие вирусы и немного трансформируют их. В основном модификация заключается в небольшом изменении функциональных возможностей программы и добавлении информации об авторе вируса (ник, принадлежность к той или иной хакерской группе, etc.). И вот, в связи с ограниченными возможностями эвристического анализатора (об этом я уже писал выше) для антивируса подобные видоизмененные вирусы уже «невидимы». И так будет продолжаться до очередного его обновления.
  • Антивирусная программа должна оберегать пользователя от всех видов вирусов (а не только от троянов, например).
  • Насколько антивирус "грузит" процессор. Антивирусные программы периодически сканируют систему на наличие вирусов, вследствие чего процессор грузится, что влияет на производительность. Конечно у широкораспространенных программ эта загрузка минимальна, но, все же, бывает ощутима.

Фаейрволл (firewall) - это программа, защищающая все Ваши порты. Каждый раз, когда Вы выходите в Internet, Ваши порты постоянно просканивают (вирусы либо ребятня, которая возомнила себя хакерами). Если они найдут незащищенный порт, Ваш ПК станет их (они смогут скопировать и удалить у Вас что угодно, или "залить" Вам троян и прикалываться над Вами). Так же, если у Вас на компьютере оказался троян или червь, то он всегда будет "пробиваться" в Internet, чтобы закачать Вам свою вторую часть или послать своему "хозяину" Ваши конфеденциальные данные (например, лог и пароль на доступ в Internet). Чтобы не допустить всего этого, следует пользоваться фаерволлом. Конечно, фаерволл (как и антивирусные программы) не понацея от всех проблем, но базовую защиту (например, от ребятни) он Вам обеспечит (при правильной настройке).

Запомните еще одну немаловажную вещь! Принцип "чем больше, тем лучше" здесь не работает, т.е. НЕ УСТАНАВЛИВАЙТЕ СРАЗУ НЕСКОЛЬКО АНТИВИРУСНЫХ ПРОГРАММ И ФАЕРВОЛЛОВ!!! В противном случае они начнут "битву" друг с другом и не смогут нормально работать! А если, например, Вы используете фаерволл от Panda Antivirus Platinum и AOF, то AOF вообще может "полететь" (у меня был случай, когда AOF грузил процессор на 100% с самого начала загрузки и непереставая). Так что если Вы будете ипользовать Panda и AOF, то отключите в Панде "Permanent firewall protection".

Если же у Вас на данный момент нет ни антивирусной программы, ни фаерволла, а в Интернет выйти необходимо, то читайте дальше.

При работе в Интернет без программ защиты следите за процессами, которые у Вас запускаются! Т.е. откройте "Диспетчер задач" (Ctrl+Alt+Del) и как только увидите неизвестный процесс - завершите его (причем, завершайте все дерево процессов, чтобы его не смог заново открыть какой-нибудь "подпроцесс").

Проверяйте в реестре ветви автозапуска (ключи и параматры run и load) в реестре (с помощью спецпрограмм, msconfig.exe или непосредственно через редактор реестра - regedit.exe).

Затем, зайдите в папку system32 (если Вы не пользуетесь файловыми менеджерами, то зайдите в "Свойства папки" и сделайте видимыми скрытые и системные папки и файлы, убрав с них защиту на время просмотра данной папки), сделайте Вид Таблицей и Упорядочте значки по дате изменения. В самом конце данного списка Вы найдете последние записанные туда файлы. Если там будут файлы *.exe, *.com, *.vbs или вообще без расширений датированные числом позжим, чем остальные (стандартные) файлы Windows, то засуньте их в rar-архив, заблокируйте его, поместите в другую папку, а из system32 эти файлы удалите.


Интернет: Общие советы

Общие советы

Если вам нужно написать письмо, но нет желания запускать почтовый клиент, то можно поступить следующим образом. Щелкните на Рабочем столе правой кнопкой и выберите команду Создать | Ярлык. В первом диалоговом окне пропишите команду mailto: и нажмите кнопку Далее. В следующем окне можете изменить название ярлыка. Например, напишите Заготовка для письма. Нажимайте на кнопку Готово, и у вас на Рабочем столе появится ярлык. Щелкните на нем, и вас запустится только шаблон письма, а не весь Outlook Express или другой почтовый клиент.

Вы можете открыть установленный по умолчанию почтовый клиент с уже заполненным адресом, просто запустив из командной строки (Пуск | Выполнить) следующую строку:
mailto:
Можно так же сразу же из коммандной строки заполнить большинство полей в email (все поля опционны, вы можете заполнять только те что нужны):
mailto:nevzorov@yahoo.com?subject=Regarding+your+advice&Body=It+is+working+great&CC=vnevzorov@trondent.com
Обратите внимание, что пробелы должны быть заменены на знак "+"
На web страницах в гиперлинках используется немного другой формат. Смотри справочник HTML в примерах (Тег A).

Если у тебя есть домашняя страничка, и ты не хочешь, чтобы поисковые роботы индексировали твою страничку с секретной информацией, то используй следующий тег: <META name="robots" content="none">
Теперь поисковики не будут замечать вашу страницу.

Если в Internet Explorer, в диалоге "Загрузка файла" при ответе на вопрос "Открыть файл"/"Сохранить на диске" вы случайно убрали галочку "Всегда задавать этот вопрос, открывая такие файлы", то можете вернуть прежнее поведение. Откройте Проводник - Сервис-Свойства папки-вкладка Типы файлов. Найдите тип файла ZIP и нажав кнопку "Дополнительно", поставьте флажок "Подтверждать открытие после загрузки.

В интернете есть очень удобная служба, которая позволяет заказывать html-страницы, включая графику, подписываться на рассылку страниц и осуществлять поиск в WWW. Доставку других файлов ни с http, ни с ftp-серверов она не обеспечивает. Для начала можно послать пустое письмо на адрес www@web2mail.com, и нам придёт файл помощи на английском языке в виде html-страницы. Далее на тот же адрес посылаем письмо с командой в поле Тема (Subject). Для заказа страницы без графики команда представляет собой лишь адрес страницы. Писать приставку http:// необязательно. Проще не придумаешь. Для заказа страницы со всей присущей ей графикой дописываем к адресу два слова - with images:
http://www.webhowto.ru/reg/reg_nd01.shtml with images
Очень удобно - все ссылки на получаемой странице переделываются таким образом, чтобы при нажатии на них почтовый клиент создавал новое письмо для службы web2mail уже с командой в поле Тема для заказа этой страницы. Остаётся только отправить созданное письмо! Абсолютно новый вид услуг - подписка на страницы. К примеру, мы хотим еженедельно получать какую-то страницу, чтобы отслеживать новую информацию на ней. Для этого перед адресом страницы пишем слово subscribe, а после - weekly: subscribe http://www.webhowto.ru/reg/reg_nd01.shtml weekly Для ежедневного получения вместо weekly надо указать daily, для ежемесячного - monthly. Причём сразу можно заказать сколько угодно страниц, перечислив их адреса через пробел. Ещё один плюс: служба не будет слать страницу, на которую подписались, если на ней не произошли изменения со времени предыдущей рассылки.
Ну и под конец - поиск. Всё так же просто, как и выше. Создаём письмо на уже известный адрес, в Теме пишем команду search и нужное словосочетание, например: search Billy Gates. Убедительная просьба: не забивайте службу сразу пятью заказами, дождитесь прихода предыдущих. Именно из-за жадности людей такие службы и сидят в дауне, не отвечая несколько дней, или вовсе закрываются. Поэтому, давайте хоть немного думать о других и о дне завтрашнем.

Ярлыки на интернет-сайты и письма (*.url) представляют собой текстовые файлы с расширением URL. Их можно создать в простом блокноте. Вот пример:

[InternetShortcut]
URL=http://www.winhowto.ru/
IconIndex=1

Или

[InternetShortcut]
URL=mailto:terminator2@mail.ru
IconIndex=1

Или

[InternetShortcut]
URL=file://C:\Windows\win.ini

Первый пример открывает браузер по умолчанию и начинает загрузку сайта, второй выводит окно нового письма, третий запускает ваши файлы.

Откройте папку Удаленный доступ к сети, вызовите свойства соеденения с провайдером, перейдите во вкладку Тип сервера и уберите флажок Войти в сеть. После этого соединитесь с провайдером и убедитесь, что все работает нормально. Большинство провайдеров не используют режим входа в сеть, а период ожидания может занять до 60 секунд, поэтому, скорее всего, процесс подключения к Интернету будет происходить быстрее.


Интернет: Поисковые системы

Поисковые системы

Google

С помощью поисковой системы Google можно найти медицинские файлы, персональные отчеты, пароли и т.д. Надо только уметь пользоваться этой системой поиска. Например, для поиска файла с определенным расширением используйте следующую строку (для excel и doc файлов)
Filetype:xls
или
filetype:doc

Inurl
Другой полезный параметр поиска - inurl: опция, которая позволяет искать некоторые слова в URL. Это дает Вам возможность искать определенные каталоги/папки, особенно в комбинации с “index of” опциями:
inurl:admin Данный запрос даст ссылки, которые имеют слово “admin” в URL.

Index of
Если Вы используете “index of” строку, Вы найдете списки каталогов определенных папок на серверах. Пример:
«index of» admin
или
«index.of.admin»

Site
Опция сайта позволяет Вам придумывать результаты, которые принадлежат некоторому домену или определенному сайту. Например, можно искать .com сайты или .box.sk сайты или .nl сайты. Пример строки для поиска:
site:gov
Site:neworder.box.sk “board”

Intitle
Intitle позволяет искать страницы, которые имеют некоторое слово или слова в заголовке
intitle:winchanger

Link
Опция Link позволяет проверять, какие сайты связаны с определенным сайтом.

Объединение Параметров поиска
Например, можно пробовать эту строку для поиска:
inurl:nasa.gov filetype:xls "restricted"
или
site:mil filetype:xls "password"
или
site:mil “index of” admin

Вы можете попробовать искать ту информацию, которая Вам кажется интересной. Например, следующие слова:
Password, passwords, pwd, account, accounts, userid, uid, login, logins, secret, secrets, all followed by either *.doc or *.xls or *.db
Это приводит к весьма интересным результатам, особенно с *.db опцией, Гугль также может найти некоторые passwords.doc файлы, которые содержат рабочие пароли.

Для поиска, например, песен MP3 можно использовать такую конструкцию
-inurl:htm -inurl:html intitle:"index of" mp3 "Имя артиста или название песни"
Для поиска электронных книг
-inurl:htm -inurl:html intitle:"index of" +("/ebooks"|"/book") +(chm|pdf|zip) +"ИМЯ ИЛИ НАЗВАНИЕ"
Более грамотно запрос можно оформить так
intitle:"index of" (название) mp3

Дополнительные возможности Google

У Google есть куча разнообразных скрытых поисковых модулей.

Google Local -находит местные предприятия и услуги в Интернете (задаёте что ищете и место где ищете)
Google Mac -поиск по Apple/Macintosh сайтам
Google's University Search -поиск по университетам
Google Linux -поиск по Linux сайтам
Google GOV -поиск по всем *.gov сайтам -государственные сайты, и по *.mil -военные сайты
Froogle -поиск товаров/продукции
Google Options -опции гугла
Google Map Site -карта сайта (гугл)
Google Features -перечень разнообразных фишек и особенностей гугла
Google Microsoft -поиск по Microsoft сайтам
Google Labs -сервисы гугла
Hacker Style Google -гугл в 31337 стиле, вроде как для хакеров =)
Google BSD --поиск по BSD сайтам
Google Наоборот -обычный google, но полностью в зеркальном отображении =)
Google Schoolar - поиск среди статей, книг и обзоров научной литературы и учебников
Google Firefox -для фанатов Mazilla Firefox
Google Fight -поединок на какое слово больше страниц, вы вводите два слова, и гугл показывает на какое сколько страниц относиться, и выявляет победителя =)
Google Suggest -довольно полезный сервис, в то время как вы пишете что нить в поиске, гугл вам предлагает возможные варианты того что вам нужно и показывает сколько будет страниц по данному запросу, опробуйте и вы всё поймёте
Cheatoogle -поиск по читам и кодам к играм
Google Easter -google'овский пасхальный кролик
Gmail -мыло от Google
Video google -поиск видео


Internet Explorer: Общие советы

Если вас не устраивает список поисковых систем в IE7, то можете добавить их самостоятельно. На сайте Microsoft (адрес http://www.microsoft.com/windows/ie/searchguide/ru-ru/default.mspx#) есть около десятка популярных сайтов, которые вы можете добавить простым щелчком мыши по нужной ссылке.

В IE7 по умолчанию не выводится строка меню. Если вы привыкли, чтобы строка меню была в браузере, то нажмите на клавишу Alt, и она появится. Также можно щелкнуть правой кнопкой мыши на панели инструментов и выбрать пункт Menu Bar. Если вы хотите, чтобы это меню было в IE7 постоянно, то воспользуйтесь реестром (параметр ITBar7Position).

Если вы хотите запретить изображение флэш-анимации в вашем браузере, то в командной строке введите строку

regsvr32 c:\windows\system32\Macromed\Flash\Flash.ocx /u
Теперь у вас съэкономится трафик и не будут отображаться флэш-анимация. Чтобы включить снова возможность просмотра анимации, введите эту же команду без параметра /u

Если вам нужно быстро заходить на определенные сайты с длинным именем, то можно поступить следующим образом. Добавляем сайт в "Избранное", причем задаем ему короткое название. Так, например, http://www.whatis.ru - wi. Теперь, чтобы попасть на этот сайт, достаточно в адресной строке Internet Explorer ввести wi и нажать Enter (сайт не должен находиться в подпапках Избранного).

Если возникают ошибки при работе с IE, то иногда помогает перегистрация файлов в системе. В Windows XP SP2 Microsoft предложила новое решение:
1. Откройте командную строку CMD.EXE
2. Введите следующую команду:

"%ProgramFiles%\Internet Explorer\iexplore.exe" /rereg

Все файлы будут заново зарегистрированы в системе

Для блокировки рекламы и нежелательных сайтов можно воспользоваться возможностями Internet Explorer. В меню Сервис|Свойства обозревателя|Вкладка Безопасность выбираем Ограниченные узлы. Нажимаем кнопку Узлы и вносим свой список баннерных служб. Кстати, найти уже готовый reg-файл (называется IE-SPYAD) для блокировки известных баннерных служб средствами самого Internet Explorer можно на сайте www.staff.uiuc.edu/~ehowes/resource.htm

Можно настроить советы, которые отображаются внизу окна Internet Explorer, когда вы выбираете в меню Справка-Полезный совет. Данные советы хранятся в файле tip.htm папки Windows\Web. Все советы находятся в отдельном слое с идентификатором от id="Tip 1" до id="Tip 74". Вы можете заменить эти советы на анекдоты, афоризмы, собственный советы или добавить новые (id="Tip 75" и т.д.). Кстати, желтая лампочка, отображаемая слева от советов, хранится в файле Tips.gif - вы ее тоже можете заменить.

Нестандартная иконка вашего сайта в Избранном.
Увидев подобную иконку у себя в "Избранном", пользователь запомнит ваш сайт. Как сделать подобную примочку у себя на сайте?
Прежде всего нужно эту иконку нарисовать. А размером она должна быть ровно 16х16 пикселей и иметь 16 цветов, так что не особо "развлекайтесь". Расширение она должна иметь .ico Вес иконки не должен превышать 1,046 кб. Но и это еще не все, название иконки должно быть favicon.ico. Заливаете себе иконку на сервак в корневую директорию и с этих пор, Internet Explorer сам найдет эту иконку в случае, если ваш сайт удостоится попасть в "Избранное". Хотелось бы заметить, что не все сервера изначально "понимают" эту иконку. Для того, чтобы не возникало проблем, убедитесь, что настройки сервера позволяют пользоваться favicon.ico
Если возникают проблемы, иконку можно подгрузить и принудительно. Для этого между тегами вставьте следующий код, который явным образом укажет браузеру на иконку. Но эта операция, как правило не требуется и является необязательной.
<LINK REL="SHORTCUT ICON" HREF="http:/ваш_сайт.ru/favicon.ico">
Все, отныне ваша иконка будет красоваться в папке "Избранное" напротив названия вашего сайта у пользователей, которые, соответственно, добавят сайт себе на заметку в "Избранное" и, возможно, забыли бы о нем. Ан нет. Теперь не забудут. Иконка эффектно отличается на фоне стандартных картинок Internet Explorer`а и это еще один повод напомнить пользователю о своем сайте...
Дополнение к совету: Кстати, вы сами можете назначать значки у себя в Избранном. При большом количестве закладок нестандартные значки позволят немного упорядочить ваш список сайтов. Откройте меню Избранное - выберите нужную вам закладку и правой кнопкой откройте Свойства. В появившемся окне нажимаете кнопку Сменить значок и выбираете любой по вкусу.

При загрузке страницы с ошибкой Internet Explorer в строке состояния в левом нижнем углу окна отображает значок ошибки и текст, предупреждающий об этом. Чтобы узнать какая именно ошибка произошла и где, надо дважды шелкнуть левой кнопкой мыши по этому значку ошибки. Появится сообщение о типе ошибки и строке, где она произошла. Если вы хотите, чтобы такое сообщение появлялось автоматически при каждой обнаруженной ошибке, надо в настройках браузера (Сервис->Свойства обозревателя->Дополнительно) отметить галочкой пункт: "Показывать уведомление о каждой ошибке сценария"

Можно сделать так, чтобы Windows блокировала баннеры. Для этого нужно в файл C:\WINDOWS\system32\drivers\etc\hosts (без расширения) внести список известных баннерных сетей примерно такого вида:
127.0.0.1 banner.kiev.ua
127.0.0.1 banner.list.ru
127.0.0.1 banner.ricor.ru
127.0.0.1 banner.trifle.net
- то есть каждой баннерной сети принудительно назначить адрес 127.0.0.1, принадлежащий вашему собственному компьютеру. При этом, встретив на веб-страничке ссылку, например, на banner.list.ru, ваш браузер попытается загрузить ее с вашего же компьютера, а поскольку веб-сервера на нем не наблюдается, то баннер попросту будет отсечен и интернет-запросов на него уходить не будет. Соответственно, не будет и качаться из Сети громоздкий графический файл. Правила и примеры составления файла hosts вы найдете в файле C:\Windows\hosts.sam, который находится на диске только в учебных целях и системой не обрабатывается. В интернете можно найти уже готовые файлы hosts с уже внесенными в него списком баннерных сетей.
Кроме того, файл hosts можно использовать и для ускорения интернета. Обычная схема обращения к определенному интернет-серверу по его имени следующая:
1. Определение IP-адреса через DNS
2. Установление TCP-соединения с данным IP-адресом и стандартным для данного сервиса (http, ftp, smtp...) номером порта
3. Собственно работа
Обращение к DNS может занимать разное время - это зависит от многих факторов. И все-таки, если Вы работаете большей частью с одними и теми же хостами (поисковые машины, интернет-библиотеки и т.п.), то время работы можно сократить за счет обращения к DNS. Для этого Вам нужно узнать IP-адреса Ваших любимых серверов и записать их в hosts-файл. Надо сказать, что такой подход является единственным при обращении к многим WWW-серверам: прямое обращение по IP-адресу может не получиться, и вот почему. Целый ряд WWW-серверов использует так называемые "виртуальные хосты", т.е. фактически по одному IP-адресу может находиться несколько (часто очень много) как-бы независимых веб-серверов. Эти виртуальные сервера, как правило, отличаются доменами третьего (более редко-второго) уровня. По полю Host заголовка HTTP-запроса веб-сервер определяет, к какому сайту идет обращение, и ведет себя соответственно. Если, скажем, сайты www.aaa.com, www.bbb.com и www.ccc.com имеют один IP-адрес 172.16.1.1, то при обращении по имени www.aaa.com сервер получит поле Host: myhost.aaa и поведет себя как сервер www.aaa.com. При обращении по IP-адресу сервер получит Host: 172.16.1.1 При этом он либо поведет себя как сервер "по умолчанию", либо выдаст сообщение об ошибке. Если же в файле hosts записано 172.16.1.1 www.aaa.com и пользователь обращается по имени, то сервер получит нормальное поле Host. Узнать IP-адреса можно разными путями. Можно использовать специальные программы (DNS Resolver), специально предназначенные для обращения к DNS. Можно использовать ответы программы ping, входящей в поставку Windows. Для этого нужно выполнить командную строчку:
ping <имя хоста>
В ответе программы будут строчки вида:
Reply from (ip-адрес этого хоста);
Можно также воспользоваться IE, дав URL с определяемым именем хоста. В строке состояния сначала появится Поиск узла..., затем - Соединение с узлом IP-адрес. Просто запишите его.

В последних версиях Internet Explorer появилась функция экспорта и импорта списка Избранное (Favorites). Для этого в меню "Файл" Internet Explorer достаточно выбрать команду "Импорт и экспорт" - запустится очень простой мастер, который и осуществит генерацию веб-страницы, содержащий ссылки из Избранного

Если очень хочется посмотреть исходный текст web-страницы просто добавьте "view-source:" перед URL. Например: view-source:http://webhowto.ru/reg/nd_add.php Откроется notepad (или чего у вас там есть) с исходным текстом этой web-страницы. Иногда даже очень помогает :-)

Определение даты последней модификации просматриваемой страницы. Если в поле адреса ввести текст: javascript:alert(document.lastModified) то появится окно в котором будет написано дата последней модификации страницы. Для удобства частого использования введенный адрес можно перетащить на панель ссылок.

Если при щелчке по ссылке в Internet Explorer'e удерживать нажатой клавишу Shift, то ссылка откроется в новом окне.

Отключение графики в браузере приводит к ускорению загрузки страниц, если у вас модем, и к существенному уменьшению траффика, если у вас локалка...

Щелчoк на кнопке максимизации (или двойной щелчoк на заголовке окна) при нажатом Ctrl раскрывает на полный экран Internet Explorer (так же как и клавиша F11).

Если у вас уже запущен один IE, второй может запускаться в маленьком размере (не на весь экран). Чтобы избавиться от этого эффекта, расширьте его окошко на весь экран, а затем закройте. При последующих запусках он будет открываться по-человечески. Это касается и Netscape.

Если во время работы в Internet Explorer'e зажать клавишу Ctrl и вращать скроллинговое колесико у мыши, то будет изменяться размер шрифта текста на страницах. Если удерживать Shift и вращать колесико, то можно перемещаться по списку просмотренных страниц в History браузера. Перемещаться по этому списку можно также удерживая Alt и нажимая клавиши стрелок "вправо", "влево". Стрелка влево - предыдущая страница, вправо - следующая.


Internet Explorer: Стартовая страница

Стартовая страница

Если вас замучали сайты, меняющие стартовую страницу в Internet Explorer, то создайте файл startpage.js в любом текстовом редакторе (напр. Блокнот), скопируйте туда этот код:

var WSHShell = WScript.CreateObject("WScript.Shell");
//Делаем задержку 10 секунд на случай если
//паразитный сайт добавил что-то в автозагрузку
WScript.Sleep(10000);
//Проверяем что у нас в стартовой странице
StartPage = WSHShell.RegRead("HKCU\\SOFTWARE\\Microsoft\\Internet Explorer\\Main\\Start Page");
//И если там не то, что мы задумали, то меняем на свое
if (StartPage!="http://www.webhowto.ru/reg") {
  WSHShell.RegWrite("HKCU\\SOFTWARE\\Microsoft\\Internet Explorer\\Main\\Start Page",
  "http://www.webhowto.ru/reg");
}
в строке if (StartPage!="http://www.webhowto.ru/reg") и в следующей поменяйте адрес сайта на нужный вам и добавьте этот файл в автозагрузку в раздел: HKCU\Software \Microsoft\ Windows\ Current Version\Run.

Предварительно убедитесь что в каталоге Windows у вас есть файл wscript.exe (если вы пользуетесь Win98/2000/XP, то он у вас скорее всего есть). Теперь при старте системы, если начальная страница IE отличается от заданной вами, она будет заменена на ту, что вы настроили. Ну, а если вам захочется узнать подробнее, как все это работает, почитайте статью о Windows Script Host (совет взят именно оттуда).

Зачастую некоторые веб-сайты имеют наглость менять вашу стартовую страницу, потом при следующем старте открывается "миллион" окон и иногда даже не удается добраться до установок браузера до того как вся винда рухнет. Может кому покажеться выгодным моя мелкая хитрость. Уменя создан текстовый файл прямо на десктопе с расширением ".reg" следующего содержания:

REGEDIT4

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
"Start Page"="http://www.webhowto.ru/"
После работы с интернетом, особенно если посещались сомнительные места, я просто запускаю этот файл...


Internet Explorer: Командная строка

Параметры командной строки

Для Internet Explorer существуют несколько ключей. Для их использования необходимо запустить файл iexplore.exe из командной строки с указанием нужного параметра (например, используя строку "Выполнить" меню "Пуск") либо прописать требуемый параметр в свойствах специально созданного ярлыка к браузеру (получится примерно следующее:
"C:\ Program Files\ Internet Explorer\iexplore.exe" -nohome).

Список ключей

  • -channelband - Internet Explorer будет запущен в качестве специальной панели каналов на Рабочем столе текущего пользователя. Данная опция работает только при выключенном активном Рабочем столе (Active Desktop)
  • -e - Internet Explorer будет запущен в двухпанельном режиме Проводника (дерево папок слева, содержание справа)
  • -new - новое окно программы Internet Explorer будет запущено как отдельный процесс;
  • -nohome - при запуске Internet Explorer не будет открывать никаких веб-страниц. При этом скорость загрузки программы гораздо быстрее, чем если даже стоит в стартовой странице about: blank
  • -k - запуск браузера в полноэкранном режиме (Kiosk mode);
  • -slf - при запуске открывается домашняя страница пользователя;
  • -embedding - Запускает Web browser control без показа странички
Можно в командной строке указать и URL-адрес страницы, которую требуется открыть: iexplore -k www.winhowto.ru


Internet Explorer: Комбинации клавиш

Горячие клавиши для просмотра и навигации

Часть горячих клавиш работает и в Проводнике, т.к. сама система очень тесно связана с iexplorer.exe
Нажать | Действие
F1 | Вывести окно помощи IE
F5 или Ctrl + F5 | Обновить страницу
F11 | Переключает в полноэкранный режим и обратно
ENTER | Переход по выбранной ссылке
SHIFT + F10 | Контекстное меню для ссылки или страницы
BACKSPACE | Переход на предыдущую страницу
ALT + Стрелка влево | Переход на предыдущую страницу (Аналогично BACKSPACE)
ALT + Стрелка вправо | Переход на следующую страницу
ALT + Home | Переход на домашнюю страницу
ALT + D | Установка фокуса на адресной строке
Стрелка вверх | Скроллинг вверх
Стрелка вниз | Скроллинг вниз
PAGE UP или SHIFT + Space (Пробел) | Скроллинг вверх на одну страницу
PAGE DOWN или Space (Пробел) | Скроллинг вниз на одну страницу
HOME | В начало документа
END | В конец документа
ESC | Прервать загрузку страницы
CTRL+E | Открыть окно Поиск
CTRL+F | Открыть диалоговое окно Найти на этой странице
CTRL+H | Открыть окно Журнал
CTRL+I | Открыть окно Избранное
CTRL+L или CTRL+O | Открыть диалоговое окно Открыть
CTRL+N | Открыть новое окно
CTRL+P | Печать текущего документа
CTRL+R | Обновить страницу (аналогично F5)
CTRL+S | Сохранить текущую страницу
CTRL+W | Закрыть окно

Горячие клавиши для Адресной строки
Нажать | Действие
F4 | Показать список записей Адресной строки
CTRL+Стрелка влево | В Адресной строке курсор перемещается к следующему логическому символу прерывания (. или /)
CTRL+Стрелка вправо | В Адресной строке курсор перемещается к следующему логическому символу прерывания (. или /)
CTRL+ENTER | Добавляет http://www. в начало и .com в конец текста, напечатанного в Адресной строке. Например, если вам надо набрать "http://www.google.com", введите "google" и нажмите Ctrl+Enter.
Горячие клавиши для работы с Избранным
Нажать | Действие
CTRL+D | Добавить текущую страницу в Избранное
CTRL+B | Открывает диалоговое окно Упорядочить Избранное

Если при щелчке по ссылке в Internet Explorer удерживать нажатой клавишу Shift, то ссылка откроется в новом окне.

Щелчoк на кнопке максимизации (или двойной щелчoк на заголовке окна) при нажатом Ctrl раскрывает на полный экран Internet Explorer (так же как и клавиша F11).

Если во время работы в Internet Explorer'e зажать клавишу Ctrl и вращать скроллинговое колесико у мыши, то будет изменяться размер шрифта текста на страницах. Если удерживать Shift и вращать колесико, то можно перемещаться по списку просмотренных страниц в History браузера. Перемещаться по этому списку можно также удерживая Alt и нажимая клавиши стрелок "вправо", "влево". Стрелка влево - предыдущая страница, вправо - следующая.

Новые горячие клавиши в Internet Explorer 7

Нажать | Действие
CTRL+Click | Открыть ссылку в новой вкладке без переключения на нее
CTRL+Shift+Click | Открыть ссылку в новой вкладке и сделать ее активной
Ctrl+T | Открыть новую вкладку и сделать ее активной
Ctrl+Tab/Ctrl+Shift+Tab | Переключение между вкладками
Ctrl+W | Закрыть текущую вкладку (или окно, если нет вкладок)
Alt+Enter | Открыть новую вкладку и сделать ее активной. Адресная строка становится плавающей
Ctrl+n (n - номер вкладки от 1 до 8) | Переключиться на нужную вкладку
Ctrl+9 | Переключиться на последнюю вкладку
Ctrl+Alt+F4 | Закрыть все остальные вкладки кроме текущей
Ctrl+Q | Открыть страницу просмотра вкладок
Ctrl+(+) | Увеличить зум на 10%
Ctrl+(-) | Уменьшить зум на 10%
Ctrl+0 | Оригинальный размер страницы (100%)
Ctrl+Е | Переход на строку поиска
Alt+Enter | Открыть поисковый запрос в новой вкладке
Ctrl+Стрелка вниз | Раскрыть список поисковых систем
Ctrl+I | Открыть вкладку Избранное (Favorites Center)
Ctrl+H | Открыть вкладку Журнал (History)
Ctrl+Q | Открыть вкладку Feeds

Управление мышкой

Нажать | Действие
Щелчок средней кнопкой на ссылке | Открыть ссылку в новой вкладке без активации
Щелчок средней кнопкой на вкладке | Закрыть вкладку
Щелчок левой кнопкой на пустой вкладке | Открыть новую вкладку
Ctrl+Колесо прокрутки мыши | Увеличить или уменьшить зум на 10%


Internet Explorer: Разное

Визуальный редактор

Оказывается Internet Explorer очень просто можно превратить в простейший визуальный (!!!) редактор HTML. Это очень удобно, когда в страничке нужно изменить одну-две буквы, а полноценного (и потому монстрообразного !) редактора HTML под рукой не оказалось. Итак: В реестре HKEY_CURRENT_USER\ SOFTWARE\ Microsoft \Internet Explorer \MenuExt создать раздел с имененм "&Режим редактирования" и присвоить параметру по умолчанию строку C:\Windows\EDIT_IE.HTM (или любой другой путь и файл). В этом же разделе создайте новый DWORD-параметр под названием Contexts и измените его значение на 1. В указанной выше папке создать файл EDIT_IE.HTM со следующим содержимым:
<script language="JavaScript"defer>
var parentwin=external.menuArguments;
var doc=parentwin.document;
doc.designMode="On";
</script>
После загрузки HTML в IE по правой кнопке мыши выбрать Режим редактирования. Чтобы выйти из него, выбрать Вид обзора. Чтобы создать документ с нуля - загрузить about:blank и войти в режим редактирования. Конечно, отсутствует панель инструментов, но начертание помеченного фрагмента текста можно изменить с помощью стандартных комбинаций клавиш CTRL-B, CTRL-I. Может работают и другие комбинации - не проверял. Доступны удаление и вставка рисунков.
© 2002 И. Чеботарев, А.Климов
http://www.webhowto.ru/reg
http://winchanger.narod.ru


Outlook Express: Общие

При плохой связи в работе с Outlook Express появляются сообщения: "Ваш сервер не ответил в течение 60 секунд. Подождать ответа еще 60 секунд?" Можно увеличить время ожидания.
В меню "Сервис" выберите "Учетные записи..." и на вкладке "Почта" выберите нужную запись и жмите кнопку "Свойства". Выберите вкладку "Дополнительно" и там, используя ползунок "Время ожидания сервера", установите нужный интервал.

Сохранение сообщений в Outlook Express.
Для сохранения ваших сообщений нужно сделать следующее: Зайти в папку "Windows\Application Data\Identities\набор цифр\Microsoft\Outlook Express\" и скопировать все файлы куда нибудь для дальнейшего их восстановления.

Если вы часто переустанавливаете систему (Win 9x), то вам приходится каждый раз вводить учетные записи в Outlook Express. Воспользуйтесь встроенной стандартной функцией? В меню Сервис - Учетные записи - вкладка Почта, отмечаем учетную запись и жмем кнопку Экспорт для сохранения в файле, для ввода учетной записи на место после переустановки системы - Импорт.

Сохранение правил для сообщений в Outlook Express. Правила сортировки входящих почтовых сообщений Outlook Express хранит в реестре, в ветви HKEY_CURRENT_USER\Identities\набор цифр\Software\Microsoft\Outlook Express\5.0\Rules\Mail. Экспортировав ее в текстовый файл с расширением reg и сохранив его, можно будет после переинсталляции Windows и Outlook Express запустить его, восстановив сразу все правила.

Если запускать Оутлук с параметром /news, то он будет работать только с группами новостей (очень удобно для пользователей TheBat).


The Bat!

The Bat!: Общие

Если The Bat! запустить с параметром /CHECKALL, то The Bat! проверит почту всех незапароленных ящиков, после чего закроется

Открыв русифицированный TheBat.LNG hex-редактором, можно вместо стандартных надписей написать что-нибудь своё! А если вы забыли пароль который ставили на аккаунт в The Bat!, то просто откройте ACCOUNT.CFG находящийся в соответствующей дириктории hex-редактором и увидите свой пароль! :)

Если при старте The Bat! в командной строке (или в свойствах ярлыка) добавить /NOLOGO, то при запуске не будет появляться логотип программы. Это позволит чуть-чуть уменьшить время загрузки

The Bat! при удалении писем не уничтожает их физически, а просто помечает как удаленные и не выводит их в общем списке писем (посмотреть удаленные письма можно, выбрав пункт меню Папка | Посмотреть удаленные письма). Со временем, при интенсивной переписке, такие письма начинают занимать очень много места (файл, где они хранятся, находится в каталоге Бата\Mail\[имя ящика]\[имя папки]\messages.tbb). Для уничтожения этого мусора рекомендуется иногда сжимать папки (Папка | Сжать все папки). При этом письма, помеченные как удаленные, будут стерты окончательно.

Достаточно просто перетащить нужные файлы в окно The Bat! и они будут автоматически присоеденены к отправляемому вами письму.

Смотри также

Восстановление параметров почтовых аккаунтов The Bat! в справочнике по реестру.


MSN Messenger

Если вы пользуетесь MSN Messenger 5 или 6 версии, то можете отключить баннерную рекламу. Вся информация о баннерах хранится в файле links.txt папки C:\Documents and Setting\username\Local Settings\Temp. Удалите содержимое файла и присвойте ему атрибут "Только для чтения"


Интернет-пейджеры: Общие советы

Аська

Чтобы удалить баннер из ICQ 5 версии, нужно в файле hosts (папка c:\windows\system32\drivers\etc) прописать
127.0.0.1 ar.atwola.com

Даже не имея ICQ, вы мoжeте пocлaть сообщение на ICQ-пейджep своему другу: зайдите нa aдpec http://wwp.mirabilis.com/****** (вмecтo звёздoчeк надо указать нужный ICQ-нoмep (UIN)) или отправьте e-mail нa aдpec *****@pager.mirabilis.com

Если вы хотите, чтобы на странице около вашего номера Аськи был показатель присутствия в сети, то используйте код:
<img alt="ICQ status" src="http://online.icq.com/scripts/online.dll?icq=UIN&img=N"/>
Вместо UIN нужно подставить ваш номер. N - вариант индикатора. Их что-то около 17-ти (1-17)

Возможно, многие это знают, но чтобы в Аське отправить набранное сообщение достаточно нажать Ctrl+Enter. Намного ускоряет работу :).


Параметры командной строки, которые поддерживаются обновлениями, разработанными с помощью технологии Iexpress

Код статьи | : | 197147
Последний просмотр | : | 21 марта 2005 г.
Редакция | : | 7.7

Аннотация

Корпорация Майкрософт выпускает обновления программного обеспечения в виде самораспаковывающихся архивов, при запуске которых автоматически запускается программа установки, находящаяся внутри архива. В данной статье рассматриваются параметры командной строки, которые поддерживаются обновлениями, использующими технологию IExpress. Корпорация Майкрософт применяет технологию IExpress для создания обновлений, предназначенных для некоторых версий Microsoft Internet Explorer, Windows и ряда других продуктов. Чтобы определить, использует ли какое-либо обновление технологию IExpress, выполните следующие действия.
1. | Щелкните файл обновления правой кнопкой мыши и выберите команду Свойства.
2. | На вкладке Общие найдите поле Описание. Если в данном поле присутствует строка Win32 Cabinet Self-Extractor, значит, данное обновление использует технологию IExpress.
Примечание. Если в поле «Описание» присутствует строка Self-Extracting Cabinet, значит, это обновление предназначено для операционных систем Windows NT 4.0, Windows 2000, Windows XP или Windows Server 2003, а в качестве программы установки данного обновления используется средство Hotfix.exe или Update.exe. Дополнительные сведения о параметрах командной строки, поддерживаемых средствами Hotfix.exe и Update.exe, см. в следующей статье базы знаний Майкрософт:
262841 Параметры командной строки, которые поддерживаются пакетами обновления для Windows
Файлы обновлений с расширениями MSI и MSP используют в качестве программы установки установщик Windows. Дополнительные сведения о параметрах командной строки, поддерживаемых установщиком Windows, см. на веб-узле Майкрософт по адресу:
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/msi/setup/command_line_options.asp
Дополнительные сведения о стандартной терминологии, которую корпорация Майкрософт использует для описания обновлений программного обеспечения, см. в следующей статье базы знаний Майкрософт:
824684 Стандартные термины, используемые при описании обновлений программных продуктов Майкрософт

Дополнительная информация

Если файл обновления, использующий технологию IExpress, запускается без параметров, то автоматически запускается программа установки, по умолчанию используемая для установки данного обновления. Для обновлений, созданных с использованием технологии IExpress, в качестве программы установки используется установочный файл (INF) или исполняемая программа.

Если в качестве программы установки используется установочный файл (INF), то для управления процессом установки следует применять параметры командной строки, поддерживаемые IExpress. Если для установки обновления IExpress используется исполняемая программа (например файл с расширением EXE или COM), то для управления процессом установки следует применять параметры командной строки, поддерживаемые этой программой.

Примечание. Для выбора программы установки, которая будет использоваться для установки пакета, а также для передачи параметров программе установки воспользуйтесь параметром /c:путь. Например, следующая команда запускает установку обозревателя Internet Explorer (файл Ie6setup.exe, использующий технологию IExpress) и передает параметры программе установки (Ie6wzd.exe), которая входит в состав данного пакета.

Ie6setup параметры_IExpress /c:" ie6wzd параметры_программы_установки_Internet_Explorer"

Ниже перечислены параметры командной строки, поддерживаемые обновлениями, которые разработаны с помощью технологии IExpress.
Значение | Описание
/q | Установка в автоматическом режиме или подавление сообщений.
/q:u | Скрытый режим (появляются только некоторые сообщения для пользователя).
/q:a | Административный скрытый режим (диалоговые окна не отображаются).
/t:путь | Задает папку для извлечения файлов.
/c | Извлечение файлов без установки. Если параметр /t: путь не задан, появится приглашение указать папку назначения.
/c:путь | Задает путь в формате UNC к установочному файлу INF или EXE.
/r:n | Не перезагружать компьютер после установки.
/r:i | В случае необходимости появляется запрос на перезагрузку (за исключением случая, когда указан параметр /q:a).
/r:a | Всегда перезагружать компьютер после установки.
/r:s | Перезагрузить компьютер без вывода соответствующего запроса.
/n:v | Не проверять версию (устанавливать поверх существующей версии).
Примечание. Использование параметра /n:v не поддерживается и может приводить к сбоям в работе. Если установка завершается неудачно, необходимо обратиться в службу поддержки и определить причину сбоев.

Ссылки

Дополнительные сведения см. на веб-узле корпорации Майкрософт по следующим адресам.

Explorer Administration Kit (IEAK) Home Page
http://www.microsoft.com/windows/ieak/default.asp

IExpress Batch-mode Setup Switches
http://www.microsoft.com/windows/ieak/techinfo/deploy/60/en/iexpswit.htm

Internet Explorer Batch-mode Setup Switches
http://www.microsoft.com/windows/ieak/techinfo/deploy/60/en/ieswitch.htm


Компонент панели управления «Установка и удаление программ» неправильно отображает установленные программы

Проблема

После установки или удаления программ компонент панели управления «Установка и удаление программ» неправильно отображает установленные программы. В списке Установленные программы содержится только одна текстовая строка, или перед названием программы отображается длинный пробел. Или же, список установленных программ может быть и вовсе пустым. Помимо этого, указанные выше проблемы с отображением программ могут сопровождаться следующими сообщениями об ошибках:
Произошла непредвиденная ошибка. Не зарегистрирован класс.
res://appwiz.cpl/listbox.htc
Строка:225
или
Объект не поддерживает это свойство или метод res://appwiz.cpl/default.hta
Строка: 75

Причина

Подобные проблемы возникают в том случае, когда программа удаления неверно удаляет из реестра записи, используемые Windows и компонентом панели управления «Установка и удаление программ».

Решение

Для решения проблемы выполните следующие действия.
1. | Нажмите кнопку Пуск, выберите пункт Выполнить и введите команду CMD.
2. | В командной строке введите REGSVR32 APPWIZ.CPL.
3. Если эта команда не выполняется, найдите записи реестра, перечисленные ниже, вручную. Попробуйте найти в реестре указанные параметры и разделы. Создайте повторно отсутствующие параметры или разделы. Помните о том, что эти параметры привязаны к букве системного диска. Возможно, придется изменить эти записи с тем, чтобы они соответствовали конфигурации вашего компьютера.
• [HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}]
"ADODB.Recordset"
• [HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}\InprocServer32]
"C:\Program Files\Common Files\System\ado\msado15.dll"
• [HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}\InprocServer32]
"ThreadingModel"="Apartment"
• [HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}\ProgID] "ADODB.Recordset.2.5"
• [HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}\VersionIndependentProgID]
"ADODB.Recordset"
• HKEY_CLASSES_ROOT\CLSID\{2048EEE6-7FA2-11D0-9E6A-00A0C9138C29}
"Microsoft OLE DB Row Position Library"
• HKEY_CLASSES_ROOT\CLSID\{2048EEE6-7FA2-11D0-9E6A-00A0C9138C29}\InprocServer32
"C:\Program Files\Common Files\System\Ole DB\oledb32.dll" "ThreadingModel"="Both"
• HKEY_CLASSES_ROOT\CLSID\{2048EEE6-7FA2-11D0-9E6A-00A0C9138C29}\ProgID
"RowPosition.RowPosition.1"
• HKEY_CLASSES_ROOT\CLSID\{2048EEE6-7FA2-11D0-9E6A-00A0C9138C29}\VersionIndependentProgID
"RowPosition.RowPosition"
• [HKEY_CLASSES_ROOT\CLSID\{352EC2B7-8B9A-11D1-B8AE-006008059382}\InProcServer32]
"%SystemRoot%\System32\appwiz.cpl"
4. Выполните действия, описанные в одной из приведенных ниже процедур, если они применимы к вашему компьютеру, после чего проверьте, устранена ли проблема. Если проблемы исчезли, пропустите дальнейшие действия. Если решить проблему не удается, перейдите к шагу 5.
• Чтобы устранить эту проблему с установленным Internet Explorer 6.0, произведите его отладку:
a. | Нажмите кнопку Пуск и выберите команду Выполнить.
b. | В поле Открыть вставьте указанную ниже команду и нажмите кнопку OK: rundll32 setupwbv.dll,IE6Maintenance "C:\Program Files\Internet Explorer\Setup\SETUP.EXE" /g "C:\WINDOWS\IE Uninstall Log.Txt Поскольку при вводе команды необходимо соблюдать регистр букв, проще скопировать ее из этой статьи в поле Открыть.
• Для устранения этой проблемы с установленным обозревателем Internet Explorer 5.0 и 5.5 произведите отладку обозревателя Internet Explorer 5.0 или 5.5:
a. | Нажмите кнопку Пуск и выберите команду Выполнить.
b. | В поле Открыть вставьте указанную ниже команду и нажмите кнопку OK: rundll32 setupwbv.dll,IE5Maintenance "C:\Program Files\Internet Explorer\Setup\SETUP.EXE" /g "C:\WINDOWS\IE Uninstall Log.Txt Поскольку при вводе команды необходимо соблюдать регистр букв, проще скопировать ее из этой статьи в поле Открыть.
5. Произведите обновление на месте:
a. | Запустите файл Winnt32.exe из каталога \I386 на установочном компакт-диске Windows 2000.
b. | В появившемся окне установки Windows 2000 выберите вариант Обновить до Windows 2000.
c. | Подождите, пока установка завершится.
Если компонент панели управления «Установка и удаление программ» по-прежнему не функционирует должным образом, не отображает содержимое или если вы хотите попробовать устранить эту проблему, не обновляя обозреватель Internet Explorer более новой версией, проверьте, содержатся ли записи в следующих параметрах реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\App Management\ARPCache
Примечание: Если в предыдущих параметрах реестра не содержатся записи, компонент панели управления «Установка и удаление программ» может также не отображать содержимое.

Через командную строку внесите в реестр каждый из приведенных ниже файлов, используя команду REGSVR32 [путь\имя файла]:
%systemroot%\System32\Appwiz.cpl
%systemroot%\System32\Mshtml.dll
%systemroot%\System32\Jscript.dll
%systemroot%\System32\Msi.dll
Program Files\Common Files\System\Ole DB\Oledb32.dll
Program Files\Common Files\System\Ado\Msado15.dll
%systemroot%\System32\Msdart32.dll [not registerable]
%systemroot%\System32\Mshtmled.dll
%systemroot%\System32\Mswstr10.dll [not registerable]
Если в списке «Установка и удаление программ» отображаются не все программы или не отображаются вовсе, проверьте даты файлов и, если существует такая возможность, внесите в реестр следующие файлы:
%systemroot%\System32\Gdi32.dll [not registerable]
%systemroot%\System32\User32.dll [not registerable]
%systemroot%\System32\Msvcrt.dll [not registerable]
%systemroot%\System32\Ole32.dll
%systemroot%\System32\Shlwapi.dll [not registerable]
%systemroot%\System32\Imm32.dll [not registerable]
%systemroot%\System32\Indicdll.dll [not registerable]
%systemroot%\System32\Urlmon.dll
%systemroot%\System32\Version.dll [not registerable]
%systemroot%\System32\Lz32.dll [not registerable]
%systemroot%\System32\Comctl32.dll [not registerable]
%systemroot%\System32\Clbcatq.dll
%systemroot%\System32\Oleaut32.dll
%systemroot%\System32\Mlang.dll
%systemroot%\System32\Shell32.dll
%systemroot%\System32\Shdoclc.dll [not registerable]
%systemroot%\System32\NetapI32.dll [not registerable]
%systemroot%\System32\Secur32.dll [not registerable]
%systemroot%\System32\Netrap.dll [not registerable]
%systemroot%\System32\Samlib.dll [not registerable]
%systemroot%\System32\Ws2_32.dll [not registerable]
%systemroot%\System32\Ws2help.dll [not registerable]
%systemroot%\System32\Wldap32.dll [not registerable]
%systemroot%\System32\Dnsapi.dll [not registerable]
%systemroot%\System32\Wsock32.dll [not registerable]
%systemroot%\System32\Plugin.ocx
%systemroot%\System32\Wininet.dll [not registerable]
%systemroot%\System32\Crypt32.dll [not registerable]
%systemroot%\System32\Msasn1.dll [not registerable]
%systemroot%\System32\Msls31.dll [not registerable]
%systemroot%\System32\Imgutil.dll
%systemroot%\System32\Cscui.dll
%systemroot%\System32\Cscdll.dll [not registerable]
Если в окне «Установка и удаление программ» отображается диалоговый интерфейс пользователя, но отсутствует список установленных программ, проверьте наличие в реестре следующих параметров:
HKEY_CLASSES_ROOT\CLSID\{352EC2B7-8B9A-11D1-B8AE-006008059382}\InProcServer32
Если данный параметр отсутствует, скопируйте следующий текст в текстовый файл, сохраните файл с расширением .reg, а затем щелкните дважды этот файл, чтобы восстановить соответствующие записи.

Для Редактора реестра Windows Registry, версии 5.00:
[HKEY_CLASSES_ROOT\CLSID\{352EC2B7-8B9A-11D1-B8AE-006008059382}\InProcServer32]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,61,00,70,00,70,00,77,00,69,00,7a,00,2e,00,63,00,70,00,6c,00,00,00
"ThreadingModel"="Apartment"

Статус

Данное поведение является подтвержденной ошибкой продуктов Майкрософт, перечисленных в начале данной статьи. Ниже приведен список всех параметров реестра, используемых объектом панели управления «Установка и удаление программ». Необходимо установить данные параметры, зарегистрировав Appwiz.cpl, но в данном случае они приведены в качестве перекрестной ссылки для подтверждения того, что регистрация прошла успешно.
• [HKEY_CLASSES_ROOT\CLSID\{352EC2B7-8B9A-11D1-B8AE-006008059382}]
@="%DESC_ShellAppMgr%"
• [HKEY_CLASSES_ROOT\CLSID\{352EC2B7-8B9A-11D1-B8AE-006008059382}\InProcServer32]
@="SystemRoot%\System32\appwiz.cpl" (REG_EXPAND_SZ)
"ThreadingModel"="Apartment"
• [HKEY_CLASSES_ROOT\CLSID\{0B124F8C-91F0-11D1-B8B5-006008059382}]
@="Installed Apps Enumerator"
• [HKEY_CLASSES_ROOT\CLSID\{0B124F8F-91F0-11D1-B8B5-006008059382}\InProcServer32]
@="SystemRoot%\System32\appwiz.cpl" (REG_EXPAND_SZ)
"ThreadingModel"="Apartment"
• [HKEY_CLASSES_ROOT\CLSID\{CFCCC7A0-A282-11D1-9082-006008059382}]
@="Darwin App Publisher"
• [HKEY_CLASSES_ROOT\CLSID\{CFCCC7A0-A282-11D1-9082-006008059382}\InProcServer32]
@="SystemRoot%\System32\appwiz.cpl" (REG_EXPAND_SZ)
"ThreadingModel"="Apartment"
• [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Approved]
"{352EC2B7-8B9A-11D1-B8AE-006008059382}"="Shell Application Manager"
• [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Approved]
"{0B124F8F-91F0-11D1-B8B5-006008059382}"="Installed Apps Enumerator"
• [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Current Version\App Management\Publishers\Darwin App Publisher]
@="{CFCCC7A0-A282-11D1-9082-006008059382}"
• [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Approved]
"{CFCCC7A0-A282-11D1-9082-006008059382}"="Darwin App Publisher"
• [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\InProcCPLs]
"appwiz.cpl"=""

Записи реестра, которые используются во время выполнения ARP.

• HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\AppInstallPath
Служит для чтения INF-файла. Программный код считывает имя INF-файла. Используемый INF-раздел "AppInstallList"
• HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Installer\Terminal Server\EnableAdminRemote
Установите значение 1 во время выполнения ARP. Сообщает TS о том, что ARP выполняется.
Установите значение 0 после завершения работы ARP.
• HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\App Management\Publishers Служит для перечисления участников публикации приложений.
• HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Wx86\cmdline
Определяет, включен ли wx86
• HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\NewShortcutHandlers
Перечислен для составления списка обработчиков «новых ссылок». Выглядит так, будто эти обработчики могут добавить связь определенному компоненту, например меню «Пуск», рабочему столу и т. д.
• HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Shutdown\ForceReboot
Прочитайте публикацию и выясните, требуется ли перезагрузка после запуска программы установки.
Наличие значения указывает на необходимость перезагрузки «must-reboot» == true.
• HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\MS-DOSOptions
Информация в данной статье относится к следующим продуктам.
• | операционная система Microsoft Windows 2000 Server
• | Microsoft Windows 2000 Advanced Server
• | Операционная система Microsoft Windows 2000 Professional


Установка и использование консоли восстановления в Windows XP

Аннотация

Если компьютер загружается неправильно или не загружается вообще, то для восстановления операционной системы можно пользоваться консолью восстановления Windows.

Введение

Корпорация Майкрософт рекомендует пользоваться консолью восстановления только в том случае, если не удается загрузить компьютер в безопасном режиме и другими доступными способами. Консоль восстановления рассчитана только на опытных пользователей, имеющих представление об основных командах, которые предназначены для идентификации проблемных драйверов и файлов. Кроме того, для работы с консолью восстановления необходимо наличие прав администратора.

Установка консоли восстановления

Если установлена консоль восстановления, то в случае проблем с запуском Windows компьютер можно загрузить с помощью этой консоли, выбрав соответствующий пункт в меню вариантов загрузки. Устанавливать консоль восстановления следует на важных серверах и рабочих станциях специалистов в области информационных технологий. Чтобы установить консоль восстановления, необходимо войти в систему с правами администратора. Хотя консоль восстановления можно запускать непосредственно с компакт-диска Windows XP, удобнее настроить ее для использования в качестве одного из пунктов меню загрузки. Сведения о запуске консоли восстановления с компакт-диска см. ниже. Для установки консоли восстановления выполните следующие действия.

  1. Вставьте компакт-диск Windows ХР.
  2. Нажмите кнопку Пуск и выберите команду Выполнить.
  3. В окне Открыть введите команду
    d:\i386\winnt32.exe /cmdcons
    , где d – буква дисковода компакт-дисков.
  4. Появится диалоговое окно программы установки Windows с кратким описанием консоли восстановления. Чтобы подтвердить установку, нажмите кнопку Да.
  5. Перезагрузите компьютер. При последующем запуске компьютера в меню загрузки будет присутствовать пункт «Консоль восстановления Microsoft Windows».

Кроме того, установить консоль восстановления можно из общей сетевой папки, указав путь в формате UNC (Universal Naming Convention).

Примечание. Может появится следующее сообщение об ошибке:

Установку невозможно продолжить, поскольку на компьютере установлена более поздняя версия Windows, чем на компакт-диске.При возникновении этой проблемы см. статью базы знаний Майкрософт:

898594 (http://support.microsoft.com/kb/898594/) При попытке установить консоль восстановления на компьютере под управлением Microsoft Windows XP с пакетом обновления 2 (SP2) появляется сообщение об ошибке (Эта ссылка может указывать на содержимое полностью или частично на английском языке)

Использование консоли восстановления

Консоль восстановления позволяет включать и отключать службы, форматировать диски, читать и записывать данные на локальный диск (в том числе диски с файловой системой NTFS), а также выполнять многие другие задачи администрирования. Она особенно полезна в тех случаях, когда необходимо восстановить работоспособность системы путем копирования определенного файла на жесткий диск с дискеты или компакт-диска или изменить параметры службы, препятствующей правильному запуску компьютера.

Если не удается загрузить компьютер, можно запустить консоль восстановления, используя набор установочных дискет или компакт-диск Windows XP.

После того как Windows XP установлена, для запуска компьютера и использования консоли восстановления требуется набор установочных дискет или компакт-диск Windows XP.

Примечание. Чтобы запустить компьютер с компакт-диска Windows XP, необходимо в BIOS установить вариант загрузки с дисковода компакт-дисков.

Чтобы запустить консоль восстановления с помощью набора загрузочных дискет или компакт-диска Windows XP, выполните следующие действия.

  1. Вставьте компакт-диск Windows XP или загрузочную дискету Windows XP и перезагрузите компьютер.

    При появлении соответствующего запроса подтвердите загрузку с компакт-диска.
  2. При появлении надписи «Вас приветствует мастер установки» нажмите клавишу R, чтобы запустить консоль восстановления.
  3. Если на компьютере имеется несколько операционных систем, выберите экземпляр Windows, к которому требуется получить доступ с консоли восстановления.
  4. После появления соответствующего запроса введите пароль администратора. Если пароль для учетной записи администратора не назначен, просто нажмите клавишу ВВОД.
  5. В командной строке введите необходимые команды для диагностики и устранения проблем экземпляра Windows XP.

    Для вывода списка команд консоли восстановления наберите в командной строке recovery console commands или help и нажмите клавишу ВВОД.

    Для получения сведений о конкретной команде введите в командной строке help имя команды и нажмите клавишу ВВОД.
  6. Чтобы завершить работу консоли восстановления и перезагрузить компьютер, введите в командной строке exit и нажмите клавишу ВВОД.

Использование командной строки консоли восстановления

Командная строка консоли восстановления отличается от используемой в Windows. В консоли восстановления имеется собственный интерпретатор команд. Чтобы войти в него, необходимо указать пароль администратора.

Когда идет запуск консоли восстановления, можно нажать клавишу F6 и установить драйвер SCSI или RAID стороннего производителя (если такой драйвер необходим для доступа к жесткому диску). Установка драйвера происходит так же, как и в процессе установки операционной системы.

Запуск консоли восстановления длится несколько секунд. Затем появляется список операционных систем Windows, установленных на данном компьютере (обычно список содержит только запись C:\Windows). Перед нажатием клавиши ВВОД следует нажать клавишу с номером нужной записи (даже если имеется только одна запись). Если нажать клавишу ВВОД, не указав номера, компьютер будет перезагружен, и процесс начнется заново.

Когда на экране появится приглашение %SystemRoot% (как правило, C:\Windows), можно запускать команды консоли восстановления.

Команды

Ниже приведен список команд, доступных с консоли восстановления.
• | Attrib Изменить атрибуты файла или подкаталога.
• | Batch Выполнить команды, содержащиеся в текстовом файле (Inputfile). Параметр Outputfile задает файл для вывода результатов выполнения команд. Если параметр Outputfile пропущен, вывод осуществляется на экран монитора.
• | Bootcfg Изменить файл Boot.ini с целью настройки процесса загрузки и восстановления.
• | CD (Chdir) Действует только в пределах системных каталогов текущего экземпляра Windows, съемных носителей, корневого каталога любого раздела жесткого диска или локальных установочных папок.
• | Chkdsk Использование параметра /p приводит к запуску программы Chkdsk, даже если на диске нет отметки о повреждении. Параметр /r служит для поиска поврежденных секторов и восстановления той части данных, которая может быть прочитана (предполагается использование параметра /p). Программа Chkdsk требует наличия средства Autochk. Она автоматически ищет файл Autochk.exe в папке автозапуска. Если данного файла в папке автозапуска нет, Chkdsk пытается обратиться к компакт-диску Windows XP. Если установочного компакт-диска в дисководе нет, пользователю будет предложено самостоятельно указать место расположения файла Autochk.exe.
• | Cls Очистить экран.
• | Copy Копировать файл в указанную папку. По умолчанию копирование не производится на съемные носители и нельзя использовать подстановочные знаки. При копировании с компакт-диска Windows XP сжатый файл автоматически распаковывается.
• | Del (Delete) Удалить файл. Действует в пределах системных каталогов текущего экземпляра Windows, съемных носителей, корневого каталога любого раздела жесткого диска и локальных установочных папок. По умолчанию постановочные знаки использовать нельзя.
• | Dir Отобразить список всех файлов, включая скрытые и системные.
• | Disable Отключить системную службу или драйвер Windows. Переменная service_or_driver – это имя отключаемой службы или драйвера. Если вы отключаете службу, то перед изменением типа запуска на SERVICE_DISABLED отображается исходный тип запуска службы. (запишите его, чтобы в дальнейшем можно было перезапустить службу с помощью команды enable).
• | Diskpart Управление разделами в томах жесткого диска. Параметр /add используется для создания нового раздела, а /delete — для удаления существующего. Переменная device – это название устройства для нового раздела (например, \device\harddisk0). Переменная drive – это буква, назначенная удаляемому разделу (например, D). Переменная partition – это соответствующее правилам именования разделов название удаляемого раздела (например, \device\harddisk0\partition1); она может использоваться вместо переменной drive. Переменная size служит для указания размера нового раздела (в мегабайтах).
• | Enable Включить системную службу или драйвер Windows. Переменная service_or_driver – это имя включаемой службы или драйвера, а start_type – тип запуска включаемой службы. Тип запуска может иметь одно из следующих значений. SERVICE_BOOT_START SERVICE_SYSTEM_START SERVICE_AUTO_START SERVICE_DEMAND_START
• | Exit Закрыть консоль восстановления и перезагрузить компьютер.
• | Expand Распаковать сжатый файл. Переменная source – это имя сжатого файла. По умолчанию постановочные знаки использовать нельзя. Переменная destination – это каталог для распакованного файла. По умолчанию этот каталог не может находиться на съемном носителе или иметь атрибут «Только чтение». Для снятия с папки назначения атрибута «Только чтение» служит команда attrib. Параметр /f:filespec используется в том случае, если источник содержит более одного файла Этот параметр допускает использование подстановочных знаков. Параметр /y служит для отмены вывода запроса на подтверждение удаления файлов. Параметр /d указывает, что файлы не должны распаковываться; отображается содержимое исходной папки.
• | Fixboot Записать новый загрузочный сектор в системный раздел.
• | Fixmbr Восстановить основную загрузочную запись в загрузочном разделе. Необязательная переменная device служит для указания имени устройства, на котором нужно создать новую основную загрузочную запись. Эта переменная не используется, если целевым является загрузочное устройство.
• | Format Отформатировать диск. Параметр /q служит для выполнения быстрого форматирования, а параметр /fs — для указания файловой системы.
• | Help Запуск команды help без указания имени определенной команды в качестве аргумента приводит к отображению всех команд, которые доступны с консоли восстановления.
• | Listsvc Отобразить все доступные на данном компьютере службы и драйверы.
• | Logon Отобразить список обнаруженных экземпляров Windows с запросом пароля локального администратора для этих экземпляров. Эта команда служит для перехода в другой экземпляр Windows или другой подкаталог.
• | Map Отобразить текущие сопоставления устройств. Чтобы использовать пути в формате Advanced RISC Computing (ARC, формат для записей в файле Boot.ini) вместо путей к устройствам в формате Windows, укажите параметр arc.
• | MD (Mkdir) Действует только в пределах системных каталогов текущего экземпляра Windows, съемных носителей, корневого каталога любого раздела жесткого диска и локальных установочных папок.
• | More/Type Отобразить содержимое указанного текстового файла.
• | Rd (Rmdir) Действует только в пределах системных каталогов текущего экземпляра Windows, съемных носителей, корневого каталога любого раздела жесткого диска и локальных установочных папок.
• | Ren (Rename) Действует только в пределах системных каталогов текущего экземпляра Windows, съемных носителей, корневого каталога любого раздела жесткого диска и локальных установочных папок. В качестве целевого нельзя указывать новый диск или путь.
• | Set Служит для отображения и установки переменных среды консоли восстановления.
• | Systemroot Изменить текущий каталог на %SystemRoot%.

Правила консоли восстановления

При работе в консоли восстановления действует несколько правил среды. Для отображения текущей среды введите команду set. По умолчанию действуют следующие правила.
• | AllowAllPaths = FALSE Запретить доступ к каталогам, не относящимся к операционной системе, которая была выбрана при входе в консоль восстановления.
• | AllowRemovableMedia = FALSE Запретить копирование файлов на съемные носители.
• | AllowWildCards = FALSE Запретить использование подстановочных символов (в т. ч. для команд copy и del).
• | NoCopyPrompt = FALSE Отображать запрос на подтверждение перезаписи существующего файла.

Удаление консоли восстановления

Чтобы удалить консоль восстановления, выполните следующие действия.
1. | Перезагрузите компьютер, выберите в меню Пуск пункт Мой компьютер, а затем два раза щелкните значок жесткого диска, на котором установлена консоль восстановления.
2. | В меню Сервис выберите команду Свойства папки и перейдите на вкладку Вид.
3. | Выберите вариант Показывать скрытые файлы и папки, снимите флажок Скрывать защищенные системные файлы и нажмите кнопку ОК.
4. | В корневой папке диска удалите папку Cmdcons и файл Cmldr.
5. | В корневой папке диска щелкните правой кнопкой мыши файл Boot.ini и выберите пункт Свойства.
6. | Снимите флажок атрибута Только чтение и нажмите кнопку OК. Предупреждение! Неправильное изменение файла Boot.ini может привести к проблемам с загрузкой компьютера. Удалите только запись, относящуюся к консоли восстановления. После этого снова установите для файла Boot.ini атрибут «Только чтение». Откройте файл Boot.ini с помощью программы «Блокнот» и удалите запись, относящуюся к консоли восстановления. Эта запись выглядит примерно так: C:\cmdcons\bootsect.dat="Microsoft Windows Recovery Console" /cmdcons
7. | Сохраните и закройте файл.

Установка консоли восстановления в автоматическом режиме

Для установки консоли восстановления в процессе автоматической установки операционной системы Windows необходимо использовать раздел [GuiRunOnce] файла unattend.txt.

Command1="path\winnt32 /cmdcons /unattend"
Дополнительные сведения об использовании файла Unattend.txt см. в руководстве Deployment Planning Guide (Планирование процесса развертывания операционной системы), которое входит в пакет Windows 2000 Server Resource Kit.

Ссылки

Изменить правила для расширения возможностей консоли восстановления можно с помощью групповой политики.

Дополнительные сведения см. в следующей статье базы знаний Майкрософт:
310497 (http://support.microsoft.com/kb/310497/) Как расширить возможности "Консоли восстановления" при помощи групповой политики в Microsoft Windows XP Professional


Как отключить простой общий доступ к файлам и назначить разрешения для доступа к общей папке в Windows XP

Введение

Данная статья содержит сведения о том, как отключить простой общий доступ к файлам.

Примечание. В Windows XP Home Edition возможность отключения простого общего доступа к файлам не предусмотрена.

Дополнительная информация

На компьютерах под управлением Windows XP, которые не являются членами домена, простой общий доступ к файлам включается по умолчанию. Это позволяет открывать доступ к папкам для всех членов рабочей группы или пользователей сети, а также определять личные папки в своем профиле пользователя. Однако в случае использования простого общего доступа невозможно запретить доступ к своим общим папкам для отдельных пользователей и групп. Если отключить простой общий доступ к файлам, появляется возможность разрешать доступ к общим папкам только отдельным пользователям и группам. Такой пользователь должен войти в систему с помощью учетных данных профиля, которому предоставлено соответствующее право.

Когда включен простой общий доступ к файлам, вместо вкладок Безопасность и Общий доступ отображается простой пользовательский интерфейс. Этот интерфейс используется по умолчанию в Windows XP Home Edition, а также Windows XP Professional, если компьютер под управлением этой операционной системы входит в состав рабочей группы. Если отключить простой общий доступ к файлам, появятся стандартные вкладки Безопасность и Общий доступ, с помощью которых можно регулировать доступ к общим папкам на данном компьютере.

Примечание. Настройка безопасности возможна только для разделов, отформатированных с помощью файловой системы NTFS. В случае удаления группы «Все» из разрешений NTFS использовать папку или файл по сети нельзя.

Как отключить простой общий доступ к файлам

Чтобы отключить простой общий доступ к файлам, необходимо выполнить следующие действия.
1. | Нажмите кнопку Пуск и выберите пункт Мой компьютер.
2. | В меню Сервис выберите команду Свойства папки и перейдите на вкладку Вид.
3. | В списке Дополнительные параметры снимите флажок Использовать простой общий доступ к файлам (рекомендуется).
4. | Нажмите кнопку ОК.

Как открыть общий доступ к папке или диску

Чтобы открыть общий доступ к папке или диску, необходимо выполнить следующие действия.
1. | Нажмите кнопку Пуск, выберите пункт Мой компьютер и найдите папку или диск, к которым необходимо открыть общий доступ.
2. | Щелкните диск или папку правой кнопкой мыши и выберите команду Общий доступ и безопасность.
3. | На вкладке Доступ установите флажок Открыть общий доступ к этой папке.
4. | Для изменения имени общей папки или диска введите новое имя в поле Общий ресурс (при получении доступа другие пользователи будут видеть именно это имя). Фактическое имя папки или диска не меняется.
5. | Введите описание общей папки или диска в поле Комментарий.
6. | Чтобы ограничить число пользователей, одновременно подключенных к общей папке или диску, в группе Предельное число пользователей выберите не более и введите нужное значение.
7. Чтобы установить разрешения для общей папки или диска, нажмите кнопку Разрешения.

Примечание. Для выполнения этого действия необходимо войти в систему с помощью учетной записи члена одной из следующих групп:
• | Администраторы
• | Операторы сервера
• | Опытные пользователи
8. | Нажмите кнопку ОК.

Устранение неполадок

• Не отображается вкладка Общий доступ.

Запустите с помощью оснастки «Службы» службу сервера. Для этого выполните следующие действия.
1. | Нажмите кнопку Пуск и выберите пункт Панель управления.
2. | Щелкните ссылку Производительность и обслуживание, затем — Администрирование, разверните компонент Службы и приложения и два раза щелкните значок Службы.
3. | Правой кнопкой мыши щелкните службу Сервер и выберите команду Пуск.
• К папке уже открыт общий доступ.

Нажмите кнопку Новый общий ресурс и введите новое имя.
• Необходимо скрыть общую папку.

Чтобы скрыть общую папку, последним символом ее имени необходимо указать $. Другие пользователи не будут видеть папку в окне «Мой компьютер», а также с помощью проводника Windows, однако смогут к ней подключаться.
• Время от времени другие пользователи не будут видеть общую папку.

К компьютеру под управлением Windows XP Professional одновременно может подключиться не более 10 пользователей, вне зависимости от значения, введенного в поле не более.
Оснастка «Общие папки» позволяет создавать и управлять общими папками, просматривать список пользователей, подключенных к общей папке по сети, отключать пользователей, просматривать список файлов, открытых удаленными пользователями, и закрывать отдельные или все файлы. Чтобы запустить оснастку «Общие папки», выполните следующие действия.
1. | Нажмите кнопку Пуск и щелкните правой кнопкой мыши пункт Мой компьютер.
2. | Выберите пункт Управление, а затем — Общие папки.
Информация в данной статье применима к:
• | Microsoft Windows XP Professional Edition
• | Microsoft Windows XP 64-Bit Edition


Как стать владельцем файла или папки в Windows XP

Введение

Данная статья содержит сведения о том, как стать владельцем файла или папки, в том случае, если необходимые права доступа отсутствуют.

Чтобы получить доступ к файлу или папке, не имея на это соответствующих разрешений, необходимо стать владельцем такого файла или папки. Это позволяет компенсировать отсутствие разрешений на доступ.

Как стать владельцем папки

Примечание. Необходимо войти в систему с помощью учетной записи, обладающей полномочиями администратора. Чтобы получить доступ к вкладке Безопасность в Windows XP Home Edition, загрузите компьютер в безопасном режиме и войдите в систему с помощью учетной записи администратора.

На компьютере под управлением Windows XP Professional необходимо отключить простой общий доступ к файлам. По умолчанию простой общий доступ к файлам используется на всех компьютерах под управлением Windows XP Professional, которые не являются членами домена.

Чтобы стать владельцем папки, выполните следующие действия.
1. | Щелкните правой кнопкой значок папки, владельца которой необходимо сменить, и выберите команду Свойства.
2. | Откройте вкладку Безопасность и нажмите кнопку OК , если появится сообщение безопасности.
3. | Нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
4. | В столбце Имя выделите свое имя пользователя, запись Администратор (если вход в систему был выполнен с помощью учетной записи «Администратор») или группу Администраторы. Чтобы стать владельцем содержимого папки, установите флажок Заменить владельца субконтейнеров и объектов.
5. | Нажмите кнопку OК, а после появления указанного ниже сообщения — кнопку Да. Вы не имеете разрешения на чтение содержимого папки имя_папки. Хотите заменить разрешения для этой папки так, чтобы иметь права полного доступа? Все разрешения будут заменены, если нажать кнопку «Да». Примечание. имя_папки — имя папки, владельца которой необходимо сменить.
6. | Нажмите кнопку ОК и настройте параметры безопасности для папки и ее содержимого.

Как стать владельцем файла

Примечание. Необходимо войти в систему с помощью учетной записи, обладающей полномочиями администратора.

Чтобы стать владельцем файла, выполните следующие действия.
1. | Щелкните правой кнопкой значок файла, владельца которого необходимо сменить, и выберите команду Свойства.
2. | Откройте вкладку Безопасность и нажмите кнопку OК , если появится сообщение безопасности.
3. | Нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
4. | В столбце Имя выделите запись Администратор или группу Администраторы, и нажмите кнопку OК. Теперь право собственности на файл принадлежит учетной записи администратора или членам группы «Администраторы». Чтобы изменить разрешения на доступ к файлам и папкам, которые расположены в текущей папке, перейдите к выполнению следующего действия.
5. | Нажмите кнопку Добавить.
6. | В списке Введите имена выбираемых объектов (примеры) введите пользователя или группу, которые должны обладать правом доступа к этому файлу (например, Администратор).
7. | Нажмите кнопку ОК.
8. | В списке Группы или пользователи выделите нужную учетную запись и установите флажки соответствующих разрешений.
9. | По окончании нажмите кнопку OК.


Как расширить возможности "Консоли восстановления" при помощи групповой политики в Microsoft Windows XP Professional

Код статьи: 310497

Информация в данной статье применима к:
• Microsoft Windows XP Professional Edition

Аннотация

В данной статье дается пошаговое описание использования групповой политики для расширения возможности "Консоли восстановления". Windows XP при помощи групповой политики позволяет Вам расширить возможности команд, доступных в "Консоли восстановления". В обычных условиях "Консоль восстановления" имеет ограничения при работе с окружением, в котором работает.

Использование групповой политики для расширения возможностей "Консоли восстановления"

Если Вы установили "Консоль восстановления" на компьютер, то для расширения ее возможностей при работе с файлами и окружением Вам следует использовать групповую политику. Для этого выполните следующие действия:
1. | Нажмите кнопку "Пуск", выберите пункт "Выполнить", в поле "Открыть" введите команду "mmc" и нажмите кнопку "ОК".
2. | В меню "Консоль" выберите пункт "Добавить или удалить оснастку" и нажмите кнопку "Добавить".
3. | Из списка выберите элемент "Групповая политика" и нажмите кнопку "Добавить".
4. | Оставьте без изменений параметр "Локальный компьютер" и нажмите кнопку "Готово", затем нажмите кнопку "Закрыть" для возврата в диалоговое окно "Добавить/удалить оснастку".
5. | Нажмите кнопку "ОК" для возврата в окно "Консоль".
6. | В дереве консоли раскройте ветвь "Локальный компьютер" до элемента "Конфигурация компьютера\Конфигурация Windows\Параметры безопасности\Локальные политики\Параметры безопасности".
7. | Выделите элемент "Параметры безопасности" в левой панели, чтобы отобразить политики безопасности в правой панели.
8. | В правой панели выберите политику "Консоль восстановления: разрешить копирование дискет и доступ ко всем дискам и папкам ".
9. | Выберите параметр "Включен" и нажмите кнопку "ОК".
10. | Закройте MMC. Вы можете сохранить консоль на случай, если понадобится внести исправления.
После включения данной групповой политики Вы сможете изменять настройки окружения, войдя в "Консоль восстановления" и используя команду "SET" (без кавычек). Синтаксис команды должен быть следующим: SET <переменная> = TRUE или FALSE (где <переменная> - это имя переменной окружения).

Примечание: Убедитесь, что значения введены по обе стороны знака "равно". Если это не так, то команда SET не будет работать и сгенерирует сообщение об ошибке "Ошибка синтаксиса".

Следующие переменные определяют окружение, используемое по умолчанию. Установка переменных в значение TRUE расширяет границы параметров окружения и включает следующее:
• | AllowWildCards = TRUE Разрешить использование символов шаблона для некоторых команд (например, команды DEL)
• | AllowAllPaths = TRUE Разрешить доступ ко всем файлам и папкам на компьютере
• | AllowRemovableMedia = TRUE Разрешить копирование файлов на сменные носители, такие как гибкие диски.
• | NoCopyPrompt = TRUE Не запрашивать подтверждения при перезаписи файла
Чтобы просмотреть текущие установки окружения, введите в командной строке команду SET без параметров.

За дополнительной информацией по "Консоли восстановления" в Windows XP обратитесь к следующей статье Microsoft Knowledge Base:
314058 (http://support.microsoft.com/kb/314058/) Description of the Windows XP Recovery Console
216417 (http://support.microsoft.com/kb/216417/) How to Install the Windows Recovery Console


После удаления программы Easy CD Creator в Windows XP пропадает доступ к проигрывателю компакт-дисков, а в сообщениях упоминаются ошибки с кодами 19, 31, 32 или 39

Информация в данной статье относится к следующим продуктам.

Windows XP Home Edition, Windows XP Professional Edition

Код статьи: 314060

Версия данной статьи для Microsoft Windows 2000: 270008 (http://support.microsoft.com/kb/270008/RU/).

Проблема

После удаления программного обеспечения для записи компакт-дисков (или другого программного обеспечения) возникают следующие проблемы.
Нет доступа к проигрывателю компакт-дисков через значок «Мой компьютер».
В диспетчере устройств каждое установленное на компьютере устройство для чтения компакт-дисков сопровождается следующим сообщением:
Это устройство работает неправильно, поскольку не удалось загрузить для него драйверы (код 31).
Диспетчер устройств выводит на экран следующее сообщение об ошибке:
Для этого устройства не требовался драйвер и он был отключен (код 32 или 31).
Также возможно появление сообщения об ошибке с кодом 39. Это означает, что драйвер поврежден.

Диспетчер устройств выводит на экран следующее сообщение об ошибке с кодом 19 (реестр вернул неизвестное значение):
Возможно, реестр поврежден. (Код 19).
Также может быть получено следующее сообщение об ошибке:
Драйвер для этого устройства успешно загружен, но само устройство не обнаружено. (Код 41)

Решение

Для решения проблемы выполните следующие действия.
1. | Запустите редактор реестра (программа Regedit32.exe).
2. | В разделе реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318} выделите параметр UpperFilters.
3. | В меню Правка выберите команду Удалить и нажмите кнопку OK.
4. | В том же разделе реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318} выделите параметр LowerFilters.
5. | В меню Правка выберите команду Удалить и нажмите кнопку OK.
6. | Закройте редактор реестра. Примечание. Если после удаления параметров Upperfilters и Lowerfilters некоторые программы (например, программное обеспечение для записи компакт-дисков) перестают выполнять часть своих функций, то необходимо их переустановить. Если проблема повторяется, обратитесь к производителю программного обеспечения.
7. | Перезагрузите компьютер.

Статус

Эта проблема может возникнуть после удаления Easy CD Creator версии 5.01 или ниже, а также DirectCD версии 3.01c или ниже. Также эта проблема может возникнуть с Easy CD Creator версии 5.01 или DirectCD версии 3.01d или выше.

Дополнительная информация

Возможно, существует другое программное обеспечение независимых производителей для записи компакт-дисков , ведущее себя подобным образом. Действия по устранению проблемы, описанные в этой статье, могут применяться и с этими продуктами, если они добавляют записи в параметры реестра UpperFilters и LowerFilters путем добавления собственных драйверов фильтра или удаления разделов реестра и параметров, описанных в данной статье, которые начинаются строкой:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

Внимание! Создайте архивную копию реестра перед внесением в него изменений. Продукты независимых производителей, упомянутые в данной статье, производятся компаниями, не зависимыми от корпорации Microsoft. Корпорация Microsoft не дает гарантий, явных или неявных, относительно работоспособности и надежности этих продуктов.


После установки пакета обновления 2 (SP2) для Windows XP создается впечатление, что некоторые программы не работают

Аннотация

После установки пакета обновления 2 (SP2) для Windows XP создается впечатление, что перестают работать некоторые программы. По умолчанию брандмауэр Windows блокирует непредусмотренные входящие подключения. В данной статье рассмотрены вопросы занесения программ в список исключений на брандмауэре. Это позволяет программам функционировать в режиме, который существовал до установки пакета обновления.

Введение

С целью обеспечения защиты компьютера под управлением Windows XP с пакетом обновления 2 (SP2) брандмауэр Windows блокирует непредусмотренные входящие подключения. Однако в некоторых случаях возникает необходимость в порядке исключения разрешить отдельным пользователям устанавливать подключение к компьютеру, например:
• | для участия в многопользовательской игре через Интернет;
• | чтобы получить файл, отправленный с помощью программы для обмена немедленными сообщениями.
После установки пакета обновления 2 (SP2) для Windows XP некоторым клиентским приложениям не удается получить данные с сервера, например:
• | клиенты FTP;
• | приложения для потоковой передачи мультимедийных данных;
• | отдельные почтовые программы (получение уведомлений о наличии новых сообщений).
Кроме того, отдельные серверные приложения на компьютере под управлением Windows XP с пакетом обновления 2 (SP2) не отвечают на запросы клиентов, например:
• | веб-серверы, в т. ч. серверы IIS (Internet Information Services);
• | Удаленный рабочий стол
• | общий доступ к файлам.

Предупреждения безопасности брандмауэра Windows

В некоторых случаях, когда брандмауэр Windows блокирует программу, появляется диалоговое окно Предупреждение системы безопасности, которое содержит следующее сообщение:
Для защиты компьютера брандмауэр Windows заблокировал эту программу от получения нежелательной информации из Интернета или по сети.
В сообщении указано название программы и ее издатель. В диалоговом окне можно выбрать одно из следующих действий.
• | Разблокировать программу
• | Продолжить блокирование программы
• | Продолжить блокирование программы, но предложить разблокирование позже
Сведения о том, как разблокировать выполнение программы с помощью диалогового окна, см. в следующем разделе.

Как разрешить выполнение программ

Некоторым программам и играм в процессе работы требуется получать данные по сети. Такие данные поступают на входящий порт. Чтобы брандмауэр Windows не блокировал поступающие данные, на компьютере должны быть открыты соответствующие порты. Ниже представлены способы, с помощью которых можно восстановить режим работы программы, существовавший до установки пакета обновления 2 (SP2) для Windows XP, а также разрешить выполнение нужных программ.

Разблокирование программы из диалогового окна предупреждения безопасности

1. | В диалоговом окне Предупреждение системы безопасности выберите вариант Разблокировать программу.
2. | Нажмите кнопку ОК.

Разрешение выполнения программы с помощью брандмауэра Windows

Если в диалоговом окне Предупреждение системы безопасности не выбрана команда Разблокировать программу, брандмауэр продолжает блокировать программу. Чтобы разблокировать программу с помощью брандмауэра Windows, выполните следующие действия.
1. | Выберите в меню Пуск пункт Выполнить, введите в поле Открыть команду wscui.cpl и нажмите кнопку ОК.
2. | Нажмите кнопку Брандмауэр Windows.
3. | В диалоговом окне Брандмауэр Windows откройте вкладку Исключения и нажмите кнопку Добавить программу.
4. | В диалоговом окне Добавление программы выберите программу в предложенном списке или нажмите кнопку Обзор и найдите ее самостоятельно. Если найти программу не удается, см. следующий раздел.
5. | Выбрав программу, нажмите кнопку ОК.
6. | Убедитесь, что на вкладке Исключения флажок напротив названия нужной программы установлен, и нажмите кнопку ОК. Примечание. Если в будущем возникнет необходимость удалить программу из списка исключений, снимите этот флажок.
Добавление программы в список исключений имеет следующие преимущества:
• | при этом не нужно знать номер сопоставленного программе порта (в отличие от способа, связанного с открытием порта, который описан далее в этой статье);
• | порт, который используется программой из списка исключений, открывается только в том случае, когда программа ожидает получения данных извне.

Определение и открытие портов

Если программа не работает даже после внесения в список исключений или не удается найти программу при выполнении действия 4 предыдущего способа, попробуйте открыть порт вручную. Однако предварительно следует определить порты, которые используются программой. Для этого в первую очередь обратитесь к разработчику программы, а если получить список портов у разработчика по каким-либо причинам не удается, воспользуйтесь средством Netstat.exe.

Определение портов с помощью средства Netstat.exe

1. | Запустите программу и попробуйте воспользоваться одной из ее сетевых функций. Например, запустите поток звука в программе мультимедиа или службу веб-сервера.
2. | Выберите в меню Пуск пункт Выполнить, введите в поле Открыть команду cmd и нажмите кнопку ОК.
3. | Чтобы получить список ожидающих портов, введите следующую команду и нажмите клавишу ВВОД: netstat –ano > netstat.txt
4. | Чтобы получить список идентификаторов запущенных процессов, введите следующую команду и нажмите клавишу ВВОД: tasklist > tasklist.txt Примечание. Если программа выполняется в виде службы, добавьте в команду параметр /svc, чтобы составить перечень служб, которые загружаются каждым процессом: tasklist /svc > tasklist.txt
5. | Откройте файл Tasklist.txt, найдите программу и выпишите идентификатор ее процесса.
6. | Откройте файл Netstat.txt и найдите все записи, которые сопоставлены данному идентификатору процесса, а также используемый протокол (TCP или UDP).
Решение проблемы отличается в зависимости от номеров используемых процессом портов:
• | если процесс использует порты с номерами меньше 1024, их номера, скорее всего, меняться не будут;
• | если процессу сопоставлены порты с номерами больше 1024, то программа, скорее всего, использует диапазон портов и, следовательно, открытие только некоторых из них не обязательно приведет к решению проблемы.

Открытие портов вручную с помощью брандмауэра Windows

Если определить используемые программой порты не удается, откройте их вручную. Чтобы определить подлежащий открытию порт, обратитесь к разработчику программы или предоставленной им документации. После этого выполните следующие действия.
1. | Выберите в меню Пуск пункт Выполнить, введите в поле Открыть команду wscui.cpl и нажмите кнопку ОК.
2. | Нажмите кнопку Брандмауэр Windows.
3. | На вкладке Исключения нажмите кнопку Добавить порт.
4. | В диалоговом окне Добавление порта введите в поле Номер порта номер открываемого порта и выберите вариант TCP или UDP.
5. | Введите название порта и нажмите кнопку ОК (например, Игровой порт).
6. | Чтобы просмотреть или изменить область исключения для порта, нажмите кнопку Изменить область, а затем — OК.
7. | Убедитесь, что на вкладке Исключения указана новая служба. Чтобы открыть порт, установите флажок рядом с новой службой и нажмите кнопку OК
Дополнительные сведения о настройке брандмауэра Windows см. в следующей статье базы знаний Майкрософт:
875357 Устранение неполадок, связанных с параметрами брандмауэра Windows в Windows XP с пакетом обновления 2 (SP2)

Программы, которым необходимо открыть порты вручную

Ниже перечислены программы и игры, для обеспечения правильной работы которых необходимо открыть определенные порты.

Программы

Программа | Производитель | Порты | Исключения по умолчанию | Примечания
Visual Studio .NET | Microsoft | См. документацию | См. документацию | Требуется только для отладки DCOM в удаленном режиме
SQL | Microsoft | Динамически назначаемые порты для удаленного вызова процедур и модели DCOM |  | Требуется только для отладки в удаленном режиме
Backup Exec 9 | Veritas | 10000 | C : \Program Files \Veritas \Backup Exec \RANT32 \beremote.exe | Требуется только для создания резервной копии клиента с сервера
Ghost Server Corporate Edition 7.5 | Symantec | TCP-порт 139 для службы сеансов NetBIOS; TCP-порт 445 для SMB по TCP; UDP-порт 137 для службы имен NetBIOS; UDP-порт 138 для службы датаграмм NetBIOS | См. документацию | Используется клиентом Ghost
Symantec AntiVirus Corporate Edition 8.0 | Symantec | Совместный доступ к файлам и принтерам | В результате установки флажка «Совместный доступ к файлам и принтерам» будут открыты следующие порты: UDP 137, 138; TCP 139, 445 | Требуется для установки клиента
SMS 2003 Server | Microsoft | Порты для совместного доступа к файлам и принтерам | См. документацию | Требуется для получения доступа к программе «Просмотр событий» на клиентском компьютере под управлением Windows XP с пакетом обновления 2 (SP2)
Cute FTP 5.0 XP | GlobalSCAPE | 21 или FTP-сервер | См. документацию | Требуется для подключения по протоколу FTP к компьютеру под управлением Windows XP с пакетом обновления 2 (SP2)
Exceed 7.0, 8.0 | Hummingbird | 21 или FTP-сервер | См. документацию | Требуется для подключения проводника Windows к удаленным компьютерам по протоколу FTP
KEA! 340 5.1 | Attachmate | 23 или сервер Telnet | См. документацию | Требуется для установки сеанса Telnet с удаленным узлом
Reflection 10 and 11 | WRQ | 23 | См. документацию | Требуется для установки сеанса Telnet с удаленным узлом
Reflection 10 and 11 | WRQ | 6000 (TCP/IP) и 177 (UDP) | См. документацию | Требуется для установки сеансов X-Windows
Reflection 10 and 11 | WRQ | 20 или 21 | См. документацию | Требуется для подключения клиента FTP к удаленным компьютерам
Smarterm Office 10 и Smarterm 11 | Esker Software | 23 или сервер Telnet | См. документацию | Требуется для установки сеанса Telnet с удаленным узлом
Smarterm Office 10 и Smarterm 11 | Esker Software | 21 или FTP-сервер | См. документацию | Требуется для подключения средства FTP к удаленным компьютерам
ViewNow 1.05 | Netmanage | 21 или FTP-сервер | См. документацию | Требуется для подключения средства FTP к удаленным компьютерам
ViewNow 1.0 и 1.05 | Netmanage | 6000 (TCP/IP) и 177 (UDP) | См. документацию | Требуется для установки сеансов X-Windows
ViewNow 1 или 1.05 | Netmanage | Сервер Telnet или 23 | См. документацию | Требуется для установки сеанса Telnet с удаленным узлом
Microsoft Operations Manager 2000 с пакетом обновления 1 (SP1) | Microsoft | Запрос эха ICMP, совместный доступ к файлам и принтерам, UDP | См. документацию | Требуется для передачи агента MOM на компьютер под управлением Windows XP с пакетом обновления 2 (SP2) с включенным брандмауэром Windows
AutoCAD 2004, 2005 | Autodesk | 21 | См. документацию | Требуется для просмотра проектов с помощью FTP (диалоговое окно «Открыть»), когда на удаленном узле FTP включен брандмауэр Windows
Backup Exec 9.1.4691 | Veritas | См. документацию | %Program Files% \Veritas \Backup Exec \RANT \beremote.exe | Требуется для создания резервной копии клиента под управлением Windows XP с пакетом обновления 2 (SP2)
Мастер работы со сканером или камерой Windows | Xerox Network Scanners | 21 | См. документацию | Требуется для запуска мастера и получения доступа к отсканированным изображениям
ColdFusion MX Server Edition 6 | Macromedia | TCP (по умолчанию — 8500) | См. документацию | Требуется для предоставления удаленного доступа к веб-серверу
CA ARCserve | Computer Associates | UDP-порт 137 для службы имен NetBIOS; UDP-порт 138 для службы датаграмм NetBIOS; TCP-порт 139 для службы сеансов NetBIOS; UDP-порт 704; UDP-порт 1478 для MS-sna-base; UDP-порт 1900 для SSDP; TCP-порт 6050 для службы ARCserve; TCP-порт 6051 для службы ARCserve | См. документацию | Требуется для удаленной установки, лицензирования и обмена данными с клиентами
EDM File System Agent 4.0 | EMC | 3895 | См. документацию | Требуется для установки клиента EDM с сервера на компьютер под управлением Windows XP с пакетом обновления 2 (SP2)
Microsoft Systems Management Server 2003 | Microsoft | TCP-порт 2701 | %WINDIR% \System32 \CCM \CLICOMP \RemCtrl \Wuser32.exe | Требуется для удаленного управления компьютером под управлением Windows XP с пакетом обновления 2 (SP2) с помощью средства Remote Tool
Aelita ERdisk для Active Directory 6.7 | Quest Software | См. документацию | Совместный доступ к файлам и принтерам | Требуется для установки подключения к удаленному компьютеру
Hummingbird Host Explorer 8 | Hummingbird | ТСР-порты 21 и 23 | См. документацию | Требуется для установки подключения Telnet к компьютеру под управлением Windows XP с пакетом обновления 2 (SP2)
BV-Admin Mobile | Bind View | См. документацию | Совместный доступ к файлам и принтерам | Требуется для установки подключения к удаленному компьютеру
SQL 2000a | Microsoft | 1433 и 1434 | См. документацию | Требуется для установки подключения к удаленному компьютеру
Backup Exec 8.6.1 |  |  |  | Требуется для передачи удаленного агента на компьютер под управлением Windows XP с пакетом обновления 2 (SP2)
Microsoft SNA 4.0 SP3 | Microsoft | См. документацию | Совместный доступ к файлам и принтерам | Требуется для того, чтобы видеть клиентский компьютер под управлением Windows XP с пакетом обновления 2 (SP2)
Extra! Personal Client 6.5 и 6.7 | Attachmate | Сервер Telnet или порт 23 | См. документацию | Требуется для установки сеанса Telnet с удаленным узлом
Extra! Enterprise 2000 | Attachmate | Сервер Telnet или порт 23 | См. документацию | Требуется для установки сеанса Telnet с удаленным узлом
Extra! Bundle for TCP/IP 6.6 | Attachmate | Сервер Telnet или порт 23 | См. документацию | Требуется для установки сеанса Telnet с удаленным узлом
Volume Manager 3.1 | Veritas | 2148 | C : \Progam Files \Veritas \Veritas Object Bus \Bin \vxsvc.exe | Требуется для установки подключения к клиентскому компьютеру под управлением Windows XP с пакетом обновления 2 (SP2)
BMC Patrol для Windows 2000 | BMC Software | На компьютере под управлением Windows XP с пакетом обновления 2 (SP2): TCP-порты 3181, 10128 и 25; UDP-порты 3181, 10128 и 25 | \\<имя_сервера> \BMC Software \Patrol 3-4 \Best1 \6.5.00 \bgs \bin \Best1CollectGroup.exe | Требуется для установки подключения сервера к клиентскому компьютеру. Перед применением стандартного пути исключения на клиентском компьютере, убедитесь, что предоставлен общий доступ к файлу BMC Patrol на сервере.
eTrust 6.0.100 | Computer Associates | Порты для совместного доступа к файлам и принтерам, запрос эха ICMP и TCP-порт 42510 | См. документацию | Требуется для удаленной установки на компьютере под управлением Windows XP с пакетом обновления 2 (SP2)
NetShield 4.5 | McAfee Security | См. документацию | Совместный доступ к файлам и принтерам | Требуется для удаленного подключения к клиентскому компьютеру под управлением Windows XP с пакетом обновления 2 (SP2)
Computer Associates eTrust 7.0 | Computer Associates | Порты для совместного доступа к файлам и принтерам, запрос эха ICMP | См. документацию | Требуется для того, чтобы сервер Windows Server 2003 eTrust 7.0 мог удаленно проверить возможность входа на компьютере под управлением Windows XP с пакетом обновления 2 (SP2)
Computer Associates eTrust 7.0 |  |  |  | Требуется для того, чтобы сервер Windows Server 2003 eTrust 7.0 мог удаленно установить клиентское приложение eTrust на компьютере под управлением Windows XP с пакетом обновления 2 (SP2). Присвойте указанному ниже параметру реестра значение 0 и перезагрузите компьютер: HKEY_LOCAL_MACHINE \SOFTWARE \Policies \Microsoft \Windows NT \RPC \RestrictRemoteClients (параметр типа DWORD )
Retrospect | Dantz | 497 | 497 | Visit http://www.dantz.com/en/support/kbase.dtml?id=28189
Symantec Ghost Corporate Edition 7.5, 8.0, and 8.2 | Symantec | В группе «Доступ к файлам и принтерам» установите флажок Разрешить общий доступ к файлам и принтерам и откройте порты 137 и 138 протокола UDP, а также порты 139 и 445 протокола TCP. |  | Необходимо для установки клиента на удаленном компьютере
Symantec AntiVirus Corporate Edition 8.x и 9.x | Symantec | Для использования протокола IPX откройте порты 2967 и 33345 протокола UDP. Откройте также порты 38293, 38037 и 38292 протокола UDP. В группе «Доступ к файлам и принтерам» установите флажок Разрешить общий доступ к файлам и принтерам и откройте порты 137 и 138 протокола UDP, а также порты 139 и 445 протокола TCP. |  | Обратитесь на веб-узел http://www.symantec.com/techsupp/ enterprise/sp2/faq.html
IBM Tivoli Storage Manager | IBM | См. документацию, поставляемую компанией IBM | См. документацию, поставляемую компанией IBM | См. документ «Windows XP Service Pack 2 firewall setting for TSM Client» по адресу http://www.ibm.com/software/sysmgmt/products/support/

Игры

Игра | Производитель | Порты | Исключения по умолчанию
Chess Advantage III: Lego Chess | Encore | См. документацию | См. документацию
Need for Speed Hot Pursuit 2 | EA Games | См. документацию | См. документацию
Unreal Tournament 2003 | Atari | См. документацию | См. документацию
Unreal Tournament Game of the Year Edition | Atari | См. документацию | См. документацию
Midnight Outlaw: Illegal Street Drag 1.0 | VALUSoft | См. документацию | Defwatch.exe
Scrabble 3.0 | Atari | См. документацию | См. документацию
Star Trek StarFleet Command III 1.0 | Activision | См. документацию | См. документацию


При попытке установить пакет обновления 2 (SP2) для Windows XP или пакет обновления 1 (SP1) для Windows Server 2003 появляется сообщение об ошибке «Отказано в доступе»

Проблема

При установке пакета обновления 2 (SP2) для Windows XP или пакета обновления 1 (SP1) для Windows Server 2003 могут возникать следующие проблемы:
• | Не удается установить пакет обновления.
• | Отображается следующее сообщение об ошибке: Установка пакета обновления не выполнена. Отказано в доступе.
• | Файл Svcpack.log содержит следующее сообщение об ошибке: DoRegistryUpdates failed

Причина

Данные проблемы возникают, если разрешения доступа к одному или нескольким разделам реестра не позволяют обновить эти разделы. Невозможность обновления какого-либо раздела реестра может привести к сбою программы установки.

Временное решение

Чтобы выполнить следующие действия, пользователь должен быть членом группы безопасности «Администраторы».

Для решения проблемы выполните следующие действия:

Шаг 1. Убедитесь в невозможности обновления реестра

a. | Откройте файл Svcpack.log. По умолчанию этот файл находится в папке C:\Windows. Чтобы открыть файл Svcpack.log, в меню Пуск выберите команду Выполнить, введите %windir%\svcpack.log и нажмите кнопку OK.
b. | В меню Правка выберите команду Найти.
c. | В поле Что введите DoRegistryUpdates failed и нажмите кнопку Найти далее.
d. | Если сообщение об ошибке DoRegistryUpdates failed будет найдено, существует проблема, препятствующая обновлению реестра. Сообщение об ошибке выглядит следующим образом: xxxx.xxx: DoInstallation:DoRegistryUpdates failed. xxxx.xxx: Access is denied. xxxx.xxx: Сообщение, выдаваемое пользователю: Отказано в доступе. Примечание. xxxx.xxx представляет собой точное время регистрации каждой записи.

Шаг 2. Найдите определенный раздел реестра

Убедившись в невозможности обновления реестра, найдите раздел реестра, для которого необходимо изменить разрешение доступа, чтобы обеспечить успешную установку пакета обновления 2 (SP2) для Windows XP или пакета обновления 1 (SP1) для Windows Server 2003. Для этого выполните следующие действия:
a. | Добавьте сведения о реестре в файл Setupapi.log, включив подробную регистрацию в журнале. Дополнительные сведения о том, как включить подробную регистрацию в журнале, см. в следующей статье базы знаний Майкрософт: 906485 (http://support.microsoft.com/kb/906485/) Активация ведения подробного журнала на компьютере под управлением Windows XP Примечание. По умолчанию сведения о разделах реестра не заносятся в файл Setupapi.log. После включения подробной регистрации в журнале повторите попытку установки пакета обновления 2 (SP2) для Windows XP или пакета обновления 1 (SP1) для Windows Server 2003, чтобы зафиксировать проблемный раздел реестра.
b. | Откройте файл Setupapi.log. По умолчанию этот файл находится в папке C:\Windows. Чтобы открыть файл Setupapi.log, нажмите кнопку Пуск, выберите команду Выполнить, введите %windir%\setupapi.log и нажмите кнопку OK.
c. | Нажмите комбинацию клавиш CTRL+END, чтобы перейти в конец файла Setupapi.log.
d. | В меню Правка выберите команду Найти.
e. | В поле Что введите Error 5: Access is denied, в разделе Направление выберите параметр Вверх и нажмите кнопку Найти далее. Найденная запись в файле Setupapi.log должна выглядеть следующим образом: #-007 Deleting registry key HKCR\vnd.ms.radio #E033 Error 5: Access is denied. Примечание. Строка перед сообщением «Access is denied» указывает на проблемный раздел реестра. В данном случае HKCR обозначает куст реестра с меткой HKEY_CLASSES_ROOT. vnd.ms.radio – это один подраздел, находящийся в этом кусте реестра.

Шаг 3. Измените разрешения доступа к реестру

Когда подраздел реестра, имеющий неправильные разрешения, будет найден, обновите разрешения доступа к нему.

Чтобы обновить разрешения доступа к подразделу реестра, выполните следующие действия:
a. | Для запуска редактора реестра нажмите кнопку Пуск, выберите пункт Выполнить, введите команду regedit и нажмите кнопку OK.
b. | Найдите и щелкните правой кнопкой мыши подраздел реестра, найденный в результате выполнения действия 2d, и выберите пункт Разрешения.
c. | В поле Группы или пользователи выделите запись Администраторы.
d. В поле Разрешения для администраторов установите флажок Разрешить для следующих элементов:
• | Полный доступ
• | Чтение
e. | Нажмите кнопку Применить, а затем кнопку ОК.
f. | В меню Файл выберите команду Выход.
В результате проблема с разрешениями доступа к подразделу реестра должна быть устранена, что обеспечит возможность успешной установки пакета обновления 2 (SP2) для Windows XP или пакета обновления 1 (SP1) для Windows Server 2003. При возникновении других проблем с установкой пакета обновления 2 (SP2) для Windows XP или пакета обновления 1 (SP1) для Windows Server 2003 повторите описанные выше действия.
Информация в данной статье относится к следующим продуктам.
• Microsoft Windows XP Service Pack 2 на следующих платформах
Microsoft Windows XP Home Edition
Microsoft Windows XP Professional Edition
• Microsoft Windows Server 2003 Service Pack 1 на следующих платформах
Microsoft Windows Server 2003 Standard Edition
Microsoft Windows Server 2003 Datacenter Edition
Microsoft Windows Server 2003 Enterprise Edition
Microsoft Windows Server 2003 Web Edition
Microsoft Windows Server 2003, Datacenter Edition for 64-Bit Itanium-Based Systems
Microsoft Windows Server 2003 64-bit Enterprise Edition
• Microsoft Windows Server 2003, Standard x64 Edition
• Microsoft Windows Server 2003, Datacenter x64 Edition
• Microsoft Windows Server 2003, Enterprise x64 Edition


При попытке установить консоль восстановления на компьютере под управлением Microsoft Windows XP с пакетом обновления 2 (SP2) появляется сообщение об ошибке

Код статьи | : | 898594
Последнее изменение : | : | 2 декабря 2005 г.
Редакция | : | 2.0

Проблема

При попытке установить консоль восстановления на компьютере под управлением Microsoft Windows XP с пакетом обновления 2 (SP2) появляется следующее сообщение об ошибке:
Установку невозможно продолжить, поскольку на компьютере установлена более поздняя версия Windows, чем на компакт-диске.
Это сообщение появляется при попытке установить консоль восстановления, используя вместо компакт-диска с пакетом обновлений 2 (SP2) для Windows XP один из следующих дисков:
• | Windows XP с пакетом обновления 1 (SP1)
• | Windows XP

Причина

Эта проблема возникает, если пользователю не удается запустить версию Winnt32.exe на компьютере под управлением Windows XP с пакетом обновлений 2 (SP2), используя один из следующих дисков:
• | Windows XP с пакетом обновления 1 (SP1)
• | Windows XP
Windows XP с пакетом обновлений 2 (SP2) распознается как операционная система более поздней версии, чем версия Winnt32.exe, содержащаяся на одном из вышеуказанных компакт-дисков.

Решение

Для решения этой проблемы воспользуйтесь одним из следующих способов.

Способ 1. Используйте компакт-диск с пакетом обновления 2 (SP2) для Windows XP

Нажмите кнопку Пуск, выберите Выполнить, введите буква_дисковода_компакт-дисков:\i386\winnt32.exe /cmdcons и нажмите кнопку OK.

Способ 2. Установите консоль восстановления перед установкой пакета обновления 2 (SP2) для Windows XP

Установите консоль восстановления перед установкой пакета обновления 2 (SP2) для Windows XP. После установки консоли восстановления установите пакет обновления 2 (SP2) для Windows XP.

Способ 3. Установите консоль восстановления, используя файлы в папке установки Windows XP с пакетом обновления 2 (SP2)

1. | Создайте папку установки Windows XP с пакетом обновления 2 (SP2). Дополнительные сведения о том, как это сделать, см. в следующей статье базы знаний Майкрософт: 900871 (http://support.microsoft.com/kb/900871/) Как интегрировать файлы пакета обновлений 2 (SP2) для Windows XP в папку установки Windows XP
2. | Нажмите кнопку Пуск и выберите пункт Выполнить.
3. | Введите в поле следующее (где D — буква дисковода компакт-дисков): путь_к_папке:\i386\winnt32.exe /cmdcons Примечание. В данном шаге путь_к_папке — это диск и имя папки, используемой в качестве папки установки. Например, диск и имя папки, которые используются в статье 90087 базы знаний Майкрософт — C:\XPSP2.
4. | Чтобы подтвердить установку, нажмите кнопку Да в появившемся окне запроса.
5. | Перезагрузите компьютер.
При последующем запуске компьютера в меню загрузки появится пункт «Консоль восстановления Microsoft Windows».


Использование сброса параметров настройки Internet Explorer (RIES)

Код статьи: 923737

Информация в данной статье относится к следующим продуктам.

Microsoft Internet Explorer 7.0

Введение

В этой статье содержатся сведения о новой функции обозревателя Windows Internet Explorer 7, сброс параметров настройки Internet Explorer. В эту статью также включено описание эффектов этой функции и представлены рекомендации по ее использованию.

Дополнительная информация

Windows Internet Explorer 7 для Microsoft Windows XP и Windows Internet Explorer 7 в Microsoft Windows Vista имеют множество улучшений безопасности, благодаря которым обозреватель Internet Explorer 7 менее подвержен воздействию шпионских и вредоносных программ. Как правило, созданные с ошибками надстройки могут влиять не работу обозревателя Internet Explorer 7 в Интернете. Функция RIES позволяет обозревателю Internet Explorer 7 решить эти проблемы.

Для использования функции RIES в обозревателе Internet Explorer 7 выполните следующие действия.

  1. В меню Сервис выберите команду Свойства обозревателя.
  2. На вкладке Дополнительно нажмите кнопку Сброс
  3. В диалоговом окне Сброс параметров настройки Internet Explorer щелкните Сброс.
  4. После восстановления настроек обозревателя Internet Explorer 7 по умолчанию щелкните Закрыть, затем два раза нажмите кнопку OK.
  5. Закройте обозреватель Internet Explorer 7. Изменения вступят в силу при следующем открытии Internet Explorer 7.

Примечание. Если запуск обозревателя Internet Explorer 7 по каким-либо причинам невозможен, запустите функцию с помощью компонента Свойства обозревателя панели управления.

Функция RIES восстанавливает параметры по умолчанию следующих функций.
• | Домашние страницы
• | Области поиска
• | Журнал обозревателя
• | Данные веб-форм
• | Пароли
• | Параметры оформления
• | Панели инструментов
• | Элементы управления ActiveX

Как работает функция RIES

Функция RIES восстанавливает значения следующих параметров.
Параметры обозревателя

Функция RIES сбрасывает все заданные пользователем параметры обозревателя на параметры Internet Explorer 7 по умолчанию. Эти параметры включают параметры, заданные установленными расширениями, панелями инструментов и другими надстройками. Если функция RIES была запущена с правами администратора, соответствующие параметры компьютера расположены в дереве реестра HKEY_LOCAL_MACHINE. Функция RIES восстанавливает значения этих параметров обозревателя Internet Explorer 7 по умолчанию. Эти параметры включают все изменения параметров Internet Explorer 7, выполненные с помощью диалогового окна Свойства обозревателя. Например, сбрасываются значения параметров безопасности, конфиденциальности и зоны.
Расширяемость

Предотвращается автоматический запуск всех устанавливаемых точек входа расширяемости. При загрузке расширений, например панелей инструментов, расширений обозревателя и объектов модуля поддержки обозревателя, при запуске обозревателя Internet Explorer 7 все расширения отключаются. Кроме того, восстанавливается состояние ввода данных элементов управления ActiveX.
Журнал обозревателя

Функция RIES удаляет временные файлы Интернета, файлы «cookie», журнал обозревателя, данные форм, пароли и данные автозаполнения.
Параметры изготовителя

Функция RIES восстанавливает значения измененных параметров Internet Explorer 7, примененных ПВТ в первоначальном пакете. Эти параметры применяются к обозревателю Internet Explorer 7 с помощью пакета администрирования Internet Explorer. Или же эти параметры применяются с помощью настроек, примененных ПВТ во время установки операционной системы.

Необходимо знать следующее

Функция RIES отключает все установленные панели инструментов, расширения обозревателя и настройки. Для использования каких-либо из этих отключенных настроек необходимо выборочно включить настройки с помощью диалогового окна Управление надстройками. Для правильной работы некоторых панелей инструментов необходимо включение двух или более элементов управления. На этих панелях инструментов находятся элементы управления для соответствующего объекта модуля поддержки обозревателя и расширений панели инструментов. Все отключенные элементы управления доверенных издателей можно просто включить с помощью диалогового окна Управление надстройками.
Для веб-страниц с элементами управления ActiveX необходимо разрешить работу отдельных элементов управления ActiveX. Работа определенных элементов управления разрешается при первом использовании этих элементов управления.
Функция RIES не удаляет папку «Избранное» и веб-каналы. Также функция RIES не сбрасывает параметры подключения, так как они могут использоваться другими программами.
Функция RIES не затрагивает параметры групповой политики. После использования функции RIES все политики и ограничения, управляемые администратором на домене, сохраняются в обозревателе Internet Explorer 7. Однако функция RIES не сохраняет некоторые политики, влияющие на работу функции RIES. Например, при включении групповой политики Отключение функции удаления журнала обозревателя функция RIES удаляет временные файлы Интернета. Политика продолжает работу после использования функции RIES с помощью отключения точек входа UI в диалоговом окне Удалить журнал обозревателя. Однако в контексте функции RIES данная групповая политика не действует. Можно отключить функцию RIES на компьютерах конечных пользователей с помощью групповой политики Не разрешать сброс параметров настройки Internet Explorer.
При запуске функции RIES с правами администратора сбрасываются параметры дерева реестра HKEY_LOCAL_MACHINE. Эти параметры применяются ко всем пользователям компьютера. Это влияет на работу в Интернете пользователей, использующих в данный момент обозреватель Internet Explorer 7, и пользователей с открытым сеансом просмотра. Если параметры не изменяются пользователями, обозреватель Internet Explorer 7 считывает эти параметры из раздела HKLM, затем параметры удаляются. Однако функция RIES не затрагивает параметры, специально измененные пользователем. Поэтому рекомендуется использовать функцию RIES только после обращения ко всем соответствующим конечным пользователям.
С обозревателем Internet Explorer 7 взаимодействуют многие приложения. Эти приложения могут запускать или включать Internet Explorer 7. Например, Microsoft Outlook открывает обозреватель Internet Explorer7, если щелчкнуть ссылку в сообщении электронной почты. Такие взаимодействия с обозревателем Internet Explorer 7 во время работы функции RIES могут привести к неожиданным результатам. Поэтому перед запуском функции RIES рекомендуется закрыть все приложения и окна.
Задачи RIES с ошибками обозначаются символом X, который указывается рядом с ними в диалоговом окне Выполнение. Кроме того, сведения о действиях со сбоями регистрируется в файлах журналов Ried.log и Brndlog.txt. Эти файлы расположены в папке %USERPROFILE%\Local Settings\Application Data\Microsoft\Internet Explorer\.

Специальные случаи для администраторов

Ключ совместимости ActiveX

Биты аннулирования совместимости находятся в следующем разделе реестра:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\ActiveX Compatibility

В этом разделе реестра содержатся биты аннулирования, предотвращающие загрузку опасных элементов управления. Функция RIES сбрасывает биты совместимости идентификаторов CLSID. Эти идентификаторы CLSID известны на момент выпуска бета-версии 2. Функция RIES оставляет другие идентификаторы CLSID без изменений.

Дополнительные сведения о битах аннулирования см. в следующей статье базы знаний Майкрософт:

240797 (http://support.microsoft.com/kb/240797/) Как отключить запуск элемента управления ActiveX в обозревателе Internet Explorer

Клавиши управления функции

Раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl позволяет выбрать определенные параметры безопасности, используемые некоторыми функциями и приложениями. Кроме того, клавиши управления функции можно использовать для выборочного применения исправлений. Эта клавиша не сбрасывается функцией RIES.

Конфигурация усиленной безопасности

Если функция конфигурации усиленной безопасности включена, функция RIES восстанавливает значения функции конфигурации усиленной безопасности Internet Explorer 7 по умолчанию. Если функция конфигурации усиленной безопасности выключена, функция RIES восстанавливает стандартные значения параметров Internet Explorer 7 по умолчанию. Функция RIES не изменяет состояния функции конфигурации усиленной безопасности.

Дополнительные сведения о конфигурации усиленной безопасности см. в следующей статье базы знаний Майкрософт:

815141 (http://support.microsoft.com/kb/815141/) Влияние использования конфигурации усиленной безопасности Internet Explorer на работу в Интернете

Групповая политика

Как было сказано выше, функция RIES не влияет на групповую политику. Однако параметры конфигурации продукта также могут быть применены с помощью расширения «Настройка Internet Explorer» в редакторе объектов групповой политики. Большинство этих параметров конфигурации продукта являются настройками, а не политиками. Поэтому после использования функции RIES эти параметры теряются. Функция RIES восстанавливает личные настройки, созданные с помощью пакета администрирования Internet Explorer или предустановочного набора OPK . Если какие-либо параметры были установлены администратором с помощью расширения «Настройка» Internet Explorer, после запуска функции RIES для конечных пользователей политики конечных пользователей теряются.

• Причина

Инфраструктура IEAK позволяет восстанавливать параметры конфигурации продукта функцией RIES. Однако инфраструктура расширения «Настройка» Internet Explorer не поддерживается, так как INS-файлы с этими параметрами присутствуют в локальной системе только временно.
• Обход проблемы

Можно включить параметр политики для повторного применения политик, примененных с помощью расширения «Настройка Internet Explorer». Для этого выполните следующие действия.
1. | Войдите в систему с учетной записью администратора.
2. | Выберите в меню Пуск пункт Выполнить, введите команду gpedit.msc и нажмите кнопку OК.
3. | На левой панели разверните Конфигурация компьютера, разверните Административные шаблоны, разверните Система, затем щелкните Групповая политика.
4. | На правой панели дважды щелкните Обработка политики настройки Internet Explorer.
5. | Выберите параметр Включена и последовательно нажмите кнопку Применить и кнопку ОК.
После включения этого параметра политики все политики, установленные с помощью расширения Настройка Internet Explorer, обновляются при обновлении объекта групповой политики.

Сценарии для ПВТ и других пользователей, настраивающих и распространяющих Internet Explorer 7

Сценарий 1

• | ПВТ настраивает Internet Explorer 7 и распространяет этот пакет конечным пользователям.
• | У конечного пользователя возникает проблема с Internet Explorer 7, и он использует функцию RIES.
• | Функция RIES применяет дополнительную настройку ПВТ.
• | Частью настройки ПВТ являются отключенные панель инструментов и расширение обозревателя.
Сведения

Если ПВТ, поставщик услуг Интернета или корпоративный администратор создают пакет Internet Explorer 7 для распространения с помощью OPK или IEAK, работа конечного пользователя, использующего функцию RIES, в Интернете может измениться. Создатель такого пакета в данном разделе называется партнером IEAK.

Возможен следующий сценарий. Партнер IEAK создает пакет Internet Explorer 7. Однако вместо прямого указания поставщика поиска партнер IEAK включает специальный компонент, запускаемый после установки Internet Explorer 7. В этом сценарии после того как пакет Internet Explorer 7 этого партнера IEAK распространяется и устанавливается на компьютере конечного пользователя, также запускается специальный компонент. При этом поставщик поиска может изменить поиск компании. Так специальным компонентом используются собственные средства, а не файл ins, повторный запуск этого специального компонента при использовании функции RIES не происходит. При использовании функции RIES специальная панель инструментов отключается, даже если компонент является частью исходной настройки партнера IEAK.

Также, если партнер IEAK настраивает панель команд после использования функции RIES конечным пользователем, восстанавливается исходное состояние панели команд Internet Explorer 7. Это происходит из-за того, что партнер IEAK производит настройку с помощью расширений обозревателя, а затем эти расширения отключаются в результате работы функции RIES.

Для повторного включения конечный пользователь может использовать диалоговое окно Управление надстройками в меню Сервис.

Сценарий 2

• | Поставщик услуг или содержимого Интернета настраивает Internet Explorer 6, а затем распространяет пакет конечным пользователям.
• | Конечный пользователь устанавливает Internet Explorer 6 с этим пакетом.
• | Конечный пользователь выполняет обновление до Internet Explorer 7, затем используется функция RIES.
• | В результате использования функции RIES настройка Internet Explorer 6 теряется. Настройка сохраняется во время обновления на Internet Explorer 7.
Сведения

Если поставщик услуг или содержимого создает настроенный пакет Internet Explorer 7 с помощью IEAK, файл Install.ins находится в папке Signup. При обновлении на версию Internet Explorer 7 без настройки программа установки заменяет файл Install.ins в папке Signup файлом ins по умолчанию. В папке Custom отсутствуют файлы ins, а в папке Signup находится файл ins для Internet Explorer 7 по умолчанию. При запуске функции RIES конечным пользователем Internet Explorer 7 сначала ищет файл ins в папке Custom, затем в папке Signup. В этом случае файл ins в папке Signup будет файлом ins обозревателя Internet Explorer 7 по умолчанию. Однако при выполнении настройки с помощью IEAK в корпоративном режиме файл ins размещается в папку Custom, а не в папку Signup. Поэтому файл сохраняется даже после использования функции RIES.

Сценарий 3

• | Корпоративный администратор настраивает Internet Explorer 7 и распространяет этот пакет конечным пользователям.
• | Конечный пользователь устанавливает другой настроенный пакет Internet Explorer 7 на корпоративный настроенный Internet Explorer 7.
• | Конечный пользователь использует функцию RIES.
• | У конечного пользователя версия Internet Explorer 7 с настройкой.
Сведения

Функция RIES использует корпоративную настройку, если она доступна. Если корпоративная настройка отсутствует, функция RIES использует настройку поставщика содержимого Интернета или ПВТ.


Авторы советов

Данный справочник является плодом сотрудничества Игоря Чеботарева и Александра Климова. При его составлении использовались самые полезные и популярные на наш взгляд советы, присланные для рубрики Народная мудрость сайта http://www.whatis.ru/. Авторство советов сохранено на том сайте. Здесь же приводится список наиболее активных советчиков, указавших либо свое полное имя, либо свой ник с электронным адресом. Если вы хотите, чтобы и ваше имя попало в справочник, присылайте свои советы на наш сайт и указывайте свои координаты.

TOP-20 наиболее активных участников

  1. babaj
  2. Vlad Master
  3. Scott Dunn
  4. kariesnn@yandex.ru
  5. Алексей (Sebulba)
  6. Crazy_Serg
  7. Ярослав Будниченко
  8. Сергей Трошин (http://www.computery.ru/upgrade/ )
  9. Евгений Соболев (http://www.softodrom.ru)
  10. Soobcha.ru
  11. Korsar
  12. Ольга КАЛИТКА
  13. 0X0THuK (http://www.rotten7.narod.ru)
  14. Alex
  15. Руслан
  16. Петков Дима
  17. Snowflake
  18. Eugene KRUGLOFF
  19. ffaster
  20. Алексеев Виктор


Специальные символы

С помощью клавиатуры можно ввести различные символы, которых нет на самой клавиатуре.
Для того чтобы поставить знак промилле (показывающий уровень солености), нужно при любой раскладке клавиатуры удерживая Alt на цифровой клавиатуре нажать 0137, затем отпустить Alt и должно получится - ‰
Для того чтобы поставить знак параграфа, нужно при любой раскладке клавиатуры, удерживая Alt на цифровой клавиатуре нажать 789, затем оптпустить Alt и должно получится - §.
Чтобы поставить знак "•" (без кавычек), надо удерживая Alt на дополнительной клавиатуре нажать 0321456789. Получится - •.

У многих пользователей до сих пор старые клавиатуры, на которых нет значка "ЕВРО". В Win98/ME/2000/XP есть возможность ввести с клавиатуры этот значок.
Он отображается, только если используемый шрифт содержит его.
Нажмите и удерживайте ALT, наберите на дополнительной цифровой клавиатуре 0136 и отпустите ALT. Значок должен появиться.


Общие советы

Hardware: Общие советы

Зависания и перезагрузка компьютера нередко связаны с нестабильностью питания или накоплением статики. Если наблюдаются такие симптомы, первым делом нужно обеспечить фильтрацию тока (качественным сетевым фильтром или источником бесперебойного питания) и заземление. Иногда помогает переустановка сетевых вилок в розетке на 180 градусов (чтобы поменять фазу и ноль местами). Часто причиной зависаний, перезагрузок или невключений является разряженная батарейка или старый аккумулятор питания CMOS. Некоторые материнские платы очень быстро «убивают» батарейку – этим прославились новые платы фирм MSI и Gigabyte. Компьютер будет нормально работать, если напряжение на 3-вольтовой литиевой батарейке составляет 3.3 В. Если значение ниже 3.1 В, то этого уже обычно недостаточно для питания CMOS и инициализации BIOS. (источник: журнал Железо)

Частые включения и выключения компьютера приводят к износу и преждевременному выходу из строя компонентов. Главной причиной этого является температура. При прогреве компьютера компоненты расширяются, а при охлаждении - сжимаются. Это уже само по себе серьёзное испытание, а, в придачу к этому, различные материалы имеют разные коэффициенты теплового расширения, т.е. расширяются и сжимаются в различной степени (и с разной скоростью), а это приводит к появлению механических напряжений. Из сказанного следует, что для продления срока службы компьютера его лучше всегда держать при постоянной температуре, т.е. оставлять его постоянно включенным. Включайте компьютер в начале рабочего дня и выключайте в конце. Не выключайте его на обед, перекуры и прочие короткие перерывы.

Не включайте в одну розетку (в одну линию) с компьютером мощные электроприборы, потребляющие большую мощность: холодильники, кондиционеры, кофеварки, копировальные аппараты, обогреватели, пылесосы, мощные электроинструменты, так как они могут стать причиной сбоев.

Если вы удалили из компьютера какую-нибудь плату адаптера, то обязательно закройте оставшееся после неё отверстие в задней стенке корпуса пластинкой-заглушкой. Дырка в корпусе нарушает внутреннюю циркуляцию воздуха, что может привести к повышенному нагреву некоторых компонентов.

Как самостоятельно поменять дисковод 3,5 дюйма?

  1. Открыть корпус компьютера.
  2. Отвинтить винты крепления дисковода.
  3. Отключить шлейф данных и разъем питания.
  4. Вынуть дисковод из корпуса.
  5. Вставить новый дисковод в корпус.
  6. Правильно подсоединить шлейф данных (красный провод шлейфа к 1 ножке разъема) и разъем питания.
  7. Завернуть винты крепления дисковода.
  8. Закрыть корпус компьютера

Говорят, что HDD нельзя форматировать слишком часто. Правда ли это? Конечно нет. Можете форматировать хоть каждый день. Ограничений никаких нет. Хоть все свободное время форматированием занимайтесь. Только зачем? Форматирование HDD в принципе не отличается от записи на него информации. Исключение составляет низкоуровневое форматирование.

Почему у меня нет переключателей (джамперов) на HDD SATA Seagate Barracuda 7200.8? SATA-кабель имеет только 2 разъема, а не три, как IDE-кабель. Поэтому SATA диски можно подключать только по одному на канал. На SATA винчестерах джамперы не нужны, потому что они подключаются к разным портам. SATA - параллельный интерфейс, ему джамперы не нужны.

Как поменять батарейку на материнской плате? Они все одинаковые или нет? И вообще, ничего там повредить нельзя? Тип батарейки - CR2032. На старых материнских платах, правда, использовалась разные типы - с этим проблемы. Если действовать аккуратно, то ничего не повредите - только не забудьте выключить машину.

Если при включении компьютера, после загрузки BIOS, появляется сообщение Warning: Your computer CPU Fan Fail, которое сопровождается звуковым сигналом, то это значит, что система предупреждает, что не получает сигнала с датчика вращения вентилятора процессора. Срочно меняйте вентилятор на процессоре.

Кабель питания из блока питания к дисководу Называется Molex-разъемом - по названию фирмы-производителя. Сам разъем молочного цвета с четырьмя проводами: желтым, красным и двумя черными.

На задней панели компьютера имеются несколько различных гнезд для подключения внешних устройств. Существует стандарт цветовых расцветок для каждого устройства:

  • Зеленый — мышь PS/2
  • Фиолетовый — клавиатура PS/2
  • Красный — 25-контактный параллельный порт
  • Темно-синий — 15-контактный (компактный) видеопорт
Аналогично, имеется специальная расцветка для гнезд звуковой карты:
  • Серый — выход на звуковые колонки или наушники
  • Светло-синий — линейный (внешний) вход
  • Оранжевый — микрофонный вход

Существует способ запретить использование USB-накопителей в Windows XP без установки дополнительных программ. Если USB-накопители еще не подключались к компьютеру, то для пользователя или группы пользователей, которым вы хотите ограничить доступ ко внешним USB-носителям, просто запретите доступ к файлам %SystemRoot%\Inf\Usbstor.pnf и %SystemRoot%\Inf\Usbstor.inf. Если же USB-диск уже подключался, то откройте раздел реестра HKLM\SYSTEM\CurrentControlSet\Services\UsbStor и установите значение параметра Start равным 4. USB-диски после этого работать перестанут

Если у вас старый компьютер с USB-портами версии 1.1, то при копировании с USB-диска стандарта USB 2.0. у вас могут появляться сообщения типа: "A HI-SPEED USB device is plugged into a non-HI-SPEED USB hub". Чтобы отключить это сообщение, появляющееся при установке устройства USB 2.0 в порт USB 1.1, необходимо открыть Диспетчер Устройств, в нем - ветвь Universal Serial Bus Controllers и для того хост-контроллера, к которому вы подключаете переносной диск, установить на вкладке Дополнительно флажок Не сообщать об ошибках USB. Учтите только, что теперь вы не увидите и никаких других сообщений об ошибках USB. Впрочем, таковые бывают редко.

Чтобы отключить встроенный динамик в Windows XP (достал, однако), то заставить спикер замолчать можно следующим образом. Для этого в "Диспетчере устройств" (Панель управления-Система-Оборудование) в меню "Вид" поставьте флажок напротив пункта "Показать скрытые устройства". Далее в появившейся ветви "Драйверы устройств не Plug and Play" найдите устройство с именем Beep и отключите его.


rundll32.exe

Местонахождение

Windows\system32

Описание

Запуск библиотеки DLL как приложения - Run a DLL as an App

Windows имеет в своем составе утилиту командной строки rundll32.exe, которая позволяет запускать некоторые команды-функции, заложенные в DLL-файлах.

Вообще-то данная утилита была разработана для внутреннего пользования программистами Microsoft. Но богатые возможности этой программы дало повод на всеобщее использование пользователями.

Область применения данной утилиты довольно широк. Вы можете вводить приведенные ниже команды в окне Запуск программы (Пуск-Выполнить), также создать ярлыки с заданнами параметрами запуска, использовать в коде на программируемом вами языке (C++, Delphi, Visual Basic и т.д.)

Список команд слишком обширен. Приведем список наиболее значимых команд.

SHELL32.DLL

  • rundll32 shell32.dll,Control_RunDLL hotplug.dll - диалоговое окно Отключение или извлечение аппаратного устройства
  • rundll32 shell32, Control_FillCache_RunDLL - запустить начальную инициализацию Панели управления.
  • rundll32 shell32,Control_RunDLL - открыть в Проводнике папку "Панель управления"
  • rundll32.exe shell32.dll,Control_RunDLL access.cpl,,1 - апплет Специальные возможности (вкладка Клавиатура)
  • rundll32.exe shell32.dll,Control_RunDLL access.cpl,,2 - апплет Специальные возможности (вкладка Звук)
  • rundll32.exe shell32.dll,Control_RunDLL access.cpl,,3 - апплет Специальные возможности (вкладка Экран)
  • rundll32.exe shell32.dll,Control_RunDLL access.cpl,,4 - апплет Специальные возможности (вкладка Мышь)
  • rundll32.exe shell32.dll,Control_RunDLL access.cpl,,5 - апплет Специальные возможности (вкладка Общие)
  • rundll32 shell32,Control_RunDLL appwiz.cpl,,1 - вызов диалогового окна "Установка и удаление программ"(вкладка Установка программ).
  • rundll32 shell32,Control_RunDLL appwiz.cpl,,2 - вызов диалогового окна "Установка и удаление программ"(вкладка Установка компонентов Windows).
  • rundll32 shell32,Control_RunDLL appwiz.cpl,,3 - вызов диалогового окна "Установка и удаление программ"(вкладка Выбор программ по умолчанию).
  • rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,0 - апплет Экран (вкладка Рабочий стол).
  • rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,1 - апплет Экран (вкладка Заставка).
  • rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,3 - апплет Экран (вкладка Параметры).
  • rundll32.exe shell32.dll,Control_RunDLL inetcpl.cpl,,0 - апплет Свойства обозревателя (вкладка Общие).
  • rundll32.exe shell32.dll,Control_RunDLL inetcpl.cpl,,1 - апплет Свойства обозревателя (вкладка Безопасность).
  • rundll32.exe shell32.dll,Control_RunDLL inetcpl.cpl,,2 - апплет Свойства обозревателя (вкладка Конфиденциальность).
  • rundll32.exe shell32.dll,Control_RunDLL inetcpl.cpl,,3 - апплет Свойства обозревателя (вкладка Содержание).
  • rundll32.exe shell32.dll,Control_RunDLL inetcpl.cpl,,4 - апплет Свойства обозревателя (вкладка Подключения).
  • rundll32.exe shell32.dll,Control_RunDLL inetcpl.cpl,,5 - апплет Свойства обозревателя (вкладка Программы).
  • rundll32.exe shell32.dll,Control_RunDLL intl.cpl,,0 - апплет Язык и региональные стандарты (вкладка Региональные параметры)
  • rundll32.exe shell32.dll,Control_RunDLL intl.cpl,,1 - апплет Язык и региональные стандарты (вкладка Языки)
  • rundll32.exe shell32.dll,Control_RunDLL intl.cpl,,2 - апплет Язык и региональные стандарты (вкладка Дополнительно)
  • rundll32.exe shell32.dll,Control_RunDLL joy.cpl - апплет Игровые устройства
  • rundll32 shell32,Control_RunDLL main.cpl @0 - открыть диалог "Свойства мыши".
  • rundll32 shell32,Control_RunDLL main.cpl @1 - открыть диалог "Свойства клавиатуры".
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL PrintersFolder - открыть папку "Принтеры" (другой способ).
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL FontsFolder - открыть папку "Шрифты" (другой способ).
  • rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,0 - апплет Звуки и аудиоустройства (вкладка Громкость)
  • rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,1 - апплет Звуки и аудиоустройства (вкладка Звуки)
  • rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,2 - апплет Звуки и аудиоустройства (вкладка Аудио)
  • rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,3 - апплет Звуки и аудиоустройства (вкладка Речь)
  • rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,4 - апплет Звуки и аудиоустройства (вкладка Оборудование)
  • rundll32.exe shell32.dll,Control_RunDLL modem.cpl - апплет Телефон и модем
  • rundll32.exe shell32.dll,Control_RunDLL ncpa.cpl - открытие окна Сетевые подключения
  • rundll32.exe shell32.dll,Control_RunDLL odbccp32.cpl - апплет ODBC Data Source Administrator
  • rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl,,0 - апплет Система (вкладка Общие). Параметры от 1 до 6 - остальные вкладки
  • rundll32.exe shell32.dll,Control_RunDLL telephon.cpl - апплет Телефон и модем
  • rundll32 shell32,Control_RunDLL timedate.cpl - открыть диалог "Дата и время".
  • rundll32 shell32,Control_RunDLL timedate.cpl,,/f - открыть вкладку Часовой пояс диалогового окна свойств времени Панели управления
  • rundll32 shell32,OpenAs_RunDLL - вызвать диалог "Открыть с помощью...".
  • rundll32 shell32,ShellAboutA WHATIS.RU - информация о версии Windows.
  • rundll32 shell32,SHExitWindowsEx 0 - закрыть все программы, перегрузить оболочку.
  • rundll32 shell32, SHExitWindowsEx 1 - выключить ПК.
  • rundll32 SHELL32, SHExitWindowsEx -1 - перегрузить оболочку Windows.
  • rundll32 shell32, SHExitWindowsEx 2 - перегрузить ПК.
  • rundll32 shell32,SHExitWindowsEx 4 - принудительно закрыть все программы.
  • rundll32 shell32,SHExitWindowsEx 8 - выход из Windows и выключение ATX-совместимого ПК.
  • rundll32 shell32,SHFormatDrive - вызов диалога форматирования диска А:.
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL AddPrinter - запуск "Мастера установки принтера".
  • rundll32 shell32,SHHelpShortcuts_RunDLL Connect - запуск мастера подключения сетевого диска.
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL PrintTestPage - распечатать тестовую страницу.

URL.DLL

  • rundll32 url.dll,FileProtocolHandler %1 - открыть веб-страницу, где %1 - URL сайта (включая http://).
  • rundll32 url.dll,MailToProtocolHandler %1 - создать новое письмо, где %1 - e-mail адресата.
  • rundll32 url.dll, NewsProtocolHandler %1 - произвести подключение к новостному серверу, где %1 - URL сервера.
  • rundll32 url.dll, TelnetProtocolHandler %1 - осуществить подключение telnet, где %1 - адрес сервера.

USER.EXE

  • rundll32 user,CASCADECHILDWINDOWS - расположить все окна каскадом.
  • rundll32 user,TILECHILDWINDOWS - расположить все окна по экрану.
  • rundll32 user,disableoemlayer - сбой системы (!) - выключить все функции ввода-вывода (клавиатура, дисплей, мышь). В результате будет черный экран с курсором и ни на что не реагирующая система, однако Windows продолжает работать.
  • rundll32 user,enableoemlayer - включить и загрузить OEM Layer, если есть возможность выполнить эту команду дистанционно.
  • rundll32 user,ExitWindowsExec - быстрая перезагрузка Windows.
  • rundll32 user,RepaintScreen - выполнить команду "Обновить".
  • rundll32 user,SetCaretBlinkTime n - задать частоту мигания курсора, соответствующую значению параметра n.
  • rundll32 user,SetCursorPos - переместить курсор мыши в верхний левый угол экрана.
  • rundll32 user,SetDoubleClickTime n - задать скорость двойного нажатия левой кнопки мыши (Double Click), соответствующую параметру n.
  • rundll32 user,SwapMouseButton - поменять местами клавиши мыши (обратная смена невозможна).
  • rundll32 user,WNetConnectDialog - вызов диалога "Подключение сетевого диска".
  • rundll32 user,WNetDisconnectDialog - вызов диалога "Отключение сетевого диска".

Разное

  • rundll32 diskcopy,DiskCopyRunDll - вызов диалога "Копирование диска".
  • rundll32 keyboard,disable - отключение клавиатуры, действует до следующей перезагрузки.
  • rundll32 mouse,disable - отключение мыши вплоть до перезагрузки.
  • rundll32 krnl386.exe,exitkernel - выгрузить ядро системы, выход из Windows.
  • rundll32 mshtml.dll,PrintHTML "HtmlFileNameAndPath" - распечатать документ HTML, где "HtmlFileNameAndPath" - путь к файлу и его имя.
  • rundll32 мсprint2.dll,RUNDLL_PrintTestPage - распечатать тестовую страницу на принтере.
  • rundll32 netplwiz.dll,AddNetPlaceRunDll - вызов мастера подключения нового сетевого ресурса "Добавление в сетевое окружение".
  • rundll32.exe ntlanui.dll,ShareCreate - вызов окна Новый общий ресурс
  • rundll32.exe ntlanui.dll,ShareManage - вызов окна Общие папки
  • rundll32 shell,ShellExecute - открыть Проводник (папка "Рабочий стол").
  • rundll32 sysdm.cpl,InstallDevice_Rundll - вызов мастера установки оборудования.
  • rundll32 AppWiz.Cpl,NewLinkHere %1 - запуск мастера создания нового ярлыка, где %1 - путь к исходному файлу.
  • rundll32 syncui.dll, Briefcase_Intro - вызов мастера по работе с "Портфелем"
  • rundll32 SYNCUI.DLL, Briefcase_Create - создать новую папку "Портфель", если эта функция установлена в системе.
  • rundll32 msgina,ShellShutdownDialog - вызов диалога "Завершение работы Windows".
  • rundll32 tcpmonui.dll, LocalAddPortUI - запуск мастера установки TCP-порта принтера.
  • rundll32 shdocvw.dll,DoOrganizeFavDlg - вызов окна "Упорядочить избранное"
  • rundll32 shdocvw.dll,OpenURL filename - запуск .url файла с именем filename
  • rundll32 user32.dll LockWorkStation - блокировка компьютера
  • rundll32 desk.cpl, InstallScreenSaver [filename.scr] - задать файл скринсейвера в диалоговом окне свойств дисплея.
  • rundll32 IEdkcs32.dll, Clear - сброс некоторых настроек Internet Explorer, полезно использовать при некоторых сбоях в работе обозревателя.
  • rundll32.exe powrprof.dll,SetSuspendState - ввести компьютер в спящий режим


SFC.EXE

Местонахождение

Windows\system32

Описание

Windows 2000 System File Checker

Утилита SFC.EXE предназначена для проверки всех версий защищенных системных файлов и восстановления их из специального кэша в случае подмены или повреждения.

В Windows XP она запускается только из командной строки - в отличие от Windows 9х, где подобная утилита имеет графический интерфейс. Запуск утилиты возможен только с правами администратора, синтаксис такой:
sfc [/scannow] [/scanonce] [/scanboot] [/revert] [/cancel] [/enable] [/purgecache] [/cache size=x] [/quiet]

Параметры командной строки, которые можно задавать для программы SFC, следующие:

  • /scannow - немедленная проверка всех защищенных системных файлов
  • /scanonce - проверка защищенных системный файлов при следующей загрузке системы
  • /scanboot - проверка всех защищенных системных файлов при каждой загрузке системы
  • /revert - восстанавливает все настройки по умолчанию (Windows XP)
  • /cancel - отменяет все проверки защищенных системных файлов (Windows Me/2000)
  • /purgecache - очистка кэша защищенных файлов программы и немедленная проверка всех защищенных системных файлов
  • /cachesize=x - установка размера кэша защищенных файлов в мегабайтах (по умолчанию 50 мГб)
  • /enable - включение защиты системных файлов Windows (Windows Me/2000)
  • /quiet - замена поврежденных файлов без предупреждения (Windows Me/2000)
  • /? - вызов справки

Давайте рассмотрим практическое применение утилиты.

Папка dllcache

Если вас не устраивает, что Windows XP занимает слишком много места и восстанавливает удалённые из его директории файлы, то может удалить папку dllcache, но после следующей проверки системных файлов Windows снова заполнит эту папку. Для устранения этого "греха", после удаления или до удаления файлов (но не папки), нужно запустить команду sfc /cachesize=число. Числом будет количество мегабайт которое должно резервироваться для папки windows\system32\dllcache. Можно поставить = 0.

Поврежденные файлы

Предположим, вы обнаружили, что на вашем компьютере отсутствуют некоторые файлы, например, шрифты (шрифты - тоже системные файлы). Проверяем наличие системных файлов с помощью команды
sfc.exe /scannow
Windows проверит файлы и при необходимости переустановит недостающие или поврежденные.