Всё о Windows XP

Лучшие программы для Windows 95/98/Me/NT/2K/XP Скачай Испытай Обсуди

Статьи

+ Windows
+ Программы
+ Из рассылки
+ Вокруг софта

Каталог

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения

СофтОбзоры

Текущий выпуск
Архив:
Программа недели
Архив:
Программа дня
Подписка на рассылку

Поиск файлов

Files.ru
FTP Search
FileSearch.ru
SOFTODROM.RU
Главная | Топ 50 | Новинки | Статистика | СофтФорум | Для авторов
Помощь | Обратная связь | Рассылка

Softodrom.ru > Статьи

Всё о Windows XP

Версия от 2.05.2002

Содержание
  • Windows XP FAQ
    Оглавление
    Общие вопросы
    Настройка
    Разрешение проблем
    Восстановление

  • Windows XP: что это такое и с чем её едят
  • Краткий обзор клиентских версий Windows XP
  • Microsoft Windows XP Plus Pack: очередные "фантики", но не только они одни...
  • Файловая система NTFS
  • Фрагментация NTFS
  • NTFS и FAT: скорость
  • Оптимизируем Windows XP. Часть 1
  • Как корректно удалить Windows XP/2K и восстановить Windows 95 или 98
  • Секреты настройки сети под Windows XP (начальные сведения)
  • Что такое иконки Windows XP
  • 20 секретов Windows XP

    Составление, оформление © Softodrom.ru
    Оптимизация, перевод в формат CHM - Янкин Н.В.
    Обязательным условием перепечатки или любого другого использования материалов сборника "Всё о Windows XP" является ссылка на первоисточник.


20 секретов Windows XP

Статьи

+ Программы
+ Из рассылки
+ Вокруг софта

Каталог

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения

СофтОбзоры

Текущий выпуск
Архив:
Программа недели
Архив:
Программа дня
Подписка на рассылку

Поиск файлов

Files.ru
FTP Search
FileSearch.ru
| Главная | Топ-50 | Новинки | Статистика | СофтФорум| Для авторов | Помощь | Обратная связь | Рассылка |

Softodrom.ru > Статьи

20 секретов Windows XP

Автор: Reviews.ru
http://www.reviews.ru/

Дата публикации: 14.04.2002
Категория: Windows

Вы почитали обзоры и знаете все о главных особенностях новой операционной системы. Теперь самое время забраться поглубже и раскрыть некоторые секреты Windows ХР.

1. Если предыдущие версии Windows скрывали, как долго они способны работать без перезагрузки, то ХР в этом плане есть чем гордиться. Войдите в командную строку из меню Accessories, которое вызывается стартовой кнопкой All Programs, и наберите systeminfo. Компьютер выдаст много полезной информации, в том числе время бесперебойной работы. Для сохранения этих данных в файле наберите systeminfo > info.txt.

2. Для того чтобы удалять файлы, не сохраняя их в «мусорной корзине», выберите Run... из меню Start и наберите gpedit.msc, затем выберите User Configuration, Administrative Templates, Windows Components, Windows Explorer и отметьте флажком Do not move deleted files to the Recycle Bin. Покопавшись в gpedit, можно найти массу параметров интерфейса и системы, однако будьте осторожны: некоторые из них могут привести к нежелательному поведению компьютера. (Это работает только в Professional Edition.)

3. Рабочую станцию ХР можно запереть двумя щелчками мыши. Кликнув на рабочем столе правой кнопкой, создайте новый ярлык и введите в поле location строку rundll32.exe user32.dll,LockWorkStation. Присвойте этому ярлыку какое-нибудь имя. Теперь двойным щелчком по нему вы сможете блокировать свой компьютер. Того же эффекта можно добиться сочетанием клавиш Windows + L.

4. XP скрывает отдельные элементы системного ПО, которые кто-то, возможно, захочет удалить. Это может быть, например, Windows Messenger. Пользуясь редактором Notepad или Edit, исправьте текстовый файл /windows/inf/sysoc.inf, найдя и удалив в нем слово hide. Затем войдите в меню Add or Remove Programs на панели управления, выберите Add/Remove Windows Components — и вам откроется все, что было сокрыто.

5. Тем, кто владеет искусством работы с пакетными файлами DOS, ХР предлагает ряд интересных новых команд. В их числе eventcreate и eventtriggers для создания системных событий и слежения за ними, typeperf для контроля за производительностью различных подсистем и schtasks для управления запланированными задачами. Как обычно, /? после имени команды выдает список опций — их слишком много, чтобы перечислять здесь все.

6. В ХР есть поддержка IP версии 6 — интернет-протокола нового поколения. К сожалению, такой поддержки нет у вашего ISP, поэтому экспериментировать с ней можно лишь в пределах локальной сети. Введите ipv6 install в поле Run... (не беспокойтесь, текущие сетевые настройки от этого не пострадают), а затем наберите ipv6 /? в командной строке, чтобы получить дополнительную информацию. Если вы не знаете, что такое IPv6, не переживайте и не утруждайте себя.

7. Наконец-то появилась возможность снимать задачи из командной строки. Наберите taskkill /pid и номер задачи или просто tskill и номер процесса. Номер можно узнать, набрав команду tasklist, которая вдобавок сообщит многое о том, что происходит в вашей системе.

8. XP считает файлы Zip папками — это удобно, если у вас быстрая машина. На более медленных системах можно заставить ХР отказаться от такой практики, набрав в командной строке regsvr32 /u zipfldr.dll. Позднее, если вы передумаете, можно все вернуть назад командой regsvr32 zipfldr.dll.

9. В ХР встроена технология сглаживания шрифтов на экране ClearType, но по умолчанию она выключена. Ее стоит попробовать, особенно если вы начинали с DOS и пялились на экран все эти годы, заработав астигматизм. Чтобы включить ClearType, кликните правой кнопкой мыши на десктопе, выберите Properties, Appearance, Effects, затем найдите во втором падающем меню ClearType и разрешите эту опцию. Лучшие результаты получаются на лаптопах. Если вы хотите использовать ClearType и на экране приветствия Welcome, присвойте параметру HKEY_USERS/.DEFAULT/Control Panel/Desktop/FontSmoothingType в реестре значение 2.

10. Вы можете помочь приятелю, который работает в домашней сети и пользуется трансляцией сетевых адресов (NAT), применив механизм удаленного доступа — но не сразу. Сначала попросите друга прислать вам e-mail с приглашением Remote Assistance, предварительно отредактировав файл. В атрибуте RCTICKET указан IP-адрес NAT, например 192.168.1.10. Его надо заменить действительным IP-адресом вашего приятеля — он может определить его, посетив сайт www.whatismyip.com, — и пусть он убедится, что в его брандмауэре порт 3389 открыт и переадресован на проблемный компьютер.

11. Вы можете исполнять программы от имени другого пользователя — без выхода из системы и повторной регистрации. Кликните на значке правой кнопкой, выберите Run As... и введите имя пользователя и пароль. Они будут действовать до окончания текущего сеанса работы. Это особенно полезно, когда нужно получить права администратора для установки программы, что случается очень часто. Имейте в виду, что многократно исполнять программы под разными именами — занятие увлекательное, но оно может привести к непредсказуемым эффектам.

12. Windows XP проявляет настойчивость в отношении автоматической проверки апдейтов, регистрации в системе Passport, использования Windows Messenger и т.п. Со временем вы привыкните, но, если чувствуете, что не доживете до этого момента в здравом уме, запустите Regedit, войдите в HKEY_CURRENT_USER/Software/Microsoft/Windows/Current Version/Explorer/Advanced и создайте параметр DWORD с именем EnableBalloonTips и значением 0.

13. Можно начинать работать, не набирая имени пользователя и пароля. Выберите Run... из стартового меню и наберите control userpasswords2, что приведет к открытию приложения, управляющего учетными записями пользователей. На вкладке Users удалите флажок у позиции Users Must Enter A User Name And Password To Use This Computer и кликните ОК. Появится диалоговое окно Automatically Log On; введите имя пользователя и пароль для нужной учетной записи.

14. Internet Explorer 6 можно настроить на автоматическое удаление временных файлов. Запустите браузер, выберите Tools / Internet Options... и Advanced, спуститесь до раздела Security и отметьте позицию Empty Temporary Internet Files Folder When Browser is Closed.

15. К ХР прилагается бесплатный индикатор работы сети — на тот случай, если вам не видно светодиодов на сетевой плате. Кликните правой кнопкой на My Network Places на рабочем столе и выберите Properties. Кликните правой кнопкой на ярлыке своей локальной сети или dial-up соединения, выберите Properties и активизируйте значок Show в зоне оповещения о работе в сети. Теперь при наличии сетевого трафика в правой части панели задач вам будет весело подмигивать маленький значок сети.

16. Меню Start, когда оно решит появиться, может показаться медлительным, но этот процесс можно ускорить, уменьшив значение параметра реестра HKEY_CURRENT_USER/Control Panel/Desktop/MenuShowDelay, которое по умолчанию равно 400. Сделайте его, например, нулевым.

17. В Windows Explorer файлы можно переименовывать скопом. Выделите в окне группу файлов, кликните правой кнопкой по одному из них и, если нужно, переименуйте его. Все выделенные файлы получат имя указанного файла с индивидуальными номерами в скобках. Кроме того, значки в папке можно организовать в упорядоченные по алфавиту группы — для этого выберите View, Arrange Icon By... Show In Groups.

18. Windows Media Player в процессе воспроизведения треков отображает обложки альбомов — если находит их изображение в интернете во время копирования трека с CD. В противном случае, а также если у вас большая библиотека музыкальных файлов WMP, вы можете поместить свою собственную копию изображения обложки в тот же каталог, где хранятся записи. Просто назовите ее имя_каталога.jpg, и Windows Media Player найдет и выведет эту картинку.

19. Сочетание клавиш Windows + Break открывает системный аплет Control Panel; сочетание клавиш Windows + D открывает рабочий стол; сочетание клавиш Windows + Tab переключает кнопки панели задач.

20. Следующая версия Windows XP с кодовым названием Longhorn должна выйти в конце следующего или в начале 2003 года, но в ней будет мало изменений. Принципиально новая версия с кодовым названием Blackcomb появится в 2003/2004 году.

страницы: 1
Обсуждение этой статьи :: Версия для печати ::

Статьи по теме:

система публикаций: Sanitarium WebLoG


Краткий обзор клиентских версий Windows XP

Статьи

+ Программы
+ Из рассылки
+ Вокруг софта

Каталог

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения

СофтОбзоры

Текущий выпуск
Архив:
Программа недели
Архив:
Программа дня
Подписка на рассылку

Поиск файлов

Files.ru
FTP Search
FileSearch.ru
| Главная | Топ-50 | Новинки | Статистика | СофтФорум| Для авторов | Помощь | Обратная связь | Рассылка |

Softodrom.ru > Статьи

Краткий обзор клиентских версий Windows XP

Автор: Евгений Кулыгин
Источник: http://www.3dnews.ru.ru/

Дата публикации: 21.03.2002
Категория: Windows

Windows XP - очередная операционная система (ОС), ориентированная как наклиента, так и (в конечном счете) на сервер, которая выпущена компанией Microsoftпосле выпуска Windows 2000 и Windows Millenium. Windows XP представляет собойнаиболее плодотворную попытку Microsoft объединить системы кодов этих ОС,и на настоящий момент все выглядит так, что она удастся. В прошлом у компанииMicrosoft было желание поставлять линейку одной ОС или, по крайней мере,линейки ОС, основанных на единственной системе кодов. Windows 2000 должнабыла стать системой, которая объединила бы Windows NT и Win 9x, но из-занескольких моментов (наименее значительным из которых является неполное использованиепотенциальных возможностей), изначальная цель Windows 2000х - слияние двухкодов - была отложена до более поздней версии. С Windows XP компания Microsoftнадеется устранить все имевшиеся ранее проблемы, которые возникали у пользователейс Windows, прислушиваясь и действуя на основе обратной связи от Beta Team(тестирующей команды), а также жалоб, запросов и вопросов от общества.

Это время становится все ближе. Компания Microsoft скоро официально выпуститWindows XP, возможно даже скорее, чем объявленная дата выпуска 25-ое октября.Фактически, по слухам XP Home (домашняя версия) и Professional (профессиональнаяверсия) достигнут стадии RTM (выпуск в массовое производство) к концу этойнедели, и будет доступна на новых системах (OEM builds) к 2-ой неделе сентября.Тем не менее, по юридическим или по каким-либо другим причинам, Windows XPочень близка к моменту выпуска. Я был членом официальной тестовой командыMicrosoft (Windows XP Beta Team) на протяжении года, если не более, и видел,что эта ОС прошла через несколько принципиальных изменений, наименьшее изкоторых известно Вам как Luna (новый синий округлый интерфейс пользователя).Сегодня я не намерен вообще что-либо говорить о Luna или GUI (это случитсяв ближайшем будущем). Сейчас я хочу обсудить различия между двумя версиямиклиентской ОС, которые скоро будут выпущены. Я знаю, непосредственно менямного раз спрашивали и на работе и в Battlefront, какая версия Windows XPлучше подходит для того-то и того-то и таких-то и таких-то целей. Надеюсь,что, прочитав это, Вы будете немного лучше представлять себе, какая версияявляется лучшей для Вас. Итак, давайте сначала опишем основы. В конце мыприведем удобную таблицу, чтобы все это пояснить.

Основы

Основные требования для двух версий клиентской Windows XP одинаковы:
  • PC с рекомендуемой тактовой частотой процессора 300 MHZ или более; 233MHZ - требуемый минимум; рекомендуемый процессор - семейство Intel Pentium/Celeron,семейство AMD K6/Athlon/Duron, или совместимые с ними.
  • Рекомендуемый объем памяти 128 МБ RAM или выше (поддерживаемый минимум 64МБ; может ограничивать работу и некоторые функции).
  • 1.5 GB доступного места на жестком диске*.
  • Видеоадаптер и монитор Super VGA (800 x 600) и выше.
  • CD-ROM или привод DVD.
  • Клавиатура и мышь Microsoft или совместимые устройства.
Мы был бы неточны, если бы не указали, что эти "требования" вдействительности должны восприниматься как требования для загрузки, а недля фактического, производительного использования. Обе версии должны управлятьсяна машине, по крайней мере, с 256МБ RAM, и ОС будет вести себя весьма медленнона чем-нибудь старше процессора поколения PIII/ATHLON.

Windows XP Домашняя версия

В двух словах, это - замена всех линеекMicrosoft Windows 9x и Windows Ме. Это наконец-то переводит всех домашнихпользователей на ОС с ядром NT. Новые поставки компьютеров от несколькихOEM, включая Compaq, Dell, Gateway и большинства магазинов будет скоро производитьсяс этой версией ОС. Поскольку это не обсуждение, почему Вы должны перейтиот Windows 9x к Windows XP (я думаю, что все мы уже знаем почему), я не будувдаваться в полный обзор всех деталей новых особенностей ОС. Давайте восприниматьдомашнюю версию (Home Edition) как следующую основную потребительскую ОС.Все основные особенности всей линейки Windows 9x были включены в домашнююверсию. Кроме того, домашняя версия имеет более развернутые варианты настроекбезопасности в Интернете (Internet Connection Firewall), и более развернутуюподдержку нескольких пользователей, которая окажется весьма удобной для семейс несколькими пользователями.

Windows XP Профессиональная версия

Профессиональная версия - заменадля Windows NT Workstation и Windows 2000 Professional. Она нацелена скореена корпоративный рынок и рынок рабочих станций. Это будет первичная ОС длямногих компьютерных гуру, использующих в настоящее время мультипроцессорныесистемы, и желающих немного большего, чем может предложить домашняя версия.Как мы скоро увидим, профессиональная версия добавляет к XP пакету множествоособенностей для "продвинутого пользователя" и "дружественных для корпоративногоиспользования". Следует ожидать, что профессиональная версия довольно быстросовершит массивное нашествие в большинство корпоративных сообществ. Большаячасть компаний, с которыми я имел дело, считают важной задачей своего бизнесаоперативный переход к Windows XP на настольных компьютерах и ноутбуках, полностьюоставляя Windows 2000 в прошлом.

Windows. NET Server (Windows XP Server)

Это - замена для WindowsNT Server, и Windows 2000 Server. Это основная рабочая лошадка для корпоративногосетевого окружения. По слухам это первая реальная ОС в .NET push. Так какWindows XP Server все еще находится в развитии (в середине бета цикла), этаверсия в данной статье не рассматривается. Однако, я хотел бы ее упомянуть,чтобы Вы знали, что она есть.

Различия между домашней и профессиональной версиями относительно аппаратных средств

На сцене аппаратных средств ЭВМ только профессиональная версия поддерживаетсимметричные мультипроцессорные системы (SMP до двух процессоров). Верно,что домашняя версия не поддерживает более одного процессора. Многие настаиваютна том, чтобы имеют проблемы в связи с отсутствием поддержки SMP в домашнейверсии, поскольку системы с двойными процессорами действительно начали быстрораспространяться в самом нижнем секторе класса самостоятельной сборки. ПоддерживающиеSMP материнские платы, основанные на Athlon и Intel, достигают ценовых отметокниже $ 300, а при возможности иметь два быстрых процессора за приблизительноте же самые деньги, имеется много причин, делающих использование сдвоенногопроцессора неплохой идеей. Microsoft задавал достаточно много вопросов поэтой проблеме своим бета-тестерам за трехмесячный период, предшествующийвыпуску версии Beta2. Хотя некоторые из наиболее, скажем так, активных, членовBattlefront считают это вредным для ОС, ни одна из предыдущих клиентскихверсий ОС от Microsoft не поддерживала SMP - ни ДОС, ни Windows 3.x, и ниодна из линейки Windows 9x. Если у Вас сдвоенная система (неважно от AMDили Intel), Вам следует перескочить непосредственно на профессиональную WindowsXP или дать шанс GNU/LINUX.

Хотя это может показаться странным, Microsoft также решил обеспечиватьдинамическую поддержку диска только для профессиональной версии. ДинамическиеДиски дебютировали в Windows 2000. Динамическая поддержка Диска убирает староеделение диска и логические отметки в Основной Записи загрузки (Master BootRecord - MBR) в пользу базы данных управления диска, хранящейся в конце диска.Логическая разметка дисков и устройств все еще используется (например, c:d: и т.д.), но фактический размер и местоположение таких логических дисковстановятся динамическими. В результате динамические диски позволяют Вам делатьтакие вещи, как мгновенно управлять размерами Ваших дисков, и создавать логическиедиски из нескольких физических.

Мы рады сообщить, что обе версии ОС предлагают поддержку несколькихмониторов. Первоначально компания Microsoft заявила, что этого не будет,но (к счастью) изменила свои намерения.

Дистанционный Доступ и Дистанционный Рабочий стол

Домашняяверсия также не включает Дистанционный Рабочий стол. Считайте, что ДистанционныйРабочий стол - это облегченная версия Terminal Server или Citrix. Это способдоступа к вашему компьютеру с другого компьютера. Вообразите, что Вы находитесьна работе, в дороге с вашим ноутбуком или в доме приятеля. Обладая профессиональнойверсией XP, Вы сможете соединиться с вашим компьютером, увидеть ваш рабочийстол в окне и делать те же вещи, как если бы Вы непосредственно сидели заВашим столом (при условии, что вы используете компьютер, на котором установленMS Terminal Client). Вы, возможно, видели подобные функциональные возможностив прошлом в приложениях типа PC Anywhere или Timbuktu. Не путайте ДистанционныйРабочий стол (Remote Desktop) с Remote Assistance, поскольку это два различныхэлемента, предназначенных для двух различных целей. И домашняя версия и профессиональнаяпредлагает Remote Assistance, которая позволяет кому-либо видеть ваш рабочийстол и с вашего разрешения иметь ограниченное управление вашим рабочим столом.Remote Assistance - это другой способ помочь родителям сделать что-то новоеили восстановить что-либо, расстроенное вашей маленькой сестрой. Что же мешаетпросто использовать Remote Assistance подобно Дистанционному Рабочему столу?Для кого-то это весьма неудобно. Remote Assistance запускается пользователемпри помощи электронной почты или специального сообщения через Windows Messenger.

Затем получатель вашего вызова помощи открывает прилагаемое приложениетипа "MsRCincident", и затем предоставляет пароль, который Вы установили(и, надеюсь, устно передали человеку, а не по электронной почте). Я предполагаю,что Вы могли бы послать такие вещи самим себе на адрес электронной почты,а затем позже получить доступ на ваш компьютер, используя этот же MsRCincident,но это мне кажется немного странным. Конечно, Вы можете оставить приглашениеоткрытым до 30 дней.

Различия системы защиты: в и вне коллективных (shared) сетей

Вне сети: Еще два пункта, отсутствующие в домашней версии - EFS (системашифрования файлов) и способность управлять и ограничивать доступ к файлам,папкам и программам. Отсутствие EFS и контроля доступа может оказаться весьмазначительным ударом по домашней версии, поскольку это отсутствие не даетпользователям домашней версии надежно обезопасить свои профильные папки,которые могут содержать частные закладки, документы и изображения, от другихместных пользователей. Без этих двух элементов защита индивидуальных счетовстановится очень трудным делом. Это еще одна особенность, которую, мне кажется,стоило оставить в домашней версии, так как для нее имеется много примененийв семейных вычислительных системах, например, для защиты таких вещей, какналоговые документы и т.п. Без управления доступа, маленький ребенок можетвыбросить в мусорную корзину важные документы отца или посмотреть его любимыевеб-сайты.

В сети: Домашняя версия не обеспечивает все сложное изобилие настроекдоступа и защиты, которые дают возможность регулировать домены NT или архитектуруактивной директории, и которые (настройки) обычно предлагаются. В некоторомсмысле, домашняя версия ориентирована на работу "рабочих групп" и обладаеттолько самыми основными элементами, поддерживаемыми для интеграции доменовили активной директории (в будущем, будем называть ее доменной интеграцией).Это - одна из проблем, которые я в настоящее время имею с домашней версиейWindows XP. Это походит просто на способ получить большее количество денегиз корпоративных сред, которые работают на основе Windows 9x, начиная с Windows95. Не имея возможности полностью воспользоваться преимуществом от участияв доменном окружении, домашняя версия много теряет. Безусловно, большинствовозможностей управления из централизованного узла в сети потеряно. В предыдущихверсиях "потребительской ОС" можно было настроить ОС так, чтобы получитьсетевой ACL от контроллера домена и настроить машину так, чтобы получитьвсю информацию о настройке защиты от контроллера домена. Однако, с тех пор,как модель контроллера домена уходит в пользу активной директории, она заставляетцентрализованную систему защиты требовать "аккаунт компьютера" в активнойдиректории, чего домашняя версия поддерживать не будет. В 9x ничего не потрясаетвоображение, но эти ОС играют важную роль во многих маленьких средах. Конечно,в конце концов, именно поэтому это и назвали домашней версией, не правдали?

Кроме того, из-за того, что профили выполнены немного по-другомув рабочих группах в отличие от доменных сред, домашняя версия теряет возможностьиспользовать автономные файлы и папки (которые могут использоваться для копированиясетевых файлов и папок в местную систему и затем для повторного синхронизированияс сетевой средой после повторного присоединения к сети). Это не очень удачно,потому что я мог бы, конечно, представить себе пользователей домашней версиина, скажем, домашнем компьютере и ноутбуке, которые хотели бы синхронизироватьсвои документы для автономного просмотра.

Наконец, отсутствие "аккаунта компьютера" в среде активной директорииозначает отсутствие администрирования групп и отсутствие мобильных пользователей.Некоторые другие проблемы, вызванные отсутствием поддержки доменов, - неспособностьпроизводить дистанционную установку ОС, программного обеспечения и дистанционноеобслуживание. Однако, с точки зрения домашнего пользователя, большинствоэтих проблем на самом деле не имело бы значения, поскольку вероятность нахождениядомашнего пользователя в доменной среде довольно маленькая.

Еще немного других мелочей

Один элемент, который по непонятным причинам был удален - многоязычный интерфейс.Профессиональная версия Windows XP может мгновенно переключать языки (еслиони установлены). Переключая язык, я имею в виду весь переход интерфейсапользователя к новому языку, начиная с меню, диалоговых файлов до словарейи подробных инструментов. Это означает, что каждый вариант домашней версиибудет ограниченным. Вы нуждаетесь в немецкой версии - Вы покупаете немецкуюдомашнюю версию. Лично я думаю, что для Microsoft было бы легче предложитьодну версию с многоязычным интерфейсом. Это кажется особенно странным, таккак с домашней и профессиональной версией Windows XP Вы можете управлятьлюбым приложением Win32 на любом языке на любой платформе XP. Это означает,что Вы можете управлять китайским MS Word в домашней версии, но Вы не можетепереключать непосредственно ОС на китайский язык (если у Вас не профессиональнаяверсия).

Другой небольшой, но стоящий упоминания аспект этих двух продуктов -их конфигурация по умолчанию. По умолчанию, аккаунт гостя включен в домашнейверсии, но отключен в профессиональной версии. Пункт стартового меню "МоиНедавние Документы" по умолчанию выключен в домашней версии, но включен впрофессиональной версии. Это кажется мне особенно спорным выбором. Другоеразличие - появление настройки XP "запирание панели задач". В домашней версии,панель задач "заперта", что означает, что ее невозможно переместить или растянуть,если ее сначала не разблокировать. Кроме того, панель быстрого запуска QuickLaunchтакже по умолчанию выключена в домашней версии. Хорошая новость, конечно,что Вы можете все это изменить.

И да, еще одна вещь. Стоимость и Модернизация (upgrade). Домашняяверсия Windows XP будет продаваться в розницу за $ 199, и $ 99 за "апгрейд"- цены, приблизительно на 10 % выше чем, текущие цены за Windows 98/ME. Профессиональнаяверсия Windows XP будет продаваться в розницу за $ 299, "апгрейд" приблизительноза $ 199 или около того (значимое увеличение по сравнению с Windows 2000).Если деньги - проблема, имейте в виду, что Вы можете всегда купить OEM копиюнамного дешевле с новым жестким диском или некоторыми другими компонентамиPC. Будучи "профессиональными потребителями (prosumers)" и т.п., нам затруднительносказать что, не стоит "апргейдить" профессиональную версию за дополнительные$ 100, но, если Вы не нуждаетесь во всем этом дополнительном материале, тоВы не нуждаетесь в этом, а Microsoft, конечно, берет лицензионный платежза эти элементы.

Однако, имейте в виду. В то время как обе версии могут модернизировать(upgrade) Win 98, Win ME, и WinNT 4.0, ОС Windows 2000 может быть модернизирована(upgrade) только профессиональной версией XP.

Все различия одним взглядом

Как и обещано, приводим удобнуютабличку некоторых из "специальных" элементов, существующих в домашней ипрофессиональной версии XP. Таблица был построена с акцентом на различиямежду двумя версиями.

Сравнительная таблица специальных элементов
 | Домашняя версия | Профессионал
Новый интерфейс "Luna" | Х | Х
Подсоединение к Интернету Firewall | X | X
Многопользовательская поддержка (и быстрое переключение пользователя) | X | X
Поддержка SMP (до 2 процессоров) |  | X
Поддержка нескольких мониторов | X | X
Динамическая поддержка диска |  | X
Remote Assistance | X | X
Дистанционный рабочий стол |  | X
Полное участие в NT Domain / Активная директория |  | X
Автономные файлы и папки |  | X
Шифрование файловой системы |  | X
Многоязычный интерфейс |  | X
Полная стоимость версии (upgrade) * | $ 199 ($ 99) | $ 299 ($ 199)
*Цена в настоящее время определяется.

Вот так вот. Не позвольте этой табличке одурачить вас: Домашняя версия- в основном то же самое, чем была любая предыдущая версия линейки 9x.

В заключение

Итак, Домашняя версия Windows XP против профессиональнойверсии Windows XP. Есть несколько основных вопросов, которые вы должны рассмотретьперед выбором наилучшего для вас варианта. Если вы рассматриваете корпоративноеразмещение ОС, забудьте о домашней версии. Говоря в самом общем смысле, этопросто не та ОС, которая способна делать то, что необходимо в структурированном,управляемом сетевом окружении организации, которое вы обнаружите на своемрабочем месте (по крайней мере, в больших организациях с реальным IT разработками).

Если вы просто заменяете Windows 98 на вашей машине для игр, воспользуйтесьдомашней версией, особенно, если ваши родители и маленькие сестренки такжесобираются использовать систему. Если вы привыкли к Windows 2000 или дажек Windows NT, перейдите к профессиональной версии Windows XP, поскольку вдомашней версии не хватает некоторых инструментов, которые вы привыкли использоватьпочти ежедневно.

страницы: 1
Обсуждение этой статьи :: Версия для печати ::

Статьи по теме:
  • Microsoft Windowx XP Plus Pack - очередные "фантики", но не только они одни...
  • По просьбам трудящихся: Как корректно удалить WinXP/2K и восстановить Windows 95 или 98
  • Windows XP: что это такое и с чем ее едят


Что такое иконки Windows XP

Статьи

+ Программы
+ Из рассылки
+ Вокруг софта

Каталог

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения

СофтОбзоры

Текущий выпуск
Архив:
Программа недели
Архив:
Программа дня
Подписка на рассылку

Поиск файлов

Files.ru
FTP Search
FileSearch.ru
| Главная | Топ-50 | Новинки | Статистика | СофтФорум| Для авторов | Помощь | Обратная связь | Рассылка |

Softodrom.ru > Статьи

Что такое иконки Windows XP

Автор: Aha-soft
Источник: http://www.aha-soft.com/

Дата публикации: 14.04.2002
Категория: Windows

Microsoft® Windows® XP представляет собой новый стиль дизайна иконок. Стиль Windows XP - это удачное сочетание юмора, цвета и передовых технологий, поскольку теперь можно создавать 32-битные варианты иконок с гладкими краями.

По рекоммендации Microsoft иконки должные содержать следующие три размера:

  • 48 x 48 пикселей
  • 32 x 32 пикселей
  • 16 x 16 пикселей
            • xp icons

    Иконки на левой стороне меню Пуск отображаются размером 24 x 24 пикселей. Это не тот размер, какой вы обычно предусматриваете.

    Если вы создаёте иконки для паналей инструментов, стандартные размеры в Windows 24 x 24 и 16 x 16 пикселей.

    Windows XP поддерживает 32-битные иконки, которые являются 24-битными изображениями c 8-битным альфа каналом. Такие иконки позволяют отображать гладкие края, которые хорошо сочетаются с любым фоном.

    Каждая иконка Windows XP должна содержать следующие цветности для поддержки отображения разными мониторами:
  • 24-битные с 8-битным alpha-каналом (32-битные)
  • 8-битные (256 цветов) с 1-битовой прозрачностью
  • 4-битные (16 цветов) с 1-битовой прозрачностью

    • Всего у вас дожно быть девять файлов - по 3 размера на каждую глубину цвета:
  • 48 x 48 при 32 битах
  • 32 x 32 при 32 битах
  • 16 x 16 при 32 битах
  • 48 x 48 при 8 битах
  • 32 x 32 при 8 битах
  • 16 x 16 при 8 битах
  • 48 x 48 при 4 битах
  • 32 x 32 при 4 битах
  • 16 x 16 при 4 битах

    • Оттенение

    Иконки Windows XP используют оттенение для обеспечения чёткости и дополнительного измерения. Этот эффект поддерживается Aha-soft ArtIcons. Для того, чтобы добавить тень к вашим изображениям, выбирите опцию Effects / Drop Shadow основного меню.
    before shadow make shadow after shadow

    Обыкновенные иконки Windows XP:

    Common Icons for Windows XP

    Обыкновенные иконки панели инструментов Windows XP:

    toolbar icons for Windows XP

    Вот первичные цвета, используемые в 8-битных иконках Windows XP:

    Windows XP icon color palette

    Microsoft Windows User Experience Team предоставляет описание создания иконок Windows XP: Создание иконок Windows XP - полная статья

    страницы: 1
    Обсуждение этой статьи :: Версия для печати ::

    Статьи по теме:
  • Оптимизируем Windows XP. Часть 1
  • Файловая система NTFS
  • Краткий обзор клиентских версий Windows XP
  • Windows XP: что это такое и с чем ее едят
  • Microsoft Windowx XP Plus Pack - очередные "фантики", но не только они одни...


Секреты настройки сети под Windows XP

Статьи

+ Программы
+ Из рассылки
+ Вокруг софта

Каталог

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения

СофтОбзоры

Текущий выпуск
Архив:
Программа недели
Архив:
Программа дня
Подписка на рассылку

Поиск файлов

Files.ru
FTP Search
FileSearch.ru
| Главная | Топ-50 | Новинки | Статистика | СофтФорум| Для авторов | Помощь | Обратная связь | Рассылка |

Softodrom.ru > Статьи

Секреты настройки сети под Windows XP

Автор: Reviews.ru
Источник: http://www.reviews.ru/

Дата публикации: 14.04.2002
Категория: Windows

О важности сетей

Говорить о важности сетевых технологий на страницах сетевого издания немного странно, однако мы считаем, что даже среди сетевой публики, многие с трудом знакомы с важностью, особенно в современных условиях, объединения компьютеров в сеть.

Итак, напомним, что сети бывают локальные и глобальные. Локальные сети объединяют некоторое количество компьютеров в пределах одного или нескольких зданий. Такие сети иногда называют интранет. Глобальные сети подразумевают соединение различных локальных сетей в одну общую сеть, называемую Интернет.

Существует мнение, что если ты хоть раз поработал в составе сети, то работа без подключения к сети становиться болезненно тяжело. Да действительно, так, например наши компьютеры объединены в локальную сеть, подключенную с Интернет. Стоит произойти какой-нибудь неприятности с Интернетом, как работать становиться значительно тяжелее. Казалось бы, почему? Ведь по большому счету в сети мы видим просто чужие диски, иногда пользуемся вычислительными ресурсами удаленного процессора. Почему бы ни воспользоваться собственными дисками и мощностью собственного процессора. Все дело в информации. Ведь сегодня сеть это огромная база знаний, созданная усилиями каждого имеющего желание поделиться с другими своими знаниями и умениями. С одной стороны, это превращает сеть в некую «помойку» где из огромного объема информации приходится извлекать полезную информацию, с другой стороны нет ни одного другого электронного или любого off-line источника, способного дать ответ на абсолютно любой вопрос.

Сеть – развращает!

После длительной работы в сети иногда пользователь частично теряет возможность решать многие, простые вопросы обычными средствами. Так, например, поиск какой-либо информации без сети становиться просто невозможной. Единственным, доступным и действенным средством общения является e-mail или Интернет-пейджеры. С одной стороны «жители» сети являются достаточно сильными людьми, однако это касается только сети. В реальной ситуации, «сетевой житель» может быть достаточно слабым и беззащитным существом. Именно поэтому потеря доступа в сеть хотя бы на несколько дней, является достаточно тяжелой потерей для таких людей.

О чем эта статья?

Без сомнения, с точки зрения организации сети Windows XP самая простая операционная система от Microsoft. Точнее сказать, эта операционная система позволяет быстро и эффективно создавать небольшие сети для дома или небольшого офиса.

В этой статье мы расскажем о трех главных составляющих небольшой сети: совместное подключение к Интернет, совместное использование принтера, файлов и каталогов. В первую очередь мы нацеливаем эту статью на людей, только начинающих вникать во все тонкости «жизни» компьютера в сети. Однако и подготовленные пользователи смогут найти для себя не мало интересного.

Несмотря на наличие русской версии Windows XP, мы решили, что все примеры, приведенные в статье, будут для англоязычной версии Windows XP. Это значительно упростит создание сети для неопытных пользователей, использующих англоязычную версию.

Немного истории

Для того, что бы лучше понять превосходство сетевых решений в Windows XP давайте совершим краткий экскурс в историю развития операционных систем Windows. Для некоторых из Вас это отступление может быть раздражающим, однако нам было даже приятно вспомнить, чему мы радовались еще несколько лет назад. Давайте начнем с Windows 3.1.

Операционная система Windows 3.1 имела очень ограниченный инструментарий для организации даже самой простой сети и требовала использование программного обеспечения сторонних разработчиков. Возможно для операционной системы, выпущенной 10-12 лет назад, это было нормально. Специально для рабочих групп Microsoft выпустила Windows 3.11 for Workgroups, которая имела только протокол совместного использования файлов. Позднее в августе 1995 года была выпущена операционная система Windows 95. Несмотря на свою “глючность”, эта операционная система имела более продвинутые сетевые средства, однако по современным меркам все было очень сложно и недостаточно для требований современного пользователя. Через год была выпущена операционная система Windows NT 4.0, с дополнительными патчами и сервис паками. Windows NT 4.0 использовала интерфейс и принципы Windows 95. Главным отличием являлись наличие расширенных особенностей защиты, лучшие средства многозадачности, администрирование пользователей и больший упор на сетевую организацию для бизнес пользователей. Однако реализация сетевых особенностей оказалась еще сложнее, и недоступной для неподготовленного пользователя.

Через 2-3 года после Windows 95 были выпущены операционные системы Windows 98 и Millennium. Windows 98, за исключением NT, была первой настоящей 32-bit версией Windows с полностью 32-bit кодом. В то время как Windows 98 имела некоторые усовершенствование сетевого инструментария и возможностей, они все еще были похожи на Windows 95. Дополнительно Microsoft выпустила “Special Edition” Windows 98, известную как Windows 98 SE, в которой исправлены ошибки в сетевых протоколах. В феврале 2000 Microsoft выпустила Windows 2000. Эта система основана на ядре Windows NT и поэтому ее иногда называют Windows NT 5.0. Windows 2000 имеет очень продвинутые сетевые возможности, однако их реализация пока не проста, и напоминает Windows NT.

И наконец, сегодня мы стали свидетелями выпуска и развития операционной системы Windows XP. Обе версии (Professional и Home) являются очень красивым сочетанием сетевых возможностей NT, 2000 и простого и понятного пользовательского интерфейса.

Теперь, когда мы вспомнили, как развивались сетевые возможности операционной системы Windows, давайте переходить к нашей главной теме.

Физическая установка сети

Для упрощения, предположим, что мы используем в сети три компьютера – два “клиентских компьютера” и один «сервера». Для организации, даже такой маленькой сети нам понадобятся сетевые карты, которые устанавливаются в каждый компьютер, свич или хаб, а так же специальный сетевой кабель, называемый витая пара.

Выбор сетевой карты

В прошлом сетевая карта представляла собой отдельную ISA (для тех, кто не знает это такой старый стандарт слота расширения) или PCI плату. Причем их цена превышала 100$, что несколько ограничивало развития сетей в небольших организациях. Сегодня сетевая карта стала настолько доступной, что частенько ее интегрируют на системную плату. В случае, если Ваша плата не имеет интегрированного сетевого контроллера, то Вам придется воспользоваться внешней PCI платой. Карта должна соответствовать стандарту Realtek 10/100. Она стоит около 10$. Более дорогие карточки имеют множество дополнительных функций, обеспечивающих большую стабильность при передаче данных. Ниже на фотографии показан внешний вид типичной сетевой карты.

При выборе сетевой карты, необходимо обратить внимание на максимальную поддерживаемую скорость передачи 10/100. Это означает, что карта может передавать данные на скорости 10mbps и 100mbps в зависимости от сетевой архитектуры. Дополнительно необходимо, что бы карточка имела разъем RJ-45 (современный стандарт CAT5), поддерживающий скорость передачи 100mbps и обратно совместимый с 10mbps стандартом (именно такой разъем показан на фотографии). Самый последний стандарт “CAT6”, (пока находится в разработке) будет поддерживать скорости от 300mbps до 1gbps. Это означает, что Вы сможете копировать файлы в сети со скоростью 125 мегабайт в секунду. Это быстрее скорости современных жестких дисков. CAT5-E или категория 5 UTP Enhanced так же обратно совместима с 10, 100 и 1000Mbit Ethernet. Использование RJ-45 предпочтительнее, чем RJ-58, или больше известные как BNC. Этот разъем предназначен для подключения на более низких скоростях (ограничена 10mbps) коаксиальным кабелем.

Хаб против свича

Для управления всеми транзакциями (передача блоков информации) в сети используется устройство называемой хаб или свич. В чем отличие между этими двумя устройствами?. Во время передачи пакета данных хаб отправляет их сразу на все компьютеры, что значительно уменьшает пропускную способность канала. Свич, имеет встроенную память, в которой храниться информация о том, к какому порту подключен какой компьютер. Поэтому во время передачи пакета, он отправляется на определенный порт. Кроме того, свич позволяет использовать в сети контроллеры с разной скоростью передачи, при этом общая пропускная способность не будет опускаться до уровня контроллера с минимальной скоростью. Учитывая незначительное ценовое отличие мы настоятельно рекомендуем приобрести именно свич. На сегодняшний день впускаются свичи с 5, 8, 16, 24 или 32 портами. Цена устройства напрямую зависит от количества портов.

802.11a и 802.11b

Говоря об организации сети мы считаем необходимым затронуть вопрос беспроводных сетей, т.е. передающих информацию по радиоканалу. Такие сети становятся все популярнее, т.к. позволяют сделать размещение компьютеров более гибким, а пользователям использующим карманные компьютеры или ноутбуки, получить доступ к сети в любой точке офиса и даже за пределами. На сегодняшний день существует два стандарта 802.11a и 802.11b. Для реализации такого подключения необходимо использовать специальные хабы и сетевые карточки.

Как выбрать свич?

В принципе, любой. Например, мы используем 8-портовый свич от CNET, но другие брэнды, такие как Kingmax, Netgear, Dlink, 3COM так же имеют очень хорошее качество. В общем, в этом вопросе можно довериться компании, которая будет проводить у Вас сеть. Они обычно ставят то, что хорошо работает.

Рекомендации по конфигурированию сервера

Если Ваш сервер не планируется использовать для игр, нет необходимости использовать самый последний процессор Pentium 4 или Athlon XP с большим объемом оперативной памяти и емким жестким диском, а так же с самой последней графической картой GeForce 4. Главное, чего необходимо добиться, это стабильной круглосуточной работой. Так. Как сервер будет использовать Windows XP, он должен быть оснащен минимум 128MB RAM.

В идеале, Вы можете использовать процессор Pentium 2, III или Athlon 500MHz, при этом система будет достаточно хорошо работать в нашей среде.

Конфигурация сети в Windows XP

Установить сетевые параметры в Windows XP Вы можете несколькими способами. Во-первых, вручную. Этот метода предпочтительнее, т.к. позволяет контролировать все настройки. Во-вторых, для тех, кто ничего не понимает в сетевых терминах Microsoft включила мастер установки сети (Network Setup Wizard). Для запуска мастера, необходимо войти в “My Network Places” и нажать на “set up a home or small office network”. Нажмите Next, на втором экране будут описаны некоторые рекомендации по правильной установке. Фактически здесь Вы найдете полное руководство к действию. Нажимаем Next. Теперь для всех клиентских компьютеров Вы должны выбрать вторую опцию (The computer connects to the Internet through another computer on my network or through a residential gateway) и нажмите Next. На следующем экране Вы можете ввести или изменить имя компьютера. Теперь переходим к следующему окну, где мы сможем изменить название рабочей группе. Следующий экран резюмирует сделанные изменения и применяет их. На следующем экране Вам будет предложено создать диск установки сети. Так как мы делаем меленькую домашнюю сеть этот диск можно не создавать. Просто нажмите «Wizard and then Finish».

Мы просим извинить нас за нескончаемые переходы к следующему экрану, однако по другому описать действия мастера невозможно. В дальнейшем мы будем использовать первый, ручной режим.

Мастер сетевой идентификации

Теперь необходимо установить имя Вашего компьютера в рабочей группе, к которой он принадлежит. Для этого нажмите Start -> Settings -> Control Panel -> System -> и выберите закладку Computer Name. Сначала нажмите “Network ID”, что позволит активизировать мастер сетевой идентификации (Network Identification Wizard). На первом экране просто нажмите Next. На следующем экране нужно выбрать первую опцию (This computer is part of a business network, and I use it to connect to other computers at work), на следующем экране выберете вторую опцию (My company uses a network without a domain), Это приведет Вас к экрану показанном ниже...

Здесь Вы должны установить название рабочей группы. Эти действия Вы должны повторить на всех компьютерах Вашей сети.

Обращаем Ваше внимание, что некоторые broadband провайдеры используют свою собственную рабочую группу. В этом случае они должны Вас проинструктировать об использовании имени рабочей группы.

IP адресация

Прежде всего вы должны идентифицировать каждый компьютер в сети. Для этого служит так называемая IP (Internet Protocol) адресация. IP адрес – это уникальный номер Вашего компьютера в Вашей сети. IP адрес может быть “статическим” или “динамическим”. В своей внутренней сети Вы можете использовать IP адреса класса C, т.е. в диапазоне 192.168.0.1 до 192.168.0.254. Другими словами в одной рабочей группе может работать до 254 компьютеров. Обычно серверу назначают адрес 192.168.0.1. Когда Вы активизируете совместный доступ к сети (Internet Connection Sharing) по умолчанию Вашему серверу будет автоматически назначен этот адрес.

Конфигурация сервера

Примечание: Под XP и Windows NT для установки сетевых параметров Вы должны войти с правами администратора. OK – установив на все компьютеры сетевые карты, Вам необходимо назначить каждому компьютеру IP адрес. Для этого нажмите Start -> Settings -> Network Connections. Теперь кликните правой кнопкой мышки на “Local Area Connection” и выберите меню Properties. Затем укажите на протокол TCP/IP и нажмите Properties. Перед Вами откроется окно, позволяющее установить все необходимые сетевые параметры...

На скриншоте выше мы показываем настройку IP адреса для сервера. Пока этого достаточно. Ниже мы покажем, как конфигурировать клиентские компьютеры. Для того, что бы Вы лучше понять, как работает сервер в сети, мы приводим примерную схему подключения компьютеров рабочей группы к Интернет, через один компьютер.

Конфигурирование клиентских машин

Выше на скриншоте мы видим, что одному из клиентских компьютеров установлен IP адрес 192.168.0.5. Маска подсети устанавливается автоматически, по этому поводу Вам волноваться не стоит. Обратите внимание, что IP адрес должен быть уникальным, и не может повторяться внутри одной сети. В случае повторного использования IP адреса, Windows сообщит о возникновении проблемы с повторяющимся IP адресом. Ниже на рисунке, показано, что такое клиентский компьютер и его роль в сети.

Совместное использование Интернет

Как мы сказали в начале статьи, современная сеть должна решать три основные задачи: Совместный доступ к Интернет, совместное использование принтера и совместное использование файлов и папок. В принципе, все три задачи уже, так или иначе, решены в некоторых предыдущих версиях Windows. Однако в Windows XP они решены лучше и проще. Итак, в первую очередь давайте рассмотрим реализацию совместного доступа в Интернет. В нашем примере настройки клиентского компьютера мы устанавливаем обращение к серверу с IP адресом 192.168.0.1. Этот адрес указан как адрес шлюза, т.е. компьютера, через который все остальные будут обращаться в Интернет. Тот же адрес мы указываем в качестве первичного DNS (DNS – это сервис который позволяет по символьному имени узла, определить его физический IP адрес). Теперь, зайдите нажмите OK, что вернет Вас в первоначальное меню свойств сетевого соединения. Здесь откройте закладку Advanced и проверьте опцию Internet Connection Firewall. На клиентских машинах эта опция должна быть отключена.

Включение совместного доступа к Интернет

После завершения настройки всех клиентских машин, Вам необходимо активизировать доступ в Интернет на серверной машине. Для этого нужно войти в меню сетевых соединений (Start -> Settings -> Network Connections), выбрать иконку, через которую подключаетесь к провайдеру (по модему или быстрому каналу). В меню свойств учетной записи необходимо выбрать закладку Advanced, где Вы найдете все опции, необходимые для организации совместного доступа …

В первую очередь обратите внимание на включение Internet Connection Firewall для Internet соединения. Firewall – это система защиты, которая работает как защитный щит между внутренней сетью и внешним миром. Internet Connection Firewall (ICF) – это программный продукт, который используется для установки ограничений передачи информации от и к вашей рабочее группе. Мы рекомендуем разрешить эту опцию. В то время как мощность такого программного «щита» не может сравниваться с подобными аппаратными межсетевыми экранами, это сможет в некоторой степени защитить Ваши данные от различных сетевых неприятностей. Теперь обратите внимание на включении опции “Allow other network users to connect through this computer’s Internet connection”, которая позволит другим пользователям входить в Интернет через сервер. Если Вы хотите управлять различными установками учетных записей Интернет с других, клиентских компьютеров, включите опцию “Allow other network users to control or disable the shared Internet connection”. И последняя опция - “Establish a dial-up connection whenever a computer on my network attempts to access the Internet”. Ее включение позволит серверу в случае получения запроса к Интернет с любого клиентского компьютера автоматически установить соединение. Теперь нажмите OK для применения всех сделанных изменений. В принципе, Windows XP не требует перезагрузки при изменении сетевых настроек, однако мы настоятельно рекомендуем это сделать не только на сервере, но и на всех клиентских компьютерах. Теперь, Вы можете попробовать войти в Интернет с любого компьютера в Вашей сети, причем в случае с Windows XP Вы можете спокойно, без необходимости делать дополнительные настройки, использовать программы, подобные ICQ.

В случае если доступа к сети нет, попробуйте сначала проветрить правильность подключения всех кабелей, и включение концентратора или свича. Если все сделано правильно то при подключении сетевого кабеля к Вашей сетевой карте, на экране в tray области (рядом с часами, появиться сообщение о подключении сетевого кабеля на скорости 100 или 10Mb). В случае если этого не происходит, необходимо проверить включение опции отображения индикатора в сетевых настройках и проверить правильность и целостность кабеля. Далее попробуйте в окне DOS набрать команду ping 192.168.0.1, которая проверит соединение с серверной машиной. Если пинг не прошел, необходимо проверить работоспособность и настройку сетевых карт и свича. Кроме того, одной из причин имеющихся проблем может быть установка Windows XP поверх другой операционной системы имеющей настроенную сеть, либо компьютер использовал собственное подключение к Интернет. После неоднократной установки различных, предлагаемых на рынке, версий и вариаций Windows XP, мы пришли к выводу, что для полной работоспособности необходимо устанавливать новую ОС на чистый диск, или раздел.

Статус Интернет соединения

Теперь необходимо коснуться вопроса контроля состояние подключения к Интернет. Особенно это касается случая использования операционных систем отличных от Windows XP. Для доступа к этой опции нажмите Start -> Network Connections. Как Вы можете видеть Windows XP достаточно подробно показывает параметры соединения, такие как скорость соединения и трафик на Вашей клиентской машине. Кроме того, здесь Вы можете отключить Интернет соединение.

Совместное использование принтера

Теперь, когда Вы установили ICS, пришло время настроить принтер для совместного использования в рабочей группе. Эта возможность очень полезна для небольших компаний или отделов. Установив совместный доступ к одному или нескольким принтерам, Вы сможете значительно сэкономить не только на принтерах, но и на времени. Если на Вашем сервере еще не установлен принтер, сделать это можно с помощью меню Printers and Faxes, открыть которое можно так: Start -> Settings -> Printers and Faxes. Как только принтер будет установлен, кликните по его иконке правой клавишей мышки и выберете пункт Sharing...

В открывшемся окне просто нажмите “Share this printer” и наберите имя, под которым принтер будет виден в сети.

Совместное использование и доступ к файлам

И наконец, мы переходим к последнему наиболее частому использованию сети – совместному использования файлов и папок. Эта особенность позволит создавать в компании библиотеку документов, шаблонов и т.д. Открывать и ограничивать доступ к документам различных сотрудников. В общем, полностью организовать документооборот в компании. Честно сказать, с полным документооборотом мы преувеличили. На самом деле для этого необходимо использовать специальные продукты, способные индексировать и архивировать документы, осуществлять быстрый поиск и т.д. Однако Windows XP частично позволяет решить эти задачи, и позволяет сэкономить на приобретении программ третьи разработчиков.

Для того, что бы разрешить сетевой доступ к файлам и папкам нужно в My Computer выбрать диск, к которому нужно открыть доступ, и правой кнопкой войти в свойства диска, где выберите закладку Sharing как показано ниже...

В целом здесь все понятно, однако необходимо обратить внимание, на то, что в случае включения опции “Allow network users to change my files” Вы даете им полный доступ к своим файлам, т.е. не только редактирование, но и удаление. В случае совместной работы с Windows 2000 и NT с точки зрения защиты Вы можете отключить простой режим совместного использования файлов через меню View->Folder Options->[X]Use Simple File Sharing.

Добавление сетевых дисков

Для упрощения доступа к часто используемым сетевым дискам, ВЫ можете добавить их в свое окно My Computer и использовать как обычный диск на Вашем компьютере. Для этого Вам необходимо правой кнопкой мышки кликнуть на сетевое окружение, и в открывшемся контекстном меню выбрать “Map Network Drive...” .

Здесь выберите букву для нового диска, и укажите путь к нему. Если Вы не знаете точного пути, то можете воспользоваться кнопкой “Brouse…”.

Заключение

Конечно же эта статья не может претендовать на звание энциклопедии сетевых возможностей Windows, однако она позволила решить две важные задачи. Те кто достаточно хорошо разбирается в сетях, наверное смогли найти для себя некоторые дополнительные особенности, которые было просто лень искать самостоятельно без особой надобности. Те, кто вообще не разбирается в сетях, смогли понять, что для реализации достаточно эффективной сети вполне достаточно использовать Windows XP.

Однако, для реализации сети в Вашем офисе мы настоятельно рекомендуем обратиться к специалистам. Поверьте нашему опыту, что как только «технический специалист» Вашей компании начинает делать сеть, это становиться в непрекращающийся ремонт в квартире. Постоянно, что-то доделывается, возникают различные «подводные камни» и т.д. Лучше всего обратиться к сетевым специалистам. Причем совсем необязательно обращаться к большим сетевым интеграторам, привыкшим работать в масштабе большого предприятия, использующего несколько сотен компьютеров с различными серверами. Вполне достаточно обратиться к компаниям, имеющим опыт создания небольших сетей, имеющих монтажников, программистов, настройщиков и, что самое главное, службу сервиса. Такая группа специалистов кроме установки сети, подключения к Интернет, сможет решить проблему с установками сетевых версий программ (например, бухгалтерских, дизайнерских, инженерных продуктов). В конце концов, каждый должен заниматься своим делом.

Мы благодарим сетевой отдел компании «Forum Computers» за помощь, оказанную при подготовке этого материала. По вопросам консультаций обращайтесь по телефонам в Москве: (095) 755-8111.

страницы: 1
Обсуждение этой статьи :: Версия для печати ::

Статьи по теме:
  • Краткий обзор клиентских версий Windows XP
  • Оптимизируем Windows XP. Часть 1
  • Файловая система NTFS
  • NTFS и FAT: скорость
  • Windows XP: что это такое и с чем ее едят


Файловая система NTFS

Статьи

+ Программы
+ Из рассылки
+ Вокруг софта

Каталог

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения

СофтОбзоры

Текущий выпуск
Архив:
Программа недели
Архив:
Программа дня
Подписка на рассылку

Поиск файлов

Files.ru
FTP Search
FileSearch.ru
| Главная | Топ-50 | Новинки | Статистика | СофтФорум| Для авторов | Помощь | Обратная связь | Рассылка |

Softodrom.ru > Статьи

Файловая система NTFS

Автор: Дмитрий Михайлов
Источник: http://www.mtu-net.ru/pinetar/dm

Дата публикации: 23.03.2002
Категория: Windows

Часть 1. Физическая структура NTFS

Начнем с общих фактов. Раздел NTFS,теоретически, может быть почти какогоугодно размера. Предел, конечно, есть, но ядаже не буду указывать его, так как его сзапасом хватит на последующие сто летразвития вычислительной техники - при любыхтемпах роста. Как обстоит с этим дело напрактике? Почти так же. Максимальный размерраздела NTFS в данный момент ограничен лишьразмерами жестких дисков. NT4, правда, будетиспытывать проблемы при попытке установкина раздел, если хоть какая-нибудь его частьотступает более чем на 8 Гб от физическогоначала диска, но эта проблема касается лишьзагрузочного раздела.

Лирическое отступление. Метод инсталляции NT4.0 на пустой диск довольно оригинален и может навести на неправильные мысли о возможностях NTFS. Если вы укажете программе установки, что желаете отформатировать диск в NTFS, максимальный размер, который она вам предложит, будет всего 4 Гб. Почему так мало, если размер раздела NTFS на самом деле практически неограничен? Дело в том, что установочная секция просто не знает этой файловой системы :) Программа установки форматирует этот диск в обычный FAT, максимальный размер которого в NT составляет 4 Гбайт (с использованием не совсем стандартного огромного кластера 64 Кбайта), и на этот FAT устанавливает NT. А вот уже в процессе первой загрузки самой операционной системы (еще в установочной фазе) производится быстрое преобразование раздела в NTFS; так что пользователь ничего и не замечает, кроме странного "ограничения" на размер NTFS при установке. :)
Структура раздела - общий взгляд

Как и любая другая система, NTFS делит всеполезное место на кластеры - блоки данных,используемые единовременно. NTFSподдерживает почти любые размеры кластеров- от 512 байт до 64 Кбайт, неким стандартом жесчитается кластер размером 4 Кбайт. Никакиханомалий кластерной структуры NTFS не имеет,поэтому на эту, в общем-то, довольнобанальную тему, сказать особо нечего.

Диск NTFS условно делится на две части.Первые 12% диска отводятся под такназываемую MFT зону - пространство, в котороерастет метафайл MFT (об этом ниже). Записькаких-либо данных в эту область невозможна.MFT-зона всегда держится пустой - этоделается для того, чтобы самый главный,служебный файл (MFT) не фрагментировался присвоем росте. Остальные 88% дискапредставляют собой обычное пространстводля хранения файлов.

Свободное место диска, однако, включает всебя всё физически свободное место -незаполненные куски MFT-зоны туда тожевключаются. Механизм использования MFT-зонытаков: когда файлы уже нельзя записывать вобычное пространство, MFT-зона простосокращается (в текущих версияхоперационных систем ровно в два раза),освобождая таким образом место для записифайлов. При освобождении места в обычнойобласти MFT зона может снова расширится. Приэтом не исключена ситуация, когда в этойзоне остались и обычные файлы: никакойаномалии тут нет. Что ж, система стараласьоставить её свободной, но ничего неполучилось. Жизнь продолжается... МетафайлMFT все-таки может фрагментироваться, хотьэто и было бы нежелательно.

MFT и его структура

Файловая система NTFS представляет собойвыдающееся достижение структуризации: каждыйэлемент системы представляет собой файл -даже служебная информация. Самый главныйфайл на NTFS называется MFT, или Master File Table -общая таблица файлов. Именно он размещаетсяв MFT зоне и представляет собойцентрализованный каталог всех остальныхфайлов диска, и, как не парадоксально, себясамого. MFT поделен на записи фиксированногоразмера (обычно 1 Кбайт), и каждая записьсоответствует какому либо файлу (в общемсмысле этого слова). Первые 16 файлов носятслужебный характер и недоступныоперационной системе - они называютсяметафайлами, причем самый первый метафайл -сам MFT. Эти первые 16 элементов MFT -единственная часть диска, имеющаяфиксированное положение. Интересно, чтовторая копия первых трех записей, длянадежности (они очень важны) хранится ровнопосередине диска. Остальной MFT-файл можетрасполагаться, как и любой другой файл, впроизвольных местах диска - восстановитьего положение можно с помощью его самого,"зацепившись" за самую основу - запервый элемент MFT.

Метафайлы

Первые 16 файлов NTFS (метафайлы) носятслужебный характер. Каждый из них отвечаетза какой-либо аспект работы системы.Преимущество настолько модульного подходазаключается в поразительной гибкости -например, на FAT-е физическое повреждение всамой области FAT фатально дляфункционирования всего диска, а NTFS можетсместить, даже фрагментировать по диску,все свои служебные области, обойдя любыенеисправности поверхности - кроме первых 16элементов MFT.

Метафайлы находятся корневом каталоге NTFSдиска - они начинаются с символа имени"$", хотя получить какую-либоинформацию о них стандартными средствамисложно. Любопытно, что и для этих файловуказан вполне реальный размер - можноузнать, например, сколько операционнаясистема тратит на каталогизацию всеговашего диска, посмотрев размер файла $MFT. Вследующей таблице приведены используемые вданный момент метафайлы и их назначение.

$MFT | сам MFT
$MFTmirr | копия первых 16 записей MFT, размещенная посередине диска
$LogFile | файл поддержки журналирования (см. ниже)
$Volume | служебная информация - метка тома, версия файловой системы, т.д.
$AttrDef | список стандартных атрибутов файлов на томе
$. | корневой каталог
$Bitmap | карта свободного места тома
$Boot | загрузочный сектор (если раздел загрузочный)
$Quota | файл, в котором записаны права пользователей на использование дискового пространства (начал работать лишь в NT5)
$Upcase | файл - таблица соответствия заглавных и прописных букв в имен файлов на текущем томе. Нужен в основном потому, что в NTFS имена файлов записываются в Unicode, что составляет 65 тысяч различных символов, искать большие и малые эквиваленты которых очень нетривиально.
Файлы и потоки

Итак, у системы есть файлы - и ничего кромефайлов. Что включает в себя это понятие наNTFS?

  • Прежде всего, обязательный элемент - запись в MFT, ведь, как было сказано ранее, все файлы диска упоминаются в MFT. В этом месте хранится вся информация о файле, за исключением собственно данных. Имя файла, размер, положение на диске отдельных фрагментов, и т.д. Если для информации не хватает одной записи MFT, то используются несколько, причем не обязательно подряд.
  • Опциональный элемент - потоки данных файла. Может показаться странным определение "опциональный", но, тем не менее, ничего странного тут нет. Во-первых, файл может не иметь данных - в таком случае на него не расходуется свободное место самого диска. Во-вторых, файл может иметь не очень большой размер. Тогда идет в ход довольно удачное решение: данные файла хранятся прямо в MFT, в оставшемся от основных данных месте в пределах одной записи MFT. Файлы, занимающие сотни байт, обычно не имеют своего "физического" воплощения в основной файловой области - все данные такого файла хранятся в одном месте - в MFT.

Довольно интересно обстоит дело и сданными файла. Каждый файл на NTFS, в общем-то,имеет несколько абстрактное строение - унего нет как таковых данных, а есть потоки(streams). Один из потоков и носит привычный намсмысл - данные файла. Но большинствоатрибутов файла - тоже потоки! Таким образом,получается, что базовая сущность у файлатолько одна - номер в MFT, а всё остальноеопционально. Данная абстракция можетиспользоваться для создания довольноудобных вещей - например, файлу можно "прилепить"еще один поток, записав в него любые данные -например, информацию об авторе и содержаниифайла, как это сделано в Windows 2000 (самаяправая закладка в свойствах файла,просматриваемых из проводника). Интересно,что эти дополнительные потоки не видныстандартными средствами: наблюдаемыйразмер файла - это лишь размер основногопотока, который содержит традиционныеданные. Можно, к примеру, иметь файл нулевойдлинны, при стирании которого освободится 1Гбайт свободного места - просто потому, чтокакая-нибудь хитрая программа илитехнология прилепила в нему дополнительныйпоток (альтернативные данные)гигабайтового размера. Но на самом деле втекущий момент потоки практически неиспользуются, так что опасаться подобныхситуаций не следует, хотя гипотетически онивозможны. Просто имейте в виду, что файл наNTFS - это более глубокое и глобальное понятие,чем можно себе вообразить простопросматривая каталоги диска. Ну инапоследок: имя файла может содержать любыесимволы, включая полый набор национальныхалфавитов, так как данные представлены вUnicode - 16-битном представлении, которое дает65535 разных символов. Максимальная длинаимени файла - 255 символов.

Каталоги

Каталог на NTFS представляет собойспецифический файл, хранящий ссылки надругие файлы и каталоги, создаваяиерархическое строение данных на диске.Файл каталога поделен на блоки, каждый изкоторых содержит имя файла, базовыеатрибуты и ссылку на элемент MFT, который ужепредоставляет полную информацию обэлементе каталога. Внутренняя структуракаталога представляет собой бинарноедерево. Вот что это означает: для поискафайла с данным именем в линейном каталоге,таком, например, как у FAT-а, операционнойсистеме приходится просматривать всеэлементы каталога, пока она не найдетнужный. Бинарное же дерево располагаетимена файлов таким образом, чтобы поискфайла осуществлялся более быстрым способом- с помощью получения двухзначных ответовна вопросы о положении файла. Вопрос, накоторый бинарное дерево способно датьответ, таков: в какой группе, относительноданного элемента, находится искомое имя -выше или ниже? Мы начинаем с такого вопросак среднему элементу, и каждый ответ сужаетзону поиска в среднем в два раза. Файлы,скажем, просто отсортированы по алфавиту, иответ на вопрос осуществляется очевиднымспособом - сравнением начальных букв.Область поиска, суженная в два раза,начинает исследоваться аналогичнымобразом, начиная опять же со среднегоэлемента.

Вывод - для поиска одного файла среди 1000,например, FAT придется осуществить в среднем500 сравнений (наиболее вероятно, что файлбудет найден на середине поиска), а системена основе дерева - всего около 10-ти (2^10 = 1024).Экономия времени поиска налицо. Не стоит,однако думать, что в традиционных системах(FAT) всё так запущено: во-первых, поддержаниесписка файлов в виде бинарного деревадовольно трудоемко, а во-вторых - даже FAT висполнении современной системы (Windows2000 илиWindows98) использует сходную оптимизациюпоиска. Это просто еще один факт в вашукопилку знаний. Хочется также развеятьраспространенное заблуждение (которое ясам разделял совсем еще недавно) о том, чтодобавлять файл в каталог в виде дереватруднее, чем в линейный каталог: этодостаточно сравнимые по времени операции -дело в том, что для того, чтобы добавить файлв каталог, нужно сначала убедится, что файлас таким именем там еще нет :) - и вот тут-то влинейной системе у нас будут трудности споиском файла, описанные выше, которые слихвой компенсируют саму простотудобавления файла в каталог.

Какую информацию можно получить, простопрочитав файл каталога? Ровно то, что выдаеткоманда dir. Для выполнения простейшейнавигации по диску не нужно лазить в MFT закаждым файлом, надо лишь читать самую общуюинформацию о файлах из файлов каталогов.Главный каталог диска - корневой - ничем неотличается об обычных каталогов, кромеспециальной ссылки на него из началаметафайла MFT.

Журналирование

NTFS - отказоустойчивая система, котораявполне может привести себя в корректноесостояние при практически любых реальныхсбоях. Любая современная файловая системаоснована на таком понятии, как транзакция- действие, совершаемое целиком и корректноили не совершаемое вообще. У NTFS просто небывает промежуточных (ошибочных илинекорректных) состояний - квант измененияданных не может быть поделен на до и послесбоя, принося разрушения и путаницу - онлибо совершен, либо отменен.

Пример 1: осуществляетсязапись данных на диск. Вдруг выясняется, чтов то место, куда мы только что решилизаписать очередную порцию данных, писать неудалось - физическое повреждениеповерхности. Поведение NTFS в этом случаедовольно логично: транзакция записиоткатывается целиком - система осознает,что запись не произведена. Место помечаетсякак сбойное, а данные записываются в другоеместо - начинается новая транзакция.

Пример 2: более сложныйслучай - идет запись данных на диск. Вдруг,бах - отключается питание и системаперезагружается. На какой фазеостановилась запись, где есть данные, а гдечушь? На помощь приходит другой механизмсистемы - журнал транзакций. Дело в том, чтосистема, осознав свое желание писать надиск, пометила в метафайле $LogFile это своесостояние. При перезагрузке это файлизучается на предмет наличия незавершенныхтранзакций, которые были прерваны аварией ирезультат которых непредсказуем - все этитранзакции отменяются: место, в котороеосуществлялась запись, помечается сновакак свободное, индексы и элементы MFTприводятся в с состояние, в котором они былидо сбоя, и система в целом остаетсястабильна. Ну а если ошибка произошла призаписи в журнал? Тоже ничего страшного:транзакция либо еще и не начиналась (идеттолько попытка записать намерения еёпроизвести), либо уже закончилась - то естьидет попытка записать, что транзакция насамом деле уже выполнена. В последнемслучае при следующей загрузке система самавполне разберется, что на самом деле всё итак записано корректно, и не обратитвнимания на "незаконченную"транзакцию.

И все-таки помните, что журналирование - неабсолютная панацея, а лишь средствосущественно сократить число ошибок и сбоевсистемы. Вряд ли рядовой пользователь NTFSхоть когда-нибудь заметит ошибку системыили вынужден будет запускать chkdsk - опытпоказывает, что NTFS восстанавливается вполностью корректное состояние даже присбоях в очень загруженные дисковойактивностью моменты. Вы можете дажеоптимизировать диск и в самый разгар этогопроцесса нажать reset - вероятность потерьданных даже в этом случае будет очень низка.Важно понимать, однако, что системавосстановления NTFS гарантируеткорректность файловой системы, ане ваших данных. Если вы производили записьна диск и получили аварию - ваши данныемогут и не записаться. Чудес не бывает.

Сжатие

Файлы NTFS имеют один довольно полезныйатрибут - "сжатый". Дело в том, что NTFSимеет встроенную поддержку сжатия дисков -то, для чего раньше приходилосьиспользовать Stacker или DoubleSpace. Любой файл иликаталог в индивидуальном порядке можетхранится на диске в сжатом виде - этотпроцесс совершенно прозрачен дляприложений. Сжатие файлов имеет оченьвысокую скорость и только одно большоеотрицательное свойство - огромнаявиртуальная фрагментация сжатых файлов,которая, правда, никому особо не мешает.Сжатие осуществляется блоками по 16кластеров и использует так называемые "виртуальныекластеры" - опять же предельно гибкоерешение, позволяющее добиться интересныхэффектов - например, половина файла можетбыть сжата, а половина - нет. Это достигаетсяблагодаря тому, что хранение информации окомпрессированности определенныхфрагментов очень похоже на обычнуюфрагментацию файлов: например, типичнаязапись физической раскладки для реального,несжатого, файла:

кластеры файла с 1 по 43-й хранятся в кластерах диска начиная с 400-го
кластеры файла с 44 по 52-й хранятся в кластерах диска начиная с 8530-го
...

Физическая раскладка типичного сжатогофайла:

кластеры файла с 1 по 9-й хранятся в кластерах диска начиная с 400-го
кластеры файла с 10 по 16-й нигде не хранятся
кластеры файла с 17 по 18-й хранятся в кластерах диска начиная с 409-го
кластеры файла с 19 по 36-й нигде не хранятся
....

Видно, что сжатый файл имеет "виртуальные"кластеры, реальной информации в которых нет.Как только система видит такие виртуальныекластеры, она тут же понимает, что данныепредыдущего блока, кратного 16-ти, должныбыть разжаты, а получившиеся данные как раззаполнят виртуальные кластеры - вот, по сути,и весь алгоритм.

Безопасность

NTFS содержит множество средствразграничения прав объектов - есть мнение,что это самая совершенная файловая системаиз всех ныне существующих. В теории это, безсомнения, так, но в текущих реализациях, ксожалению, система прав достаточно далекаот идеала и представляет собой хоть ижесткий, но не всегда логичный наборхарактеристик. Права, назначаемые любомуобъекту и однозначно соблюдаемые системой,эволюционируют - крупные изменения идополнения прав осуществлялись уженесколько раз и к Windows 2000 все-таки они пришлик достаточно разумному набору.

Права файловой системы NTFS неразрывносвязаны с самой системой - то есть они,вообще говоря, необязательны к соблюдениюдругой системой, если ей дать физическийдоступ к диску. Для предотвращенияфизического доступа в Windows2000 (NT5) всё жеввели стандартную возможность - об этом см.ниже. Система прав в своем текущемсостоянии достаточно сложна, и я сомневаюсь,что смогу сказать широкому читателю что-нибудьинтересное и полезное ему в обычной жизни.Если вас интересует эта тема - вы найдетемножество книг по сетевой архитектуре NT, вкоторых это описано более чем подробно.

На этом описание строение файловойсистемы можно закончить, осталось описатьлишь некоторое количество простопрактичных или оригинальных вещей.

Hard Links

Эта штука была в NTFS с незапамятных времен,но использовалась очень редко - и тем неменее: Hard Link - это когда один и тот же файлимеет два имени (несколько указателей файла-каталогаили разных каталогов указывают на одну и туже MFT запись). Допустим, один и тот же файлимеет имена 1.txt и 2.txt: если пользовательсотрет файл 1, останется файл 2. Если сотрет 2- останется файл 1, то есть оба имени, смомента создания, совершенно равноправны.Файл физически стирается лишь тогда, когдабудет удалено его последнее имя.

Symbolic Links (NT5)

Гораздо более практичная возможность,позволяющая делать виртуальные каталоги -ровно так же, как и виртуальные дискикомандой subst в DOSе. Применения достаточноразнообразны: во-первых, упрощение системыкаталогов. Если вам не нравится каталогDocuments and settings\Administrator\Documents, вы можетеприлинковать его в корневой каталог -система будет по прежнему общаться скаталогом с дремучим путем, а вы - с гораздоболее коротким именем, полностью емуэквивалентным. Для создания таких связейможно воспользоваться программой junction (junction.zip(15 Kb), 36 кб), которую написал известныйспециалист Mark Russinovich (http://www.sysinternals.com).Программа работает только в NT5 (Windows 2000), каки сама возможность. Для удалениясвязи можно воспользоваться стандартнойкомандой rd. ВНИМАНИЕ: Попытка удалениясвязи с помощью проводника или другихфайловых менеджеров, не понимающихвиртуальную природу каталога (например, FAR),приведет к удалению данных, на которыессылается ссылка! Будьте осторожны.

Шифрование (NT5)

Полезная возможность для людей, которыебеспокоятся за свои секреты - каждый файлили каталог может также быть зашифрован,что не даст возможность прочесть его другойинсталляцией NT. В сочетании со стандартными практически непрошибаемым паролем назагрузку самой системы, эта возможностьобеспечивает достаточную для большинстваприменений безопасность избранных вамиважных данных.

страницы: 1
Обсуждение этой статьи :: Версия для печати ::

Статьи по теме:
  • NTFS и FAT: скорость
  • Фрагментация NTFS
  • Краткий обзор клиентских версий Windows XP
  • Microsoft Windowx XP Plus Pack - очередные "фантики", но не только они одни...

    • система публикаций: Sanitarium WebLoG


Фрагментация NTFS

Статьи

+ Программы
+ Из рассылки
+ Вокруг софта

Каталог

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения

СофтОбзоры

Текущий выпуск
Архив:
Программа недели
Архив:
Программа дня
Подписка на рассылку

Поиск файлов

Files.ru
FTP Search
FileSearch.ru
| Главная | Топ-50 | Новинки | Статистика | СофтФорум| Для авторов | Помощь | Обратная связь | Рассылка |

Softodrom.ru > Статьи

Фрагментация NTFS

Автор: Дмитрий Михайлов
Источник: http://www.mtu-net.ru/pinetar/dm

Дата публикации: 22.03.2002
Категория: Windows

Или факты, которые Diskeeper 'забывает'нам рассказать...

В самом начале утверждалось, что NTFSне подвержена фрагментации файлов. Этооказалось не совсем так, и утверждениесменили - NTFS препятствует фрагментации.Оказалось, что и это не совсем так. То естьона, конечно, препятствует, но толк от этогоблизок к нулю... Сейчас уже понятно, что NTFS -система, которая как никакая другая предрасположенак фрагментации, что бы не утверждалосьофициально. Единственное что - логическиона не очень от этого страдает. Всевнутренние структуры построены такимобразом, что фрагментация не мешает быстронаходить фрагменты данных. Но отфизического последствия фрагментации -лишних движений головок - она, конечно, неспасает. И поэтому - вперед и с песней...

NTFS - очень экономная система.Размер кластеров в ней разумно минимален -обычно это 4 кб (на стандартных сейчасдисках в десяток-другой гигабайт). Какизвестно, система сильнее всегофрагментирует файлы когда свободное местокончается, когда приходится использоватьмелкие дырки, оставшиеся от других файлов.Тут возникает первое свойство NTFS, котороепрямо способствует серьезной фрагментации.
Диск NTFS поделен на две зоны. В началадиска идет MFT зона - зона, куда растет MFT, MasterFile Table. Зона занимает минимум 12% диска, изапись данных в эту зону невозможна. Этосделано для того, чтобы не фрагментировалсяхотя бы MFT. Но когда весь остальной дискзаполняется - зона сокращается ровно в двараза :). И так далее. Таким образом мы имеемне один заход окончания диска, а несколько.В результате если NTFS работает при диске,заполненном на около 90% - фрагментациярастет как бешенная.

  • Попутное следствие - диск, заполненныйболее чем на 88%, дефрагментировать почтиневозможно - даже API дефрагментации не можетперемещать данные в MFT зону. Может оказатьсятак, что у нас не будет свободного места дляманевра.

Далее. NTFS работает себе и работает,и всё таки фрагментируется. Этомуспособствует странный алгоритм нахождениясвободного места - второе серьезноеупущение. Если файл пишется большимикусками - всё нормально. Но если файлмедленно растет - алгоритм такой: беретсякакой-то определенный объем диска изаполняется файлом до упора. Причем поочень интересному алгоритму: сначалазаполняются большие дырки, потом маленькие.Т.е. типичное распределение фрагментовфайла по размеру на фрагментированной NTFSвыглядит так (размеры фрагментов):
16 - 16 - 16 - 16 - 16 - [скачек назад] - 15 - 15 - 15 -[назад] - 14 - 14 - 14 .... 1 - 1 - 1 -1 - 1...
Так процесс идет до самых мелкихдырок в 1 кластер, несмотря на то, что надиске наверняка есть и гораздо болеебольшие куски свободного места.

Может быть я забыл написать что-тоеще... Смысл в том, что никак нельзя сказать,что NTFS препятствует фрагментации файлов.Наоборот, она с радостью их фрагментирует.Фрагментация NTFS через пол года работыдоведет до искреннего удивления любогочеловека, знакомого с работой файловойсистемой. Поэтому приходится запускатьдефрагментатор. Но на этом все нашипроблемы не заканчиваются, а, увы, тольконачинаются...

В NT существует стандартное APIдефрагментации. Обладающее интереснымограничением для перемещения блоков файлов:за один раз можно перемещать не менее 16кластеров (!), причем начинаться этикластеры должны с позиции, кратной 16кластерам в файле. В общем, операцияосуществляется исключительно по 16кластеров. Следствия:

  • В дырку свободного места менее 16кластеров нельзя ничего переместить (кромесжатых файлов, но это тонкости).
  • Файл, будучи перемещенный в друге место,оставляет после себя (на новом месте) "временнозанятое место", дополняющее его поразмеру до кратности 16 кластерам.
  • При попытке как-то неправильно ("некратно 16") переместить файл результатчасто непредсказуем. Что-то округляется,что-то просто не перемещается.. Тем не менее,всё место действия щедро рассыпается "временнозанятым местом". Наверное о нас заботятся,чтобы мы отстали от этого места - чтобыалгоритм дефрагментации не клинило. :)
  • "Временно занятое место"освобождается через некоторое время,обычно где-то пол минуты. Гы.

Тем не менее, логично было быиспользовать это API. Его и используют.Поэтому процесс стандартнойдефрагментации, с поправками наограниченность API, идет следующими фазами,не обязательно в этом порядке:

  • Вынимание файлов из MFT зоны. Не специально- просто обратно туда их положить непредставляется возможным :) Безобидная фаза,и даже в чем то полезная.
  • Дефрагментация файлов. Безусловнополезный процесс, несколько правдаосложняемый ограничениями кратностиперемещений - файлы часто приходитсяперекладывать сильнее, чем это было былогично сделать по уму.
  • Дефрагментация MFT, виртуалки (pagefile.sys) икаталогов. Возможна через API только в Windows2000,иначе - при перезагрузке, отдельнымпроцессом, как в Diskeeper-е.
  • Складывание файлов ближе к началу - такназываемая дефрагментация свободногоместа. Вот это - воистину страшный процесс...

Допустим, мы хотим положить файлыподряд в начало диска. Кладем один файл. Оноставляет хвост занятости дополнения дократности 16. Кладем следующий - после хвоста,естественно. Через некоторое время, поосвобождению хвоста, имеем дырку <16кластеров размером. Которую потомневозможно заполнить через APIдефрагментации! В результате, дооптимизации картина свободного меставыглядела так: много дырок примерноодинакового размера. После оптимизации -одна дыра в конце диска, и много маленьких<16 кластеров дырок в заполненном файламиучастке. Какие места в первую очередьзаполняются? Правильно, находящиеся ближе кначалу диска мелкие дырки <16 кластеров...Любой файл, плавно созданный напрооптимизированном диске, будет состоятьиз дикого числа фрагментов. Да, диск потомможно оптимизировать снова. А потом еще раз..и еще.. и так - желательно каждую неделю. Бред?Реальность.

Таким образом, имеется двапримерно равнозначных варианта. Первый -часто оптимизировать диск такимдефрагментатором, смиряясь при этом с дикойфрагментацией заново созданных файлов.Второй вариант - вообще ничего не трогать, исмириться с равномерной, но гораздо болееслабой фрагментацией всех файлов на диске.

!

Пока есть один дефрагментатор,который игнорирует API дефрагментации иработает как-то более напрямую - Norton Speeddisk 5.0для NT. Когда его пытаются сравнить со всемиостальными - Diskeeper, O&O defrag, т.д. - неупоминают этого главного, самогопринципиального, отличия. Просто потому,что эта проблема тщательно скрывается, покрайней мере уж точно не афишируется накаждом шагу. Speeddisk - единственная насегодняшний день программа, которая можетоптимизировать диск полностью, не создаваямаленьких незаполненных фрагментовсвободного места. Стоит добавить также, что стандартное API не может дефрагментировать тома NTFS с кластером более 4 Кбайт - а SpeedDisk, по прежнему, может.

К сожалению, в Windows 2000 засунулидефрагментатор, который работает через API, исоответственно плодит дырки <16 кластеров.Так что как только появится (если уже непоявился) - так сразу надо качать Speeddisk дляW2k. Как некоторый вывод из всего этого - всеостальные дефрагментаторы при одноразовомприменении просто вредны. Если вызапускали его хоть раз - нужно запускать егопотом хотя бы раз в месяц, чтобы избавитсяот фрагментации новоприбывающих файлов. Вэтом основная суть сложностидефрагментации NTFS теми средствами, которыесложились исторически.

Хочется выразить огромнуюблагодарность человеку по имени Mark Russinovich (http://www.sysinternals.com),который предоставил общественности .h ипримеры использования интерфейсадефрагментации.

И напоследок - программа fv выводитколичество фрагментов в файлах текущегокаталога, а с ключом /v [имя файла] - списокразмеров блоков(фрагментов) указанногофайла, в кластерах. Знак ~ означает, чтоследующий фрагмент находился ближе кначалу диска, чем предыдущий. На всеостальные непонятные выводимые данныесоветую внимания не обращать - что-то я тудавписал, что-то было - в любом случае не оченьполезные данные :)
Написал Андрей Шабалин (a.shabalin@public.mtu.ru)

fv.rar (12 кб)
fv_source.rar (70кб) Исходные тексты (проект VC6)

Также была попытка написатьдефрагментатор :). Дело дошло до написаниямною программы, которая расчищаетуказанный участок диска, разбрасывая файлыкуда попало. Она даже работает! Ну, в умелыхруках :). В общем, вам её не запустить дажедля этой цели, слишком всё коряво - ну даразработчики меня поймут.. :) Тем не менее,основа любого дефрагментатора уже написана.Криво, правда, но дело поправимо. Комуинтересно - могу отдать и описать, как онаработает. В текущем виде какая либодеятельность отключена, единственное чтоона делает - кладет битовую картусвободного места с указанного диска в файлi4.dat. В принципе, если вы хотите посмотреть,как распределяется свободное место навашем NTFS диске - тоже полезная программа :). Яиногда её использую для этого.

страницы: 1
Обсуждение этой статьи :: Версия для печати ::

Статьи по теме:
  • Краткий обзор клиентских версий Windows XP
  • Windows XP: что это такое и с чем ее едят
  • По просьбам трудящихся: Как корректно удалить WinXP/2K и восстановить Windows 95 или 98


NTFS и FAT: скорость

Статьи

+ Программы
+ Из рассылки
+ Вокруг софта

Каталог

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения

СофтОбзоры

Текущий выпуск
Архив:
Программа недели
Архив:
Программа дня
Подписка на рассылку

Поиск файлов

Files.ru
FTP Search
FileSearch.ru
| Главная | Топ-50 | Новинки | Статистика | СофтФорум| Для авторов | Помощь | Обратная связь | Рассылка |

Softodrom.ru > Статьи

NTFS и FAT: скорость

Автор: Дмитрий Михайлов
Источник: http://www.mtu-net.ru/pinetar/dm

Дата публикации: 22.03.2002
Категория: Windows

В этой статье я попытаюсь дать оценкубыстродействию файловых систем,используемых в операционных системахWindows 95/98/ME, а также Windows NT/2000. Статья несодержит графиков и результатовтестирований, так как эти результатыслишком сильно зависят от случая, методиктестирования и конкретных систем, и неимеют почти никакой связи с реальнымположением дел. В этом материале я вместоэтого постараюсь описать общие тенденции исоображения, связанные спроизводительностью файловых систем.Прочитав данный материал, вы получитеинформацию для размышлений и сможете самисделать выводы, понять, какая система будетбыстрее в ваших условиях, и почему. Возможно,некоторые факты помогут вам такжеоптимизировать быстродействие своеймашины с точки зрения файловых систем,подскажут какие-то решения, которыеприведут к повышению скорости работы всегокомпьютера. В данном обзоре упоминаются трисистемы - FAT (далее FAT16), FAT32 и NTFS, так какосновной вопрос, стоящий передпользователями Windows2000 - это выбор междуэтими вариантами. Я приношу извинениепользователям других файловых систем, нопроблема выбора между двумя, внешнесовершенно равнозначными, вариантами совсей остротой стоит сейчас только в средеWindows2000. Я надеюсь, всё же, что изложенныесоображения покажутся вам любопытными, и высможете сделать какие-то выводы и о техсистемах, с которыми вам приходитсяработать.

Данная статья состоит из множестваразделов, каждый из которых посвящен какому-тоодному вопросу быстродействия. Многие изэтих разделов в определенных местах теснопереплетаются между собой. Тем не менее,чтобы не превращать статью в кашу, всоответствующем разделе я буду писатьтолько о том, что имеет отношение кобсуждаемый в данный момент теме, и ни о чемболее. Если вы не нашли каких-то важныхфактов в тексте - не спешите удивляться:скорее всего, вы встретите их позже. Прошувас также не делать никаких поспешныхвыводов о недостатках и преимуществах тойили иной системы, так как противоречий иподводных камней в этих рассуждениях оченьи очень много. В конце я попытаюсь собратьвоедино всё, что можно сказать обыстродействии систем в реальных условиях.

1. Теория

Самое фундаментальное свойство любойфайловой системы, влияющее набыстродействие всех дисковых операций -структура организации и храненияинформации, т.е. то, как, собственно,устроена сама файловая система. Первыйраздел - попытка анализа именно этогоаспекта работы, т.е. физической работы соструктурами и данными файловой системы.Теоретические рассуждения, в принципе,могут быть пропущены - те, кто интересуетсялишь чисто практическими аспектамибыстродействия файловых систем, могутобратиться сразу ко второй части статьи.

Для начала хотелось бы заметить, что любаяфайловая система так или иначе хранит файлы.Доступ к данным файлов - основная инеотъемлемая часть работы с файловойсистемой, и поэтому прежде всего нужносказать пару слов об этом. Любая файловаясистема хранит данные файлов в некихобъемах - секторах, которые используютсяаппаратурой и драйвером как самаямаленькая единица полезной информациидиска. Размер сектора в подавляющем числесовременных систем составляет 512 байт, и всефайловые системы просто читают этуинформацию и передают её без какой либообработки приложениям. Есть ли тут какие-тоисключения? Практически нет. Если файлхранится в сжатом или закодированном виде -как это возможно, к примеру, в системе NTFS - то,конечно, на восстановление или расшифровкуинформации тратится время и ресурсыпроцессора. В остальных случаях чтение изапись самих данных файла осуществляется содинаковой скоростью, какую файловуюсистему вы не использовали бы.

Обратим внимание на основные процессы,осуществляемые системой для доступа кфайлам:

Поиск данных файла

Выяснение того, в каких областях дискахранится тот или иной фрагмент файла -процесс, который имеет принципиальноразное воплощение в различных файловыхсистемах. Имейте в виду, что это лишь поискинформации о местоположении файла - доступк самим данным, фрагментированы они или нет,здесь уже не рассматривается, так как этотпроцесс совершенно одинаков для всехсистем. Речь идет о тех "лишних"действиях, которые приходится выполнятьсистеме перед доступом к реальным даннымфайлов.

На что влияет этот параметр: наскорость навигации по файлу (доступ кпроизвольному фрагменту файла). Любаяработа с большими файлами данных идокументов, если их размер - несколькомегабайт и более. Этот параметр показывает,насколько сильно сама файловая система страдает от фрагментации файлов.

  • NTFS способна обеспечить быстрый поиск фрагментов, поскольку вся информация хранится в нескольких очень компактных записях (типичный размер - несколько килобайт). Если файл очень сильно фрагментирован (содержит большое число фрагментов) - NTFS придется использовать много записей, что часто заставит хранить их в разных местах. Лишние движения головок при поиске этих данных, в таком случае, приведут к сильному замедлению процесса поиска данных о местоположении файла.
  • FAT32, из-за большой области самой таблицы размещения будет испытывать огромные трудности, если фрагменты файла разбросаны по всему диску. Дело в том, что FAT (File Allocation Table, таблица размещения файлов) представляет собой мини-образ диска, куда включен каждый его кластер. Для доступа к фрагменту файла в системе FAT16 и FAT32 приходится обращаться к соответствующей частичке FAT. Если файл, к примеру, расположен в трех фрагментах - в начале диска, в середине, и в конце - то в системе FAT нам придется обратиться к фрагменту FAT также в его начале, в середине и в конце. В системе FAT16, где максимальный размер области FAT составляет 128 Кбайт, это не составит проблемы - вся область FAT просто хранится в памяти, или же считывается с диска целиком за один проход и буферизируется. FAT32 же, напротив, имеет типичный размер области FAT порядка сотен килобайт, а на больших дисках - даже несколько мегабайт. Если файл расположен в разных частях диска - это вынуждает систему совершать движения головок винчестера столько раз, сколько групп фрагментов в разных областях имеет файл, а это очень и очень сильно замедляет процесс поиска фрагментов файла.

Вывод: Абсолютный лидер - FAT16, онникогда не заставит систему делать лишниедисковые операции для данной цели. Затемидет NTFS - эта система также не требуетчтения лишней информации, по крайней мере,до того момента, пока файл имеет разумноечисло фрагментов. FAT32 испытывает огромныетрудности, вплоть до чтения лишних сотенкилобайт из области FAT, если файл разбросанпо разным областям диска. Работа свнушительными по размеру файлами на FAT32 влюбом случае сопряжена с огромнымитрудностями - понять, в каком месте на дискерасположен тот или иной фрагмент файла,можно лишь изучив всю последовательностькластеров файла с самого начала,обрабатывая за один раз один кластер (черезкаждые 4 Кбайт файла в типичной системе).Стоит отметить, что если файлфрагментирован, но лежит компактной кучейфрагментов - FAT32 всё же не испытываетбольших трудностей, так как физическийдоступ к области FAT будет также компактен ибуферизован.

Поиск свободного места

Данная операция производится в том случае,если файл нужно создать с нуля илископировать на диск. Поиск места подфизические данные файла зависит от того,как хранится информация о занятых участкахдиска.

На что влияет этот параметр: наскорость создания файлов, особенно больших.Сохранение или создание в реальном временибольших мультимедийных файлов (.wav, кпримеру), копирование больших объемовинформации, т.д. Этот параметр показывает,насколько быстро система сможет найтиместо для записи на диск новых данных, икакие операции ей придется для этогопроделать.

  • Для определения того, свободен ли данный кластер или нет, системы на основе FAT должны просмотреть одну запись FAT, соответствующую этому кластеру. Размер одной записи FAT16 составляет 16 бит, одной записи FAT32 - 32 бита. Для поиска свободного места на диске может потребоваться просмотреть почти всего FAT - это 128 Кбайт (максимум) для FAT16 и до нескольких мегабайт (!) - в FAT32. Для того, чтобы не превращать поиск свободного места в катастрофу (для FAT32), операционной системе приходится идти на различные ухищрения.
  • NTFS имеет битовую карту свободного места, одному кластеру соответствует 1 бит. Для поиска свободного места на диске приходится оценивать объемы в десятки раз меньшие, чем в системах FAT и FAT32.

Вывод: NTFS имеет наиболееэффективную систему нахождения свободногоместа. Стоит отметить, что действовать "влоб" на FAT16 или FAT32 очень медленно, поэтомудля нахождения свободного места в этихсистемах применяются различные методыоптимизации, в результате чего и тамдостигается приемлемая скорость. (Одноможно сказать наверняка - поиск свободногоместа при работе в DOS на FAT32 -катастрофический по скорости процесс,поскольку никакая оптимизация невозможнабез поддержки хоть сколь серьезнойоперационной системы).

Работа с каталогами и файлами

Каждая файловая система выполняетэлементарные операции с файлами - доступ,удаление, создание, перемещение и т.д.Скорость работы этих операций зависит отпринципов организации хранения данных оботдельных файлах и от устройства структуркаталогов.

На что влияет этот параметр: наскорость осуществления любых операций сфайлом, в том числе - на скорость любойоперации доступа к файлу, особенно - вкаталогах с большим числом файлов (тысячи).

  • FAT16 и FAT32 имеют очень компактные каталоги, размер каждой записи которых предельно мал. Более того, из-за сложившейся исторически системы хранения длинных имен файлов (более 11 символов), в каталогах систем FAT используется не очень эффективная и на первый взгляд неудачная, но зато очень экономная структура хранения этих самих длинных имен файлов. Работа с каталогами FAT производится достаточно быстро, так как в подавляющем числе случаев каталог (файл данных каталога) не фрагментирован и находится на диске в одном месте.
    Единственная проблема, которая может существенно понизить скорость работы каталогов FAT - большое количество файлов в одном каталоге (порядка тысячи или более). Система хранения данных - линейный массив - не позволяет организовать эффективный поиск файлов в таком каталоге, и для нахождения данного файла приходится перебирать большой объем данных (в среднем - половину файла каталога).
  • NTFS использует гораздо более эффективный способ адресации - бинарное дерево, о принципе работы которого можно прочесть в другой статье (Структура NTFS). Эта организация позволяет эффективно работать с каталогами любого размера - каталогам NTFS не страшно увеличение количества файлов в одном каталоге и до десятков тысяч.
    Стоит заметить, однако, что сам каталог NTFS представляет собой гораздо менее компактную структуру, нежели каталог FAT - это связано с гораздо большим (в несколько раз) размером одной записи каталога. Данное обстоятельство приводит к тому, что каталоги на томе NTFS в подавляющем числе случаев сильно фрагментированы. Размер типичного каталога на FAT-е укладывается в один кластер, тогда как сотня файлов (и даже меньше) в каталоге на NTFS уже приводит к размеру файла каталога, превышающему типичный размер одного кластера. Это, в свою очередь, почти гарантирует фрагментацию файла каталога, что, к сожалению, довольно часто сводит на нет все преимущества гораздо более эффективной организации самих данных.

Вывод: структура каталогов на NTFSтеоретически гораздо эффективнее, но приразмере каталога в несколько сотен файловэто практически не имеет значения.Фрагментация каталогов NTFS, однако, увереннонаступает уже при таком размере каталога.Для малых и средних каталогов NTFS, как это непечально, имеет на практике меньшеебыстродействие.

Преимущества каталогов NTFS становятсяреальными и неоспоримыми только в томслучае, если в одно каталоге присутствуюттысячи файлов - в этом случаебыстродействие компенсируетфрагментированность самого каталога итрудности с физическим обращением к данным(в первый раз - далее каталог кэшируется).Напряженная работа с каталогами,содержащими порядка тысячи и более файлов,проходит на NTFS буквально в несколько разбыстрее, а иногда выигрыш в скорости посравнению с FAT и FAT32 достигает десятков раз.

2. Практика

К сожалению, как это часто бывает вовсевозможных компьютерных вопросах,практика не очень хорошо согласуется стеорией. NTFS, имеющая, казалось бы, очевидныепреимущества в структуре, показывает ненастолько уж фантастические результаты,как можно было бы ожидать. Какие ещесоображения влияют на быстродействиефайловой системы? Каждый израссматриваемых далее вопросов вносит свойвклад в итоговое быстродействие. Помните,однако, что реальное быстродействие -результат действия сразу всех факторов,поэтому и в этой части статьи не стоитделать поспешных выводов.

2.1. Объем оперативной памяти (кэширование)

Очень многие данные современных файловыхсистем кэшируются или буферизируются впамяти компьютера, что позволяет избежатьлишних операций физического чтения данныхс диска. Для нормальной (высокопроизводительной)работы системы в кэше приходится хранитьследующие типы информации:

  • Данные о физическом местоположении всех открытых файлов. Это, прежде всего, позволит обращаться к системным файлам и библиотекам, доступ к которым идет буквально постоянно, без чтения служебной (не относящейся к самим файлам) информации с диска. Это же относится к тем файлам, которые исполняются в данный момент - т.е. к выполняемым модулям (.exe и .dll) активных процессов в системе. В эту категорию попадают также файлы системы, с которыми производится работа (прежде всего реестр и виртуальная память, различные .ini файлы, а также файлы документов и приложений).
  • Наиболее часто используемые каталоги. К таковым можно отнести рабочий стол, меню "пуск", системные каталоги, каталоги кэша интернета, и т.п.
  • Данные о свободном месте диска - т.е. та информация, которая позволит найти место для сохранения на диск новых данных.

В случае, если этот базовый объеминформации не будет доступен прямо воперативной памяти, системе придетсясовершать множество ненужных операций ещедо того, как она начнет работу с реальнымиданными. Что входит в эти объемы в разныхфайловых системах? Или, вопрос в болеепрактической плоскости - каким объемомсвободной оперативной памяти надорасполагать, чтобы эффективно работать стой или иной файловой системой?

  • FAT16 имеет очень мало данных, отвечающих за организацию файловой системы. Из служебных областей можно выделить только саму область FAT, которая не может превышать 128 Кбайт (!) - эта область отвечает и за поиск фрагментов файлов, и за поиск свободного места на томе. Каталоги системы FAT также очень компактны. Общий объем памяти, необходимый для предельно эффективной работы с FAT-ом, может колебаться от сотни килобайт и до мегабайта-другого - при условии огромного числа и размера каталогов, с которыми ведется работа.
  • FAT32 отличается от FAT16 лишь тем, что сама область FAT может иметь более внушительные размеры. На томах порядка 5 - 10 Гбайт область FAT может занимать объем в несколько Мбайт, и это уже очень внушительный объем, надежно кэшировать который не представляется возможным. Тем не менее, область FAT, а вернее те фрагменты, которые отвечают за местоположение рабочих файлов, в подавляющем большинстве систем находятся в памяти машины - на это расходуется порядка нескольких Мбайт оперативной памяти.
  • NTFS, к сожалению, имеет гораздо большие требования к памяти, необходимой для работы системы. Прежде всего, кэширование сильно затрудняет большие размеры каталогов. Размер одних только каталогов, с которыми активно ведет работу система, может запросто доходить до нескольких Мбайт и даже десятков Мбайт! Добавьте к этому необходимость кэшировать карту свободного места тома (сотни Кбайт) и записи MFT для файлов, с которыми осуществляется работа (в типичной системе - по 1 Кбайт на каждый файл). К счастью, NTFS имеет удачную систему хранения данных, которая не приводит к увеличению каких-либо фиксированных областей при увеличении объема диска. Количество данных, с которым оперирует система на основе NTFS, практически не зависит от объема тома, и основной вклад в объемы данных, которые необходимо кэшировать, вносят каталоги. Тем не менее, уже этого вполне достаточно для того, чтобы только минимальный объем данных, необходимых для кэширования базовых областей NTFS, доходил до 5 - 8 Мбайт.

К сожалению, можно с уверенностью сказать:NTFS теряет огромное количество своеготеоретического быстродействия из-занедостаточного кэширования. На системах,имеющих менее 64 Мбайт памяти, NTFSпросто не может оказаться быстрееFAT16 или FAT32. Единственное исключение изэтого правила - диски FAT32, имеющие объемдесятки Гбайт (я бы лично серьезно опасалсядисков FAT32 объемом свыше, скажем, 30 Гбайт). Востальных же случаях - системы с менее чем 64мегабайтами памяти просто обязаны работатьс FAT32 быстрее.

Типичный в настоящее время объем памяти в 64Мбайта, к сожалению, также не даетвозможности организовать эффективнуюработу с NTFS. На малых и средних дисках (до 10Гбайт) в типичных системах FAT32 будетработать, пожалуй, немного быстрее.Единственное, что можно сказать по поводубыстродействия систем с таким объемомоперативной памяти - системы, работающие сFAT32, будут гораздо сильнее страдать отфрагментации, чем системы на NTFS. Но еслихотя бы изредка дефрагментировать диски, тоFAT32, с точки зрения быстродействия, являетсяпредпочтительным вариантом. Многие люди,тем не менее, выбирают в таких системах NTFS -просто из-за того, что это даст некоторыедовольно важные преимущества, тогда кактипичная потеря быстродействия не оченьвелика.

Системы с более чем 64 Мбайтами, аособенно - со 128 Мбайт и более памяти, смогутуверенно кэшировать абсолютно всё, чтонеобходимо для работы систем, и вот на такихкомпьютерах NTFS, скорее всего, покажет болеевысокое быстродействие из-за болеепродуманной организации данных.

2.2. Быстродействие накопителя

Влияют ли физические параметры жесткогодиска на быстродействие файловой системы?Да, хоть и не сильно, но влияют. Можновыделить следующие параметры физическойдисковой системы, которые по-разному влияютна разные типы файловых систем:

  • Время случайного доступа (random seek time). К сожалению, для доступа к системным областям на типичном диске более сложной файловой системы (NTFS) приходится совершать, в среднем, больше движений головками диска, чем в более простых системах (FAT16 и FAT32). Гораздо большая фрагментация каталогов, возможность фрагментации системных областей - всё это делает диски NTFS гораздо более чувствительными к скорости считывания произвольных (случайных) областей диска. По этой причине использовать NTFS на медленных (старых) дисках не рекомендуется, так как высокое (худшее) время поиска дорожки дает еще один плюс в пользу систем FAT.
  • Наличие Bus Mastering. Bus Mastering - специальный режим работы драйвера и контроллера, при использовании которого обмен с диском производится без участия процессора. Стоит отметить, что система запаздывающего кэширования NTFS сможет действовать гораздо более эффективно при наличии Bus Mastering, т.к. NTFS производит отложенную запись гораздо большего числа данных. Системы без Bus Mastering в настоящее время встречаются достаточно редко (обычно это накопители или контроллеры, работающие в режиме PIO3 или PIO4), и если вы работаете с таким диском - то, скорее всего, NTFS потеряет еще пару очков быстродействия, особенно при операциях модификации каталогов (например, активная работа в интернете - работа с кэшем интернета).
  • Кэширование как чтения, так и записи на уровне жестких дисков (объем буфера HDD - от 128 Кбайт до 1-2 Мбайт в современных дорогих дисках) - фактор, который будет более полезен системам на основе FAT. NTFS из соображений надежности хранения информации осуществляет модификацию системных областей с флагом "не кэшировать запись", поэтому быстродействие системы NTFS слабо зависит от возможности кэширования самого HDD. Системы FAT, напротив, получат некоторый плюс от кэширования записи на физическом уровне. Стоит отметить, что, вообще говоря, всерьез принимать в расчет размер буфера HDD при оценке быстродействия тех или иных файловых систем не стоит.

Подводя краткий итог влияниюбыстродействия диска и контроллера набыстродействия системы в целом, можносказать так: NTFS страдает от медленныхдисков гораздо сильнее, чем FAT.

2.3. Размер кластера

Хотелось бы сказать пару слов о размерекластера - тот параметр, который в файловыхсистемах FAT32 и NTFS можно задавать приформатировании практически произвольно.Прежде всего, надо сказать, что большийразмер кластера - это практически всегда большее быстродействие. Размер кластера натоме NTFS, однако, имеет меньшее влияние набыстродействие, чем размер кластера длясистемы FAT32.

  • Типичный размер кластера для NTFS - 4 Кбайта. Стоит отметить, что с большим размером кластера отключается встроенная в файловую систему возможность сжатия индивидуальных файлов, а также перестает работать встроенный API дефрагментации - т.е. подавляющее число дефрагментаторов, в том числе встроенный в Windows 2000, будут неспособны дефрагментировать этот диск. SpeedDisk, впрочем, сможет - он работает не через это API. Оптимальным с точки зрения быстродействия, по крайней мере, для средних и больших файлов, считается (самой Microsoft) размер 16 Кбайт. Увеличивать размер далее неразумно из-за слишком больших расходов на неэффективность хранения данных и из-за мизерного дальнейшего увеличения быстродействия. Если вы хотите повысить быстродействие NTFS ценой потери возможности сжатия - задумайтесь о форматировании диска с размером кластера, большим чем 4 Кбайта. Но имейте в виду, что это даст довольно скромный прирост быстродействия, который часто не стоит даже уменьшения эффективности размещения файлов на диске.
  • Быстродействие системы FAT32, напротив, можно довольно существенно повысить, увеличив размер кластера. Если в NTFS размер кластера почти не влияет на размер и характер данных системных областей, то в системе FAT увеличивая кластер в два раза, мы сокращаем область FAT в те же два раза. Вспомните, что в типичной системе FAT32 эта очень важная для быстродействия область занимает несколько Мбайт. Сокращение области FAT в несколько раз даст заметное увеличение быстродействия, так как объем системных данных файловой системы сильно сократиться - уменьшается и время, затрачиваемое на чтение данных о расположении файлов, и объем оперативной памяти, необходимый для буферизирования этой информации. Типичный объем кластера для систем FAT32 составляет тоже 4 Кбайт, и увеличение его до 8 или даже до 16 Кбайт - особенно для больших (десяток и более гигабайт) дисков - достаточно разумный шаг.

2.4. Другие соображения

NTFS является достаточно сложной системой,поэтому, в отличие от FAT16 и FAT32, имеются идругие факторы, которые могут привести ксущественному замедлению работы NTFS:

  • Диск NTFS был получен преобразованием раздела FAT16 или FAT32 (команда convert). Данная процедура в большинстве случаев представляет собой тяжелый случай для быстродействия, так как структура служебных областей NTFS, скорее всего, получится очень фрагментированной. Если есть возможность - избегайте преобразования других систем в NTFS, так как это приведет к созданию очень неудачного диска, которому не поможет даже типичный (неспециализированный) дефрагментатор, типа Diskeeper-а или встроенного в Windows 2000.
  • Активная работа с диском, заполненным более чем на 80% - 90%, представляет собой катастрофический для быстродействия NTFS случай, так как фрагментация файлов и, самое главное, служебных областей, будет расти фантастически быстро. Если ваш диск используется в таком режиме - FAT32 будет более удачным выбором при любых других условиях.

3. Выводы

В данной заключительной части "однойстрочкой" собраны ключевые особенностибыстродействия этих трех файловых систем.

FAT - плюсы:

  • Для эффективной работы требуется немного оперативной памяти.
  • Быстрая работа с малыми и средними каталогами.
  • Диск совершает в среднем меньшее количество движений головок (в сравнении с NTFS).
  • Эффективная работа на медленных дисках.

FAT - минусы:

  • Катастрофическая потеря быстродействия с увеличением фрагментации, особенно для больших дисков (только FAT32).
  • Сложности с произвольным доступом к большим (скажем, 10% и более от размера диска) файлам.
  • Очень медленная работа с каталогами, содержащими большое количество файлов.

NTFS - плюсы:

  • Фрагментация файлов не имеет практически никаких последствий для самой файловой системы - работа фрагментированной системы ухудшается только с точки зрения доступа к самим данным файлов.
  • Сложность структуры каталогов и число файлов в одном каталоге также не чинит особых препятствий быстродействию.
  • Быстрый доступ к произвольному фрагменту файла (например, редактирование больших .wav файлов).
  • Очень быстрый доступ к маленьким файлам (несколько сотен байт) - весь файл находится в том же месте, где и системные данные (запись MFT).

NTFS - минусы:

  • Существенные требования к памяти системы (64 Мбайт - абсолютный минимум, лучше - больше).
  • Медленные диски и контроллеры без Bus Mastering сильно снижают быстродействие NTFS.
  • Работа с каталогами средних размеров затруднена тем, что они почти всегда фрагментированы.
  • Диск, долго работающий в заполненном на 80% - 90% состоянии, будет показывать крайне низкое быстродействие.

Хотелось бы еще раз подчеркнуть, что напрактике основной фактор, от которогозависит быстродействие файловой системы -это, как ни странно, объем памяти машины.Системы с памятью 64-96 Мбайт - некий рубеж, накотором быстродействие NTFS и FAT32 примерноэквивалентно. Обратите внимание также насложность организации данных на вашеймашине. Если вы не используете ничего, кромепростейших приложений и самой операционнойсистемы - может случиться так, что FAT32 сможетпоказать более высокое быстродействие и намашинах с большим количеством памяти.

NTFS - система, которая закладывалась набудущее, и это будущее для большинствареальных применений сегодняшнего дня еще, ксожалению, видимо не наступило. На данныймомент NTFS обеспечивает стабильное иравнодушное к целому ряду факторов, но,пожалуй, всё же невысокое - на типичной "игровой"домашней системе - быстродействие. Основноепреимущество NTFS с точки зрениябыстродействия заключается в том, что этойсистеме безразличны такие параметры, каксложность каталогов (число файлов в одномкаталоге), размер диска, фрагментация и т.д.В системах FAT же, напротив, каждый из этихфакторов приведет к существенному снижениюскорости работы.

Только в сложных высокопроизводительныхсистемах - например, на графическихстанциях или просто на серьезных офисныхкомпьютерах с тысячами документов, или, темболее, на файл-серверах - преимуществаструктуры NTFS смогут дать реальный выигрышбыстродействия, который порой заметенневооруженным глазом. Пользователям, неимеющим большие диски, забитые информацией,и не пользующимся сложными программами, нестоит ждать от NTFS чудес скорости - с точкизрения быстродействия на простых домашнихсистемах гораздо лучше покажет себя FAT32.

страницы: 1
Обсуждение этой статьи :: Версия для печати ::

Статьи по теме:
  • Фрагментация NTFS
  • Краткий обзор клиентских версий Windows XP
  • Windows XP: что это такое и с чем ее едят
  • Microsoft Windowx XP Plus Pack - очередные "фантики", но не только они одни...


Оптимизируем Windows XP. Часть 1

Статьи

+ Программы
+ Из рассылки
+ Вокруг софта

Каталог

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения

СофтОбзоры

Текущий выпуск
Архив:
Программа недели
Архив:
Программа дня
Подписка на рассылку

Поиск файлов

Files.ru
FTP Search
FileSearch.ru
| Главная | Топ-50 | Новинки | Статистика | СофтФорум| Для авторов | Помощь | Обратная связь | Рассылка |

Softodrom.ru > Статьи

Оптимизируем Windows XP. Часть 1

Автор: Joel Durham Jr.
http://www.extremetech.com/
Источник: http://tech.stolica.ru

Дата публикации: 23.03.2002
Категория: Windows

Является ли XP самой быстрой среди всех других версий Windows? Вопрос тот обсуждается уже очень давно, мнения на этот счет бытуют разные, а ни конца ни края разговорам на эту тему не видно. Даже на нашем сайте вы сможете найти пару статей по этому вопросу. Зато не подлежит сомнению, что, подобно всем другим операционным системам до нее, WinXP сразу после установки работает отнюдь не так шустро, как могла бы. А чтобы добиться от нее максимума производительности, необходимо проделать немало операций по настройке.

Все операционные системы Windows никогда не имели оптимальных настроек при установке по-умолчанию. Частично причиной тому является тот факт, что инсталляционная база этих ОС просто огромна - она во много раз превышает инсталляционную базу других операционных систем (хотя, может быть, если собрать все остальные вместе, то что-то близкое и получится. Независимо от того насколько хорошо могла бы быть оптимизирована любая из операционных систем Windows, Microsoft вынуждена балансировать межу производительность, простотой использования и совместимостью со всем на свете.

Так уж получается, что Windows XP сама наводит на мысль, что с ней надо что-то проделать. (Мне тут подсказывают, что делать - format c: ). Интерфейс XP задумывался с целью придать ОС приятный, естественный, дружественный вид, но в результате выходит, что всякие визуальные эффекты, типа отбрасывания теней и плавно выдвигающихся меню, немало тормозят работу всей системы. Такие важные и нужные утилиты, как System Restore, способны помочь восстановить работоспособность вашей системы после сбоев или выявления различного рода несовместимостей существенно проще и надежнее, чем раньше, но они при этом пожирают дисковое пространство как троглодты, а их тихая и незаметная работа в фоновом режиме отбирает на себе процессорное время, обделяя все остальные приложения, как буржуазия мировой пролетариат.

Так же Windows XP по-умолчанию активизирует немалое количество служб и сервисов, независимо от ваших потребностей, всегда найдутся те, которые вам абсолютно не нужны. Настройка пула системных процессов позволяет ускорить процесс загрузки ОС и экономить некоторую часть процессорного времени. К тому же такие, присутствующие практически на каждом компьютере программные пакеты, как Microsoft Office, грузят в бэкграунд свои приложения, пожирающие немало системной памяти и ресурсов процессора.

Потратив не очень много времени на выявление приложений и сервисов, которые вам не нужны, и подсократив количество визуальных эффектов XP, можно довольно существенно повысить производительность и игровых и офисных приложений. Сама XP несколько помогает нам, оптимизируя файловую систему, основываясь на наших привычках (надпись на экране курильщика - "Табак убивает" ;-), а Microsoft позаботилась о наличии в составе ОС нескольких приложений, ускоряющих процесс оптимизации.

Большее число действий по оптимизации,которые мы будем в этой статье рассматривать, потребуют от вас редактирования системного реестра или внесения иных изменений в конфигурацию операционной системы. Не забывайте, что для этого вам понадобятся права администратора. Перед тем как начать, следует завершить все антивирусные программы и тому подобные приложения, и сделать резервное копирование важных данных на какой-либо внешний носитель. Это вовсе не означает, что мы будем заниматься какой-либо разрушительной деятельностью, просто, на Бога надейся, а сам к берегу греби.

Windows XP имеет огромное количество настроек. Microsoft позаботилась о том, чтобы пользователи самого различного уровня подготовки могли получить доступ к максимальному количеству настроек операционной системы. Экспериментируя с ними и не боясь запачкать руки, копаясь в завалах дефолтовых настроек ОС, чтобы в результате получить оптимальное для соотношение удобного и приятного внешнего вида ОС и ее производительности.

Самым простым способом начать настройку Windows XP, является простое ее использование. Когда вы запускаете программы и работаете с ними, Windows следит за вашими действиями, после чего вносит изменения в динамический файл Layout.ini. Каждые три дня, в моменты когда компьютер простаивает, ОС изменяет местоположение программ на жестком диске, для оптимизации их запуска и исполнения.

XP так же ускоряет процесс загрузки и оптимизирует запуск программ, используя систему предсказаний. Windows изучает программы, которые используются при загрузке и немедленно после нее, создавая списки данных, для предсказаний на ранних стадиях загрузки. Аналогичным же образом, когда запускаются отдельные программы, Windows ведет списки различных файлов и компонент, к которым программа обращается. Когда программа запускается в следующий раз, Windows имеет возможность предсказать, какие файлы могут потребоваться для ее старта.

Оптимизирующий код предсказаний присутствует как в ядре XP, так и в службе планировщика задач. Ядро начинает создание списка ресурсов, к которым обращается конкретный процесс, немедленно после его создания. Служба планировщика преобразует эти записи в инструкции предсказаний для данного процесса. В следующий раз при создании процесса ядро исполняет инструкции предсказаний, ускоряя создание процесса.

Оптимизация диска и механизм предсказаний загрузки системы и запуска приложений работают в тандеме. Так что когда XP оптимизирует файлы на диске для быстро к ним доступа со стороны программ, то она использует данные, записанные блоком предсказаний, для определения оптимального размещения файлов на диске.

Иконки и обои

Хороший рабочий стол - это эффективный рабочий стол. Для оперативной памяти вашего компьютера и для процессора можно отыскать гораздо лучшее применение, чем игры с симпатичненькими обоями и сортировка восьмидесяти пяти иконок на десктопе. Как и в случае с предыдущими версиями Windows, и иконки рабочего стола и обои постоянно находятся в оперативной памяти, и постоянно обновляются средствами графической системы. А уж анимированные рабочие столы пожирают столько системных ресурсов, что мама не балуйся.

Хотя, с другой сторон, выигрыш в производительности при отказе от вышеперечисленных "красот" минимален. Так что, если в вашем компьютере 256Мб оперативной памяти или больше, и более менее современный процессор (что-то не слабее 800МГц), то волноваться насчет влияния иконок и обоев рабочего стола на производительность системы вам не стоит. Однако владельцам систем с процессором Celeron 333МГц и объёмом оперативной памяти 64Мб следует экономить каждый такт процессора и каждый байт памяти.

Отключаем эффекты

Кроме простой возможности менять скины, Windows XP в плане визуализации имеет гораздо больше возможностей, чем любая ОС от Microsoft до нее. Меню могут быть анимированными, у диалоговых окон и мышиных курсоров могут быть тени, экранные шрифты настраиваются на максимальную читабельность и так далее.

Все это очень здорово, только не следует забывать, что все эти визуальные эффекты и возможности замедляют работу пользовательского интерфейса. XP при установке автоматически (и совершенно скрыто от пользователя) прогоняет несколько системных тестов для определения оптимальных с ее точки зрения (если у операционной системы может быть точка зрения) настроек графического интерфейса пользователя, которые должны совмещать красоту и удобство использования (для определения последнего мне очень нравится термин "юзабилити"). Но принятые на стадии установки ОС решения можно довольно просто изменить. Если плавно выпадающие меню больше раздражают, чем радуют глаз, а тени у диалоговых окон волнуют вас меньше, чем рождение десятого ребенка в китайской семье , живущей в предгорьях Гималаев, вы можете со спокойной совестью поэкспериментировать с визуальными настройками ОС и добиться от нее своей собственной, единственной и неповторимой золотой середины.

Некоторые из этих настроек доступны через закладку Appearance (Оформление) диалогового окна Display Properties (Свойства Экрана), доступ к которому можно получить, кликнув на пустом пространстве рабочего стола и выбрав из всплывающего меню пункт Properties (Свойства). Кликните по кнопке эффекты, и в появившемся диалоге настраивайте себе поведение меню, теней и свойства шрифтов сколько душе вашей угодно. Что касается шрифтов, то тут же вы найдете и возможность активизировать новую технологию сглаживания экранных шрифтов, придуманную Microsoft, которая называется ClearType. По поводу ее применения у меня есть свое личное мнение. Мне кажется, что ClearType позволяет прекрасно отображать фонты на экранах ноутбуков и ЖК-мониторах, а на обычных CRT экранах эту опцию лучше отключать, так она делает изображение несколько размытым. При этом есть у меня знакомые, которые придерживаются абсолютно противоположного мнения, то есть считают, что ClearType на плоскопанельных экранах выглядит просто отвратительно. Так что вам лучше самим попробовать и принять собственное решение по этому поводу.

Дальнейшую настройку графического интерфейса пользователя вы можете выполнять, используя утилиту System Properties (Свойства Системы). Запустить ее можно из Control Panel (Панели Управления) или кликнув правой кнопкой мыши по иконке My Computer (Мой компьютер) и выбрав в меню пункт Properties (Свойства). На закладке Advanced (Дополнительно) вы обнаружите переключатели, позволяющие сделать выбор между настройками ОС на оптимальную (с точки зрения ее создателей) производительность либо пожертвовать этой производительностью в пользу красивого внешнего вида. Специально для тех, кто не доверяет специалистам по настройке из Microsoft (а кто им доверяет?), вы можете создать свою схему настроек операционной системы, помечая или снимая отметки в списке визуальных эффектов.

Так же на закладке Advanced (Дополнительно) диалога Performance Options (Настройка производительности) убедитесь, что использование процессора и памяти настроены на работу с программами (впрочем, именно эта опция включена по-умолчанию). Конфигурировать память и процессор на оптимальную работу кэша фоновых служб и сервисов вам может понадобиться только в случае, если вы настраиваете сервер. Тут же у вас есть возможность указать размер и местоположение системного файла подкачки. Хотя, на самом деле, Windows XP проделывает колоссальную работу, управляя размером собственного файла подкачки автоматически, приходится признать, что делает она это просто прекрасно. Самое интенсивное тестирование, включавшее в себя и синтетические тесты и игровые бенчмарки, убедило нас в полном отсутствии какой-либо необходимости устанавливать параметры файла подкачки вручную.

Быстрое переключение пользователей

Быстрое переключение пользователей доступно в XP Home Edition и Professional. Когда компьютер не является членом домена, то быстрое переключение пользователей позволит пользователям одного и того же компьютера переключаться между учетными записями без выхода из системы.

Когда в систему входит больше одного пользователя, то настройки каждого остаются активными, а программы запущенные под разными учетными записями остаются открытыми, даже если кто-то переключится на чужой аккаунт.

Теперь посмотрим чем это грозит. Предположим глава семьи работал, работал, устал и оставил открытыми Word и Excel. затем пришла его младшая дочь и немного побаловалась с Barbie Fashion Designer и тоже оставила любимую программу открытой. Пришел с института ее старший брат, переключился на свою учетную запись и со злости на преподавателя по сопромату решил немного поиграть в Red Faction. И тут то его ждет разочарование, тут ему придется осознать, что производительность системы резко упала по сравнению с тем разом, когда он играл в выходные, а все остальные члены семьи уехали на дачу и ни кто не вешал в память бедного компьютера кучу ненужных молодому оболтусу программ.

Windows XP автоматически отключает возможность быстрого переключения пользователей, если на компьютере, куда ее устанавливают объем оперативной памя составляет 64Мб или меньше. Если вам кажется, что компьютер стал работать медленнее, чем обычно, и вы чувствуете себя в роли того старшего брата, которого я вам только что описал, убедитесь, что в данный момент в систему вошел только один пользователь. А при необходимости просто отключите саму возможность такого входа в систему: открывайте Control Panel(Панель Управления)\User Accounts(Учетные записи пользователей), нажмите кнопку "Change the way users log on or off" (Изменение порядка входа в систему), и снимите отметку с опции "Use Fast User Switching"(Использовать быстрое переключение пользователей).

Автоматическое обновление

Уже из опыта предыдущих версий Windows можно сделать вывод, что лучше постоянно следить за выходом различных новых патчей, исправлений ошибок, обновленных версий DirectX, решений проблем совместимости и всяких других обновлений. Тут WinXP отнюдь не является исключением. Посмотрите сами сколько обновлений для нее уже выпустила MS, хотя самой операционке не исполнилось еще и полгода. Но вам не придется самостоятельно следить за выходом всех этих обновлений, не придется отыскивать ссылки в новостях на различных сайтах, посвященных компьютерной тематике или усердно копаться в недрах неисчерпаемого по мегабайтам сайта самой MS. По-умолчанию всю эту работу за вас проделывает сама XP. Казалось бы надо радоваться такой трогательной заботе о пользователе. Но подвох заключается в том, что для этого требуется небольшая программка, вечно висит в фоновом режиме и регулярно проверяет или напоминает вам проверить наличие новых обновлений Windows.

Если вы способны провести процедуру обновления Windows самостоятельно, то можете совершенно смело дать XP указания не беспокоиться больше по этому вопросу. Настройку выполнения процедуры автоматического обновления (Automatic Updates) вы найдете в диалоговом окне System Properties (Свойства Системы). Тут вы можете указать Windows самой определять, какие обновления системе необходимы, а после автоматически их скачивать, можете заставить ее только проверять наличие обновлений и предупреждать вас об этом, а можете сказать ей не делать вообще ничего.

Восстановление системы (System Restore)

System Restore относится к разряду действительно полезных приложений, так что до тех пор пока вы не решите для себя, что программы или игры, которые вы ежедневно используете, требуют от компьютера большего, чем он может дать в текущем состоянии, вам лучше оставить System Restore в покое. Эта служба периодически создает "моментальные снимки" всех важных системных файлов (таких как файлы системного реестра, базы данных COM+, профили пользователей, и т.д.) и сохраняет их в качестве "точки восстановления". Если вас вдруг угораздило установить программу, которая нарушила работоспособность операционной системы, вы можете спокойно вернуться к предыдущему состоянию, в котором она была, продолжать работать ни о чем не беспокоясь.

Точки восстановления автоматически генерируются службой System Restore при возникновении ряда событий, таких как установка нового программного обеспечения, выполнение процедуры обновления Windows, установка непописанного драйвера или любые другие события способные негативно влиять на работу операционной системы. Так же ни кто не мешает пользователю создать точку восстановления самостоятельно вручную в любой момент времени. Естественно, что работа этой службы влияет на производительность системы, а сохраненная информация о точках восстановления занимает место на жестком диске. Вы можете контролировать объем свобдного места, доступный для System Restore (что в конечном счете влияет на количество точек восстановления, которое эта служба может создать), или отключить ее совсем. Проделываются все эти операции на закладке System Restore (Восстановление ситемы) окна System Properties (Свойства Системы).

Точки восстановления автоматически генерируются службой System Restore при возникновении ряда событий, таких как установка нового программного обеспечения, выполнение процедуры обновления Windows, установка неподписанного драйвера или любые другие события способные негативно влиять на работу операционной системы. Так же ни кто не мешает пользователю создать точку восстановления самостоятельно вручную в любой момент времени. Естественно, что работа этой службы влияет на производительность системы, а сохраненная информация о точках восстановления занимает место на жестком диске. Вы можете контролировать объем свободного места, доступный для System Restore (что в конечном счете влияет на количество точек восстановления, которое эта служба может создать), или отключить ее совсем. Проделываются все эти операции на закладке System Restore (Восстановление системы) окна System Properties (Свойства Системы).

Окно настроек System Restore содержит список всех разделов жесткого диска. Вы можете для каждого раздела в отдельности указа указать, какой процент от его объема может быть задействован для нужд System Restore. Там же вы найдете "выключатель" System Restore, который позволит вам отключить данную службу совсем.

В активном состоянии служба System Restore может значительно влиять на производительность системы, особенно сильно это проявляется при проведении различных тестов на производительность, в связи с чем тестовые лаборатории всегда отключают System Restore в таких ОС как XP и Me перед проведением тестов.

страницы: 1
Обсуждение этой статьи :: Версия для печати ::

Статьи по теме:
  • Windows XP: что это такое и с чем ее едят
  • Microsoft Windowx XP Plus Pack - очередные "фантики", но не только они одни...
  • Краткий обзор клиентских версий Windows XP
  • NTFS и FAT: скорость


Статьи

+ Из рассылки
+ Вокруг софта

Каталог

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения

СофтОбзоры

Текущий выпуск
Архив:
Программа недели
Архив:
Программа дня
Подписка на рассылку

Поиск файлов

Files.ru
FTP Search
FileSearch.ru
| Главная | Топ-50 | Новинки | Статистика | СофтФорум| Для авторов | Помощь | Обратная связь | Рассылка |

Softodrom.ru > Статьи

По просьбам трудящихся:
Как корректно удалить Windows XP/2K и восстановить Windows 95 или 98

Автор: Евгений А. Соболев
Источник: http://softodrom.ru
Категория: Windows

31.10.2001

Конечно, проще всего было бы послать трудящихся к разработчику всех этих операционных систем - на сайт Microsoft, добавив - кто ищет, тот всегда найдет, но я ведь прекрасно понимаю, что там без труда можно заблудиться, поэтому перескажу официальную позицию MS по поводу удаления WinXP/2K и последующей установки Win9*. Ну и от себя, конечно, кое-что добавлю.

Прежде всего, следует отметить, что Windows 9* можно устанавливать только на жесткий диск с файловой системой FAT, поэтому, если вы отформатировали диск 'С' в NTFS, потребуется хирургическое вмешательство, т.е. переформатирование его в FAT, причем совсем необязательно терять при этом находящиеся на диске данные: программа PartitionMagic умеет преобразовывать файловые системы без потери данных. Заодно, если есть необходимость, сможете и размеры разделов изменить, и тоже без потери находящихся на них данных...

Кроме этого, необходимо подчеркнуть, что "восстановить" Windows 9* не получится - поставить-то ее, конечно, вы сможете, но все установленные ранее программы придется инсталлировать заново. Потеряются и все настройки, имевшиеся в WinXP/2K.

А теперь перейдем собственно к процессу удаления Windows XP/2K. Допустим, что диск 'C' был отформатирован в NTFS - файловую систему, которую ни MS-DOS, ни Windows 95/98/Me не понимают. В случае, если необходимости сохранить то, что находится на жестком диске, нет, переформатировать диск в FAT можно двумя способами:

  • загрузиться с загрузочной дискеты Win9* (думаю, она у вас сохранилась), скомандовать FDISK и сначала удалить основной раздел (или все разделы NTFS, если их несколько), а затем создать заново, после чего отформатировать его в FAT

  • воспользоваться Панелью восстановления (Recovery Console): загрузиться с установочного компакт-диска WinXP/2K (или воспользоваваться созданными четырьмя дискетами Startup disks от Win2K) и после появления экрана "Welcome to Setup" нажать клавишу F10, выбрать соответствующую установку и ввести пароль Администратора. После этого следует напечатать map и нажать Enter, а затем скомандовать format x: /fs:fat32, где x - имя диска, файловую систему которого нужно преобразовать в FAT (напомню, что этот способ, как и предыдущий, приводит к уничтожению всех данных, находящихся на диске). Ну и, наконец, следует нажать y, подтвердив тем самым введенную команду, а после окончания форматирования - перезагрузить компьютер.

    Если WinXP/2K устанавливалась на диск с FAT (или после конвертации NTFS в FAT без потери данных) необходимо будет удалить те файлы и папки от WInXP/2K, которые Windows 95/98 будут мешать или просто не нужны. Удаляем файлы Pagefile.sys и Hyberfil.sys, а также папки Recycle Bin, Windows (или WinNT, т.е. ту папку, в которую производилась установка WinXP/2K) и Program Files.

    Сохранять папки Windows и Program Files не только не имеет смысла, но и вредно: мало того, что Windows 9* при установке все равно перезапишет системный реестр и поэтому потребуется переустановка всех ранее установленных программ, так еще при инсталляции наверняка произойдут глюки - операционная система может не понять, что ей нужно поменять новые версии системных файлов (те, что останутся от WInXP/2K, если папки Program Files и Windows не удалить) на их более старые версии. Кроме того, имеет смысл удалить системную папку Documents and Settings - в Windows 9* эта папка не нужна, а также удалить файлы Boot.ini, Ntbootdd.sys, Ntdetect.com и NTLDR.

    Все, теперь можно приступать к установке Windows 9*. Хотя, честно говоря, я так и не понял, зачем вам потребовалось менять W2K и уж тем более WinXP на Windows 98. Про Windows 95 я вообще промолчу...

    Чуть не забыл про еще один возможный вариант - когда Windows 9* была в свое время установлена на диск 'C', а XP или 2K - на другой, например 'D'. В этом случае достаточно загрузиться с системной дискеты Windows 9*, дождаться появления на экране строки a:\ с мигающим курсором, ввести команду sys c: и перезагрузить компьютер (предварительно удалив дискету). Потом можно будет для освобождения места на диске 'D' удалить относящиеся к XP/2K папки (прежде всего - ту, куда была установлена сама операционная система, и папку Documents and Settings). Файлы Pagefile.sys, Hyberfil.sys, Boot.ini, Ntbootdd.sys, Ntdetect.com и NTLDR тоже можно будет безбоязненно удалить.


Статьи

+ Из рассылки
+ Вокруг софта

Каталог

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения

СофтОбзоры

Текущий выпуск
Архив:
Программа недели
Архив:
Программа дня
Подписка на рассылку

Поиск файлов

Files.ru
FTP Search
FileSearch.ru
| Главная | Топ-50 | Новинки | Статистика | СофтФорум| Для авторов | Помощь | Обратная связь | Рассылка |

Softodrom.ru > Статьи

Windows XP: что это такое и с чем ее едят

Автор: Евгений А. Соболев
Источник: http://softodrom.ru
Категория: Windows

22.09.2001

По слухам, с 23 сентября крупнейшие поставщики начнут поставлять заказчикам компьютеры с предустановленной операционной системой Windows XP, в которой сливаются воедино две существовавшие до сих пор линейки Windows ("домашняя" Windows 9*/Me и "корпоративная" NT/2000), так что счастливые покупатели этих компьютеров смогут познакомиться с новой операционной системой за месяц до начала ее официальной продажи, намеченной на 25 октября. Будем считать, что я уже стал одним из этих счаcтливчиков, решившим поделиться своими впечатлениями от новинки...

Итак, Windows XP Professional build 2600 (есть еще Home, т.е. "домашняя" версия, но эта приставка лично у меня вызывает ощущение, что подсовывают что-то недоделанное или, вернее, не обладающее всеми нужными мне функциями, поэтому о "home" речь пока идти не будет). Так вот, что бросилось в глаза прежде всего (буду перечислять по мере бросания):
  • загрузка Windows идет со свистом - значительно быстрее, чем загружается и NT, и 2K, да и, пожалуй, Windows 9* грузится тоже чуть медленнее
  • интерфейс. Он стал каким-то модненько-красивеньким, а не понравится тот, что "по умолчанию", его можно и заменить - в комплект поставки входит три темы (скина), к тому же допускается вообще отказаться от разукрашивания ОС и продолжать пользоваться "классическим" стилем окон. Кроме скинов для смены всего интерфейса, обнаружилось множество визуальных примочек вроде обьемного текста в подписях к иконкам
  • новое меню Пуск (Start), в котором в дополнение ко всем установленным программам при желании отображаются и те программы, что недавно запускались
  • в системном лотке (где расположены часы) появилось автоскрытие иконок от тех программ, которые, хоть и запущены, но долгое время не используются
  • Language Bar ("языковая" панель). Это теперь не только иконка на панели задач с надписью "Ru" или "Eng", но еще и опционно появляющаяся (по клику) маленькая панелька, которую при желании можно прилепить к любому удобную месту экрана, причем она всегда будет поверх открытых окон
  • работа с zip-архивами как с обычными папками; создание zip'ов собственными средствами
  • набор новых интернет-игр
  • добавилась возможность работать с CD-R(W) без установки дополнительных программ. Эта фича входит в Windows Media Player 8, поставляемый вместе с WinXP. Кстати, Internet Explorer 6 тоже несколько другой, чем тот, что не для Windows XP - более разукрашенный, что ли...
  • новая система восстановления ОС с возможностью "слепка" системы и последующим откатом до этого слепка;
  • довольно много новых утилит для администрирования: удаленный полноэкранный доступ, удобная настройка списка программ, которые загружаются автоматом из реестра; новая утилита сетевой диагностики и штук двадцать (а может, и тридцать) новых утилит, работающих из командной строки
  • крайне полезная вещица - визарды для переноса настроек и документов между эккаунтами и для перехода на новый диск или машину
  • значительно улучшена система Plug & Play - автоматический поиск нового оборудования и установка соответствующих драйверов для него
  • новая (и, как мне показалось, значительно более удобная) система помощи

    Вот, пожалуй, и все, что бросилось в глаза, хотя наверняка я перечислил далеко не все, чем примечательна новая ОС. Ах да, чуть не забыл о принципиально новой фиче - необходимости "активации" установленной операционной системы. Заключается это действо в том, что после установки системы ее необходимо ее активировать, т.е. ввести специальный код, который можно будет узнать, сообщив свой номер копии Windows в местное отделение службы техподдержки Microsoft (или через Интернет, или по телефону). Если же этого не сделать, то через некоторое время, а точнее - через 30 дней, операционная система работать откажется ... Кстати, в коропоративной версии Windows XP (есть, вроде бы, и такой вариант - при покупке многопользовательской лицензии), а также в большинстве тех копий, что предустанавливаются на новые машины, системы активации нет. Это, опять же, только по слухам...

    Пара слов о стабильности работы и установке Windows XP. Установка - если железо не слишком левое - должна пройти без проблем, вообще же Windows XP довольно строго относится к тому, куда ее хотят впихнуть, и часто взбрыкивает, если ее пытаются поставить на компьютер с кривой материнской платой, спаянной на коленке в каком-нибудь сарае, или до предела разогнанным процессором.
    Что касается стабильности работы, то я не заметил - по сравнению с Windows 2000 - ни ее ухудшения, ни особенного улучшения; впрочем, и та стабильность, что была в Windows 2K, меня вполне устраивала. Учитывая, что Windows NT/2000 до сих пор являются почти экзотикой, скажу по-другому: Windows XP падает значительно более реже, чем операционные системы Windows 95/98/Me, причем "значительно более реже" означает, что система cможет работать не то что сутками, а и неделями...

    В виде заключения - о том, на каких машинах может работать Windows XP. Формально - на тех же, что и Windows 2000 (минимум - 233 MHz/64 MB RAM, но рекомендуется процессор не ниже 300 МГц и 128 МБ ОЗУ), а на практике получилось вот что: Pentium II 300 MHz 256 MB RAM - работает без заметного торможения, Pentium II 400 MHz 72 MB RAM - небольшое торможение, Pentium 200 128 MB RAM - работает примерно так же, как и c Windows 2000 (то есть работать можно). Это то, что я видел своими собственными глазами; другими словами, если компьютер не очень древний, то вполне можно поставить на него Windows XP, желательно только увеличить обьем оперативной памяти хотя бы до 128 MB.

    Продолжение


Статьи

+ Из рассылки
+ Вокруг софта

Каталог

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения

СофтОбзоры

Текущий выпуск
Архив:
Программа недели
Архив:
Программа дня
Подписка на рассылку

Поиск файлов

Files.ru
FTP Search
FileSearch.ru
| Главная | Топ-50 | Новинки | Статистика | СофтФорум| Для авторов | Помощь | Обратная связь | Рассылка |

Softodrom.ru > Статьи

Windows XP: что это такое и с чем ее едят
Часть вторая

Автор: Евгений А. Соболев
Источник: http://softodrom.ru
Категория: Windows

23.09.2001

Начало

Продолжая обзор Windows XP, поподробнее остановлюсь на принципиальных отличиях этой системы от Windows 95/98/Me.

Если вкратце, то Windows XP построена на ядре (т.е. основном программном коде) Windows NT/2000, что делает ее значительно более эффективной, безопасной и стабильной по сравнению с Windows 95/98/Me. Тот, кто пользуется Windows NT/2K, знает, что даже в тех случаях, когда происходит сбой в программе, компьютер в большинстве случаев продолжает работать, чего практически никогда не происходит при использовании Windows 95/98/Me - вместо продолжения работы в таких случаях, как правило, появляется экран смерти ОС или она просто-напросто наглухо зависает.

Второе принципиальное отличие Windows XP - возможность использования не только файловых систем FAT16 и FAT32, но и значительно более безопасной и надежной файловой системы NTFS. Использование NTFS повышает безопасность компьютера, т.к. эта файловая система допускает защиту данных (файлов и папок) путем их шифрования и возможности установки запрета на доступ к ним. Кроме этого, NTFS обеспечивает более высокую степень сжатия информации и полную поддержку разделов и файлов большого размера.

Учитывая, что Windows XP поддерживает не только NTFS, но и FAT16, и FAT32, на одном компьютере можно запускать не только Windows XP, но и более ранние версии Windows. Для этого используется конфигурация с двойной загрузкой, причем в случае установки Windows XP не в виде обновления Windows 95/98/Me, а в новый каталог мультизагрузчик для запуска нескольких операционных систем будет установлен автоматически, так что вам лишь останется в начальной стадии загрузки компьютера выбрать ту операционную систему, которая требуется в этом сеансе работы.

Несколько слов о слиянии двух линеек Windows, о чем было вскользь упомянуто в первой части этого обзора. Как известно, Windows 95/98/Me являются операционными системами, предназначенными прежде всего для домашних пользователей, и они обладают, по сравнению с "корпоративными" Windows NT, таким преимуществом, как простота установки оборудования за счет системы Plug & Play (включи и работай); кроме этого, в "домашних" окошках были значительно лучше развиты различные мультимедийные "примочки".
Windows XP, обладая надежностью операционных систем NT/2000, получила даже более удобную и простую в использовании, чем в Windows 98/Me, систему Plug & Play, практически полностью автоматизирующую установку нового оборудования, плюс приобрела полный набор мультимедийных средств, включая функции видеозаписи и проведения видеоконференций.

Таким образом, Windows XP, оставаясь надежной, безопасной и эффективной ОС из-за применения при ее построении ядра NT, приобрела те функции (включая простоту использования), которые были до сих пор присущи только "домашним" операционным системам, что и позволило прекратить разделение операционных систем семейства Windows на "домашние" и "рабочие". Несмотря на это, Windows XP поступит в продажу в двух модификациях - Home Edition и Professional, и на их различиях мы сейчас и остановимся.

Чего же нет в Windows XP Home Edition? - А вот чего:

  • Отсутствует удаленный доступ к компьютеру, что делает невозможным подключение в удаленном режиме к компьютеру, работающему под управлением Windows XP, с любого другого компьютера под управлением Windows (а ведь эта функция очень полезна в случае необходимости работать с приложениями и данными, если часто находишься вдалеке от "основного" компьютера)
  • Нет доступа к файлам и папкам, хранящимся на общем сетевом диске даже во время отключения компьютера от сервера (эта фича, как я понимаю, нужна только в локальной сети)
  • Удалены функции по работе с серверами Microsoft Windows Server и системами управления предприятиям ("Home" ведь не является предприятием)
  • Еще один минус - отсутствует многоязычный пользовательский интерфейс, позволяющий менять язык интерфейса, чтобы работать с локализованными диалоговыми окнами, файлами справки, словарями, средствами проверки правописания и т.п. Другими словами, в WinXP Pro заложена возможность менять интерфейс самой операционной системы: сел за компьютер, к примеру, китаец, кликнул пару раз, и английская версия XP превратилась в китайскую (но это можно проделывать только в том случае, если будут установлены специальные языковые модули - в инсталляционном CD их нет).
  • Отсутствует возможность использования шифрования данных и управления доступа к ним
  • Нет масштабируемой поддержки процессора (Pro - вплоть до поддержки двусторонней многопроцессорной обработки), но у многих ли из нас многопроцессорные системы?
Обобщая: из Windows XP Home Edition исключены те компоненты, которые, по разумению Microsoft, не нужны при домашнем использовании операционной системы. Насколько верно выбраны те компоненты, что "не нужны", судить не берусь, но разница в стоимости двух редакций Windows XP настолько ощутима, что наверняка стоит задуматься, а так ли уж нужен, к примеру, удаленный доступ к компьютеру...

А теперь - мое личное мнение о том, стоит ли переходить с Windows 9*/Me на XP: если железо позволяет (про кошелек разговор отдельный), то однозначно стоит, потому что с переходом на Windows XP вы приобретете не только надежную (что уже прекрасно), но и настоящую операционную систему вместо той так и не доведенной до ума, что именуется Windows 95, 98 или Millennium.

Продолжение


Статьи

+ Из рассылки
+ Вокруг софта

Каталог

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения

СофтОбзоры

Текущий выпуск
Архив:
Программа недели
Архив:
Программа дня
Подписка на рассылку

Поиск файлов

Files.ru
FTP Search
FileSearch.ru
| Главная | Топ-50 | Новинки | Статистика | СофтФорум| Для авторов | Помощь | Обратная связь | Рассылка |

Softodrom.ru > Статьи

Windows XP: что это такое и с чем ее едят
Часть третья

Автор: Евгений А. Соболев
Источник: http://softodrom.ru
Категория: Windows

23.09.2001

Начало

В заключение обзора новой операционной системы - несколько дополнений, уточнений, а также еще один важный вопрос: какое программное обеспечение совместимо с Windows XP.

Прежде всего - о некоторых возможностях Windows XP, которые могут быть не сразу обнаружены, но от этого не становящихся менее полезными. Речь идет о новом подходе к поиску файлов и информации на компьютере, в локальной сети или Интернете и усовершенствованиях в интернет-защите.

В Windows XP Pro процесс поиска значительно изменен за счет дополнения Search Companion, позволившего объединить задачу поиска с оптимизацией наиболее типичных сценариев поиска. Так, при поиске текстового документа совсем необязательно знать расширение файла или название документа - допустимо выполнять поиск по приблизительному времени, когда документ использовался в предыдущий раз, или просто выбрать "Документы"; подобный же принцип допустим и в отношении графических, аудио и видеофайлов, тоже выделенных в отдельную категорию. Кроме этого, использование Search Companion позволяет при поиске информации в Интернете вводить запрос поиска на естественном языке.

Интернет-защита. Тут следует отметить появление защиты системы от вирусов и общую защиту системы при работе в Интернете.
Защита от вирусов включает в себя средства ограничения работы приложений, позволяющие не только сделать работу приложений строго контролируемой (т.е. пользователь может сам решать, когда и где может запускаться код, включая полный запрет на работу какого-либо конкретного кода или, например, запрет на запуск приложений, которые не проверены антивирусной программой), но и допускающие полную изоляцию вызывающего подозрения кода в специальной области памяти, где он будет находиться до тех пор, пока не будет установлена его безопасность (или опасность). Подчеркну, что такой способ изоляции позволяет безбоязненно использовать даже подозрительное программное обеспечение - оно не сможет повредить систему.

Средства интернет-защиты Windows XP позволяют защититься от зараженных вирусами вложений в сообщения электронной почты, а также от ссылок, которые могут запустить Internet Explorer или другое приложение и загрузить веб-страницу, содержащую опасный внедренный макрос; есть в Windows XP и средства для защиты от опасных элементов управления ActiveX, загружаемых из Интернета. Наконец, Windows XP имеет расширенные возможности по управлению файлами "cookie", а также легко включаемый файрволл (Internet Connection Firewall), обеспечивающий приемлемый уровень безопасности при подключении к Интернету домашней сети или сети малого предприятия.

И еще чуть-чуть об Интернете, точнее, о подсистеме удаленного доступа в Интернет. В отличие от Windows 9*/Me, Windows XP имеет вполне рабочий, а не ущербный "удаленный доступ" - с возможностью дозваниваться до провайдера сразу по нескольким телефонам и допустимостью разрешения (или запрета) подключаться к Интернету с вашим логином/паролем другим пользователям компьютера. Ну и, раз уж речь зашла о паролях, нельзя не отметить и такой приятный факт: в Windows XP нельзя войти, не введя пароль (это вам не домашние окошки с издевательской кнопкой "Отменить"), как нельзя и вытащить пароли из файла *.pwl - никакого подобного файла в этой операционной системе нет...

И последняя тема - какое программное обеспечение будет работать в Windows XP. Прежде всего уточню, что Windows XP, в отличие от Windows 95/98/Me, является по-настоящему 32-битной операционной системой. Да-да, несмотря на широко распространенное заблуждение о 32-битности всей линейки Windows, даже самая последняя "домашняя" версия - Millennium - содержит большое число 16-битных подсистем.

Так вот, 32-битная Windows XP допускает использование только 32-битных программ, так что старые 16-битные программы в этой операционной системе работать не будут. Не будут работать в Windows XP и те программы, что написаны специально для Windows 9* и при этом используют прямое обращение к жесткому диску и другим аппаратным средствам - Windows XP запрещает это по соображениям безопасности.

Большинство остальных программ - как предназначенных для "домашних" Windows (если они написаны грамотно, а не на коленке - лишь бы шевелились, и не используют каких-либо специализированных функций Windows 9*), так и тех, о которых пишут, что они - для Windows 9*/Me/NT/2000, будут работать и в Windows XP. Правда, может оказаться, что некоторые из программ после установки Windows XP начнут работать не совсем так, как хотелось бы, но это - дело наверняка поправимое: уже сейчас, за месяц до начала розничной продажи Windows XP, появляется все больше новых версий самого разнообразного программного обеспечения, авторы которого в "что нового" первым пунктом указывают - "поддержка Windows XP"...


Статьи

+ Из рассылки
+ Вокруг софта

Каталог

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения

СофтОбзоры

Текущий выпуск
Архив:
Программа недели
Архив:
Программа дня
Подписка на рассылку

Поиск файлов

Files.ru
FTP Search
FileSearch.ru
| Главная | Топ-50 | Новинки | Статистика | СофтФорум| Для авторов | Помощь | Обратная связь | Рассылка |

Softodrom.ru > Статьи

Windows XP FAQ

Автор: Евгений А. Соболев
Источник: http://softodrom.ru
Категория: Windows

Версия от 2.05.2002

Новое:
  • Система не загружается...
  • Как удалять файлы, минуя "мусорную корзину"?
  • Можно ли в WinXP снимать задачи из командной строки?
  • Как переименовать сразу несколько файлов?
  • Можно ли отключить работу с zip-архивами как с папками?
  • Допускается ли, не перелогиниваясь, запускать программы от имени другого пользователя?
  • Как автоматизировать вход в систему - без ввода логина и пароля?
  • Как восстановить повреждённый загрузчик XP?

Общие вопросы
  • Что такое Windows XP?
  • Что включает в себя Windows XP Plus Pack?
  • Предусматривается ли установка Windows XP сверху на уже установленную, например, Windows 2000?
  • Чем отличается WinXP Professional от WinXP Home?
  • Как русифицировать английскую Windows XP?
  • Есть ли в Windows XP средства для работы с видео?
  • Как в XP обстоят дела с совместимостью со старыми программами (играми)?
  • Что представляет собой система восстановления Windows XP?
  • Слышал, что в WinXP есть система восстановления файлов. Она что, все файлы восстанавливает?
  • Как работает шифрование файлов?
  • Что такое Remote Assistance?
  • А Remote Desktop?
  • Что за новый подкаталог WinSxS с dll-ками появился в каталоге Windows? Для чего он?
  • Что такое NTFS?
  • В чем отличие NTFS4 от NTFS5?
  • Стоит ли переходить на NTFS? И как это сделать?
  • Что такое boot defrag и для чего это?
  • Можно ли установить WinXP так, чтобы остался и Windows 98?
  • Как корректно удалить WinXP/2K и восстановить Windows 95 или 98?
  • Что за режим выключения компьютера - Hibernate?
  • Что такое иконки Windows XP?
  • Можно ли в WinXP снимать задачи из командной строки"?
  • Как переименовать сразу несколько файлов?
  • Допускается ли, не перелогиниваясь, запускать программы от имени другого пользователя?
Настройка
  • Можно ли уменьшить размер Windows XP?
  • А что это в XP хелп такой урезанный?
  • Что можно предпринять для оптимизации Windows XP?
  • Как удалить "скрытые" компоненты Windows XP?
  • Можно ли самому создать скин для Windows XP?
  • Можно ли заменить картинку в меню "Start" рядом с моим именем на мою фотку?
  • Позволяет ли эта версия Windows вносить изменения в файл config.sys?
  • Какие из драйверов больше подходят для WinXP - от NT или 2K?
  • Для чего нужна вкладка Compatibility в свойствах exe-файла?
  • Хочу заменить файл в папке System32, а Windows ругается и не дает. Что делать?
  • Windows все время хочет обновиться и пытается лезть в Интернет. Это безобразие можно прекратить?
  • Как включить интернет-защиту?
  • Где находятся те утилиты, о которых говорится в обзоре Windows XP?
  • Вроде бы Microsoft уже выпустила пакет дополнений для Windows XP. Откуда его можно скачать?
  • Можно ли в XP снимать с аудио-CD цифровой звук?
  • Как запустить дефрагментатор из контекстого меню Проводника?
  • Как выставить права пользователям, работающим на компьютере?
  • Как зайти в систему администратором (пользователь Administrator)?
  • Как включить mp3-кодирование с высоким битрейтом?
  • Как изменить интервал синхронизации системных часов компьютера с time-сервером?
  • Как изменить число открытых окон программы, при достижении которого на панели задач включается режим их группировки в одну кнопку?
  • Можно ли в окне "Welkome" изменить шрифты на сглаженные (cleartype)?
  • А что, в XP нет своего факса?
  • Как удалять файлы, минуя "корзину"?
  • Как переименовать папку аккаунта Administrator?
  • Как сделать, чтобы при перезагрузке стирался/создавался заново файл подкачки pagefile.sys?
  • Как мне залочить компьютер? Через Crtl+Alt+Del не получается...
  • Как сделать, чтобы зависшие и переставшие отвечать задачи убивались автоматически
  • Откуда загружаются программы при старте системы? У меня папка Автозагрузка пустая...
  • Можно ли ввести компьютер в состояние Hibernate из командной строки?
  • Как изменить time-server, используемый для подстройки системного времени?
  • Можно ли отключить сообщение о недостатке свободного места на диске?
  • Как отключить появление предложения об отправке рапорта об ошибке?
  • Можно ли сделать так, чтобы определенная папка открывалась по горячей клавише?
  • Как добавить содержимое Рабочего стола в меню Start?
  • Как (и можно ли вообще) уменьшить размеры огромных файлов Pagefile.sys и Hyberfil.sys?
  • Как удалить с рабочего стола все системные иконки, включая корзину?
  • Как отключить автозапуск компакт-дисков?
  • Куда подевалась закладка Security на NTFS-дисках и почему так упростилась закладка Sharing?
  • Как назначить диску другую букву?
  • А как обстоят дела в WinXP с переименованием загрузочного (или системного) диска?
  • Можно ли отключить отображение zip-архивов как папок?
  • Можно ли полностью отключить скрытые общие ресурсы (ADMIN$, C$ и т.д.)?
  • Вопрос по сети. Как включить роутинг?
  • Как автоматизировать вход в систему - без ввода логина и пароля?
Разрешение проблем
  • Система стала глючить или пропали системные шрифты
  • Почему вместо русских букв видны какие-то закорючки?
  • DOS: русские буквы видны, а вот раскладка не переключается. Что делать?
  • Для особо забывчивых: как создать дискету для сброса пароля
  • Проблема с инсталляцией программ: программа вроде бы устанавливается, но в конце все исчезает, хотя процесс остается в памяти
  • Установка Windows 9*/Me после установки Windows XP
  • Что делать, если после перезагрузки система не находит внешний модем?
  • Почему в режиме Standby не выключаются вентиляторы на блоке питания и процессоре?
Восстановление
  • Что представляет собой система восстановления Windows XP?
  • Слышал, что в WinXP есть система восстановления файлов. Она что, все файлы восстанавливает?
  • Система не загружается...
  • Как добавить прав в Recovery Console?
  • Как восстановить повреждённый загрузчик XP?
  • Где хранится код активации Windows XP?
  • Можно ли в WinXP сделать загрузочные дискеты?


Статьи

+ Из рассылки
+ Вокруг софта

Каталог

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения

СофтОбзоры

Текущий выпуск
Архив:
Программа недели
Архив:
Программа дня
Подписка на рассылку

Поиск файлов

Files.ru
FTP Search
FileSearch.ru
| Главная | Топ-50 | Новинки | Статистика | СофтФорум| Для авторов | Помощь | Обратная связь | Рассылка |

Softodrom.ru > Статьи

Windows XP FAQ

Автор: Евгений А. Соболев
Источник: http://softodrom.ru
Категория: Windows

Общие вопросы

Что такое Windows XP?

Windowx XP - это новая операционная система, обьединяющая, по словам Microsoft, две существовавших ранее независимо друг от друга линейки Windows - "домашнюю" Windows 95/98/Me и "профессиональную" NT/2000. О моих первых впечателениях от знакомства с Windows XP можно узнать из заметки, которая так и называется - Windows XP: что это такое и с чем ее едят.

Предусматривается ли установка Windows XP сверху на уже установленную, например, Windows 2000?

Конечно, и при этом будут сохранены все существующие настройки. Операционные системы Windows NT/2000 можно обновить до Windows XPProfessional, а Windows 98/98SE/Me - до любой из двух редакций Windows XP (Home Edition и Professional). Windows XP, кстати, будет продаваться как в "полном" варианте, так и в виде обновления (стоимостью подешевше). Единственное условие - обновляемая операционная система должна иметь тот же язык интерфейса, что и устанавливаемая Windows XP, иначе обновление будет невозможно.

К сожалению, пользователи Windows 3.1, Windows 95 и Windows NT 3.51 лишены возможности обновить свою систему до Windows XP - установить Windows XP они, конечно, смогут, но имевшиеся настройки не сохранятся, да и ранее инсталлированные программы придется переустанавливать.

Чем отличается WinXP Professional от WinXP Home?

Чего же нет в Windows XP Home Edition? - А вот чего:

  • Отсутствует удаленный доступ к компьютеру, что делает невозможным подключение в удаленном режиме к компьютеру, работающему под управлением Windows XP, с любого другого компьютера под управлением Windows (а ведь эта функция очень полезна в случае необходимости работать с приложениями и данными, если часто находишься вдалеке от "основного" компьютера)
  • Нет доступа к файлам и папкам, хранящимся на общем сетевом диске даже во время отключения компьютера от сервера (эта фича, как я понимаю, нужна только в локальной сети)
  • Удалены функции по работе с серверами Microsoft Windows Server и системами управления предприятиям ("Home" ведь не является предприятием)
  • Еще один минус - отсутствует многоязычный пользовательский интерфейс, позволяющий менять язык интерфейса, чтобы работать с локализованными диалоговыми окнами, файлами справки, словарями, средствами проверки правописания и т.п. Другими словами, в WinXP Pro заложена возможность менять интерфейс самой операционной системы: сел за компьютер, к примеру, китаец, кликнул пару раз, и английская версия XP превратилась в китайскую (но это можно проделывать только в том случае, если будут установлены специальные языковые модули - в инсталляционном CD их нет).
  • Отсутствует возможность использования шифрования данных и управления доступа к ним
  • Нет масштабируемой поддержки процессора (Pro - вплоть до поддержки двусторонней многопроцессорной обработки), но у многих ли из нас многопроцессорные системы?
Обобщая: из Windows XP Home Edition исключены те компоненты, которые, по разумению Microsoft, не нужны при домашнем использовании операционной системы. Насколько верно выбраны те компоненты, что "не нужны", судить не берусь, но разница в стоимости двух редакций Windows XP настолько ощутима, что наверняка стоит задуматься, а так ли уж нужен, к примеру, удаленный доступ к компьютеру...

Как русифицировать английскую WinXP?

Частично (процентов на сорок) русифицировать интерфейс английской версии Windows XP Professional можно патчем, меняющим языковые ресурсы в парочке файлов. Подробности - здесь.
Есть и другой способ, причем значительно более эффективный - позволяющий не только полностью перевести инфтерфейс Windows XP на русский язык, но и переключить на русский язык встроенную систему помощи. Заключается он в установке Multilingual User Interface - специального модуля для быстрого переключения операционной системы с одной локализации на другую. Распространяется этот модуль на компакт-дисках (т.е. скачать его легальную копию через Интернет нельзя, да и не маленький он - русский модуль занимает около 100 мб).Обратите внимание - использовать Multilingual User Interface можно только в Windows XP Professional.

Есть ли в Windows XP средства для работы с видео?

Кроме фирменного медиаплеера (Windows Media Player 8), воспроизводящего локальные и потоковые файлы Windows Media, а также многие другие форматы аудио и видеофайлов, в Windows XP входит новый компонент - Movie Maker, предназначенный для создания и редактирования цифровых видеофильмов. Ну и, конечно, есть возможность пользоваться сканером, а также перегонять фотографии из цифрового фотоаппарата на жесткий диск компьютера.

Как в XP обстоят дела с совместимостью со старыми программами (играми)?

Несмотря на то, что ядро NT, являющееся основой Windows XP, накладывает некоторые ограничения на совместимость со старым программным обеспечением, однако (по сравнению с Windows 2000) положение явно улучшилось. Например, в старых досовских игрушках появился звук. Кроме этого, стоит отметить поддержку эмуляции Sound Blaster 2 и General MIDI, поэтому в Windows XP без проблем будут работать со звуком такие "старички", как, к примеру, Duke Nukem 3D, Warcraft 1/2 или Dune 2. Наконец, не стоит забывать о таком нововведении, как режим совместимости...

Что представляет собой система восстановления Windows XP?

В самом общем плане: System Restore производит "слепок" с системного реестра и создает резервные копии других необходимых для нормального функционирования операционной системы файлов, что дает возможность в случае необходимости произвести возврат системы к прошлому состоянию. Параметры системы восстановления задаются на вкладке System Restore апплета System Properties, до которого можно добраться так: Start/Control Panel/System. Хочу обратить внимание на то, что по умолчанию System Restore включена не только для загрузочного, но и для всех остальных дисков, при этом отключить System Restore штатными средствами ОС можно у всех дисков, кроме загрузочного.
Кроме этого, с целью дополнительной защиты системы от кривых рук некоторых разработчиков программного обеспечения, в Windows XP имеется система защиты файлов

Слышал, что в WinXP есть система восстановления файлов. Она что, все файлы восстанавливает?

Нет, не все. В действительности имеющийся в Windows XP модуль Windows File Protection и вправду восстанавливает файлы, но не все, а только те из исполняемых и системных файлов (*.exe, *.dll, *.ocx и некоторые другие), которые оказались без всякой на то необходимости замененными (например, в процессе инсталляции какой-либо программы), предотвращая тем самым возможные нарушения в работе операционной системы. Дело в том, что для защиты наиболее важных файлов Microsoft ввела их цифровую подпись, и в том случае, если обнаруживается, что происходит замена системного файла другим, не имеющим такой цифровой пописи, следует немедленное оповещение пользователя, а подмененный файл заменяется "правильным", до поры до времени находящемся в специально для этого созданном хранилище. Если же "правильного" файла по какой-то причине на жестком диске не оказывается, то следует предложение вставить в CD-привод компакт-диск, с которого устанавливалась Windows XP...

Как работает шифрование файлов?

По умолчанию служба шифрования, имеющаяся в Windows XP, запускается автоматически при загрузке операционной системы, поэтому никакого дополнительного ее включения не требуется. А вот для того, чтобы зашифровать конкретный файл или папку, нужно проделать следующее: щелкаем правой кнопкой мыши по файлу/папке, выбираем в меню пункт Properties и нажимаем в появившемся окошке (на вкладке General) кнопку Advanced. После открытия новой вкладки отмечаем там пункт "Encrypt contents to secure data". Маленькое замечание: шифровать допустимо только те файлы и папки, которые размещены на дисках с файловой системой NTFS; необходимо помнить, что шифруются только несжатые данные (в том случае, если зашифровать сжатый файл или папку, они будут разжаты); не допускается шифрование файлов, отмеченных как системные, как нельзя зашифровать и системную директорию (по умолчанию это папка c:/windows). И еще: не удивляйтесь, что внешне после зашифровки файла или папки ничего не изменится - хозяин зашифрованных данных может обращаться с ними точно так же, как и с незашифрованными, а вот для всех остальных, кто войдет в систему под другим логином, зашифрованные данные окажутся недоступными...

Что такое Remote Assistance?

Remote Assistance (удаленная помощь) - еще одно новшество, включенное в Windows XP (по-моему, только в версию Pro). Теперь представители группы техподдержки могут не выезжать к пользователю, чтобы, например, научить, как менять разрешение экрана, а подключиться к его компьютеру и рассказать и, если вы разрешите, показать, как это делается - то есть удаленно настроить компьютер или устранить какую-либо неполадку в операционной системе. Естественно, удаленная помощь может быть оказана не только специалистами техподдержки, но и, например, вашим приятелем, разбирающемся в компьютерах.

А Remote Desktop?

Remote Desktop (удаленный рабочий стол) позволяет получить практически полное управление над удаленным компьютером. Весьма полезная вещь, если вы, находясь, к примеру, дома, решите поработать на компьютере, установленном на работе...

Что за новый подкаталог WinSxS с dll-ками появился в каталоге Windows? Для чего он нужен?

WinSxS, или Windows Side by Side (бок о бок), является еще одним новшеством Windows XP. Microsoft, озаботившись криворукостью программистов, создала систему, позволяющую сохранять несколько версий одинаковых библиотек (DLL) и использовать при необходимости именно ту, что требует конкретная программа. Дело в том, что некоторые программы почему-то считают, что только они имеют нужную версию DLL, и перезаписывают при инсталляции даже более новую версию библиотеки, что может привести ко всякого рода неприятностям, поэтому, если какая-нибудь программа вздумает беспричинно заменить уже имеющуюся в системном каталоге DLL, операционная система поместит сомнительную библиотеку в специальную папку (WinSxS), а дурная программа так и останется уверенной, что сделала свое черное дело...

Что такое NTFS?

NTFS - это файловая система, которую не понимает Windows 9*/Me. Учитывая, что NT - это сокращение от английского "новая технология", можно предположить, что в NTFS есть много чего хорошего, и это действительно так. Вот лишь краткий перечень преимуществ NTFS:

- возможность работать с большими дисками, причем с действительно большими - теоретически NTFS поддерживает диски размером до 16777216 терабайт ("теоретически" потому, что диски такого огромного размера вряд ли появятся даже в не очень ближайшем будущем)

- надежность. Не вдаваясь в подробности, подчеркну, что NTFS устроена так, что в случае копирования, перемещения или удаления файлов (папок) гарантируется абсолютная сохранность данных. Проще говоря, чтобы не случилось, будь то сбой питания во время выполнения задачи или какая-то другая напасть вроде кривого пальца, нажавшего в самый неподходящий момент кнопку Reset, операционная система после перезагрузки будет работать без ошибок, а, к примеру, перемещенный только наполовину до момента аварии файл останется целым и невредимым. Кроме этого, NTFS имеет не одну, а две копии аналога FAT (MFT - Master File Table), и при повреждении одной копии система при перезагрузке использует другую - целую - копию MFT, одновременно создавая (с учетом повреждений) ее копию.

Короче говоря, надежность и устойчивость - это главные отличительные черты NTFS. А из "мелочей" - зищищенность, включающая в себя возможность определить каждому пользователю его права буквально на каждый файл (открытие, закрытие, чтение, запись), а также допустимость шифрования файлов.

В чем отличие NTFS4 от NTFS5?

В XP используется файловая система NTFS5. Ее основное отличие от NTFS4, используемой в Windows NT, заключается в дальнейшем расширении функциональности, и прежде всего - в возможности квотирования. Квотирование позволяет ограничить каждому пользователю максимальный обьем дискового пространства, которое он сможет использовать. Выделено ему, к примеру, 50 мегабайт, и больше "захапать" ему никак не удасться.

Полезность этой функции наверняка оценят в крупных организациях /сетях (диски ведь не безразмерные), да и дома такая опция может пригодиться: выделил, например, ребенку столько-то места, и можно быть уверенным, что диск не будет захламлен тоннами мусора.

Другими характерными чертами NTFS5 являются возможность поиска файла по имени его владельца, а также появление функции точки монтирования (junction point), позволяющей присоединить любой диск в любое место файловой системы. Например, можно присоединить диск D в каталог Documents, который находится на диске С, и тогда, зайдя в папку С:\Documents, мы увидим содержимое корневого каталога диска C (что-то я перемудрил с каталогами/папками, поэтому для новичков поясню, что каталог и папка - это одно и то же). Но самое интересное заключается в другом: убрав через Computer management / Disk Management букву, присвоенную этому диску, мы получим один обьединенный диск - диск С. Монтирование / размонтирование производится через меню Change disk letter and path, в которое можно попасть через Administrative Tools / Computer management / Disk Management

Стоит ли переходить на NTFS? И как это сделать?

Вопрос, конечно, интересный... NTFS из-за своей системы безопасности, вернее, из-за необходимости загружать специализированные службы, поддерживающие ее, работает несколько медленнее, чем FAT; кроме этого (и что даже важнее), NTFS занимает больше памяти, поэтому, если оперативной памяти меньше 128 мегабайт, переходить на NTFS не стоит. А вот если оперативки больше, то и впрямь стоит задуматься о преимуществах NTFS...

А теперь - о том, как перейти с FAT на NTFS и при не потерять данные. Во-первых, при установке WIndows XP это можно сделать автоматически - в соответствующий момент ответив утвердительно на соответствующий вопрос. Можно преобразовать FAT16 (или FAT32) в NTFS и позже - воспользовавшись командой CONVERT. Синтаксис этой команды такой:
convert [диск] /fs:ntfs [/v]
где V - параметр, позволяющий не гадать при следующей перезагрузке системы, идет конвертация или нет, а видеть соответствующие сообщения о происходящем процессе на экране.

Кроме встроенных средств Windows XP, для преобразования FAT в NTFS можно воспользоваться замечательной программой Partition Magic, позволяющей к тому же при необходимости выполнить и обратное преобразование - из NTFS в FAT, и тоже без потери данных.

Что такое boot defrag и для чего это?

Суть boot defrag заключается в дефрагментации тех файлов, что нужны для старта операционной системы. Выключение этой функции позволит на некоторое время уменьшить время загрузки, но со временем она будет становиться все медленнее... Все равно хотите отключить? - Пожалуйста: открываем реестр, идем в HKEY_LOCAL_MACHINE \SOFTWARE \Microsoft \Dfrg \BootOptimizeFunction и меняем там значение параметра Enable. Y - дефрагментация включена, N - выключена.

Можно ли установить WinXP так, чтобы остался и Windows 98?

Windows XP такое позволяет - в этом случае в начальной стадии загрузки компьютера можно будет выбирать, какая операционная система должна быть загружена. Для этого следует в начале инсталляции Windows XP отказаться от предложения обновить систему и указать другой каталог для установки Wundows XP - не предлагаемый по умолчанию каталог Windows (где у вас уже стоит Windows 9*), а, например, WinXP.
Несколько замечаний:
- нежелательно устанавливать Windows XP второй системой на тот же раздел жесткого диска, где уже стоит Windows 9*/Me (Windows XP при инсталляции перезапишет некоторые файлы их новыми версиями, в результате чего в Windows 9*/Me кое-что перестанет работать - например, Outlook Express)
- установка Windows XP второй операционной системой возможна только в том случае, если имеющийся у вас инсталляционный CD предназначен для установки Windows XP "с нуля", а не для обновления операционной системы.

Что за режим выключения компьютера - Hibernate?

Hibernate (в русской версии XP - "спящий режим") - это режим "засыпания" операционной системы, заключающийся в том, что все содержимое оперативной памяти сохраняется на жестком диске, монитор и жесткие диски отключаются, после чего компьютер выключается. Главной особенностью этого режима является то, что при перезапуске компьютера состояние рабочего стола полностью восстанавливается, т.е. система полностью восстанавливает свое состояние, имевшееся на момент "засыпания". Проще говоря, на чем вы остановились, выключив компьютер его переводом в спящий режим, с того же самого места и сможете продолжить свою работу или игру: все приложения будут работать точно также, как и до "спячки" - будто ее и не было вовсе.

Можно ли в WinXP снимать задачи из командной строки?

Для этого следует набрать
taskkill /pid и номер задачи или просто
tskill и номер процесса.
Номер можно узнать, набрав команду tasklist - еще одну новую команду, которая к тому же сообщит многое другое о том, что происходит в операционной системе.

Как переименовать сразу несколько файлов?

Выделяем в окне группу файлов, щелкаем по любому из них правой кнопкой и, если нужно, переименовываем. Все выделенные файлы получат имя указанного файла с индивидуальным номером в скобках.
Кстати в Windows XP есть еще одна любопытная опция - возможность "разложить" значки в папках по алфавиту: после выбора в меню View -> Arrange Icon By... -> Show In Groups значки окажутся организованными в упорядоченные по алфавиту группы.

Допускается ли, не перелогиниваясь, запускать программы от имени другого пользователя?

В Windows XP такое предусмотрено, но только в том случае, если известен пароль этого пользователя: щелкаем на исполняемом файле программы (или ее ярлыку) правой кнопкой, выбираем Run As... (Запуск от имени) и вводим имя пользователя и пароль - они будут действовать до окончания текущего сеанса работы. Одно из применений такой опции - получение прав администратора для установки новой программы.

Оглавление
Общие вопросы
Настройка системы
Разрешение проблем
Восстановление


Статьи

+ Из рассылки
+ Вокруг софта

Каталог

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения

СофтОбзоры

Текущий выпуск
Архив:
Программа недели
Архив:
Программа дня
Подписка на рассылку

Поиск файлов

Files.ru
FTP Search
FileSearch.ru
| Главная | Топ-50 | Новинки | Статистика | СофтФорум| Для авторов | Помощь | Обратная связь | Рассылка |

Softodrom.ru > Статьи

Windows XP FAQ

Автор: Евгений А. Соболев
Источник: http://softodrom.ru
Категория: Windows

Настройка системы

Можно ли уменьшить размер Windows XP?

В том случае, если уже установлено все оборудование, можно удалить папку %SystemRoot%\Driver Cache\i386\ (т.е. по умолчанию C:\Windows\Driver Cache\i386\). Правда, в этом случае при добавлении любого нового оборудования Windows будет запрашивать установочный CD.
Можно также отключить System Restore, удалив тем самым информацию, которая хранится в папке System Volume Informatiоn.

И еще одну папку можно удалить - %SystemRoot%\system32\dllcache\ (в ней хранятся защищенные системные файлы, используемые для автоматического восстановления оригиналов в случае их повреждения). Кстати, по умолчанию размер этой папки - 400 мб (он задается в реестре параметром SFCQuota (0xFFFFFFFF), находящемся в ключе HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows NT \ CurrentVersion \ Winlogon), но его можно изменить до нуля командой sfc: sfc /cachesize=0 (если поставить, например, 10, то размер папки уменьшится до 10 мб)

А что это в XP хелп такой урезанный?

На самом деле система помощи в Windows XP даже более подробная, чем, например, в NT, но она разделена на несколько частей - та, что появляется через через пункт Help and Support кнопки Start, предназначена, выражаясь помягче, для неквалифицированных пользователей. Этот "главный" хелп не содержит сведений об очень многих аспектах управления операционной системой, поэтому, чтобы почерпнуть действительно важную информацию, придется прогуляться по файлам помощи отдельных апплетов, например тех, что находятся в разделе Computer Management (Start / Control Panel).

Что можно предпринять для оптимизации Windows XP?

Для начала - отключить ненужные системные службы (сервисы), ускорив тем самым работу системы. Заодно и памяти немного освободиться...

Вот список служб, которые, в принципе, можно безбоязненно отключить:

  • Automatic Updates (Автоматичесткое обновление). Учитывая, что обновлять систему можно и вручную, имеет смысл отключить эту службу. Особенно в том случае, если нет постоянного соединения с Интернетом. Следует только не забыть не только отключить службу, но и отменить Automatic Updates в одноименной закладке System Properties.

  • Computer Browser. Занимается обновлением списка компьютеров в сети. При отсутствии сети не нужна.
  • Cryptographic Service. Служба безопасного обмена ключами и шифрования передаваемых данных в локальной сети. Если локальной сети нет, то эту службу можно отключить, если сеть есть - думайте сами...

  • DHCP client. Занимается автоматическим распределением IP-адресов. Если сети нет (ни локальной, ни Интернета - даже через модем), то эта служба не нужна.
  • Event Log. Ведет лог системных, программных событий и событий в системы безопасности. В принципе, можно отключить. Ничего страшного не произойдет.

  • Messenger. Отвечает за прием и отправку сообщений, посланных администратором. При отсутствии сети (и администратора) абсолютно бесполезна.

  • Network Connections. Управление всеми сетевыми соединениями. Если нет сети (в том числе нет и Интернета), то эта служба не нужна.

  • Print Spooler (Спулер печати). Если принтера нет, то он не нужен.

  • Portable media serial number. Отвечает за получение серийного номера переносного музыкального устройства, подключаемого к компьютеру. Лично у меня ничего подобного нет...

  • Protected Storage. Защита важных данных, в т.ч. ключей пользователей; запрещает неавторизированный доступ. Если нет сети (в том числе и Интернета), то эту службу можно отключить (если безопасность не волнует - можно отключить и при наличии сети).
  • Remote Registry Service. Предназначена для удалённого управления реестром (нужна только администраторам сети).
  • System Event Notification. Отслеживает системные события. Если все уже настроено и нормально работает, можно отключить.
  • SSDP Discovery. Обеспечивает работу подключаемых устройств, поддерживающих UPnP (универсальная система Plug & Play, которая, по задумке, должна связывать компьютер с самой различной бытовой техникой, вроде пылесоса или холодильника. Мне такой техники пока не встречалось).

  • Task Scheduler. Запуск приложений в заданное время. Если эта возможность не используется, эту службу можно отключить.

  • Telephony. Взаимодействие с модемом. Нет модема - отключаем службу

  • Telnet. Обеспечивает возможность соединения и удалённой работы по протоколу telnet. Если не знаете (и не хотите знать), что это такое, то эту службу можно отключить.
  • Uninterruptible power supply. Управляет работой бесперебойных источников питания (UPS). Если UPS с обратной связью нет, то не нужна.
  • Terminal Service. Служит для подключения к компьютеру по сети и удаленного управления им. Домашнему пользователю она в общем-то ни к чему.

  • Windows time. Синхронизирует время на локальной машине и сервере; если нет time-сервера, то и служба не нужна.

  • Wireless zero configuration. Служба автоматической настройки беспроводных сетей стандарта 803.11 и 803.11b. Если беспроводной сети нет, то зачем работать этой службе?

    • Подчеркну, что этот список - не окончательный, потому что необходимость той или иной системной службы определяется теми задачами, которые выполняются на конкретном компьютере, поэтому каждый должен решать сам, что можно отключить, а что нет. Главное - не переборщить, помня, что последствия необдуманных действий могут быть непредсказуемыми. И еще о последствиях. Для того, чтобы уменьшить риск "запороть" систему, имеет смысл перед началом эксперименетов со службами сделать резервную копию той ветви реестра, что отвечает за запуск системных служб: открываем regedit, идем в HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Serviсes, выбираем в меню File, а там - пункт Export Registry Key.

    Еще один метод, позволяющий ускорить работу системы и несколько освободить занимаемую ею оперативную память, заключается в отключении Dr.Watson'a, отладчика, запускаемого по умолчании при каждом сбое в работе приложений. Чтобы отключить этого "доктора", нужно будет в реестре найти ключ HKEY_LOCAL_MACHINE \SOFTWARE \Microsoft \Windows NT \CurrentVersion \AeDebug и изменить в нем значение параметра Auto на 0. После такой модификации реестра при возникновении сбоя в работе приложения система будет предлагать либо закрыть его, либо передать отладчику для отладки (если выбрать второе, то запустится Dr.Watson и создаст лог-файл).

    Следующий этап - оптимизация интерфейса, призванная ускорить его работу. Заходим в System Properties, открываем закладку Advanced, нажимаем в разделе Performance кнопку Settings и в открывшейся вкладке Visual Effects отмечаем пункт Adjust for best performance, отключая тем самым абсолютно все эффекты. А можно отключить их и по отдельности, оставив те, без которых прожить ну никак нельзя...

    Теперь примемся за стартовое меню. Изначально оно открывается с некоторой задержкой (по умолчанию - 400 миллисекунд), регулировать которую можно, изменяя в реестре значение ключа MenuShowDelay, находящегося по адресу HKEY_CURRENT_USER \ControlPanel \Desktop. В случае установки для этого параметра значения 0 меню будет появляться без задержки.

    Там же - в реестре - находится еще один параметр, изменение которого приведет к некоторому ускорению работы интерфейса - MinAnimate, включающий анимацию при сворачивании и разворачивании окон, находится по адресу HKEY_CURRENT_USER \ControlPanel \Desktop \WindowsMetrics. Значение 1 - эффект анимации включен, 0 - выключен. Если этого ключа в реестре нет, то создайте его (тип - String). И не забудьте - для вступления подобных изменений в силу необходимо перезагрузить компьютер.

    Открытие на NTFS-разделе папок с большим количеством файлов происходит довольно медлено, потому что Windows каждый раз обновляет метку последнего доступа к файлам и на это, естественно, тратиться какое-то время. Для отключения этой функции нужно запустить regеdit и по адресу HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Control \FileSystem cоздать параметр типа DWord, назвав его NtfsDisableLastAccessUpdate и присвоив ему значение 1.

    Кроме всего перечисленного, для оптимизации работы системы можно воспользоваться программами, специально для этого предназначенным, например, Tweak-XP - набором из двух десятков утилит для настройки Windows XP.

    Как удалить "скрытые" компоненты Windows XP?

    В отличие от Windows 9*/NT, в процессе установки Windows XP нет возможности выбирать необходимые компоненты. На мой взгляд, это правильное решение Microsoft - сначала следует установить операционную систему со всеми ее прибамбасами, а уж затем, поработав, можно решать, что следует оставить, а что нет.

    Правда, и в этом случае получается, как сказал бы наш незабвенный Б.Н.Ельцин, в некотором роде заковыка: в окне "Add/Remove Windows Components", что присутствует в апплете "Add or Remove Programs" Контрольной панели, удалять-то практически нечего, потому что многие из составляющих Windows скрыты от шаловливых ручек не слишком опытных юзеров.

    Так что же, у этой проблемы нет решения? - Конечно же, решение есть. Открываем системную папку Inf (по умолчанию - C:\Windows\Inf), находим в ней файл sysoc.inf, открываем его и удаляем во всех строках слово HIDE. Главное при этом - оставить неизменным формат файла, то есть следует удалять только HIDE, оставляя запятые до и после этого слова.

    Для примера - исходная строка и та, что должна получиться:
    msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,hide,7
    msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,,7

    Сохраняем файл sysoc.inf, открываем "Add/Remove Windows Components" и видим значительно более длинный список, чем тот, что был на этой страничке до проведения описанной выше операции. Правда, и в этом случае много удалить не получится.
    Кстати, точно также можно поступить и в случае с Windows 2000...

    Можно ли самому создать скин для Windows XP?

    Можно - недавно появилась программа Windowblinds XP, специально предназначенная для самостоятельного изменения внешнего вида Windows XP.

    Можно ли заменить картинку в меню "Start" рядом с моим именем на мою фотку?

    Можно, причем не только на свою фотографию, но и на любой другой графический файл, и сделать это очень просто: после клика по этой картинке выскочит окошко "User Аccount", в правой нижней части которого есть ссылка "Browse for more pictures" (обзор других картинок), с помощью которой и следует найти ту картинку/фотку, которая будет показываться напротив имени пользователя.

    Позволяет ли эта версия Windows вносить изменения в файл config.sys?А то в Миллениуме нельзя заставить компьютер запомнить, скажем, такую строку: files=200

    В Windows XP (как и в WinNT/2K) подобный файл называется config.nt. Он поддаетсямодификации, в том числе и установке числа одновременно доступных файлов во время работы подсистемы MS-DOS. Следует только понимать, что в Windows XP, строго говоря, нет MS-DOS, а есть только ее эмуляция.

    Какие из драйверов больше подходят для WinXP - от NT или 2K?

    Я бы ответил на этот вопрос так: лучше всего подходят драйверы, специально написанные для Windows XP, но такой ответ, скорее всего, мало кого удовлетворит, поэтому продолжу. Как мне кажется, лучший способ подобрать недостающий драйвер - это метод научного тыка, заключающийся в последовательной установке всех драйверов, какие имеются, тем более что в Windows XP предусмотрен очень простой способ возврата к старой версии драйвера - одним нажатием на кнопку "Roll Back Driver", которая находится на вкладке "Driver" окна со свойствами соответствующего устройства.

    Для чего нужна вкладка Compatibility в свойствах exe-файла?

    Эта вкладка предназначена для "обмана" программ.
    Учитывая, что Windows XP является вроде как бы "гибридной" операционной системой, на которую будут переходить пользователи и Windows 98, и Windows NT, и Windows 2000, Microsoft приняла решение не ждать, пока разработчики программного обеспечения выпустят патчи и обновленные версии программ, совместимые с Windows XP, а сама добавила в операционную систему специальную функцию "режим совместимости", который как раз и настраивается на вкладке Compatibility (совместимость).

    Поставив на этой вкладке галку напротив надписи "Run this program in compatibility mode for" и выбрав одну из предложенных операционных систем (Windows 95, 98, Me, NT или 2000), мы тем самым заставим программу поверить, что она работает не в Windows XP, а в выбранной операционной системе. Стоит отметить, что Windows XP не просто сообщает программе, что она - не Windows XP, но и эмулирует структуру системного реестра соответствующей операционной системы, что позволяет заставить нормально работать в Windows XP большинство из программ, формально не предназначенных для работы в этой ОС, и только некоторые из них (те, что проверяют ядро ОС) не поддадутся на эту уловку и откажутся работать.

    На этой же вкладке, кстати, можно изменить и некоторые другие параметры запуска конкретного приложения - установить разрешение экрана 640х480, уменьшить цветность до 256 цветов и отключить общий для всей операционной системы скин.

    Хочу заменить файл в папке System32, а Windows ругается и не дает. Что делать?

    Не дает - и правильно делает: незачем систему ломать. Это срабатывает система защиты файлов, которая не отключается для загрузочного раздела жесткого диска даже в том случае, если отключить Систему Восстановления (System Restore), убрав соответствующую галку на странице ее настройки.

    С другой стороны, если нельзя, но очень хочется, и при этом вы ясно представляете, что делаете и чем все это дело может закончиться (а итог может быть весьма плачевным), то можно воспользоваться крохотной утилитой по имени SetSfс, позволяющей изменить параметры системы восстановления Windows 2K/XP, а также отключить ее полностью - в том числе и для загрузочного раздела.

    Windows все время хочет обновиться и пытается лезть в Интернет. Это безобразие можно прекратить?

    Можно: Start/Control Panel/System, а там на вкладке Automatic Updates следует отметить последний пункт - "Turn off". После этого следить за появлением обновлений операционной системы придется самостоятельно...

    Как включить интернет-защиту?

    Одна из новых опций, появившихся в WinXP - файрволл для интернет-защиты.Заходим в свойства того соединения, которое нужно защитить: через Start /Control Panel /Network Connections в контекстом меню нужной иконки выбираем пункт Properties, выбираем вкладку Advanced и отмечаем пункт "Protect my computer and..." (ошибиться вряд ли получится - больше галку там поставить негде)

    Где находятся те утилиты, о которых говорится в обзоре Windows XP?

    В процессе установки Windows XP они не автоматически не устанавливаются, поэтому их придется инсталлировать уже после установки операционной системы. А находятся они на установочном компакт-диске Windows XP Pro, в папке Support\Tools

    Вроде бы Microsoft уже выпустила пакет дополнений для Windows XP. Откуда его можно скачать?

    Выпущен пакет Powertoys для Windows XP, включающий утилиту для "тонкой" настройки Tweak UI, а также мелкие, но полезные дополнения: Faster User Switcher, Task Switcher, Slide Show Generator, ISO Image Burner и некоторые другие, в том числе графический калькулятор, виртуальный менеджер рабочих экранов и добавочка для управления Windows Media Player из системной панели. Этот пакет уже включен в каталог Softodrom.ru: Powertoys for Windows XP

    Можно ли в XP снимать с аудио-CD цифровой звук?

    Можно - Windows XP допускает передачу аудиоданных с компакт-диска в цифровом виде через IDE-шлейф (без использования проводка, которым обычно соединяют CD-ROM со звуковой картой). Чтобы воспользоваться такой очень полезной возможностью, следует зайти через Control Panel /System на вкладку Hardware, там нажать на кнопку Device Manager и выбрать CD-ROM, в свойствах которого (Properties CD) на одноименной закладке поставить галку напротив "Enable Digital CD-Audio for this CD-ROM device". После этого тот проводок, о котором говорилось выше, можно выбросить.

    Как запустить дефрагментатор из контекстого меню Проводника?

    Загрузите файл context_defrag.vbs. После установки (для этого достаточно щелкнуть по файлу) в контекстном меню Проводника появится пункт defrag, позволяющий быстро запустить дефрагментацию жесткого диска

    Как выставить права пользователям, работающим на компьютере?

    В Windows XP каждому пользователю можно выставить определенные права - что делать разрешается, а что - нет, причем, если пользователей много, их можно распределить по группам, присвоив каждой группе определенные права. Управление пользователями и группами производится через апплет Users Accounts, находящийся в Контрольной панели. Сразу после инсталляции WinXP в этом апплете можно будет увидеть двух пользователей - того, кто был создан в процессе установки (с правами администратора) и второго - гостя (Guest), по умолчанию отключенного. Вообще-то сразу же после установки появляются еще несколько пользователей (например, знакомый еще со времен NT пользователь по имени Administrator), но они не показаны в списке - таков общий принцип построения Windows XP: операционная система предназначена для всех, другими словами - и для чайников тоже, поэтому до "лишнего" можно добраться только после некоторых дополнительных манипуляций. В общем-то, это правильно - меньше дров будет наломано...

    В случае, если вы обладаете правами администратора, апплет Users Accounts даст возможность добавлять или удалять пользователей, менять пользователю пароль или сооветствующую ему картинку-пиктограмму, а также изменять метод входа в систему. По умолчанию при входе в систему показывается экран Welcome screen с пиктограммами и именами пользователей, но, если выбрать пункт "Change the way users log on and off" и убрать в появившемся окне галку с пункта "Use the Welcome screen", вход в систему будет происходить по NT-шному - через окно, в котором предлагается ввести имя пользователя и пароль.

    А где же группы, где возможность редактирования уже существующих пользователей, короче говоря, где все то, что было в NT/2K? - Чтобы получить доступ к контролю над пользователями, который можно назвать "полным", придется заглянуть в апплет Computer Management (Start /Administrative Tools /Computer Management) и кликнуть по плюсику, раскрывающему Local Users and Groups...

    Но и это не все хитрости: есть еще апплет Local Security Setings (он там же, в Administrative Tools), с помощью которого можно, например, изменить время жизни паролей и выставить конкретные права каждой имеющейся группе пользователей.

    Как зайти в систему администатором (пользователь Administrator)?

    Самый простой способ - отключить режим Welcome screen (см. предыдущий вопрос). Кроме этого, залогиниться как Administrator можно, если начать загрузку системы в режиме Safe mode. Наконец, есть и третий, самый хитрый способ: после появления экрана "Welcome screen" дважды нажмите Ctrl+Alt+Del

    Как включить MP3-кодирование с высоким битрейтом?

    Создайте reg-файл (назвав его, например, mp3.reg) следующего содержания:

    Regedit 4
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\Settings]
    [HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\MediaPlayer\Settings\MP3Encoding]
    "LowRate"=dword:0000dac0
    "MediumRate"=dword:0000fa00
    "MediumHighRate"=dword:0001f400
    "HighRate"=dword:0002ee00

    и импортируйте его в реестр (щелчок по файлу - установить). После внесения такого изменения в реестр включится встроенный MP3 кодек, но его максимальный битрейт будет ограничен 192 килобитами.
    Второй способ кодирования с высоким битрейтом - использование для кодирования не встроенного, а внешнего MP3-кодека.

    Как изменить интервал синхронизации системных часов компьютера с time-сервером?

    Находим в реестре ключ
    HKEY_LOCAL_MACHINE \SYSTEM \ControlSet001 \Services \W32Time \TimeProviders \NtpClient
    Выбираем параметр SpecialPollInterval и изменяем его значение: оно должно быть равно требуемому интервалу между синхронизациями системного времени, выраженному в секундах (например, 172800 - 2 дня, 43200 - 12 часов)

    Как изменить число открытых окон программы, при достижении которого на панели задач включается режим их группировки в одну кнопку?

    Режим группирования нескольких открытых окон в одну кнопку - одно из многочисленных не сразу заметных, но очень удобных нововведений. Смысл его заключается в том, что при достижении числа открытых окон определенного значения они группируются и отображаются на панели задач в виде одной кнопки, щелчок по которой вызывает ниспадающее меню со всеми открытыми окнами этой программы. Очень удобная функция, например, при прогулках по Сети с помощью Internet Explorer - уже первый десяток открытых страниц без использования режима группировки донельзя захламляет панель задач.

    Для изменения числа открытых окон программы, которое приводит к включению режима их группировки, нужно запустить Regedit, найти в реестре ключ
    HKEY_CURRENT_USER \Software \Microsoft \Windows \CurrentVersion \Explorer \Advanced
    и изменить параметр TaskbarGroupSize. Если такого параметра нет, то нужно его создать (в виде DWORD) и настроить: щелкаем по параметру правой кнопкой мыши и выбираем в контекстном меню пункт Modify (к примеру, установка для TaskbarGroupSize значения 5 заставит Windows включать режим группировки при пяти открытых однотипных окнах)

    Кстати: а как вообще включить этот режим группировки? Очень просто: щелкаем правой кнопкой по панели задач, выбираем пункт Properties и на вкладке Панель задач ставим галку напротив "Сгруппировать похожие кнопки..."

    Можно ли в окне "Welkome" изменить шрифты на сглаженные (cleartype)?

    Элементарно: открываем реестр, находим ключ HKEY_USERS \.DEFAULT \Control Panel \Desktop, находим в нем параметр FontSmoothingType и изменяем его значение на 2. При следующей перезагрузке системы ждем появления экрана "Welkome", после чего наслаждаемся полученным эффектом...

    А что, в XP нет своего факса?

    Есть, но автоматически при инсталляции операционной системы Cлужба факсов не устанавливается. Чтобы воспользоваться ее возможностями, включающими в себя отправку, прием и контроль факсов, следует через Start / Control Panel открыть апплет 'Установка или удаление программ', щелкнуть там по иконке 'Установка/удаление компонентов Windows', отметить пункт 'Fax Services' и нажать кнопку Next (Далее). После этого последует просьба вставить инсталляционный компакт-диск с Windows XP и начнется процесс установки факс-службы.

    Как удалять файлы, минуя "мусорную корзину"?

    Start -> Run и даем команду gpedit.msc
    В открывшейся консоли выбирает User Configuration, Administrative Templates, Windows Components, Windows Explorer и отмечаем "Do not move deleted files to the Recycle Bin" (не уверен, что подобный пункт есть в Windows XP Home Edition)

    Как переименовать папку аккаунта Administrator?

    Сначала входим в систему под аккаунтом Administrator и создаем в директории Documents and Settings папку с нужным именем. Затем через контекстное меню My computer / Properties / Advanced добираемся до User Profiles, где сопируем профиль администратора в созданную папку. После этого открываем в реестре ключ HKLM\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ ProfileList и находим там ветвь, соответствующую профилю администратора (по значению ключа ProfileImagePath) и исправляем в ней этот параметр на нужный. Теперь можно перелогиниться...

    Как сделать, чтобы при перезагрузке стирался/создавался заново файл подкачки pagefile.sys?

    Открываем реестр и находим ключ
    HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Control \Session Manager \Memory Management
    где выставляем значение "ClearPageFileAtShutdown"=dword:00000001
    Следует отметить, что этот ключ не стирает файл подкачки, а очищает, т.е. заполняет его нулями, но сам файл на диске остается. Такого же рузультата, ксати, можно добиться и через апплет Local Security Policy, находящийся в Administrative Tools (раздел Local Policies, Security Options, ключ Shutdown: Clear virtual memory pagefile when system shuts down).

    Как мне залочить компьютер? Через Crtl+Alt+Del не получается...

    Теперь для этого установлена другая комбинация - Win+L. Кроме этого, можно создать *.cmd файл и лочить машину, запуская его. Содержание этого файла должно быть таким:
    rundll32.exe user32.dll,LockWorkStation

    Как сделать, чтобы зависшие и переставшие отвечать задачи убивались автоматически?

    В реестре по адресу HKCU\Control Panel\Desktop находится ключ HungAppTimeout, значение которого определяет интервал (в миллисекундах), через которое не отвечающее приложение считается зависшим. Кроме этого ключа, в той же ветви находятся ключи WaitToKillServiceTimeout (задаёт время ожидания перед "убийством" зависшей службы), и AutoEndTasks (при установке его значения в 1 системе дается разрешение убивать зависшие процессы самостоятельно).

    Откуда загружаются программы при старте системы? У меня папка Автозагрузка пустая...

    При загрузке операционной системы каманды на запуск некоторых программ даются из системного реестра, где имеется специальная ветвь HLKM \SOFTWARE \MICROSOFT \WINDOWS \CURRENTVERSION \RUN (и аналогичная ...\RUNONCE). В этих ветвях записаны значения, каждое из которых соответствует одной запускаемой при старте программе...
    Только не стоит спешить - если не уверены, что за программа записана, перед удалением обязательно сохраните выбранные строчки (через пункт редактора реестра "экспорт").
    На закуску - маленький секрет. В Windows XP есть утилитка под названием msconfig, которая позволяет очень комфортно управлять параметрами загрузки. Запустить эта утилиту можно через кнопку Start (Пуск) - Run... (Выполнить).

    Можно ли ввести компьютер в состояние hibernate из командной строки?

    Можно. Делается это такой вот командой:
    %windir%\System32\rundll32.exe powrprof.dll,SetSuspendState

    Как изменить time-server, используемый для подстройки системного времени?

    Это можно сделать через апплет "Date and Time Properties", до которого проще всего добраться с помощью двойного щелчка по времени в системном лотке; изменение адреса time-сервера производится в этом апплете на вкладке Internet Time.

    Можно ли отключить сообщение о недостаточности свободного места на диске?

    Можно. Для блокирования появления такого сообщения следует открыть реестр, найти ключ
    HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explоrer
    и вписать в него новый параметр NoLowDiskSpaceChecks типа DWORD, присвоив ему значение 1.

    Как отключить появление предложения об отправке рапорта об ошибке?

    Запускаем утилиту msconfig (кнопка Start -> Run -> msconfig), выбираем вкладку Services и снимаем там галку с пункта Error Reporting Service, после чего нажимаем кнопку ОК и утвердительно отвечаем на предложение перезагрузиться. Или отрицательно, но в этом случае отключение службы отправки рапортов об ошибках произойдет только после следующей перезагрузки операционной системы.

    Можно ли сделать так, чтобы определенная папка открывалась по горячей клавише?

    Можно, но для этого необходимо, чтобы ярлык от этой папки находился на рабочем столе. Находим папку, которую требуется открывать с помощью горячих клавиш, щелкаем по ней правой кнопкой мыши, выбираем пункт Sent To, а в нем - команду Desktop (create Shortcut); или - "захватываем" папку правой кнопкой, передвигаем ее на рабочий стол, отпускаем и в открывшемся меню выбираем пункт Create Shortcuts Here. После этого щелкаем той же правой кнопкой по созданному ярлыку, выбираем в контекстном меню пункт Properties и на вкладке Shortcut в поле Shortcut key (по-русски это, вероятно, будет звучать как Быстрый вызов) впечатываем ту комбинацию клавиш, которая должна будет открывать папку. Необходимо учесть, что в виде горячих клавиш можно использовать как комбинации CTRL+ALT+буква, так и CTRL+SHIFT+буква.

    Как добавить содержимое Рабочего стола в меню Start?

    Находим в системном реестре ключ
    HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ User Shell Folders. В нем есть параметр Desktop, имеющий по умолчанию значение "%USERPROFILE%\Desktop". Изменяем это значение на "%USERPROFILE%\Start Menu\Desktop". Кроме этого, нужно будет скопировать папку %USERPROFILE%\Desktop (папка %USERPROFILE% находится в папке Documents and Settings) в папку %USERPROFILE%\Start Menu\Desktop и перезагрузиться, после чего в меню, появляющемся при нажатии на кнопку Start, появится раскрывающееся субменю Desktop.

    Как (и можно ли вообще) уменьшить размеры огромных файлов Pagefile.sys и Hyberfil.sys?

    Начнем по порядку. Pagefile.sys - это своп-файл (или виртуальная память), куда система сбрасывает из оперативной памяти временно ненужные данные. Его размер по умолчанию выбирается самой операционной системой, но он может быть изменен через Start -> Control Panel -> System -> Advanced -> Perfomance -> Settings. После нажатия на кнопку Settings появится двухвкладочное окно, выбираем в нем вкладку Advanced, давим на кнопку Change virtual memory и устанавливаем тот размер виртуальной памяти, который считаем достаточным. Там же, кстати, можно выбрать, на каком из разделов жесткого диска должен находиться своп-файл.
    Hyberfil.sys - файл, используемый системой при переходе в "спящий" режим. Его размер равен размеру оперативной памяти; в принципе, если вы не собираетесь использовать для выключения компьютера спящий режим (Hybernate) (хотя лично я считаю этот режим выключения очень удобным), то можно отключить его (Start -> Control Panel -> Power Options -> Hibernate, где снять галку с Enable Hibernation), после чего файл Hyberfil.sys окажется ненужным...

    Как удалить с рабочего стола все системные иконки, включая корзину?

    Для этого придется или вручную вносить изменения в системный реестр, или - что значительно проще и безопаснее - воспользоваться одной из специализировнных утилит, например - бесплатным комплектом Powertoys for Windows XP производства Microsoft. Powertoys - это набор расширений для XP, включающий, кроме всего прочего, TweakUI - утилиту для настройки пользовательского интерфейса, с помощью которой можно много чего изменить или отключить, в том числе и определить, какие из системных иконок должны показываться на рабочем столе.

    Как отключить автозапуск компакт-дисков?

    Настройка реакции системы на вставленный в привод компакт-диск производится через CD Properties, вызываемые щелчком правой кнопки мышки по CD-диску. Правда, в этом случае нельзя определить действие системы при установке data-CD (уж не знаю почему, но пункта data-CD в CD Properties нет), поэтому, если требуется отключить автозапуск таких дисках, следует во время загрузки диска нажать и удерживать левый Shift.
    Другой способ состоит в правке реестра: находим ключ HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Services \CDRom и присваиваем паpаметpу Autorun (его тип - REG_DWORD) значение 0.

    Куда подевалась закладка Security в свойствах NTFS-томов и почему так упростилась закладка Sharing?

    Учитывая, что Windows XP - система не только для опытных пользователей, но и для всех остальных, ее разработчики сделали все, чтобы не мозолить начинающим пользователям глаза непонятными им понятиями и обозначениями. К таким понятиям отнесены и Security с Sharing, поэтому, чтобы привести вид вкладок свойств диска к тому виду, к которому уже привыкли пользователи Windows 2000, придется заглянуть в свойства папки (Windows Explorer -> Tools -> Folder Options -> View -> Advanced Settings), где необходимо будет убрать галку с пункта "Use simple file sharing (Recommended)"; после этого в свойствах диска не только появится вкладка Security, но и измениться вкладка Sharing - появится возможность выставлять уровни прав доступа.

    Как назначить диску другую букву?

    Для начала - пара слов о том, как происходит в Windows XP присвоение дискам буквенных обозначений, тем более что происходит оно несколько по другому, чем это делается в Windows 9*/Me.

    В процессе инсталляции Windows XP буква C: присваивается загрузочнуму диску, буквы D:, Е: и так далее - всем остальным обнаруженным при инсталляции жестким дискам, а последняя буква присваивается CD-драйву, причем в дальнейшем при установке в систему новых дисков, например, пишущего CD-привода или еще одного винчестера, им будут присвоены следующие из незанятых букв, то есть у уже установленных дисков буквы не меняются.

    Такой принцип назначения дискам букв, естественно, приводит к тому, что у давно стоящего CD-драйва оказывается меньшая буква, чем у только что установленного винчестера, что может смутить пользователей, перешедших на XP с Windows 9* и привыкших, что у CD-драйвов всегда последние буквы. Но ведь безвыходных положений не бывает: в XP, как и в Windows 9*, можно переназначить дискам другие буквы, вот только делается это несколько по-другому - вручную через консоль управления компьютером (Computer Management). Быстренько добраться до нее можно вот так: Start (Пуск) -> Run (Выполнить):
    compmgmt.msc

    Результатом исполнения этой команды станет открытие консоли, в которой следует выбрать пункт Disk Management. Disk Management - это мощный инструмент для управления дисками, позволяющий, кроме много другого, изменять присвоенные дискам буквенные обозначения.

    А как обстоят дела в WinXP с переименованием загрузочного (или системного) диска?

    И с этим в XP дела обстоят хорошо. Правда, присвоить другую букву загрузочному/системному диску не так просто, как это делается в случае остальных дисков, но в принципе - ничего особо сложного. В качестве примера возьмем да и поменяем буквы у дисков C: и D:

    Для этого запускаем редактор реестра (обязательно под эккаунтом администратора), находим ключ HKLM\SYSTEM\MountedDevices и разрешаем администратору (то есть себе) полный доступ к этому ключу. Делается это через меню Security (Безопасность) -> Permissions (Разрешения).

    После этого находим в HKLM\SYSTEM\MountedDevices букву диска, которую нужно изменить (в нашем случае - "\DosDevices\C:") и меняем ее на любую из тех, что еще не использованы, например, на Z: (т.е. у нас должно получиться вот так: "\DosDevices\Z:").

    Следующий этап - замена буквы у диска D:
    Выбираем \DosDevices\D: и изменяем D: на C:, в результате чего получаем "\DosDevices\C:"
    Наконец, выбираем параметр \DosDevices\Z: и переименовываем его в \DosDevices\D:, после чего перегружаем компьютер.

    Примечание: в случае, если не требуется менять названия дисков с C: на D: и наоборот, а нужно всего лишь заменить C: на еще неиспользованную букву, достаточно изменить значение \DosDevice\С: на любую неиспользуемую букву.

    Два важных замечания:

  • При смене буквы у диска необходимо учитывать, где окажется своп-файл: в случае исчезновения диска, на котором он должен быть размещен, система при перезагрузке сразу после окна входа в систему сообщит, что своп-файл слишком мал, и вновь вернётся в окно логона, причем этот процесс будет продолжаться до бесконечености, вернее, до тех пор, пока вы не поймете, что - увы и ах - необходимо переустанавливать систему. Единственная от этого радость - систему можно будет поставить поверх той, что была установлена, а это позволит не переустанавливать установленные ранее программы.

  • Изменение буквы диска приведет к тому, что перестанут работать те программы, которые используют абсолютный метод адресации, поэтому придется переинсталлировать их или вручную править все пути в реестре, изменившиеся в связи со сменой буквы диска.

    Можно ли отключить работу с zip-архивами как с папками?

    Вообще-то работа с zip-архивами, как с обычными папками - это очень удобно, и есть, как мне кажется, только одна причина для отключения этой возможности - слабая и тормозящая машина. Отключается эта опция очень просто - набором в командной строке
    regsvr32 /u zipfldr.dll
    (обратное включение - regsvr32 zipfldr.dll).

    Можно ли полностью отключить скрытые общие ресурсы (ADMIN$, C$ и т.д.)?

    Эти ресурсы в Windows XP (как и в W2K) существуют по умолчанию (доступ к ним возможен только из под эккаунта администратора), причем, если удалить эти ресурсы через "Управление компьютером" (Computer Management) -> "Общие папки", то после перезагрузки они появятся снова, и полностью отключить их можно только с помощью внесения изменений в реестр.
    Открываем
    HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
    и изменениям (или добавляем) следующий параметр:
    AutoShareWks (его тип - REG_DWORD) значение 0

    Вопрос по сети. Как включить роутинг?

    Открываем реестр, ищем ключ
    SYSTEM\CurrentControlSet\Services \Tcpip \Parametersи в параметре IPEnableRouter (тип - REG_DWORD) меняем значение 0 на 1.

    Как автоматизировать вход в систему - без ввода логина и пароля?

    Start -> Run, вводим команду
    control userpasswords2
    После открытия апплета, служащего для управления учетными записями пользователей, снимаем на вкладке Users флажок напротив "Users Must Enter A User Name And Password To Use This Computer". После нажатия на кнопку ОК появится диалоговое окно "Automatically Log On", где нужно будет указать имя пользователя и пароль.

    Оглавление
    Общие вопросы
    Настройка системы
    Разрешение проблем
    Восстановление


Статьи

+ Из рассылки
+ Вокруг софта

Каталог

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения

СофтОбзоры

Текущий выпуск
Архив:
Программа недели
Архив:
Программа дня
Подписка на рассылку

Поиск файлов

Files.ru
FTP Search
FileSearch.ru
| Главная | Топ-50 | Новинки | Статистика | СофтФорум| Для авторов | Помощь | Обратная связь | Рассылка |

Softodrom.ru > Статьи

Windows XP FAQ

Автор: Евгений А. Соболев
Источник: http://softodrom.ru
Категория: Windows

Разрешение проблем

Система стала глючить или пропали системные шрифты

Проверяем наличие системных файлов с помощью команды
sfc.exe /scannow
Windows проверит их (шрифты - тоже системные файлы) и при необходимости переустановит недостающие или поврежденные. Если не помогло - запускаем установочный диск Windows XP и выбираем пункт Upgrade to Windows XP (делать это надо из Windows XP).

Вместо русских букв видны какие-то закорючки

Если такое происходит в Фотошопе, то проблема решается так: находим в реестре ключ HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Control \Nls \CodePage и изменяем значение параметра 1252 на c_1251.nls (было c_1252.nls, станет c_1251.nls). Кстати, такая манипуляция помогает иногда и для некоторых других программ.

Если же кракозябры все равно не исчезли, следует проверить правильность установки Languadge Options: запускаем апплет Regional and Languadge Options (он в Контрольной панели) и открываем закладку Regional Options. В разделе Standart and formats имеет смысл выставить "russian", в разделе Location, отвечающем в том числе за системные шрифты - обязательно указать "Russia". Для полного счастья необходимо проверить вкладку Advanced: Language for non-Unicode programs должен быть выставлен в "Russian".

DOS: русские буквы видны, а вот раскладка не переключается

Открываем реестр, находим ключ HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Control \KeyboardLayout \DosKeybCodes и изменяем значение 00000409 на "ru". После этого открываем файл autoexec.nt (он находится в папке %SystemRoot%\system32) и добавляем строку
lh %SystemRoot%\system32\kb16.com ru
Перегружаем компьютер и убеждаемся, что теперь в DOS-прилложениях переключение на русскую раскладку происходит по нажатию Ctrl+Right Shift, на английскую - Ctrl+Left Shift.

Для особо забывчивых: создание дискеты для сброса пароля (Password Reset Disk)

С помощью этой дискеты можно будет зарегистрироваться на компьютере даже в том случае, если пароль забыт. Для создания Password Reset Disk следует нажать кнопку Start, выбрать Control Panel, а в ней - User Accounts, и щелкнуть по своему эккаунту. В появившемся окошке в левой колонке (под Related Tasks) есть пункт Prevent a forgotten password - после щелчка по нему запустится мастер создания "спасительной" дискеты.

Эта дискета создается один раз - ее не нужно переделывать при каждой смене пароля, поэтому особое внимание следует обратить на порядок ее хранения: дискета должна храниться в укромном месте, потому что тот, кто найдет и воспользуется ей, сможет войти в систему под вашим именем.

Проблема с инсталляцией программ: программа вроде бы устанавливается, но в конце все исчезает, хотя процесс остается в памяти

По умолчанию временные папки, используемые инсталляторами для распаковки данных, необходимых для установки программы, размещаются по адресу C:\Documents and Settings\[имя пользователя]\. Для некоторых инсталляторов такой путь оказывается слишком длинным: распаковав данные, они затем не могут их обнаружить. Чтобы избежать этого недоразумения, следует определить временной папке путь покороче: заходим на вкладку Advanced в System Properties и нажимаем там кнопку Environment, после чего на открывшейся вкладке меняем пути к TEMP и TMP на, например, C:\Windows\Temp

Установка Windows 9*/Me после установки Windows XP

Прежде всего, следует помнить, что Windows 95/98/Me не понимают файловой системы NTFS, так что установить Windows 9*/Me можно только на диск с FAT16 или FAT32. Но и это еще не все: при инсталляции Windows 9* затирает загрузочный сектор Windows XP, поэтому перед установкой Win9* придется переконфигурировать инсталлятор этой операционной системы. Для этого открываем дистрибутив Windows 9* и ищем там файл msbatch.inf (в случае, если файла в дистрибутиве нет, нужно будет его создать). В msbatch.inf следует вписать следующие две строки:
[Setup]
CleanBoot=0
В виде ответа на еще не заданный вопрос "Так ведь дистрибутив - на CD, как же туда этот файл запихнуть?":
кладем msbatch.inf, например, прямо в корень диска C: (c:\msbatch.inf), после чего запускаем установку Windows 9* со следующим параметром:
setup.exe c:\msbatch.inf
И последнее: имя файла может быть совершенно другим, главное, чтобы в нем были эти две строчки.

Что делать, если после перезагрузки система не находит внешний модем?

Причина "потери" внешнего модема (если модем исправен) кроется в том, что при загрузке Windows XP он был выключен. Для того, чтобы система его определила, достаточно включить модем и произвести поиск новых устройств (делается это через Start -> Control Panel -> Add Hardware) - модем будет найден и включен в список имеющегося оборудования.
В случае, если такой вариант не очень подходит по причине постоянного забывания включить модем перед загрузкой (или перезагрузкой) системы, можно поставить не PnP-версию драйвера для этого модема (поискать её можно в *.inf файле модема). Если такой версии там не окажется, придётся ограничиться установкой какого-нибудь стандартного драйвера, например - Standart Modem. В этом случае, если ваш модем соответствует понятиям операционной системы о стандартном модеме (а для большинства модемов, подключаемых к COM-порту, так оно и есть), система будет постоянно помнить, что модем установлен, и не будет "забывать" о нем вне зависимости от того, включен модем в момент загрузки системы или нет. Правда, в случае установки стандартного драйвера могут исчезнуть некоторые полезные настройки модема (например, возможность включить аппаратную компрессии данных), но ведь любые настройки можно задать через строку инициализации, нужно лишь повнимательнее прочитать инструкцию к модему...
Наконец, есть еще один способ, позволяющий системе не забывать про внешний модем. Заключается он в выключении компьютера переводом его в режим Hibernate (спящий режим).

Почему в режиме Standby не выключаются вентиляторы на блоке питания и процессоре?

Скорее всего, этому мешает одна из установок BIOS. Попробуйте переключить в BIOS (в разделе Power Management Suspend Mode) ST1 на ST3.
Если это не поможет, следует проверить, включен ли ACPI-режим. Для этого нужно перейти через Control Panel в апплет Power Options. При отключенном ACPI-режиме нижняя часть вкладки Advanced апплета Power Options оказывается пустой, при включенном - на ней присутствует несколько пунктов для изменения характеристик включения/отключения компьютера и монитора. Если ACPI-режим включен, но вентиляторы все равно не выключаются, то это может говорить о том, что BIOS не поддерживает такую функцию.

Оглавление
Общие вопросы
Настройка системы
Разрешение проблем
Восстановление


Статьи

+ Из рассылки
+ Вокруг софта

Каталог

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения

СофтОбзоры

Текущий выпуск
Архив:
Программа недели
Архив:
Программа дня
Подписка на рассылку

Поиск файлов

Files.ru
FTP Search
FileSearch.ru
| Главная | Топ-50 | Новинки | Статистика | СофтФорум| Для авторов | Помощь | Обратная связь | Рассылка |

Softodrom.ru > Статьи

Windows XP FAQ

Автор: Евгений А. Соболев
Источник: http://softodrom.ru
Категория: Windows

Восстановление

Что представляет собой система восстановления Windows XP?

В самом общем плане: System Restore производит "слепок" с системного реестра и создает резервные копии других необходимых для нормального функционирования операционной системы файлов, что дает возможность в случае необходимости произвести возврат системы к прошлому состоянию. Параметры системы восстановления задаются на вкладке System Restore апплета System Properties, до которого можно добраться так: Start/Control Panel/System. Хочу обратить внимание на то, что по умолчанию System Restore включена не только для загрузочного, но и для всех остальных дисков, при этом отключить System Restore штатными средствами ОС можно у всех дисков, кроме загрузочного.
Кроме этого, с целью дополнительной защиты системы от кривых рук некоторых разработчиков программного обеспечения, в Windows XP имеется система защиты файлов

Слышал, что в WinXP есть система восстановления файлов. Она что, все файлы восстанавливает?

Нет, не все. В действительности имеющийся в Windows XP модуль Windows File Protection и вправду восстанавливает файлы, но не все, а только те из исполняемых и системных файлов (*.exe, *.dll, *.ocx и некоторые другие), которые оказались без всякой на то необходимости замененными (например, в процессе инсталляции какой-либо программы), предотвращая тем самым возможные нарушения в работе операционной системы. Дело в том, что для защиты наиболее важных файлов Microsoft ввела их цифровую подпись, и в том случае, если обнаруживается, что происходит замена системного файла другим, не имеющим такой цифровой пописи, следует немедленное оповещение пользователя, а подмененный файл заменяется "правильным", до поры до времени находящемся в специально для этого созданном хранилище. Если же "правильного" файла по какой-то причине на жестком диске не оказывается, то следует предложение вставить в CD-привод компакт-диск, с которого устанавливалась Windows XP...

Система не загружается...

Для того, чтобы упростить восстановление системы после возможного отказа (хоть такое и случается - если сравнивать Windows XP с Windows 9*/Me - крайне редко), нужно будет заранее предпринять некоторые шаги.

Первый способ состоит в резервном копировании всех основных системных файлов: в Properties системного жёсткого диска открываем вкладку Tools и нажимаем на кнопку Backup now... (это же можно проделать через Start -> Programs -> Accessories -> System Tools -> Backup). В открывшемся окне выбираем вкладку Backup и отмечаем галочкой System state, после чего нажимаем кнопку "Start Backup".
Способ этот хорош всем, кроме одного - созданный "резервирующий" файл (*.bkf) будет иметь размер примерно 200 MB, да и восстановить (вернее, исправить возникшие в ее работе ошибки) можно только при работающей системе, так этот способ всего лишь позволяет, восстанавливая системные файлы, не потерять все свои настройки, а значит, кроме прочего, и не переустанавливать заново инсталлирование программы.

Для уменьшения размера создаваемого при резервировании файла до 15-30 MB можно сохранить только содержимое папки \system32\config (полный список файлов реестра можно узнать, если заглянуть реестр: HKEY_LOCAL_MACHINE\System\CotnrolSet\Control\HiveList\ ), причем для этой цели совсем не обязательно проводить все те манипуляции, о которых рассказывалось выше - можно просто скопировать требующиеся для восстановления файлы в другое место, а при возникновении проблем с реестром загрузиться с любой загрузочной дискеты (хотя бы для DOS) и перезаписать сбойный реестр его резервной копией.

Всё это, конечно, прекрасно, но Windows XP может быть установлена не только на FAT, но и NTFS-раздел, и в этом случае обычная дискета не поможет - NTFS-раздел из DOS не виден. Естественно, и в этом случае выход есть, но для решения этой проблемы нужно будет воспользоваться утилитами сторонних разработчиков - например, воспользоваться программой NTFSDOS Pro, позволяющей производить чтение/запись файлов, размещенных на NTFS-разделе, из-под DOS. Кстати, на сайте разратчика NTFSDOS Pro есть подобная же утилита, но для работы с NTFS-разделами из-под Windows 9*.

А если NFSDOS (или какой-нибудь другой подобной утилиты) нет? - Сама Microsoft предумотрела лишь один способ - загрузку с загрузочного компакт-диска Windows XP: в процессе загрузки системы будет предложено два варианта - установить систему заново или восстановить ее с помощью Recovery Сonsole. В случае, если выбрать Recovery Сonsole, поступит предложение ввести пароль Администратора, после чего - если введенный пароль окажется правильным - загрузится интерфейс командной строки. Список всех допустимых команд выводится командой "help", а наиболее важные для них следующие:
перезапись реестра - copy
вывод на экран списка системных служб и драйверов - listsvc
оключение определенной службы - disable (включение - "enable"),
восстановление загрузочных файлов - fixboot
восстановление Master Boot Record - fixmbr

Кстати, загрузить Recovery Соnsole совсем необязательно с CD - ее можно установить на жёсткий диск, м тогда при загрузке можно будет выбирать, загружать ли систему полностью или загружаться в Recovery Console.

Для установки Recovery Console нужно из командной строки в директории i386 дистрибутива Windows XP набрать
winnt32.exe /cmdcons

Учитывая, что набор команд в Recovery Соnsole является очень ограниченным, имеет смысл поставить жесткий диск с неработающей системой на другой компьютер, работающий под управлением Windows XP или 2000, и попытаться спокойно разобраться в причинах краха системы - если и не разберетесь, то уж все данные с NTFS-разделов сможете перенести без проблем...

Как добавить прав в Recovery Console?

Хорошая мысль - включить максимальные возможности восстановительного инструмента - Recovery Console, только сделать это нужно, не дожидаясь сбоев...
Для разрешения полного доступа к папкам в Recovery Console открываем (под эккаунтом Администратора) Control Panel -> Administrative Tools и запускаем апплет Local Security Policy -> Local Policies -> Security Options, находим там пункт "Recovery Console: Allow floppy copy and access to all drives and folders" и переключаем его в "Enable". Проделав это, перегружаемся в режим Recovery Console и даем команду
SET AllowAllPaths = TRUE

Как восстановить повреждённый загрузчик XP?

Загружаемся в Recovery Console и даем команду
fixboot

Где хранится код активации Windows XP?

Как известно, лицензионная Windows XP при переустановке системы требует повторной активации. Чтобы этого избежать, достаточно перед переустановкой системы скопировать файл wpa.dbl, расположенный в папке windows\System32, например, на дискету - именно в этом файле хранится код активации. После переустановки системы, естественно, нужно будет заменить файл wpa.dbl на тот, что записали на дискету.

Можно ли в WinXP сделать загрузочные дискеты?

Можно, но для этого придется прогуляться на сайт Microsoft - уж не знаю почему, но необходимый для этого пакет теперь (в отиличие от W2K) не входит в дистрибутив. Адреса страниц загрузки - вот здесь: английская и некоторые другие локализации, русская локализация.
Обратите внимание: созданные загрузочные дискеты не будут "аварийными" - они предназначены лишь для установки операционной системы на компьютеры, не поддерживающие загрузку с компакт-диска. При загрузке компьютера с установочных дисков Windows XP будут автоматически загружены драйверы привода компакт-дисков, и начнется установка операционной системы.

Оглавление
Общие вопросы
Настройка системы
Разрешение проблем
Восстановление


Статьи

+ Из рассылки
+ Вокруг софта

Каталог

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения

СофтОбзоры

Текущий выпуск
Архив:
Программа недели
Архив:
Программа дня
Подписка на рассылку

Поиск файлов

Files.ru
FTP Search
FileSearch.ru
| Главная | Топ-50 | Новинки | Статистика | СофтФорум| Для авторов | Помощь | Обратная связь | Рассылка |

Softodrom.ru > Статьи

Microsoft Windows XP Plus Pack:
очередные "фантики", но не только они одни...

Автор: Евгений А. Соболев
Источник: http://softodrom.ru
Категория: Windows

3.11.2001

Microsoft Windows XP Plus Pack - пакет дополнений к Windows XP, позволяющий, как отмечено на сайте Microsoft, расширить возможности компьютера за счет мощных цифровых инструментальных средств, включающих в себя в том числе и голосовое управление плеером, добавить несколько эфектных 3D-игр, а также прибавить к уже имеющимся еще несколько красивых тем и скринсейверов.

Начну с "фантиков", т.е. разнообразных украшатеств. В Plus Pack включено четыре темы (обои, курсоры, звуки) - Аквариум, Космос, Природа и Да Винчи, причем каждой теме соответствует своя заставка и свое оформление (скин) для Windows Media Player. Самая красивая заставка, по крайней мере на мой вкус, в теме Аквариум, хотя ничего нового в ней нет - это давно известная заставка Sachs Marine aquarium, только в урезанном виде.

Что удивительно, в Plus Pack не включено ни одного дополнительного "стиля" - модуля, позволяющего менять внешний вид интерфейса Windows XP. Вероятно, в Microsoft посчитали, что программы Windowblinds3, разработанной компанией Stardock, более чем достаточно для экспериментов с интерфейсом...

Следующий блок пакета включает в себя три игры: Russian Square, The Labyrinth и HyperBowl. Ничего не скажешь - симпатичные игрушки с отменной графикой и звуком. Кстати, раз уж речь зашла о звуке, то пора перейти к более серьезным дополнениям, которые появляются после установки XP Plus Pack.

Итак - звук и вообще мультимедийные дополнения. Как известно, в связке плеер > звуковая карта > колонки последний элемент - колонки - играет далеко не последнюю роль, поэтому Microsoft добавила такую опцию, как улучшение качества звучания аудиоколонок за счет возможности выбрать профайл, устанавливающий индивидуальные характеристики воспроизведения для конкретной модели колонок (что-то вроде установки драйвера для конкретной модели аудиокарточки, принтера и т.п.).

Продолжаем осмотр мультимедийных дополнений, имеющихся в XP Plus Pack. Голосовое управление Windows Media Player - это, конечно, на любителя, хотя, если обучить компьютер своему произношению английских фраз, можно будет, например, запускать плеер не кликаньем по кнопкам, а просто произнеся фразу "media player, play".

Следующие два дополнения тоже относятся к Windows Media Player - это Personal DJ и CD Label Maker. Первая утилита служит для автоматического составления плейлистов с использованием самых разнообразных критериев отбора музыки, вторая позволяет быстро создавать красивые обложки для компакт-дисков. Кроме этого, в пакет XP Plus Pack входит MP3 Audio Converter - конвертор для преобразования MP3 и WAV-файлов в формат WMA.

Ну и "на закуску" XP Plus Pack предлагает три модуля визуализационных эфектов для Windows Media Player, представляющих из себя трех интерактивных существ, танцующих в такт музыке. "Существа" - это медуза (обьяснять, что это такое, думаю, не стоит), симпатичный до безобразия уродец, выделывающий самые разнообразные па на своей инвалидной коляске, а также добрячок-толстячок, с ловкостью жоглирующий всеми своими частями тела.

симпатичный до безобразия уродец

Вот, пожалуй, и все, что можно вкратце рассказать о компонентах, входящих в Microsoft Windowx XP Plus Pack. На мой взгляд - вполне оптимальное соотношение приятного с полезным, хотя полезного, конечно же, хотелось бы увидеть побольше. Впрочем, и приятного - тоже...