Creating an installation CD for Grafis components

For dissemination of additional data such as personal construction systems, component parts, plotter drivers, text components or similar to other Grafis users the creation of a personal installation CD or installation disk(s) is recommended.

The following is required:

  • a CD or DVD writer with relevant burner software (e.g. Ahead Nero)
  • an installation CD for Grafis Version 9
  • a specially prepared directory on your harddisk
  • the data you want to disseminate

Prepare an installation CD

  1. In your prepared folder on the harddisk (in this example C:\My_CD), create a subfolder named "Grafis".
  2. Copy your data into this new directory following the usual Grafis directory structure.
    Example: You want to disseminate the construction system Tempo_1. From your Grafis drive (e.g. C: ) copy the folder C:\Grafis\Tempo_1 to C:\My_Cd\Grafis\Tempo_1
  3. Copy all files from the folder \Weitergabe on your installation CD Grafis V9 to C:\My_Cd. The Help file "so_funktionierts.chm" should not be copied.
  4. Insert a writable CD into the CD writer drive and start the burner software. Generate a project which saves all data under C:\My_Cd to the CD.
    Example: the construction system named above is to be copied. You have prepared C:\My_Cd\Grafis\Tempo_1 and some sub directories. \Grafis\Tempo_1 will appear on the CD, plus Installx.exe, Autorun.inf amongst others will be copied to the main directory of the CD.
  5. Burn the data onto your data carrier.

Create one/ several installation disks

The above files can also be used for installation disks. Follow the procedure for creating an installation CD up to point 3. Then, copy the files from C:\My_Cd to disk. The first disk must contain the data from the directory C:\My_Cd. If more than one disk is required, the total number of disks must be noted under Disks.txt on the first disk. The file Lnkfiles.dll must be available under A:\ on all subsequent disks. The other files are not required.