Общие сведения о WinRAR

WinRAR это архиватор RAR для Windows — мощный инструмент для архивирования и управления архивами. Помимо Windows, существуют версии RAR для других операционных систем — Linux, FreeBSD, macOS, Android.

RAR для Windows доступен в двух вариантах:

  • WinRAR.exe — версия с графическим интерфейсом (GUI);
  • RAR.exe — консольная версия, запускаемая из командной строки и работающая в текстовом режиме.

WinRAR и модули самораспаковки WinRAR работают в среде Windows XP SP3 и новее.

Некоторые отличительные особенности WinRAR

  • полная поддержка архивов RAR и ZIP 2.0;
  • собственный высокоэффективный алгоритм сжатия данных;
  • графический интерфейс с поддержкой перетаскивания (drag-and-drop);
  • возможность использования интерфейса командной строки;
  • работа с архивами других форматов (7Z, ARJ, BZ2, CAB, GZ, ISO, JAR, LZ, LZH, TAR, UUE, XZ, Z, 001 и ZIPX нескольких типов);
  • поддержка непрерывного (solid) архивирования, при котором, как правило, достигается заметно более высокая степень сжатия (на 10–50% и более), чем дают обычные методы, особенно если упаковывается значительное количество небольших файлов однотипного содержания;
  • поддержка многотомных (состоящих из нескольких частей) архивов;
  • создание самораспаковывающихся (SFX) обычных и многотомных архивов с помощью разных SFX-модулей;
  • возможность восстановления физически повреждённых архивов;
  • особые тома для восстановления, позволяющие воссоздавать отсутствующие или повреждённые тома многотомных архивов.
  • поддержка кодировки Юникод в именах файлов;
  • другие дополнительные функции, например шифрование содержимого и имён файлов в архиве, добавление архивных комментариев, запись ошибок в файл-журнал и т.д.


Ограничения WinRAR

Внутренний формат создаваемых с помощью WinRAR архивов RAR и ZIP позволяет хранить практически любое количество файлов любого размера. Реальные ограничения зависят лишь от файловой системы и доступной памяти. Так, некоторые старые файловые системы не поддерживают файлы размером более 4 ГБ.

WinRAR распределяет память для хранения имени и атрибутов каждого архивируемого файла. Если в архив добавлена информация для быстрого открытия, хранение имён и атрибутов файлов требует вдвое больше памяти. Конкретный объём зависит от длины имени файла в кодировке UTF-8; чтобы оценить требования к памяти при архивации, обычно можно добавлять несколько сотен байт на каждый файл к памяти, необходимой для словаря сжатия. Также помните, что 32-разрядная версия WinRAR не может использовать более 2 ГБ памяти. Если требуется обрабатывать большие количества файлов или использовать крупные словари, предпочтительнее 64-разрядная версия WinRAR.

Максимальная длина пароля для шифрования данных — 127 символов. Более длинные пароли усекаются до этой длины.


Консольная версия RAR

Помимо WinRAR в дистрибутив архиватора входит файл Rar.exe. Это тоже версия RAR для Windows, но она поддерживает только интерфейс командной строки и работает в текстовом (консольном) режиме. Консольная версия RAR удобна для вызова из пакетных файлов (BAT и CMD), для запуска из командной строки и т.п. У неё больше команд и ключей в командной строке, чем у WinRAR. Общие аспекты синтаксиса командной строки WinRAR, описанные в разделе Интерфейс командной строки, верны и для консольного RAR. Однако в этом файле справки нет описания ключей и параметров, присущих только консольной версии. Подробные сведения о консольной версии RAR приведены в файле rar.txt.


Благодарности

Выражаем глубокую благодарность Рону Двайту (Ron Dwight), так много сделавшему для WinRAR и его пользователей. Очень жаль, что Рону уже не суждено увидеть следующие версии WinRAR…

Для работы с архивами ZIP в WinRAR применяется программный код группы Info-ZIP.

Алгоритм сжатия текстов основан на общедоступных исходных кодах PPMII (автор Дмитрий Шкарин) и carryless rangecoder (автор Дмитрий Субботин). Их можно найти на ftp.elf.stuba.sk/pub/pc/pack.

Для шифрования данных в WinRAR используются части кода алгоритма AES (авторы Szymon Stefanek и Brian Gladman), а также исходный код SHA-1 (автор Steve Reid).

Функция вычисления контрольных сумм CRC32 в WinRAR основана на алгоритме Intel Slicing-by-8.

Архивы RAR могут факультативно включать хеш BLAKE2sp (авторы Jean-Philippe Aumasson, Samuel Neves, Zooko Wilcox-O'Hearn и Christian Winnerlein).

Значительно увеличить степень и скорость сжатия архивов RAR позволили полезные советы Александра Хорошева и Булата Зиганшина.

Для распаковки архивов 7z используется библиотека 7zxa.dll, авторские права на которую принадлежат Игорю Павлову, разработчику архиватора 7-Zip. Библиотека распространяется по лицензии LGPL версии 2.1 или новее. Части 7zxa.dll разрешается модифицировать и выполнять обратный инжиниринг исключительно с целями отладки модификаций библиотеки 7zxa.dll в соответствии с LGPL. Для распаковки архивов XZ и LZMA ZIP используется общедоступный LZMA SDK Игоря Павлова. Исходный код библиотеки 7zxa.dll и LZMA SDK доступны на сайте www.7-zip.org.

Для улучшения производительности кодов Рида-Соломона мы использовали документ "Screaming Fast Galois Field Arithmetic Using Intel SIMD Instructions" (авторы James S. Plank, Kevin M. Greenan и Ethan L. Miller). Также выражаем признательность Артёму Дробанову и Булату Зиганшину за примеры и идеи, позволившие повысить эффективность кодов Рида-Соломона.

Графическое оформление WinRAR подготовлено Aditya Nugraha Putra (weirdsgn.com).

Идея встраивания WinRAR в оболочку операционной системы была навеяна отличной программой "RAR shell extension" (автор Ylian Saint-Hilaire).

Отдельная благодарность Андрею Спасибожко за помощь в разработке и реализации ранних версий RAR.

Перевод программы и сопутствующей документации на русский язык: Дмитрий Ерохин. Благодарю своего отца — ты навсегда в моём сердце.

Выражаю благодарность Юрию Марцинчику из Киева, более пяти лет принимавшему участие в поддержке русскоязычной версии WinRAR.


Краткое введение

Режимы графической оболочки и командной строки

WinRAR можно использовать двумя способами: в режиме графической оболочки (со стандартным интерфейсом Windows-программ) и в командной строке. Чтобы использовать WinRAR в режиме графической оболочки, дважды щёлкните левой кнопкой мыши на значке WinRAR — после этого для архивации и извлечения файлов вы сможете пользоваться кнопками и меню. В двух следующих разделах приведены последовательные инструкции.

Как извлечь файлы из архива с помощью графической оболочки WinRAR

Как заархивировать файлы с помощью графической оболочки WinRAR

Для использования WinRAR в режиме командной строки необходимо в системном меню Пуск открыть окно Выполнить... или Программы/Стандартные/Командная строка и ввести нужную команду. Примеры простых команд архивации и извлечения файлов приведены в двух указанных ниже разделах, а более полное описание режима командной строки дано в разделе Интерфейс командной строки. Обратите внимание, что если запустить WinRAR из командной строки без параметров, то будет активизирована графическая оболочка.

Как извлечь файлы из архива в режиме командной строки

Как заархивировать файлы в режиме командной строки

Если при установке WinRAR вы не выключали параметр Встроить WinRAR в оболочку, то извлекать и архивировать файлы можно прямо из оболочки Windows (из Проводника или с рабочего стола). Подробности см. ниже.

Как извлечь файлы из архива в Проводнике или на рабочем столе

Как заархивировать файлы в Проводнике или на рабочем столе


Краткое введение: извлечение файлов в графической среде WinRAR

Чтобы извлечь из архива файлы, используя графическую оболочку WinRAR, сначала нужно открыть архив в WinRAR. Это можно сделать несколькими способами:

· дважды щёлкните левой кнопкой мыши или нажмите Enter на файле архива в оболочке Windows (в Проводнике или на рабочем столе). Если при установке WinRAR был ассоциирован с архивами (что делается по умолчанию), то архив будет открыт в WinRAR. Ассоциировать WinRAR с архивами можно и после его установки в окне Интеграция;

· дважды щёлкните мышью или нажмите Enter на файле архива в окне WinRAR;

· перетащите архив на значок или окно WinRAR. Передварительно убедитесь, что в окне WinRAR не открыт другой архив, иначе перетаскиваемый архив будет добавлен в уже открытый;

· запустите WinRAR из командной строки, указав в качестве параметра имя архива.

Содержимое открытого архива отображается в окне WinRAR. Выделите файлы и папки, которые вы хотите извлечь. Это можно сделать клавишами управления курсором или левой кнопкой мыши при нажатой клавише Shift (как в Проводнике и других Windows-программах). Выделять файлы в WinRAR также можно клавишами Пробел и Insert. Клавиши <+> и <–> на цифровой клавиатуре позволяют выделять и снимать выделение с группы файлов с помощью шаблонов (т.е. задавая маски файлов символами "*" и "?").

Выделив один или несколько файлов, нажмите кнопку Извлечь... вверху окна WinRAR или клавиши Alt+E, введите в появившемся окне нужный путь, после чего нажмите OK. Здесь же можно поменять несколько дополнительных параметров (более подробную информацию см. в разделе Окно указания пути и параметров извлечения).

Во время извлечения отображается окно со статистикой. Если вы хотите прервать извлечение, нажмите кнопку Отмена. Окно WinRAR можно свернуть в область уведомлений, нажав кнопку Фоновый режим. Если извлечение закончится без ошибок, WinRAR вернётся в оболочку, в противном случае появится окно диагностических сообщений.


Краткое введение: извлечение файлов в командной строке

Краткое введение: извлечение файлов в режиме командной строки

Общий синтаксис командной строки для извлечения файлов с полными путями таков:

WinRAR X [ -ключи ] <архив> [ файлы ] [ @файлы-списки ] [ целевая папка\ ]

Для извлечения файлов без путей:

WinRAR E [ -ключи ] <архив> [ файлы ] [ @файлы-списки ] [ целевая папка\ ]

К примеру, чтобы извлечь файл LETTER.TXT в текущую папку из архива LETTERS.RAR, выполните следующую команду:

WinRAR X LETTERS.RAR LETTER.TXT

Расширение архива указывать не обязательно.

Следующая команда извлечёт все файлы *.WAV из архива Songs в папку Audio:

WinRAR X Songs *.WAV Audio\

Файлы для извлечения допускается перечислять не только в командной строке, но и в текстовом файле-списке. В этом случае в командной строке необходимо указать имя этого текстового файла, предварив его символом @. Например, можно создать файл Binaries, содержащий строки

*.exe

*.com

и выполнить команду

WinRAR X TOOLS @Binaries

чтобы извлечь в текущую папку из архива TOOLS все файлы с расширениями .EXE и .COM.

Во время извлечения отображается окно со статистикой. Если вы хотите прервать извлечение, нажмите кнопку Отмена. Окно WinRAR можно свернуть в область уведомлений, нажав кнопку Фоновый режим. Если извлечение закончится без ошибок, WinRAR завершит свою работу, в противном случае появится окно диагностических сообщений.

Подробное описание команд и ключей см. в разделе Интерфейс командной строки.


Краткое введение: извлечение файлов в Проводнике или на рабочем столе

Если при установке WinRAR вы не выключали параметр Встроить WinRAR в оболочку Windows, то извлекать файлы можно прямо в оболочке (Проводнике) Windows. Щёлкните правой кнопкой мыши на значке архива, выберите команду Извлечь файлы..., введите в появившемся окне имя папки, в которую их надо извлечь, и нажмите OK. В этом же окне можно настроить несколько дополнительных параметров (см. подробности в разделе Окно указания пути и параметров извлечения).

Также можно выбрать команду Извлечь в <имя папки>, чтобы распаковать файлы в предложенную папку без каких-либо дополнительных запросов, либо команду Извлечь в текущую папку, чтобы извлечь файлы в текущую папку.

Обратите внимание, что если включён параметр Вложенные контекстные меню в окне параметров интеграции, то для доступа к описанным пунктам меню нужно войти в подменю WinRAR. Если данный параметр выключен, то эти пункты находятся на верхнем уровне контекстного меню.

Ещё один способ извлечь файлы — перетащить один или несколько архивов с нажатой правой кнопкой мыши в целевую папку, а затем выбрать в появившемся меню команду Извлечь в текущую папку.


Краткое введение: архивация файлов в графической среде WinRAR

Прежде всего, запустите WinRAR. Для этого дважды щёлкните мышью или нажмите Enter на значке WinRAR. Также можете запустить его из меню Пуск: зайдите в группу Программы, потом в группу WinRAR и выберите пункт WinRAR.

После запуска WinRAR покажет в своём окне список файлов и папок в текущей папке. Перейдите в папку с файлами, которые вы хотите заархивировать. Чтобы сменить текущий диск, нажмите клавиши Ctrl+D, воспользуйтесь списком дисков (под панелью инструментов) или щёлкните на маленьком значке диска в нижнем левом углу окна. Для перехода в родительскую папку нажмите Backspace или Ctrl+PgUp, либо щёлкните на маленькой кнопке Вверх (под панелью инструментов), либо дважды щёлкните на папке ".." в списке файлов. Чтобы перейти в другую папку, нажмите на ней Enter или Ctrl+PgDn, либо дважды щёлкните мышью. Для перехода в корневую папку текущего диска или в папку, где находится архив, нажмите клавиши Ctrl+\.

После того как вы вошли в папку с нужными файлами, выделите файлы и папки, которые хотите заархивировать. Это можно сделать клавишами управления курсором или левой кнопкой мыши при нажатой клавише Shift (как в Проводнике и других программах Windows). Выделять файлы в окне WinRAR можно также клавишами Пробел и Insert. Клавиши <+> и <–> на цифровой клавиатуре позволяют выделять и снимать выделение с группы файлов с помощью шаблонов (т.е. задавая маски файлов символами "*" и "?").

Выделив один или несколько файлов, нажмите кнопку Добавить, либо клавиши Alt+A, либо выберите команду Добавить файлы в архив в меню Команды. В появившемся окне введите имя архива или просто подтвердите предложенное имя. Здесь же можно выбрать формат нового архива (RAR или ZIP), метод сжатия, размер тома и другие параметры архивации (см. подробности в разделе Окно ввода имени архива и его параметров). Нажмите OK, чтобы создать архив.

Во время архивации отображается окно со статистикой. Если вы хотите прервать процесс, нажмите Отмена. Окно WinRAR можно свернуть в область уведомлений кнопкой Фоновый режим. По окончании архивации окно статистики исчезнет, а созданный архив станет текущим выделенным файлом.

Добавлять файлы в существующий архив RAR можно также методом перетаскивания. Выделите архив в окне WinRAR и нажмите Enter (или дважды щёлкните мышью) на его имени — WinRAR прочитает архив и покажет его содержимое. Теперь вы можете добавлять файлы в архив, просто перетаскивая их из другой программы в окно WinRAR.


Краткое введение: архивация файлов из командной строки

Краткое введение: архивация файлов в режиме командной строки

Общий синтаксис командной строки для архивации файлов таков:

WinRAR A [-ключи ] <архив> [ файлы ] [ @файлы-списки ]

Например, если вы хотите добавить файл LETTER.TXT в архив LETTERS.RAR, введите:

WinRAR A LETTERS.RAR LETTER.TXT

Если не указать расширение архива, WinRAR будет использовать формат архива по умолчанию, заданный в профиле архивации по умолчанию. Однако это можно переопределить и задать тип архива явно, введя соответствующее расширение файла архива — .RAR или .ZIP.

В следующем примере добавляются все файлы *.WAV в непрерывный RAR-архив Songs:

WinRAR A -S Songs.RAR *.WAV

Файлы для архивации можно указывать не только в командной строке, но и в текстовом файле-списке. В этом случае в командной строке необходимо ввести имя этого файла, предваря его символом @. Можно, например, создать файл Binaries, содержащий строки *.exe и *.com, и выполнить команду

WinRAR A TOOLS.ZIP @Binaries

чтобы добавить в ZIP-архив TOOLS все файлы из текущей папки с расширениями .EXE и .COM.

Во время архивации отображается окно со статистикой. Если вы хотите прервать архивацию, нажмите кнопку Отмена. Окно WinRAR можно свернуть в область уведомлений, нажав кнопку Фоновый режим. Если архивация закончится без ошибок, WinRAR завершит свою работу, в противном случае появится окно диагностических сообщений.

Подробное описание команд и ключей см. в разделе Интерфейс командной строки.


Краткое введение: архивация файлов в Проводнике или на рабочем столе

Если при установке WinRAR вы не выключали параметр Встроить WinRAR в оболочку, то архивировать файлы можно прямо в оболочке (Проводнике) Windows. В Проводнике или на рабочем столе выделите файлы, которые хотите заархивировать, нажмите правую кнопку мыши на выделенных файлах и выберите команду Добавить в архив. В появившемся окне введите имя архива или просто подтвердите предложенное имя. Здесь же можно выбрать формат нового архива (RAR или ZIP), метод сжатия, размер тома и другие параметры архивации. См. подробности в описании окна ввода имени архива и его параметров. Нажмите OK, чтобы создать архив. Он будет создан в папке с выделенными файлами.

Чтобы добавить файлы в предложенный архив без дополнительных запросов, воспользуйтесь командой Добавить в <имя архива>. В этом случае будут применены параметры из профиля архивации по умолчанию.

Обратите внимание, что если включён параметр Вложенные контекстные меню в окне параметров интеграции, то для доступа к описанным пунктам меню необходимо открыть подменю WinRAR. Если данный параметр выключен, то эти пункты будут находиться на верхнем уровне контекстного меню.

Ещё один способ заархивировать файлы — перетащить значки файлов на значок существующего архива, чтобы добавить файлы в этот архив.


RAR или ZIP?

WinRAR может создавать архивы двух разных форматов: RAR и ZIP. Ниже описаны сравнительные особенности каждого из них.

Архивы ZIP

Основное преимущество формата ZIP — его популярность. Так, большинство архивов в Интернете имеют формат ZIP. Если вы хотите кому-то отправить архив, но не уверены, что у адресата есть программа WinRAR для распаковки архива, то имеет смысл использовать ZIP. Впрочем, в этом случае можно отправить самораспаковывающийся (SFX) архив — такие архивы чуть больше обычных, но для их распаковки не требуется никаких дополнительных программ.

Другое преимущество ZIP — скорость. Архивы ZIP обычно создаются быстрее архивов RAR, однако на современных компьютерах эта разница в скорости зачастую не имеет решающего значения.

Архивы RAR

Формат RAR обычно обеспечивает лучшее сжатие, чем ZIP, особенно в режиме непрерывного (solid) архивирования. Многотомные архивы RAR функционально богаче, чем разделённые на части (split) ZIP, например, они значительно удобнее в создании и распаковке, в том числе могут быть самораспаковывающимися.

Кроме того, у формата RAR есть ряд очень важных функций, которых нет в ZIP, например поддержка данных для восстановления, позволяющих восстанавливать физически повреждённые архивы, блокировка архивов для предотвращения случайной модификации особо ценной информации, и др.

Оба формата — RAR и ZIP — позволяют обрабатывать файлы практически неограниченного размера (до 8 589 934 591 ГБ).


Формат архивов RAR5

В WinRAR 5.0 появилась новая версия формата архивов RAR — RAR5.

Особенности формата RAR5:

  • Максимальный размер словаря сжатия увеличен до 1 ГБ. При упаковке больших файлов, особенно в непрерывном режиме, крупный словарь нередко позволяет достичь более высокой степени сжатия.
  • Шифрование данных основано на алгоритме AES-256, который теоретически более надёжен, чем AES-128, использующийся в RAR4.
  • Данные для восстановления используют коды коррекции ошибок Рида-Соломона, которые значительно устойчивее к множественным повреждениям, чем в RAR4.
  • Ускорены операции с томами для восстановления. Максимальное количество томов RAR+REV в RAR5 составляет 65 535, а не 255, как это было ранее.
  • Информация о времени файлов хранится во Всемирном координированном времени (Coordinated Universal Time, UTC), а не в местном, как это было в RAR4, благодаря чему упростился обмен файлами между пользователями в разных часовых поясах.
  • В качестве контрольных сумм файлов можно использовать BLAKE2sp. В отличие от контрольных сумм CRC32, для BLAKE2 практически исключена ситуация, когда два разных файла имеют одинаковую контрольную сумму. Поэтому BLAKE2 можно применять для идентификации файлов.
  • В архивы можно добавлять информацию для быстрого открытия, ускоряющую чтение оглавления архива.
  • Поддержка многопоточности в алгоритме распаковки. Прирост скорости особенно заметен при обработке больших файлов с плохо сжимаемыми данными и при вычислении контрольных сумм BLAKE2.
  • Поддержка точек соединения (reparse points), символических (мягких) ссылок и жёстких ссылок для накопителей с файловой системой NTFS.
  • Возможность хранить вторые и последующие копии идентичных файлов как ссылки на первую копию такого файла.
  • Полная поддержка Юникода. Имена файлов и комментарии хранятся в формате UTF-8.

В RAR5 не включены некоторые устаревшие или неэффективные функции формата RAR4:

  • В архивах RAR5 недоступны особые алгоритмы упаковки, среди которых сжатие текста, необработанного аудио и полноцветной (TrueColor) несжатой графики, исполняемых файлов Itanium. Необработанные аудиоданные и графика TrueColor, распознаваемые RAR предыдущих версий, сегодня стали значительно менее распространёнными. Алгоритм сжатия текста на современных многоядерных процессорах работает существенно медленнее, чем обычный алгоритм сжатия. Однако хотя эти алгоритмы не поддерживаются в архивах RAR5, новейшие версии WinRAR способны распаковывать любые архивы RAR4, включая те, в которых использованы упомянутые выше алгоритмы. В RAR5 по-прежнему включены алгоритмы сжатия исполняемых файлов Intel IA-32 и дельта-сжатия, которые остаются эффективными для современных данных и аппаратуры.
  • При создании многотомных архивов не поддерживается старый стиль именования томов на основе расширений файлов — archive.r00, archive.r01 и т.д. Главной целью такого именования была совместимость с файловой системой MS-DOS, однако на таких платформах, как Windows, где расширения файлов используются для определения типов файлов и ассоциаций, эта схема неудобна.

Архивы RAR5 не распознаются старыми программами, включая WinRAR версий более ранних, чем 5.0. Поэтому если нужна уверенность, что архив будет распакован старым ПО, имеет смысл выбирать формат архивов RAR4. Это можно сделать либо в окне Имя и параметры архива, либо с помощью ключа -ma в командной строке. Кроме того, формат RAR4 может быть предпочтительнее, если требуется использовать особые алгоритмы сжатия текста или мультимедийных данных, либо когда нужна старая схема именования томов.


Поддержка архивов других форматов

WinRAR полностью поддерживает архивы RAR и ZIP, а также способен выполнять основные операции с архивами 7Z, ARJ, BZ2, CAB, GZ, ISO, JAR, LZ, LZH, TAR, UUE, XZ, Z, созданными с помощью других программ. Такие архивы можно распаковывать, просматривать их содержимое, показывать комментарии и информацию об архиве. Никаких дополнительных программ, кроме WinRAR, для работы с этими архивами не требуется.

Кроме того, WinRAR умеет объединять разделённые на несколько частей файлы c расширениями .001, .002 и т.д. Таким образом, можно открыть файл .001 как обычный архив и затем распаковать его содержимое. Перед началом извлечения (объединения) убедитесь, что все части находятся в одной папке.


Непрерывные архивы

Непрерывные (solid) архивы

Непрерывный (solid) архив — это архив, упакованный специальным способом, при котором несколько или все сжимаемые файлы рассматриваются как один последовательный поток данных. Непрерывная архивация доступна только в формате RAR, для ZIP такого типа упаковки не существует. Чтобы использовать непрерывное архивирование, включите параметр Создать непрерывный архив в окне Имя и параметры архива или укажите в командной строке ключ -s.

Непрерывная архивация значительно увеличивает степень сжатия при добавлении в архив существенного количества небольших файлов с похожим содержимым.

Недостатки и особенности непрерывных архивов:

· обновление (добавление файлов в уже существующий непрерывный архив или удаление из него) выполняется медленнее, чем в обычных архивах;

· чтобы извлечь один файл из непрерывного архива, нужно проанализировать все файлы, расположенные в архиве перед ним, поэтому распаковка отдельных файлов из середины или конца непрерывного архива происходит медленнее, чем из обычного архива. Однако если извлекаются все или первые последовательно идущие файлы, то время распаковки практически такое же, как у обычного архива;

· если в непрерывном архиве какой-либо файл окажется повреждённым, то не удастся извлечь и все файлы, идущие в архиве после него. Поэтому при сохранении непрерывного архива на потенциально ненадёжных носителях настоятельно рекомендуется добавлять данные для восстановления (эти данные могут пригодиться и в других случаях, поэтому без веских причин не отказывайтесь от них).

Непрерывные архивы предпочтительнее обычных, когда:

· архив предполагается редко обновлять;

· планируется чаще распаковывать архив целиком, а не извлекать из него один или несколько файлов;

· степень сжатия важнее скорости.

Файлы в непрерывных архивах обычно отсортированы по расширению, однако сортировку можно отменить с помощью ключа -ds или самостоятельно задать альтернативный порядок сортировки с помощью особого файла — rarfiles.lst.

Многотомные и самораспаковывающиеся архивы тоже могут быть непрерывными.

См. также: ключ -s, ключ -ds, файл-список RarFiles.lst


Тома (архивы из нескольких частей)

WinRAR позволяет создавать архивы, состоящие из нескольких частей. Такие архивы называются многотомными, а составляющие такие архивы отдельные файлы — томами. Тома обычно используются для хранения больших объёмов данных на сменных носителях или для передачи данных по электронной почте.

С помощью WinRAR можно создавать тома в форматах RAR и ZIP. Тома ZIP также часто называют разделёнными на части (split) ZIP-файлами.

Тома RAR по умолчанию получают имена вида "архив.partNNN.rar", где NNN — номер тома. Для формата RAR4 с помощью ключа -vn можно выбрать схему именования, основанную на расширениях файлов: первый том получает расширение .rar, а расширения последующих томов нумеруются как .r00, .r01, .r02 ... до .r99. Для архивов формата RAR5 ключ -vn и имена на основе расширений не поддерживаются.

Тома RAR также могут быть непрерывными и самораспаковывающимися. Первый самораспаковывающийся том имеет другое (не .rar) расширение, например у SFX-томов для Windows это .exe.

Чтобы распаковать тома RAR, нужно начинать распаковку с первого тома. Если тома находятся на несменном носителе (например на жёстком диске), необходимо перед началом извлечения поместить все тома в одну папку.

Тома ZIP получают имена вида "архив.zip", "архив.z01", "архив.z02". Для выполнения всех операций обработки архива, например чтобы начать извлечение или открыть архив, нужно использовать том с расширением .zip.

В отличие от томов RAR, тома ZIP не могут быть самораспаковывающимися. Для создания или распаковки ZIP-томов с помощью WinRAR необходимо, чтобы они были доступны все сразу. Поэтому создавать или распаковывать тома ZIP на сменных носителях, по одному тому на диск, невозможно. Если вы хотите получить многотомный ZIP-архив, нужно сначала создать все тома в одной и той же папке, после чего вручную скопировать их на сменные диски. Аналогично и с извлечением: сначала требуется собрать все тома ZIP в одной папке, и лишь затем начинать распаковку.

Уже созданные многотомные архивы не допускают изменения, т.е. в них нельзя добавлять, обновлять или удалять файлы. Можно только создать новый набор томов.

Начиная с версии 3.40, WinRAR сохраняет номер тома внутри самого RAR-тома. Этот номер можно увидеть вверху окна с информацией, если вызвать его командой Показать информацию на архивном томе. Этот номер может пригодиться для восстанавления имён файлов вручную, если тома по какой-либо причине окажутся переименованными.


Тома для восстановления

Тома для восстановления — это создаваемые WinRAR особые файлы с расширением .rev, которые позволяют воссоздавать отсутствующие или повреждённые тома в многотомном архиве. Тома для восстановления можно использовать только с многотомными архивами.

Такие тома особенно полезны при резервном копировании или, к примеру, при отправке многотомного архива в сетевую конференцию (форум), когда до некоторых подписчиков по каким-то причинам дошли не все обычные тома. В подобной ситуации может быть эффективнее отослать тома для восстановления, а не обычные тома, так как не нужно беспокоиться, какой именно том кому отправить.

С помощью каждого тома для восстановления можно воссоздать один любой отсутствующий том RAR-архива. Например, если архив состоит из 30 томов, и для него создано 3 тома для восстановления, то можно воссоздать любые 3 отсутствующих тома. Если файлов .rev меньше, чем отсутствующих томов, воссоздать такой архив невозможно. Общее количество обычных томов и томов для восстановления не может превышать 255 для формата RAR4, и 65 535 для формата RAR5. Томов для восстановления должно быть меньше, чем томов RAR-архива.

После того как были созданы томы для восстановления, исходные тома RAR-архива уже нельзя модифицировать. При воссоздании отсутствующих томов алгоритм восстановления использует данные, хранящиеся как в REV-файлах, так и в томах RAR. Поэтому если после создания REV-файлов вы измените тома RAR, например заблокируете их от изменения, то восстановление выполнить не удастся.

Помимо собственно защитных данных, в томах для восстановления RAR5 хранится служебная информация, в частности контрольные суммы защищённых RAR-файлов. Поэтому REV-тома чуть больше по размеру, чем тома RAR, которые они защищают. Если вы собираетесь копировать отдельные файлы RAR и REV на какой-либо сменный носитель, следует это учитывать и указывать размер томов RAR на несколько килобайт меньше, чем объём носителя.

Чтобы WinRAR воссоздал недостающие и повреждённые тома, нужно либо щёлкнуть мышью по файлу .rev, либо воспользоваться командой rc. Кроме того, если WinRAR при распаковке не находит следующий том, но обнаруживает необходимое число файлов .rev, то недостающие тома воссоздаются автоматически.

Чтобы создать тома для восстановления, используйте соответствующий параметр в окне Имя и параметры архива на вкладке Дополнительно или аналогичным параметром в окне команды защиты архива от повреждений. В режиме командной строки тома для восстановления создаются командой RV или ключом -rv.

Исходные копии повреждённых томов перед реконструкцией переименовываются в *.bad. Например, volname.part03.rar будет переименован в volname.part03.rar.bad.


Самораспаковывающиеся архивы

Самораспаковывающиеся архивы (SFX)

Самораспаковывающийся (SFX, от англ. SelF-eXtracting) архив — это архив, к которому прикреплён исполняемый модуль. Этот модуль позволяет извлекать файлы простым запуском архива как обычной программы, то есть для извлечения содержимого SFX-архива не нужны никакие дополнительные внешние программы. Вместе с тем, WinRAR может работать с SFX-архивами точно так же, как с любыми другими, поэтому если вы не хотите запускать SFX-архив (например, когда нет гарантии, что в нём нет вирусов), то для его просмотра или распаковки можно использовать WinRAR.

Как и любые другие исполняемые файлы, SFX-архивы обычно имеют расширение .EXE.

SFX-архивы удобны в тех случаях, когда нужно передать кому-то архив, но вы не уверены, что у адресата есть соответствующий архиватор для его распаковки. SFX-архивы также можно использовать для распространения своих собственных программ. Например, при создании дистрибутива WinRAR используется SFX-модуль Default.sfx с графическим интерфейсом.

Чтобы создать SFX-архив из командной строки, можно использовать ключ -sfx при создании нового архива или команду S для преобразования существующего архива в SFX. При создании нового архива в оболочке WinRAR включите параметр Создать SFX-архив в окне ввода имени и параметров архива.

Если нужно создать SFX-архив из уже существующего, то войдите в него и нажмите кнопку SFX.

В дистрибутив WinRAR входит несколько SFX-модулей. Все SFX-модули (они имеют расширение .sfx) должны находиться в той же папке, что и WinRAR. По умолчанию WinRAR всегда использует модуль Default.sfx, но можно указать имя другого модуля сразу после ключа -sfx или команды S. Например, для преобразования архива myarchive.rar в SFX с модулем WinCon.SFX выполните следующую команду:

WinRAR SWinCon.SFX myarchive.rar

В оболочке WinRAR нужный SFX-модуль можно выбрать из списка при выполнении команды Преобразовать архив в SFX.

Информация об SFX-модулях:

Графические SFX-модули RAR и ZIP (Default.SFX и Zip.SFX)

Консольный SFX-модуль RAR (WinCon.SFX)


Шифрование

Форматы RAR и ZIP поддерживают шифрование информации. Чтобы зашифровать файлы, нужно до начала архивации указать пароль — в командной строке, в меню или на вкладке "Общие" в окне "Имя и параметры архива". В командной строке это делается ключом -p<пароль>. Для ввода пароля в оболочке WinRAR нажмите <Ctrl+P> (либо выберите команду "Установить пароль по умолчанию" в меню "Файл" или щёлкните по маленькому значку ключа в левом нижнем углу окна WinRAR). Чтобы ввести пароль в окне "Имя и параметры архива", нажмите кнопку "Установить пароль" на вкладке "Дополнительно".

В отличие от ZIP, в архивах RAR можно шифровать не только сами данные файлов, но и другие важные области: имена файлов, размеры, атрибуты, комментарии и прочие блоки. Чтобы использовать общее шифрование, включите параметр "Шифровать имена файлов" в окне ввода пароля. В режиме командной строки для этого вместо ключа -p[пароль] нужно указать ключ -hp[пароль]. Зашифрованный в таком режиме архив без пароля нельзя не только распаковать, но даже просмотреть список находящихся в нём файлов.

Непрерывные RAR-архивы и архивы с зашифрованными именами файлов могут содержать только один пароль, одинаковый для всех файлов в архиве. Файлы в обычных (не непрерывных) архивах RAR с незашифрованными именами файлов и в архивах ZIP могут быть зашифрованы с разными паролями (т.е. в одном архиве могут находиться файлы с разными паролями).

Не забывайте удалять введённый пароль после того, как он становится ненужным, иначе вы можете случайно запаковать какие-либо файлы с паролем, не намереваясь этого делать. Чтобы удалить пароль, введите пустую строку в окне ввода пароля или перезапустите WinRAR. Когда пароль введён, жёлтый значок ключа становится красным. Кроме того, в начале архивации с паролем заголовок окна имени и параметров архива дважды мигнёт.

Если в окне ввода пароля был включён параметр "Использовать для всех архивов", а в качестве пароля указана пустая строка, команды извлечения и тестирования будут пропускать все зашифрованные файлы и архивы. В этом режиме значок ключа в строке состояния WinRAR не отображается.

Если вы ввели пароль непосредственно в окне "Имя и параметры архива", то отменять его самостоятельно не нужно — пароль будет действовать только в течение одной операции архивирования, по окончании которой автоматически сбросится.

При извлечении зашифрованных файлов можно ввести пароль заранее, хотя это и необязательно. Если пароль не был введён перед началом извлечения, то при обнаружении зашифрованного файла WinRAR спросит пароль у пользователя.

Архивы RAR5 шифруются по алгоритму AES-256 в режиме CBC, архивы RAR4 шифруются по алгоритму AES-128 в режиме CBC. Функция деривации ключа в RAR5 основана на PBKDF2 с использованием HMAC-SHA256.

По умолчанию в архивах ZIP применяется алгоритм шифрования AES-256 в режиме CTR. Однако такие архивы могут быть несовместимыми с некоторыми старыми программами распаковки ZIP-файлов. Если требуется совместимость со старыми программами, включите параметр "Традиционное (устаревшее) шифрование ZIP" в окне установки пароля (помните, что такое шифрование значительно менее стойкое, чем AES).

Хотя WinRAR позволяет использовать шифрование AES-256 как в RAR, так и в ZIP, применяемые в RAR параметры функции деривации ключа делают шифрование RAR предположительно более устойчивым к атакам перебором (brute force). Кроме того, в RAR можно шифровать имена и другие свойства файлов. Поэтому для защиты важной информации лучше выбирать формат RAR. Для обеспечения достаточно высокого уровня надёжности используйте пароли длиной не менее восьми символов. Избегайте в паролях распространённые слова – они ослабляют пароль. Обратите внимание, что в паролях учитывается рЕгиСтР букв. Максимальная длина пароля — 127 символов. Если указан более длинный пароль, то он усекается до этой длины.

Если параметр "Шифровать имена файлов" выключен, контрольные суммы зашифрованных в архивах RAR5 файлов изменяются с помощью особого, зависящего от пароля алгоритма. Это важно, поскольку иначе можно было бы угадывать содержимое файлов только по значениям контрольных сумм, без знания пароля. Особенно велик этот риск в случае маленьких файлов или при использовании надёжных контрольных сумм BLAKE2. Поэтому не ждите, что контрольные суммы зашифрованных файлов совпадут с действительными значениями CRC32 или BLAKE2. Если параметр "Шифровать имена файлов" включён, контрольные суммы хранятся в немодифицированном виде, поскольку доступ к ним возможен лишь после ввода правильного пароля.

ВНИМАНИЕ: Если вы забудете пароль, то не сможете извлечь из архива зашифрованные файлы, и в этом вам не сумеет помочь даже сам автор WinRAR.


Комментарий архива

В архивы RAR и ZIP можно добавлять необязательную текстовую информацию — комментарий архива, содержащий его описание, пояснения, инструкции и т.п. Чтобы добавить комментарий вручную к уже существующему архиву в режиме графической оболочки WinRAR, используйте команду "Добавить комментарий архива", для чтения комментария из файла в режиме командной строки — команду "c " или ключ "-z<файл>".

Комментарий можно также указать непосредственно при архивации файлов в окне "Имя и параметры архива".

Если вы открываете в WinRAR архив, содержащий комментарий, а в окне настроек программы включён параметр "Показывать комментарий архива", то справа от списка файлов будет отображаться окно с комментарием. Ширину этого окна можно изменять, перетаскивая мышью его левый край.


Защита архивов от повреждений

В архивы RAR можно добавлять особую избыточную информацию — данные для восстановления. Такие данные увеличивают размер архива, но позволяют восстановить его даже в случае физического повреждения (например из-за сбоя диска) или потери информации вследствие любых других причин при условии, что повреждение не слишком серьёзное. Починка повреждённого архива выполняется командой Восстановить архив. Архивы ZIP не могут содержать данных для восстановления.

Чтобы добавить в архив данные для восстановления, включите параметр Добавить данные для восстановления в окне Имя и параметры архива. Ещё один способ — включить соответствующий параметр в профиле архивации по умолчанию, тогда данные для восстановления будут добавляться в архив после любого его изменения.

О том, как добавить данные для восстановления в режиме командной строки, см. в описаниях команды rr[N] и ключа -rr[N].

Для исправления ошибок данные для восстановления в архивах RAR5 используют коды Рида-Соломона. Если повреждения идут подряд, возможности восстановления в RAR5 примерно такие же, как в RAR4 — можно восстанавливать информацию чуть меньшего объёма, чем размер данных для восстановления. Однако если повреждения множественные и расположены в разных областях архива, средства восстановления в RAR5 значительно эффективнее, чем в RAR4.

Данные для восстановления в RAR4 находятся в секторах размером 512 байт, общее число которых не может превышать 524 288. Таким образом, их полезный объём и размер восстанавливаемой информации не могут превышать 256 МБ. В архивах RAR5 данные для восстановления могут быть такого же размера, как сам архив.

Размер данных для восстановления задаётся на вкладке Дополнительно в окне Имя и параметры архива как процент от размера архива. Также его можно указать в команде Добавить данные для восстановления. Чем больше данных для восстановления, тем более крупную повреждённую область можно восстановить, однако при этом сильнее увеличивается размер архива и замедляется обработка. Как правило, разумный объём — 3–10% от размера архива. Так как помимо собственно защитных данных требуется хранить служебную информацию, действительный объём данных для восстановления соответствует указанному пользователем значению лишь приблизительно, и чем меньше архив, тем больше может быть эта разница.

Для восстановления повреждённого архива, защищённого с помощью данных для восстановления, в WinRAR служит команда Восстановить. В командной строке используется команда r. Восстановленный архив получает имя fixed.архив.rar, где "архив" – это имя исходного (повреждённого) архива. Если повреждённый архив не защищён данными для восстановления или когда его невозможно полностью восстановить из-за серьёзности повреждений, то выполняется вторая стадия восстановления, при которой реконструируется только структура архива. Файлы с неверной контрольной суммой после этой операции восстановить не удастся, однако становится возможным восстановить неповреждённые файлы, которые ранее были недоступны из-за нарушения структуры архива. Данный метод в основном работает с обычными, но не с непрерывными архивами. Для архивов с зашифрованными именами файлов эта стадия не выполняется — такие архивы могут быть исправлены только при наличии данных для восстановления.

По окончании второго этапа реконструированному архиву присваивается имя rebuilt.архив.rar, где "архив" – это имя исходного архива.

Данные для восстановления RAR5 более устойчивы к повреждениям их самих, поэтому даже при частичной порче этих данных их всё равно можно использовать для восстановления информации. Обратите, однако, внимание, что команда Восстановить архив не исправляет повреждённые блоки в данных для восстановления, восстанавливаются только файловые данные. После успешной починки архива следует создать новые данные для восстановления для сохранённых файлов.

Данные для восстановления в RAR4 и RAR5 наиболее эффективны, если повреждённая информация в архиве находится на своих исходных местах, т.е. никуда не смещена. Если для копирования архива с повреждённого носителя вы применяете какую-либо специальную программу, позволяющую на выбор заполнять повреждённые области нулями (или любыми другими данными), либо вырезать такие места из файла, то лучше выбрать заполнение, чтобы сохранить исходную последовательность данных. Тем не менее данные для восстановления обеих версий пытаются восстановить информацию даже в неоптимальном режиме, когда она была смещена в разумных пределах из-за вставок или удалений. Данные для восстановления в RAR5 обрабатывают удаления и вставки эффективнее, чем в RAR4.


Блокировка архивов

Архивный формат RAR поддерживает блокировку архивов. Заблокированный архив невозможно изменить с помощью WinRAR, таким образом, можно блокировать важные данные, чтобы их нельзя было случайно модифицировать.

Блокировка архива выполняется соответствующей командой в режиме оболочки WinRAR или командой K и ключом -k в командной строке.


Выбор оптимальных параметров архивации

При создании нового архива на вкладке Общие в окне "Имя и параметры архива" предлагается несколько относящихся к сжатию параметров. Сначала нужно выбрать формат архива: RAR, ZIP или RAR4. Формат ZIP предпочтителен, когда нет уверенности, что у получателя есть WinRAR или другая программа для распаковки RAR-архивов. В противном случае рекомендуется выбирать формат RAR, так как он значительно богаче функционально и обеспечивает более сильное сжатие. RAR4 – это предыдущая версия формата RAR, у которой отсутствуют некоторые важные изменения, появившиеся в формате RAR5 в 2013 году, например шифрование AES-256, более эффективная защита архивов от повреждений, увеличенные размеры словаря. Ряд старых программ, включая WinRAR версий ниже 5.0, неспособны распаковывать архивы RAR новейшего формата. Если вы хотите создавать архивы RAR, совместимые с таким ПО, то выберите формат RAR4.

Вслед за форматом архива необходимо выбрать метод архивации. Доступны следующие методы: "Без сжатия", "Скоростной", "Быстрый", "Обычный", "Хороший" и "Максимальный". Метод "Максимальный" обеспечивает наиболее высокую степень сжатия, но с наименьшей скоростью. Напротив, "Скоростной" сжимает сравнительно плохо, но очень быстро. При выборе метода "Без сжатия" файлы просто добавляются в архив с максимально возможной скоростью в своём исходном виде, т.е. без сжатия. Для создания ежедневных резервных копий лучше всего использовать метод "Скоростной", для распространения данных в Интернете — "Максимальный", а метод "Обычный" хорошо подходит для повседневного применения, например для упаковки вложений в сообщения электронной почты.

Если выбран формат ZIP, то на этом этапе подготовка заканчивается. Форматы RAR и RAR4 поддерживают ещё два важных параметра, влияющих на степень сжатия данных — размер словаря и непрерывное (solid) архивирование.

Словарь — это область в памяти, используемая алгоритмом упаковки для поиска и сжатия повторяющихся наборов данных. Чем больше словарь, тем обычно лучше степень сжатия крупных файлов, особенно в режиме непрерывного архивирования, однако при этом снижается скорость упаковки и повышаются требования к памяти. В повседневной работе мы рекомендуем использовать словарь размером 32 МБ для формата RAR5, и 4 МБ — для формата RAR4. Подробнее о размере словаря можно прочитать тут.

Если включён параметр "Создать непрерывный архив", архивируемые файлы сжимаются как один непрерывный поток данных, благодаря чему достигается высокая степень сжатия при упаковке значительного количества небольших файлов с однотипным содержимым. Следует, однако, иметь в виду, что изменение уже созданных непрерывных архивов выполняется медленнее, чем обычных, и, кроме того, в случае повреждения непрерывного архива потери данных могут быть более существенными, чем при повреждении обычного (не solid) архива. Этот режим подробно описан в разделе "Непрерывные архивы".

Вот и все основные установки, влияющие на степень и скорость сжатия. Но даже их необязательно настраивать перед каждой архивацией. Можно просто один раз указать свои наиболее часто используемые установки в профиле архивации по умолчанию, задаваемом в окне "Параметры архивации".


Знакомство с интерфейсом WinRAR

В этом разделе кратко описаны основные части интерфейса WinRAR.

Меню WinRAR содержит следующие пункты: Файл, Команды, Операции, Избранное, Настройки и Справка. Щёлкните на интересующей вас ссылке, чтобы показать информацию о соответствующем меню.

Ещё один элемент интерфейса — панель инструментов. Она находится ниже меню и выше списка файлов. Кнопки на панели инструментов повторяют пункты из меню Команды (обратите внимание, что у всех пунктов в этом меню есть "горячие клавиши" для быстрого доступа). Во время просмотра содержимого архива некоторые кнопки могут быть отключены, если их функции неприменимы к архиву. При желании вы можете выбрать отображаемые кнопки, убрать текст с кнопок или уменьшить их размер, вызвав окно общих параметров программы или щёлкнув правой кнопкой мыши на панели инструментов.

Под панелью инструментов находится маленькая кнопка со стрелкой вверх и строка списка дисков. При нажатии этой кнопки происходит переход в родительскую папку. Список дисков служит для выбора текущего диска или, скажем, сети. Этот список также можно открыть нажатием клавиши F4. При желании кнопку Вверх и список дисков можно перетащить в правый угол панели инструментов. Текущий диск также можно изменить нажатием Ctrl+D или щелчком мыши на маленьком значке диска в строке состояния.

Ниже панели инструментов расположено файловое окно. В нём отображается содержимое текущей папки или, если в WinRAR открыт архив, содержимое архива. Эти режимы называются режимом управления файлами и режимом управления архивами. Для каждого файла выводятся имя, размер, тип и дата изменения. Для файлов в архиве показываются ещё два параметра — контрольная сумма и упакованный размер. Контрольная сумма — это особое значение, вычисляемое на основании данных файла, с её помощью можно определить, не повреждены ли упакованные в архиве файлы. Для вычисления контрольных сумм WinRAR может использовать либо CRC32, либо алгоритм BLAKE2.

Все параметры представлены в виде колонок. Порядок сортировки файлов можно поменять щелчком на заголовке колонки (там же синей стрелкой указывается направление сортировки). Кроме того, можно изменить ширину колонок, перетаскивая мышью разделители их заголовков. Несколько дополнительных параметров списка можно изменить в окне Список файлов.

Если находящийся в архиве файл зашифрован, то после его имени будет стоять звёздочка ( * ). Если файл продолжается в следующем томе, то после его имени будут стоять символы "-->". Если файл продолжается из предыдущего тома, то после имени будут стоять символы "<--". А если файл продолжается из предыдущего и переходит на следующий том, то после его имени будут стоять символы "<->".

Прежде чем обрабатывать файлы, их необходимо выделить. Помимо стандартных способов выделения Windows в WinRAR для той же цели служат несколько дополнительных клавиш: Пробел, Insert, а также <+> и <–> на цифровой клавиатуре. Более подробно это описано в разделе Выделение файлов.

Для навигации по списку файлов можно использовать комбинации клавиш. Чтобы перейти в родительскую папку, нажмите Backspace или Ctrl+PgUp, либо дважды щёлкните мышью на папке ".." в списке файлов. Если вы сделаете это в корневой папке архива, то закроете архив и перейдёте в папку на диске, где он находится. Для перехода в другую папку нажмите Enter или Ctrl+PgDn, либо дважды щёлкните левой кнопкой мыши на этой папке. То же действие на файле архива приведёт к открытию архива. Для перехода в корневую папку диска или папку с архивом служит комбинация клавиш Ctrl+\.

Чтобы попробовать открыть как архив файл с расширением, отличным от стандартного архивного, нажмите Ctrl+PgDn. Например, если нужно проверить, является ли exe-файл самораспаковывающимся архивом, но вы не хотите его запускать, нажмите Ctrl+PgDn на имени этого файла. Если файл — SFX-архив, то WinRAR покажет его содержимое.

Если щёлкнуть правой кнопкой мыши на списке файлов, то появится меню с командами интерфейса и управления файлами. Эти команды доступны также из обычных меню WinRAR, с панели инструментов и с помощью сочетаний клавиш, поэтому вы можете использовать наиболее удобный для себя способ.

В левой части окна WinRAR может отображаться панель с деревом папок, если это включено в подменю Дерево папок в меню Настройки. Дерево папок удобно использовать для быстрой навигации по папкам на диске и в архиве. Ширину панели с деревом можно изменять, перетаскивая мышью её правую границу.

Если включён параметр Показывать комментарий в окне общих параметров, а в открытом архиве есть комментарий, то он будет показан в специальном окне справа от списка файлов. Ширину окна комментария можно изменять, перетаскивая мышью его левый край.

Внизу окна WinRAR (под списком файлов) находится строка состояния. В её левой части расположены два маленьких значка: "накопитель" и "ключ". Щелчком по значку "накопитель" можно изменить текущий диск, а по "ключу" — текущий пароль. Две соответствующие команды также есть в меню Файл. По умолчанию значок "ключ" жёлтого цвета, но если введён пароль, то он становится красным. В средней части строки состояния выводится информация об общем размере выделенных файлов или о текущем состоянии. В правой части строки состояния отображаются общее количество файлов в текущей папке и их размер.


Режимы управления файлами и архивами

Оболочка WinRAR имеет два основных режима: режим управления файлами и режим управления архивами.

В режиме управления файлами в окне WinRAR отображается список файлов и папок в текущей папке на диске. Вы можете выделить эти файлы и папки с помощью мыши или клавиатуры (как принято в Windows) и произвести с ними различные операции, например заархивировать или удалить. В этом режиме также можно протестировать группу архивов и извлечь из них файлы.

В режиме управления архивами в окне WinRAR отображается список файлов и папок в открытом архиве. Здесь вы также можете выделить файлы и папки и выполнить с ними различные действия, специфичные для архива, например распаковать, протестировать или добавить комментарий.

В обоих режимах можно изменить текущую папку (на диске или в архиве). Для перехода в родительскую папку нажмите клавишу Backspace или Ctrl+PgUp, либо дважды щёлкните мышью на папке ".." в списке файлов. Если вы сделаете это в корневой папке архива, то закроете архив и перейдёте в папку на диске, в которой он находится. Для перехода в другую папку нажмите Enter или Ctrl+PgDn, либо дважды щёлкните мышью на этой папке. То же действие на файле архива откроет архив. Для перехода в корневую папку диска или папку с архивом нажмите клавиши Ctrl+\.

Для входа в режим управления файлами запустите WinRAR двойным щелчком на его значке или введите в командной строке WinRAR без параметров.

Для входа в режим управления архивами запустите WinRAR в режиме управления файлами, поместите курсор на нужный вам архив и нажмите Enter (это же действие выполняется при выборе пункта Открыть архив в меню Файл или при двойном щелчке мышью на имени архива). Кроме того, вход в режим управления архивами происходит при нажатии на архиве Enter или двойном щелчке мышью в оболочке Windows (в Проводнике или на рабочем столе), но только если WinRAR ассоциирован с архивами (что делается по умолчанию во время установки). Связать WinRAR с архивами несложно и после установки — для этого служит окно Параметры интеграции. И, наконец, зайти в нужный архив можно непосредственно из командной строки, указав имя этого архива как единственный параметр для WinRAR (т.е. введя в командной строке WinRAR имя_архива).


Выделение файлов

Перед выполнением любой операции нужно выделить в списке файлов WinRAR те файлы и папки, которые необходимо обработать.

Если вы хотите выделить только один файл, то просто переместите на него курсор, после чего можно выполнять желаемую операцию. Выделять файлы можно разными способами. Как и в других Windows-программах, для выделения непрерывной группы файлов можно использовать клавиши управления курсором или левую кнопку мыши, удерживая нажатой клавишу Shift. Чтобы выделить несколько отдельных элементов, держите нажатой клавишу Ctrl и щёлкайте мышью на каждом нужном элементе. Чтобы выделить все файлы и папки в текущей папке, нажмите Ctrl+A или вызовите команду Выделить все в меню Файл.

Все описанные выше способы служат для обычного, непостоянного выделения, которое сбрасывается при перемещении курсора. Как правило, этих стандартных методов достаточно, но иногда более удобно постоянное выделение, позволяющее перемещать курсор в текущей папке без потери выделения ранее отмеченных элементов. Для этого в WinRAR предусмотрено несколько клавиш:

Пробел, Insert | Выделяет файл, находящийся под курсором, и перемещает курсор вниз. Для отмены выделения файла, отмеченного клавишами Пробел или Insert, ещё раз нажмите на этом файле Пробел или Insert, либо <–> на цифровой клавиатуре
<*> (на цифровой клавиатуре) | Инвертирует текущее выделение
<+> (на цифровой клавиатуре) | Выделяет файлы, соответствующие введённому шаблону
<–> (на цифровой клавиатуре) | Снимает выделение с файлов, соответствующих введённому шаблону

Если перед началом извлечения или тестирования не было выделено ни одного файла, то будут извлечены или протестированы все файлы в архиве. Это правило справедливо только для операций извлечения и тестирования.


Темы интерфейса

Интерфейсные темы позволяют изменять вид графической оболочки WinRAR. Темы распространяются в виде архивов RAR с расширением ".theme.rar". Ряд тем доступен для загрузки в разделе Themes на сайте WinRAR. Чтобы установить новую тему, нужно просто открыть файл с этой темой в WinRAR подобно любому другому обычному архиву RAR (например дважды щёлкнув мышью на значке архива). После этого WinRAR покажет окно, в котором нужно подтвердить установку.

Список установленных тем находится в подменю Темы в меню Настройки. Чтобы активизировать тему, просто выберите в списке её название. Находящиеся в этом же меню команды Упорядочить темы… и Загрузить дополнительные темы… служат для манипулирования темами и загрузки их с сайта, соответственно.

Файлы тем хранятся в папке Themes, вложенной в папку %APPDATA%\WinRAR.


Режим мастера

Режим мастера WinRAR предназначен для новичков, чтобы максимально облегчить им выполнение основных операций архивирования и распаковки с помощью простой пошаговой процедуры.

Чтобы вызвать окно мастера, нажмите кнопку Мастер на панели инструментов WinRAR. По умолчанию эта кнопка отображается и внутри архивов, и вне их, но её можно отключить/включить (подобно остальным кнопкам) в окне выбора кнопок — нажмите Кнопки… в окне общих параметров программы. Другой параметр в том же окне — При старте запускать мастера — позволяет включить автоматический вызов мастера при каждом запуске WinRAR.

Каждое окно мастера снабжено краткой инструкцией, описывающей содержимое окна и возможные действия пользователя. Если этой информации будет недостаточно и требуются более подробные сведения, нажмите кнопку Справка.


Мастер: Выбор операции

Здесь нужно выбрать операцию.

Если вы хотите извлечь содержимое RAR, ZIP или архивов других типов, выберите Распаковать архив. Укажите этот пункт, если, например, нужно распаковать полученный из Интернета файл.

Если вы хотите создать новый архив и поместить в него свои файлы в уплотнённом виде, выберите параметр Создать новый архив. Сжатие файлов полезно перед отправкой их по электронной почте или копированием на внешний накопитель, так как они будут занимать меньше места и, следовательно, экономить ресурсы.

Если вы хотите добавить файлы в уже существующий архив (т.е. не создавая нового архива), выберите параметр Добавить файлы в уже существующий архив.

Выбрав желаемую операцию, нажмите кнопку Далее внизу окна. Если вы выбрали параметр Создать новый архив или Добавить файлы в уже существующий архив, то появится окно выбора файлов, в котором будет нужно выбрать те файлы, которые вы хотите заархивировать. Если же был указан параметр Распаковать архив, то вы сразу попадёте в окно выбора архива.


Мастер: Выбор архива

Здесь нужно указать архив, который вы хотите распаковать.

Нажмите кнопку Обзор, найдите свой архив, щёлкните мышью на его имени и нажмите кнопку Открыть. Открыть архив также можно, перетащив его мышью на это окно.

Выбрав имя архива, нажмите кнопку Далее внизу окна.

Обратите внимание, что при вызове этого окна WinRAR пытается "угадать" архив и подставить имя существующего архива с рабочего стола. Если это действительно тот архив, который требуется распаковать, просто нажмите кнопку Далее. Если же предположение WinRAR оказалось неправильным, укажите нужный вам архив, как описано выше.


Мастер: Выбор архива

Здесь нужно указать архив, который требуется создать или обновить.

Если вы создаёте новый архив, WinRAR обычно сам предлагает для него имя. Вы можете либо согласиться с предложенным именем, либо ввести другое. Если поле Папка по умолчанию для архивов в настройках WinRAR не пусто, WinRAR предложит создать архив в этой папке. В противном случае предложенное имя будет без пути, а архив создастся на рабочем столе Windows. Если вы хотите создать архив в другой папке, нажмите кнопку Обзор, найдите папку для размещения в ней архива, введите имя архива в поле Имя файла и нажмите кнопку Открыть.

Чтобы добавить файлы в уже существующий архив, можно также нажать кнопку Обзор и выбрать обновляемый архив, либо перетащить мышью значок архива на это окно.

Выбрав имя архива, нажмите кнопку Далее внизу окна.


Мастер: Выбор папки для распаковки файлов

Здесь нужно выбрать папку, в которой будут сохраняться извлекаемые из архива файлы.

По умолчанию WinRAR предлагает извлекать их в папку, указанную в поле Папка по умолчанию для извлекаемых файлов в настройках путей, либо, если папка не задана, на рабочий стол. Вы можете принять предложенное имя или нажать кнопку Обзор и выбрать папку самостоятельно.

Выбрав имя папки, нажмите расположенную внизу окна кнопку Готово, чтобы начать извлечение.


Мастер: Параметры архивации

Здесь можно указать дополнительные параметры архивирования.

Если важна высокая скорость архивирования, и вы готовы пожертвовать ради этого степенью сжатия, включите параметр Сжимать быстрее, но менее сильно.

Если нужно, чтобы после успешного помещения в архив файлы были удалены с диска, включите параметр Удалить файлы после архивации.

Если требуется создать самораспаковывающийся архив, включите параметр Создать самораспаковывающийся (.exe) архив. Для распаковки такого архива WinRAR не требуется — архив имеет расширение .EXE, и чтобы извлечь его содержимое, нужно просто запустить этот файл (дважды щёлкнуть мышью на его значке).

Если вы хотите зашифровать архивируемые файлы, нажмите кнопку Установить пароль и укажите пароль. ВНИМАНИЕ: Если вы забудете пароль, извлечь файлы из архива будет невозможно!

При создании нового архива его можно разделить на несколько отдельных частей (так называемых "томов"). В некоторых ситуациях несколько файлов меньшего размера бывают удобнее, чем один большой файл. Если вы решили создать архив из нескольких частей, просто введите размер одной его части в поле внизу окна. Размер можно указывать в байтах, килобайтах, мегабайтах или гигабайтах, выбирая подходящий элемент из выпадающего списка правее поля ввода размера тома. Допускается указывать десятичные дроби.

Если вы обновляете уже существующий архив, параметры для создания самораспаковывающегося архива и разделения архива на тома недоступны. Они применимы только для создания нового архива.

Обратите внимание, что все параметры в этом окне — необязательные, обычно можно оставлять значения, принимаемые по умолчанию.

Определившись с параметрами, нажмите расположенную внизу окна кнопку Готово, чтобы начать архивирование.


Просмотр файлов

Команда Просмотреть файл показывает содержимое файла под курсором в окне встроенной программы просмотра вне зависимости от содержимого файла и настроек, однако если на имени файла нажать Enter, то возможны несколько вариантов. Если файл под курсором — архив, то WinRAR откроет его и покажет содержимое, если же не архив, то действие зависит от настроек в окне параметров просмотра. В этом окне можно указать действие, выполняемое WinRAR для просмотра файла:

· всегда использовать внутреннюю программу просмотра,

· запускать внешнюю программу просмотра,

· запускать программу, связанную в Windows с файлом этого типа,

· перед каждым просмотром файла выдавать запрос о том, какой из трёх описанных выше способов следует применить.

В WinRAR можно просматривать как заархивированные, так и обычные файлы. Если для просмотра файла в архиве вызывается внешняя программа, то WinRAR извлекает этот файл во временную папку, передаёт его имя внешней программе и ждёт, пока та закончит свою работу. Далее проверяется время изменения файла, и если он был обновлён внешней программой, то предлагается обновить его в архиве. После этого временная папка вместе с извлечённым файлом удаляется.

Обратите внимание, что эта схема слегка меняется, если вы нажимаете Enter на находящемся в архиве файле с расширением .exe. В этом случае WinRAR извлекает во временную папку не только этот файл, но и всё содержимое архива, после чего запускает выделенный исполняемый файл. Последующие шаги аналогичны описанным выше: WinRAR ожидает окончания работы программы, затем проверяет время изменения извлечённых и наличие новых файлов, предлагая при необходимости обновить архив. После этого временная папка со всем её содержимым удаляется. Данный метод обработки EXE-файлов позволяет запускать программы непосредственно из архива. Например, вы можете установить новую программу, не распаковывая при этом её дистрибутив, а просто войдя в архив и нажав Enter на файле setup.exe или install.exe.


Встроенное средство просмотра

Команды встроенного средства просмотра:

Меню / Пункт | Клавиша | Функция
Файл / Выход | Alt+F4, Ctrl+W | Выход из встроенного просмотра
Правка / Копировать | Ctrl+C | Скопировать выделенный текст в буфер обмена
Правка / Выделить все | Ctrl+A | Выделить весь просматриваемый текст
Правка / Найти | Ctrl+F | Найти строку в тексте
Правка / Найти далее | F3 | Найти следующую соответствующую строку
Вид / Показывать как текст Windows | Ctrl+I | Использовать таблицу символов Windows
Вид / Показывать как текст DOS | Ctrl+D | Использовать таблицу символов DOS
Вид / Показывать как Юникод (UTF-16LE) |  | Просмотр текста как Юникода в формате UTF-16 little-endian
Вид / Показывать как Юникод (UTF-8) |  | Просмотр текста как Юникода в формате UTF-8
Вид / Перенос по словам | Ctrl+S | Включить/выключить режим переноса строк по словам
Вид / Выбрать шрифт… |  | Установить шрифт для просмотра
Справка / Справка по просмотру | F1 | Показать справку по встроенному просмотру

Чтобы изменить таблицу символов, щёлкните мышью в правой части строки состояния программы просмотра, где отображается имя текущей таблицы символов. Таблицу символов, которая будет использоваться по умолчанию, можно указать в окне параметров просмотра.


Команда "Добавить файлы в архив"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами.

Если WinRAR находится в режиме управления файлами, выделите те файлы и папки, которые нужно заархивировать. После этого выберите команду Добавить файлы в архив в меню Команды (это же действие выполняет кнопка Добавить на панели инструментов или комбинация клавиш Alt+A). Укажите имя архива и параметры в окне ввода имени архива и его параметров и нажмите Enter, чтобы начать архивацию.

Если WinRAR находится в режиме управления архивами, то сначала нужно выбрать команду Добавить файлы в архив, потом в появившемся окне выделить добавляемые файлы, а затем указать имя и параметры архива, как описано выше.

Эквивалент в командной строке: команда A


Команда "Извлечь в указанную папку"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами.

В режиме управления архивами (т.е. когда WinRAR показывает содержимое архива) выделите те файлы и папки в архиве, которые требуется извлечь. После этого воспользуйтесь командой Извлечь в указанную папку в меню Команды, кнопкой Извлечь... на панели инструментов или комбинацией клавиш Alt+E. В окне указания пути и параметров извлечения можно указать папку, в которую будут извлечены файлы, и при необходимости настроить дополнительные параметры. После закрытия этого окна начнётся извлечение файлов.

В режиме управления файлами можно распаковывать сразу несколько архивов. В целом операция похожа на описанную выше, но вместо выбора файлов внутри архива необходимо выбрать архивы и папки на диске, в которых WinRAR будет искать архивы. Если будет обнаружен хотя бы один архив, то появится окно Пути и параметры извлечения. После закрытия этого окна начнётся распаковка всех найденных архивов.

Эквивалент в командной строке: команда X


Команда "Протестировать файлы в архиве"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами.

В режиме управления архивами, когда WinRAR отображает содержимое архива, выделите те файлы и папки в архиве, которые требуется извлечь. После этого вызовите команду Протестировать файлы в архиве в меню Команды, либо нажмите кнопку Тест на панели инструментов или комбинацию клавиш Alt+T.

Любые обнаруженные при тестировании ошибки будут показаны в окне Диагностические сообщения. Если ошибок не произойдёт, WinRAR выдаст соответствующее сообщение.

В режиме управления файлами можно протестировать сразу несколько архивов. В целом операция похожа на описанную выше, только вместо выбора файлов внутри архива необходимо выбрать архивы и папки, в которых WinRAR будет искать архивы. По окончании поиска все найденные архивы будут протестированы.

Эквивалент в командной строке: команда T


Команда "Просмотреть файл"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами. Она открывает файл под курсором во встроенной программе просмотра. Для этого выберите пункт Просмотреть файл в меню Команды, либо нажмите кнопку Просмотр на панели инструментов или комбинацию клавиш Alt+V.

См. также: Встроенная программа просмотра, Просмотр файлов


Команда "Удалить файлы"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами. В режиме управления файлами выбранные файлы и папки удаляются в Корзину, поэтому случайно удалённые данные можно будет восстановить. Однако в режиме управления архивами выбранные файлы и папки удаляются из архива окончательно, поэтому будьте осторожны. Для выполнения этой команды используйте меню Команды, кнопку Удалить на панели инструментов, либо клавиши Alt+D или Del.

Окончательно удалять файлы, не помещая их в Корзину, можно и в режиме управления файлами. Для этого вместо Del используйте Shift+Del. Комбинация Shift+Del удаляет без дополнительных запросов даже файлы с атрибутами "Системный" и "Только чтение", а также файлы с нестандартными именами, например с пробелами или точками в конце. Обычное удаление в Корзину может не справиться с такими именами.

Эквивалент в командной строке: команда D


Команда "Переименовать файл"

Эта команда позволяет переименовать файл или папку под курсором. Она доступна как в режиме управления файлами, так и в режиме управления архивами. Переименование файлов внутри архивов поддерживается для форматов RAR и ZIP. Чтобы воспользоваться этой командой, вызовите её в меню Команды или нажмите клавишу F2.

Переименование имеет некоторые ограничения при работе с многотомными архивами. Можно переименовывать только файлы, которые находятся в текущем томе. Если вы хотите переименовать файлы в многотомном архиве, сначала выключите параметр Объединять содержимое томов на вкладке Список файлов в окне настроек WinRAR, а затем откройте тот том, в котором содержатся нужные файлы.

Выбирайте новое имя файла внимательно! Если оно будет содержать символы, не поддерживаемые файловой системой, впоследствии возможны проблемы при извлечении переименованного файла. Если такое всё же произойдёт, просто переименуйте файл ещё раз, дав ему более подходящее имя.

Эквивалент в командной строке: команда RN


Команда "Распечатать файл"

Эта команда предназначена для распечатки файла под курсором. Она доступна как в режиме управления файлами, так и в режиме управления архивами. Команду можно вызвать из меню Команды или комбинацией клавиш Ctrl+I.


Команда "Извлечь без подтверждения"

Эта команда доступна как в режиме управления архивами, так и в режиме управления файлами. Если WinRAR находится внутри архива, нужно выделить файлы и папки в архиве, которые требуется извлечь. Если WinRAR находится в режиме управления файлами (т.е. вне архива), выделите те файлы и папки, среди которых будет выполняться поиск архивов для распаковки. После этого воспользуйтесь командой Извлечь без подтверждения в меню Команды, кнопкой Извлечь на панели инструментов или комбинацией клавиш Alt+W. Выбранные файлы будут извлечены в текущую папку или в папку для извлекаемых файлов по умолчанию, если это определено в окне настроек путей. Если нужно указать папку для распаковки или другие дополнительные параметры, то используйте команду Извлечь в указанную папку.

Эквивалент в командной строке: команда X


Команда "Добавить комментарий архива"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами. Если вы внутри архива, никакие файлы выделять не нужно, просто вызовите команду Добавить комментарий архива из меню Команды, либо нажмите кнопку Комментарий на панели инструментов или комбинацю клавиш Alt+M и введите в появившемся окне комментарий архива. Если же вы вне архива, сначала выделите те файлы и папки на диске, среди которых будет выполняться поиск архивов для добавления комментариев.

Эквиваленты в командной строке: команда C , ключ -z<файл>


Команда "Добавить данные для восстановления"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами. Если WinRAR находится внутри архива, никакие файлы выделять не нужно, просто выберите пункт Добавить данные для восстановления в меню Команды, нажмите кнопку Защита на панели инструментов или комбинацию клавиш Alt+P. В режиме управления файлами (т.е. вне архива) сначала выделите те файлы и папки, среди которых будет выполняться поиск архивов для добавления защитных данных.

Эта команда добавляет в текущий открытый архив или в выделенные архивы данные для восстановления. Такие данные могут впоследствии помочь восстановить архив, если он по какой-либо причине окажется физически повреждённым. Данные для восстановления поддерживаются только в архивах RAR.

Если открытый архив – первый том многотомного архива, для него также можно создать тома для восстановления. Для этого просто укажите количество создаваемых файлов .rev. Кроме того, к этому параметру можно добавить знак процента (%), чтобы вычислить количество создаваемых файлов .rev как процент от общего количества томов архива RAR.

Эквивалент в командной строке: команда RR, команда RV


Команда "Запретить изменения в архиве"

Команда "Заблокировать архив"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами. Если WinRAR находится внутри архива, никакие файлы выделять не нужно, просто выберите команду Заблокировать архив в меню Команды, нажмите кнопку Запрет на панели инструментов или комбинацию клавиш Alt+L. В режиме управления файлами (т.е. вне архива) сначала выделите те файлы и папки, среди которых будет выполняться поиск архивов для блокировки.

Заблокированный архив (т.е. архив, изменение которого запрещено) невозможно изменить средствами WinRAR. Блокировка может пригодиться, например, чтобы предотвратить случайное изменение важных архивов.

Блокировать можно только архивы RAR.

Эквивалент в командной строке: команда K


Команда "Проверить архив на вирусы"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами. Она распаковывает один или несколько архивов во временную папку, после чего проверяет содержимое этой папки с помощью одного из антивирусных сканеров, установленных в компьютере пользователя. В режиме управления архивами обрабатывается только содержимое открытого в данный момент архива, а в режиме управления файлами — все архивы, обнаруженные среди выделенных файлов и папок.

Команда вызывает окно со следующими полями:

  • Обнаруженные антивирусные программы

    Список антивирусных программ, установленных в компьютере и обнаруженных WinRAR. Если в этом списке несколько антивирусных сканеров, то можно выбрать любой из них по вкусу. Если же список состоит только из элемента Задано пользователем, это означает, что WinRAR не смог найти в системе ни одной антивирусной программы, и вы должны указать имя и параметры сканера самостоятельно.

  • Имя антивирусного сканера

    Имя исполняемого файла антивирусного сканера. Информацию в этом поле следует изменять только тогда, когда WinRAR не смог обнаружить установленного в компьютере антивирусного ПО, и в списке Обнаруженные антивирусные программы присутствует только элемент Задано пользователем. В этом случае нажмите кнопку Обзор и укажите exe-файл вашего антивируса, который будет вызываться WinRAR для проверки извлечённых из архивов файлов.

  • Параметры антивирусного сканера

    Параметры, передаваемые антивирусному сканеру. Информацию в этом поле следует изменять только тогда, когда WinRAR не смог обнаружить установленного в компьютере антивирусного ПО, либо когда указанные параметры не соответствуют данному сканеру. Такое может произойти, например, если в новой версии антивирусной программы изменился синтаксис командной строки. Обычно для антивирусных сканеров требуется указывать только один параметр – имя папки с распакованными файлами. Для обозначения этой папки WinRAR использует сочетание символов %f. Поскольку в имени могут содержаться пробелы, его необходимо заключать в кавычки, поэтому вероятнее всего в этом поле следует указывать строку "%f". Тем не менее некоторым антивирусам могут быть нужны дополнительные параметры, сведения о которых приведены в соответствующей документации.

    Если вы постоянно пользуетесь только одной антивирусной программой, изменять её параметры при каждом сканировании не нужно, поэтому можно выключить появление окна выбора антивирусного сканера с помощью параметра Предлагать выбор антивирусного сканера в настройках безопасности.

    Примечания

    1. WinRAR не ищет вирусы самостоятельно, а лишь вызывает для этого антивирусную программу, уже установленную в компьютере. Если такой программы в вашей системе нет, воспользоваться этой командой WinRAR не удастся;
    2. WinRAR не выводит никаких сообщений по окончании работы этой команды. Чтобы узнать, найдены вирусы или нет, следите за информацией, отображаемой антивирусным сканером;
    3. WinRAR распаковывает все выбранные архивы во временную папку перед вызовом антивирусного сканера, поэтому позаботьтесь, чтобы на диске хватило свободного места для всех извлечённых файлов. По окончании сканирования WinRAR удаляет эти файлы;
    4. WinRAR умеет автоматически обнаруживать множество популярных антивирусных программ, поэтому самостоятельно редактировать поля Имя антивирусного сканера и Параметры антивирусного сканера обычно не требуется. Просто выберите в списке название сканера и нажмите OK, а два других поля потребуются только в случае, если этот метод не сработает;
    5. WinRAR запоминает параметры антивирусного сканера, которые использовались в прошлый раз, и подставляет их при следующем вызове этой команды.


Команда "Преобразовать архивы"

Эта команда позволяет преобразовывать архивы из одного формата в другой. Она доступна как в режиме управления файлами, так и в режиме управления архивами. В режиме управления файлами нужно выделить несколько файлов и папок для обработки – WinRAR просмотрит их и преобразует найденные архивы. В режиме управления архивами по умолчанию преобразуется только текущий архив. Далее приведены параметры в окне Преобразование архивов, определяющие выполнение команды.

  • Архивы для преобразования

    Список архивов, которые будут преобразованы. Элементы в этом списке можно добавлять и удалять кнопками Добавить и Удалить. Кнопка Удалить не удаляет файлы с диска, а лишь убирает их из списка конвертируемых.

    Содержимое списка архивов зависит от следующего параметра — списка форматов (типов).

  • Типы архивов

    Здесь можно выбрать, архивы каких форматов следует преобразовать. Рядом с названием формата может быть число в скобках, показывающее, сколько архивов данного типа обнаружено и готово к преобразованию. Например "zip(12)" означает, что имеется 12 архивов ZIP. Если число отсутствует, значит, архивы данного типа не найдены.

    Параметры преобразования

  • Минимально допустимая степень сжатия

    Этот параметр позволяет указать наименьшее допустимое процентное соотношение <размер нового архива>/<размер старого архива>, при котором следует выполнять преобразование. Например, укажите 100, чтобы WinRAR сохранял исходные архивы, если новый архив окажется больше старого. Если параметр выключен, размеры архивов не учитываются.

  • Кнопка Сжатие

    Эта кнопка вызывает окно, в котором можно выбрать различные параметры преобразования архивов, например результирующий формат — RAR или ZIP.

  • Папка для преобразованных архивов

    Здесь можно указать папку для сохранения преобразованных архивов. Если это поле пустое, новые архивы будут в той же папке, что и старые.

  • Удалять исходные архивы

    Этот параметр позволяет указать, следует ли удалять исходные архивы после удачного преобразования.

    Если исходный и новый архивы имеют один и тот же формат, а в поле Папка для преобразованных архивов ничего не указано, исходные архивы будут удалены вне зависимости от состояния этого параметра.

  • Пропускать зашифрованные архивы

    Если включено, то архивы с зашифрованными данными обрабатываться не будут. Может пригодиться, когда требуется выполнить преобразование без участия пользователя, чтобы избежать запросов паролей. Однако если известно, что во всех зашифрованных архивах используется один и тот же пароль, этот параметр можно выключить, предварительно установив пароль по умолчанию в меню Файл перед вызовом команды преобразования.

  • Кнопка Сохранить

    Эта кнопка сохраняет состояние всех управляющих элементов окна, за исключением списка Архивы для преобразования, чтобы при следующем вызове этого окна все настройки были восстановлены. Используйте её, чтобы запомнить свои привычные параметры преобразования.

    • Примечания

    1. Новый архив сохраняется только в том случае, если он был успешно создан и протестирован, а общий объём несжатых файлов в нём такой же, как в исходном архиве.
    2. WinRAR старается по возможности сохранять комментарии архивов. Однако если пользователь указал свой комментарий в окне, вызываемом кнопкой Сжатие, это будет иметь более высокий приоритет. Комментарии файлов не преобразовываются. Возможность преобразования другой информации в архивах (например потоков NTFS и сведений о правах файлов) зависит от параметров сжатия и формата архива.
    3. Исходные архивы перед преобразованием распаковываются во временную папку, поэтому необходимо, чтобы в этой папке было достаточно свободного места.
    4. Если архив содержит такие особые данные, как ссылки или версии файлов, то преобразование может быть не выполнено.


Команда "Восстановить архив"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами. Она подразумевает, что выделенные файлы или открытый архив — это повреждённые архивы, и пытается их восстановить. Команда вызывается в меню Операции, кнопкой Исправить на панели инструментов или комбинацией клавиш Alt+R.

Поддерживается восстанавление только архивов RAR и ZIP. Тип архива WinRAR пытается определить автоматически по данным в файле архива и по его расширению, но можно указать тип архива и принудительно.

Исходный архив не изменяется. Полученный в результате восстановления архив сохраняется под именем fixed.архив.rar или rebuilt.архив.rar, где "архив" – имя исходного архива.

Успех восстановления зависит от типа архива, а также от типа и размера повреждённой области. Шансы на удачное восстановление архива RAR значительно выше, если в нём есть данные для восстановления. Если архив не содержит таких данных, то шансы на успешное восстановление непрерывных архивов низки, а архивы с зашифрованными именами файлов восстановить невозможно.

Технические подробности восстановления архивов см. в описании команды R.

Эквивалент в командной строке: команда R


Команда "Преобразовать архив в SFX"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами. Она преобразовывает архив в самораспаковывающийся (SFX). Если WinRAR находится внутри архива, никакие файлы выделять не нужно, просто вызовите команду Преобразовать архив в SFX в меню Операции, нажмите кнопку SFX на панели инструментов или комбинацию клавиш Alt+X и выберите в появившемся списке нужный SFX-модуль. В режиме управления файлами (т.е. вне архива) сначала выделите те файлы и папки, среди которых будет выполняться поиск архивов для преобразования в SFX.

Если архив уже самораспаковывающийся, с помощью этой команды из него можно удалить SFX-модуль. В этом случае исходный архив остаётся неизменным, а WinRAR создаёт новый с тем же содержимым, но без модуля самораспаковки.

При выборе SFX-модуля с графическим интерфейсом (он предлагается по умолчанию) можно нажать кнопку Дополнительные параметры SFX, чтобы указать ряд дополнительных параметров SFX-модуля, например пути распаковки по умолчанию, заголовок и текст окна. См. подробности в разделе Дополнительные параметры SFX.

Информация об SFX-модулях, входящих в комплект поставки WinRAR:

Графические SFX-модули RAR и ZIP (Default.SFX и Zip.SFX)

Консольный SFX-модуль RAR (WinCon.SFX)

Эквивалент в командной строке: команда S


Команда "Найти файлы"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами. Можно искать файлы с указанной строкой как в открытом архиве, так и в выделенных папках или дисках. Ниже приведено описание элементов окна поиска.

  • Искомые имена файлов

    По умолчанию в этом поле указана звёздочка ( * ), т.е. будут просматриваться все файлы. При желании можно ввести другую маску файлов, например чтобы выполнить поиск только в TXT-файлах, укажите *.txt. Допускается указывать несколько масок файлов, разделяя их пробелами. Если требуется указать имя файла с пробелами, его нужно заключить в кавычки.

  • Искомая строка

    Здесь указывается строка для поиска. Если оставить это поле пустым, будут показаны все файлы, удовлетворяющие выбранным критериям.

  • Учитывать регистр букв

    Включите, чтобы при сравнении строк учитывался регистр букв (прописные/строчные).

  • Использовать все таблицы

    Включите, чтобы при поиске строки использовать таблицы символов ANSI, Юникода и OEM (MS-DOS). Выключите, чтобы использовать только стандартную таблицу символов Windows (ANSI).

  • Шестнадцатеричный поиск

    Включите, чтобы введённая строка рассматривалась программой как последовательность шестнадцатеричных значений, разделённых пробелами.

  • Область поиска

    Этот параметр ограничивает поиск внутри архива текущим открытым архивом. Вне архива используйте пункт "Текущая папка", чтобы выполнить поиск только в текущей папке, и пункт "Выбранные элементы" для поиска в папках и файлах, выбранных в списке файлов WinRAR. Чтобы выполнить поиск на конкретных дисках, выберите соответствующие буквы дисков.

    Это поле содержит список дисков, папок или архивов, в которых нужно выполнить поиск. Кроме того, из выпадающего списка можно выбрать предопределённые значения <Текущая папка>, <Локальные жёсткие диски>, а также отдельные диски.

  • Типы архивов

    Типы архивов, в которых нужно выполнить поиск. По умолчанию в этом поле указана звёздочка ( * ), т.е. все поддерживаемые форматы архивов, но если вы хотите найти данные только в архивах RAR, то укажите "*.rar". Допускается указывать несколько масок архивов, разделяя их пробелами.

  • Поиск во вложенных папках

    Включите, чтобы выполнить поиск не только в указанной папке, но и во вложенных в неё подпапках. Действует только для области поиска <Текущая папка>.

  • Поиск в файлах

    Включите, чтобы выполнить поиск в обычных файлах (не в архивах), соответствующих указанному имени файла.

  • Поиск в архивах

    Включите, чтобы выполнить поиск в файлах внутри архивов. Чтобы найти нужную строку и в архивах, и в файлах на диске, включите оба параметра — Поиск в файлах и Поиск в архивах.

  • Пропускать зашифрованные

    Включите, чтобы зашифрованные архивы, для поиска внутри которых требуется ввод пароля, пропускались без вывода сообщения.

  • Кнопка Сохранить

    Эта кнопка сохраняет часть параметров в этом окне, чтобы они были автоматически восстановлены при следующем вызове. Некоторые параметры не запоминаются, вместо этого для них подставляются значения, подходящие для текущего поиска.

    • Эквивалент в командной строке: команда i


Команда "Информация об архиве"

Команда "Информация"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами. Просто воспользуйтесь пунктом Показать информацию в меню Операции, кнопкой Информация на панели инструментов или комбинацией клавиш Alt+I.

В режиме управления файлами эта команда выдаёт информацию о содержимом выбранных файлов и папок: общий объём, количество файлов и вложенных папок, количество архивов. Для ускорения операции архивы определяются только по расширениям, поэтому самораспаковывающиеся архивы в подсчёте не участвуют. Сканирование файлов может быть достаточно долгим, но при желании можно в любой момент закрыть окно.

Занимаемое файлами место на диске определяется блоками фиксированного размера, называемыми кластерами. Например, если размер кластера равен 4096 байтам, а размер файла — всего 1 байт, то такой файл в действительности займёт на диске 4096 байт. Поэтому чтобы дать возможность оценить, как много места занимают файлы на самом деле и сколько места на диске можно сэкономить после их архивирования, в информационном окне помимо прочего отображается размер кластера для текущего диска, истинный объём, занимаемый выбранными файлами с учётом неиспользованных остатков кластеров, а также общий объём потерь на остатках кластеров.

По завершении сканирования файлов можно нажать кнопку Оценить, чтобы получить прогноз о степени и времени сжатия выбранных файлов. Прогноз выполняется для метода сжатия Максимальный, при этом предполагается, что диск быстрый и время на обмен данными с диском мало. Оценка очень быстра и весьма приблизительна, поэтому не ждите здесь точного результата. Впрочем, этой информации обычно достаточно, чтобы понять, имеет ли смысл вообще тратить время на упаковку выбранных данных. Если перед закрытием информационного окна вы включили параметр Оценивать автоматически, то при следующем вызове этого окна подсчёт начнётся автоматически, без нажатия кнопки Оценить.

Кроме того, после сканирования можно перейти на другие страницы этого окна и указать различные архивные параметры, например комментарий, размер данных для восстановления, SFX-модуль и др. Таким образом, имеется возможность применить все необходимые изменения ко всем архивам RAR и ZIP, содержащимся среди выбранных папок и файлов. В отличие от сканирования, здесь также обрабатываются и самораспаковывающиеся архивы. Будьте осторожны при использовании этой операции: она способна изменить параметры сразу сотен и тысяч архивов! Как и любая другая мощная функция, она может оказаться достаточно опасной при неправильном употреблении.

Если команда Информация вызывается, когда WinRAR находится внутри архива, либо вне его, но в списке файлов при этом выделен всего один архив, то о нём выводятся следующие сведения:

· имя архива (в заголовке окна);

· тип архива (непрерывный, SFX, многотомный) и формат (RAR, ZIP, CAB, ARJ, LZH...). Все эти параметры объединены в одной строке вверху окна.
Для томов RAR, созданных с помощью WinRAR версии 3.40 или новее, эта строка также содержит номер тома. Он может пригодиться при утере исходных имён томов, чтобы их можно было правильно восстановить вручную;

· минимальная версия архиватора, необходимая для извлечения файлов. Для некоторых архивных форматов (например ZIPX) может быть также указано название алгоритма сжатия;

· операционная система, в которой был создан архив;

· общее количество файлов;

· общий размер несжатых и сжатых файлов;

· общая степень сжатия;

· размер модуля самораспаковки или 0 (ноль) для обычных архивов;

· наличие архивного комментария;

· наличие зашифрованных файлов;

· наличие блокировки архива;

· максимальный размер последовательно повреждённых данных, которые ещё можно восстановить с помощью данных для восстановления (если они имеются в архиве);

· максимальный размер словаря, использованного для упаковки файлов в архиве.

Если в архиве имеется главный комментарий, он отображается на соответствующей вкладке окна.

Как и в режиме управления файлами, для текущего архива тоже можно переходить на другие страницы этого окна и указывать различные параметры. Чтобы получить более подробные сведения об элементах на других страницах, нажмите там кнопку Справка.


Команда "Создать отчёт"

Эта команда применима в обоих режимах WinRAR: как вне, так и внутри архивов.

В режиме управления архивами она создаёт отчёт с полным списком файлов в текущем открытом архиве. Выделение файлов при этом игнорируется.

В режиме управления файлами отчёт содержит информацию только о выбранных элементах. В зависимости от указанных параметров, в отчёте могут быть сведения как об обычных файлах, так и о содержимом архивов, если таковые имеются среди выбранных элементов. Если выделить папку, WinRAR обработает имеющиеся в ней файлы, а также вложенные подпапки.

С помощью следующих параметров можно изменять стиль отчёта:

  • Сохранить отчёт в файле

    Здесь можно указать имя файла для сохранения отчёта. Если вы не хотите сохранять отчёт в файле, оставьте это поле пустым.

  • Распечатать отчёт

    Включите, если хотите отправить отчёт на принтер.

  • Скопировать отчёт в буфер обмена

    Включите, чтобы скопировать отчёт в буфер обмена. Поскольку для сохранения данных в буфере обмена требуется определённое количество памяти, применяйте этот параметр осмотрительно, особенно если предполагается создание многомегабайтного отчёта. Это может потребовать слишком много памяти и замедлить операцию.

  • Формат вывода (HTML, текст в Юникоде, текст)

    Выберите формат вывода для файла отчёта. Форматы HTML и Текст в Юникоде поддерживают Юникод, поэтому не-английские символы в именах файлов и архивов будут отображаться правильно. Формат Текст несовместим с Юникодом и потому может повредить не-английские символы.

  • Тип сортировки файлов (без сортировки, по имени, по размеру, по размеру в архиве, по времени изменения, по контрольной сумме)

    Здесь можно указать режим сортировки или выбрать значение без сортировки", чтобы помещать сведения в отчёт в их исходном порядке.

  • Сортировать архивы отдельно

    Если включено, содержимое каждого включённого в отчёт архива будет сортироваться отдельно от других архивов и файлов, т.е. все файлы каждого архива будут помещаться в отдельные группы. В противном случае все сведения о файлах в отчёте будут отсортированы как единый поток без учёта границ архивов. Этот параметр не влияет на исходный порядок сортировки.

    Элементы для добавления в отчёт

  • Содержимое архивов

    Этот параметр доступен только в режиме управления файлами. Если параметр включён, WinRAR анализирует все файлы и при обнаружении среди них архива помещает в отчёт его содержимое. Когда требуется получить лишь список обычных файлов на диске, а содержимое архивов неважно, выключите этот параметр, чтобы ускорить операцию.

  • Сведения об обычных файлах

    Этот параметр доступен только в режиме управления файлами. Если параметр включён, в отчёте будут сведения об обычных файлах. Если вам нужен отчёт с информацией только об архивных файлах, этот параметр следует выключить.

  • Имена архивов

    Если включено, в отчёт будет добавляться имя архива перед каждой группой файлов, содержащихся в этом архиве. Этот параметр следует выключать лишь в особых случаях, например когда требуется передать отчёт внешней программе.

  • Сводная информация

    Если включено, в конец отчёта помещается информация об общем количестве и размере файлов. Если выбран параметр Обычные файлы, в общую информацию включаются только сведения об обычных файлах, в противном случае — только об архивных файлах. Подсчёт и обычных, и архивных файлов вместе невозможен. Если файлы разделены между томами, общая информация подсчитывается для тех из них, которые начинаются с текущего тома. Это сделано во избежание многократного подсчёта разделённых файлов при обработке группы томов.

  • Размеры файлов

    Если включено, в отчёте будут сведения о размерах несжатых файлов.

  • Размеры сжатых файлов

    Если включено, в отчёте будут сведения о размерах сжатых файлов. Для обычных файлов значения могут отличаться от размеров несжатых файлов только на дисках с файловой системой NTFS и только когда файл имеет атрибут "Сжатый".

  • Даты файлов

    Если включено, в отчёте будут даты модификации файлов. Вне зависимости от системных региональных установок, даты всегда указываются в формате ГГГГ-ММ-ДД чч:мм.

  • Контрольные суммы файлов

    Если включено, в отчёте будут контрольные суммы файлов. Этот параметр работает как с файлами в архиве, так и с обычными файлами. Тип контрольной суммы для файлов в архиве зависит от формата архива и настроек, а для обычных файлов он всегда CRC32. Использование этого параметра с обычными файлами может значительно замедлить операцию, поскольку WinRAR придётся считывать данные файлов и вычислять CRC32 для каждого обработанного файла. Поскольку архивы обычно уже содержат ранее вычисленные контрольные суммы, для файлов в архивах этот параметр никаких задержек не вызывает.

Кнопка Сохранить

Эта кнопка позволяет запомнить все значения параметров окна, за исключением имени файла отчёта. Для данной команды сохраняется два набора принимаемых по умолчанию значений: один для режима управления архивами, другой для режима управления файлами.


Команда "Тест быстродействия"

Эта команда позволяет сравнивать производительность алгоритма сжатия RAR на разных компьютерах.

Она генерирует случайные данные, вызывающие повышенную нагрузку на процессор и память. Затем данные сжимаются и распаковываются по алгоритму RAR, после чего результат распаковки сравнивается с исходными данными. Если обнаруживается какое-либо различие, в окне команды в строке "Ошибки" выводится сообщение "Да". Такие ошибки могут свидетельствовать о проблемах с аппаратурой, например о нестабильной работе памяти. Кроме того, отображается объём обработанных данных и скорость сжатия — текущая и результирующая, в КБ/с. Результирующую скорость можно использовать для сравнения производительности RAR в различных условиях, например при выборе нового компьютера, чтобы узнать, какой из них быстрее сжимает данные. Используется только общий алгоритм упаковки в режиме максимального сжатия со словарём 4096 КБ, все дополнительные фильтры и алгоритмы отключаются, т.е. измеряется производительность основного алгоритма сжатия RAR на произвольном наборе данных.

С помощью параметра Многопоточность можно сравнить производительность обычной однопоточной и многопоточной (оптимизированной для мультипроцессорных архитектур) версий алгоритма сжатия RAR. В зависимости от результатов, многопоточность можно включить или отключить в окне общих настроек.

Для заполнения словаря упаковки, который в начале операции пуст, требуется некоторое время. Пока он не будет заполнен, значение скорости непостоянно, поэтому текущая скорость начинает отображаться лишь через несколько секунд после вызова команды. Результирующая скорость выводится только после сбора статистики, необходимой для получения точного результата. После того как результирующая скорость установлена, она больше не изменяется. Несмотря на то что исходные данные случайны, степень их избыточности и другие параметры всегда остаются одинаковыми, поэтому команда выдаёт практически постоянную текущую скорость вне зависимости от длительности выполнения при условии, что загрузка системы не изменяется.

Учтите, что разные версии WinRAR могут показывать разные скорости сжатия, поэтому если вы используете эту команду для сравнения производительности различных компьютеров, проследите, чтобы во всех тестах участвовала одна и та же версия WinRAR. Кроме того, прежде чем приступать к тестированию, рекомендуется закрыть все остальные запущенные приложения.

Команда Тест быстродействия не имеет автоматического завершения, вы должны прекратить её работу самостоятельно. В тесте не используется жёсткий диск, все операции выполняются в оперативной памяти.


Меню "Файл"

Команда | Клавиша | Функция
Открыть архив | Ctrl+O | Открыть указанный архив (это можно сделать и другими способами).
Выбрать диск | Ctrl+D | Изменить текущий диск.
Установить пароль по умолчанию | Ctrl+P | Установить пароль, используемый по умолчанию. Для подтверждения правильности пароль необходимо ввести дважды. Этот пароль будет использован для всех операций архивации.
Скопировать файлы в буфер обмена | Ctrl+C | Скопировать файлы (находящиеся в архиве или обычные) в буфер обмена Windows. Например, можно выделить файлы в архиве, нажать Ctrl+C, открыть папку в Проводнике и нажать Ctrl+V, чтобы распаковать в неё эти файлы. Если нажать Ctrl+V в текстовом редакторе, то будут вставлены только имена файлов, а не их содержимое.
Вставить файлы из буфера обмена | Ctrl+V | Вставка файлов в WinRAR вызывает операцию архивирования, т.е. можно выделить файлы в Проводнике и вставить их в WinRAR, чтобы заархивировать эти файлы.
Скопировать полные имена в буфер обмена |  | Скопировать в буфер обмена только полные имена выбранных файлов или папок, но не содержимое файлов.
Выделить все | Ctrl+A | Выделить все файлы и папки.
Выделить группу | + (на цифровой клавиатуре) | Выделить все файлы и папки, соответствующие введённому шаблону.
Снять выделение | – (на цифровой клавиатуре) | Снять выделение со всех файлов и папок, соответствующих введённому шаблону.
Инвертировать выделение | * (на цифровой клавиатуре) | Инвертировать выделение всех файлов и папок.
Выход | Alt+F4, Ctrl+W | Завершить работу WinRAR.

В зависимости от состояния параметра Вести историю архивов в окне общих параметров, ниже команды Выход могут находиться имена недавних архивов для их быстрого открытия.


Меню "Команды"

Функция | Клавиша
Добавить файлы в архив | Alt+A
Извлечь в указанную папку | Alt+E
Протестировать файлы в архиве | Alt+T
Просмотреть файл | Alt+V
Удалить файлы | Del, Shift+Del
Переименовать файл | F2
Распечатать файл | Ctrl+I
Извлечь без подтверждения | Alt+W
Добавить комментарий архива | Alt+M
Добавить данные для восстановления | Alt+P
Заблокировать архив | Alt+L


Меню "Операции"

Функция | Клавиша
Мастер |
Проверить архивы на вирусы | Alt+D
Преобразовать архивы | Alt+Q
Восстановить архивы | Alt+R
Преобразовать архивы в SFX | Alt+X
Найти файлы | F3
Показать информацию | Alt+I
Создать отчёт | Alt+G
Тест быстродействия | Alt+B


Меню "Избранное"

Меню Избранное содержит список ваших избранных папок и архивов. Чтобы добавить в этот список открытый в настоящий момент архив или папку, воспользуйтесь командой Добавить в избранное или комбинацией клавиш Ctrl+F. При желании к элементам списка можно добавлять необязательные комментарии. Если комментарий присутствует, WinRAR будет отображать в меню именно его, если же нет, то имя архива или папки.

При выборе архива или папки из этого списка они будут открыты в окне WinRAR. Обратите внимание, что первые десять пунктов из этого меню можно открывать комбинациями клавиш Ctrl+1 ... Ctrl+0. Нажатие Ctrl+1 активизирует первый избранный элемент, Ctrl+2 — второй, …, Ctrl+9 — девятый, Ctrl+0 — десятый.

Команда Упорядочить избранное позволяет редактировать или удалять пункты этого меню, а также перемещать их выше или ниже по списку. Выберите нужный пункт и нажмите соответствующую кнопку для выполнения действия. Чтобы удалить один из пунктов, нажмите кнопку Удалить или клавишу Del.


Меню "Настройки"

Команда Установки… в этом меню вызывает окно со следующими вкладками: Общие, Архивация, Пути, Список файлов, Просмотр, Безопасность и Интеграция. Выберите любую из этих ссылок для получения подробной информации. Окно Установки… также можно вызвать клавишами Ctrl+S.

С помощью двух соответствующих команд в подменю Импорт и экспорт можно экспортировать параметры WinRAR и импортировать их потом для восстановления ранее сохранённой конфигурации. Имя файла — Settings.reg, по умолчанию он находится в папке %APPDATA%\WinRAR, но вы можете указать для него другую папку в окнах сохранения или загрузки параметров WinRAR. Восстановление параметров из файла может существенно сократить время, необходимое для настройки WinRAR при переустановке Windows или переносе WinRAR на другой компьютер. Если во время запуска WinRAR не может найти свои параметры в реестре, а в папке WinRAR или %APPDATA%\WinRAR находится файл Settings.reg, то он будет импортирован автоматически. Чтобы некоторые из импортированных параметров вступили в силу, может потребоваться перезапуск WinRAR. Эти команды недоступны, если для сохранения установок используется файл WinRAR.ini.

Команда Создать файл WinRAR.ini в подменю Импорт и экспорт создаёт новый файл WinRAR.ini и копирует в него из реестра имеющиеся установки WinRAR.

Подменю Список файлов содержит две группы параметров. Команда Одноуровневый вид папок (быстрый вызов: Ctrl+H) переключает стиль отображения содержимого архива между обычным классическим и "одноуровневым", при котором все находящиеся в архиве файлы и папки выводятся в одном списке (словно все они расположены в одной корневой папке). Данная функция работает только в режиме управления архивами. Две другие команды в этом подменю, Список и Таблица, влияют на вид списка файлов. В режиме Список включается многоколоночный режим c показом только имён файлов, а в режиме Таблица выводится более подробная информация о файлах, включая их размеры и другие параметры.

Подменю Дерево папок позволяет включать/выключать показ панели с деревом папок. Вывод панели можно настроить отдельно для режима управления файлами (пункт меню Показывать папки на дисках) и для режима управления архивами (пункт Показывать папки в архивах). Включать/выключать показ панели с деревом папок также можно клавишами Ctrl+T. Дерево папок удобно для быстрой навигации по папкам на дисках или в архивах. Ширину панели с деревом можно изменять, перетаскивая мышью её правую границу.

Подменю Темы содержит список доступных WinRAR интерфейсных тем, команду Упорядочить темы… для манипулирования темами, а также команду Загрузить дополнительные темы… для загрузки тем с сайта.

Подменю Кодировка имён позволяет указывать кодировку для имён файлов в архиве.

Ещё одна команда в этом меню — Просмотр журнала. При её выполнении во встроенном средстве просмотра открывается файл rar.log, который находится в папке %APPDATA%\WinRAR. Обратите внимание, что запись ошибок в журнал ведётся, только если включён параметр Записывать ошибки в журнал в окне общих установок.

Для очистки журнала используйте команду Очистить журнал в этом же меню.

Запись ошибок в журнал доступна только в зарегистрированной версии RAR.


Меню "Справка"

Выберите команду Содержание для вывода оглавления справки WinRAR.

Если есть доступ в Интернет, то с помощью пункта Веб-страница WinRAR можно перейти на сайт WinRAR, где всегда доступна самая новая версия архиватора. Там же предоставляется возможность зарегистрировать вашу копию программы.

Пункт меню О программе… вызывает окно с информацией о версии и авторских правах на программу WinRAR.


Как открыть архив в среде Windows

Если при установке WinRAR вы не выключали его ассоциацию с архивами, то открыть архив в Проводнике или на рабочем столе с помощью WinRAR очень просто — нужно лишь дважды щёлкнуть мышью на значке архива.

Связать WinRAR с архивами можно и после установки с помощью окна параметров интеграции.


Использование контекстных меню

Если при установке WinRAR вы не выключали параметр Встроить WinRAR в оболочку Windows, то в обычные контекстные меню папок и файлов, вызываемые щелчком на них правой кнопкой мыши в Проводнике или на рабочем столе, были добавлены несколько дополнительных пунктов.

Для поддерживаемых WinRAR архивов добавляются пункты Извлечь файлы..., Извлечь в <имя папки> и Извлечь в текущую папку. Все эти команды вызывают WinRAR для извлечения содержимого архива, но первая команда позволяет ввести имя папки для распаковки и некоторые параметры извлечения в окне указания пути и параметров извлечения, вторая извлекает файлы из архива в предложенную папку, а третья — в текущую папку без дополнительных запросов. При распаковке группы архивов контекстное меню также содержит пункт Извлечь каждый архив в отдельную папку, позволяющий поместить распакованное содержимое каждого архива в отдельную папку. В 64-разрядной версии Windows эта функция не поддерживается.

WinRAR также изменяет в контекстном меню архивов пункт Свойства, дополняя его вкладкой для отображения сведений об архиве и комментария архива, если он есть. Сведения об архиве аналогичны тем, которые выводится командой Информация.

В контекстные меню обычных файлов и папок WinRAR помещает пункты Добавить в архив..., Добавить в архив <имя архива>, Добавить в архив и отправить по e-mail и Добавить в архив <имя архива> и отправить по e-mail, где <имя архива> заменяется действительным именем архива. Обе команды Добавить… вызывают WinRAR для добавления выбранных файлов в архив, но первая команда позволяет ввести имя архива и некоторые параметры архивации в окне ввода имени и параметров архива, а вторая немедленно начинает добавлять файлы в предложенный архив без дополнительных запросов. Аналогично, обе команды …e-mail предназначены для упаковки выбранных файлов и прикрепления созданного архива к электронному письму, но первая команда позволяет указать дополнительные параметры, а вторая сразу начинает выполнять операцию без всяких запросов. Команды …e-mail работают, только если установленная почтовая программа совместима с интерфейсом MAPI (его поддерживают большинство современных почтовых программ).


Поддержка перетаскивания

WinRAR поддерживает привычное для Windows-программ перетаскивание элементов (drag-and-drop).

Если в режиме управления файлами перетащить один архив в окно WinRAR, то будет отображено содержимое этого архива, а WinRAR перейдёт в режим управления архивами.

Если в режиме управления файлами перетащить в окно WinRAR один или несколько обычных файлов (не архивов), то WinRAR запросит имя архива и добавит их в этот архив.

Если в режиме управления архивами перетащить один архив на панель инструментов или адресную строку WinRAR, в окне WinRAR будет показано содержимое этого архива. Если вы хотите добавить один или несколько файлов в текущий открытый архив, их нужно перетащить в поле со списком файлов. Впрочем, если файлы не являются архивами, то при их перетаскивании на панель инструментов или адресную строку они также будут добавлены в открытый архив. Перетаскивание файлов в окно WinRAR доступно только для архивов RAR и ZIP.

Перетаскивать файлы из окна WinRAR в другие программы можно вне зависимости от текущего режима WinRAR и формата просматриваемого архива.

Если при установке вы не выключали параметр Встроить WinRAR в оболочку Windows, то для добавления файлов в архивы ZIP или RAR можно перетаскивать эти файлы на значок архива на рабочем столе. Кроме того, если перетащить архив с помощью правой кнопки мыши в другую папку, то в контекстном меню можно выбрать пункт Извлечь в текущую папку для извлечения всех папок из перетаскиваемого архива в целевую папку. Если нажать правую кнопку мыши и перетащить в целевую папку один не являющийся архивом файл или несколько файлов, то в этой папке можно создать архив, содержащий данные файлы — для этого нужно выбрать в контекстном меню команду Добавить в архив... или Добавить в <имя архива>.


Общий синтаксис командной строки

Синтаксис командной строки

WinRAR допускает управление из командной строки.

Общий синтаксис:

WinRAR <команда> -<ключ1> -<ключN> <архив> <файлы…> <@файл-список…> <путь для извлечения\>

команда | Комбинация символов, определяющая действие, которое будет выполнять WinRAR. См. список команд.
ключ | Ключи используются для определения специфических действий, степени сжатия, типа архива и пр. См. список ключей.
архив | Имя обрабатываемого архива.
файлы | Имена обрабатываемых файлов.
файл-список | Файлы-списки — это обычные текстовые файлы, содержащие имена файлов для обработки. Каждое имя файла должно быть указано на отдельной строке и начинаться с её первой позиции. В файл-список можно помещать комментарии; признак начала комментария — символы «//» (без кавычек). Например, для архивирования файлов *.txt из папки c:\work\doc, файлов *.bmp из папки c:\work\image и всех файлов из папки c:\work\misc можно создать файл-список backup.lst, содержащий следующие строки: c:\work\doc\*.txt//резервная копия текстов c:\work\image\*.bmp//резервная копия рисунков c:\work\misc После этого для архивирования достаточно будет выполнить команду: winrar a backup @backup.lst В одной и той же командной строке разрешается указывать как обычные имена или группы файлов для обработки, так и файлы-списки. Если не указаны ни файлы, ни файлы-списки, то подразумевается шаблон *.* (т.е. будут обработаны все файлы).
путь для извлечения | Используется только с командами e и x и указывает папку, в которую нужно извлекать файлы. Если эта папка не существует, то она будет создана.

Примечания

а) Если не указаны ни файлы, ни файл-список, то подразумевается шаблон *.* (т.е. будут обработаны все файлы).

б) Если при создании архива не указано его расширение, то используется формат архива, выбранный в профиле архивации по умолчанию. Чтобы указать тип архива явно, добавьте расширение .rar или .zip к имени архива.

Если при распаковке архива не указано его расширение, то подразумевается, что это архив .rar, т.е. маска «*» (без кавычек) означает все архивы с расширением .rar. Если требуется обработать все архивы, не имеющие расширения, то нужно использовать маску «*.» (без кавычек). Маска *.* выбирает все файлы. Символы подстановки (шаблоны) можно использовать в большинстве операций (извлечение, тестирование и др.), однако при архивировании и удалении шаблоны запрещены.

в) Ключи в командной строке имеют более высокий приоритет, чем соответствующие установки в окне конфигурации, т.е. используются параметры, заданные ключами.

г) Для команд C, E, S, T, RR, K и X в имени архива допускается использовать шаблоны, поэтому одной командой можно обработать сразу нескольких архивов. Если вместе с этими командами указать ключ -r, то поиск архивов будет выполняться и во всех вложенных папках.

д) Некоторые команды и ключи применимы только к архивам RAR, некоторые — к RAR и ZIP, а некоторые — к архивам всех поддерживаемых форматов. Это зависит от возможностей, заложенных в формате архива.

е) Команды и ключи можно набирать как строчными, так и прописными буквами — они не зависят от регистра.

ж) Если какой-либо компонент командной строки содержит пробелы, то он должен быть заключён в двойные кавычки.

Примеры

  1. Добавить папку "c:\latest data" в архив Info.rar:

WinRAR a Info.rar "c:\latest data"

  2. Распаковать архив Info.rar в папку d:\data:

WinRAR x Info.rar d:\data\


Алфавитный список команд

A | Добавить файлы в архив
C | Добавить комментарий архива
CH | Изменить параметры архива
CV | Преобразовать архивы
CW | Сохранить комментарий архива в файле
D | Удалить из архива
E | Извлечь файлы из архива без сохранённых в архиве путей
F | Обновить файлы, имеющиеся в архиве
I | Найти строку в архивах
K | Заблокировать архив
M | Переместить в архив файлы и папки
R | Восстановить повреждённый архив
RC | Воссоздать отсутствующие тома
RN | Переименовать файлы в архиве
RR[N] | Добавить данные для восстановления
RV[N] | Создать тома для восстановления
S[имя] | Преобразовать архив в самораспаковывающийся (SFX)
S- | Удалить из архива SFX-модуль
T | Протестировать файлы в архиве
U | Обновить файлы в архиве
X | Извлечь файлы из архива с полными путями


Команда A - добавить в архив

Команда A — добавить в архив

Добавляет в архив указанные файлы и папки. Является эквивалентом в командной строке команды Добавить.

Так как многотомные архивы не допускают изменения, этой командой нельзя добавлять файлы в архивные тома, с её помощью их можно только создавать.

Примеры

1. Добавить все файлы *.hlp из текущей папки в архив help.rar:

WinRAR a help *.hlp

2. Заархивировать все файлы из текущей и вложенных папок в самораспаковывающийся непрерывный архив, разделённый на тома save.part1.exe, save.part2.rar, save.part3.rar, … размером по 362 000 байт, и добавить к каждому тому данные для восстановления:

WinRAR a -r -v362 -s -sfx -rr save

Так как имена обрабатываемых файлов не указаны, подразумеваются все файлы (*.*).

3. Как особое исключение, если в качестве аргумента указано имя папки, и это имя не содержит файловых масок и завершающего символа обратной косой черты (\), то в архив будет добавлено всё содержимое указанной папки и её вложенных папок, даже если не указан ключ -r. Следующая команда добавит все файлы из папки Bitmaps и вложенных в неё папок в RAR-архив Pictures:

WinRAR a -r Pictures.rar Bitmaps

4. Если в имени папки содержатся файловые маски или завершающий символ обратной косой черты, то применяются обычные правила, и чтобы включить в обработку вложенные папки, необходимо указать ключ -r.

Следующая команда добавит все файлы из папки Bitmaps, но не из её вложенных папок, так как не указан ключ -r:

WinRAR a Pictures.rar Bitmaps\*


Команда C - добавить комментарий архива

Команда C — добавить комментарий архива

Добавляет комментарий в архив. Максимальная длина комментария: 256 КБ для RAR, 32 768 байт для ZIP. Комментарии также можно добавлять с помощью команды Добавить комментарий архива в режиме управления архивами.

Так как многотомные архивы не допускают изменения, эта команда неприменима к томам. Для добавления комментария в тома нужно использовать ключ -z<файл> при их создании.

Примеры

а) Добавить комментарий в архив distrib.rar:

WinRAR c distrib.rar

б) С помощью ключа -z<файл> комментарий можно добавить из файла:

WinRAR c -zinfo.txt dummy


Команда CH - изменить параметры архива

Команда CH — изменить параметры архива

Позволяет изменять параметры архива. Можно применять с большинством ключей, служащих для модификации архивов. Это особенно удобно для таких ключей, как -cl, -cu, -tl, которые не имеют специально предназначенных для них команд.

Этой командой нельзя переупаковывать, зашифровывать или расшифровывать данные в архиве, а также объединять архивные тома или создавать их. При использовании без ключей команда ch просто копирует архивные данные, не изменяя их.

Пример

Установить время архива по времени новейшего файла:

WinRAR ch -tl files.rar


Команда CV - преобразовать архивы

Команда CV — преобразовать архивы

Позволяет использовать WinRAR для преобразования архивов из командной строки. Чтобы в начале операции не появлялось окно Преобразование архивов, укажите вместе с этой командой ключ -y — в этом случае операция будет выполнена с параметрами по умолчанию. Для изменения параметров по умолчанию в окне Преобразование архивов имеется кнопка Сохранить.

Пример

Преобразовать все архивы ZIP в папке c:\files, используя параметры по умолчанию:

WinRAR cv -y c:\files\*.zip


Команда CW - сохранить комментарий архива в файле

Команда CW — сохранить комментарий архива в файле

Позволяет сохранять в файле комментарий архива. Формат файла зависит от ключа -sc.

Примеры

а) Сохранить комментарий архива arc в ASCII-файл comment.txt:

WinRAR cw arc comment.txt

б) Сохранить комментарий архива arc в файл unicode.txt в кодировке Юникод:

WinRAR cw -scuc arc unicode.txt


Команда D - удалить файлы из архива

Команда D — удалить из архива

Позволяет удалять из архива указанные файлы и папки. Является эквивалентом в командной строке команды Удалить режима управления архивами.

Примечания

1) Если этой командой удаляются все файлы из архива, то пустой архив также удаляется.

2) Эта команда неприменима к томам, так как изменение многотомных архивов невозможно.

Пример

Удалить из архива dummy все файлы *.dmy:

WinRAR d dummy *.dmy


Команда E - извлечь файлы без сохранённых в архиве путей

Команда E — извлечь файлы без сохранённых в архиве путей

Извлекает из архива файлы в текущую или указанную папку, игнорируя хранящуюся в архиве информацию об их путях. Является эквивалентом в командной строке команды Извлечь в указанную папку режима управления архивами с включённым параметром Извлечение без путей в окне Пути и параметры извлечения.

Пример

Извлечь в текущую папку все файлы *.doc из всех имеющихся в текущей папке архивов RAR:

WinRAR e *.rar *.doc


Команда F - обновить файлы, имеющиеся в архиве

Команда F — обновить файлы, имеющиеся в архиве

Обновляет только те файлы в архиве, которые там уже есть, но имеют более старую дату, чем файлы с теми же именами на диске. Файлы, которых в архиве нет, этой командой не добавляются. Является эквивалентом в командной строке команды Добавить в архив режима управления файлами, с выбранным методом обновления Обновить существующие файлы в окне Пути и параметры извлечения.

Эта команда неприменима к томам, так как изменение многотомных архивов невозможно.

См. также: команда A - добавить в архив


Команда I - найти строку в архивах

Команда I[i|c|h|t]=<строка> — найти строку в архивах

Поиск строки в архивах.

Необязательные параметры:

i — не различать прописные и строчные буквы (по умолчанию)

c — различать прописные и строчные буквы

h — поиск в шестнадцатеричном режиме

t — использовать таблицы символов ANSI, Юникода и OEM

Если ни один параметр не указан, то вместо синтаксиса i=< строка> можно использовать более простую команду i<строка>.

Модификатор t допускается применять вместе с другими параметрами, например команда ict=строка выполнит чувствительный к регистру букв поиск с использованием всех вышеупомянутых таблиц символов.

Примеры

1) Найти строку "FirSt leVel" в файлах *.txt, находящихся в архивах *.rar на диске C:, учитывая регистр букв:

WinRAR "ic=FirSt leVel" -r c:\*.rar *.txt

2) Найти шестнадцатеричную строку f0 e0 ae ae ab 2d 83 e3 a9 в архивах RAR, находящихся в папке e:\texts:

WinRAR ih=f0e0aeaeab2d83e3a9 -r e:\texts\*.rar


Команда K - заблокировать архив

Команда K — заблокировать архив RAR

После выполнения этой команды все дальнейшие изменения RAR-архива средствами WinRAR становятся невозможны. Является эквивалентом в командной строке команды Заблокировать архив режима управления архивами.

Применимо только к архивам RAR, блокировать архивы ZIP невозможно.

Пример

Запретить изменения архива release.rar:

WinRAR k release


Команда M - переместить файлы и папки в архив

Команда M — переместить файлы и папки в архив

Аналогична команде A, но после успешного завершения архивации файлы и папки удаляются. Является эквивалентом в командной строке команды Добавить в архив режима управления файлами с включённым параметром Удалять файлы после архивации в окне Имя и параметры архива.

Так как многотомные архивы не допускают изменения, этой командой нельзя обновлять тома архивов, с её помощью можно их только создавать.


Команда R - исправить повреждённый архив

Команда R — исправить повреждённый архив

Восстанавливает повреждённый архив. Процедура состоит из двух этапов. Сначала в повреждённом архиве ищутся данные для восстановления (см. команду rr). Если в архиве есть эти ранее добавленные данные, а повреждённая часть информации непрерывна и её размер не превышает размера кода коррекции ошибок в данных для восстановления, то шансы на успешное восстановление высоки.

По завершении этого этапа создаётся новый архив с именем fixed.архив.rar, где "архив" — это имя исходного (повреждённого) архива.

Если в повреждённом архиве нет данных для восстановления или его невозможно полностью восстановить с их помощью из-за слишком серьёзных повреждений, то выполняется второй этап восстановления — реконструкция только структуры архива. Файлы с неверной контрольной суммой при этом не восстанавливаются, но становится возможным восстановить неповреждённые файлы, которые ранее были недоступны из-за повреждения структуры архива. Как правило, этот этап даёт хороший процент восстановления простых архивов, в случае непрерывного архива обычно можно восстановить только неповреждённые файлы, расположенные в начале архива. Этот этап не выполняется для архивов с зашифрованными именами файлов — такие архивы можно исправить лишь при наличии в них данных для восстановления.

По окончании этого этапа создаётся новый архив с именем rebuilt.архив.rar, где "архив" — это имя исходного архива.

Во время восстановления WinRAR может спросить у пользователя, нужно ли добавлять в архив найденный элемент, считая его файлом:

Подозрительный элемент <возможное имя файла>. Добавить в архив: Да/Нет/Все

Ответьте "Да", чтобы добавить этот элемент в rebuilt.архив.rar.

Эта команда — эквивалент в командной строке команды Восстановить архив режима управления файлами.

Пример

Починить архив buggy.rar и поместить результат в папку c:\fixed:

WinRAR r buggy.rar c:\fixed\


Команда RC - воссоздать отсутствующие/повреждённые тома

Команда RC — воссоздать отсутствующие/повреждённые тома

Воссоздаёт отсутствующие или повреждённые тома многотомного архива, используя тома для восстановления (файлы .rev). В качестве имени архива нужно указать любой существующий архивный том.

Пример

WinRAR rc backup.part03.rar

Подробности о томах для восстановления см. здесь.


Команда RN - переименовать файлы в архиве

Команда RN — переименовать файлы в архиве

Позволяет переименовывать файлы в архивах RAR и ZIP.

Синтаксис:

WinRAR rn <архив> <исходное_имя1> <целевое_имя1> ... <исходное_имяN> <целевое_имяN>

Например, эта команда переименует файл readme.txt в readme.bak и файл info.txt в info.bak в архиве data.rar:

WinRAR rn data.rar readme.txt readme.bak info.txt info.bak

Для простых переименований, например чтобы изменить расширения файлов, в качестве исходного и целевого имён можно применять символы подстановки (шаблоны). Так, следующая команда переименует все файлы *.txt в *.bak:

WinRAR rn data.rar *.txt *.bak

ВНИМАНИЕ: При переименовании не проверяется, имеется ли в архиве файл с таким же именем, как указанное целевое, поэтому будьте осторожны во избежание появления дублирующихся имён. Особенно аккуратно используйте шаблоны — это потенциально опасно, поскольку если неправильно указать шаблон, то можно испортить имена всех файлов в архиве.


Команда RR[N] - добавить данные для восстановления

Команда RR[n ] — добавить данные для восстановления

При желании в архивы RAR можно добавлять данные для восстановления. Это увеличивает размер архива, но способно помочь при его восстановлении, если он будет повреждён в результате сбоя носителя или другой потери информации при условии, что повреждение не слишком серьёзное. Восстановление таких повреждений выполняется командой R. Архивы ZIP данные для восстановления не поддерживают.

В архивах RAR4 и RAR5 структура и алгоритмы данных для восстановления разные.

В RAR4 данные для восстановления основаны на алгоритме XOR. Их размер в RAR4 можно указывать как число секторов для восстановления или как процент от размера архива. Чтобы указать число секторов, просто добавьте его сразу после rr, например для 1000 секторов это будет rr1000. Чтобы указать процент, добавьте после числа процентов латинскую букву p или знак %, например, для 5% это будет rr5p или rr5%. Обратите внимание, что при вызове из пакетных файлов Windows (.bat и .cmd) вместо rr5% нужно указывать rr5%%, поскольку командный процессор воспринимает одиночный знак процента как начало параметра пакетного файла, поэтому в данном случае может быть предпочтительнее применять p, а не %.

В RAR4 размер каждого сектора для восстановления равен 512 байтам. Если повреждённая область занимает непрерывный участок, каждый сектор способен восстановить 512 байт повреждённой информации. При многочисленных повреждениях это значение может быть меньше. Максимальное количество секторов для восстановления — 524 288.

Размер данных для восстановления в архивах RAR4 можно приблизительно определить по формуле:

<размер архива> / 256 + <число секторов для восстановления> * 512 байт

В архивах RAR5 данные для восстановления используют коды Рида-Соломона. Возможности восстановления последовательно расположенной повреждённой информации у них примерно такие же, как в RAR4 — с их помощью можно восстанавливать информацию чуть меньшего объёма, чем размер данных для восстановления. Но эти данные значительно эффективнее, чем в RAR4, если повреждённых участков много.

В данных для восстановления RAR5 не используются 512-байтовые сектора, указывать размер данных можно только как процент от размера архива. В RAR5 даже если не указан модификатор % или p, архиватор считает значение как процент, поэтому и rr5, и rr5p означают 5%. Из-за необходимости хранить служебную информацию фактический размер данных для восстановления лишь приблизительно совпадает с указываемым пользователем, особенно заметной разница может быть на маленьких архивах.

Размер данных для восстановления в RAR5 не может превышать размера защищаемого архива, поэтому нельзя указывать свыше 100%. Чем больше данные для восстановления, тем медленнее они обрабатываются — как при их создании, так и при восстановлении информации.

Данные для восстановления в RAR4 и RAR5 наиболее эффективны, когда вся информация в повреждённом архиве находится на своих исходных позициях, т.е. никуда не смещена. Если для копирования архива с повреждённого носителя вы используете какую-то особую программу, и она предлагает выбор — заполнять повреждённые участки нулями (или какими-либо другими данными) или вырезать их из копируемого файла, лучше выбрать заполнение нулями, чтобы были сохранены исходные позиции данных. Тем не менее даже в неоптимальном режиме, когда информация в результате вставки или удаления смещена на разумную величину, данные для восстановления обеих версий всё равно пытаются восстановить повреждения. Данные для восстановления RAR5 справляются с удалениями и вставками значительно лучше, чем в RAR4.

Если команда rr указана без параметра, то по умолчанию размер данных для восстановления равен 3% от размера архива.

Эта команда — эквивалент командной строки команды Добавить данные для восстановления в режиме управления архивами.

Примеры

а) добавить в архив backup данные для восстановления стандартного объёма (3%):

WinRAR rr backup

б) добавить в архив pictures данные для восстановления размером 5% от его общего объёма:

WinRAR rr5p pictures


Команда RV[N] - создать тома для восстановления

Команда RV[n ] — создать тома для восстановления

Позволяет создавать тома для восстановления (файлы .rev), которые впоследствии можно использовать для воссоздания отсутствующих или повреждённых томов в многотомном архиве.

Эта команда применима только к многотомным архивам RAR. В качестве имени архива нужно указывать имя первого тома в наборе. Например:

WinRAR rv3 data.part01.rar

Необязательный числовой параметр <n> указывает количество создаваемых томов для восстановления; оно должно быть меньше, чем всего томов в многотомном RAR-архиве. К этому параметру можно добавлять знак процента (%) или латинскую букву "p", чтобы число создаваемых файлов .rev вычислялось как процент от общего количества томов RAR-архива. Например:

WinRAR rv15% data.part01.rar

Подробности о томах для восстановления см. здесь.


Команда S[имя] - преобразовать архив в самораспаковывающийся (SFX)

Команда S[имя ] — преобразовать архив в самораспаковывающийся (SFX)

Позволяет создать из обычного архива самораспаковывающийся (SFX), для извлечения файлов из которого нужно просто запустить его как любую другую программу.

SFX-архив также можно создать из первого тома многотомного архива, но при этом следует учитывать, что этот том увеличится на размер модуля SFX. Самораспаковывающиеся тома лучше создавать с помощью команды A с ключами -v[<размер>] -sfx, чтобы не следить за размером первого тома: он (как и все остальные) будет иметь правильный размер.

Эта команда — эквивалент в командной строке команды Преобразовать архив в SFX режима управления архивами.

Пример

WinRAR s diamant

По умолчанию для архивов RAR используется модуль Default.sfx (он должен находиться в той же папке, что и файл WinRAR.exe), а для ZIP — модуль Zip.sfx. Однако можно использовать и альтернативные SFX-модули. Для этого нужно указать имя модуля как параметр команды S.

Например, в следующей команде используется консольный SFX-модуль WinCon.sfx:

WinRAR sWinCon.sfx myinst


Команда S- - удалить из архива SFX-модуль

Команда S- — удалить из архива SFX-модуль

Удаляет модуль самораспаковки из уже существующего самораспаковывающегося (SFX) архива.

Команда создаёт новый архив без SFX-модуля, при этом исходный SFX-архив не удаляется.

Пример:

WinRAR s- rarsetup.exe


Команда T - протестировать файлы в архиве

Команда T — протестировать файлы в архиве

Имитирует извлечение указанных файлов с целью их проверки, ничего не записывая в выходной поток. Это эквивалент в командной строке команды Протестировать файлы режима управления архивами.

Пример

Протестировать все архивы *.rar на текущем диске:

WinRAR t -r \*.rar


Команда U - обновить файлы в архиве

Команда U — обновить файлы в архиве

Как и команда F, обновляет только те файлы в архиве, дата которых старее, чем у добавляемых файлов. Однако в отличие от F, в архив при этом добавляются и файлы, которых там ещё нет.

Это эквивалент в командной строке команды Добавить в архив с выбранным методом Добавить с обновлением файлов в окне Пути и параметры извлечения.

Команда U неприменима к томам, так как изменение многотомных архивов невозможно.

См. также: команда A — добавить в архив


Команда X - извлечь файлы с полными путями

Команда X — извлечь файлы с полными путями

Извлекает файлы и папки с полными путями, полностью восстанавливая сохранённую в архиве структуру папок. Это эквивалент в командной строке команды Извлечь в указанную папку режима управления архивами.

Данной командой (как и командой E) можно извлечь файлы как в текущую, так и в указанную пользователем папку.

Примеры

Извлечь все файлы *.ttf из архива Fonts в текущую папку:

WinRAR x Fonts *.ttf

Извлечь все файлы *.ttf из архива Fonts в папку NewFonts.

WinRAR x Fonts *.ttf NewFonts\

Чтобы указать папку, в которую нужно извлечь файлы из архива, добавьте после имени папки обратную косую черту (\), как это показано в примере выше.


Алфавитный список ключей

-- | Прервать дальнейший поиск ключей в командной строке
-@[+] | Запретить [разрешить] списки файлов
-ac | Снять атрибут "Архивный" после архивации или извлечения
-ad | Добавить к целевому пути имя архива
-af<тип> | Указать формат архива
-ag[формат] | Добавить к имени архива текущие дату и время
-ai | Игнорировать файловые атрибуты
-ao | Добавить файлы с установленным атрибутом "Архивный"
-ap<путь> | Указать путь внутри архива
-as | Синхронизировать содержимое архива
-cfg- | Игнорировать профиль по умолчанию и переменную окружения
-cl | Преобразовывать имена файлов в нижний регистр
-cp<имя> | Выбрать профиль архивации
-cu | Преобразовывать имена файлов в верхний регистр
-df | Удалить файлы после архивации
-dh | Открывать совместно используемые файлы
-dr | Удалить файлы в Корзину
-ds | Не сортировать файлы при добавлении в непрерывный архив
-dw | Уничтожить (затереть) файлы после архивации
-ed | Не добавлять пустые папки
-en | Не добавлять в архив блок "Конец архива"
-ep | Исключить пути из имён
-ep1 | Исключить базовую папку из имён
-ep2 | Сохранять полные пути файлов
-ep3 | Сохранять полные пути, включая буквы дисков
-e[+]<атр> | Задать исключение или включение файлов из/в обработку по маске атрибутов
-f | Обновить имеющиеся файлы
-hp[пароль] | Шифровать и данные, и заголовки файлов
-ht[b|c] | Выбрать тип хеша [BLAKE2, CRC32] для контрольных сумм
-iadm | Запрашивать права администратора для SFX-архива
-ibck | Запустить WinRAR как фоновый процесс в области уведомлений
-ieml[.][адрес] | Отправить архив по электронной почте
-iicon<имя> | Указать значок для SFX-модуля
-iimg<имя> | Указать логотип для SFX-модуля
-ilog[имя] | Записывать ошибки в файл-журнал
-im | Показывать дополнительную информацию
-inul | Не показывать сообщения об ошибках
-ioff[n] | Выключить компьютер по завершении операции
-k | Заблокировать архив
-isnd[-] | Управление звуками оповещений
-kb | Сохранять на диске файлы, извлечённые с ошибками
-log[формат][=имя] | Записывать имена в файл-журнал
-m<n> | Метод сжатия
-ma[4|5] | Версия формата архивирования (RAR4 или RAR5)
-mc<параметры> | Дополнительные параметры сжатия
-md<n> | Размер словаря
-me[параметры] | Параметры шифрования
-ms[список] | Расширения файлов для архивирования без сжатия
-mt<потоки> | Количество потоков
-n<файл> | Дополнительный фильтр файлов, включённых в обработку
-n@<файл-список> | Прочитать дополнительные маски фильтрации из файла-списка
-oc | Устанавливать NTFS-атрибут "Сжатый"
-oh | Сохранять жёсткие ссылки как ссылки, а не как файлы
-oi[-] | Сохранять идентичные файлы как ссылки
-ol | Сохранять символические ссылки как ссылки, а не как файлы
-or | Переименовывать файлы автоматически
-os | Сохранять потоки NTFS
-ow | Сохранять/восстанавливать информацию о правах доступа к файлам
-o[+|-] | Режим перезаписи
-p[пароль] | Указать пароль шифрования архива
-qo[-|+] | Добавить информацию для быстрого открытия архива [нет|принудительно]
-r | Включить в обработку вложенные папки
-r- | Запретить обработку вложенных папок
-r0 | Обрабатывать вложенные папки в соответствии с шаблоном
-ri | Приоритет процесса и время простоя
-rr[N] | Добавить данные для восстановления
-rv[N] | Создать тома для восстановления
-s | Создать непрерывный архив
-s<N> | Создать непрерывные группы, используя счётчик файлов
-sc<кодировка>[объекты] | Указать кодировку [и объекты]
-se | Создать непрерывные группы, используя расширения файлов
-sfx[имя] | Создать самораспаковывающийся (SFX) архив
-sl<размер> | Обрабатывать файлы размером меньше указанного
-sm<размер> | Обрабатывать файлы размером больше указанного
-sv | Создать независимые непрерывные тома
-sv- | Создать зависимые непрерывные тома
-s- | Запретить создание непрерывных архивов
-t | Протестировать файлы после архивации
-ta[m,c,a,o]<дата> | Обрабатывать файлы, изменённые, созданные или к которым было обращение после указанной даты
-tb[m,c,a,o]<дата> | Обрабатывать файлы, изменённые, созданные или к которым было обращение до указанной даты
-tk | Сохранять исходное время архива
-tl | Устанавливать время архива по времени новейшего файла
-tn[m,c,a,o]<время> | Обрабатывать файлы не старее, чем указанный период времени
-to[m,c,a,o]<время> | Обрабатывать файлы более старые, чем указанный период времени
-ts[m,c,a][+,-,1] | Сохранять или восстанавливать время файлов (изменения, создания, доступа)
-u | Обновить файлы
-v<n>[k|b|f|m|M|g|G] | Создать многотомный архив
-vd | Удалять содержимое сменного диска перед созданием тома
-ver[n] | Управление версиями файлов
-vn | Старая схема именования томов
-vp | Пауза перед каждым томом
-w<путь> | Задать папку для временных файлов
-x<файл> | Не обрабатывать указанный файл или папку
-x@<файл-список> | Не обрабатывать файлы, указанные в файле-списке
-y | Подразумевать ответ "Да" на все запросы
-z<файл> | Прочитать комментарий архива из файла


Ключ -- - прервать дальнейший поиск ключей в командной строке

Ключ -- — прервать дальнейший поиск ключей в командной строке

Этот ключ указывает WinRAR, что в командной строке больше нет ключей. Может пригодиться, когда с символа "-" начинается имя архива или какого-либо файла. Без ключа "--" подобное имя будет трактоваться как ключ.

Пример

Добавить все файлы из текущей папки в непрерывный архив с именем -StrangeName:

WinRAR a -s -- -StrangeName


Ключ -@[+] - запретить [разрешить] списки файлов

Ключ -@[+] — запретить [разрешить] списки файлов

Если при обработке командной строки WinRAR встречает символ '@', он считает, что далее указаны списки файлов. То есть если WinRAR обнаруживает параметр @filename, он по умолчанию пытается прочитать содержимое файла filename, считая, что в нём находится список файлов. Однако если имеется файл с именем @filename, WinRAR считает параметр @filename именем файла вместо того, чтобы прочитать список файлов из файла filename.

Ключ -@[+] позволяет избежать такой неопределённости, чётко определяя, как нужно обрабатывать параметры, начинающиеся с символа "@".

Если указать -@, то все параметры, обнаруженные после этого ключа, будут считаться именами файлов, а не файлами-списками.

Если указать -@+, то все параметры, обнаруженные после этого ключа, будут считаться файлами-списками, а не именами файлов.

Этот ключ не влияет на обработку параметров, которые указаны в командной строке до него.

Пример

Протестировать находящийся в архиве файл "@home":

WinRAR t -@ notes.rar @home


Ключ -AC - снять атрибут "Архивный"

Ключ -AC — снять атрибут "Архивный"

Этот ключ предназначен для резервного копирования. Если он используется при архивации, то по окончании операции у всех успешно упакованных файлов будет снят атрибут Архивный. Если ключ используется при распаковке, то атрибут Архивный будет снят у извлечённых файлов. На атрибуты папок этот ключ не влияет.


Ключ -AD[1] - добавить имя архива

Ключ -AD[1] — добавить имя архива

Ключ может пригодиться при распаковке группы архивов. По умолчанию WinRAR извлекает файлы из всех архивов в одну и ту же папку, если же указать ключ -ad, то файлы из каждого архива будут распакованы в отдельные папки. Эти отдельные папки создаются в целевой папке для ключа -ad, и в каждой архивной папке для ключа -ad1. Для ключа -ad1 параметр целевой папки игнорируется.

Примеры

Распаковать все архивы RAR, создавая для каждого из них вложенные папки в папке data:

WinRAR x -ad *.rar data\

Выполнить рекурсивный поиск архивов *.rar в папке arc и создать вложенные папки в каждой папке архива:

WinRAR x -r -ad1 arc\*.rar


Ключ -AF<тип> - указать формат архива

Ключ -AF<тип> — указать формат архива

С помощью этого ключа можно указывать в командной строке тип создаваемого WinRAR архива. Параметр <тип> может принимать значения rar или zip.

Пример

Создать архив arc.zip:

WinRAR a -afzip arc

Ключ -af поддерживается только в WinRAR. Консольная версия RAR создавать архивы ZIP не может.


Ключ -AG[формат] - добавить к имени архива текущие дату и время

Ключ -AG[формат] — добавить к имени архива текущие дату и время

Добавляет к имени архива текущие дату и время при создании или обработке архива. Полезно для ежедневного резервного копирования.

Если параметр формат не указан, то используется стандартный формат YYYYMMDDHHMMSS. Строка формата может включать следующие символы:

Y | Год
M | Месяц
MMM | Месяц в виде строки (Jan, Feb и т.д.)
W | Номер недели (неделя начинается с понедельника)
A | День недели (1 - понедельник, 7 - воскресенье)
D | Порядковый день месяца
E | Порядковый номер дня в году
H | Часы
M | Минуты (обрабатывается как минуты, если стоит после часов)
I | Минуты (обрабатывается как минуты вне зависимости от местоположения часов)
S | Секунды
N | Номер архива (числовое значение начиная с 1) При архивировании WinRAR ищет уже существующий архив со сгенерированным именем, и если таковой обнаруживается, то увеличивает номер архива, пока не будет создано уникальное имя. Форматирующий символ 'N' не поддерживается при создании томов. При операциях, не связанных с архивированием (например при извлечении), WinRAR выбирает архив с именем, предшествующим первому неиспользуемому, либо устанавливает N в 1, если такого архива не существует.

Каждый из указанных выше форматирующих символов соответствует только одному символу, добавляемому к имени архива. Например, для двухсимвольного номера недели используйте WW, а для обозначения года из четырёх цифр — YYYY.

Если строка формата начинается с символа "+", то дата и базовое имя архива меняются местами, т.е. дата будет перед именем архива.

Строка формата может содержать необязательный текст, заключённый в фигурные скобки "{" и "}". Этот текст будет вставлен в имя архива.

Все остальные символы добавляются к имени архива без изменений.

Будьте осторожны с ключом -ag при обработке уже существующих архивов. В зависимости от строки формата и времени, прошедшего с момента предыдущего использования ключа -ag, имена сгенерированного и имеющегося архивов могут оказаться разными. В этом случае WinRAR вместо обработки уже существующего архива создаст новый. Можно воспользоваться ключом -log, чтобы записать в файл сгенерированное имя архива, а затем прочитать его оттуда для дальнейшей обработки.

Примеры

1. Использовать формат по умолчанию YYYYMMDDHHMMSS:

WinRAR a -ag backup

2. Использовать формат DD-MMM-YY:

WinRAR a -agDD-MMM-YY backup

3. Использовать формат YYYYMMDDHHMM, поместив дату перед именем архива backup:

WinRAR a -ag+YYYYMMDDHHMM backup

4. Использовать формат YYYY-WW-A с описаниями полей:

WinRAR a -agYYYY{год}-WW{неделя}-A{день} backup

5. Использовать формат YYYYMMDD и нумерацию архива. Это позволяет генерировать уникальные имена даже в том случае, если маска формата YYYYMMDD используется несколько раз в день:

WinRAR a -agYYYYMMDD-NN backup


Ключ -AI - игнорировать файловые атрибуты

Ключ -AI — игнорировать файловые атрибуты

Если ключ указан при распаковке, WinRAR не устанавливает у извлекаемых файлов атрибуты, сохранённые в архиве. Вместо этого файлам назначаются атрибуты, которые ОС присваивает по умолчанию всем вновь создаваемым файлам. Это относится к атрибутам "Архивный", "Системный", "Скрытый" и "Только чтение".

Если ключ указан при архивировании, то вместо действительных атрибутов в архиве сохраняются предустановленные значения, типичные для файла и папки.

При распаковке ключ поддерживается только для форматов RAR и ZIP, а при архивировании — только для RAR.


Ключ -AO - добавить файлы с установленным атрибутом "Архивный"

Ключ -AO — добавить файлы с установленным атрибутом "Архивный"

Этот ключ предназначен для резервного копирования. Если указать его при архивации, то в архив будут добавлены только файлы с установленным атрибутом "Архивный". Ключ не влияет на папки, поэтому все подходящие папки добавляются вне зависимости от их атрибутов. Если нужно исключить все записи о папках, используйте ключ -ed в командной строке.

Пример

Добавить в архив f:backup все файлы с диска C:, имеющие атрибут "Архивный", после чего снять этот атрибут со всех добавленных файлов:

WinRAR a -r -ac -ao f:backup c:\*.*


Ключ -AP<путь> - указать путь внутри архива

Ключ -AP<путь> — указать путь внутри архива

Задаваемый этим ключом путь добавляется к именам файлов при архивировании и удаляется из имён при извлечении файлов.

Например, если нужно добавить файл readme.txt в папку DOCS\ENG в архиве release, выполните:

WinRAR a -apDOCS\ENG release readme.txt

Чтобы извлечь папку ENG в текущую папку, выполните:

WinRAR x -apDOCS release DOCS\ENG\*.*

Применимо только для форматов RAR и ZIP.


Ключ -AS - синхронизировать содержимое архива

Ключ -AS — синхронизировать содержимое архива

Если этот ключ используется при архивации, то файлы, которых нет среди добавляемых, будут удалены из архива. Этот ключ удобно использовать совместно с ключом -u для синхронизации содержимого архива и архивируемой папки.

Например, после команды:

WinRAR a -u -as backup sources\*.cpp

в архиве backup.rar останутся только файлы *.cpp из папки sources, а все остальные будут удалены. Это аналогично созданию нового архива, но за одним важным исключением: если после прошлой архивации файлы не изменялись, то операция будет выполнена значительно быстрее, чем создание нового архива.


Ключ -CFG- - игнорировать профиль по умолчанию и переменную окружения

Ключ -CFG- — игнорировать профиль по умолчанию и переменную окружения

Если указан этот ключ, WinRAR игнорирует параметры в профиле архивации по умолчанию, переменную окружения RAR, папку по умолчанию для архивов, поля Выбирать для архивов в окне управления паролями, и некоторые другие сохранённые параметры.


Ключ -CL - преобразовывать имена файлов в нижний регистр

Ключ -CL — преобразовывать имена файлов в нижний регистр

Если указан этот ключ, имена всех файлов, извлекаемых из архива, добавляемых в архив, изменяемых или обновляемых в архиве, будут преобразованы в нижний регистр. Иногда это может пригодиться при переносе архива с регистронезависимой на регистрозависимую операционную систему, например при извлечении в среде UNIX файлов из архива, созданного в DOS.

Пример

Извлечь все файлы из архива port.rar, преобразовав их имена в нижний регистр:

WinRAR x -cl port


Ключ -CP<имя> - выбрать профиль архивации

Ключ -CP<имя> — выбрать профиль архивации

С помощью этого ключа можно загружать установки, сохранённые в профиле архивации WinRAR. В качестве параметра ключа необходимо указать имя профиля. Если в профиле сохранены выбранные имена файлов, WinRAR будет упаковывать и файлы с этими именами, и файлы, указанные в командной строке. Если профиль содержит имя архива, то оно и будет использоваться при архивировании — в этом случае указывать в командной строке другое имя архива не нужно.

В имени профиля учитывается регистр букв. Указывайте имя профиля точно так, как при его сохранении.

Пример

Заархивировать файлы *.txt с использованием установок из профиля архивации "My Texts":

WinRAR a "-cpMy Texts" texts *.txt


Ключ -CU - преобразовывать имена файлов в верхний регистр

Ключ -CU — преобразовывать имена файлов в верхний регистр

Если указан этот ключ, имена всех файлов, извлекаемых из архива, добавляемых в архив, изменяемых или обновляемых в архиве, будут преобразованы в ВЕРХНИЙ регистр.

Пример

Извлечь все файлы из архива port.rar, преобразовав их имена в верхний регистр:

WinRAR x -cu port


Ключ -DF - удалить файлы после архивации

Ключ -DF — удалить файлы после архивации

Перемещает файлы в архив. При использовании вместе с командой A этот ключ выполняет то же действие, что и команда M.


Ключ -DH - открывать совместно используемые файлы

Ключ -DH — открывать совместно используемые файлы

Позволяет обрабатывать файлы, открытые для записи другими программами.

Это опасный ключ, так как он разрешает архивировать файлы, которые в тот же момент могут быть изменены другой программой. Если при этом будет нарушена внутренняя структура заархивированного файла, то программа для его обработки после распаковки такого файла может его не открыть. Используйте этот ключ очень осторожно!

Если ключ -dh не указан, то обработка совместно используемых файлов зависит от параметра Открывать совместно используемые файлы в профиле архивации по умолчанию.

Пример

WinRAR a -dh dbf *.dbf


Ключ -DR - удалить файлы в Корзину

Ключ -DR — удалить файлы в Корзину

Удалить файлы после архивирования и поместить их в Корзину.


Ключ -DS - не сортировать файлы при добавлении в непрерывный архив

Ключ -DS — не сортировать файлы при добавлении в непрерывный архив

Этот ключ имеет смысл использовать только с непрерывными архивами RAR. Степень сжатия в непрерывных архивах зависит от порядка следования в них файлов. По умолчанию при добавлении файлов в непрерывный архив они сортируются по расширениям. Ключ -ds позволяет запретить эту сортировку и попробовать задать более подходящий, по вашему мнению, порядок следования файлов. В общем случае, файлы с похожими данными должны находиться в архиве как можно ближе друг к другу.

Пример

Добавить в непрерывный архив tools.rar файлы в следующем порядке: *.com, *.exe, *.doc, *.txt, затем файлы всех остальных типов:

WinRAR a -s -ds tools *.com *.exe *.doc *.txt *.*

Примечание

Порядок следования файлов в непрерывных архивах также можно указывать с помощью файла rarfiles.lst.


Ключ -DW - уничтожить (затереть) файлы после архивации

Ключ -DW — уничтожить (затереть) файлы после архивации

Надёжно удалить файлы после архивирования. Перед удалением содержащиеся в файле данные перезаписываются нулевыми байтами, чтобы нельзя было восстановить удалённые файлы, файл усекается и ему даётся временное имя.

Имейте в виду, что эта функция рассчитана на обычные жёсткие диски. При использовании с твердотельными накопителями (SSD) перезапись исходных данных может не работать из-за применяемой в SSD-накопителях технологии Wear Leveling (перераспределения блоков при записи) и более сложной адресации данных.


Ключ -ED - не добавлять пустые папки

Ключ -ED — не добавлять пустые папки

Если указать этот ключ, в создаваемом архиве не будут сохраняться записи о папках. При распаковке таких архивов WinRAR создаст непустые папки на основе путей к содержащимся в них файлам. Информация о пустых папках будет утеряна. Также будут утеряны все атрибуты непустых папок (права доступа, потоки и пр.) за исключением их имён, поэтому ключ -ed следует применять только тогда, когда вам не нужно сохранять такую информацию.

Если ключ -ed используется месте с командой m или с ключом -df, пустые папки удаляться не будут.


Ключ -EN - не добавлять в архив блок "Конец архива"

Ключ -EN — не добавлять в архив блок "Конец архива"

Не поддерживается в архивах RAR5.

По умолчанию при создании или обновлении архива WinRAR добавляет в его конец блок "Конец архива". Это позволяет безопасно пропускать такие внешние данные, как, скажем, цифровые подписи, однако в особых случаях эту функцию бывает нужно отключить. Например, если архив передаётся между двумя системами по ненадёжной линии связи, и одновременно с этим отсылающая сторона добавляет в архив новые файлы, важна гарантия того, что уже принятая часть файла не будет изменена на другом конце между сессиями передачи данных.

Этот ключ нельзя использовать с архивными томами, так как блок конца архива содержит информацию, важную для правильной обработки томов.


Ключ -EP - исключить пути из имён

Ключ -EP — исключить пути из имён

Если ключ указан при архивировании, файлы добавляются в архив без информации об их путях. Учтите, что это может привести к тому, что в одной папке архива окажется несколько файлов с одним и тем же именем.

Если ключ указан при распаковке, то у извлекаемых файлов игнорируются сохранённые в архиве пути, т.е. все файлы будут созданы в одной и той же целевой папке.

Пример

Заархивировать без путей все файлы *.bas с текущего диска:

WinRAR a -r -ep bsources \*.bas


Ключ -EP1 - исключить базовую папку из имён

Ключ -EP1 — исключить базовую папку из имён

Не сохранять в архиве и не извлекать из архива путь, указанный в командной строке.

Примеры

  1. Добавить все файлы и папки из папки tmp в архив test, исключив tmp из сохраняемых в архиве путей:

WinRAR a -ep1 -r test tmp\*

 Это эквивалентно командам:

cd tmp

WinRAR a -r ..\test

cd ..

  2. Извлечь соответствующие маске images\* файлы в папку dest\, удалив images\ из путей создаваемых файлов:

WinRAR x -ep1 data images\* dest\


Ключ -EP2 - сохранять полные пути файлов

Ключ -EP2 — сохранять полные пути файлов

Сохранять при архивировании полные пути файлов, за исключением буквы диска и идущей в начале обратной косой черты ( \ ).


Ключ -EP3 - сохранять полные пути, включая буквы дисков

Ключ -EP3 — сохранять полные пути, включая буквы дисков

При архивировании этот ключ служит для сохранения полных путей добавляемых файлов, включая букву диска. Символ признака дисков (двоеточие) заменяется на подчёркивание ( _ ).

Если ключ -ep3 указан при распаковке архива, символы подчёркивания снова заменяются двоеточиями, а извлекаемые файлы будут созданы в их исходных папках и дисках. Если при этом также указан целевой путь, он будет проигнорирован.

Кроме того, ключ преобразовывает UNC-пути из \\server\share в __server\share при архивировании, и восстанавливает их в исходный вид при извлечении.

Этот ключ полезен для резервного копирования информации с нескольких дисков в один архив. Например, команда

WinRAR a -ep3 -r backup.rar c:\ d:\ e:\

создаст резервную копию дисков C:, D: и E:, а команда

WinRAR x -ep3 backup.rar

восстановит из неё все данные с абсолютными путями.

Однако соблюдайте осторожность: ключ -ep3 следует использовать, только когда вы уверены, что распаковываемый архив не содержит никаких "злонамеренных" файлов. Иными словами, используйте этот ключ только с архивами, созданными лично вами или людьми, которым вы всецело доверяете. Причина в том, что данный ключ позволяет перезаписать любой файл в любой папке компьютера, включая важные системные файлы, поэтому его следует применять только в целях резервного копирования.


Ключ -E<атр> - исключить/включить в обработку файлы с указанными атрибутами

Ключ -E[+]<атр> — исключить/включить в обработку файлы с указанными атрибутами

Позволяет указать маску атрибутов файлов, которые необходимо исключить из обработки или включить в неё. Здесь <атр> — это число в десятичном, восьмеричном (если начинается с "0") или шестнадцатеричном (если начинается с "0x") формате.

По умолчанию, без символа "+" перед <атр> этот ключ служит для определения маски исключения из обработки. Так, если результат побитового И (AND) между <атр> и атрибутами файла ненулевой, то файл не будет обработан.

Если символ "+" указан, будет использоваться маска включения в обработку. Т.е. обрабатываться будут только те файлы, которые имеют хотя бы один из указанных в маске атрибутов.

В версии RAR для Windows при указании атрибутов вместо цифровой маски можно также использовать буквы D, S, H, A и R, обозначающие, соответственно, атрибуты “Папка”, “Системный”, “Скрытый”, “Архивный” и “Только чтение”. Порядок перечисления атрибутов не имеет значения.

В одной командной строке допускается использовать одновременно ключи -e<атр> и -e+<атр>.

Примеры

1. Заархивировать только имена папок, но не их содержимое:

WinRAR a -r -e+d папки

2. Не упаковывать файлы с атрибутами "Системный" и "Скрытый":

WinRAR a -esh файлы

3. Не извлекать файлы с атрибутом "Только чтение":

WinRAR x -er файлы


Ключ -F - обновить имеющиеся файлы

Ключ -F — обновить имеющиеся файлы

Этот ключ можно использовать при добавлении в архив или извлечении из него. Командная строка a -f эквивалентна команде f. Этот ключ также допускается использовать с командой m.

Если ключ -f указан вместе с командами x или e, то из архива будут извлечены только те файлы, которые уже есть на диске, но имеют более старые даты, чем соответствующие им файлы в архиве. Если файлу из архива не соответствует ни один из файлов на диске, то такой файл не будет извлечён из архива.

Эквивалентом этого ключа в режиме оболочки являются пункты Обновить существующие файлы в окне Имя и параметры архива и одноимённый параметр в окне Путь и параметры извлечения.

Поддерживается только для форматов RAR и ZIP.


Ключ -HP[пароль] - шифровать содержимое файлов и оглавление архива

Ключ -HP[пароль] — шифровать содержимое файлов и оглавление архива

Как и -p[пароль], этот ключ активизирует режим шифрования архива, но -p шифрует только содержащиеся в файлах данные, а другая информация, например имена файлов, остаётся видимой. При указании ключа -hp шифруются все важные области архива, включая данные файлов, имена файлов, размеры, атрибуты, комментарии и другие блоки, благодаря чему обеспечивается более высокая степень защиты.

Архив, зашифрованный с ключом -hp, без пароля невозможно не только распаковать, но даже просмотреть список содержащихся в нём файлов.

Пример

Добавить файл report.txt в зашифрованный архив secret.rar, используя пароль fGzq5yKw:

WinRAR a -hpfGzq5yKw secret report.txt


Ключ -HT[B|C] - выбрать тип хеша [BLAKE2|CRC32] для контрольных сумм

Ключ -HT[B|C] — выбрать тип хеша [BLAKE2|CRC32] для контрольных сумм

Целостность данных в архивах RAR определяется по контрольным суммам, вычисляемым и сохраняемым для каждого файла в архиве.

Для вычисления контрольных сумм WinRAR по умолчанию использует функцию CRC32. В архивах формата RAR5 вместо CRC32 можно использовать хеш-функцию BLAKE2.

BLAKE2 выбирается ключом -htb, а CRC32 — ключом -htc. Так как CRC32 используется по умолчанию, указывать ключ -htc нужно только тогда, когда требуется переопределить режим -htb, заданный в конфигурации WinRAR.

Длина вывода CRC32 составляет 32 бита. Возможностей CRC32 хватает для определения большинства непреднамеренных ошибок в данных, но их недостаточно для проверки подлинности файловых данных. Иными словами, если два файла имеют одну и ту же CRC32, нет гарантии, что у этих файлов одинаковое содержимое.

Длина вывода BLAKE2 равна 256 битам. Так как это криптостойкая хеш-функция, она практически полностью гарантирует, что если у двух файлов одинаковое значение BLAKE2, содержимое этих файлов также одинаково. Кроме того, у BLAKE2 надёжнее, чем у более короткого CRC32, определение ошибок.

Поскольку вывод BLAKE2 длиннее, при указании ключа -htb архив получается чуть большего объёма.

Если заголовки архива не зашифрованы (не указан ключ -hp), контрольные суммы зашифрованных файлов в архивах RAR5 изменены с помощью особого зависящего от пароля алгоритма, чтобы по контрольным суммам нельзя было угадать содержимое файлов. Поэтому не ждите, что контрольные суммы зашифрованных файлов совпадут с обычными значениями CRC32 и BLAKE2.

Этот ключ поддерживается только для формата RAR5, поэтому его нужно использовать вместе с ключом -ma.

Ключ -htb — эквивалент в командной строке параметра Использовать контрольные суммы BLAKE2 в окне Имя и параметры архива.

Пример

Добавить все файлы *.lst в архив lists.rar, используя контрольные суммы BLAKE2:

WinRAR a -ma -htb lists.rar *.lst


Ключ -IADM - запрашивать права администратора для SFX-архива

Ключ -IADM — запрашивать права администратора для SFX-архива

Ключ -iadm следует применять в тех случаях, когда необходимо создать SFX-архив, который будет требовать административный доступ при запуске в среде Vista и более новых версиях Windows. На поведение SFX-архива в более старых версиях Windows ключ -iadm не влияет.

Этот ключ — эквивалент в командной строке параметра Запрашивать права администратора в окне дополнительных параметров SFX.

Пример

WinRAR a -sfx -iadm install.exe c:\data


Ключ -IBCK - запустить WinRAR как фоновый процесс в области уведомлений

Ключ -IBCK — запустить WinRAR как фоновый процесс в области уведомлений

Сворачивает WinRAR в область уведомлений в панели задач при запуске операции обработки архива.

Этот ключ эквивалентен параметрам Архивировать в фоновом режиме в окне Имя и параметры архива и Извлекать в фоновом режиме в окне извлечения.


Ключ -IEML [.][адрес] - отправить архив по электронной почте

Ключ -IEML[.][адрес] — отправить архив по электронной почте

Прикрепить к электронному письму архив, созданный или обновлённый командой добавления файлов. Чтобы использовать этот ключ, в компьютере должна быть установлена клиентская почтовая программа, совместимая с интерфейсом MAPI (его поддерживают большинство современных почтовых программ).

Адрес получателя можно указать непосредственно вместе с этим ключом или не указывать его вовсе — тогда он будет запрошен почтовой программой. Допускается указывать несколько адресов, разделяя их запятыми или точками с запятой.

Если следом за ключом -ieml добавить точку, то после успешного прикрепления к письму архив будет удалён.

Если этот ключ используется при создании многотомного архива, каждый том прикрепляется к отдельному письму.


Ключ -IICON<имя> - указать значок для SFX-архива

Ключ -IICON<имя> — указать значок для SFX-архива

Этот ключ позволяет указать значок для создаваемого или обновляемого SFX-архива. Параметр <имя> это имя файла со значком (.ico). SFX-модуль не должен быть сжат с помощью какой-либо программы упаковки исполняемых файлов (например UPX).

Ключ -iicon — эквивалент в командной строке параметра Загрузить значок SFX из файла в окне Дополнительные параметры SFX на вкладке Текст и значок.

Примеры

1. Добавить содержимое папки c:\myfiles в SFX-архив setup.exe, используя в качестве значка файл c:\myicons\ver1.ico:

WinRAR a -sfx -iiconc:\myicons\ver1.ico setup.exe c:\myfiles

2. Заменить значок на c:\myicons\ver2.ico в существующем SFX-архиве setup.exe:

WinRAR s -iiconc:\myicons\ver2.ico setup.exe


Ключ -IIMG<имя> - указать логотип для SFX-архива

Ключ -IIMG<имя> — указать логотип для SFX-архива

Этот ключ позволяет указать для создаваемого или обновляемого SFX-архива графический файл с растровым изображением, которое будет отображаться как логотип. Параметр <имя> — это имя графического файла в формате BMP. Если вы собираетесь использовать ключ -iimg, то SFX-модуль не должен быть сжат с помощью какой-либо утилиты для упаковки исполняемых файлов (например UPX).

Ключ -iimg — эквивалент в командной строке параметра Загрузить логотип для SFX из файла в окне Дополнительные параметры SFX на вкладке Текст и значок.

Размер стандартного SFX-логотипа — 93×302 пиксела. Рекомендуется использовать изображения такого же или меньшего размера.

Примеры

Добавить содержимое папки c:\myfiles в SFX-архив setup.exe, используя в качестве SFX-логотипа файл c:\pictures\logo1.bmp:

WinRAR a -sfx -iimgc:\pictures\logo1.bmp setup.exe c:\myfiles

Заменить логотип в уже существующем SFX-архиве setup.exe на файл logo2.bmp, находящийся в текущей папке:

WinRAR s -iimglogo2.bmp setup.exe


Ключ -ILOG[имя] - записывать ошибки в файл-журнал

Ключ -ILOG[имя] — записывать ошибки в файл-журнал

Записывать сообщения об ошибках в файл rar.log, создаваемый в папке WinRAR. Просмотреть содержимое этого файла можно командой Просмотр журнала в меню Настройки. Вместо используемого по умолчанию файла rar.log можно указать другое имя файла, например:

-ilogc:\log\backup.log

Если в указанном имени нет пути, файл с журналом будет создан в папке %APPDATA%\WinRAR.

Если в общих настройках WinRAR включён параметр Записывать ошибки в журнал, то сообщения об ошибках будут сохраняться в файле rar.log даже без указания ключа -ilog.

По умолчанию файл с журналом сохраняется в кодировке UTF-16 little endian, но с помощью ключа -sc<кодировка>g можно указать другую кодировку. Например, ключ -scag задаёт "родную" однобайтовую кодировку.


Ключ -IM - показывать дополнительную информацию

Ключ -IM — показывать дополнительную информацию

Показывать больше информации при использовании в режиме командной строки. На данный момент ключ можно применять только с командой T для отображения сообщения об успешном завершении тестирования архива. Без этого ключа команда T завершает работу без каких-либо сообщений, если тестирование не выявило никаких ошибок.


Ключ -INUL - не показывать сообщения об ошибках

Ключ -INUL — не показывать сообщения об ошибках

Если указать этот ключ, WinRAR не будет показывать сообщения об ошибках.


Ключ -IOFF[n] - по окончании операции выключить компьютер

Ключ -IOFF[n] — по окончании операции выключить компьютер

Завершить работу компьютера по завершении операции или перевести его в состояние гибернации/сна.

-ioff или -ioff1 — выключить компьютер

-ioff2 — перевести компьютер в состояние гибернации

-ioff3 — перевести компьютер в состояние сна

-ioff4 — перезагрузить компьютер

Для работы этого ключа требуется, чтобы операционная система поддерживала соответствующие функции управления электропитанием.

Если запущено несколько копий WinRAR, компьютер будет выключен, когда завершит работу последняя копия.


Ключ -ISND[-] - управление звуками оповещений

Ключ -ISND[-] — управление звуками оповещений

Используйте -isnd, чтобы разрешить звуки оповещений, и -isnd-, чтобы их запретить.


Ключ -K - заблокировать архив

Ключ -K — заблокировать архив

Этот ключ служит для блокирования архива, чтобы впоследствии его уже нельзя было изменить средствами WinRAR. С помощью этого ключа можно блокировать архив сразу же при его создании или обновлении.


Ключ -KB - не удалять файлы, извлечённые с ошибками

Ключ -KB — не удалять файлы, извлечённые с ошибками

Если при извлечении файла обнаруживается, что он повреждён, то по умолчанию такой файл удаляется с диска. Если указать ключ -kb, повреждённые файлы будут сохраняться на диске, что иногда позволяет извлечь из них хоть какую-то полезную информацию.


Ключ -LOG[формат][=имя] - записывать имена в файл-журнал

Ключ -LOG[формат][=имя] — записывать имена в файл-журнал

Этот ключ позволяет записывать имена архива и файлов в указанный текстовый файл при использовании с командами архивирования, извлечения, удаления для формата RAR, и с командами архивирования для формата ZIP. Поведение ключа определяется строкой формат, которая может включать один или несколько следующих символов:

A | Записывать в журнал имена архивов. При создании или обработке томов в журнал записываются все имена томов.
F | Записывать в журнал имена обработанных файлов (добавляемых в архив, извлекаемых и удаляемых из архива, а также отображаемых командой листинга содержания архива).
P | Если журнал с указанным именем существует, не создавать новый файл, а добавлять данные в уже имеющийся.
U | Записывать данные в кодировке Юникод.

Если не указаны ни A, ни F, то подразумевается A.

Параметр имя позволяет указать имя файла с журналом. Имя должно быть отделено от строки формат символом "=" (без кавычек). Если имя не указано, будет использоваться имя по умолчанию — rarinfo.log.

В одной и той же командной строке разрешается указывать несколько ключей -log.

Этот ключ может быть особенно полезен, когда нужно обработать архив, созданный с ключами -ag или -v в пакетном сценарии. Так, вы можете указать ключ -loga=arcname.txt при создании архива, а затем прочитать сгенерированное WinRAR имя архива из файла arcname.txt с помощью соответствующей команды в пакетном файле, например: set /p name=<arcname.txt

Все функции этого ключа поддерживаются только для формата RAR. Для формата ZIP поддерживаются только операции архивирования. Для других форматов архивов этот ключ не поддерживается.

Примеры

  1. Записать имена созданных томов в файл vollist.txt:

WinRAR a -v100m -loga=vollist.txt volume.rar c:\data

  2. Записать сгенерированное имя архива в файл backup.txt в кодировке Юникод:

WinRAR a -ag -logau=backup.txt backup.rar myfiles\*

  3. Записать имена протестированных томов в файл vollist.txt, а имена протестированных заархивированных файлов внутри томов — в файл filelist.txt:

WinRAR t -log=vollist.txt -logf=filelist.txt volume.part01.rar


Ключ -M<n> - метод сжатия

Ключ -M<n> — метод сжатия

С помощью параметра <n> (от 0 до 5) можно указать желаемый метод сжатия.

-m0 | Без сжатия | Добавить файлы в архив без сжатия
-m1 | Скоростной | Самый быстрый метод (минимальное сжатие)
-m2 | Быстрый | Быстрый метод
-m3 | Обычный | Обычный метод сжатия (по умолчанию)
-m4 | Хороший | Хороший метод сжатия (более сильное сжатие)
-m5 | Максимальный | Наилучший метод сжатия (максимальное, но самое медленное сжатие)

Если этот ключ не указан, используется метод -m3 ("обычный").

Метод сжатия также можно выбрать из списка Метод сжатия в окне Имя и параметры архива.


Ключ -MA[4|5] - версия формата архивирования

Ключ -MA[4|5] — версия формата архивирования

По умолчанию WinRAR создаёт архивы в формате RAR5. Чтобы создавать архивы RAR4, используйте ключ -ma4. Ключ -ma5 или просто -ma нужен для отмены действия -ma4, сохранённого в конфигурации, и принудительного использования формата RAR5.

Этот ключ применяется только при создании нового архива. При обновлении уже существующего архива он игнорируется.

Пример

Создать непрерывный архив data.rar формата RAR4 и упаковать в него папку SrcDir, используя словарь размером 2 МБ:

WinRAR a -ma4 -md2m data SrcDir


Ключ -MC<параметры> - дополнительные параметры сжатия

Ключ -MC<параметры> — дополнительные параметры сжатия

Этот ключ предназначен преимущественно для испытаний и экспериментов, в реальной жизни обычно лучше позволить WinRAR автоматически выбирать оптимальные параметры архивирования. Обратите внимание, что неправильное применение этого ключа может привести к очень существенным потерям времени и сжатия, поэтому используйте его, только если чётко понимаете, что вы делаете.

Ключ имеет следующий синтаксис:

-mc[Параметр1][:Параметр2][Модуль][+|-]

где <Модуль> — односимвольное поле, указывающее часть алгоритма сжатия, который должен быть сконфигурирован. Может принимать следующие значения:

A | Сжатие аудиоданных
C | Сжатие графических данных TrueColor (RGB)
D | Дельта-сжатие
E | Сжатие исполняемых файлов Intel x86
I | Сжатие исполняемых файлов Intel Itanium
T | Сжатие текстов

Архивный формат RAR5 поддерживает только значения D и E.

Знак "+" в конце ключа указывает, что выбранный алгоритмический модуль должен быть использован для всех обрабатываемых данных, а знак "-" отключает этот модуль совсем. Если не указан ни плюс, ни минус, модули выбираются автоматически в зависимости от данных и текущего метода сжатия. Ключ -mc- запрещает использование всех дополнительных модулей, разрешая применять только общий алгоритм сжатия.

<Параметр1> и <Параметр2> зависят от конкретного модуля, ниже приведено их описание.

Сжатие аудиоданных, дельта-сжатие

<Параметр1> — число байтовых каналов (от 1 до 31).

WinRAR разделяет многобайтовые каналы на байты, например два 16-битовых аудиоканала WinRAR считает за четыре канала по одному байту каждый.

<Параметр2> не используется.

Сжатие исполняемых файлов Intel x86, Intel Itanium, графики TrueColor (RGB)

<Параметр1> и <Параметр2> не используются.

Сжатие текста

Алгоритм сжатия текста обеспечивает заметно более высокую степень упаковки простых текстовых данных. Однако поскольку этот алгоритм не может эффективно использовать многоядерные процессоры, в системах с многоядерными ЦП и несколькими ЦП его скорость работы ниже, чем у основного алгоритма. Кроме того, скорость распаковки у этого алгоритма значительно ниже, чем у основного, вне зависимости от числа ядер процессора. Поэтому алгоритм сжатия текста по умолчанию отключён. Если вы хотите, чтобы WinRAR автоматически использовал этот алгоритм при упаковке соответствующих данных, укажите ключ -mct. Ключ -mct+ принудительно включает текстовое сжатие для всех данных.

Ключ -mct может также содержать <Параметр1> и <Параметр2>, поэтому его полный синтаксис следующий: -mc[Параметр1][:Параметр2]t[+ | -].

<Параметр1> — порядок алгоритма PPM (от 2 до 63).

<Параметр2> — память для алгоритма PPM в мегабайтах (от 1 до 128).

Алгоритму PPM требуется для распаковки такой же объём памяти, какой применялся при упаковке, поэтому если при создании архива выделить ему слишком много памяти, могут возникнуть проблемы с распаковкой такого архива на компьютере с меньшим объёмом памяти. Извлечение файлов будет возможно при помощи виртуальной памяти, но это может занять очень много времени.

Примеры

1. Ключ -mc1a+ принудительно включает 8-битовое сжатие монофонического звука для всех данных.

2. Ключ -mc10:40t+ принудительно включает алгоритм сжатия текста для всех данных, устанавливая порядок сжатия 10 и выделяя 40 МБ памяти.

3. Ключ -mc12t устанавливает порядок сжатия текста в значение 12, если вступает в действие алгоритм сжатия текста, но оставляет WinRAR право решать, когда именно нужно его использовать.

4. Ключи -mct -mcd- разрешают WinRAR применять алгоритм сжатия текста для подходящих данных и отключать дельта-сжатие.


Ключ -MD<n>[k,m,g] - размер словаря

Ключ -MD<n>[k,m,g] — размер словаря

Скользящий словарь — это специальная область памяти, используемая алгоритмом сжатия. Если сжимаемый файл (в случае непрерывного архива — всех сжимаемых файлов) больше словаря, то увеличение размера словаря обычно приводит к улучшению степени сжатия, замедлению обработки и большему потреблению памяти.

Для архивов формата RAR4 размер словаря может принимать следующие значения: 64/128/256/512 КБ, 1/2/4 МБ.

Для архивов формата RAR5 размер словаря может принимать следующие значения: 128/256/512 КБ, 1/2/4/8/16/32/64/128/256/512 МБ, 1 ГБ.

Для указания размера в кило-, мега- и гигабайтах можно использовать модификаторы k, m и g. Например, ключ -md64m задаёт словарь размером 64 МБ. Если модификатор не указан, подразумеваются мегабайты, т.е. ключи -md64m и -md64 эквивалентны.

При архивировании требуется памяти в шесть раз больше, чем выбранный размер словаря, поэтому размеры 512 МБ и 1 ГБ доступны только в 64-разрядной версии WinRAR. В среде Windows XP x86 максимальный размер словаря сжатия даже меньше и составляет 128 МБ. При распаковке требуется памяти чуть больше, чем один размер словаря, так что обе версии — 32- и 64-разрядная — способны распаковывать архивы со словарями любого размера, включая 1 ГБ.

Если размер всех исходных файлов для непрерывного архива или размер наибольшего исходного файла для обычного (не непрерывного) архива хотя бы вдвое меньше заданного размера словаря, то WinRAR может уменьшить размер словаря. Это снижает требования к памяти, не ухудшая сжатие.

По умолчанию размер скользящего словаря для формата RAR4 составляет 4 МБ, а для RAR5 — 32 МБ.

При создании архивов ZIP всегда используется словарь размером 32 КБ.

Размер словаря выбирается в списке Размер словаря в окне Имя и параметры архива.

Пример

Создать непрерывный архив stuff.rar, используя словарь размером 512 КБ и метод сжатия "Максимальный":

WinRAR a -md512 -m5 -s stuff


Ключ -MS - расширения файлов для архивирования без сжатия

Ключ -MS[список] — расширения файлов для архивирования без сжатия

С помощью этого ключа можно указать типы файлов, которые нужно помещать в архив без сжатия. При правильном применении это может существенно ускорить архивирование без заметных потерь в степени сжатия всего архива.

Необязательный параметр <список> позволяет указать список файловых расширений, которые должны быть перечислены через точку с запятой (;). Например, ключ -msrar;zip;jpg указывает, что нужно помещать в архив без сжатия все архивы RAR и ZIP, а также изображения в формате JPG. В списке можно применять символы подстановки (шаблоны), поэтому ключ -ms*.rar;*.zip;*.jpg имеет такое же значение. В одной командной строке разрешается указывать несколько ключей -ms, например -msrar -mszip вместо -msrar;zip.

Если параметр <список> не указан, ключ -ms будет использовать набор расширений по умолчанию:

7z, ace, arj, bz2, cab, gz, jpeg, jpg, lha, lz, lzh, mp3, rar, taz, tgz, xz, z, zip, zipx


Ключ -MT<потоки> - количество потоков

Ключ -MT<потоки> — количество потоков

Параметр <потоки> может принимать значения от 1 до 32. Он определяет рекомендуемое максимальное число активных потоков для алгоритма сжатия, а также для других модулей WinRAR, которые могут запускать несколько потоков. WinRAR пытается следовать этой рекомендации, но иногда реальное количество потоков может быть больше указанного значения.

Изменение параметра <потоки> оказывает небольшое воздействие на степень сжатия, поэтому архивы, созданные с разными ключами -mt, будет иметь слегка различающиеся размеры, даже если все остальные параметры упаковки были одинаковые.

Если ключ -mt не указан, WinRAR попытается определить число доступных процессоров и автоматически выберет оптимальное количество потоков.


Ключ -N<файл> - дополнительный фильтр файлов, включённых в обработку

Ключ -N<файл> — дополнительный фильтр файлов, включённых в обработку

Применить маску как дополнительный фильтр к списку файлов, включённых в обработку. В качестве имени или частей имени можно указывать шаблоны. Синтаксис шаблонов см. в описании ключа -x.
Ключ -n разрешается применять несколько раз в одной командной строке. Этот ключ не заменяет обычные маски файлов, вводимые в командной строке. Его назначение — в дополнительной фильтрации, чтобы ограничить обрабатываемые файлы теми, которые подходят под маску включения, заданную ключом -n. Иногда такой способ помогает сократить длину командной строки.

Например, если нужно упаковать в архив text.rar все файлы *.txt и *.lst в папках Project и Info, можно ввести следующую команду:

WinRAR a -r text Project\*.txt Project\*.lst Info\*.txt Info\*.lst

или воспользоваться ключом -n:

WinRAR a -r -n*.txt -n*.lst text Project Info


Ключ -N@<файл-список> - прочитать дополнительные маски фильтрации из файла-списка

Ключ -N@<файл-список> — прочитать дополнительные маски фильтрации из файла-списка

Аналогичен ключу -n<файл>, но с тем отличием, что маски фильтрации считываются из файла-списка.

Этот ключ не заменяет обычные списки файлов или маски файлов, которые по-прежнему должны вводиться в командной строке. Это дополнительный фильтр, ограничивающий обработку только теми файлами, которые подходят под маску включения, определённую в ключе -n.

Пример

WinRAR a -r -n@inclist.txt text Project Info @listfile.txt


Ключ -OC - устанавливать NTFS-атрибут "Сжатый"

Ключ -OC — устанавливать NTFS-атрибут "Сжатый"

Этот ключ позволяет восстанавливать у извлекаемых из архива файлов атрибут "Сжатый", применяемый в файловой системе NTFS. При создании архивов WinRAR всегда сохраняет у файлов состояние атрибута "Сжатый", но не восстанавливает его при извлечении, если только не указан ключ -oc. В режиме оболочки WinRAR эквивалентом этого ключа является параметр Установить атрибут "Сжатый" в окне извлечения на вкладке Дополнительно.

Ключ -oc применим только к архивам RAR.


Ключ -OH - сохранять жёсткие ссылки как ссылки, а не как файлы

Ключ -OH — сохранять жёсткие ссылки как ссылки, а не как файлы

Если среди архивируемых файлов содержится несколько жёстких ссылок NTFS, то при указании этого ключа первая жёсткая ссылка добавляется в архив как обычный файл, а остальные жёсткие ссылки из того же набора — как ссылки на этот первый файл. При извлечении таких файлов WinRAR будет создавать жёсткие ссылки, а не обычные файлы.

После создания архива нельзя удалять или переименовывать первую жёсткую ссылку в архиве, иначе станет невозможным извлечение последующих ссылок. Если вы измените первую ссылку, последующие ссылки при извлечении также будут иметь изменённое содержимое. Для успешного извлечения последующих ссылок команда извлечения должна быть вызвана сначала для первой жёсткой ссылки.

Поддерживается только в архивах RAR5.

Этот ключ — эквивалент в командной строке группы параметров Сохранять жёсткие ссылки как ссылки в окне Имя и параметры архива.


Ключ -OI[-][:<мин_размер>] - сохранять идентичные файлы как ссылки

Ключ -OI[-][:<мин_размер>] — сохранять идентичные файлы как ссылки

Если указан этот ключ, WinRAR перед архивированием анализирует содержимое файлов и если обнаруживает несколько идентичных файлов размером более 64 КБ, то первый файл из набора сохраняет как обычный файл, а все остальные — как ссылки на этот первый файл. Это позволяет уменьшить размер архива, но накладывает некоторые ограничения на результирующий архив. Первый файл из набора идентичных файлов в созданном архиве нельзя удалять или переименовывать, потому что это сделает невозможным извлечение остальных ссылающихся на него файлов. Если изменить содержимое первого файла, то при извлечении изменёнными будут и все остальные ссылающиеся на него файлы. Команда извлечения должна применяться сначала к первому файлу, чтобы были успешно созданы остальные файлы.

Ключ -oi рекомендуется применять только при сжатии большого количества идентичных файлов и если архив в дальнейшем не предполагается изменять, а распаковывать его вы будете полностью, без необходимости извлекать или пропускать отдельные файлы. Если все идентичные файлы достаточно малы, чтобы уместиться в словаре сжатия, указываемом с помощью ключа -md<n>, то более гибкое решение, нежели ключ -oi, даёт ключ -s.

Необязательное значение <мин_размер> позволяет указывать порог минимального размера файлов. Файлы размером меньше заданного значения не анализируются и не считаются идентичными. Если данный параметр отсутствует, подразумевается принимаемое по умолчанию значение 64 КБ. Выбор слишком маленького значения <мин_размер> может привести к увеличению времени определения идентичных файлов.

Поддерживается только для архивов RAR5.

Ключ -oi- служит для запрета обработки идентичных файлов, включённой в конфигурации WinRAR.

Этот ключ — эквивалент в командной строке параметра Сохранять идентичные файлы как ссылки в окне Имя и параметры архива.

Пример

Сохранить содержимое текущей папки в архиве archive.rar, добавляя идентичные файлы размером равным или больше 1 000 000 байт как ссылки:

WinRAR a -oi:1000000 -ma archive


Ключ -OL[A] - обрабатывать символические ссылки как ссылки [с абсолютными путями]

Ключ -OL[A] — обрабатывать символические ссылки как ссылки [с абсолютными путями]

Хранить символические ссылки и точки соединения NTFS как ссылки, без архивирования содержимого файлов или папок. При извлечении из архива такие элементы восстанавливаются как символические ссылки или как точки соединения.

Поддерживается только в архивах RAR5.

Чтобы можно было создавать символические ссылки при извлечении, нужно запускать WinRAR от имени администратора.

Если ключ -ol указан при архивировании, WinRAR добавляет все ссылки вне зависимости от их целевых объектов. При извлечении WinRAR по умолчанию пропускает символические ссылки, указывающие на папку вне папки назначения, с абсолютными путями, чрезмерным количеством элементов ".." в целевом объекте ссылки, либо с другими потенциально опасными параметрами. Чтобы извлечь такие ссылки, укажите ключ -ola.

Ссылки, указывающие на папки вне папки назначения, могут представлять угрозу безопасности. Разрешайте их извлечение, только если уверены в безопасности содержимого архива, например при распаковке ваших собственных резервных копий.

Ссылки, которые WinRAR считает безопасными, извлекаются всегда — вне зависимости от того, указан ли ключ -ol или -ola.

Ключ -ol — эквивалент в командной строке параметра Сохранять символические ссылки как ссылки в окне Имя и параметры архива.

Ключ -ola — эквивален параметра Разрешить абсолютные пути в символических ссылках в окне извлечения.


Ключ -ONI - разрешить потенциально несовместимые имена

Ключ -ONI — разрешить потенциально несовместимые имена

Файловая система NTFS позволяет давать файлам имена с пробелами и точками в конце, однако множество Windows-программ не умеют корректно обращаться с такими именами. Если этот ключ не указан, то WinRAR при извлечении удаляет обнаруженные пробелы и точки в конце имён файлов. Указывайте ключ -oni, только если требуется извлекать потенциально несовместимые имена такими, какие они есть.

Ключ -oni — эквивалент в командной строке параметра Разрешить потенциально несовместимые имена в окне извлечения.


Ключ -OR - переименовывать файлы автоматически

Ключ -OR — переименовывать файлы автоматически

Автоматически переименовывать извлекаемые файлы, если файл с таким же именем уже существует. Переименованный файл получает имя вида 'filename(N).txt', где 'filename.txt' – исходное имя файла, а 'N' – номер, начинающийся с 1, и увеличивающийся, если файл существует.


Ключ -OS - сохранять потоки NTFS

Ключ -OS — сохранять потоки NTFS

Этот ключ предназначен только для файловой системы NTFS. Он позволяет сохранять в архиве альтернативные потоки данных, связанные с файлами, расположенными на диске с файловой системой NTFS. Может понадобиться, если вы пользуетесь какими-либо программами, хранящими данные в альтернативных потоках, и вам нужно сохранить эти потоки.

Для файлов с NTFS-атрибутом "Зашифрованный" потоки не сохраняются.

Эквивалент этого ключа в режиме оболочки — параметр Сохранять файловые потоки в окне Имя и параметры архива.

Этот ключ применим только к архивам RAR.


Ключ -OW - сохранять/восстанавливать информацию о правах доступа к файлам

Ключ -OW — сохранять/восстанавливать информацию о правах доступа к файлам

При добавлении файлов в архив этот ключ сохраняет информацию о правах доступа, а при извлечении восстанавливает её.

WinRAR сохраняет/восстанавливает информацию о владельце, группе, правах доступа и информацию аудита, но только если у вас для этого достаточно привилегий. Обратите внимание, что файловую безопасность поддерживает только NTFS.

Эквивалент этого ключа в режиме оболочки — параметр Сохранять данные о правах доступа в окне Имя и параметры архива.

Этот ключ применим только к архивам RAR.


Ключ -O[+|-] - режим перезаписи

Ключ -O[+|-] — режим перезаписи

Этот ключ можно использовать как при извлечении, так и при обновлении файлов в архиве.

Доступные режимы:

-o | Выдавать запрос перед перезаписью (действие по умолчанию при извлечении файлов)
-o+ | Перезаписывать все (действие по умолчанию при обновлении файлов в архиве)
-o- | Пропускать существующие файлы


Ключ -P<пароль> - указать пароль шифрования архива

Ключ -P<пароль> — указать пароль шифрования архива

С помощью этого ключа можно установить <пароль> для шифрования файлов при архивации или для их расшифровки при извлечении. Регистр символов в пароле различается. Максимальная длина пароля — 127 символов. Если указан более длинный пароль, то он усекается до этой длины. Из соображений безопасности можно не указывать пароль в командной строке — в этом случае программа предложит его вам ввести.

В режиме оболочки пароль можно ввести с помощью окна Ввод пароля по умолчанию или в окне Имя и параметры архива.

Пример

Добавить содержимое папки games в архив secret, используя пароль ZaBaToAd:

WinRAR a -pZaBaToAd -r secret games\*.*

Примечания

  1. Чтобы защита была достаточно надёжной, пароль должен быть не короче 8 символов. Не следует применять легко угадываемые пароли.
  2. Храните пароли в надёжном месте. Если вы забудете или потеряете пароль, то не сможете получить доступ к своим данным!


Ключ -QO[-|+] - добавить информацию для быстрого открытия архива [нет|принудительно]

Ключ -QO[-|+] — добавить информацию для быстрого открытия архива [нет|принудительно]

В архивах RAR непосредственно перед данными каждого файла находится его заголовок, содержащий такие сведения, как имя файла, время, размер и атрибуты. Такая реализация более устойчива к повреждениям, нежели хранение заголовков всех файлов в одном непрерывном блоке, разрушение или усечение которого способно повлечь уничтожение всего содержимого архива. Однако есть и недостаток: поскольку файловые заголовки рассредоточены по всему архиву, доступ к ним не столь быстрый, как при хранении заголовков в одном блоке, что может быть заметно, когда нужно быстро открыть содержание архива в таких графических оболочках, как, например, WinRAR.

Чтобы повысить скорость открытия архивов и вместе с тем не делать весь архив зависящим от повреждения одиночного блока, архивы RAR5 могут содержать факультативную запись для быстрого открытия. Такая запись добавляется в конец архива и содержит копии имён файлов и другую информацию о находящихся в архиве файлах в одном непрерывном блоке в дополнение к обычным файловым заголовкам внутри архива. Поскольку блок непрерывный, его содержимое считывается быстро, без необходимости выполнять множество операций чтения с диска. Каждый файловый заголовок в таком блоке защищён контрольной суммой. Если WinRAR обнаруживает, что информация для быстрого открытия повреждена, он переходит к чтению индивидуальных заголовков внутри архива, поэтому устойчивость к повреждениям не снижается.

Информация для быстрого открытия содержит полную копию файлового заголовка, которая может занимать несколько десятков или сотен байт на файл, и на этот же объём увеличивается размер архива. Такое увеличение размера наиболее заметно, если архив содержит большое количество маленьких файлов, когда размер файловых данных сопоставим с размером файловых заголовков. Поэтому по умолчанию, если не указан ключ -qo или у него нет параметра, WinRAR сохраняет копии заголовков только для относительно больших файлов и продолжает использовать локальные заголовки для маленьких. Конкретный порог размера файлов зависит от версии WinRAR. Такой подход обеспечивает разумный компромисс между скоростью открытия и размером архива. Если предпочтительнее скорость открытия архива и неважен его размер, укажите ключ -qo+ для сохранения копий заголовков всех файлов. Если же нужно получить архив наименьшего размера, а скорость открытия его в других программах неважна, укажите ключ -qo-, чтобы полностью исключить информацию для быстрого открытия.

Если вы хотите оценить влияние этого ключа на производительность, удостоверьтесь, что содержимое архива не находится в дисковом кэше. Когда архивный файл в кэше, реальные операции поиска на диске не выполняются, так что доступ к файловым заголовкам будет быстрым даже без информации для быстрого открытия.

Этот ключ — эквивалент в командной строке группы параметров Информация для быстрого открытия в окне Имя и параметры архива.


Ключ -R - включить в обработку вложенные папки

Ключ -R — включить в обработку вложенные папки

Включает рекурсию вложенных папок (т.е. обработку текущей папки и всех её вложенных папок). Можно использовать вместе с командами: A, U, F, M, X, E, T, K, RR, C и S.

При использовании с командами A, U, F или M будут обработаны файлы не только в рабочей, но и во всех вложенных папках.

При использовании с командами X, E, T, K, RR, C или S будут обработаны архивы не только в рабочей, но и во всех вложенных папках.

Примеры

1. Добавить содержимое диска C: в архив Backup:

WinRAR a -r Backup c:\*.*

2. Протестировать все архивы *.rar на текущем диске:

WinRAR t -r \*.rar


Ключ -R- - запретить обработку вложенных папок

Ключ -R- — запретить обработку вложенных папок

Запретить обработку вложенных папок (рекурсию).

Даже если не указан ключ -r, в некоторых ситуациях WinRAR всё равно автоматически использует рекурсию. Ключ -r- позволяет её полностью запретить.

Если при архивировании указать имя папки, и в этом имени нет символов подстановки (шаблонов), в архив по умолчанию добавляется содержимое этой папки, даже если не указан ключ -r. Кроме того, рекурсия автоматически включается, когда в качестве файловой маски указан корневой каталог диска без символов подстановки. Ключ -r- запрещает такое поведение.

Примеры

Добавить в архив только пустую папку dirname, проигнорировав её содержимое:

WinRAR a -r- arc dirname

Упаковать только содержимое корневой папки диска C:, но не обрабатывать имеющиеся в ней вложенные папки:

WinRAR a -r- arc c:\


Ключ -R0 - обрабатывать вложенные папки в соответствии с шаблоном

Ключ -R0 — обрабатывать вложенные папки в соответствии с шаблоном

Аналогично ключу -r, но при использовании с командами A, U, F и M файлы из вложенных папок будут добавляться только в случае, если при указании масок файлов были использованы символы подстановки "*" и "?".

Этот ключ работает только для имён файлов. На имена папок без части с именем файла (например 'foldername') ключ -r0 не влияет, их содержимое добавляется в архив полностью, если только не был указан ключ -r-.

Пример

Добавить все файлы *.doc из текущей папки и её вложенных папок, а также файл readme.txt только из текущей папки в архив docs.rar (если использовать обычный ключ -r, то WinRAR искал бы readme.txt и во вложенных папках):

WinRAR a -r0 docs.rar *.doc readme.txt


Ключ -RI<p>[:<s>] - приоритет процесса и время простоя

Ключ -RI<p>[:<s>] — приоритет процесса и время простоя

Этот ключ регулирует загрузку системы задачей WinRAR. Возможные приоритеты задачи, определяемые параметром <p> — от 0 до 15.

Если <p> — 0, то используется приоритет по умолчанию, 1 — минимальный приоритет, 15 — максимальный.

Время простоя <s> указывается в миллисекундах и может принимать значения от 0 до 1000. Это время, которое WinRAR будет отдавать системе после операций чтения или записи при архивации или извлечении файлов. Указывать время простоя, отличное от нуля, имеет смысл для большего уменьшения загрузки системы, чем этого можно добиться одним лишь параметром <p>.

Пример

Запустить WinRAR с приоритетом по умолчанию и 10-миллисекундным временем простоя:

WinRAR a -ri0:10 backup *.*


Ключ -rr[N] - добавить данные для восстановления

Ключ -RR[n] — добавить данные для восстановления

Этот ключ используется только при создании или изменении архива RAR, чтобы добавить к нему данные для восстановления. При использовании формата RAR4 параметр "n" может обозначать либо количество секторов для восстановления (n=1…524288), либо процент от размера архива, если после числа указан знак процента ( % ) или латинская буква "p". Для архивов RAR5 параметр "n" всегда означает процент от размера архива вне зависимости от наличия модификаторов "p" или "%".

Синтаксис этого ключа такой же, как у команды RR[n]. См. подробности в описаниях команды RR[n] и данных для восстановления.

Эквивалент этого ключа в режиме оболочки — параметр Добавить данные для восстановления в окне Имя и параметры архива.

Пример

Добавить все файлы *.txt из текущей папки в архив Books и добавить данные для восстановления размером 3% от общего объёма архива:

WinRAR a -rr3p Books *.txt


Ключ -RV[N] - создать тома для восстановления

Ключ -RV[n] — создать тома для восстановления

Этот ключ используется при создании многотомного архива RAR для генерирования томов для восстановления. По синтаксису ключ аналогичен команде RV.


Ключ -S - создать непрерывный архив

Ключ -S — создать непрерывный архив

Непрерывный (solid) — это особый вид архива. При непрерывной архивации существенно улучшается степень сжатия, но обновление таких архивов происходит медленнее, чем обычных. Указывать ключ -s имеет смысл только при создании новых архивов RAR.

Эквивалент этого ключа в режиме оболочки — параметр Создать непрерывный архив в окне Имя и параметры архива.

Пример

Добавить все файлы *.c и *.h из текущей папки в непрерывный архив Sources:

WinRAR a -s Sources *.c *.h

Более подробную информацию см. в разделе Непрерывные архивы.


Ключ -S<N> - создать непрерывные группы, используя счётчик файлов

Ключ -S<n> — создать непрерывные группы, используя счётчик файлов

Аналогично ключу -s, но после сжатия <n> файлов происходит сброс статистики для непрерывного архива. Степень сжатия при этом обычно ухудшается, но вместе с тем уменьшается риск потери данных в случае повреждения непрерывного архива.


Ключ -SC<кодировка>[объекты] - указать кодировку символов (и объекты)

Ключ -SC<кодировка>[объекты] — указать кодировку символов (и объекты)

С помощью этого ключа можно указать кодировку (набор символов) для файлов-списков, журналов и файлов с комментариями архивов.

Параметр кодировка обязателен и может принимать одно из следующих значений:

U | Юникод UTF-16
F | Юникод UTF-8
A | "Родная" однобайтовая кодировка, для Windows это ANSI
O | Кодировка OEM (DOS)

Порядок байтов в файлах с кодировкой UTF-16 (таких, как файлы-списки или комментарии) определяется по метке порядка байтов. Если такой метки нет, то подразумевается порядок little endian.

Параметр объекты необязательный. Он может принимать одно из следующих значений:

G | Журналы, создаваемые ключом -ilog
L | Файлы-списки
C | Файлы с комментариями

Разрешается указывать более одного объекта, например -scolc. Если параметр объекты не указан, кодировка будет применена ко всем объектам.

Этот ключ позволяет определять кодировку для файлов в ключе -z<файл>, файлов-списков и файлов с комментариями, записываемых командой cw.

Примеры

  1. Прочитать имена, содержащиеся в файле list, используя OEM-кодировку:

WinRAR a -scol data @list

  2. Прочитать comment.txt как файл в кодировке Юникод:

WinRAR c -scuc -zcomment.txt data

  3. Записать comment.txt как файл в кодировке Юникод:

WinRAR cw -scuc data comment.txt


Ключ -SE - создать непрерывные группы, используя расширения файлов

Ключ -SE — создать непрерывные группы, используя расширения файлов

Аналогично ключу -s, но статистика для непрерывного архива сбрасывается при смене расширения файла. Степень сжатия обычно ухудшается, но снижается риск потери данных в случае повреждения непрерывного архива.


Ключ -SL<размер> - обрабатывать файлы размером меньше указанного

Ключ -SL<размер> — обрабатывать файлы размером меньше указанного

Включать в обработку только те файлы, размер которых меньше, чем указанный в параметре <размер> этого ключа. Параметр <размер> должен указываться в байтах.


Ключ -SM<размер> - обрабатывать файлы размером больше указанного

Ключ -SM<размер> — обрабатывать файлы размером больше указанного

Включать в обработку только те файлы, размер которых больше, чем указанный в параметре <размер> этого ключа. Параметр <размер> должен указываться в байтах.


Ключ -SV - создать независимые непрерывные тома

Ключ -SV — создать независимые непрерывные тома

По умолчанию WinRAR пытается сбросить статистику непрерывности как можно раньше после начала нового тома, но только если после предыдущего сброса было запаковано достаточно данных (хотя бы несколько мегабайт).

Данный ключ указывает WinRAR, что необходимо сбрасывать статистику для любого тома независимо от размера запакованных данных. Степень сжатия при этом уменьшается, но вместе с тем увеличивается вероятность успешного извлечения части данных, если один из томов с непрерывным архивированием будет утерян или повреждён.

Обратите внимание, что в некоторых случаях на сброс статистики не действует даже этот ключ. Например, невозможно сбросить статистику при сжатии одного большого файла, разделяемого по нескольким томам. WinRAR способен сбрасывать статистику непрерывности только между разными файлами, но не внутри одного файла.

Ключ игнорируется, если он указывается при создании обычных архивов (не многотомных).

Чтобы использовать этот ключ в оболочке WinRAR, его можно задать в переменной окружения RAR.


Ключ -SV- - создать зависимые непрерывные тома

Ключ -SV- — создать зависимые непрерывные тома

Данный ключ запрещает сброс статистики непрерывности между томами. Степень сжатия при этом незначительно улучшается, но вместе с тем существенно уменьшаются шансы на восстановление хотя бы части данных при повреждении или потере одного из томов непрерывного архива.

Ключ игнорируется, если он указывается при создании обычных архивов (не многотомных).

Этот ключ можно задать в переменной окружения RAR для использования в оболочке WinRAR.

См. также: ключ -SV — создать независимые непрерывные тома


Ключ -S- - запретить создание непрерывных архивов

Ключ -S- — запретить создание непрерывных архивов

Запрещает использование непрерывного архивирования, даже если оно включено в профиле архивации по умолчанию.


Ключ -SFX[имя] - создать самораспаковывающийся архив

Ключ -SFX[имя] — создать самораспаковывающийся архив

Если этот ключ указан при создании нового архива, то будет создан самораспаковывающийся (SFX) архив. По умолчанию WinRAR использует SFX-модуль Default.SFX для архивов RAR, и Zip.SFX — для ZIP. Эти модули должны находиться в той же папке, что и файл WinRAR.exe. После ключа -sfx можно указать альтернативный SFX-модуль.

Эквивалент этого ключа в режиме оболочки — параметр Создать SFX-архив в окне Имя и параметры архива.

Примеры

1. Создать самораспаковывающийся многотомный непрерывный архив:

WinRAR a -sfx -v360 -s Games

2. Создать самораспаковывающийся архив с модулем WinCon.SFX:

WinRAR a -sfxWinCon.SFX Gift.rar

См. также: команда S[имя].


Ключ -T - протестировать файлы после архивации

Ключ -T — протестировать файлы после архивации

Проверка файлов после помещения их в архив. Этот ключ особенно полезен в сочетании с командой перемещения файлов в архив, поскольку файлы будут удалены с диска только в том случае, если их копии в архиве успешно прошли тестирование.


Ключ -TA[m,c,a,o]<дата> - обрабатывать файлы, изменённые, созданные или к которым был доступ после указанной даты

Ключ -TA[m,c,a,o]<дата> — обрабатывать файлы, изменённые, созданные или к которым был доступ после указанной даты

При указании этого ключа будут обрабатываться только файлы, изменённые после указанной даты. Файлы, точно соответствующие указанной дате, также включаются в обработку.

Дата указывается в следующем формате: ГГГГММДДЧЧММСС. В поле даты допускается вставлять символы-разделители ('-' или ': ') и не указывать оставшиеся поля. Например, следующий ключ будет правильным: -ta2001-11-20

Если говорить точнее, при внутренней обработке RAR будет трактовать вышеуказанный ключ как -ta20011120000000, что означает: "файлы, изменённые после 0 часа 0 минут 0 секунд 20 ноября 2001 года" (т.е. сама эта дата в заданный диапазон времени не входит).

Используйте модификаторы 'm', 'c', 'a' для указания времени изменения, создания и последнего доступа. Например, ключ -tac20011120 задаёт время создания. Если модификатора нет, то подразумевается время изменения.

В одном и том же ключе допускается указывать несколько модификаторов, например -tamc20190215, чтобы задать ту же дату для всех указанных времён. Также можно указывать в командной строке несколько фильтрующих время ключей. По умолчанию фильтры времени используют логику AND (И), то есть чтобы быть включённым в обработку, файл должен удовлетворять всем таким фильтрам. С помощью модификатора 'o' эту логику можно изменить на OR (ИЛИ), то есть файл должен удовлетворять хотя бы одному фильтру 'o'. Например, чтобы включить в обработку файлы, созданные после 1 января 2019 года, или изменённые после 10 февраля 2019 года, укажите ключи -taco20190201 -tamo20190210.


Ключ -TB[m,c,a]<дата> - обрабатывать файлы, изменённые, созданные или к которым был доступ до указанной даты

Ключ -TB[m,c,a]<дата> — обрабатывать файлы, изменённые, созданные или к которым был доступ до указанной даты

При указании этого ключа будут обрабатываться только файлы, модифицированные до указанной даты. Файлы, точно соответствующие указанной дате, не включаются в обработку.

Дата указывается в следующем формате: ГГГГММДДЧЧММСС. В поле даты допускается вставлять символы-разделители ('-' или ':') и не указывать оставшиеся поля. Например, следующий ключ будет правильным: -tb2001-11-20

Если говорить точнее, при внутренней обработке RAR будет трактовать вышеуказанный ключ как -tb20011120000000, что означает: "файлы, изменённые до 0 часа 0 минут 0 секунд 20 ноября 2001 года" (т.е. сама эта дата в заданный диапазон времени не входит).

Используйте модификаторы 'm', 'c', 'a' для указания времени изменения, создания и последнего доступа. Например, ключ -tbc20011120 задаёт время создания. Если модификатора нет, то подразумевается время изменения.

В одном и том же ключе допускается указывать несколько модификаторов, например -tbmc20190215, чтобы задать ту же дату для всех указанных времён. Также можно указывать в командной строке несколько фильтрующих время ключей. По умолчанию фильтры времени используют логику AND (И), то есть чтобы быть включённым в обработку, файл должен удовлетворять всем таким фильтрам. С помощью модификатора 'o' эту логику можно изменить на OR (ИЛИ), то есть файл должен удовлетворять хотя бы одному фильтру 'o'. Например, чтобы включить в обработку файлы, созданные после 1 января 2019 года, или изменённые после 10 февраля 2019 года, укажите ключи -tbco20190201 -tbmo20190210.


Ключ -TK - сохранять исходное время архива

Ключ -TK — сохранять исходное время архива

При обновлении архива будет сохраняться время его последней модификации.


Ключ -TL - устанавливать время архива по времени новейшего файла

Ключ -TL — устанавливать время архива по времени новейшего файла

При изменении архива у него будет установлено такое же время модификации, как у самого нового файла в архиве.


Ключ -TN[m,c,a,o]<время> - обрабатывать файлы не старее указанного периода времени

Ключ -TN[m,c,a,o]<время> — обрабатывать файлы не старее указанного периода времени

Используйте этот ключ, если нужно обработать только те файлы, дата изменения которых попадает в указанный период времени. Файлы, точно соответствующие указанному периоду, также включаются в обработку.

Время указывается в следующем формате:

[<дни>d] [<часы>h] [ <минуты>m] [<секунды>s]

Например, для обработки файлов, изменённых менее 15 дней назад, используйте ключ -tn15d, а для обработки файлов, изменённых менее чем 2 часа 15 минут назад, используйте -tn2h15m.

Используйте модификаторы 'm', 'c', 'a' для указания времени изменения, создания и последнего доступа. Например, ключ -tnc2h30m задаёт время создания. Если модификатора нет, то подразумевается время изменения.

В одном ключе допускается использовать несколько модификаторов, например -tamc30d, чтобы задать тот же период для всех указанных времён. Также можно указывать в командной строке несколько фильтрующих время ключей. По умолчанию фильтры времени используют логику AND (И), то есть чтобы быть включённым в обработку, файл должен удовлетворять всем таким фильтрам. С помощью модификатора 'o' эту логику можно изменить на OR (ИЛИ), то есть файл должен удовлетворять хотя бы одному фильтру 'o'. Например, чтобы включить в обработку файлы с временем создания новее 30 дней или временем изменения новее 20 дней, укажите ключи -tnco30d -tnmo20d.


Ключ -TO[m,c,a,o]<время> - обрабатывать файлы старее указанного периода времени

Ключ -TO[m,c,a,o]<время> — обрабатывать файлы старее указанного периода времени

Используйте этот ключ, если нужно обработать только те файлы, дата изменения которых не попадает в указанный период времени, т.е. они были созданы/изменены раньше, чем определяет параметр <время>. Файлы, точно соответствующие указанному периоду, не включаются в обработку.

Время указывается в следующем формате:

[<дни>d] [<часы>h] [ <минуты>m] [<секунды>s]

Например, для обработки файлов, изменённых более 15 дней назад, используйте ключ -to15d, а для обработки файлов, изменённых более чем 2,5 часа назад, используйте -to2h30m.

Используйте модификаторы 'm', 'c', 'a' для указания времени изменения, создания и последнего доступа. Например, ключ -toc2h30m задаёт время создания. Если модификатора нет, то подразумевается время изменения.

В одном ключе допускается использовать несколько модификаторов, например -tomc30d, чтобы задать тот же период для всех указанных времён. Также можно указывать в командной строке несколько фильтрующих время ключей. По умолчанию фильтры времени используют логику AND (И), то есть чтобы быть включённым в обработку, файл должен удовлетворять всем таким фильтрам. С помощью модификатора 'o' эту логику можно изменить на OR (ИЛИ), то есть файл должен удовлетворять хотя бы одному фильтру 'o'. Например, чтобы включить в обработку файлы с временем создания новее 30 дней или временем изменения новее 20 дней, укажите ключи -toco30d -tomo20d.


Ключ -TS[m,c,a][+,-,1] - сохранять или восстанавливать время файлов (изменения, создания, доступа)

Ключ -TS[m,c,a][+,-,1] — сохранять или восстанавливать время файлов (изменения, создания, доступа)

Ключ -tsm сохраняет время изменения файла, -tsc — время создания, -tsa — время последнего доступа. В одной командной строке можно указывать сразу несколько ключей -ts, например -tsc -tsa. Если нет модификаторов m, c или a, то подразумеваются все три поля.

Добавьте в конце ключа "+", чтобы сохранить время с максимально возможной точностью. Конкретное значение зависит от операционной и файловой систем, оно может быть равным 100 наносекундам в Windows и 1 наносекунде в UNIX. Добавьте в конец ключа "1", чтобы установить 1-секундную точность. Добавьте "-", чтобы не сохранять время файлов. Если нет модификаторов "+", "-" или "1", то подразумевается "+", т.е. оба ключа — -ts+ и -ts — сохраняют все три времени с высокой точностью.

Архивы RAR4 всегда содержат время изменения, и для них ключ -tsm- по-прежнему сохраняет время изменения с наименьшей 2-секундной точностью. Два других времени могут быть отключены. В архивах RAR5 можно исключать любое время файлов, в том числе время изменения, так что распаковываемые файлы будут иметь текущее системное время. Ключи -tsm- -tsc- -tsa- или просто -ts- сохраняют время изменения с наименьшей точностью для архивов RAR4 и не сохраняют никакое время файлов для RAR5.

Если ключ -ts не указан, WinRAR сохраняет с высокой точностью время изменения и опускает два других времени.

При извлечении WinRAR по умолчанию устанавливает у файлов только время изменения, даже если в архиве сохранены и другие времена. Укажите ключ -ts или -ts+ при распаковке, чтобы восстановить все три времени. Ключи -tsc и -tsa восстанавливают времена создания и последнего доступа, а ключ -tsm- или -ts- устанавливает у файлов время изменения, равное текущему системному времени, а не сохранённому в архиве.

Windows позволяет устанавливать у извлекаемых из архива файлов все три времени. В UNIX можно устанавливать только время изменения и последнего доступа, но не время создания.

Все описанные выше режимы поддерживаются только для формата RAR. В архивах ZIP высокоточное время модификации хранится в той же структуре данных, что и времена создания и последнего доступа. При архивировании в ZIP все три времени контролируются ключами -ts или -tsm, а ключи -tsa и -tsc игнорируются. Чтобы сохранить все времена в высокоточном формате (режим ZIP по умолчанию), указывайте ключ -ts или -tsm. Чтобы сохранить только время модификации с низкой точностью, указывайте ключ -ts- или -tsm-. При распаковке архива ZIP ключи -tsm -tsc -tsa можно использовать индивидуально, чтобы управлять соответствующими временами так же, как в формате RAR.

Примеры

1. Сохранить все времена файлов с максимально высокой точностью:

WinRAR a -ts backup

2. Восстановить у файлов времена модификации и последнего доступа. Ключ -tsm можно не указывать, так как WinRAR по умолчанию устанавливает время изменения. Если нужно восстановить только время последнего доступа, то следует указать ключи -tsm- -tsa:

WinRAR x -tsa backup

3. Сохранить времена модификации и создания с низкой точностью:

WinRAR a -tsm1 -tsc1 backup


Ключ -U - обновить файлы

Ключ -U — обновить файлы

Этот ключ можно использовать как при добавлении файлов в архив, так и при извлечении из него. Командная строка a -u эквивалентна команде u. Ключ -u также можно использовать с командой m.

Если ключ -u применяется вместе с командами x или e, то из архива извлекаются файлы, которых нет на диске или копии которых на диске старее, чем в архиве. Отличие от ключа -f в том, что если для файла в архиве нет соответствующего файла на диске, то этот файл также будет извлечён.

Эквиваленты этого ключа в режиме оболочки — пункт Добавить с обновлением файлов в окне Имя и параметры архива и параметр Извлечь с обновлением файлов в окне Путь и параметры извлечения.

Поддерживается только для форматов RAR и ZIP.


Ключ -V<n>[k|b|f|m|M|g|G] - создать тома

Ключ -V<n>[k|b|f|m|M|g|G] — создать многотомный архив

Ключ -v создаёт многотомный архив с томами размером=<n>×1000.

По умолчанию параметр <n> считается в тысячах байт (т.е. число умножается на 1000, а не на 1024). Размер томов также можно указывать в килобайтах, байтах, мегабайтах и миллионах байт. Для этого нужно после числового значения поставить один из следующих буквенных модификаторов (все буквы латинские):

k | килобайты (множитель 1024)
b | байты (множитель 1)
m | мегабайты (1 МБ=1 048 576 байтам)
M | миллионы байт (множитель 1 000 000)
g | гигабайты (1 ГБ=1 073 741 824 байтам)
G | миллиарды байт (множитель 1 000 000 000)

Кроме того, можно ввести одно из предопределённых значений — 360, 720, 1200, 1440 или 2880 — добавив после него букву f, и тогда оно будет заменено точным размером соответствующей дискеты. Если размер тома не указан, то он определяется автоматически в зависимости от объёма свободного места на носителе.

Разрешается вводить десятичные дроби, разделяя целую и дробную части числа точкой. Например, ключ -v1.5g соответствует размеру 1,5 гигабайта.

Допускается указывать несколько ключей -v, чтобы задать разные размеры для разных томов. Например, следующая команда устанавливает для первого тома размер 100 КБ, для второго — 200 КБ, а для всех последующих томов — 300 КБ:

RAR a -v100k -v200k -v300k arcname

Если тома создаются на сменном носителе, то после создания первого тома будет выдан запрос:

Создать следующий том? Да/Нет/Создать все

В этот момент вы должны сменить диск и ответить "Да". При ответе "Создать все" все последующие тома будут созданы без промежуточных пауз.

По умолчанию тома RAR получают имена вида volname.partNNN.rar, где NNN — номер тома. При использовании формата RAR4 с помощью ключа -vn можно активизировать старую схему именования томов, основанную на изменении расширений файлов, при которой первый том получает расширение .rar, а последующие тома нумеруются от .r00 до .r99. В архивах RAR5 ключ -vn и именование на основе расширений файлов не поддерживаются.

При распаковке или тестировании многотомного архива нужно указывать только имя первого тома. Если следующего тома нет на диске, то будет выдан запрос:

Вставьте диск с <имя следующего тома>. OK/Отмена

Вставьте диск с указанным томом и нажмите OK.

Архивные тома нельзя изменять. К многотомным архивам неприменимы команды D, F, U и S. Команду A можно использовать только для создания новых многотомных архивов.

Возможна (хотя и маловероятна) ситуация, при которой размер файла в многотомном архиве окажется больше, чем размер неупакованного файла. Причина в том, что при создании многотомных архивов не поддерживается метод упаковки "Без сжатия" (т.е. добавление файла в архив в его исходном виде, если после сжатия размер файла увеличился).

Архивные тома могут быть непрерывными и/или самораспаковывающимися.

Эквивалент этого ключа в режиме оболочки — параметр Размер тома в окне Имя и параметры архива.

Пример

Создать самораспаковывающийся непрерывный многотомный архив с томами размером 1 200 000 байт:

WinRAR a -v1200 -s -sfx bitmaps


Ключ -VD - удалять содержимое сменного носителя перед созданием тома

Ключ -VD — удалять содержимое сменного носителя перед созданием тома

Если указать этот ключ, то перед созданием архива с целевого носителя будут удалены все файлы и папки. При создании многотомного архива очистка выполняется перед созданием каждого тома, что позволяет архивировать данные на непустые сменные носители. При использовании этого ключа убедитесь, что носители не содержат нужной вам информации.

Ключ -vd применим только к сменным носителям, содержимое жёсткого диска им не удаляется.


Ключ -VER[n] - управление версиями файлов

Ключ -VER[n] — управление версиями файлов

Если указан этот ключ, то при обновлении файлов в уже существующем архиве их предыдущие версии остаются в архиве, получая имена вида filename;n, где n — номер версии.

Применимо только к архивам RAR.

Если при распаковке архива, содержащего предыдущие версии файлов, не указан ключ -ver, то по умолчанию извлекаются лишь последние версии, имена которых не содержат цифрового суффикса. Однако если указать точное имя файла, включая версию, он также будет извлечён. Например, команда "rar x arcname" распакует только последние версии файлов, тогда как команда "rar x arcname file.txt;5" извлечёт файл "file.txt;5", если он имеется в данном архиве.

Если указать ключ -ver без параметра при распаковке, то будут извлечены все версии всех файлов в соответствии с введённой маской файлов. В этом случае номера версий из имён распакованных файлов не удаляются. Вы также можете извлечь файл конкретной версии, указав её номер в качестве параметра ключа -ver. Такой ключ сообщит архиватору, что нужно распаковать только файлы этой версии и удалить номер версии из имён. Например, команда "rar x -ver5 arcname" извлечёт из архива только пятые версии файлов.

Если указать ключ -ver с параметром "n" при архивировании, то он будет ограничивать количество хранящихся в архиве версий файлов. Старые версии файлов, превосходящие указанный предел, удаляются из архива.

При архивировании с ключом -ver рекомендуется избегать имён вида 'filename;n' среди добавляемых файлов. Такие имена могут привести в образованию дублирующихся элементов, если старая версия с тем же именем либо существует в архиве, либо будет создана позже.


Ключ -VN - старая схема именования томов

Ключ -VN — старая схема именования томов

По умолчанию тома многотомных архивов RAR получают имена вида "volname.partNNN.rar", где NNN — номер тома. Для архивного формата RAR4 с помощью ключа -vn можно включить старую схему именования томов, при которой изменяются расширения файлов: первый том получает расширение .rar, а последующие тома нумеруются от .r00 до .r99.

В архивах RAR5 ключ -vn и именование на основе расширений файлов не поддерживаются.


Ключ -VP - пауза перед каждым томом

Ключ -VP — пауза перед каждым томом

По умолчанию WinRAR запрашивает подтверждение перед обработкой следующего тома только при архивировании на сменном носителе и только если объём свободного места на диске меньше, чем размер тома. При указании этого ключа WinRAR будет запрашивать такое подтверждение всегда при создании или распаковке томов. Например, это может быть полезно в случае, если вы хотите каждый созданный том сразу копировать на другой носитель.


Ключ -W<путь> - задать папку для временных файлов

Ключ -W<путь> — задать папку для временных файлов

При выполнении некоторых операций (например при изменении архива) WinRAR создаёт временные файлы и папки. По умолчанию они создаются в папке, указанной в поле Папка для временных файлов на вкладке Пути в окне настроек программы. В режиме командной строки этот параметр можно переопределить ключом -w<путь>.

Пример

Использовать для временных файлов папку d:\tmp при добавлении нового комментария в архив info.rar:

WinRAR c -wd:\tmp -zcomment.txt info.rar


Ключ -X<файл> - не обрабатывать указанный файл или папку

Ключ -X<файл> — не обрабатывать указанный файл или папку

Этот ключ позволяет указать файл или папку для исключения из обработки. В имени и пути файла можно использовать шаблоны. Этот ключ разрешается указывать в командной строке несколько раз, чтобы определить несколько масок исключения.

Если маска содержит шаблоны (символы подстановки), её действие распространяется на текущую и вложенные в неё папки. Без указания шаблонов действие ключа не рекурсивно, поэтому маска имя_файла исключит из обработки файл имя_файла только в текущей папке при архивировании или в корневой папке архива при извлечении.

Используйте синтаксис *\имя_файла для рекурсивного исключения имя_файла во всех папках.

Если известен точный путь к файлу, то для исключения из обработки только этой копии имя_файла используйте синтаксис путь\имя_файла. Если используется синтаксис -xпуть\имя_файла при распаковке архива, то компонент "путь" должен быть путём внутри архива, а не путём к файлу на диске после извлечения.

Маски, содержащие шаблоны, по умолчанию применяются только к файлам. Если маску с шаблонами нужно применить к нескольким папкам, необходимо использовать особый синтаксис масок для исключения папок. Такие маски должны заканчиваться символом \ (обратной косой чертой). Например, маска *tmp*\ исключит из обработки все папки, подходящие под шаблон *tmp*, а маска *\tmp\ исключит все папки tmp. Так как присутствуют символы подстановки, обе маски будут применены к содержимому текущей папки и всех её подпапок. Маски исключения папок работают только с архивами RAR и ZIP.

Если нужно исключить из обработки только одну папку, укажите её точное имя, включая абсолютный или относительный путь без каких-либо символов подстановки. В этом случае добавлять к маске символ разделителя пути не нужно, он требуется лишь для масок исключения папок, содержащих символы подстановки, чтобы их можно было отличить от масок исключения файлов.

Если маска содержит шаблоны, её действие распространяется на текущую папку и вложенные в неё папки. Без указания шаблонов действие ключа не рекурсивно, поэтому если требуется исключить из обработки какой-либо файл имя_файла во всех папках, нужно указать две маски: имя_файла для текущей папки и *\имя_файла для вложенных папок. Если известен точный путь к файлу, то для исключения из обработки только этой копии имя_файла допускается применять синтаксис Путь\имя_файла. Если использовать синтаксис -xпуть\имя_файла при распаковке архива, то компонент "путь" должен быть путём внутри архива, а не путём к файлу на диске после распаковки.

Примеры

1. Добавить в архив rawfiles все файлы из текущей папки и вложенных в неё подпапок, за исключением файлов *.jpg и *.avi:

WinRAR a -r -x*.jpg -x*.avi rawfiles

2. Упаковать все файлы на диске C:, за исключением тех, которые находятся в папках temp, и файлов внутри папок temp:

WinRAR a -r -x*\temp\ SaveC c:\*

3. Извлечь из архива docs.rar всё, кроме файлов *.txt:

WinRAR x -x*.txt docs


Ключ -X@<файл-список> - не обрабатывать файлы, указанные в файле-списке

Ключ -X@<файл-список> — не обрабатывать файлы, указанные в файле-списке

Исключить из обработки файлы, указанные в текстовом <файле-списке>.

Пример

Добавить в архив bin все файлы *.exe, кроме перечисленных в файле list.txt:

WinRAR a -x@list.txt bin *.exe


Ключ -Y - отвечать "Да" на все запросы

Ключ -Y — подразумевать ответ "Да" на все запросы

Если указан этот ключ, то на все запросы будет автоматически даваться ответ "Да".


Ключ -Z<файл> - прочитать комментарий архива из файла

Ключ -Z<файл> — прочитать комментарий архива из файла

Если использовать этот ключ с любой командой, изменяющей архив, то в архив будет добавлен комментарий, прочитанный из указанного файла. Чтобы указать кодировку текстового файла, используйте этот ключ вместе с ключом -sc.

Пример

Добавить все файлы из текущей папки в непрерывный архив Receipts, прочитав комментарий для него из файла Receipts.diz:

WinRAR a -zReceipts.diz -s Receipts


Коды возврата WinRAR

В случае успешного окончания операции WinRAR завершает работу с нулевым (0) кодом возврата. Если код возврата отличается от нулевого, это говорит о том, что произошла какая-то ошибка.

Код возврата | Описание
0 | Операция успешно завершена.
1 | Предупреждение. Некритические ошибки.
2 | Критическая ошибка.
3 | Неверная контрольная сумма. Данные повреждены.
4 | Попытка изменить заблокированный архив.
5 | Ошибка записи на диск.
6 | Ошибка открытия файла.
7 | Неверный параметр в командной строке.
8 | Недостаточно памяти для выполнения операции.
9 | Ошибка при создании файла.
10 | Нет параметров и файлов, удовлетворяющих указанной маске.
11 | Неверный пароль.
255 | Операция прервана пользователем.


Общие параметры

Окно общих параметров

Чтобы вызвать это окно, выберите команду Установки... в меню Параметры и перейдите на вкладку Общие. Ниже описано содержимое окна.

Система

· Низкий приоритет

Этот параметр управляет загрузкой системы при работе WinRAR в многозадачной среде. Как правило, лучше использовать стандартный приоритет, т.е. не включать данный параметр, однако если вы часто запускаете WinRAR в фоновом режиме и одновременно работаете с другими программами, то имеет смысл установить низкий приоритет.

· Многопоточность

Если включено, то используется многопоточная версия алгоритма сжатия RAR, обеспечивающая более высокую производительность на компьютерах с многопроцессорной или многоядерной архитектурой. По умолчанию данный параметр включён, если операционная система сообщает, что в компьютере имеется более одного процессора, однако его можно включить вручную даже в системе с одним процессором.

Этот параметр влияет не только на сжатие, но и на другие модули WinRAR, способные запускать несколько потоков. Как правило, предлагаемое WinRAR состояние по умолчанию даёт оптимальный результат, поэтому обычно его менять не нужно.

История

· Вести историю архивов

По умолчанию WinRAR сохраняет имена нескольких недавно открывавшихся архивов в меню Файл, чтобы можно было быстро открыть их снова. Если по каким-либо причинам (например из соображений секретности) вы не хотите, чтобы запоминались имена открывавшихся архивов, то выключите этот параметр.

Кроме того, если параметр включён, WinRAR добавляет открываемые архивы в список недавних документов Windows. Если параметр Вести историю архивов выключен, Windows сама управляет списком недавних документов, и в этом случае — в зависимости от версии и настроек Windows — имена архивов могут быть в него как добавлены, так и не добавлены.

· История в полях ввода

Во многих окнах WinRAR поля ввода поддерживают списки ранее введённых строк, чтобы можно было быстро восстановить параметры из прошлых сеансов (имя архива, целевой путь и т.д.). Это экономит ваше время, однако данный параметр (как и предыдущий) может угрожать конфиденциальности, если за компьютером работают несколько человек. Поэтому на многопользовательском компьютере историю имеет смысл отключить.

Панель инструментов

· Размер кнопок

Выбрать размер кнопок на панели инструментов. Доступно только со стандартной темой интерфейса WinRAR.

· Надписи на кнопках

Включить/отключить показ надписей на кнопках.

· Заблокировать панели

Запретить пользователю перемещать или изменять размер панелей инструментов. Может пригодиться, чтобы исключить случайное изменение вида настроенных вами панелей.

· Панели…

Эта кнопка вызывает окно, в котором можно включить или выключить показ главной панели инструментов WinRAR, дополнительной маленькой панели с кнопкой Вверх на один уровень и адресной строки с информацией о пути или архиве.

· Кнопки…

Нажмите, чтобы открыть окно выбора кнопок, отображаемых на панели инструментов.

Интерфейс

· При старте запускать мастера

Если включено, WinRAR при запуске будет сразу переходить в режим мастера.

· Включить звуковые сигналы

Если включено, ошибки и окончание длительного процесса будут сопровождаться звуковым сигналом.

· Показывать комментарий архива

Если в открываемом архиве есть комментарий, то он будет отображаться в панели справа.

· Открывать в одном окне

Если включено, то при попытке открыть архив командой WinRAR <архив> или щелчком по значку архива, он будет открыт в существующем окне, если WinRAR уже был запущен ранее. Если параметр выключен, то архив будет открыт в новом окне WinRAR.

· Всегда поверх других окон

Помещать окно WinRAR поверх окон всех остальных программ. Может быть удобно, если вы часто перетаскиваете файлы в окно WinRAR.

· Полные пути в заголовке

Показывать в заголовке окна WinRAR полный путь к открытой папке или архиву.

· Индикаторы Windows

Этот параметр определяет вид индикаторов при архивировании и распаковке. Если включено, то отображаются стандартные индикаторы Windows, если же выключено, то собственные индикаторы WinRAR. В версиях Windows старее, чем Vista, имеет смысл выключить этот параметр, а в Windows Vista и новее, где органы управления более красивые — включить. Но учтите, что индикаторы Windows — двухцветные, в отличие от трёхцветных индикаторов WinRAR они не показывают текущую степень сжатия. Тем не менее процент сжатия в любом случае выводится на отдельной строке в окне хода операции.

· Индикатор в панели задач

Если включено, общий ход операции также отображается на значке WinRAR в панели задач Windows. Эта функция работает только в Windows 7 и новее, поэтому в более старых версиях Windows этот параметр недоступен.

Журнал

· Записывать ошибки в журнал

Если этот параметр включён, то все сообщения об ошибках и информация о повреждении архива будут записаны в файл rar.log, находящийся в той же папке, что и WinRAR.exe, или в папке %APPDATA%\WinRAR. Эта возможность доступна только после регистрации. Для просмотра журнала служит команда Просмотр журнала… в меню Настройки.

· Ограничить размер журнала до <nnn> КБ

Ограничивает размер создаваемого WinRAR файла rar.log. Минимально допустимый размер — 50 КБ.


Параметры архивации

Окно параметров архивации

Чтобы вызвать это окно, выберите команду Установки... в меню Настройки и перейдите на вкладку Архивация. Ниже описано содержимое окна. Обратите внимание, что большинство параметров можно задать с помощью кнопки Профили архивации / Создать профиль по умолчанию.

Более подробная информация о различных параметрах приведена в разделе Выбор оптимальных параметров архивации.

Профили архивации

· Создать профиль по умолчанию

В окне, вызываемом этой кнопкой, можно указать значения по умолчанию для большинства параметров архивации. Для всех параметров этого окна имеются разделы в справочной системе, вызываемой кнопкой "Справка.

Введённые в этом окне параметры сохраняются в профиле архивации по умолчанию с именем Профиль по умолчанию и автоматически восстанавливаются перед каждой операцией архивации.

Некоторые параметры профиля по умолчанию используются не только при добавлении файлов в архив, но и при других операциях, модифицирующих архив, например при удалении или переименовании файлов. В этом случае WinRAR считывает только те параметры, которые подходят для текущей операции. При извлечении никакие параметры из профиля по умолчанию не используются.

· Упорядочить профили…

Открывает окно, в котором можно упорядочить профили архивации. В окне управления профилями можно удалить существующие профили или изменить их параметры, например переименовать или сделать профилем по умолчанию.

Список размеров томов

· Определить размеры томов…

Эта кнопка вызывает окно определения размеров томов, в котором можно настроить список предопределённых размеров для поля Разделить на тома размером в окне имени и параметров архива.

Типы файлов, открываемых сначала как архивы

Здесь можно определить, как в списке файлов WinRAR нужно обрабатывать нажатие Enter или двойной щелчок мышью на файлах с архивным содержимым, но имеющих отличное от архивов расширение. На обработку обычных архивов с такими традиционными расширениями, как .rar или .zip, эта настройка не влияет.

Укажите одну или несколько масок файлов, разделяя их пробелами, чтобы выбрать файлы для данного параметра. Все файлы с не-архивными расширениями, не подпадающие под эти маски, будут либо запускаться, либо открываться в ассоциированных с ними программах, если таковые программы присутствуют. Например, если здесь не указана маска *.exe, а вы нажали Enter на самораспаковывающемся exe-архиве в списке файлов WinRAR, то этот SFX-архив будет запущен на выполнение, а не открыт в WinRAR.

Если файл соответствует любой маске, WinRAR будет сначала пытаться открыть его как архив, и только если он не архив, то будет обработан как обычный файл или пропущен – в зависимости от параметра Никогда не запускать файлы этих типов.

Вне зависимости от этой настройки, можно просмотреть содержимое любого архивного файла, внутри или вне архива, со стандартным или нестандартным расширением, нажав Ctrl+PgDn на его имени в списке файлов WinRAR.


Параметры путей

Окно параметров путей

Чтобы вызвать это окно, выберите команду Установки... в меню Настройки и перейдите на вкладку Пути. Ниже описано содержимое окна.

· Папка для временных файлов

WinRAR использует указанную папку для создания временных файлов. Если это поле пустое, то в зависимости от типа команды, временные файлы и папки будут создаваться либо в текущей папке, либо в папке для временных файлов Windows.

Исходное состояние этого параметра — стандартная временная папка Windows. Если вы её изменили и хотите впоследствии вернуть временную папку Windows, введите переменную %temp% вместо имени папки, и тогда WinRAR перед созданием временных файлов будет её заменять именем временной папки Windows.

· Использовать только для сменных дисков

При работе с жёсткими дисками, как правило, быстрее всего создавать временный архив в текущей папке. Однако для медленных внешних дисков может быть эффективнее сначала создавать архив на жёстком диске, и лишь потом копировать его на внешний диск. Чтобы WinRAR архивировал данные именно таким образом, нужно задать папку для временных файлов и включить параметр Использовать только для сменных дисков.

Этот параметр влияет только на команды, которые изменяют архив. Прочие команды данный параметр не используют, игнорируя тип текущего диска.

· Папка запуска

Здесь можно ввести имя папки, в которую WinRAR будет переходить сразу после запуска. Обратите внимание, что если включён параметр При запуске переходить в последнюю рабочую папку, то значение этого поля ни на что не влияет — WinRAR всегда будет переходить в ту папку, которая была активной в последнем сеансе работы.

· При запуске переходить в последнюю рабочую папку

Если включено, то при запуске WinRAR переходит в папку, которая была активной во время предыдущего сеанса работы.

· Кнопка Обзор

Нажмите, чтобы выбрать папку запуска.

· Папка по умолчанию для архивов

Если это поле не пустое и в имени создаваемого архива не задан полный путь, то архив будет создан в указанной папке по умолчанию. Например, если ввести в этом поле путь к рабочему столу Windows, то создаваемые в WinRAR архивы будут появляться на рабочем столе.

Если это поле пустое и в имени архива не указан полный путь, то архивы будут создаваться в той же папке, где находятся архивируемые файлы.

В режиме командной строки ключ -cfg- запрещает большинство установок WinRAR, включая папку по умолчанию для архивов.

· Папка по умолчанию для извлекаемых файлов

Здесь можно ввести имя папки, которая будет использоваться как базовая для конструирования папки назначения в командах Извлечь без подтверждения и Извлечь в указанную папку. При использовании этих двух команд извлечения WinRAR создаёт путь назначения, добавляя имя архива к папке по умолчанию. Иногда здесь удобно ввести путь к рабочему столу Windows, чтобы все извлекаемые из архива данные сразу появлялись на рабочем столе.

В отличие от папки по умолчанию для архивов, папка по умолчанию для извлекаемых файлов не используется в режиме командной строки. В контекстных меню она задействуется только для команды Извлечь файлы....

· Добавлять к пути имя архива

Определяет, нужно ли добавлять имя архива к имени папки по умолчанию или папки, предлагаемой в окне извлечения, при формировании целевого пути для извлекаемых файлов.

· Удалять избыточные папки из пути извлечения

Этот параметр работает только в контекстных меню, только для одного выбранного архива с одной папкой и без файлов в корневой папке архива и только для команды Извлечь в DestName\, где DestName — имя папки, предложенное WinRAR на основе имени архива. Если соблюдены все эти условия, данный параметр удалит из пути извлечения на основе имени архива папку верхнего уровня.

Например, если архив Pictures.rar содержит все файлы в папке Samples, и вы распаковываете его с помощью команды Извлечь в Pictures\ в контекстном меню, то при выключенном параметре WinRAR поместит файлы в Pictures\Samples, а при включённом — в Samples. Таким образом, экономится один щелчок мыши — не нужно открывать папку Pictures, в которой нет ничего, кроме Samples.

Этот параметр вносит дополнительную задержку перед началом извлечения, так как сначала нужно просканировать архив и проанализировать структуру его папок. Обратите внимание, что в контекстном меню по-прежнему будет отображаться имя папки на основе имени архива, даже если оно будет удалено из пути при извлечении. Показ истинного имени папки сразу в контекстном меню вызывал бы потенциальные задержки между щелчком правой кнопкой мыши по архиву и появлением меню.


Параметры списка файлов

Окно настройки вида списка файлов

Чтобы вызвать это окно, выберите команду Установки..." в меню Настройки и перейдите на вкладку Список файлов. Ниже описано содержимое окна.

Тип списка (краткий / подробный)

Выберите Краткий вид (многоколоночный, отображаются только имена файлов) или Подробный (одна колонка, отображаются размер, дата и тип каждого файла). По умолчанию включён Подробный режим.

Стиль списка

· Показывать разделители

Показывать сетку, разделяющую колонки и строки в списке файлов.

· Курсор на всю строку

Если включено, то при использовании Подробного вида курсор будет выделять всю строку (с размером, временем и пр.), в противном случае — только имя файла.

· Флажки

Выбирать элементы списка с помощью флажков. Доступно в Windows Vista и новее.

Файлы

· Показывать архивы первыми

Показывать архивы в списке файлов перед всеми остальными файлами вне зависимости от текущего режима сортировки.

· Выделять цветом сжатые и зашифрованные NTFS-файлы

Если включено, то WinRAR будет отображать имена файлов с NTFS-атрибутами Сжатый и Зашифрованный такими же цветами, как в Проводнике Windows. По умолчанию для атрибута Сжатый используется синий цвет, а для Зашифрованный — зелёный.

· Объединять содержимое томов

Если включено, то при открытии первого тома многотомного архива WinRAR попытается также прочитать и отобразить содержимое всех остальных томов этого архива, находящихся в той же папке, что и первый том. Таким образом, будут показаны файлы, хранящиеся не только в первом томе, но и во всех остальных томах архива.

· Показывать секунды

Показывать секунды в датах у файлов в списке. Если выключено, даты в списке файлов отображаются с точностью 1 мин.

· Точные размеры

Если включено, размеры файлов всегда отображаются в байтах. Если выключено, размеры округляются до КБ или МБ. Размеры маленьких файлов могут по-прежнему выводиться в байтах.

· Колонки…

Выбрать колонки, отображаемые в режимах управления файлами и архивами.

· Шрифт…

Выбрать шрифт для списка файлов.

Выбор

В этой группе параметров можно определить разные стили выбора элементов списка мышью. Включите Открывать по одинарному щелчку, если вы привыкли к стилю выбора, применяемому в интернет-браузерах. В этом режиме можно также указать, как будут подчёркиваться имена файлов. По умолчанию используется режим Открывать по двойному щелчку, как это принято в стандартной среде Windows 95.


Параметры просмотра

Окно параметров просмотра

Чтобы вызвать это окно, выберите команду Установки... в меню Настройки и перейдите на вкладку Просмотр. Ниже описано содержимое окна.

Тип просмотра

Здесь выбирается стандартное действие, которое будет происходить при нажатии на файле клавиши Enter. Возможные действия:

Встроенное средство просмотра | Использовать встроенное средство просмотра WinRAR
Внешняя программа просмотра | Использовать внешнюю программу просмотра (она должна быть определена в поле Внешняя программа просмотра)
Ассоциированная программа | Для просмотра использовать программу, связанную в Windows с данным типом файлов
Спросить | При нажатии Enter спрашивать у пользователя, какое из трёх вышеперечисленных действий следует выполнить

Для файлов некоторых типов эти параметры игнорируются. В режиме управления файлами они игнорируются для архивов и исполняемых файлов. WinRAR по нажатию Enter всегда пытается входить в архивы и запускать EXE-файлы. В режиме управления архивами эти параметры игнорируются для типов файлов, указанных в поле Распаковывать весь архив для файлов на вкладке Просмотр в окне настроек WinRAR. Если нажать Enter на таком файле, WinRAR извлечёт всё содержимое архива во временную папку, запустит этот файл, подождёт, пока тот закончит свою работу, в случае необходимости обновит архив и удалит временную папку со всеми файлами. Таким образом, можно легко устанавливать (инсталлировать) приложения непосредственно из архивов.

В отличие от нажатия Enter, команда Просмотреть файл всегда открывает файл во встроенной программе просмотра WinRAR.

Встроенное средство просмотра

· Автоопределение кодировки

Если этот параметр включён, встроенная программа просмотра пытается автоматически распознать содержимое файла как текст Windows (ANSI), текст DOS (OEM), Юникод UTF-8 или UTF-16 little endian. Если автоопределение сработало неверно, кодировку уже открытого файла можно изменить командами Просмотр… в меню Вид или в контекстном меню во встроенной программе просмотра.

· Просмотр в одном окне

Если этот параметр выключен, то при просмотре каждого файла WinRAR создаёт отдельное окно. Если же включён, то для просмотра будет использоваться только одно уже существующее окно, т.е. открывается только одна копия внутреннего средства просмотра.

· Перенос по словам

Переключает во встроенном средстве просмотра режимы заворота длинных строк и прокрутки. Этот параметр влияет только на вновь открываемые окна просмотра, уже открытые окна не изменяются.

Распаковывать весь архив для файлов

В этом поле можно указать маски для файлов в архиве, при нажатии Enter или двойном щелчке мышью на которых требуется распаковать содержимое всего архива. Маски должны быть разделены пробелами. Например, если это поле содержит "*.exe *.htm *.html", то весь архив будет распаковываться перед открытием заархивированных исполняемых файлов и файлов HTML. Данный параметр необходим для тех файлов, которым для выполнения или просмотра требуется доступ к другим находящимся в архиве файлам.

Для указанных в этом поле типов файлов WinRAR игнорирует установку в группе Тип просмотра и всегда открывает такие файлы в ассоциированной им программе.

Игнорировать изменения этих файлов

По умолчанию WinRAR пытается обновить архив, если программа просмотра изменила открытый файл или создала новые файлы, но такое поведение можно запретить. Введите в поле Игнорировать изменения этих файлов одну или несколько масок файлов, разделяя их пробелами, и WinRAR не будет предлагать обновить архив, если созданный или изменённый программой просмотра файл подпадает под одну из этих масок.

Например, если это поле содержит *.doc *.txt, то любые файлы .doc и .txt, изменённые или созданные внешней или ассоциированной программой просмотра, будут игнорироваться, и все сделанные пользователем при просмотре изменения в этих файлах будут утеряны. Если вы хотите отключить обновление для любых просматриваемых файлов, используйте маску "*" (без кавычек).

Маски в этом параметре могут иметь более сложный синтаксис, сочетающий архивную и файловую маски, разделённые двумя символами обратной косой черты: arcmask\\filemask. Маски могут включать путь, ограничивающий архивы или файлы указанной папкой и её подпапками. В пути разрешается использовать переменные окружения. Если требуется выбрать все архивы или все файлы, то компоненты arcmask\\ или filemask можно опустить.

Например, маска *.rar\\*.txt соответствует всем файлам .txt во всех архивах .rar, маска *\\temp\* или просто temp\* указывает на все файлы в папках temp внутри архивов, а маска %temp%\*\\* или %temp%\*\\ сообщает программе просмотра, что не нужно обновлять никакие архивы во временной папке Windows.

Внешняя программа просмотра

Здесь нужно указать имя программы, которая должна использоваться для просмотра, если выбран вариант Внешняя программа просмотра. Имя просматриваемого файла передаётся программе как единственный параметр.


Параметры безопасности

Окно параметров безопасности

Чтобы вызвать это окно, выберите команду Установки… в меню Настройки и перейдите на вкладку Безопасность. Ниже приведено описание элементов этого окна.

Типы файлов для исключения из распаковки

Если включить этот параметр, то при распаковке или открытии архивов WinRAR будет пропускать все потенциально опасные файлы, соответствующие маскам в расположенном ниже поле. Разрешается вводить несколько масок, разделяя их пробелами.

Может пригодиться для защиты от инфицированных вложений в сообщения электронной почты. Например, чтобы запретить распаковывать, просматривать и запускать с помощью WinRAR файлы .scr, .pif и .exe, укажите в этом поле:

*.scr *.pif *.exe

Уничтожение (затирание) временных файлов

В этой группе параметров выбирается режим удаления временных файлов во временной папке WinRAR, создаваемых при обработке уже существующих архивов. Затрагивает операции с внешней или внутренней программой просмотра, выполнение файлов в архиве и распаковку перетаскиванием (drag-and-drop).

  • Не использовать

Временные файлы удаляются с помощью стандартной системной функции удаления, поэтому их иногда можно восстановить с помощью специального ПО. Это самый быстрый, но наименее безопасный способ обращения с временными файлами.

  • Использовать всегда

Перед удалением временные файлы перезаписываются нулевыми байтами, благодаря чему их уже невозможно восстановить. Это заметно медленнее, но безопаснее.

  • Использовать только для зашифрованных

Временные файлы удаляются с помощью надёжной и медленной функции затирания, только если содержащий эти файлы архив зашифрован паролем. В противном случае применяется стандартное быстрое удаление.

Об уничтожении временных файлов

  • Функция уничтожения (затирания) рассчитана на обычные жёсткие диски. При использовании с твердотельными накопителями (SSD) перезапись исходных данных может не работать из-за применяемой в SSD-накопителях технологии Wear Leveling (перераспределения блоков при записи) и более сложной адресации данных.
  • Если временные файлы всё ещё используются, WinRAR может не удалить их немедленно. Вместо этого все временные файлы, возраст которых превосходит один час, будут удалены или уничтожены при следующем запуске WinRAR. То же самое происходит, если не удаётся наверняка определить, продолжают ли временные файлы использоваться внешней программой.
  • Данный параметр работает только с временными файлами, созданными после операций извлечения. С другими временными файлами (например создаваемыми при изменении архива) он не работает. Такие файлы всегда удаляются с помощью стандартной быстрой функции удаления.

Предлагать выбор антивирусного сканера

Эта опция изменяет поведение команды Проверить архив на вирусы. По умолчанию данная опция включена, поэтому при каждом вызове команды проверки на вирусы предлагается выбрать антивирусный сканер и его параметры. Если вы пользуетесь только какой-то одной антивирусной программой, появление окна выбора сканера можно отменить, выключив эту опцию.


Параметры интеграции

Окно параметров интеграции

Чтобы вызвать это окно из WinRAR, выберите команду Установки... в меню Настройки и перейдите на вкладку Интеграция. То же самое доступно во время установки WinRAR, поэтому описанные ниже параметры можно изменить как при установке, так и во время работы WinRAR.

Ассоциирование с файлами (архивами RAR, ZIP и др.)

Назначить WinRAR стандартной программой просмотра для файлов выбранных форматов. Здесь лучше оставить все опции включёнными, чтобы открывать архивы в WinRAR нажатием <Enter> или двойным щелчком мыши на имени или значке архива в Проводнике или на рабочем столе. Кнопка Переключить все позволяет выбрать все форматы сразу или снять с них выбор, если они уже выбраны.

Пользовательские расширения архивов

В этом поле можно указать дополнительные расширения файлов для форматов архивов, поддерживаемых WinRAR. Например, если архивы RAR у вас имеют расширение .dat, введите в этом поле dat, чтобы ассоциировать WinRAR с такими файлами и добавить команды извлечения в контекстные меню, отображаемые в оболочке Windows для файлов dat. Если требуется указать несколько расширений, разделяйте их пробелами.

Этот параметр доступен только в настройках WinRAR, но не в программе установки WinRAR.

Интерфейс

· Добавить значок WinRAR на рабочий стол

Поместить на рабочий стол значок WinRAR.

· Добавить значок WinRAR в меню "Пуск"

Поместить в меню Пуск пункт, вызывающий WinRAR.

Этот параметр добавляет значок WinRAR в верхний уровень классического меню Пуск в Windows XP. Начиная с Windows Vista, программам запрещено добавлять себя в верхний уровень меню Пуск, поэтому данный параметр добавляет вызов WinRAR в список Все программы. Если вы хотите добавить значок WinRAR в верхний уровень меню Пуск в Vista и более новых версиях Windows, то используйте в Windows команду Закрепить в меню 'Пуск'.

· Создать групп программ WinRAR

Создать группу программ WinRAR в меню Пуск/Программы.

Интеграция с оболочкой Windows

· Встроить WinRAR в оболочку Windows

Позволяет использовать контекстные меню и перетаскивание (drag-and-drop) для обработки архивов, поддерживаемых WinRAR.

· Вложенные контекстные меню

Поместить все элементы, добавляемые WinRAR в контекстное меню, в отдельное подменю.

· Значки в контекстных меню

Показывать маленькие значки рядом с пунктами WinRAR в контекстных меню файлов и архивов.

· Элементы контекстного меню

Здесь можно выбрать элементы, которые будут отображаться в контекстных меню Проводника Windows.


Профили архивации

Профиль — это набор различных параметров, который можно быстро установить перед началом архивации. Чтобы перед каждой архивацией не нужно было указывать тип архива, размер тома, метод сжатия и множество других параметров, можно создать несколько профилей для часто используемых операций и в дальнейшем быстро загружать сразу все эти параметры, просто выбирая в меню соответствующий профиль.

У профилей архивации есть присваемые пользователем имена, которые отображаются в списке профилей. Рекомендуется давать профилям осмысленные имена, по которым можно было бы сразу понять назначение профиля. Чтобы воспользоваться профилем, нужно нажать кнопку Профили в окне Имя и параметры архива и выбрать в появившемся списке имя нужного вам профиля — все сохранённые в профиле параметры будут восстановлены. По умолчанию в WinRAR уже имеется несколько предопределённых профилей (для создания вложений в электронные письма, для резервного копирования и др.), но при желании вы их можете удалить и создать свои.

Профили можно создавать двумя способами. Первый — открыть окно Имя и параметры архива, выставить все параметры, нажать кнопку Профили и в появившемся меню выбрать пункт Сохранить текущие параметры как новый профиль. В окне параметров профиля можно указать имя профиля и его настройки, самая важная из которых — Установить как профиль по умолчанию. Если установить этот параметр, профиль будет применяться перед каждой архивацией и некоторыми операциями, модифицирующими архив. Другие параметры позволяют сохранить имя архива и список выбранных файлов, создать ярлык на рабочем столе и начать архивацию сразу после выбора данного профиля из меню. Более подробную информацию обо всех параметрах см. в разделе Параметры профиля.

Второй способ создать профиль — нажать кнопку Создать профиль по умолчанию на вкладке Архивация в настройках WinRAR. В появившемся окне нужно выбрать все необходимые параметры и нажать OK. В результате будет создан новый профиль с именем "Профиль по умолчанию". В отличие от первого метода, здесь нельзя указать такие параметры профиля, как, например, сохранение имени архива и выбранных файлов, создание ярлыка. Если при определении профилей нужна большая гибкость, то следует использовать первый метод.

Сохранённые в профиле параметры архивации изменять нельзя. Однако вы можете изменять другие параметры профиля, например его имя, статус (используется он по умолчанию или нет) и др. Чтобы изменить параметры профиля или удалить существующие профили, используйте команду Упорядочить профили, доступную как в меню профилей окна Имя и параметры архива, так и в окне настроек WinRAR на вкладке Архивация. С помощью этой команды можно сделать любой профиль используемым по умолчанию или отменить этот статус у профиля.

В профиле можно сохранять пароль, однако имейте в виду, что пароль хранится в реестре в незащищённом виде. Поэтому узнать сохранённый пароль может любой пользователь, у которого есть доступ к вашему компьютеру.


Файл WinRAR.ini

По умолчанию WinRAR хранит свои настройки в реестре. Это удобно, когда WinRAR установлен и используется на одном и том же отдельном компьютере. Если же предполагается установить WinRAR на сменный носитель (например на USB-накопитель — "флэшку") для использования на разных ПК, то предпочтительнее не хранить относящуюся к WinRAR информацию в реестре этих компьютеров.

С этой целью предусмотрена возможность перенаправлять доступ WinRAR к реестру в текстовый файл. Если создать пустой файл WinRAR.ini либо в папке с WinRAR.exe, либо в %APPDATA%\WinRAR, то WinRAR будет перенаправлять доступ к ключам реестра HKEY_CURRENT_USER\Software\WinRAR и HKEY_LOCAL_MACHINE\Software\WinRAR в этот файл. Сначала WinRAR ищет этот файл в своей папке, а затем в %APPDATA%\WinRAR.

Используйте команду Создать файл WinRAR.ini в подменю Импорт и экспорт, чтобы создать новый файл WinRAR.ini и скопировать в него из реестра имеющиеся установки WinRAR. Созданный этой командой файл нужно скопировать либо в собственную папку WinRAR, либо в %APPDATA%\WinRAR, чтобы сделать его активным.

Обычно текущие установки записываются в WinRAR.ini только при выходе, а до того момента они хранятся в памяти. Параметры сохраняются с учётом регистра символов как текстовые строки в кодировке UTF-16LE и имеют следующий формат:

<корневая ветвь>\<имя ключа>=значение

где <корневая ветвь> может быть HKCU для HKEY_CURRENT_USER, HKLM для HKEY_LOCAL_MACHINE, и Global для глобальных установок, добавленных пользователем вручную. Заключённые в кавычки строковые значения и байтовые массивы имеют префикс "bin:".

Для управления поведением WinRAR.ini можно менять глобальные установки. Если запись в WinRAR.ini не запрещена, WinRAR автоматически создаёт указанные ниже строки, и чтобы изменить какую-либо установку, вам нужно отредактировать параметр после "=". Эти строки создаются в начале WinRAR.ini. Если вы собираетесь запретить запись в этот файл установкой у него атрибута "Только чтение", то потребуется добавить соответствующую строку в WinRAR.ini вручную перед установкой этого атрибута, по одной команде на строку. Все такие строки должны быть в кодировке UTF-16LE, и они чувствительны к регистру символов. Доступны следующие глобальные установки:

Global\AppData=0

Запрещает WinRAR доступ к папке APPDATA%\WinRAR. Если указан параметр Global\AppData=0, то все файлы, обычно хранящиеся в этой папке (например регистрационный ключ или темы интерфейса), следует хранить в папке с файлом WinRAR.exe. Укажите Global\AppData=1, чтобы разрешить доступ к APPDATA%\WinRAR.

Global\Integration=0

Хотя WinRAR перенаправляет свои ветви HKEY_CURRENT_USER и HKEY_LOCAL_MACHINE ключей реестра в WinRAR.ini, для правильной установки расширения оболочки и файловых ассоциаций по-прежнему требуется записывать данные в HKEY_CLASSES_ROOT и другие части реестра. Например, это происходит при использовании настроек интеграции. Если вы хотите полностью запретить все операции с реестром, добавьте в файл WinRAR.ini команду Global\Integration=0. После этого WinRAR не сможет изменять настройки интеграции в систему. Эта команда также запрещает создание или удаление ярлыка WinRAR на рабочем столе и программной группы WinRAR. Укажите Global\Integration=1, чтобы разрешить интеграцию в систему.

Global\SaveSettings=0

Запрещает запись текущих установок в WinRAR.ini, поэтому при выходе все изменения конфигурации, сделанные в текущей копии WinRAR, будут утеряны. Такого же результата можно добиться, включив у файла WinRAR.ini атрибут "Только чтение". Таким образом, следует сначала настроить WinRAR так, как вы хотите, закрыть WinRAR, чтобы сохранить установки в файле, и только затем добавить команду Global\SaveSettings=0. Этот режим может также влиять на другие компоненты WinRAR, зависящие от WinRAR.ini, например встраивание в оболочку Windows не видит изменений в окне элементов контекстного меню. Укажите Global\SaveSettings=1, чтобы разрешить сохранение установок в WinRAR.ini.

Примечания

  • В отличие от других переменных в реестре, переменная AppData не перенаправляется в WinRAR.ini и всегда считывается из реестра. Она определяет местоположение папки %APPDATA%\WinRAR, а поскольку в этой папке может храниться файл WinRAR.ini, необходимо узнавать значение этой переменной до обращения к файлу WinRAR.ini.
  • Если в папке с программой установки WinRAR находится файл winrar.ini, то по окончании установки этот файл будет скопирован в программную папку WinRAR.


Переменная окружения RAR

Ключи, которые вы хотите использовать по умолчанию, можно определить с помощью переменной окружения Windows с именем RAR, задав её командой SET. Большинство определённых в этой переменной ключей будут применяться только при работе в режиме командной строки. Ключи -cl , -cu, -tk, -tl, -p используются как в режиме командной строки, так и в режиме оболочки.

Пример

SET RAR= -s -m5 -md1024

Эта команда указывает WinRAR, что при запуске из командной строки нужно создавать непрерывные архивы, используя режим максимального сжатия и словарь размером 1024 КБ.


Переменные в реестре

При работе в многопользовательской среде из соображений безопасности может потребоваться запретить доступ к некоторым функциям WinRAR. В этом случае нужно создать в системном реестре ключ

HKEY_LOCAL_MACHINE\Software\WinRAR\Policy

или

HKEY_CURRENT_USER\Software\WinRAR\Policy

Ключ в HKEY_LOCAL_MACHINE имеет более высокий приоритет, чем в HKEY_CURRENT_USER.

Этот ключ может содержать следующие значения:

Значение | Тип | Описание
Menu | DWORD | Если установлено в 0, отключает главное меню WinRAR.
Settings | DWORD | Если установлено в 0, отключает окно Настройки, команды подменю Импорт и экспорт и контекстное меню панели инструментов.
Password | DWORD | Если установлено в 0, запрещает изменение пароля архивирования (например чтобы избежать шифрования важных данных).
OrgPasswords | DWORD | Если установлено в 0, запрещает доступ к окну упорядочивания паролей. При этом доступ к паролям, уже сохранённым в этом окне, остаётся, поэтому если необходимо, удалите их перед установкой переменной OrgPasswords.
Shutdown | DWORD | Если установлено в 0, запрещает параметр По окончании, чтобы пользователь не мог отключить компьютер, перезагрузить, либо перевести его в состояние гибернации или сна после завершения операции.
Benchmark | DWORD | Если установлено в 0, запрещает команду Тест быстродействия. В многопользовательском окружении эта команда может неблагоприятно влиять на совместные вычислительные ресурсы.

После смены политики может потребоваться перезапустить WinRAR. Ключ политики не влияет на консольную версию RAR (файл Rar.exe), поэтому если при работе нескольких пользователей на одной машине вы хотите обезопасить себя в большей степени, имеет смысл удалить файл Rar.exe и оставить только WinRAR.exe.

Кроме того, можно переопределить расположение папки %APPDATA%\WinRAR, указав новый путь к дополнительным файлам WinRAR в строковом значении AppData в ключе реестра HKEY_CURRENT_USER\Software\WinRAR\Paths.


RARFILES.LST - порядок файлов в непрерывных архивах

RARFILES.LST — порядок файлов в непрерывных архивах

При добавлении в непрерывные архивы файлы обычно сортируются по расширению, но можно задать и другой порядок сортировки, определив его в файле rarfiles.lst. Этот файл должен находиться в той же папке, что и WinRAR.exe, или в папке %APPDATA%\WinRAR. Такой файл входит в комплект поставки WinRAR, но вы можете настроить его сами под свои конкретные нужды. Это обычный текстовый файл, в котором записан порядок следования файлов при добавлении в непрерывный архив. Файл rarfiles.lst может содержать имена файлов, шаблоны и специальный элемент — $default. Этот элемент задаёт место в списке для файлов, которые не соответствуют ни одному другому критерию, определённому в rarfiles.lst.

Советы по повышению степени сжатия и скорости операций:

· файлы с похожим содержимым должны быть сгруппированы в архиве максимально близко;

· файлы, к которым планируется обращаться чаще всего, должны находиться в начале архива.

Обычно маски следует располагать ближе к началу списка, чтобы они имели более высокий приоритет, однако из этого правила есть исключение. Если rarfiles.lst содержит такие две маски, для которых выполняется условие, что все файлы, подходящие под первую маску, также подходят и под другую, то маска, указывающая на меньшее подмножество, будет иметь более высокий приоритет вне зависимости от её расположения. Например, при указании масок *.cpp и f*.cpp более высокий приоритет будет у маски f*.cpp, поэтому расположение в архиве файла filename.cpp будет выбрано в соответствии с f*.cpp, а не с *.cpp.

Пример файла RarFiles.lst:

file_id.diz
readme.*
*.doc
*.txt
*.hlp
*.inf
*.exe
*.dll
$default
*.rar


SFX-модули RAR и ZIP с графическим (GUI) интерфейсом (Default.SFX и Zip.SFX)

C помощью этих двух модулей можно создавать самораспаковывающиеся архивы с GUI (графическим интерфейсом) для Windows.

Для архивов RAR используется модуль Default.SFX, для архивов ZIP — Zip.SFX.

WinRAR x64 также включает 64-разрядные версии этих SFX-модулей — Default64.SFX и Zip64.SFX. По умолчанию WinRAR x64 использует 32-разрядные версии, но вы можете выбрать 64-разрядные модули явно в окне Дополнительные параметры SFX: Модуль. При этом результирующий 64-разрядный SFX-архив будет работать только в 64-разрядных версиях Windows.

Оба этих модуля поддерживают несложные команды создания установочных пакетов и параметры командной строки. См. подробности в следующих темах:

  • SFX: команды создания установщиков
  • SFX: параметры командной строки

Примечания

  1. SFX-модули можно приспособить под свои конкретные нужды, отредактировав содержащиеся в них Windows-ресурсы. Например, допускается изменять размеры начального окна или добавлять туда свои рисунки. В комплект поставки WinRAR не входит ни редактор ресурсов, ни соответствующая документация. Редактирование ресурсов — процесс, требующий известной квалификации, и если вы собираетесь этим заниматься, то у вас наверняка уже есть нужный инструментарий и вы знаете, как с ним работать. Если же вас устраивает стандартное начальное окно SFX, то редактировать ресурсы не требуется. Кроме того, если нужно изменить только рисунок или значок в SFX-модуле, вы можете сделать это в окне дополнительных параметров SFX на вкладке Текст и графика.
  2. Коды возврата, сообщаемые самораспаковывающимися архивами с графическим интерфейсом (GUI) при прекращении работы, по умолчанию такие же, как у WinRAR. Это поведение можно изменить с помощью команды SetupCode, чтобы SFX также сообщал коды возврата программы установки.


Графические SFX-модули: команды создания установщиков

SFX-модули WinRAR с графическим интерфейсом (GUI) поддерживают несложные команды для создания установочных пакетов. Эти команды должны находиться в комментарии SFX-архива. Ниже приведён список команд. Щёлкните по названию команды, чтобы ознакомиться с её описанием.

Delete | Удалить файл перед извлечением
License | Показать экран с лицензионным соглашением
Overwrite | Выбор режима перезаписи файлов
Path | Установить предлагаемый по умолчанию путь для распаковки
Presetup | Выполнить указанную программу до начала распаковки
SavePath | Сохранить путь назначения
Setup | Выполнить указанную программу после успешной распаковки
SetupCode | Ждать завершения работы программы установки и установить её код возврата
Shortcut | Создать ярлык для распакованного файла
Silent | Не показывать начальное окно
TempMode | Распаковать архив во временную папку
Text | Добавить текст в окно SFX-архива
Title | Указать заголовок окна SFX-архива
Update | Выбор режима обновления файлов

SFX-модуль развёртывает переменные окружения в командных параметрах, поэтому можно использовать, например, такие команды:

Path=%temp%\myapp

Setup=mysetup.exe %sfxpar%

(см. описание переменной sfxpar для команды Setup).

Щёлкните здесь, чтобы ознакомиться с примером полного сценария установки.


SFX-модули с GUI: параметры командной строки

SFX-модули WinRAR с графическим интерфейсом (GUI) поддерживают следующие параметры в командной строке.

Параметр | Описание
-d<путь> | Указать целевую папку для извлекаемых файлов.
-p<пароль> | Указать пароль для зашифрованного SFX-архива.
-s, -s1, -s2 | Режим подавления выводимых на экран сообщений. Ключ -s это сокращённая форма ключа -s1. Ключи -s и -s1 скрывают окно SFX и индикатор хода извлечения. Ключ -s1 также скрывает окно с лицензией. Ключ -s2 скрывает только начальное окно, но индикатор операции отображается.
-sp<параметры> | Если приложение, указанное в SFX-команде Setup, не содержит никаких параметров, вы можете использовать этот ключ для передачи параметров в такое приложение. Если в команде Setup параметры уже заданы, этот ключ игнорируется. Кроме того, программа установки может считывать полную командную строку SFX из переменной окружения sfxcmd, а переменная окружения sfxpar содержит только параметры командной строки SFX, без имени SFX-модуля в начале.

Если требуется вставить в параметр командной строки символ кавычки, укажите этот символ дважды.


Консольный SFX-модуль RAR (WinCon.SFX)

С помощью этого модуля можно создавать самораспаковывающиеся архивы, выполняющиеся в текстовом режиме в среде Windows. В MS-DOS модуль не работает.

WinRAR x64 также включает 64-разрядную версию этого SFX-модуля – WinCon64.SFX. По умолчанию 64-разрядная версия WinRAR использует 32-разрядную версию SFX, но можно явно выбрать 64-разрядный модуль в окне Дополнительные параметры SFX: Модуль. При этом результирующий 64-разрядный SFX-архив будет работать только в 64-разрядных версиях Windows.

Модуль поддерживает следующие ключи командной строки:

-e Извлечь файлы из архива (действие по умолчанию)

-t Протестировать файлы в архиве

-v Показать подробное содержание архива

-? Показать справку

Коды возврата, сообщаемые консольными SFX-архивами при прекращении работы, такие же, как у WinRAR.


Типичные вопросы

Вопросы

Я хочу извлечь файлы из архива. Как это сделать с помощью WinRAR?

RAR позволяет сжимать данные несколькими "методами". Каковы преимущества и недостатки каждого из них, каким лучше пользоваться ежедневно?

Мне часто доводилось слышать о "непрерывных" (solid) архивах. Что это такое и как их использовать?

Как пользователь моего сайта (электронной почты, FTP-сервера и т.д.) может извлекать файлы из архивов RAR, если RAR — условно-бесплатная программа, требующая регистрации после 40-дневного испытательного срока?

Где можно получить новейшие версии WinRAR?

При извлечении файлов программа сообщает об ошибке контрольной суммы. Что это значит?

Мне не удалось извлечь файлы из многотомного непрерывного архива RAR, потому что один из томов оказался повреждённым. Помогите!

Не могу вспомнить свой пароль! Помогите!

Почему WinRAR не удаляет свои временные файлы из папки временных файлов Windows?

Почему для моего архива WinRAR не использует словарь максимального размера?

Вопросы и ответы

? Я хочу извлечь файлы из архива. Как это сделать с помощью WinRAR?

! Прочтите раздел Режимы оболочки и командной строки — в нём есть ссылки на разделы, описывающие несколько способов извлечения файлов.

? RAR позволяет сжимать данные несколькими "методами". Каковы преимущества и недостатки каждого из них, каким лучше пользоваться ежедневно?

! Ответ на этот вопрос см. в разделе Выбор оптимальных параметров архивации.

? Мне часто доводилось слышать о "непрерывных" ("solid") архивах. Что это такое и как их использовать?

! Прочтите раздел Непрерывные архивы.

? Как пользователь моего сайта (электронной почты, FTP-сервера и т.д.) может извлекать файлы из архивов RAR, если RAR — условно-бесплатная программа, требующая регистрации после 40-дневного испытательного срока?

! В комплект поставки WinRAR входит бесплатная программа UnRAR.exe, которой может пользоваться кто угодно для распаковки архивов RAR без отчисления лицензионного гонорара автору. Кроме того, на сайте WinRAR (www.rarlab.com) доступен переносимый на разные платформы исходный текст UnRAR. Обратите внимание, что алгоритм RAR является частной собственностью, поэтому использовать исходные тексты UnRAR для его восстановления запрещено.

? Где можно получить новейшие версии WinRAR?

! Посетите сайт WinRAR — www.rarlab.com.

? При извлечении файлов программа сообщает об ошибке контрольной суммы. Что это значит?

! Извлечённые файлы испорчены из-за повреждения архива или каких-либо аппаратных проблем. Если архив повреждён, но в нём имеются данные для восстановления, можно попробовать его восстановить. Если данных для восстановления нет, спасти повреждённые данные не удастся. Обратите также внимание, что если испорченный архив — непрерывный, то будут утеряны и все файлы, следующие в архиве за повреждённым файлом.

? Мне не удалось извлечь файлы из многотомного непрерывного архива RAR, потому что один из томов оказался повреждённым. Помогите!

! Если для архива есть тома для восстановления, поместите их в ту же папку, где находятся тома RAR, и дважды щёлкните по первому тому для восстановления (файлу .rev), чтобы начать восстановление.
Если томов для восстановления нет или они не помогли, попробуйте применить к повреждённому тому команду Восстановить. Затем переименуйте восстановленный том (он будет назван fixed.архив.rar или, если не удастся найти данные для восстановления, rebuilt.архив.rar), дав ему настоящее имя тома, после чего попробуйте распаковать архив ещё раз, начав с первого тома.
Чтобы увеличить шансы на успешное восстановление многотомных архивов RAR в случае повреждения информации, при их создании добавляйте к ним данные для восстановления и создавайте тома для восстановления. Кроме того, в особо ответственных ситуациях лучше не прибегать к непрерывному архивированию, пусть даже это и ухудшит степень сжатия.

Если повреждён том непрерывного архива, попробуйте восстановить его. В этом помогают данные для восстановления (если они были добавлены при создании или изменении архива). Проверить наличие таких данных можно командой Информация об архиве. Измените имя восстановленного тома с fixed.архив.rar (или с rebuilt.архив.rar, если данных о восстановлении в томе не было) на его исходное и попробуйте извлечь файлы из архива, начиная с первого тома.

? Не могу вспомнить свой пароль! Помогите!

! В схему шифрования WinRAR не встроено никаких потайных "лазеек". Если сами авторы WinRAR забудут пароль к любому из своих архивов, то извлечь файлы не смогут даже они. Пожалуйста, не обращайтесь к авторам за помощью в такой ситуации.

? Почему WinRAR не удаляет свои временные файлы в папке временных файлов Windows?

! Это происходит, если для извлечения файлов из архивов вы пользуетесь перетаскиванием (drag-and-drop) или открываете заархивированные файлы во внешней программе просмотра. В таких случаях эти файлы могут продолжать использоваться другой программой и после закрытия WinRAR, а надёжного способа определить, нужны внешней программе эти распакованные файлы или уже нет, не существует. Именно поэтому WinRAR и не удаляет такие файлы сразу. Вместо этого при следующем запуске WinRAR удаляет все свои временные файлы, оставшиеся после предыдущих сеансов, если они были извлечены более часа назад.

Если при извлечении файлов вы вообще не хотите задействовать папку для временных файлов, то пользуйтесь не перетаскиванием, а командой Извлечь... в оболочке WinRAR или Извлечь в <имя_папки> в контекстном меню Проводника.

? Почему для моего архива WinRAR не использует словарь максимального размера?

! Даже если для сжатия был указан максимальный размер словаря, WinRAR может автоматически уменьшить этот размер, если объём сжимаемых данных хотя бы вдвое меньше размера словаря. Это не ухудшает степень сжатия, но уменьшает требования к объёму доступной памяти.


Советы

Как установить программу из архива

Программы можно устанавливать или запускать прямо из архива. Для этого войдите в архив и нажмите <Enter> на программе установки, например на файле setup.exe или install.exe. WinRAR извлечёт всё содержимое архива во временную папку, после чего запустит выделенный исполняемый файл. Далее WinRAR будет ждать окончания работы программы, после чего проверит время изменения извлечённых файлов и наличие новых, и при необходимости предложит обновить архив. После этого временная папка со всем её содержимым будет удалена.

Вы хотите открывать архивы в WinRAR, но какая-то другая программа поменяла ассоциации архивов

Некоторые программы могут регистрировать себя в Windows как стандартное средство обработки архивов, даже не спрашивая у вас разрешения. Если это произошло, а вы хотите снова связать с архивами программу WinRAR, выберите пункт Установки... в меню Настройки, перейдите на вкладку Интеграция, выберите форматы архивов, с которыми хотите ассоциировать WinRAR, и нажмите <Enter>.

Как установить WinRAR в неинтерактивном режиме

Если нужно установить WinRAR на большое количество компьютеров, то отвечать при каждой установке на одни и те же вопросы довольно утомительно. В этом случае можно установить WinRAR с параметрами по умолчанию, пропустив все вопросы. Для этого необходимо запустить дистрибутив WinRAR с ключом -s.


Лицензионное соглашение

Лицензионное соглашение с конечным пользователем

Нижеследующее Лицензионное соглашение, относящееся к архиватору RAR (и его версии для Windows — WinRAR), в дальнейшем именуемым "программой", заключается между компанией win.rar GmbH, в дальнейшем именуемой "лицензиаром", и любым лицом, в дальнейшем именуемым "пользователем", кто устанавливает программу, получает к ней доступ или использует её каким-либо иным способом.

1. Автором RAR и WinRAR и владельцем авторских прав на программу является Александр Л. Рошал. Лицензиаром и исключительным общемировым владельцем прав на использование программы, включая права на её воспроизведение, распространение и публикацию в любой форме, является компания win.rar GmbH, Marienstraße 12, 10117, Берлин, Германия.

2. Программа распространяется по принципу "попробуй перед тем, как купить". Это означает, что вы можете использовать программу бесплатно на протяжении испытательного периода длительностью не более 40 дней. По истечении этого периода пользователь обязан приобрести лицензию, чтобы продолжать использовать программу.

3. Пробную версию программы разрешается свободно распространять (кроме случаев, оговорённых ниже) лишь в том виде, в котором она поставляется, т.е. без каких бы то ни было изменений.

    1. Запрещается распространять отдельные части дистрибутива, за исключением компонентов UnRAR, без письменного разрешения владельца авторских прав.
    2. Запрещается распространять нелицензированную пробную версию программы в составе любого другого программного обеспечения без письменного разрешения владельца авторских прав. Предназначенная для загрузки программа должна оставаться в исходном немодифицированном установочном файле без каких-либо препятствий и условий для пользователя, например взимания платы за загрузку или требования от пользователя указывать свои контактные данные.
    3. Немодифицированный установочный файл WinRAR должен поставляться без каких-либо добавок. Любая его доукомплектация другими материалами запрещена. В частности, без письменного разрешения win.rar GmbH запрещается использовать любые программы для установки или загрузки комплектов ПО.
    4. При распространении пробной версии запрещается дополнять её программами для взлома, ключами и генераторами ключей, в том числе ссылками на них.
    5. Нарушение вышеуказанных условий немедленно и автоматически влечёт аннулирование разрешения на распространение программы.

4. Пробная версия программы может отображать напоминание о регистрации с предложением пользователю приобрести лицензию. В зависимости от версии и конфигурации программы, такое напоминание может содержать либо заранее сформированный текст и ссылки, загружаемые локально, либо веб-страницу, загружаемую из Интернета. Такая веб-страница может содержать инструкции о приобретении лицензии и другие материалы в соответствии с выбором лицензиара, в том числе рекламу. При открытии веб-страницы программа передаёт только те параметры, которые технически необходимы протоколу HTTP для открытия веб-страницы в обозревателе Интернета (браузере).

5. Программа распространяется по принципу "Как есть". Никаких гарантий, явных или подразумеваемых, не предусматривается. Вы используете программу на свой собственный риск. Ни автор, ни лицензиар, ни его уполномоченные агенты не несут никакой ответственности за потери данных, повреждения, убытки или любые другие виды потерь, связанные с правильным или неправильным использованием программы.

6. Предусмотрено два основных типа лицензий на использование программы:

    1. Однопользовательская лицензия. Пользователь приобретает одну лицензию на использование программы на одном компьютере.
      Домашние пользователи, купившие такую лицензию, могут использовать её на всех принадлежащих им компьютерах и мобильных устройствах (USB-накопителях, внешних жёстких дисках и т.п.).
      Корпоративные пользователи должны иметь по одной лицензии на каждый компьютер или мобильное устройство, где установлена программа.
    2. Многопользовательская лицензия. Приобретение нескольких лицензий даёт право использовать программу покупателю или его наёмному работнику на таком же количестве компьютеров.
      При работе в сетевом окружении (сервер/клиент) вы обязаны приобрести копию лицензии на каждый отдельный клиент (рабочую станцию), где программа установлена, используется, или к ней осуществляется доступ. Отдельная копия лицензии на каждый клиент (рабочую станцию) требуется вне зависимости от того, используется программа на этих станциях одновременно или в разное время. Например, если требуется, чтобы доступ к программе в сети имели девять разных клиентов (рабочих станций), необходимо приобрести девять копий лицензии.

      Пользователь, купивший лицензию, получает неэксклюзивное право на использование программы в любых легальных целях на том количестве компьютеров, на которое приобретена лицензия.

7. Кроме стоимости лицензии не предусматривается никаких дополнительных лицензионных отчислений, связанных с созданием и распространением архивов RAR, томов, самораспаковывающихся архивов и самораспаковывающихся томов. Легальные владельцы лицензии могут использовать свои копии программы для создания архивов и самораспаковывающихся архивов и распространения этих архивов без дополнительных авторских отчислений.

8. Лицензированная копия программы не может быть сдана в аренду или дана напрокат, но может быть навсегда передана в полном комплекте другому лицу, если получатель согласен со всеми условиями этого Лицензионного соглашения.

9. Информация о покупке лицензии находится в файле order.htm.

10. Запрещается использовать, копировать, эмулировать, клонировать, сдавать в аренду, давать напрокат, продавать, изменять, декомпилировать, дизассемблировать, передавать лицензированную программу или её часть иначе, чем это описано в данном Лицензионном соглашении. Любое подобное неавторизованное использование приводит к немедленному и автоматическому прекращению действия этого Лицензионного соглашения и может повлечь за собой уголовное и/или гражданское преследование.

Без письменного разрешения запрещается использовать двоичный код RAR, двоичный код WinRAR, исходные тексты UnRAR и двоичный код UnRAR для реконструирования алгоритма сжатия RAR, который является собственностью автора.

Программа может использовать компоненты, разработанные другими компаниями, или авторское право на которые принадлежит другим компаниям. Подробности указаны в разделе "Благодарности" в справочном руководстве WinRAR или в текстовом файле acknow.txt в комплекте других версий RAR.

11. Данное Лицензионное соглашение целиком и полностью соответствует закону Германии. Если вы коммерсант, исключительная юрисдикция по поводу любых диспутов, связанных с этим Лицензионным соглашением или его правомерностью, принадлежит судам по месту регистрации офиса win.rar GmbH в Берлине, Германия.

12. Установка и использование программы свидетельствует о вашем согласии с условиями данного Лицензионного соглашения. Если вы не согласны с условиями Лицензионного соглашения, то должны удалить все файлы программы со своих устройств хранения информации и отказаться от дальнейшего использования программы.


О покупке

О покупке программы

Если вы хотите использовать WinRAR и RAR по окончании 40-дневного испытательного периода, вам необходимо приобрести лицензию у одного из региональных распространителей. Зарегистрироваться в онлайн-режиме или ознакомиться с новейшим списком распространителей можно на сайте WinRAR.

После получения от вас оплаты мы вышлем вам регистрационный ключевой файл, соответствующий указанной вами регистрационной строке. Пожалуйста, указывайте при покупке лицензии действующий адрес электронной почты, так как он будет использован для отправки вам ключа.

В письме с подтверждением регистрации вы найдёте все необходимые инструкции, поэтому просто следуйте им. Ниже изложено краткое описание процедуры регистрации, однако инструкции в письме более свежие, и их следует принимать во внимание в первую очередь.

Если вы используете WinRAR, скопируйте ключевой файл (rarreg.key) в папку с WinRAR или в папку %APPDATA%\WinRAR. По умолчанию папка с WinRAR это "C:\Program Files\WinRAR", но в вашей системе путь может быть иным (если он был изменён при установке WinRAR). Кроме того, для регистрации можно перетащить ключевой файл на окно WinRAR.

Если ключ заархивирован (находится внутри файла .rar или .zip), перед копированием извлеките файл rarreg.key из архива. Если имя архива – rarkey.rar, то есть другой способ установить ключевой файл: нужно открыть такой архив в WinRAR и ответить "Да" на запрос.


Добавить ярлык

Здесь вы можете указать параметры нового ярлыка, который будет создан SFX-архивом после распаковки. Это окно содержит следующие поля:

Место создания ярлыка

· На рабочем столе

Ярлык будет создан на рабочем столе Windows.

· В меню "Пуск"

Ярлык будет создан в меню кнопки "Пуск".

· В меню "Пуск/Программы"

Ярлык будет создан в меню кнопки "Пуск" в пункте "Программы".

· В папке "Автозагрузка"

Ярлык будет создан в папке автозагрузки Windows.

Параметры ярлыка

· Имя файла, для которого будет создан ярлык

Имя извлекаемого из архива файла, для которого нужно создать ярлык.

· Папка, в которую будет помещён ярлык

Папка, в которой должен быть создан ярлык. Если указанная папка не существует, то она будет создана SFX-архивом.

· Описание ярлыка

Текст, описывающий создаваемый ярлык.

· Имя ярлыка

Имя файла .LNK (ярлыка), создаваемого SFX-архивом.

Значок ярлыка

Имя файла со значком, ассоциированным с ярлыком. Если оставить пустым, то будет использоваться стандартный значок. Если имя файла со значком не содержит полный путь, SFX-архив будет искать значок в папке с распакованными файлами.

Обязательно требуется указывать только место создания ярлыка и имя файла, для которого будет создан ярлык. Остальные параметры факультативные.


Папка %APPDATA%\WinRAR

Старые версии WinRAR хранили свои дополнительные файлы (регистрационный ключ, файл экспортированных настроек settings.reg, темы, файл с журналом) в той же папке, что и исполняемый файл WinRAR. В Vista и последующих версиях Windows хранить такие данные в папке программы не рекомендуется. При попытке это сделать даже возможен сбой в работе программы. Программные данные рекомендуется располагать во вложенных папках в так называемой папке %APPDATA%.

Путь к %APPDATA% зависит от версии Windows. Чтобы открыть папку %APPDATA%, сделайте следующее: запустите Проводник Windows или откройте окно "Мой компьютер", введите в строке адреса %APPDATA% и нажмите Enter. Дополнительные файлы WinRAR хранятся во вложенной папке "WinRAR" в %APPDATA%. Чтобы быстро перейти в папку данных WinRAR, можно ввести в адресной строке Проводника %APPDATA%\WinRAR.

Обращаться к папке %APPDATA%\WinRAR вручную требуется нечасто. Например, это может понадобиться для копирования файла settings.reg на другой компьютер или чтобы просмотреть файл с журналом в какой-либо внешней программе.

Обратите внимание, что WinRAR пытается найти регистрационный ключ и файл settings.reg как в %APPDATA%\WinRAR, так и программной папке WinRAR, но сначала — в %APPDATA%\WinRAR.

Если вам требуется изменить расположение папки %APPDATA%\WinRAR, добавьте строковый параметр "AppData" с новым путём к дополнительным файлам WinRAR в ключ реестра HKEY_CURRENT_USER\Software\WinRAR\Paths.


Типы архивов

RAR или ZIP?

Архивный формат RAR5

Поддержка архивов других форматов

Непрерывные архивы

Самораспаковывающиеся (SFX) архивы

Многотомные архивы (из нескольких частей)

Тома для восстановления

Шифрование

Комментарий архива

Защита архивов от повреждений

Блокировка архивов

Выбор оптимальных параметров архивации


Архивирование с паролем

В этом окне можно ввести пароль для создаваемого архива. Введённый пароль будет действовать только в течение одной текущей операции архивирования. Если вместо этого вы хотите задать глобальный пароль, то воспользуйтесь командой "Установить пароль по умолчанию" в меню "Файл".

Если параметр "Отображать пароль при вводе" выключен, то придётся ввести пароль дважды, чтобы гарантировать правильность ввода.

Если включён параметр “Шифровать имена файлов”, то будет зашифроваться не только содержимое файлов, но и другие значимые области архива (имена, размеры, атрибуты, комментарии и другие блоки), что повышает степень защиты информации. У такого архива без указания пароля невозможно даже просмотреть список содержащихся в нём файлов. Этот параметр доступен только для архивов RAR, для архивов ZIP он не поддерживается.

Параметр "Традиционное (устаревшее) шифрование ZIP" доступен только при добавлении файлов в архивы ZIP. Как понятно из названия, он включает устаревший алгоритм шифрования ZIP. Если этот параметр выключен, архивы ZIP шифруются с помощью более надёжного алгоритма AES-256, но он может быть несовместим с некоторыми старыми утилитами для распаковки архивов ZIP.

Если вы уже сохраняли какие-то пароли, то они доступны в выпадающем списке в поле ввода пароля, а с помощью функции автозавершения. Нажмите кнопку "Упорядочить пароли...", чтобы открыть окно управления паролями, в котором можно сохранять свои часто используемые пароли.

Если сохранённые пароли защищены главным паролем, то для доступа к ним нужно ввести его и нажать OK. Если введённый пароль отличается от главного пароля, то он считается обычным паролем для операций с архивами.


Окно "Параметры операции"

Это окно позволяет оперативно, не прерывая архивирования, извлечения или тестирования, изменять состояние параметра По окончании, т.е. здесь можно указать, что после завершения операции компьютер будет выключен, перезагружен, либо переведён в состояние гибернации или сна.

Кроме того, при операциях архивирования здесь можно изменить режим сжатия, выбрав отличный от указанного при запуске архивирования. Исключение — режим Без сжатия. Если архивирование было начато в этом режиме, переключиться на любой другой не удастся, равно как нельзя переключиться с любого другого режима на режим Без сжатия, если архивирование было начато с использованием сжатия.


Дополнительные параметры сжатия

Как правило, изменять параметры в этом окне не требуется, надёжнее, чтобы оптимальные настойки сжатия WinRAR выбирал автоматически. Имейте в виду, что неправильное использование параметров в этом окне может привести к значительному снижению скорости работы архиватора и ухудшению степени сжатия, поэтому изменяйте здесь что-либо, только если чётко понимаете, что вы делаете.

Большинство указанных ниже параметров поддерживаются только в архивах формата RAR4. Ни одна из этих настроек не доступна для формата ZIP. Для архивов RAR5 можно включать только дельта-сжатие и сжатие 32-разрядных исполняемых файлов.

Это окно содержит следующие параметры:

Сжатие текста

· Автовыбор / Принудительно / Запретить

Алгоритм сжатия текста позволяет улучшить степень сжатия обычных текстовых данных ценой снижения скорости упаковки и распаковки, а также невозможности использовать несколько процессорных ядер. Поэтому по умолчанию для этого параметра выбрано значение Запретить. Если изменить его на Автовыбор, то алгоритм сжатия текста будет выбираться автоматически для данных соответствующего типа. При выборе значения Принудительно алгоритм сжатия текста будет применяться ко всем данным, но будьте готовы к более низкой скорости упаковки и распаковки, чем при использовании общего алгоритма сжатия.

· Порядок предсказания

Здесь можно установить порядок предсказания для алгоритма PPM (ядра текстового сжатия в RAR). Допустимый диапазон — от 2 до 63. Более высокое значение обычно слегка улучшает степень сжатия избыточных данных, но только если имеется достаточно памяти для PPM. Когда памяти не хватает, результат может быть отрицательным. Чем выше значение порядка, тем медленнее сжатие и распаковка. Если установлено значение 0 (ноль), порядок выбирается автоматически.

· Используемая память, МБ

Память в мегабайтах, выделяемая для алгоритма PPM. Допустимый диапазон — от 1 до 128. Более высокое значение может улучшить степень сжатия, но учтите, что для распаковки PPM требуется столько же памяти, сколько использовалось при упаковке. Поэтому если выделить слишком много памяти при создании архива, то могут возникнуть сложности с его распаковкой на другом компьютере с меньшим объёмом памяти. Если установлено значение 0 (ноль), объём памяти выбирается автоматически.

Сжатие аудио

· Автовыбор / Принудительно / Запретить

В режиме Автовыбор WinRAR анализирует обрабатываемые данные и в зависимости от них решает, когда следует использовать алгоритм сжатия аудио, причём только если выбран Обычный, Хороший или Максимальный метод сжатия. При выборе параметра Принудительно алгоритм сжатия аудио будет применяться ко всем обрабатываемым данным. Включать принудительное сжатие аудио имеет смысл только в случае, когда все упаковываемые файлы целиком состоят из необработанных аудиоданных. Параметр Запретить полностью отключает алгоритм сжатия аудио.

Алгоритм сжатия аудио предназначен для упаковки необработанных аудиоданных (например несжатых файлов WAV). На степень упаковки уже сжатых аудиофайлов (M4A, MP3, FLAC, APE и т.п.) он не влияет.

· Байтовые каналы

Количество байтовых каналов. Допустимый диапазон — от 1 до 31.

WinRAR разделяет многобайтовые каналы на байты, например два 16-битовых аудиоканала будут считаться за четыре канала по одному байту каждый. Если установлено значение 0 (ноль), количество выбирается автоматически.

Сжатие полноцветной графики

· Автовыбор / Принудительно / Запретить

В режиме Автовыбор WinRAR анализирует обрабатываемые данные и в зависимости от них решает, когда следует использовать алгоритм сжатия графики True Color, причём только если выбран Обычный, Хороший или Максимальный метод сжатия. При выборе параметра Принудительно алгоритм сжатия полноцветной графики будет применяться ко всем обрабатываемым данным. Включать принудительное сжатие полноцветной графики имеет смысл только в случае, когда все упаковываемые файлы целиком состоят из данных True Color (RGB). Параметр Запретить полностью отключает алгоритм сжатия полноцветной графики.

Алгоритм сжатия полноцветной графики предназначен для упаковки необработанных данных с RGB-представлением цвета (например 24-битовых файлов BMP). На степень упаковки уже сжатых графических файлов (JPG, PNG и т.п.) он не влияет.

Алгоритм сжатия исполняемых файлов x86

Позволяет достигать более плотного сжатия исполняемых файлов архитектуры Intel x86 с помощью специально оптимизированного для таких данных алгоритма. Может быть эффективным как для 32-, так и для 64-разрядных исполняемых файлов x86.

Алгоритм сжатия исполняемых файлов Itanium

Позволяет достигать более плотного сжатия исполняемых файлов архитектуры Intel Itanium с помощью специально оптимизированного для таких данных алгоритма.

Алгоритм дельта-сжатия

Позволяет достигать более плотного сжатия структурированных табличных данных с помощью специально оптимизированного для таких данных алгоритма.

Кнопка По умолчанию возвращает все параметры этого окна в стандартные значения.


Элементы контекстного меню

Группа параметров Команды в контекстном меню Проводника позволяет выбрать элементы, добавляемые в контекстные меню Проводника Windows. Эти элементы выводятся в меню при щелчке правой кнопкой мыши на файле или значке архива в Проводнике или на рабочем столе.

Параметры в группе Контекстное меню при перетаскивании позволяют удалять команды команды архивирования и распаковки WinRAR из контекстного меню, отображаемого при перетаскивании файлов с нажатой правой кнопкой мыши. По умолчанию эти параметры включены, поэтому WinRAR при перетаскивании с нажатой правой кнопкой мыши предлагает упаковывать файлы и распаковывать архивы, используя целевую папку как место назначения.

Параметры в группе Место обнаружения SFX-архивов влияют на обработку SFX-архивов в контекстных меню. Проверка содержимого исполняемого файла и выяснение, является ли он самораспаковывающимся (SFX) архивом, вызывает некоторую задержку при щелчке правой кнопкой мыши на любом файле с расширением .exe, так как WinRAR должен прочитать и проанализировать данные файла, чтобы определить, SFX это или нет. Для быстрых локальных жёстких дисков задержка пренебрежимо мала, но на медленных сетевых дисках она может быть заметна. Параметры в этой группе позволяют разрешить или запретить проверку SFX индивидуально для локальных жёстких дисков, сетевых дисков и других носителей вроде CD и USB. Если эти параметры выключены, то при щелчке правой кнопкой мыши на SFX-архиве в контекстном меню не будет никаких пунктов, относящихся к SFX. Поэтому отключайте эти параметры, только если у вас в самом деле возникают задержки при вызове контекстного меню на EXE-файлах.

Если щёлкнуть правой кнопкой мыши по одному архиву, то контекстное меню Проводника Windows по умолчанию будет содержать только команды извлечения. Это можно изменить, указав одну или несколько разделяемых пробелами масок в поле Всегда показывать команды архивирования для в окне Элементы контекстного меню, вызываемом на вкладке Интеграция в настройках WinRAR. Таким образом, команды архивирования для файлов указанных типов будут отображаться всегда, даже есть файл распознан как архив. Если вы хотите, чтобы команды архивирования и извлечения присутствовали в контекстных меню всех архивов, то укажите в этом поле звёздочку ("*").


Окно "Определение размеров томов"

Это окно позволяет настроить список предварительно установленных размеров томов, связанный с полем Разделить на тома размером в окне имени и параметров архива.

В группе Предустановленные размеры указывается, какие значения будут отображаться в списке. Если нужного вам значения нет среди предложенных, можно указать до четырёх дополнительных элементов в группе Пользовательские размеры — просто введите название и размер для каждого элемента. Название – это любая короткая строка текста, а размер – число в байтах. При желании название можно не указывать.

Параметр Строка 'Автоопределение' в группе Другие элементы позволяет включать/отключать вывод в списке элемента Автоопределение. Если при архивировании на сменные носители вы никогда не используете автоматическое определение размеров томов, то этот параметр можно отключить, чтобы сделать выпадающий список короче.

Параметр Элементов в истории определяет количество элементов, ранее указанных пользователем, которые выводятся в верхней части списка. Если запоминать введённые вручную размеры томов не нужно, установите этот параметр в ноль. Запоминается не более девяти элементов.


Ввод пароля по умолчанию

В этом окне можно ввести пароль по умолчанию, который будет применяться в операциях добавления, извлечения, тестирования и просмотра. Если параметр Отображать пароль при вводе выключен и для архивирования необходимо ввести пароль, то потребуется указать тот же пароль ещё раз в поле подтверждения, чтобы гарантировать правильность набора.

Если включить параметр Шифровать имена файлов, то будут шифроваться не только данные в файлах, но и другие значимые области архива: имена файлов, размеры, атрибуты, комментарии и другие блоки, благодаря чему достигается более высокая степень защиты от несанкционированного доступа. Если архив зашифрован с этим параметром, то без пароля не удастся просмотреть даже список содержащихся в нём файлов. Шифрование имён файлов действует только при упаковке в архивы RAR, параметр игнорируется при распаковке данных с помощью пароля по умолчанию и при упаковке в ZIP.

Параметр Традиционное (устаревшее) шифрование ZIP доступен только при добавлении файлов в архивы ZIP. Включите его, чтобы использовать устаревший алгоритм шифрования ZIP. Если этот параметр выключен, то архивы ZIP шифруются с помощью алгоритма AES-256, который значительно более надёжен, но может быть несовместим со старыми программами распаковки ZIP.

Если в окне ввода пароля вы включили параметр Использовать для всех архивов и указали в качестве пароля пустую строку, команды извлечения и тестирования будут пропускать все зашифрованные файлы и архивы. Кроме того, пока этот параметр не будет выключен, все попытки открыть зашифрованные файлы и архивы будут блокироваться. Данный режим может пригодиться, если вы собираетесь распаковать группу архивов без вмешательства пользователя и хотите избежать запросов пароля. Для непустых паролей параметр Использовать для всех архивов недоступен, так как непустые используемые по умолчанию пароли применяются ко всем архивам автоматически, без дополнительных настроек.

Если вы уже сохраняли какие-то пароли, доступ к ним можно получить либо с помощью выпадающего списка, связанного с полем ввода пароля, либо воспользовавшись функцией автозавершения. Нажмите кнопку Упорядочить пароли..., чтобы открыть окно управления паролями, в котором можно сохранять свои часто используемые пароли.

Если сохранённые пароли защищены главным паролем, то для доступа к ним нужно ввести главный пароль и нажать OK. Если введённый пароль отличается от главного пароля, то WinRAR будет считать его обычным паролем для операций с архивами.


Выполнение операции с архивом

Сейчас выполняется операция с архивом. Дождитесь её завершения или нажмите кнопку Отмена, чтобы немедленно прекратить операцию. Во время архивирования или извлечения также можно воспользоваться кнопками Фоновый режим и Пауза. Кнопка Фоновый режим сворачивает WinRAR в область уведомлений (системный лоток). По окончании текущей операции окно WinRAR восстановится автоматически, но его можно восстановить и принудительно, щёлкнув по значку WinRAR в области уведомлений. Кнопка Пауза приостанавливает текущую операцию; чтобы её возобновить, нажмите кнопку Продолжить.

При архивировании и извлечении в верхней части командного окна выводится индикатор хода выполнения, показывающий степень обработки текущего файла.

При архивировании ниже отображается ещё один индикатор. Его вид зависит от параметра Индикаторы Windows в настройках WinRAR. Если этот параметр выключен, то при архивировании индикатор будет трёхцветным: сжатые данные отображаются жёлтым цветом, а прочитанные — светло-серым, что позволяет наглядно оценить текущую степень сжатия файлов. Если параметр Индикаторы Windows включён, то индикаторы будут двухцветными, но в любом случае общая степень сжатия также выводится на отдельной строке этого окна.

Во время архивирования, извлечения или тестирования можно нажать кнопку Параметры операции…, чтобы оперативно изменить состояние параметра По окончании, выбрав выключение компьютера, перезагрузку, либо перевод его в состояние гибернации или сна по завершении операции. При архивировании здесь также можно изменить метод сжатия (за исключением режима Без сжатия: переключиться на этот режим или выйти из него, если он был выбран при запуске архивации, нельзя).


Окно установки пути и параметров извлечения: Дополнительно

Здесь доступны следующие параметры:

Время файлов

· Восстанавливать время изменения/создания/последнего доступа

Файловые системы Windows сохраняют три разных поля времени для каждого файла: время последнего изменения, создания и последнего обращения к файлу. По умолчанию WinRAR сохраняет только время последнего изменения, однако с помощью параметров времён файлов на вкладке Время в окне архивирования можно включить сохранение времени создания и последнего обращения. Следует иметь в виду, что даже когда в архиве присутствует нужное вам поле времени, в окне извлечения необходимо выбрать соответствующий параметр, если нужно, чтобы это время было восстановлено у файлов при распаковке. Наличие этих параметров зависит от формата архива, некоторые форматы их не поддерживают.

Атрибуты

· Снимать у файлов атрибут "Архивный"

У всех извлечённых файлов будет снят атрибут "Архивный". Этот параметр предназначен для использования в операциях резервного копирования данных.

· Восстанавливать права доступа

Этот параметр имеет значение только для файловой системы NTFS и позволяет восстанавливать информацию о владельце файла, группе, контроле доступа и аудите, если такие сведения были предварительно сохранены в архиве. Для сохранения такой информации нужно при создании архива включить параметр Сохранять данные о правах доступа на вкладке Дополнительно в окне архивирования. Чтобы воспользоваться этой возможностью, вы должны обладать соответствующими системными правами. Обработка информации о правах доступа может замедлить операцию архивирования, поэтому включайте данный параметр, только если вы понимаете его назначение и вам это действительно необходимо. Домашним пользователям обработка данных о правах доступа обычно не нужна.

Поддерживается только для архивов RAR.

· Восстанавливать атрибут "Сжатый"

Этот параметр позволяет восстанавливать NTFS-атрибут "Сжатый" у извлекаемых из архива файлов. WinRAR всегда сохраняет данный атрибут при создании архива, но не восстанавливает его при распаковке, если только не указан этот параметр.

Поддерживается только для архивов RAR.

Пути файлов

· Извлекать с относительными путями

Этот режим используется по умолчанию. Если вы находитесь в какой-либо вложенной папке в архиве, открытом в WinRAR, часть пути к этой папке, включая её имя, будет удалена из извлекаемых путей файлов. Например, если вы, находясь в архивной папке Backup\MyData, извлечёте имеющуюся там папку Images, то она будет распакована как Images, а не как Backup\MyData\Images.

Если вы находитесь в корневой папке архива или начинаете извлечение из контекстного меню, данный режим работает точно так же, как Извлекать с полными путями.

· Извлекать с полными путями

Содержимое архива будет извлечено в папку назначения вместе с сохранённой в архиве информацией о путях. В отличие от режима Извлекать с относительными путями, информация о путях извлекается полностью, вне зависимости от того, в какой из архивных папок вы находитесь.

· Извлекать файлы без путей

Выбранные файлы из корневой папки архива и его выбранных вложенных папок будут извлечены в папку назначения без учёта информации о путях.

· Извлекать с абсолютными путями

Если при создании архива был использован режим Сохранять полные пути, включая букву диска, выбираемый в окне архивирования на вкладке Файлы, и вы включили параметр Извлекать с абсолютными путями, то распакованные файлы будут записны в их исходные папки и диски. Будьте осторожны! Не включайте этот параметр, если не уверены, что в архиве нет "злонамеренных" файлов. Более подробную информацию о потенциальных преимуществах и опасностях, присущих режиму Извлекать с абсолютными путями, см. в описании ключа -ep3, являющегося эквивалентом этого параметра WinRAR для командной строки.

Поддерживается только для архивов RAR и ZIP.

Удаление архива

· Не удалять

Не удалять архив после распаковки.

· Запрашивать подтверждение

Выдавать запрос на подтверждение удаления архива после распаковки.

· Удалять всегда

После распаковки удалять архив без предупреждения.

Архив удаляется, только если он распакован без ошибок, а для извлечения были выбраны все находящиеся в нём файлы. При успешной распаковке многотомного архива удаляются все его тома.

Обратите внимание, что вы можете сохранить значение этого параметра как используемое по умолчанию, нажав кнопку Сохранить установки на вкладке Общие окна извлечения, и это также повлияет на работу в режиме командной строки и на команды извлечения в контекстных меню. Поэтому чтобы не потерять данные из-за удаления архива после распаковки, следует с осторожностью использовать режимы Запрашивать подтверждение и особенно Удалять всегда.

Разное

· Извлекать в фоновом режиме

Сворачивать WinRAR в область уведомлений при запуске извлечения.

· Ждать, если работает другая копия WinRAR

Если в данный момент в системе запущена ещё одна копия WinRAR, создающая, модифицирующая или распаковывающая какой-либо архив, и включён этот параметр, то операция будет начата, только когда другая копия WinRAR завершит свою работу или будет приостановлена. Когда требуется выполнить серию операций по архивированию или распаковке данных, такое последовательное выполнение способно снизить нагрузку на диски и повысить общую производительность.

Чтобы отменить этот параметр для текущей операции, нажмите кнопку Продолжить в окне хода операции — WinRAR выйдет из состояния ожидания вне зависимости от того, работают ли сейчас другие копии WinRAR.

Не поддерживается для архивов 7z.

Разрешить абсолютные пути в символических ссылках

Если этот параметр выключен, команда извлечения пропускает символические ссылки, которые указывают на объекты вне папки назначения, содержат абсолютные пути, чрезмерное количество элементов ".." в целевом объекте или другие потенциально опасные параметры ссылки. Ссылки, указывающие на папки вне целевой папки извлечения, могут представлять угрозу безопасности. Разрешайте их извлечение, только если уверены, что содержимое архива безопасно, например когда это созданная вами же резервная копия данных.

Ссылки, которые WinRAR считает безопасными, извлекаются всегда – вне зависимости от того, включён этот параметр или нет.

Разрешить потенциально несовместимые имена

Файловая система NTFS позволяет давать файлам имена с пробелами и точками в конце, однако множество Windows-программ не умеют корректно обращаться с такими именами. Если этот параметр выключен, то WinRAR при извлечении удаляет обнаруженные пробелы и точки в конце имён файлов.


Окно установки пути и параметров извлечения: Общие

Эта часть окна распаковки позволяет выбрать папку назначения и параметры для извлечения файлов. По умолчанию папка получает то же имя, что и архив (без расширения) и размещается в текущей папке, но вы можете изменить это в окне Параметры архивации. В поле Путь для извлечения следует ввести нужный путь (если его ещё не существует, то он будет создан) или выбрать папку в панели дерева папок.

В этом окне по мере ввода имени папки WinRAR пытается автоматически открывать подходящую папку в дереве папок, но с небольшой задержкой (около полсекунды), если вводимый путь начинается с буквы диска и если такой автоматический выбор длится не слишком долго. Если папка не существует, то будет выбрана родительская папка или другая папка, наиболее похожая на указанную. Кроме того, можно принудительно начать поиск введённого имени папки нажатием кнопки Показать, что бывает нужно, когда имя было автоматически подставлено программой при открытии окна, либо автоматический выбор был прерван из-за низкой скорости.

С помощью кнопки Создать папку можно создать новую папку. Она будет создана в папке, выбранной в окне с деревом или указанной в поле Путь для извлечения, в зависимости от того, что вы изменили последним. Клавиша F2 позволяет переименовывать папки в окне с деревом, Del — удалять их, а F5 — обновлять содержимое этого окна.

При желании можно изменять размер окна извлечения. Чтобы увеличить область со списком папок, перетащите мышью границу окна до нужного вам размера. Новые размеры окна запоминаются и используются в дальнейшем.

В этом окне также доступно несколько дополнительных параметров:

Режим обновления

· Извлечь и заменить файлы (действие по умолчанию)

Извлекаются все выбранные файлы.

· Извлечь и обновить файлы

Извлекаются только те из выбранных файлов, которых нет в папке назначения или копии которых в архиве новее, чем файлы на диске.

· Обновить только существующие файлы

Извлекаются только те из выбранных файлов, которые имеются в папке назначения, но их копии в архиве новее, чем файлы на диске. Файлы, которых нет на диске, извлекаться не будут.

Режим перезаписи

· Выдавать запрос перед перезаписи (действие по умолчанию)

Перед попыткой перезаписи файла будет выдаваться запрос.

· Перезаписывать все файлы без запроса

Файлы перезаписываются без запроса.

· Пропускать существующие файлы

Уже имеющиеся на диске файлы перезаписываться не будут.

· Переименовывать автоматически

Автоматически переименовывать извлекаемые файлы, если файл с таким же именем уже существует. При переименовании файлы получают имена вида filename(N).txt, где filename.txt – исходное имя файла, а N – номер.

Разное

· Распаковать архивы во вложенные папки

Этот параметр доступен только при распаковке сразу нескольких архивов. Распакованное содержимое каждого архива будет помещаться в отдельную вложенную папку, имя которой генерируется на основании имени архива.

· Не удалять файлы, извлечённые с ошибками

Если включено, WinRAR не будет удалять с диска файлы, извлечённые с ошибками (по умолчанию эти файлы удаляются). Такие файлы могут возникнуть, например, из-за повреждения архива. С помощью данного параметра можно попытаться получить из повреждённого файла хоть какую-то полезную информацию.

· Показать файлы в Проводнике

По окончании распаковки WinRAR откроет окно Проводника Windows с содержимым папки, в которую были извлечены файлы.

· Сохранить установки

Нажмите эту кнопку, чтобы сохранить текущее состояние обеих частей окна извлечения (вкладки Общие и Дополнительно). При следующем вызове окна извлечения сохранённое состояние будет восстановлено как используемое по умолчанию. Запоминаются все параметры, кроме целевого пути. Если требуется указать путь назначения по умолчанию, воспользуйтесь окном параметров сжатия.


Ввод пароля для извлекаемого файла

Вы пытаетесь извлечь зашифрованный файл или просмотреть содержание зашифрованного архива. Введите пароль или откажитесь от выполнения операции.

При распаковке сразу нескольких архивов можно включить параметр Для всех архивов, чтобы применить указанный пароль ко всем архивам. Если обрабатывается только один архив, этот параметр недоступен. Ещё одно применение данного параметра – пропуск зашифрованных архивов. Просто укажите в качестве пароля пустую строку и включите параметр Для всех архивов.

Если вы уже сохраняли какие-то пароли, доступ к ним можно получить либо с помощью выпадающего списка, связанного с полем ввода пароля, либо воспользовавшись функцией автозавершения. Нажмите кнопку Упорядочить пароли..., чтобы открыть окно управления паролями, в котором можно сохранять свои часто используемые пароли.

Если сохранённые пароли защищены главным паролем, то для доступа к ним нужно ввести главный пароль и нажать OK. Если введённый пароль отличается от главного пароля, то WinRAR будет считать его обычным паролем для операций с архивами.


Имя и параметры архива: Дополнительные параметры

NTFS

· Сохранять данные о правах доступа

Только для файловой системы NTFS. Позволяет сохранять данные о владельце, группе, правах доступа и аудит-информацию, если вы обладаете для этого достаточными правами. Обработка данных о правах доступа может замедлить работу, поэтому включайте этот параметр лишь тогда, когда это действительно необходимо (так, домашние пользователи в этом обычно не нуждаются). Обратите внимание, что файловая безопасность Windows NT имеется только в разделах с NTFS.

Поддерживается только для архивов RAR.

· Сохранять файловые потоки

Только для файловой системы NTFS. Позволяет сохранять в архиве альтернативные потоки данных, связанные с файлами на диске с NTFS. Может потребоваться, если вы пользуетесь какими-либо программами, хранящими данные в альтернативных потоках, и нужно сохранить эти потоки. Для файлов с установленным NTFS-атрибутом "Зашифрованный" потоки не сохраняются.

Поддерживается только в архивах RAR.

Сохранять символические ссылки как ссылки

Хранить символические ссылки и точки соединения NTFS как ссылки, не архивируя содержимое файлов или папок. При извлечении из архива такие элементы восстанавливаются как символические ссылки или как точки соединения. Чтобы можно было создавать символические ссылки при извлечении, нужно запускать WinRAR от имени администратора. Символические ссылки, которые указывают на объекты вне целевой папки, содержат абсолютные пути или чрезмерное количество элементов ".." в целевом объекте, а также другие потенциально опасные присущие ссылкам параметры, могут представлять угрозу безопасности. Поэтому такие ссылки извлекаются, только если включён параметр Разрешить абсолютные пути в символических ссылках в окне извлечения, либо в командной строке указан ключ -ola.

Поддерживается только в архивах RAR5.

Сохранять жёсткие ссылки как ссылки

Если среди архивируемых файлов содержится несколько жёстких ссылок NTFS, первая жёсткая ссылка добавляется в архив как обычный файл, а остальные ссылки из того же набора — как ссылки на этот первый файл. При извлечении таких файлов WinRAR будет создавать жёсткие ссылки, а не обычные файлы.

Когда архив уже создан, в нём нельзя удалять или переименовывать первую жёсткую ссылку, иначе будет невозможно извлечь последующие ссылки. Если изменить первую ссылку, то последующие ссылки при извлечении также получат изменённое содержимое. Для успешного извлечения последующих ссылок команда извлечения должна быть сначала вызвана для первой жёсткой ссылки.

Поддерживается только в архивах RAR5.

Тома

· Пауза после каждого тома

По умолчанию WinRAR запрашивает подтверждение на создание или распаковку тома только при использовании съёмных носителей. Если включить данный параметр, то запросы на подтверждение будут выдаваться всегда. Это может пригодиться при недостатке места на диске, когда каждый созданный архивный том нужно сразу же вручную копировать на другое устройство.

Поддерживается только для томов RAR.

· Старый стиль именования томов

По умолчанию архивные тома RAR получают имена вида том.partNNN.rar, где NNN — номер тома. Для формата RAR4 этот параметр позволяет использовать старую схему именования томов на основе расширений файлов: первый том получает расширение .rar, а все последующие тома нумеруются от .r00 до .r99. Архивы RAR5 не поддерживают ни этот параметр, ни именование на основе расширений файлов.

· Томов для восстановления

Это поле доступно только при создании многотомного архива RAR и позволяет указать, сколько томов для восстановления создать для этого архива. К числовому значению можно добавить знак процента (%) — тогда количество создаваемых файлов .rev будет вычисляться как процент от общего числа томов многотомного архива RAR. С помощью каждого тома для восстановления можно воссоздать один любой отсутствующий архивный том. Подробности об этой функции см. здесь.

Система

· Архивировать в фоновом режиме

Если включено, при запуске архивации WinRAR будет сворачиваться в область уведомлений панели задач (рядом с часами).

· Ждать, если работает другая копия WinRAR

Если в текущий момент в системе запущена ещё одна копия WinRAR, создающая, модифицирующая или распаковывающая какой-либо архив, и включён этот параметр, то операция будет начата, только когда другая копия WinRAR завершит работу или будет приостановлена. Если требуется выполнять серию операций по архивированию или распаковке данных, такое последовательное выполнение способно снизить нагрузку на диски и повысить общую производительность.

Отменить этот параметр для текущей операции можно кнопкой Продолжить в окне хода операции. Нажатие этой кнопки выводит WinRAR из состояния ожидания вне зависимости от того, работают другие копии или нет.

Данные для восстановления

Здесь можно указать объём данных для восстановления в процентах от общего размера архива. Чем больше размер таких данных, тем более серьёзные повреждения архива можно устранить с их помощью, но и тем сильнее увеличиваются размер архива и время на обработку, поэтому в большинстве случаев оптимальным будет 3–10%. Это значение используется только при включённом параметре Добавить данные для восстановления на вкладке Общие этого окна. Нулевое значение установить нельзя. Вместо этого, если данные для восстановления не нужны, выключите параметр Добавить данные для восстановления.

Параметры сжатия…

Открывает окно Дополнительные параметры сжатия, в котором можно настроить различные алгоритмы упаковки. Имейте в виду, что неправильные установки в этом окне способны значительно ухудшить работу архиватора, поэтому используйте их осторожно.

Параметры SFX…

Позволяет выбрать модуль самораспаковки и настроить ряд дополнительных параметров SFX, например путь назначения или заголовок окна. Обратите внимание, что параметры SFX можно задавать только для Windows-модулей с графическим интерфейсом (GUI), но не для консольных и отличных от Windows. Кнопка Параметры SFX доступна только при включённом параметре Создать SFX-архив на вкладке Общие в этом окне.

Сделанные настройки параметров SFX можно сохранить в профиле архивации; команды, описывающие параметры SFX, помещаются в комментарий архива.

· По окончании

Здесь можно указать действие, которое будет выполнено после завершения операции: отключение компьютера, перезагрузку, либо перевод в состояние гибернации или сна. Соответствующие функции управления электропитанием должны поддерживаться операционной системой.


Имя и параметры архива: Резервные копии

Параметры для резервного копирования

· Перед архивацией на сменный носитель очищать его содержимое

Перед созданием архива с целевого носителя будут удалены все файлы и папки. Если вы создаёте тома, то удаление происходит перед созданием нового тома, что даёт возможность архивировать на непустые сменные носители. При использовании этого режима вы должны быть уверены, что на целевых носителях нет нужной вам информации. Этот параметр применим только к сменным носителям, содержимое жёсткого диска им не удаляется.

· Добавлять только файлы с установленным атрибутом "Архивный"

Если включено, в архив будут добавлены только файлы с установленным атрибутом "Архивный". Папки добавляются вне зависимости от их атрибутов. Этот параметр полезен при резервном копировании.

· Снимать у файлов атрибут "Архивный" после упаковки

После успешной упаковки файлов у них будет снят атрибут "Архивный".

· Открывать совместно используемые файлы

Включать в обработку файлы, открытые для записи другими программами. Это опасный параметр, так как он позволяет заархивировать те файлы, которые в тот же момент могут быть изменены другой программой. Пользуйтесь этим параметром осторожно!

· Добавлять к имени архива окончание по маске

При создании архива добавляет к его имени строку с текущей датой. Это удобно при периодическом резервном копировании. Формат добавляемой строки задаётся маской. Подробности см. в описании ключа -ag.

· Сохранять предыдущие версии файлов

Если включено, то при добавлении в уже созданный архив файлов, которые там уже есть, предыдущие версии из архива не удаляются, а переименовываются. Старые версии файлов получают имена вида filename;n, где n — номер версии. Применимо только для архивов RAR.

При использовании этого параметра рекомендуется избегать имён в формате 'filename;n' среди добавляемых файлов. Такие имена могут привести к возникновению дублирующихся элементов, если старая версия с тем же именем либо существует в архиве, либо будет создана позже.


Имя и параметры архива: Комментарий

Здесь можно указать комментарий для создаваемого или обновляемого архива. Добавить комментарий можно двумя способами:

  1. указать имя файла с текстом комментария в поле Загрузить комментарий из файла
  2. ввести комментарий самостоятельно в расположенном ниже окне


Имя и параметры архива: Файлы

Добавляемые файлы

Имена файлов и папок, добавляемых в архив. Это поле автоматически заполняется списком файлов, выделенных в окне файлов WinRAR, но вы можете изменить этот список самостоятельно или нажать кнопку Добавить, чтобы выбрать дополнительные файлы.

Здесь допускается использовать маски-шаблоны — в этом случае WinRAR будет искать соответствующие маске файлы в текущей и вложенных папках. При указании нескольких масок разделяйте их пробелами. Если в маске содержатся пробелы, то она должна быть заключена в кавычки. Например, чтобы добавить в архив все файлы с расширениями .txt и .doc, а также файлы, соответствующие маске set 1.*, укажите:

*.txt *.doc "set 1.*"

Файлы для исключения из обработки

Маски и имена файлов, которые должны быть исключены из архивирования. Маски могут быть как в именах файлов, так и в их путях. При указании нескольких масок разделяйте их пробелами. Если в маске содержатся пробелы, то она должна быть заключена в кавычки. Например, чтобы исключить из обработки файл c:\temp\info.txt, все файлы .bak и .tmp, все папки temp и все файлы в папках temp, введите:

c:\temp\info.txt *.bak *.tmp *\temp\

Вводить имена файлов можно вручную или кнопкой Добавить, выбирая их в дереве папок.

Подробнее о синтаксисе масок исключения см. в описании ключа -x. В этом ключе используется тот же формат масок исключения, что и в поле Файлы, исключаемые из обработки.

Файлы для добавления в архив без сжатия

Маски и имена файлов, которые должны помещаться в архив без сжатия. Это может быть полезно, чтобы не тратить попусту время на попытку сжать уже сжатые файлы. Тем самым можно ускорить создание/обновление архивов, практически не жертвуя общей степенью сжатия. При указании нескольких масок разделяйте их пробелами. Если в маске содержатся пробелы, то она должна быть заключена в кавычки. Например, чтобы упаковать без сжатия все архивы RAR и ZIP, а также изображения JPG, введите:

*.rar *.zip *.jpg

Сохранение путей файлов при добавлении в архив

Выбрать метод хранения в архиве путей файлов. Можно сохранять пути относительно текущей папки (по умолчанию), полные пути без буквы диска и символа обратной косой черты в начале, только имена файлов без путей, а также полные пути с буквой диска.

В режиме Сохранять относительные пути исключается текущая папка WinRAR. Для путей, указанных вручную в поле Добавляемые файлы, исключается базовая папка до последнего разделителя пути (аналогично ключу -ep1).

При сохранении имён без путей возможна ситуация, когда в архиве окажутся несколько файлов с одним и тем же именем, поэтому используйте параметр Не сохранять пути осторожно.

В режиме сохранения полных путей с буквой диска WinRAR заменяет символы признака дисков (двоеточия) подчёркиваниями. Если в окне распаковки архива на вкладке Дополнительно выбрать параметр Извлекать с абсолютными путями, WinRAR заменит эти подчёркивания на двоеточия и создаст извлечённые из архива файлы в их исходных папках и дисках. Более подробные сведения о потенциальных преимуществах и опасностях режима Сохранять полные пути, включая букву диска см. в описании ключа -ep3, являющегося эквивалентом этого параметра для командной строки.

Архив

· Помещать каждый файл в отдельный архив

Для каждого выбранного файла или папки будет создаваться отдельный архив. Если включить этот параметр, то введённое имя архива трактуется только как целевой путь для новых архивов (если это не папка, то часть, обозначающая имя, игнорируется), а имена создаваемых архивов генерируются на основе имён файлов.

· Двойные расширения архивов

Этот параметр изменяет поведение параметра Помещать каждый файл в отдельный архив. Если включено, то архивы, создаваемые с параметром Помещать каждый файл в отдельный архив, будут получать имена вида 'имя.расширение.rar', то есть расширение архива добавляется к имени файла. Если выключено, то у создаваемых архивов будут имена вида 'имя.rar', то есть расширение файла заменяется расширением архива. Но даже если этот параметр выключен, WinRAR может применять режим двойных расширений для файлов с одинаковыми именами, но с разными расширениями.

· Архивы во вложенных папках

Этот параметр изменяет поведение параметра Помещать каждый файл в отдельный архив. Если включено, то параметр Помещать каждый файл в отдельный архив будет помещать каждый файл в выбранных вложенных папках в отдельный архив. Если выключено, в отдельный архив будет помещаться всё содержимое каждой выбранной папки.

· Отправить архив по электронной почте на адрес [<адрес>] [после чего удалить]

Данный параметр позволяет прикрепить созданный архив к сообщению электронной почты. При этом требуется, чтобы в системе была установлена почтовая программа, совместимая с интерфейсом MAPI (поддерживается большинством современных почтовых клиентов). Указывать здесь адрес необязательно: если оставить поле пустым, то он будет запрошен почтовой программой. Допускается указывать несколько адресов, разделяя их запятыми или точками с запятой. Если отметить пункт после чего удалить, то после успешного прикрепления к письму архив будет удалён.

Если этот параметр используется при создании многотомного архива, то каждый том будет прикреплён к отдельному письму.


Имя и параметры архива: Общие параметры

Это окно содержит следующие элементы:

Имя архива

Введите имя вручную или нажмите кнопку Обзор и выберите архив на диске. Имя может содержать букву диска или полный путь к архиву.

Кнопка Профили...

Открывает меню, в котором можно создать новый профиль, упорядочить существующие или выбрать один из профилей архивации. Профили позволяют быстро восстановить ранее сохранённые параметры архивации или указать параметры по умолчанию для данного окна. После установки в WinRAR доступно несколько предопределённых стилей (например для создания вложений в электронные письма, резервного копирования и др.). Над кнопкой Профили... отображается имя активного в данный момент профиля. Более подробную информацию см. в разделе Профили архивации.

Формат архива (RAR, RAR4, ZIP)

Выбор формата создаваемого архива. Доступны RAR — новейший формат RAR5, RAR4 — формат, совместимый с WinRAR 4.x, и формат ZIP. В зависимости от выбранного архивного формата некоторые расширенные параметры могут быть недоступны. При обновлении имеющегося архива данный параметр игнорируется, так как в этом случае используется формат обновляемого архива.

Метод сжатия

Выбор одного из методов упаковки: без сжатия, скоростной, быстрый, обычный, хороший и максимальный. Метод "Без сжатия" помещает файлы в архив с предельно возможной скоростью, не сжимая их. Остальные методы сжимают данные — чем сильнее, тем медленнее.

Размер словаря

Здесь выбирается размер области памяти, используемый для поиска и сжатия повторяющихся элементов в обрабатываемых данных. Увеличение размера словаря иногда позволяет улучшить сжатие крупных файлов, особенно при создании непрерывного архива. Однако чем больше словарь, тем медленнее архивирование и тем больше памяти требуется. Для упаковки нужно примерно в шесть раз больше памяти, чем выбранный размер словаря. Для распаковки требуется памяти чуть больше однократного размера словаря, использовавшегося при создании архива. Если нужно, чтобы архив RAR5 можно было распаковать на любых компьютерах, в том числе с малым количеством памяти, лучше избегать больших словарей, выбирая что-то посередине, например 32 или 64 МБ.

Максимальный размер словаря для архивов RAR4 равен 4 МБ. В формате RAR5 можно создавать архивы со словарём до 1 ГБ в 64-разрядной версии WinRAR, и до 256 МБ — в 32-разрядной (в Windows XP x86 – до 128 МБ). Распаковка требует меньше памяти, чем упаковка, поэтому обе версии WinRAR — 32- и 64-разрядная — способны распаковывать архивы с любым размером словаря, включая 1 ГБ, при условии, что в компьютере не менее 1 ГБ доступной памяти. Для формата ZIP размер словаря фиксированный и составляет 32 КБ.

Если размер всех исходных файлов для непрерывного архива или размер наибольшего исходного файла для обычного (не непрерывного) архива хотя бы вдвое меньше заданного размера словаря, то WinRAR может уменьшить размер словаря. Это снижает потребление памяти, не ухудшая сжатия.

Разделить на тома размером…

Если вы хотите создать многотомный архив, то введите здесь размер тома. В расположенном правее выпадающем списке можно выбрать единицу измерения. В этом списке "байт" означает байты, "КБ" — килобайты, "МБ" — мегабайты, "ГБ" — гигабайты.

Разрешается вводить десятичные дроби, разделяя целую и дробную части числа символом, определённым в региональных настройках Windows.

Единицы размера также можно указывать, добавляя после числового значения одно- или двухбуквенный идентификатор (все буквы латинские).

k | килобайты (множитель 1024)
K | тысячи байт (множитель 1000)
m | мегабайты (1 МБ = 1 048 576 байт)
M | миллионы байт (множитель 1 000 000)
g | гигабайты (1 ГБ = 1 073 741 824 байт)
G | миллиарды байт (множитель 1 000 000 000)

Для обозначения килобайтов, мегабайтов и гигабайтов также можно указывать KB, MB и GB — регистр букв значения не имеет.

Чтобы ускорить выбор, поле размера тома снабжено выпадающим списком с ранее вводившимися, предустановленными и заданными пользователем значениями. Список можно настроить в окне Определение размеров томов, вызываемом кнопкой Определить размеры томов… в окне параметров сжатия.

Если вы создаёте многотомный архив на сменных дисках и используете формат RAR, то лучше выбрать пункт Автоопределение, чтобы размер каждого нового тома автоматически подбирался в зависимости от свободного места на диске.

Метод обновления

· Добавить с заменой файлов (действие по умолчанию)

Всегда заменять файлы в архиве одноимёнными добавляемыми файлами. Всегда добавлять файлы, которых нет в архиве.

· Добавить с обновлением файлов

Заменять файлы в архиве, только если одноимённый добавляемый файл более новый. Всегда добавлять файлы, которых нет в архиве.

· Обновить существующие файлы

Заменять файлы в архиве, только если одноимённый добавляемый файл более новый. Не добавлять файлы, которых нет в архиве.

· Запрос перед перезаписью

Запрашивать подтверждение перед перезаписью файлов в архиве, имеющих те же имена, что и добавляемые файлы. Всегда добавлять файлы, которых нет в архиве.

· Пропускать существующие файлы

Не заменять файлы в архиве, имеющие те же имена, что и добавляемые файлы. Всегда добавлять файлы, которых нет в архиве.

· Синхронизировать содержимое архива

Заменять файлы в архиве, только если одноимённый добавляемый файл более новый. Всегда добавлять файлы, которых нет в архиве. Удалять из архива те файлы, которых нет среди добавляемых. Это похоже на создание нового архива, но за одним важным исключением: если после предыдущей архивации файлы не изменялись, то операция будет выполнена значительно быстрее, чем создание нового архива.

Параметры архивации

· Удалить файлы после упаковки

После архивации успешно упакованные исходные файлы удаляются.

· Создать SFX-архив

Будет создан не обычный архив, а самораспаковывающийся (SFX) в виде EXE-файла, для распаковки которого не требуется никаких других программ. В окне Дополнительные параметры можно выбрать SFX-модуль и указать несколько других параметров самораспаковки, например папку назначения.

· Создать непрерывный архив

Использовать режим непрерывного архивирования. Непрерывные (solid) архивы, как правило, получаются более компактными, чем обычные, но при этом следует учитывать некоторые их особенности. См. подробности в разделе о непрерывном архивировании.

· Добавить данные для восстановления

В архив будут добавлены данные для восстановления, которые могут помочь восстановить архив в случае его повреждения. В окне Дополнительные параметры можно указать их размер (по умолчанию — 3% от общего размера архива).

· Протестировать файлы после упаковки

После помещения файлов в архив они будут там протестированы, что особенно полезно в сочетании с включённым параметром Удалить файлы после упаковки, так как исходные файлы будут удалены с диска только в том случае, если после их добавления в архив он успешно прошёл тестирование.

· Заблокировать архив

Заблокированный архив нельзя изменить средствами WinRAR. Блокирование может быть полезно для важных архивов, чтобы предотвратить их случайную модификацию.

Кнопка Установить пароль…

Эта кнопка позволяет установить пароль для шифрования файлов. Заданный здесь пароль действует только в течение одной операции архивирования и имеет более высокий приоритет, чем пароль по умолчанию, указываемый в меню Файл. После сеанса архивации введённый пароль не сохраняется, а текущим становится пароль по умолчанию (если пароля по умолчанию не было, то по окончании архивации его тоже не будет).


Окно указания имени и параметров архива

Это окно отображается при выполнении команды Добавить в архив непосредственно перед добавлением файлов в архив.

Параметры в этом окне поделены на несколько групп:

Общие

Дополнительно

Опции

Файлы

Резервные копии

Время

Комментарий


Имя и параметры архива: Опции

Режим удаления

Все указанные ниже опции удаления изменяют поведение параметра Удалить файлы после упаковки на вкладке Общие и действуют, только когда он включён. Любую из опций можно включить в профиль архивации по умолчанию, чтобы изменить стандартное поведение этого параметра.

· Удалить файлы

Удалить файлы обычным образом. Файлы удаляются окончательно, но без гарантии уничтожения информации, поэтому в некоторых случаях данные можно восстановить с помощью специального ПО.

· Переместить файлы в Корзину

Удалить файлы и поместить их в Корзину Windows.

· Уничтожить (затереть) файлы

Перед удалением файла содержащиеся в нём данные перезаписываются нулевыми байтами, чтобы удалённые файлы нельзя было восстановить, файл усекается и ему даётся временное имя.

Имейте в виду, что эта функция предназначена для обычных жёстких дисков. При использовании с твердотельными накопителями (SSD) перезапись исходных данных может не работать из-за применяемой в SSD-накопителях технологии Wear Leveling (перераспределения блоков при записи) и более сложной адресации данных.

· Уничтожать файлы, если задан пароль

Если включён этот параметр, а файлы заархивированы с паролем, режим уничтожения (затирания) файлов используется вне зависимости от значений других параметров в группе Режим удаления.

Применять данный параметр непосредственно в окне архивирования особого смысла нет, поскольку вместо этого можно просто включить параметр Уничтожить (затереть) файлы. Поэтому он рассчитан на использование в профилях архивации. Если вы хотите, чтобы зашифрованные файлы всегда удалялись без возможности восстановления, то включите параметр Уничтожать файлы, если задан пароль в профиле по умолчанию.

Особенности архива

· Использовать контрольные суммы BLAKE2

Сохранять для файлов контрольные суммы BLAKE2. Доступно только для архивного формата RAR5.

В архивах RAR целостность данных определяется по контрольным суммам, вычисляемым и сохраняемым для каждого файла в архиве. Для вычисления контрольных сумм WinRAR по умолчанию использует функцию CRC32. Для формата RAR5 вместо CRC32 можно выбрать версию BLAKE2sp хеш-функции BLAKE2.

Длина вывода CRC32 — 32 бита. Возможностей CRC32 хватает для определения большинства непреднамеренных ошибок в данных, но их недостаточно для проверки подлинности файловых данных. Иными словами, если два файла имеют одну и ту же CRC32, нет гарантии, что у этих файлов одинаковое содержимое.

Длина вывода BLAKE2 — 256 бит. Так как это криптостойкая хеш-функция, она практически гарантирует, что если у двух файлов одинаковое значение BLAKE2, содержимое этих файлов тоже одинаково. Кроме того, у BLAKE2 надёжнее, чем у более короткого CRC32, определение ошибок.

Поскольку вывод BLAKE2 длиннее, при выборе данного параметра архив получается чуть большего размера.

Если заголовки архива не зашифрованы (не выбран параметр Шифровать имена файлов), контрольные суммы зашифрованных файлов RAR5 изменены с помощью особого, зависящего от пароля алгоритма, чтобы по контрольным суммам нельзя было угадать содержимое файлов. Поэтому не ждите, что контрольные суммы зашифрованных файлов совпадут с обычными значениями CRC32 или BLAKE2.

· Сохранять идентичные файлы как ссылки

Если выбран этот параметр, то перед началом архивирования выполняется анализ содержимого файлов. Если обнаруживаются несколько идентичных файлов размером более 64 КБ, первый файл из набора сохраняется как обычный файл, а все остальные — как ссылки на этот первый файл. Это позволяет уменьшить размер архива, но накладывает некоторые ограничения на результирующий архив. Первый файл из набора идентичных файлов в созданном архиве нельзя удалять или переименовывать, потому что это сделает невозможным извлечение остальных ссылающихся на него файлов. Если изменить содержимое первого файла, то при извлечении изменёнными будут и все остальные ссылающиеся на него файлы. Команда извлечения должна применяться сначала к первому файлу, чтобы остальные файлы могли быть успешно созданы.

Данный параметр рекомендуется применять только при сжатии большого количества идентичных файлов и если архив в дальнейшем не предполагается изменять, а распаковывать его вы будете полностью, без необходимости извлекать или пропускать отдельные файлы. Если все идентичные файлы достаточно малы, чтобы уместиться в словаре сжатия, то более гибкое решение, нежели данный параметр, даёт непрерывное (solid) архивирование.

Поддерживается только в архивах RAR5.

Информация для быстрого открытия архива

В архивах RAR непосредственно перед данными каждого файла находится его заголовок, содержащий такие сведения, как имя файла, время, размер и атрибуты. Такой метод более устойчив к повреждениям, чем хранение заголовков всех файлов в одном непрерывном блоке, разрушение или усечение которого способно повлечь уничтожение всего содержимого архива. Однако хотя такая реализация и более надёжна, у неё есть недостаток: поскольку файловые заголовки рассредоточены по всему архиву, доступ к ним не столь быстрый, как при хранении заголовков в одном блоке, что может быть заметно, когда нужно быстро открыть содержание архива в таких графических оболочках, как, например, WinRAR.

Чтобы повысить скорость открытия архивов и вместе с тем не делать весь архив зависящим от повреждения одиночного блока, архивы RAR5 могут содержать необязательную запись для быстрого открытия. Она добавляется в конец архива и содержит копии имён файлов и другую информацию о файлах в архиве в одном непрерывном блоке в дополнение к обычным файловым заголовкам внутри архива. Поскольку блок непрерывный, его содержимое считывается быстро, без необходимости выполнять множество операций чтения с диска. Каждый файловый заголовок в таком блоке защищён контрольной суммой. Если WinRAR обнаруживает, что информация для быстрого открытия повреждена, он переходит к чтению индивидуальных заголовков внутри архива, поэтому устойчивость к повреждениям не понижается.

Запись для быстрого открытия содержит полную копию файлового заголовка, которая может занимать несколько десятков или сотен байт на файл, и на этот же объём увеличивается размер архива. Такое увеличение размера наиболее заметно, если архив содержит большое количество маленьких файлов, когда размер файловых данных сопоставим с размером файловых заголовков. Поэтому по умолчанию, в режиме Добавлять для крупных файлов, WinRAR сохраняет копии заголовков только для относительно больших файлов и продолжает использовать локальные заголовки для маленьких. Конкретный порог размера файлов зависит от версии WinRAR. Такой подход обеспечивает разумный компромисс между скоростью открытия и размером архива. Если предпочтительнее скорость открытия архива вне зависимости от его размера, выберите параметр Добавлять для всех файлов, чтобы сохранять копии заголовков всех файлов. Если же нужно получить архив наименьшего размера, а скорость открытия его в других программах неважна, выберите параметр Не добавлять, чтобы полностью исключить информацию для быстрого открытия.

Если вы хотите оценить влияние этой настройки на производительность, удостоверьтесь, что содержимое архива не находится в дисковом кэше. Когда архивный файл находится в кэше, реальные операции поиска на диске не выполняются, так что доступ к файловым заголовкам будет быстрым даже без использования информации для быстрого открытия.


Имя и параметры архива: Время

· Сохранять время изменения, создания, последнего доступа к файлам

Разрешить сохранение в архиве времени изменения, создания, последнего доступа к файлам. Поддерживается только в архивах RAR. Отключить хранение времени изменения файлов можно только в архивах формата RAR5. Если какое-то из этих времён не сохранено в архиве, то при извлечении оно будет таким же, как текущее время в системе.

Чтобы восстановить время создания и последнего доступа у извлекаемых файлов, нужно включить параметры Установить время создания и Установить время последнего доступа на вкладке Дополнительно в окне извлечения. Восстановление времени изменения включено по умолчанию.

· Формат времени высокой точности

Если выключено, то время последнего изменения файлов сохраняется с двухсекундной точностью для архивов RAR4 и ZIP, и с секундной точностью для архивов RAR5. Если включено, то время файлов сохраняется с точностью 0,0000001 секунды, но при этом незначительно увеличивается размер архива.

Если включить этот параметр при архивировании в ZIP, то в результирующий архив будут записываться с высокой точностью все три времени. В отличие от формата RAR, сохранять в ZIP с высокой точностью только какое-то одно время нельзя.

· Обрабатывать файлы: с любым временем / старше, чем / новее, чем / до / после

По умолчанию у этого параметра принимается значение "с любым временем", т.е. архивируются все выбранные файлы независимо от их времени. При выборе значения "старше, чем" или "новее, чем" будут архивироваться только файлы, у которых время модификации, создания или последнего доступа старше или младше указанного количества дней, часов и минут. Например, это может пригодиться для архивирования только файлов, которые изменялись за последние три дня. Варианты "до" и "после" позволяют выбрать только файлы, у которых время модификации, создания или последнего доступа старше или моложе конкретной указанной даты.

При выборе параметров "новее, чем" и "после" в обработку также включаются файлы с временем, точно совпадающим с указанным. При выборе параметров "старше, чем" и "до" такие файлы исключаются.

· Установить время архива по: текущему системному времени / времени исходного архива / времени самого нового файла

По умолчанию у этого параметра принимается значение "по текущему системному времени", т.е. каждому создаваемому или изменяемому архиву присваивается текущее системное время как время модификации. Если нужно, чтобы при изменении архива у него не изменялось время, выберите вариант "по времени исходного архива". При указании значения "по времени самого нового файла" архив получит такое же время модификации, как у содержащегося в нём самого нового файла.


Brian Gladman's AES implementation

Реализация AES Брайана Гладмана (Brian Gladman)

Применяемые в WinRAR алгоритмы шифрования и дешифрования используют части кода реализации AES Брайана Гладмана (Brian Gladman), лицензированной на следующих условиях:

Copyright (c) 2002, Dr Brian Gladman < >, Вустер, Великобритания.

Все права защищены.

ЛИЦЕНЗИОННОЕ СОГЛАШЕНИЕ

Разрешается свободное распространение и использование этого программного обеспечения как его исходного кода, так и в бинарном виде (с изменениями или без таковых) при условии, что:

  1. распространение исходного кода включает вышеуказанные сведения об авторских правах, данный список условий и нижеследующий отказ от гарантий;
  2. распространение в бинарном виде включает вышеуказанные сведения об авторских правах, данный список условий и нижеследующий отказ от гарантий в документации и/или сопутствующих материалах;
  3. имя держателя авторских прав не используется для подтверждения/рекомендации продуктов, созданных с использованием данного ПО, без письменного на то разрешения.

В КАЧЕСТВЕ АЛЬТЕРНАТИВЫ, если это примечание остаётся в неизменном полном виде, данный продукт может распространяться в соответствии с условиями общедоступной лицензии (GPL) проекта по свободному распространению ПО (GNU). В этом случае условия GPL применяются ВМЕСТО тех, что указаны выше.

ОТКАЗ ОТ ГАРАНТИЙ

Данное программное обеспечение предоставляется по принципу 'как есть', без каких-либо явных или подразумеваемых гарантий его свойств, включая (но не ограничиваясь этим) его функциональность и/или пригодность.

Исходный код данного пакета, как и прочие ссылки, относящиеся к другим криптографическим технологиям и вычислительным проектам, доступны на сайте Брайана Гладмана.


Окно параметров архива

В этом окне содержатся команды для защиты архива от повреждений, создания томов для восстановления и блокировки архива. Все они поддерживаются только в архивах RAR.

Защита архива может помочь восстановить его в случае незначительного физического повреждения. Чтобы защитить архив от повреждений, то укажите размер данных для восстановления в процентах от общего размера архива. Максимально допустимое значение — 100%. Если указать 0 (ноль), то данных для восстановления в архиве не будет. Чем больше размер таких данных, тем более серьёзные повреждения могут быть восстановлены, но вместе с тем увеличивается и размер всего архива, поэтому в большинстве случаев оптимальным значением будет 3—5%.

Особый случай защиты архива — тома для восстановления (файлы с расширением .rev). Создать их можно, только если открытый архив это первый том многотомного архива — просто укажите количество создаваемых REV-файлов. К числовому значению в этом параметре можно добавить знак процента (%), чтобы количество создаваемых файлов .rev вычислялось как указанный процент от общего числа томов архива RAR. Каждый том для восстановления позволяет воссоздать один любой отсутствующий архивный том. Подробнее об этой функции см. здесь.

Если включить параметр Заблокировать архив, то архив будет будет заблокирован, т.е. впоследствии его содержимое уже нельзя будет изменять средствами WinRAR. Обычно блокировка применяется для защиты важных архивов от случайного изменения.

У томов для восстановления более высокий приоритет, чем у остальных параметров, использовать их вместе нельзя. Если указано отличное от нуля количество файлов .rev, то WinRAR будет игнорировать параметры данных для восстановления и блокировки архива и станет создавать тома для восстановления.


Исходный код Info-ZIP

Для работы с архивами ZIP в WinRAR применяется исходный код группы Info-ZIP. Оригинальный исходный код Info-ZIP свободно доступен на ftp://ftp.info-zip.org/pub/infozip/ и www.info-zip.org.

Лицензия Info-Zip

Это версия лицензии Info-ZIP от 02 января 2009 г. Окончательная версия данного документа должна быть неограниченно доступна на странице ftp://ftp.info-zip.org/pub/infozip/license.html, а её копия — на странице http://www.info-zip.org/pub/infozip/license.html.

Copyright (c) 1990-2009 Info-ZIP. All rights reserved.

For the purposes of this copyright and license, "Info-ZIP" is defined as the following set of individuals:

Mark Adler, John Bush, Karl Davis, Harald Denker, Jean-Michel Dubois, Jean-loup Gailly, Hunter Goatley, Ed Gordon, Ian Gorman, Chris Herborth, Dirk Haase, Greg Hartwig, Robert Heath, Jonathan Hudson, Paul Kienitz, David Kirschbaum, Johnny Lee, Onno van der Linden, Igor Mandrichenko, Steve P. Miller, Sergio Monesi, Keith Owens, George Petrov, Greg Roelofs, Kai Uwe Rommel, Steve Salisbury, Dave Smith, Steven M. Schweda, Christian Spieler, Cosmin Truta, Antoine Verheijen, Paul von Behren, Rich Wales, Mike White.

This software is provided "as is," without warranty of any kind, express or implied. In no event shall Info-ZIP or its contributors be held liable for any direct, indirect, incidental, special or consequential damages arising out of the use of or inability to use this software.

Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter it and redistribute it freely, subject to the above disclaimer and the following restrictions:

  1. Redistributions of source code (in whole or in part) must retain the above copyright notice, definition, disclaimer, and this list of conditions.

  2. Redistributions in binary form (compiled executables and libraries) must reproduce the above copyright notice, definition, disclaimer, and this list of conditions in documentation and/or other materials provided with the distribution. Additional documentation is not needed for executables where a command line license option provides these and a note regarding this option is in the executable's startup banner. The sole exception to this condition is redistribution of a standard UnZipSFX binary (including SFXWiz) as part of a self-extracting archive; that is permitted without inclusion of this license, as long as the normal SFX banner has not been removed from the binary or disabled.

  3. Altered versions--including, but not limited to, ports to new operating systems, existing ports with new graphical interfaces, versions with modified or added functionality, and dynamic, shared, or static library versions not from Info-ZIP--must be plainly marked as such and must not be misrepresented as being the original source or, if binaries, compiled from the original source. Such altered versions also must not be misrepresented as being Info-ZIP releases--including, but not limited to, labeling of the altered versions with the names "Info-ZIP" (or any variation thereof, including, but not limited to, different capitalizations), "Pocket UnZip," "WiZ" or "MacZip" without the explicit permission of Info-ZIP. Such altered versions are further prohibited from misrepresentative use of the Zip-Bugs or Info-ZIP e-mail addresses or the Info-ZIP URL(s), such as to imply Info-ZIP will provide support for the altered versions.

  4. Info-ZIP retains the right to use the names "Info-ZIP," "Zip," "UnZip," "UnZipSFX," "WiZ," "Pocket UnZip," "Pocket Zip," and "MacZip" for its own source and binary releases.


CRC32-алгоритм Intel Slicing-by-8

Алгоритм Intel Slicing-by-8 для подсчёта CRC32

Для вычисления контрольных сумм CRC32 в WinRAR используется функция на основе алгоритма Intel Slicing-by-8.

Исходный код Intel Slicing-by-8 доступен на странице sourceforge.net/projects/slicing-by-8 и лицензирован по лицензии BSD, доступной на странице http://www.opensource.org/licenses/bsd-license.html.

Лицензия BSD:

Copyright (c) 2004-2006 Intel Corporation.
All Rights Reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  • Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  • Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


Лицензия и информация о покупке

Выберите один из следующих разделов:

Лицензия на использование WinRAR

Информация о покупке


Ввод главного пароля

Введите главный пароль, чтобы зашифровать записи о паролях в реестре, защитив их от несанкционированного доступа. После этого для доступа к паролям вам потребуется вводить в окне запроса главный пароль. Будучи введённым, главный пароль действует до закрытия WinRAR. Чтобы посмотреть, как работает защита, после указания главного пароля закройте WinRAR и откройте снова. Чтобы удалить шифрование ранее защищённых паролей, введите пустой пароль.

В действительности шифрование происходит после нажатия OK в родительском окне Управление паролями, а не сразу после закрытия этого запроса главного пароля.


Хранение пароля в профиле упаковки

Хранение пароля в профиле архивации

Если не задан главный пароль, сохранённые в профилях архивации пароли не шифруются, поэтому их может увидеть каждый, у кого есть доступ к компьютеру. Чтобы зашифровать хранящиеся в реестре парольные данные, защитив их от неавторизованного доступа, нужно задать главный пароль. После этого, чтобы получить доступ к такому профилю архивации, нужно будет при запросе пароля вводить главный пароль.

Вы можете использовать тот же пароль, что и в органайзере паролей, либо выбрать другой. Допускается даже присваивать разные главные пароли разным профилям архивации, хотя это может быть и неудобным в работе.

Будучи введённым, главный пароль остаётся действительным при последующем чтении профилей до закрытия WinRAR или до выбора профиля с другим главным паролем. Если вы хотите посмотреть, как работает защита, то после указания главного пароля закройте WinRAR и откройте снова.


Кодировка имён

Меню Кодировка имён вызывается в меню Настройки, либо клавишами Ctrl+E. Оно позволяет выбрать кодировку для имён файлов в архиве. Этот выбор влияет на просмотр содержимого архива и команды извлечения. Обычно следует предпочесть пункт По умолчанию, чтобы WinRAR выбирал кодировку сам на основании языковых установок Windows и знаний о типичных параметрах формата архива. Однако если выбор По умолчанию даёт неудовлетворительный результат, то можно указать другую кодовую страницу.

Сделанный пользователем выбор действует до закрытия WinRAR, либо пока не будет выбран другой пункт в этом меню. Если нужно сохранить текущую выбранную кодировку, чтобы она применялась постоянно, выберите пункт Сохранить текущую. Делать это следует только в случае, когда приходится обрабатывать множество архивов с одной и той же кодовой страницей, которую WinRAR не распознаёт автоматически, иначе лучше выбрать пункт По умолчанию. Вариант По умолчанию всегда можно вернуть, указав его в меню, а затем выбрав Сохранить текущую.

Если архив содержит имена файлов в Юникоде, и WinRAR может это достоверно определить, то выбранное в данном меню значение игнорируется и используется Юникод. Меню Кодировка имён применяется, если нет имён в Юникоде, либо когда не удаётся уверенно определить кодировку. Хотя это меню доступно как вне, так и внутри архивов, выбор кодовой страницы влияет только на имена файлов в архивах и игнорируется для обычных (не архивированных) файлов.


Окно "Управление профилями";Управление профилями;Профили, управление

Окно "Управление профилями"

В этом окне можно исправить некоторые параметры уже существующего профиля архивации или удалить его. Создать новый профиль здесь нельзя, для этого нужно воспользоваться способами, описанными в разделе Профили архивации.

Для изменения параметров профиля необходимо выбрать профиль, нажать кнопку Изменить и в появившемся окне Параметры профиля установить необходимые параметры. Обратите внимание, что сохранённые в профиле параметры архивации изменить нельзя. Можно откорректировать только несколько параметров, непосредственно связанных с профилем, например его имя или значение параметра, разрешающего использовать этот профиль по умолчанию. Если необходимо изменить параметры архивации, то следует создать новый профиль с таким же именем, как у уже существующего.

Чтобы удалить профиль, выберите его в списке и нажмите кнопку Удалить.

Кнопки Выше и Ниже служат для перемещения в списке профиля под курсором.

Профиль, который используется по умолчанию, обозначается в списке значком WinRAR ("стопка книг") слева от его имени.


Окно "Управление темами"

Это окно позволяет манипулировать интерфейсными темами WinRAR.

Нажмите кнопку Выбрать, чтобы сделать активной тему, на которой стоит курсор. С помощью кнопки Добавить можно установить файл с новой темой. Кнопка Удалить не только убирает тему под курсором из списка, но и удаляет с диска все относящиеся к этой теме файлы, поэтому вы уже не сможете выбрать её снова.

Параметр Применить к значкам архивов относится ко всем темам. Если он выключен, темы модифицируют только графический интерфейс WinRAR, но не изменяют значки, которыми обозначаются в системе архивы RAR, ZIP и др. Если параметр включён, то изменяются и интерфейс WinRAR, и значки архивов. В отличие от остальных команд в этом окне, для подтверждения изменения параметра Применить к значкам архивов необходимо нажать кнопку OK.


Управление паролями

Окно управления паролями служит для сохранения часто используемых паролей и быстрого к ним доступа в дальнейшем. Оно содержит список сохранённых пользователем записей о паролях. Обычно в этом списке содержатся метки паролей и маски архивов, но если если метка не была задана, вместо неё в колонке Метка отображается сам пароль.

Окно управления паролями вызывается из обычного окна ввода пароля WinRAR. Просто нажмите кнопку Упорядочить пароли... при вводе пароля по умолчанию или когда WinRAR потребует ввести пароль для зашифрованного файла или архива.

Нажмите кнопку Добавить, чтобы внести новый пароль в список в позиции ниже курсора. Откроется окно Информация о пароле, в котором можно указать текст пароля, метку и архивную маску. Более подробные сведения приведены в разделе Окно информации о пароле.

Кнопка Удалить в окне управления паролями позволяет удалить все выбранные записи. Кнопка Изменить служит для изменения параметров записи под курсором. Кнопки Выше и Ниже изменяют расположение выбранных паролей в списке.

Нажмите кнопку Установить главный пароль, введите главный пароль и затем нажмите OK в окне Управление паролями, если хотите зашифровать записи о паролях, защитив их от несанкционированного доступа. После этого для получения к ним доступа потребуется вводить главный пароль в окне запроса. Будучи введённым, главный пароль остаётся действительным до закрытия WinRAR. Если вы хотите посмотреть, как работает защита, то после задания главного пароля закройте WinRAR и запустите снова. Чтобы удалить шифрование с ранее защищённых записей о паролях, введите пустой пароль.

Если не задан главный пароль, пароли хранятся в системном реестре в незащищённом формате. Это означает, что их может увидеть любой, у кого есть доступ к вашему компьютеру. Если вам часто приходится использовать пароли, то органайзер паролей может упростить работу с ними, однако при этом нужно тщательно взвесить связанные с этим риски. Если защищаемая паролями информация &mdash особо важная и конфиденциальная, то либо не пользуйтесь органайзером паролей, либо применяйте его только в компьютере, к которому ни у кого нет неавторизованного доступа, либо установите главный пароль.

Параметр Автозавершение позволяет использовать в окне ввода пароля функцию автозавершения паролей. Достаточно ввести только первые буквы пароля или метки пароля, и если эти пароль или метка имеются в списке сохранённых паролей, WinRAR предложит их полный текст. Функция автозавершения работает, только если в окне ввода пароля включён параметр Отображать пароль при вводе. Если пароли скрыты, автозавершение отключено. Если для сохранённого пароля задана метка, автозавершение будет работать только для метки, но не для текста пароля.

Когда все изменения в списке паролей в окне управления паролями будут выполнены, необходимо нажать кнопку OK, чтобы сохранить их.

Сохранённые пароли в окне ввода пароля доступны в выпадающем списке поля Введите пароль и как результат действия функции автозавершения.


Подтверждение перезаписи файла

Файл уже существует. Вы можете перезаписать его (кнопка Да), пропустить (кнопка Нет), переименовать (кнопка Переименовать), переименовать все (кнопка Переименовать все), перезаписать все файлы (кнопка Да для всех), пропустить все существующие файлы (кнопка Нет для всех), либо прервать текущую операцию (кнопка Отмена).

При выборе Переименовать все переименованные файлы получают имена вида filename(N).txt, где filename.txt – исходное имя файла, а N – номер.


Окно "Параметры профиля"

В этом окне можно описать новый профиль архивации или исправить параметры уже существующего профиля. Здесь доступны следующие элементы:

Имя профиля

Текстовая строка, описывающая профиль. В имени могут содержаться пробелы, например допустимо имя Создать вложение в e-mail. Лучше давать профилям понятные имена, чтобы упростить их идентификацию и управление. Данное поле должно быть заполнено.

Сохранить имя архива

Если включено, то указанное ниже имя архива включается в профиль и будет восстанавливаться всякий раз при выборе профиля. Если выключено, то WinRAR будет предлагать имя архива как обычно.

Сохранить имена выделенных файлов

Если включено, то в расположенной ниже строке можно указать имена файлов, которые будут записаны в архив. При последующем выборе этого профиля будут архивироваться файлы, указанные в профиле, а не выбранные до его загрузки.

Изначально это поле содержит имена файлов, выбранных в списке файлов WinRAR, но вы можете ввести в этой строке другие имена. Допускается указывать имена папок и шаблоны. Например, можно создать профиль, у которого в поле Сохранить имена выделенных файлов будет "C:\". При вызове такого профиля будет архивироваться весь диск C:.

Если этот параметр выключен, то WinRAR заархивирует только выбранные файлы.

Сделать профилем по умолчанию

Если указано, что данный профиль — это профиль по умолчанию, то его параметры будут восстанавливаться при открытии окна Имя и параметры архива до начала любых операций. В профиле по умолчанию имеет смысл указывать параметры, которыми вы пользуетесь чаще всего, чтобы не устанавливать их каждый раз заново. Профилем по умолчанию может быть только один профиль. Если профиль по умолчанию не назначен, в окне архивации используются значения по умолчанию.

Некоторые параметры применяемого по умолчанию профиля архивации используются не только при добавлении файлов в архив, но и при других операциях, модифицирующих архив, например при удалении или переименовании файлов. В этом случае WinRAR считывает только те параметры, которые подходят для текущей операции. При извлечении никакие параметры из применяемого по умолчанию профиля архивации не используются.

Немедленное выполнение

При выборе из меню профиля с параметром Немедленное выполнение архивация начинается немедленно, без возможности поменять какие-либо параметры. Это полезно для устоявшихся операций (например для создания резервных копий), поскольку после выбора такого профиля не нужно нажимать OK.

Создать ярлык на рабочем столе

Этот параметр доступен только при включённом параметре Сохранить имена выделенных файлов. Он позволяет создать на рабочем столе значок с именем профиля, чтобы профиль можно было быстро активизировать щелчком по его значку. Например, можно создать профиль для резервного копирования файлов, а для упрощения операции поместить его ярлык на рабочий стол.

Добавить в контекстное меню

Если включено, имя профиля будет отображаться в контекстных меню Проводника Windows, что позволяет активизировать профиль оттуда. Если также включить в профиле параметр Немедленное выполнение, то архивирование будет начинаться сразу же при выборе этого профиля в контекстном меню. Если параметр Немедленное выполнение выключен, то сначала будет появляться окно выбора имени и параметров архива. При включённом параметре Сохранить имя архива WinRAR будет использовать сохранённое имя для нового архива. Если включён параметр Сохранить имена выделенных файлов, то в архив будут добавлены как имена, сохранённые в профиле, так и выбранные в Проводнике.


Окно информации о пароле

Окно Информация о пароле вызывается кнопками Добавить или Изменить в окне Управление паролями. Таким образом, вы можете либо ввести информацию о новом пароле, либо отредактировать запись об уже имеющемся пароле. Эта информация включает текст пароля (т.е. собственно пароль), метку, маску архивов в поле Выбирать для архивов и параметр Принимать без подтверждения.

Единственное обязательное для заполнения поле — Текст пароля. Оно должно содержать сохраняемый пароль.

Поле Метка пароля используется для того, чтобы в окне паролей не было видно настоящих паролей. Т.е. вы можете указать здесь метку для пароля и затем вводить не сам пароль, а эту метку всякий раз, когда потребуется указать пароль. WinRAR будет автоматически подменять такую метку паролем. О том, что была введена метка, окно пароля проинформирует вас сообщением "Введена метка пароля" прямо над полем ввода пароля.

Например, вы можете указать Fhtfl34Shu как текст пароля, и home как его метку, после чего вводить home вместо Fhtfl34Shu. Эта подстановка работает только в окне пароля. Она не влияет на режим командной строки и ключ -p[пароль].

Метки паролей должны быть уникальными. Они не должны совпадать ни с одной другой меткой или паролем. В метках не учитывается регистр букв, поэтому home и Home считаются одной и той же меткой.

Если вы указали и текст пароля, и метку, то в колонке Метка в окне Управление паролями будет отображаться метка. Если был указан только текст пароля, то в этом списке будет отображаться пароль.

Поле Выбирать для архивов может содержать одно или несколько имён или масок архивов (только имена, без пути), разделённых пробелами. Если в имени архива есть пробелы, такое имя должно быть заключено в кавычки. Если имя распаковываемого архива удовлетворяет одной из этих масок, WinRAR автоматически выберет пароль, указанный в поле Текст пароля. Если параметр Принимать без подтверждения" выключен, этот пароль будет установлен как принимаемый по умолчанию в окне ввода пароля, но у пользователя будет возможность его изменить. Если же параметр Принимать без подтверждения включён, пароль будет принят немедленно.

Например, если указать MailDGWT58 как текст пароля, а в поле Выбирать для архивов ввести mymail*.rar mymail*.zip, то при распаковке архивов mymail*.rar и mymail*.zip будет автоматически выбираться пароль MailDGWT58. Этот параметр работает только при распаковке, но не при архивировании.

Имейте в виду, что сохранённые пароли хранятся в реестре Windows в виде обычного незашифрованного текста, поэтому их может увидеть любой, у кого есть доступ к компьютеру. Таким образом, хотя функция хранения паролей делает работу с ними более удобной, следует осознавать весь риск, который она несёт. Если защищённая паролем информация носит конфиденциальный характер, либо не пользуйтесь этой функцией, либо применяйте её в компьютере, защищённом от неавторизованного доступа.


Окно "Результаты поиска"

В этом окне находятся элементы, обнаруженные командой Найти файлы. Здесь можно выделить один или несколько файлов, а затем распаковать их, нажав кнопку Извлечь.... Кнопка Просмотр позволяет просмотреть содержимое файла под курсором, а кнопка Выделить помещает курсор в главном окне WinRAR на файл, выбранный последним в окне поиска.

По техническим причинам операции с найденными файлами выполняются с некоторой задержкой, если при этом продолжается поиск. WinRAR выполнит команду только тогда, когда будет закрыт обрабатываемый в данный момент архив.


Окно "Дополнительные параметры SFX"

Чтобы вызвать это окно, выберите команду Преобразовать архив в SFX и нажмите кнопку Дополнительные параметры SFX. Здесь можно настроить ряд параметров самораспаковывающегося архива, например предлагаемый по умолчанию путь для извлечения, заголовок окна и текст. Состоящий из команд (см. раздел об SFX-модулях для Windows) сценарий генерируется автоматически, поэтому от вас не требуется знание языка сценариев: вводить команды вручную необязательно — просто включите нужные параметры.

Обратите внимание, что параметры SFX применимы только к Windows-модулю с графическим интерфейсом (GUI), консольные и не-Windows модули SFX их не поддерживают.

SFX-параметры в этом окне разнесены по нескольким вкладкам:

SFX-параметры: Общие

SFX-параметры: Установка

SFX-параметры: Режимы

SFX-параметры: Дополнительно

SFX-параметры: Обновление

SFX-параметры: Текст и графика

SFX-параметры: Лицензия

SFX-параметры: Модуль


SFX-команды: Delete

Delete=<имя файла>

Перед началом извлечения удаляет указанный файл в папке назначения. Допускается использовать несколько команд Delete.

Если указанный в команде Delete файл заблокирован и не может быть удалён, SFX-модуль попытается перед извлечением переименовать его, дав ему временное имя, а после перезагрузки Windows — удалить. Успех этой операции зависит от версии Windows.

Пример

Delete=winrar95.exe

Delete=rarlng.dll


SFX-команды: License

License=<заголовок окна c Лицензионным соглашением>

{

текст лицензионного соглашения 1

текст лицензионного соглашения 2

…

}

Показывает лицензионное соглашение при запуске SFX-архива. Пользователь может либо принять это соглашение и продолжить распаковку, либо не принимать его и выйти.

Лицензионное соглашение может быть как в формате HTML, так и в виде обычного текста. В последнем случае SFX-модуль объединяет и переформатирует указанные текстовые строки так, чтобы они оптимально заполняли окно. Поэтому если нужно начать новый абзац, вставьте перед ним пустую строку.

С помощью языка HTML можно управлять цветами, шрифтами и форматированием выводимого текста. С описанием синтаксиса HTML можно ознакомиться на сайте Консорциума World Wide Web (www.w3.org). Для подготовки текста в формате HTML подойдёт любой редактор веб-страниц.

Если текст состоит из нескольких строк, SFX-модуль трактует закрывающую фигурную скобку ('}') как признак конца текста, поэтому этот символ не следует указывать в тексте в самой первой позиции строки. Если же символ '}' всё-таки нужно использовать в начале строки, вставьте перед ним знак пробела.

Пример

License=Лицензионное соглашение

{

Все права на программу RAR принадлежат исключительно её автору.

Это условно-бесплатная программа (shareware), её можно использовать в течение пробного периода.

По окончании этого периода вы ОБЯЗАНЫ зарегистрировать программу".

}


SFX-параметры: Дополнительно

Эта вкладка окна Дополнительные параметры SFX содержит следующие элементы:

Файлы для удаления в папке назначения

Перед началом извлечения SFX попытается удалить один или несколько указанных файлов в целевой папке. Здесь можно указать несколько имён файлов, разделяя их пробелами.

Если указанный в этом поле файл заблокирован другим процессом и потому не может быть удалён, SFX-модуль перед извлечением попытается его переименовать, дав временное имя, а после перезагрузки Windows — удалить. Успех операции зависит от версии Windows.

Соответствующая команда SFX-сценария: Delete

Ярлыки

После распаковки создать ярлыки для извлечённых из архива файлов. Нажмите кнопку Добавить ярлык, чтобы задать параметры ярлыка. Параметры ярлыков см. в описании команды сценариев Shortcut. Область ниже кнопки Добавить ярлык содержит уже введённые ярлыки, при необходимости их можно здесь отредактировать.

Соответствующая команда SFX-сценария: Shortcut

Запрашивать права администратора

Включите, если нужно создать SFX-архив, который должен требовать права администратора при запуске в Vista или более новых версиях Windows. На поведение SFX-архива в старых версиях Windows этот параметр не влияет.

Соответствующий ключ командной строки: -iadm


SFX-параметры: Общие

Эта вкладка окна Дополнительные параметры SFX содержит следующие элементы:

Путь для распаковки

Здесь можно указать предлагаемый по умолчанию путь для извлечения файлов. Доступно три варианта: создавать путь в пользовательской папке Program Files, в текущей папке, или же указать абсолютный путь. В первых двух случаях введённый путь не должен начинаться ни с буквы диска, ни с обратной косой черты ("\"). При указании абсолютного пути, напротив, он должен начинаться с буквы диска или с "\".

Соответствующая команда SFX-сценария: Path

Сохранять и восстанавливать пути

Если включено, SFX сохраняет в реестре указанный пользователем целевой путь, который затем восстанавливается при следующем запуске SFX-архива, у которого то же содержимое поля Путь для распаковки. Исходный путь помещается в список, связанный с полем ввода целевого пути, поэтому пользователь может выбирать между ранее введённым и исходным путями.

Может быть полезно при установке новых версий или обновлений ПО в одну и ту же папку, так как позволяет изменить предлагаемый путь на желаемый лишь единожды, а не вводить его каждый раз заново.

Для использования этой функции необходимо, чтобы поле Путь для распаковки было непустым.

Соответствующая команда SFX-сценария: SavePath

Кнопка Сохранить текущие параметры как стандартные

Отображается, только если окно Дополнительные параметры SFX вызвано из команды Преобразовать архивы в SFX. Нажмите эту кнопку, чтобы запомнить установки на всех вкладках данного окна. Сохранённые параметры будут в дальнейшем применяться только при преобразовании архивов в самораспаковывающиеся. Для других модифицирующих архивы команд используйте профиль архивации по умолчанию.


SFX-параметры: Лицензия

Эта вкладка окна Дополнительные параметры SFX содержит следующие элементы:

Заголовок окна с лицензией

Введённый в этом поле текст будет отображаться как заголовок окна с лицензионным соглашением.

Соответствующая команда SFX-сценария: License

Текст лицензии

В этом поле вводится текст лицензионного соглашения, отображаемого при запуске SFX-архива. Пользователь может либо принять его и продолжить распаковку архива, либо не принимать и выйти.

Лицензионное соглашение может быть как в формате HTML, так и в виде обычного текста. В последнем случае SFX-модуль объединяет и переформатирует указанные текстовые строки так, чтобы они оптимально заполняли окно. Поэтому если нужно начать новый абзац, вставьте перед ним пустую строку.

С помощью языка HTML можно управлять цветами, шрифтами и форматированием выводимого текста. С описанием синтаксиса HTML можно ознакомиться на сайте Консорциума World Wide Web (www.w3.org). Для подготовки текста в формате HTML подойдёт любой редактор веб-страниц.

Соответствующая команда SFX-сценария: License

Кнопка Загрузить текст из файла

Нажмите, чтобы выбрать файл, содержимое которого будет загружено как текст лицензии.


SFX-параметры: Режимы

Эта вкладка окна Дополнительные параметры SFX содержит следующие элементы:

Временный режим / Распаковать во временную папку

Если включить этот параметр, SFX-модуль при выполнении создаст временную папку, извлечёт в неё все файлы, запустит программу, указанную в поле Программа установки / Выполнить после распаковки, а по завершении работы этой программы удалит временную папку со всем её содержимым. При всех этих операциях SFX-модуль автоматически использует "тихий" режим вывода информации Не показывать начальное окно, но при желании его можно переопределить на режим Скрыть всё (см. ниже). В качестве временной папки для распаковываемых файлов используется текущая папка программы установки.

Кроме того, можно ввести два необязательных строковых параметра, определяющих вопрос и заголовок окна с вопросом, выводимых перед извлечением. В этом случае извлечение начнётся, только если пользователь нажмёт кнопку Да.

Если вы включили параметр Распаковать во временную папку, то должны также указать программу установки. В этом режиме поле Путь для извлечения игнорируется.

Этот параметр может не работать с программой установки, которая прерывается раньше, чем её дочерний процесс. См. подробности в описании команды TempMode.

Соответствующая команда SFX-сценария: TempMode

Режим вывода информации

По умолчанию SFX-модуль запрашивает подтверждение перед началом извлечения и позволяет пользователю изменить путь распаковки. Выберите Не показывать начальное окно, чтобы не отключить этот запрос. Если также нужно запретить вывод лицензионного соглашения и информации о распаковке архива, выберите опцию Скрыть всё.

Соответствующая команда SFX-сценария: Silent


SFX-параметры: Модуль

На этой вкладке окна Дополнительные параметры SFX можно выбрать модуль самораспаковки. Обратите внимание, что не все SFX-модули поддерживают дополнительные параметры. Расширенные настройки есть у GUI-модулей RAR и ZIP (Default.SFX и Zip.SFX). Консольный модуль RAR (WinCon.SFX) дополнительных настроек не имеет.


SFX-параметры: Установка

Это вкладка окна Дополнительные параметры SFX содержит следующие элементы:

Выполнить после распаковки

SFX попытается выполнить указанную программу после успешного завершения извлечения. Перед выполнением программы текущей назначается папка с извлечёнными файлами. Если имя программы содержит пробелы, оно должно быть заключено в кавычки.

Разрешается указывать несколько команд установки, по одной на строку. Если вы не хотите, чтобы все программы установки запускались одновременно, включите параметр Ждать и устанавливать код возврата.

См. дополнительную информацию в описании команды Setup.

Соответствующая команда SFX-сценария: Setup

Выполнить до распаковки

SFX попытается выполнить указанную программу до начала извлечения файлов, поэтому программа уже должна быть на диске. Перед выполнением программы текущей назначается целевая папка. Если имя программы содержит пробелы, оно должно быть заключено в кавычки. Эту команду можно использовать, например, для удаления предыдущей версии ПО, когда новая версия устанавливается поверх старой.

Разрешается указывать несколько программ, по одной на строку. SFX ждёт завершения работы каждой такой программы, прежде чем запустить следующую или продолжить, приступив к распаковке данных.

Соответствующая команда SFX-сценария: Presetup

Ждать и устанавливать код возврата

Если включено, SFX ждёт завершения работы каждой программы установки, указанной для запуска после извлечения данных, и устанавливает код возврата исполняемого SFX-файла равным коду возврата программы установки. Если из-за какой-либо ошибки SFX не может запустить программу установки, то он возвращает свои собственные коды ошибки, такие же, как коды возврата WinRAR. Коды возврата можно изменить на указанную величину, введя её в поле Коррекция кода возврата.

Коррекция кода возврата

Так как у задаваемой пользователем программы установки и SFX-модуля могут оказаться одинаковые коды возврата, определяющие разные события, с помощью параметра Коррекция кода возврата можно разнести коды в разные области. Если указать положительное целое число, то оно будет добавляться к кодам возврата программы установки, в то время как SFX будет возвращать свои коды как они есть. Если же указать отрицательное целое число, то его абсолютное значение будет добавляться к собственным кодам возврата SFX, а коды возврата программы установки меняться не будут. Укажите в этом поле 0 (ноль), чтобы коды возврата программы установки и SFX не изменялись.

См. дополнительную информацию в описании команды SetupCode.

Соответствующая команда SFX-сценария: SetupCode


SFX-параметры: Текст

SFX-параметры: Текст и графика

Эта вкладка окна Дополнительные параметры SFX содержит следующие элементы:

Заголовок окна SFX

Введённый в этом поле текст будет отображаться как заголовок окна SFX-архива.

Соответствующая команда SFX-сценария: Title

Текст в окне SFX

В этом поле нужно указать сообщение, которое будет отображаться в окне SFX-архива.

Сообщение может быть как в формате HTML, так и в виде обычного текста. В последнем случае SFX-модуль объединяет и переформатирует указанные текстовые строки так, чтобы они оптимально заполняли окно. Поэтому если нужно начать новый абзац, вставьте перед ним пустую строку.

С помощью языка HTML можно управлять цветами, шрифтами и форматированием выводимого текста. С описанием синтаксиса HTML можно ознакомиться на сайте Консорциума World Wide Web (www.w3.org). Для подготовки текста в формате HTML подойдёт любой редактор веб-страниц.

Соответствующая команда SFX-сценария: Text

Кнопка Загрузить текст из файла

Нажмите, чтобы загрузить содержимое выбранного файла как текст для окна SFX.

Загрузить логотип SFX из файла

Укажите здесь графический (*.bmp) файл с изображением логотипа для создаваемого или обновляемого SFX-архива.

Стандартный размер логотипа SFX — 93×302 пиксела. Рекомендуется использовать изображения такого же или меньшего размера.

Если вы собираетесь менять логотип, SFX-модуль не должен быть сжат какой-либо программой упаковки исполняемых файлов (например UPX).

Соответствующий ключ в командной строке: -iimg.

Загрузить значок SFX из файла

В этом поле можно указать файл .ico со своим собственным значком, чтобы заменить им стандартный значок модуля SFX. При этом SFX-модуль не должен быть сжат какой-либо программой упаковки исполняемых файлов (например UPX).

Соответствующий ключ в командной строке: -iicon


SFX-параметры: Обновление

Эта вкладка окна Дополнительные параметры SFX содержит следующие элементы:

Режим обновления

· Извлечь и заменить файлы

Извлечь из архива все файлы вне зависимости от их времени.

· Извлечь и обновить файлы

Извлечь только те файлы, копий которых нет в папке назначения, или если извлекаемые файлы более новые, чем имеющиеся.

Соответствующая команда SFX-сценария: Update=U

· Обновить только существующие файлы

Извлечь только те файлы, которые есть в папке назначения и их дата более старая, чем у соответствующих файлов в архиве. Если одноимённого файла на диске нет, то он пропускается.

Соответствующая команда SFX-сценария: Update=F

Режим перезаписи

· Выдавать запрос перед перезаписью (действие по умолчанию)

Запрашивать действие перед перезаписью файла.

· Перезаписывать все файлы без запроса

Перезаписывать файлы без выдачи запросов пользователю.

Соответствующая команда SFX-сценария: Overwrite=1

· Пропускать существующие файлы

Не перезаписывать уже имеющиеся файлы.

Соответствующая команда SFX-сценария: Overwrite=2


SFX-команды: Overwrite

Overwrite=[n]

Если параметр 'n' равен 0 (нулю), то при перезаписи существующих файлов будет выдан запрос подтверждения. Это действие выполняется по умолчанию, поэтому для него необязательно указывать команду Overwrite. Если параметр 'n' отсутствует или равен 1, то все файлы будут перезаписываться без подтверждения. Если 'n' — 2, то перезаписи имеющихся файлов не будет.

Пример

Overwrite=1


SFX-команды: Path

Path=<путь>

Устанавливает путь, используемый по умолчанию для распаковки файлов. Абсолютные пути, т.е. начинающиеся с "<буквы диска>:", используются без изменений. Если <путь> содержит только имя, то он будет рассматриваться как начинающийся от папки Program Files. Если вы хотите отменить подобное поведение и создать указанную папку в текущей папке, то начните <путь> с символов ".\" (точка и обратная косая черта).

Примеры

а) Установить в качестве пути по умолчанию папку "Program Files\Calc 3.05":

Path=Calc 3.05

б) Установить в качестве пути по умолчанию папку "C:\Calc":

Path=C:\Calc

в) Установить в качестве пути по умолчанию папку "Calc" без какого-либо предшествующего пути:

Path=.\Calc

Примечания

  1. В Path можно указывать системные переменные окружения в формате %varname% (например "Path=%APPDATA%\MyApp"). SFX-модуль раскрывает их автоматически. Динамические переменные окружения, такие как %date% или %random%, не раскрываются.
  2. SFX-модуль устанавливает переменную окружения sfxstime, содержащую время запуска модуля в формате "ГГГГ-ММ-ДД-ЧЧ-ММ-СС-мс". Её можно указывать в команде Path, если требуется генерировать уникальный путь установки ПО на основе времени, например "Path=MyApp-%sfxstime%"


SFX-команды: Presetup

Presetup=<программа>

SFX-модуль попытается выполнить <программу> до начала извлечения файлов, поэтому она уже должна быть на диске. Перед выполнением программы текущей папкой становится целевая папка. Эту команду можно использовать, например, для удаления предыдущей версии ПО при установке новой версии поверх старой. Если имя программы содержит пробелы, то оно должно быть заключено в кавычки.

Пример

Presetup=uninstall.exe /clean

Примечание

Если в комментарии архива нет команд Setup или Presetup, то вместо кнопки Установить отображается кнопка Извлечь. Если нужно, чтобы отображалась кнопка Установить, но никакие программы установки не выполнялись, добавьте команду Setup без параметров.


SFX-команды: пример сценария

Приведённый ниже сценарий устанавливает для окна заголовок "Калькулятор v3.05", изменяет выводимый перед распаковкой стандартный текст на указанный, устанавливает путь распаковки по умолчанию в "Program Files\Calculator", разрешает перезапись существующих файлов и запускает файл setup.exe после извлечения из архива всех файлов.

Title=Калькулятор v3.05

Text

{

"Калькулятор" - условно-бесплатная программа. Вы можете

использовать её в течение 40-дневного пробного периода.

Если вы хотите с ней работать и по окончании этого

испытательного периода, то ДОЛЖНЫ зарегистрироваться.

}

Path=Calculator

Overwrite=1

Setup=setup.exe


SFX-команды: SavePath

SavePath

Эта команда позволяет SFX сохранять в реестре указанный пользователем целевой путь, который затем восстанавливается при следующем запуске SFX-архива, у которого тот же параметр команды Path. Исходное значение команды Path помещается в список, связанный с полем ввода целевого пути, поэтому пользователь может выбирать между ранее введённым и исходным путями.

Может быть полезно при установке новых версий или обновлений ПО в одну и ту же папку, так как позволяет изменить предлагаемый путь на желаемый лишь единожды, а не вводить его каждый раз заново.

Команду SavePath можно использовать только в сочетании с командой Path.

Пример

Path=Calc 3.05

SavePath


SFX-команды: Setup

Setup=<программа>

После удачного извлечения файлов SFX-модуль попытается запустить указанную <программу>. Перед запуском программы текущей станет папка, в которую были извлечены файлы. Если в имени программы есть пробелы, то оно должно быть заключено в кавычки.

Пример

Setup=setup.exe

Примечания

  1. В случае проблем при использовании SFX для запуска файла setup.exe, созданного пакетом InstallShield, попробуйте вместо обычной командной строки "setup.exe" использовать "setup.exe /SMS". Ключ /SMS позволяет SFX-модулю определить завершение работы установщика InstallShield.
  2. Если указанная в команде Setup программа не имеет никаких параметров, то с помощью ключа -sp<параметр> в командной строке SFX можно передавать этой программе дополнительные параметры.
  3. Перед запуском программы установки SFX-модуль создаёт переменные окружения sfxname, sfxcmd и sfxpar. В переменной sfxname содержится имя SFX-архива. Переменная sfxcmd содержит полную командную строку, полученную SFX-модулем, первый параметр этой командной строки — имя SFX-модуля. Переменная sfxpar содержит только параметры командной строки, без имени SFX-модуля. Таким образом, если программе установки нужны такие сведения, она может прочитать их из этих переменных. Кроме того, в качестве параметра можно указывать развёрнутое %имя_переменной%, например "Setup=setup.exe %sfxpar%".
  4. Если в комментарии архива нет команд Setup или Presetup, то вместо кнопки Установить отображается кнопка Извлечь. Если нужно, чтобы была кнопка Установить, но никакие программы установки не выполнялись, добавьте команду Setup=<>. Либо, если вы настраиваете SFX-архив в окне параметров SFX, просто укажите <> в качестве имени программы установки. SFX-модуль не будет пытаться выполнить программу с таким именем, но изменит надпись на кнопке.


SFX-команды: SetupCode

SetupCode[=параметр]

Если присутствует эта команда, SFX-архив ждёт, пока завершит работу программа, указанная в команде Setup или Presetup, и использует её код возврата как код возврата исполняемого SFX-файла.

Если из-за какой-либо ошибки SFX не может запустить программу установки, он возвращает свои собственные коды ошибки, такие же, как коды возврата WinRAR.

Так как у программы установки и SFX-модуля могут быть одинаковые коды возврата, определяющие разные события, эта команда позволяет разнести коды в разные области.

Если параметр — положительное целое число, он добавляется к кодам возврата программы установки. Коды возврата SFX при этом не корректируются.

Если параметр — отрицательное целое число, его абсолютное значение добавляется к собственным кодам возврата SFX. Коды возврата программы установки не корректируются.

Если параметр равен 0 (нулю), то не корректируются коды возврата ни SFX, ни программы установки .

Если параметр не указан, то подразумевается 1000, то есть "SetupCode" и "SetupCode=1000" эквивалентны.

Допустим, указана команда "SetupCode=1000". Если SFX-модуль не смог запустить программу установки, то он вернёт собственный код меньше 1000, например 3, если обнаружена ошибка контрольной суммы. Если SFX-модуль успешно запустит программу установки и она завершится с нулевым кодом возврата, то SFX вернёт 1000. Если программа установки вернёт 10, то SFX вернёт 1010.

Если же указана команда с отрицательным целым числом, например "SetupCode=-1000", то при ошибке контрольной суммы SFX вернёт 1003. Если программа установки вернёт 0, то и SFX вернёт 0, а если 10, то 10.

Если используются несколько команда Setup и Presetup и присутствует SetupCode, то SFX будет ждать завершения каждой команды Setup и Presetup и вернёт наибольший код возврата, установленный программами установки.

Пример

Setup=setup.exe

SetupCode


SFX-команды: Shortcut

Shortcut=<Тип>,<ИсходныйФайл>,<ЦелеваяПапка>,<Описание>,<ИмяЯрлыка>,<ЗначокЯрлыка>

Эта команда создаёт ярлык для извлечённого из архива файла.

Тип — это односимвольное поле, которое может принимать следующие значения:

D | Создать ярлык на рабочем столе
P | Создать ярлык в меню Пуск/Программы
T | Создать ярлык в папке Автозагрузка

ИсходныйФайл — имя извлекаемого из архива файла, для которого нужно создать ярлык. Если это исполняемый файл, то после имени файла можно указать дополнительные параметры, заключив его в кавычки.

ЦелеваяПапка — результирующая папка, в которой нужно создать ярлык; если указанной папки не существует, то она будет создана SFX-архивом.

Описание — текстовая строка с описанием ярлыка.

ИмяЯрлыка — имя файла .lnk (ярлыка), создаваемого SFX-архивом.

ЗначокЯрлыка — имя файла со значком, ассоциированного с ярлыком. Если этот параметр пропущен, то будет использоваться стандартный значок. Если имя файла со значком не содержит полного пути, SFX-архив будет искать файл значка в папке с извлечёнными файлами.

Все параметры разделяются запятыми. Если внутри какого-либо параметра требуется наличие запятых, весь такой параметр должен быть заключён в кавычки. Если требуется вставить в строку знак кавычек, введите его дважды. Обязательно указывать только Тип и ИсходныйФайл, остальные параметры факультативные — их можно пропустить или оставить пустыми.

Примеры

1. Создать ярлык на рабочем столе в папке WinRAR для извлекаемого из архива файла winrar.exe с описанием "Исполняемый файл WinRAR", названием ярлыка "Архиватор WinRAR" и значком winrar.ico:

Shortcut=D,winrar.exe,WinRAR,"Исполняемый файл","Архиватор WinRAR",winrar.ico

2. Предоставить дополнительные параметры для rar.exe, исключить параметры ЦелеваяПапка и ЗначокЯрлыка:

Shortcut=D, "rar.exe" a -ag c:\mydata\backup\daily c:\mydata\files, , Daily backup, Backup


SFX-команды: Silent

Silent[=параметр]

Приступить к извлечению, не показывая начальное окно. Файлы будут извлечены либо в папку, указанную в команде Path, либо в текущую папку, если путь по умолчанию не задан.

Параметр можно принимать значения 1 или 2.

Если параметр равен 1, начальное окно скрывается полностью, включая индикатор выполнения и имена файлов. Также в этом режиме SFX не выводит окно с лицензионным соглашением.

Если параметр не указан или равен 2, то пропускается подтверждение начала извлечения, но процесс распаковки пользователю виден.

Пример

Silent=2


SFX-команды: TempMode

TempMode=[запрос][,заголовок]

Если в сценарии указана эта команда, SFX создаёт временную папку, извлекает в неё все файлы, запускает программу, определённую в команде Setup, а после завершения работы этой программы удаляет временную папку со всем её содержимым. При выполнении этих операций SFX-модуль автоматически устанавливает "тихий" режим в значение 2, не выводя начальное окно, но при желании этот режим можно переопределить, указав команду Silent с другим параметром. В качестве временной папки для распаковываемых файлов используется текущая папка программы установки.

Команда TempMode может иметь необязательный строковый параметр, определяющий строку запроса и заголовок окна с запросом, отображаемого перед началом извлечения. В этом случае извлечение начнётся только если пользователь нажмёт кнопку Да.

Если присутствует команда TempMode, то в сценарии также должна содержаться команда Setup. Команда Path в этом режиме игнорируется.

В режиме TempMode для удаления временных файлов SFX-модулю требуется определять, что программа установки прекратила работу. Такой метод работает правильно, только если программа установки не завершает свою работу до окончания установки. Однако иногда программа установки порождает дочерний процесс, а сама прекращает работу, предполагая, что установку завершит дочерний процесс. В таком случае SFX удаляет временные файлы сразу же после того, как обнаружит, что основная программа установки завершила работу, а это приводит к сбою в работе дочернего процесса. Поэтому TempMode корректно функционирует только с теми программами установки, которые не порождают дочерних процессов или, по крайней мере, не завершают свою работу до тех пор, пока не закончат работать все дочерние процессы.

Примеры

а) TempMode

б) TempMode=Продолжить установку Calculator 3.05?,Установка калькулятора


SFX-команды: Text

Для этой команды поддерживаются два вида синтаксиса:

1.

Text=<строка>

2.

Text

{

строка1

строка2

…

}

Команда Text добавляет указанные обычные текстовые или HTML-строки в окно вывода текста SFX-модуля. Первая команда Text очищает окно от стандартного текста перед добавлением <строки>. Следующие команды добавляют <строку> к уже существующему тексту.

В зависимости от используемого синтаксиса, эта команда может добавлять одну либо несколько строк за раз.

Если используется обычный текст, SFX-модуль объединяет и переформатирует текстовые строки так, чтобы они оптимально заполняли окно. Поэтому если нужно начать новый абзац, вставьте перед ним пустую строку.

С помощью языка HTML можно управлять цветами, шрифтами и форматированием выводимого текста. С описанием синтаксиса HTML можно ознакомиться на сайте Консорциума World Wide Web (www.w3.org). Для подготовки текста в формате HTML подойдёт любой редактор веб-страниц.

Если текст состоит из нескольких строк, SFX-модуль считает символ "}" признаком конца текста, поэтому этот символ не следует указывать в тексте в самой первой позиции строки. Если символ "}" всё-таки нужно использовать в начале строки, вставьте перед ним пробел.

Примеры

1) Добавить в окно одну строку:

Text=Это моя новая программа

2) Добавить в окно указанный текст:

Text

{

Наиболее интересные возможности программы:

- поддержка буфера обмена Windows;

- работа с файлами размером до 10 КБ каждый;

}


SFX-команды: Title

Title=<заголовок>

Эта команда устанавливает заголовок окна SFX-архива.

Пример

Title=Калькулятор, версия 3.05


SFX-команды: Update

Update=<режим>

Параметр <режим> это буква U или F.

Если указана буква U, то SFX-модуль извлечёт файлы, копий которых ещё нет на диске, а также файлы с датами более новыми, чем у одноимённых файлов на диске.

Если указана буква F, то SFX-модуль извлечёт только те файлы, копии которых на диске имеют более старые даты. Если в целевой папке нет файла с таким же именем, как у файла в архиве, то такой файл в режиме F извлечён не будет.

Пример

Update=U


Ключ -ME[параметры] - задать параметры шифрования

Ключ -ME[параметры] — задать параметры шифрования

В настоящее время поддерживается только один параметр: ZL (Zip Legacy — традиционное старое шифрование ZIP). Укажите ключ -mezl вместе с -p[пароль], чтобы создать зашифрованный ZIP-архив с использованием устаревшего алгоритма шифрования ZIP. Без ключа -mezl архивы ZIP шифруются с помощью алгоритма AES-256 — значительно более надёжного, но несовместимого со старыми программами распаковки ZIP-архивов.

Пример

Создать зашифрованный архив, используя устаревшее ZIP-шифрование:

WinRAR a -s -pmypassword -mezl docs.zip *.txt


Выбор кнопок панели инструментов

В этом окне можно указать, какие кнопки должны присутствовать на панели инструментов при просмотре папок на диске (группа Кнопки вне архивов) и при просмотре содержимого архивов (группа Кнопки внутри архивов).

Порядок расположения кнопок можно менять. Для этого просто выделите кнопки, которые хотите переместить, и нажмите кнопку Выше или Ниже. Если нужно восстановить стандартную конфигурацию панели инструментов, нажмите кнопку По умолчанию.

Кнопка Разделитель служит для вставки разделяющей линии перед выбранной в данный момент кнопкой. Чтобы удалить разделитель, либо снимите с него отметку, либо поместите на него курсор и нажмите кнопку Разделитель.

Кроме того, кнопки можно перетаскивать мышью прямо на панели инструментов, если удерживать нажатой клавишу Alt.