UniChat. Инструкция по применению.

Программа создавалась с целью заменить ProChat и Intranet Chat

(взять все лучшее из этих чатов и при этом избежать их ошибок и недостатков).

Общие сведения.

Программа предназначена для общения OnLine в локальных сетях (LAN) Intranet, а также в многосегментных сетях и Internet.

Основные особенности:

1. Поддержка выделенного сервера.

2. Широковещание.
3. Полноцветные графические смайлы.
4. Полная поддержка полов пользователей.
5. Стилизованный дружественный интерфейс.
6. Личные разговоры.
7. Личные сообщения.
8. Комнаты.

9. Фильтрация.

10. Доска объявлений.

11. Макросы.
12. Строчные команды.
13. ... Оцените сами!

Начало работы.

Для начала необходимо настроить подключение. По возможности (особенно если вы в этом не разбираетесь) осуществляйте настройки сетевого подключения под руководством администратора сети. Если используется широковещание, вы должны правильно прописать широковещательный IP-адрес. Выглядит это так: ХХХ.ХХХ.ХХХ.255 (где ХХХ.ХХХ.ХХХ часть IP-адреса вашей сети). Если вы используете выделенный сервер, просто пропишите его IP-адрес и порт. После смены типа подключения программу необходимо перезапустить.

Имя пользователя.

По умолчанию программа использует в качестве ника имя пользователя из логина Windows. Чтобы это изменить, вам нужно переключить опцию «Имя пользователя из логина Windows» на «Последний использованный из списка». Далее пропишите свой новый ник, укажите пол, и добавьте в список. Для быстрого выбора и смены имени из вашего списка используйте его аналог над списком пользователей. Если выбрана и активирована опция «Имя пользователя из логина Windwos», вы можете задействовать функцию «Определять пол из списка» (чат попытается найти имя логина в списке пользователей, определить пол и использовать его. В противном случае будет выставлен мужской пол).

Главное окно.

Здесь все предельно просто. В строке редактора вы пишите текст и, по нажатию на Enter, он публикуется в текущем активном канале.

Основной.

Основной разговор. Текст в этом потоке видят все пользователи.

Объявления.

Здесь вы можете разместить небольшое текстовое сообщение или объявление. Объявления могут быть многострочными – для этого вы можете растянуть текстовый редактор немного вверх и использовать Ctrl+Enter для перехода на новую строку. Если вы не хотите пользовать данной комбинацией, можно использовать символ «\n», который будет интерпретироваться как переход на новую строку. Во всех остальных каналах многострочный текст преобразовывается в однострочный, указанный выше символ игнорируется.

Разговор.

Он же приват. Текст набранный в этом канале отправляется непосредственно вашему собеседнику. Этот канал не доступен никому кроме вас двоих.

Комната.

Объединяет группу пользователей по интересам. По функциям это окно программы аналогично основному разговору, с той лишь разницей, что для начала комнату нужно создать и/или зайти. Для этого вам необходимо:

1. Нажать клавишу F2 либо выбрать «Комнаты» в меню «Разговор»;

2. В открывшемся окне будет 2 списка. Левый – ваш список комнат, правый – комнаты которые уже созданы и вы можете в них заходить;

3. Если вы просто хотите зайти в комнату, вам необходимо дважды щелкнуть по созданной комнате или выбрать комнату из вашего списка и нажмить «Создать ->». Если такой комнаты не было, вы ее создадите, если была – просто в нее зайдете;

4. Чтобы создать в своем списке комнату нажимайте «Добавить», чтобы удалить – одноименную кнопку.

Показывать список комнат другим пользователям. Если вы хотите чтобы список ваших комнат был доступен другим пользователям при просмотре вашей информации, а также предоставить свободный доступ пользователей в созданные вами комнаты, поставьте флажок у этой опции (и наоборот). Таким образом, можно избежать незваных гостей (если ваши друзья точно будут знать названия ваших комнат и также отключат эту опцию, то никто другой не попадет в вашу комнату).

Информировать пользователей о создании комнаты. Если комната не существовала и вы ее создаете, то при включенной опции все увидят сообщение «…. создал(а) команту #...». Если вы выключили предыдущую опцию, рекомендуется выключить и эту (для обеспечения полной секретности).

Отмеченные галочками в левом списке комнаты будут автоматически создаваться при старте чата. Если комнаты до этого не существовало, вы автоматически из создадите.

Активная комната при старте чата – программа автоматически установит нужную закладку при старте чата. В списке перечислятся только те комнаты, которые создаются при старте.

Использование функций чата.

Выберите в списке пользователя, к которому будут обращены ваши дальнейшие действия, затем нажимаете правую кнопку мыши, и в появившемся меню вы обнаружите следующее:

Сообщение. Вы можете отправить личное сообщение пользователю.

Разговор. Вы можете начать приватный разговор.

Сигнал. Вы можете посигналить пользователю.

Сказать. Вы можете обратиться к пользователю. В строке редактора появиться «-> Nick: ». Также эту функцию можно задействовать, если дважды кликнуть имя пользователя в тексте. При обращении (по умолчанию) текст у получателя будет подсвечен.

Информация. Здесь можно узнать логин, имя компьютера, IP-адрес, комментарий режима и другую информацию.

Фильтрация. Здесь вы можете настроить фильтры сообщений. Описание приведено ниже.

Обновить. Вы можете обновить список пользователей.

Многоадресное сообщение. Вы можете отправить сообщение нескольким пользователям сразу.

Текстовые команды.

Это команды, которые можно набирать в строке ввода текста. Любая команда начинается со знака «/».

/me <Текст>. Пользователи увидят текст от третьего лица типа «<YourNick> <текст>». Например предположим, что у вас ник Евлампий, набираете: /me ушел покушать, все пользователи видят строку: «Евлампий ушел покушать».

/topic <Новая тема> - сменить топик.

/join <Комната> - зайти в указанную комнату.

/here – перечисляет пользователей в текущей комнате.

/chat <Псевдоним> - аналогично «Разговор».

/whois <Псевдоним> - аналогично «Информация».

Понятие макросов.

Макросы – это заранее определенные текстовые строки, привязанные к «горячим клавишам». Доступно 12 макросов.

Чтобы записать макрос:

1. Набираете в строке ввода необходимый текст, но Enter не нажимаете;

2. Нажимаете Ctrl+Shift+F(1..12).

Чтобы вызвать ранее записанный макрос нажимаете Ctrl+F(1..12).

Фильтрация сообщений.

Предположим в вашей сети объявился флудер, который спамит сообщениями и делает другие малоприятные вещи.

1. Выбираете виновника в списке пользователей;

2. Нажимаете правую кнопку и выбираете «Фильтрацию»;

3. Далее тот пункт, который вам подходит.

Существует 6 видов фильтров, которые разделяются на 2 группы.

Группа фильтров по имени: фильтр будет срабатывать на псевдоним пользователя, независимо с какого компьютера он говорит.

Группа фильтров по IP-адресу: фильтр будет срабатывать на IP-адрес, независимо от псевдонима на данном IP.

Пояснение на примерах:

Многие утверждают, что фильтра по IP предостаточно, но это не всегда так. Например, за одной машиной могут работать ваш друг, его брат-флудер и, скажем, еще их продвинутая в современных технологиях бабушка. Вам нужно исключить речи брата-флудера. Фильтр по IP не позволит вам пообщаться со всеми тремя, в то время как фильтр по псевдониму прекрасно справиться с поставленной задачей.

Отсылать уведомление о фильтрации. Если фильтруемый по сообщениям и/или приватам попытается послать вам сообщение или начать разговор, то он получит сообщение вида:

[18:17:47] Вы добавлены в фильтр приватов у *****

[18:18:58] Вы добавлены в фильтр сообщений у *****

В противном случае никаких сообщений не будет.

Автоответ игнорируемым по сообщениям. Если задана не пустая строка и включены уведомления о фильтрации, то пользователь получит сообщение вида:

[18:18:58] Вы добавлены в фильтр сообщений у *****: [опять начинаешь, дремучий шакал??]

Автоответ игнорируемым по приватам. Если задана не пустая строка и включены уведомления о фильтрации, при попытке создать с вами разговор, фильтруемый пользователь получит сообщение вида:

[18:17:47] Вы добавлены в фильтр приватов у *****: [я с тобой не хочу разговаривать!!!]

Понятие о режимах.

Режим позволит вам уменьшить активность чата и пользователей по отношению к вам на период, пока вы находитесь в заданном режиме.

В UniChat реализовано 5 режимов. При переходе в режим пользователи получают уведомление типа «.*** вошел (шла) в режим **** [комментарий]». Также изменится ваша иконка в списке пользователей на условное обозначение режима.

Активен. Звуки есть, сообщения "выкидывают" из текущего окна.

Не беспокоить. Звуки есть. Сообщения приходят свернутыми.

Ушел. Звуки есть, сообщения "выкидывают" из текущего окна.

Отключен. Звуков нет. Сообщения не проходят.

Играю. Звуков нет. Сообщения приходят свернутыми.

Если человек получает сообщение/сигнал, то у отправителя появится "... получил сообщение/сигнал в режиме "..." [...]" В противном случае появится ".... находится в режиме ...."

Запрашивать комментарий режима. Перед переходом в режим появиться окно с запросом комментария. Рекомендуется включить. Комментарий режима позволит правильно вас понять.

Отключать смайлы в режиме «Игровой». Пока вы находитесь в этом режиме, смайлы не будут преобразовываться в картинки, что позволит экономить память если во время игры будут происходить активные разговоры с обилием смайлов.

Сменить комментарий. Вы можете изменить текущий комментарий режима. (Находится в меню «Режим»).

Информация о пользователе.

Краткие сведения о вас. Две этих опции находятся в пункте «Разговор» главного меню.

Информация о пользователе. Краткая строка, характеризующая вас и доступна для просмотра всем, кто посмотрит вашу ифнормацию.

Показывать активное окно. Если данная функция включена, пользователи смогут увидеть заголовок вашего активного окна, при просмотре вашей информации.

Протоколирование.

Включает 6 пунктов, разъяснять которые не требуется. Позволяет вести протоколы всех ваших разговоров.

Обзор функций, не вошедших в другие разделы.

Главное меню, пункт «Правка».

Скопировать все. Скопировать весь текст в текущей закладке.

Очистить чат. Очистить текст в текущей закладке.

Очистить строку. Очищает введенный, но не отправленный текст в троке ввода.

Очистить историю ввода. Очищает введенный вами строки из буфера. Т.е. после очистки вернуться к ранее набранному тексту стрелками «вверх» и «вниз» будет уже нельзя.

Послать ссылку. Отправить ссылку на файл, находящийся на вашем сетевом ресурсе.

Переключить раскладку. Произвести перевод набранного (или отмеченного) текста, набранного не в той раскладке и заодно ее переключить. Несмотря на то, что у пункта «Обратить» макрос не указан, он существует, эта комбинация клавиш Ctrl+Backspace.

Главное меню, пункт «Вид».

Список пользователей. Выбираете положение списка пользователей, слева или справа.

Временной штамп. Разъяснений не требуется.

Тип закладок. Разъяснений не требуется.

Полоса прокрутки редактора. Включает/выключает полосу прокрутки у редактора. На самом деле редактор многострочный, но замаскирован под одну строку. Если вам по душе лицезреть многострочный редактор – включайте эту опцию. Многострочность полезна, когда вы, например, хотите рассказать анекдот, скопированный из обычного TXT – текст вставиться многострочно, но при отправке автоматически преобразуется в одну строку.

Отрисовывыть смайлы. Преобразовывать символьные смайлы в графические.

Мигающий значок при изменениях. Если в чате появляется новая строка (в основном, комнате, привате), значок в трее будет мигать.

Мигать Scroll Lock. Аналогично, только мигать будет светодиод на клавиатуре.

Показывать тему. Разъяснений не требуется.

Показывать доску объявлений. Разъяснений не требуется.

Показывать инфо пользователя при наведении. Логин, имя компьютера и IP-адрес в всплывающей подсказке пользователя, на которого наведен курсор.

Сообщения в «Основном». Отправленные сообщения и полученные сообщения будут отображаться в «Основном».

Не раскрывать окно сообщения. Если вы включили «Сообщения в основном» и не хотите чтобы вас донимало всплывающее окно, можно активировать эту опцию в меню «Вид» (данная функция скрытая и вызывается нажатием сочетания клавиш Alt+Shift+BackSpace). Учтите, если вы включите эту опцию и выключите предыдущую, то вы вообще не сможете увидеть сообщения. Скрытость этой опции для того и сделана, чтобы вы понимали что делаете.

Главное меню, пункт «Настройки».

Всплывать на новую строку. Разворачивать окно чата на новую строку. Запускать свернутым. Пояснений не требуется. Следующие 2 пункта описаны в «Понятие о режимах». Общие настройки. Окно, включающее в себя основные настройки.

Общие настройки.

Общие.

Автообновление списка пользователей. Обновление списка по таймеру.

Горячая клавиша. Задать горячую клавишу для активизации окна чата.

Пользователи.

Сетевое подключение. Тип сетевого подключения.

Интерфейс.

Дублирует «Вид».

Звуки.

Включение/выключения звуков на указанные события.

Шрифты и цвета.

Настройка цветов и шрифтов для различных событий чата, также включает цвета и шрифты интерфейса.

Системные сообщения.

Включение/выключения различных системных сообщений чата.

Уведомления.

Включение/выключения различных системных сообщений чата в «воздушном шарике» иконки трея.

Фильтрация.

Управление фильтрами. Подробное описание есть в «Фильтрация сообщений».