О программе

Программа Cache Burst 32 является законченной полнофункциональной утилитой. Предназначена для анализа и диагностики работы подсистемы кэш и памяти компьютера. Позволяет оценить пропускную способность и латентность кэш и памяти.

Последнюю версию программы всегда можно найти на ее домашней странице: http://user.rol.ru/~dxover/cburst

Copyright (c)2002 Владимир Афанасьев & Сергей Романов


Лицензионное соглашение

Cache Burst 32 является свободно распространяемой программой и поставляется в виде "Как есть ". Автор не несет никакой ответственности за возможную порчу оборудования или информации в результате использования этой программы. Также он не дает никаких гарантий, явных или подразумеваемых, относительно корректности результатов и не несет ответственности за прямые или косвенные убытки, связанные с ее использованием. Перед применением программы настоятельно рекомендуется ознакомиться с разделом справки Системные требования. Вы, как конечный пользователь, имеете право свободно использовать и распространять в неизменном виде данную программу при условии отсутствия коммерческой выгоды от этого.


Системные требования

  • Операционная система Microsoft Windows 95/98/Me/NT/2000/XP.
  • x86 совместимый центральный процессор поддерживающий инструкции CPUID и RDTSC *.
  • Объем свободной физической памяти не менее 36 Мб.

* Желательна поддержка процессором наборов инструкций MMX и SSE.

Перед использованием программы необходимо завершить все активные и фоновые приложения. В противном случае их работа будет полностью блокирована, на время выполнения тестов. Это может привести к потере данных и сбоям в работе приложений. Для получения более достоверных результатов желательно производить измерения сразу после загрузки Windows.


Описание кнопок

 Start
Запускает отмеченные флажками тесты на выполнение. По умолчанию выбраны тесты MMX Read/ Write и SSE Read/ Write . Если процессор не поддерживает технологии MMX и SSE, то соответствующие флажки выбора будут не доступны. Тест Memory Walk не может быть выбран совместно с любым другим тестом.
Report
Создает отчет в виде HTML файла и открывает его в вашем обозревателе Интернет, установленном по умолчанию. Для теста Memory Walk создается отдельный отчет. Одновременно с созданием отчета, значения графиков экспортируются в файл в формате CSV (разделители - точка с запятой) для дальнейшей обработки результатов в Microsoft Excel.
Exit
Завершает работу программы. Вы не можете отменить или остановить выполнение выбранных тестов до полного их завершения. Если это необходимо, снимите задачу средствами операционной системы.


Команды меню

 File
Команды этого меню полностью дублируют назначение кнопок .
Settings
Команда Colors этого меню позволяет переопределить цвета графиков.
Help
Содержит команды вызова Английской или Русской справки, а также окна About (О программе).


Настройки

 Start/End Block Size
Позволяет определить начальный и конечный размер блока данных для тестирования.
Read Latency Step
Позволяет задать шаг теста латентности чтения.
Memory Walk Start Step
Позволяет задать начальный размер шага для тестирования латентности памяти.
Copy to Itself
Становится активна только в случае выбора тестов копирования ( Copy/ MMX Copy/ SSE Copy ). С установленным флажком копирование блока данных осуществляется в тоже место, где находится сам копируемый блок, т.е. фактически содержимое памяти не изменяется. По умолчанию эта опция не выбрана и копирование осуществляется со смещением, равным длине перемещаемого блока данных. В связи со 100% попаданиями операций записи в кеш в Copy to itself мы тестируем, в основном,способность памяти к чтению после записи (read around write). В этом случае значительно выше утилизации кеш-памяти и тест является значительно более "лёгким" для подсистемы памяти, что обуславливает более высокие результаты и меньшее время тестирования.
Log Y Axis
С установленным флажком делает шкалу Y логарифмической.
4x Iteration
С установленным флажком увеличивает количество проходов в 4 раза. Это повышает стабильность результатов, но во столько же раз увеличивает время выполнения тестов.


Определение пропускной способности кэш и памяти

Пропускная способность определяется по тестам Read/ Write/ Copy (Чтение/ Запись/ Копирование), MMX Read/ MMX Write/ MMX Copy и SSE Read/ SSE Write/ SSE Copy.Тесты Read/ Write/ Copy определяют пропускную способность кэш и памяти в режиме 32 битной передачи данных. Тесты MMX Read/ MMX Write/ MMX Copy определяют пропускную способность кэш и памяти в режиме 64 битной передачи данных с использованием MMX инструкций. Тесты SSE Read/ SSE Write/ SSE Copy определяют пропускную способность кэш и памяти в режиме 128 битной передачи данных с использованием SSE инструкций.

Алгоритмы тестов пропускной способности кэш и памяти в Cache Burst 32 оптимизированы для работы с малыми блоками данных. Это сделано для получения адекватных результатов в кэш процессора. При использовании других алгоритмов возможно значительное улучшение показателей пропускной способности памяти на блоках данных превышающих размеры кэш.


Определение латентности кэш и памяти

Латентность кэш и памяти определяется по тестам Read Latency (Латентность чтения) и Memory Walk (Проход по памяти). Тест Read Latency наиболее эффективно показывает латентность кэш и отражает латентность чтения кеш и памяти для выбранного шага. Когда шаг меньше размера строки кеш, мы меряем время получения критического слова, поэтому для измерения латентности кеш L2, L3 или памяти необходимо выбрать шаг равный или превышающий размер строки кеш.
Тест Memory Walk служит для определения латентности памяти и также как тест Read Latency, определяет латентность чтения. Memory Walk измеряет латентность при всех шагах для блока памяти размером 32 мегабайта. Построение графика Memory Walk занимает несколько минут и прорисовывается с некоторыми паузами, это нормально.

Значения латентности кэш и памяти определяются в циклах процессора.


Известные недостатки

1. MMX/SSE скорости чтения, для размеров блоков превышающих размеры кэш, могут флуктуировать на некотрых компьютерах. Измените End Block Size, чтобы исправить это.

2. Латентность кэш L2 в 4 цикла, при шаге равном размеру строки кэш, является завышенной для процессоров AMD Athlon-Palomino и Duron-Morgan. Установите Read Latency Step в 128 байт для получения правильных результатов.

3.На некоторых компьютерах переход с кэш L1 на L2 или с L2 на L3 на графиках может начинаться раньше, чем действительный размер кэш L2 или L3. Перезапустите Cache Burst 32 (возможно несколько раз), чтобы исправить это.


Часто задаваемые вопросы

Пока нет часто задаваемых вопросов.


Что нового?

 Версия 0.90.70
- Первая доступная версия.
Version 0.90.91
- Добавлено определение Memory Peak Bandwidth.
- Добавлено определение новых процессоров.
- Некоторые дополнения, изменения и исправления ошибок.