ColorMania : Welcome

Добро пожаловать в ColorMania 3.2

от Blacksun Software

В этой справке представлены ответы на общие вопросы по использованию программы ColorMania, дано описание основных функций и назначение команд.

Если в этом документе вы не найдете ответы на некоторые вопросы, пожалуйста, отправьте e-mail с вашим вопросом (или вопросами) в службу технической поддержки Blacksun Software.

Если вы только первый раз запустили ColorMania, то знакомство с ней мы предлагаем вам начать с этой главы:
  • О программе ColorMania
    • Если же вам необходимо найти ответ или решение на определенный вопрос, то воспользуйтесь содержанием справки.

    Copyright © 2001-2011 Blacksun Software. All Rights Reserved


ColorMania : Info

ColorMania 3.2

О программе ColorMania

Если вы художник, веб-дизайнер или программист, то наверняка знаете, как бывает иногда сложно подобрать нужный цвет, который гармонично подходил к вашему проекту. Стандартные диалоги выбора цвета не позволяют решить эту задачу полностью, к тому же они не дают информацию о коде цвета, который необходимо использовать при проектировании. Чтобы восполнить этот пробел и была создана программа ColorMania, которая дает вам полный контроль над управлением цвета.

ColorMania - это идеальное решение как для домашних пользователей, так и для профессионалов. Утилита позволяет просмотреть, определить, выбрать, захватить, проверить и настроить цвет для различных форматов и цветовых моделей.

ColorMania имеет простой пользовательский интерфейс и, в сочетании с другими графическими программами, позволяет получить неоспоримое преимущество по работе с цветом в различных областях творческой деятельности. Этот инструмент обязательно должен быть в копилке полезных программ у каждого программиста, дизайнера или художника.

Особенности:
- Интуитивно-понятный интерфейс;
- Поддержка различных форматов цвета (включая формат Photoshop):
- Набор стандартных HTML цветов (безопасная палитра);
- RGB и HSV настройки цвета;
- Захват цвета и экранная лупа;
- Создание и сохранение пользовательских наборов цвета;
- Определение цвета по коду;
- Выбор цвета из цветового круга, случайно или диалога Windows.

Поддерживаемые форматы цвета:
- HTML Hex / CSS: наиболее распространенный формат, используется при создании документов с гипертекстовой разметкой (HTML / CSS);
- Delphi Hex: используется при программировании на языке Borland's Delphi;
- VB Hex: используется при программировании на языке Microsoft's Visual Basic;
- C++ Hex: используется при программировании на языке C++;
- RGB Values: используется в простейших программах для рисования;
- RGB% Values: используется в некоторых программах DTP, подобных Paint;
- HSV Values: используется в графических редакторах;
- CMY: используется в программах для рисования;
- CMYK: используется в некоторых программах DTP, подобных Paint;
- HLS: используется некоторыми программами;
- Photoshop: используется в программе Adobe Photoshop.

Программа ColorMania абсолютно бесплатна.


ColorMania : Installation

Установка

Шаг 1: Загрузите последнюю версию программы с сайта: Blacksun Software.

Шаг 2: Запустите файл установки и следуйте указания Мастера.

Системные требования

Минимальные
  • Операционная система: Windows 98/98SE/ME/NT/2000/XP/2003/Vista
  • Свободное место на диске: 4 Mб
Рекомендуемые
  • Память: 1 Гб ОЗУ
  • Операционная система: Windows XP/2003/Vista/7
Удаление

Метод 1: В меню ПУСК -> Программы -> ColorMania выберите пункт "Удаление". Запустится программа удаления. Следуйте указаниям на экране.

Метод 2: В панели управления Windows выберите приложение "Установка/Удаление программ". В списке установленных программ выберите "ColorMania", а затем нажмите кнопку "Добавить/Удалить". Запустится программа удаления. Следуйте указаниям на экране. .


ColorMania : History

История версий

версия 3.2 : Август 2011
- Автоматическое сохранение цветов палитры (исправлено)

версия 3.1 : Июль 2011
- Добавлена цветовая модель HSL
- Исправлено вычисление значений CMYK

версия 3.0 : Август 2009
- При ручном вводе кода цвета подтверждение можно выполнить клавишей [Enter]
- Добавлена функция Отманить/Повторить (10-ти уровневая)

версия 2.7 : Ноябрь 2008
- Быстрое обновление экранной лупы
- Улучшение отрисовки цветового круга

версия 2.6 : Январь 2008
- Добавлено отображение координат для инструмента "Пипетка"
- Добавлены горячие клавиши для управления координатами [Ctrl+Alt+C] и [Ctrl+Alt+X]
- Добавлен формат цвета Adobe Photoshop®

версия 2.5 : Апрель 2007
- Модернизация цветового круга (вращение и переворот)
- Небольшие улучшения интерфейса программы

версия 2.4 : Октябрь 2005
- Добавлена всплывающая подсказка для каждого цвета в секции "Палитра", которая показывает код цвета в соответсвии с установленным форматом
- Добавлено контекстное меню для секции "Палитра"
- Небольшие улучшения интерфейса программы

версия 2.3 : Июнь 2005
- Добавлена безопасная палитра HTML цветов
- Добавлена кнопка "Установить" при ручном вводе кода цвета
- Небольшие улучшения интерфейса программы
- Удалены цветовые соответствия
- Исправлена ошибка вычисления CMYK

версия 2.2 : Август 2004
- Различные мелкие изменения

версия 2.1 : Май 2004
- Добавлена поддержка тем Windows XP
- Добавлена диаграмма HSV
- Добавлена возможность выбора любого пикселя из эранной лупы

версия 2.0 : Декабрь 2003
- Добавлены настройки HSV (HSB)
- Добавлена поддержка различных форматов экрана
- Добавлены цветовые соответствия
- Добавлена визирная метка в экранную лупу
- Модернизация интерфейса

версия 1.1 : Июль 2003
- Добавлены индикаторы цвета RGB

версия 1.0 : Ноябрь 2002
- Первый релиз


Blacksun Software

Контактная информация

  • Домашняя страница:
    Blacksun Software Website

  • Техническая поддержка:
    support@blacksunsoftware.com

  • Другие вопросы:
    support@blacksunsoftware.com

    • Русификация программ

  • Автор перевода: Leserg

  • Сайт русификации:

            •
    Другая продукция Blacksun Software

  • X-Fonter : менеджер шрифтов

  • Disk Recon : анализ дискового пространства

  • ColorMania : выбор и определение цветов

  • Texefex : создание различных текстовых эффектов для документов и сайтов

  • Mousotron Pro : сбор различной статистики по манипулятору мышь.

  • Magnifixer : утилита для увеличения заданной области экрана.

    • Copyright © 2001-2011 Blacksun Software. All Rights Reserved


ColorMania : Working with..

Главное окно программы

После установки и запуска программы, перед вами появится главное окно ColorMania:

Рабочее окно программы условно можно разделить на 6 секций:

1. Идентификация цвета

Здесь вы можете увидеть цвет, который вы выбрали, а также определить его значение для различных форматов записи. И наоборот, если у вас есть значение цвета, то введя его в установленное поле, вы может увидеть, что он из себя представляет.

Более подробное описание этой секции смотрите в главе -> Идентификация цвета.

2. Настройки цвета (RGB и HSV)

Здесь вы можете более тонко настроить выбранный цвет, изменяя значения цветовых составляющих RGB (красный [R], зеленый [G], синий [B]) или регулируя значения HSV (оттенок [H], насышенность [S], яркость [V]). Вы также можете вводить числовые данные соответствующих параметров в установленные поля.

Более подробное описание этой секции смотрите в главе -> Настройки цвета.

3. Пользовательские наборы цвета

В этой секции вы можете создавать свои наборы, состоящих из шести различных цветов. Эти наборы можно сохранить на диск и при необходимости загрузить обратно в программу.

Более подробное описание этой секции смотрите в главе -> Палитра.

4. Стандартные HTML цвета

В этой секции вы можете выбрать один из стандартных HTML цветов, которые рекомендуется использовать при создании сайтов или веб-дизайне.

Более подробное описание этой секции смотрите в главе -> HTML цвета.

5. Цветовой круг

ColorMania также позволяет выбрать цвет нажатием по определенной области цветового круга. Выбранный таким образом цвет можно инвертировать. Цвет может быть еще выбран случайно или через стандартный диалог выбора цвета Windows.

Более подробное описание этой секции смотрите в главе -> Цветовой круг.

6. Увеличение области (Захват цвета)

С помощью инструмента "Пипетка" вы можете выполнить захват цвета из любой области Рабочего стола или приложения. Для более точного выбора цвета можно воспользоваться масштабированием (или увеличением) области, находящейся под курсором.

Более подробное описание этой секции смотрите в главе -> Захват цвета (увеличитель).


ColorMania : Color Display

Идентификация цвета

Панель идентификации цвета состоит из двух частей:

1. Предварительный просмотр цвета

В этой секции окна ColorMania вы можете визуально видеть выбранный вами цвет. Любые изменения с цветом, которые можно выполнить в других секциях программы, будут тут же отображены в окошке предварительного просмотра. Показываемый здесь цвет является главным (основным). Дополнительно можно включить или отключить отображение текста, для которого выбранный цвет будет служить фоном.

Окошко предварительного просмотра цвета

Как можно изменять цвет

Изменить цвет можно несколькими путями и все они описаны на страницах этого руководства. Вот краткий обзор:
 - Захват цвета из любой области Рабочего стола или
                приложения;
- Изменение значений RGB или HSV;
- Выбор цвета из цветового круга;
- Выбор цвета из пользовательского набора;
- Случайный выбор цвета (кнопка "Случайно");
- Инвертирование текущего цвета (кнопка "Обратить");
- Выбор цвета из списка HTML цветов;
- Ввод цветового кода в одном из известных форматов.

Как изменить цвет текста

Цвет для текста можно выбрать только из пользовательского набора цветов (секция "Палитра"). Нажмите правой кнопкой мышки по одному из шести цветов и в контекстном меню выберите пункт "Установить как цвет текста".

Как включить/отключить отображение текста

Вы можете отключить или включить отображение текста в окошке предварительного просмотра цвета. Для этого нажмите правой кнопкой мышки в любой части окна ColorMania, в контекстном меню выберите пункт "Отображение текста", а в нем отметьте или снимите отметку с пункта "Вкл./Откл. текст".

Как изменить шрифт текста

Для этого нажмите правой кнопкой мышки в любой части окна ColorMania и в контекстном меню выберите пункт "Показывать текст -> Изменить шрифт". Откроется стандартный диалог настроек шрифта. Выберите желаемый шрифт, укажите его параметры и подтвердите свой выбор.

2. Код цвета (формат)

При создании сайтов, веб-дизайне, программировании и т.д. требуется указывать код цвета для тех или иных элементов. Если, к примеру, цвет является стандартным (красный ,синий, зеленый) и не содержит оттенков, то указать его не сложно, достаточно ввести его название: red, blue, green и т.д. Но если цвет представляет собой оттенок одного из основных цветов или их совокупность, то без специальных инструментов очень тяжело сказать, какой у данного цвета код. Решить эту задачу позволяет программа ColorMania. Выбрав цвет и настроив его параметры вы тут же получите его код в одном из поддерживаемых форматов.

ColorMania поддерживает следующие форматы цвета:
- HTML Hex / CSS: наиболее распространенный формат, используется при создании документов с гипертекстовой разметкой (HTML / CSS);
- Delphi Hex: используется при программировании на языке Borland's Delphi;
- VB Hex: используется при программировании на языке Microsoft's Visual Basic;
- C++ Hex: используется при программировании на языке C++;
- RGB Values: используется в простейших программах для рисования;
- RGB% Values: используется в некоторых программах DTP, подобных Paint;
- HSV Values: используется в графических редакторах;
- CMY: используется в программах для рисования;
- CMYK: используется в некоторых программах DTP, подобных Paint;
- HLS: используется некоторыми программами;
- Photoshop: используется в программе Adobe Photoshop.
Любой из этих форматов вы можете выбрать из выпадающего списка, кликнув левой кнопкой мышки по элементу.

Как использовать код цвета в другой программе

Подберите необходимый цвет, выберите формат цвета и нажмите кнопку "Копировать". Код цвета будет скопирован в буфер обмена. Теперь перейдите в вашу программу и вставьте его из буфера обмена в необходимое поле или место. Для этого воспользуйтесь клавишными командами Windows ([Ctrl+V] - вставить.)

Пример: Если вы редактируете документ CSS, то установите в ColorMania формат цвета "HTML Hex / CSS". Подберите цвет, затем нажмите кнопку "Копировать". В редакторе CSS установите курсор в необходимую позицию, где требуется вставить код цвета, и по нажатию правой кнопки мышки в контекстном меню выберите команду "Вставить" (или нажмите клавиши [Ctrl+V]).

Как узнать цвет по его коду

ColorMania позволяет также показать цвет, если известен только его код в одном из поддерживаемых форматов. Для этого введите код цвета в поле кода и нажмите кнопку "Установить" (или нажмите клавишу [Enter]). В окошке предварительного просмотра вы тут же увидите цвет, который соответствует указанному коду.

Пример: Вы редактируете документ HTML (или CSS) и очень бы хотели узнать цвет, который используется одним из элементов. Выберите в программе ColorMania формат цвета "HTML Hex / CSS". Введите в поле код интересуемого вас цвета и нажмите кнопку "Установить" (или нажмите клавишу [Enter]).


ColorMania : RGB and HSV Sliders

Настройки цвета

Программа позволяет отобразить цвет с использованием двух цветовых моделей.

RGB - изображение в данной цветовой модели состоит из трех цветов: Red (красный), Green (зеленый) и Blue (синий). Эти цвета считаются основными. Другие цвета получаются путем смешения основных в различных пропорциях. Такая цветовая модель считается аддитивной. Значения цветов лежат в диапазоне от 0 до 255.

HSV - изображение в этой цветовой модели состоит из оттенка цвета [H], насыщенности [S] и яркости [V]. Эта модель является нелинейным преобразованием цветовой модели RGB. Значения оттенка лежат в диапазоне от 0° до 360° (угловая величина). Значения насыщенности и яркости могут принимать значения от 0 до 255.

Как изменить текущие значения цвета

Вы можете изменить текущие значения цвета, перемещая ползунок скроллбара влево или вправо. Например,

Альтернативно можно также ввести заданные значения в поля, расположенные с левой стороны от скроллбара.

Что означает настройка "Интенсивность"?

В цветовой модели RGB эта настройка является дополнительной. Позволяет изменять значения яркости одновременно (синхронно) для трех цветов: красного [R], зеленого [G] и синего [B].
Например,


ColorMania : Color Palette

Пользовательские наборы цвета

Секция "Палитра" предназначена для хранения пользовательских цветов и получения быстрого доступа к необходимому цвету. Для хранения цветов палитра содержит 6 ячеек.

Вы имеет возможность сохранить вашу палитру на жесткий диск в виде файла. Позже, при необходимости, вы можете загрузить её обратно в программу. Таким образом вы можете создать свои собственные, уникальные наборы цветов и в случае необходимости пользоваться ими. Файлы наборов имеют расширение *.PLT.

Загрузка или сохранение палитры

Чтобы сохранить текущий набор цветов, нажмите кнопку "Сохранить". откроется стандартный диалог сохранения файл, где вам нужно будет указать место записи и имя файла.
Чтобы загрузить ранее сохраненный набор цветов, нажмите кнопку "Загрузить". Откроется стандартный диалог выбора файлов. Найдите файл в проводнике, выберите его и нажмите кнопку "Открыть".

Как сохранить цвет в палитре

Чтобы сохранить текущий цвет в одной из шести ячеек, кликните по ячейке правой кнопкой мышки и в контекстном меню выберите команду "Сохранить цвет здесь".

Альтернативно сохранить цвет в одной из ячеек можно из окна предварительного просмотра цвета. Нажмите правой кнопкой в области цвета и в контекстном меню выберите команду сохранения в соответствующую ячейку (Цвет 1 ... Цвет 6).

Как выбрать цвет из палитры

Для выбора цвета из палитры, просто нажмите левой кнопкой мышки на ячейку с нужным цветом. Альтернативно кликните правой кнопкой мышки по ячейке с нужным цветом и в контекстном меню выберите команду "Установить как цвет фона".

Как установить цвет текста цветом из палитры

Чтобы изменить цвет текста в окне предварительного просмотра на один из цветов в палитре, нажмите правой кнопкой мышки на ячейку с нужным цветом и в контекстном меню выберите команду "Установить как цвет текста" (см. рис. выше).

Как скопировать код цвета

В программе имеется возможность копировать в буфер обмена код одного из цветов палитры. Например, ни один цвет палитры не является текущим, а вам необходимо получить код, поэтому нажмите правой кнопкой мышки на ячейку с нужным цветом и в контекстном меню выберите команду "Копировать код цвета" (см. рис. выше).


ColorMania : HTML Colors

HTML цвета

Эта секция предназначена для быстрого выбора одного из стандартных цветов HTML (всего 216).

HTML цвета были добавлены в программу намеренно, чтобы облегчить работу вед-дизайнеров. Цвета в списке упорядочены по именам в алфавитном порядке. Рядом с названием имеется образец цвета, который показывает как он выглядит.

Как выбрать HTML цвет

Чтобы выбрать один из цветов, нажмите по элементу выпадающего списка. Откроется список с набором цветов. Выберите один цвет, нажав на него левой кнопкой мышки.

Как узнать имя HTML цвета

Всякий раз, когда вы подбираете нужный цвет, выбираете его из цветового круга или выполняете захват, при совпадении его с одним из стандартных HTML цветов, имя цвета будет автоматически выбрано из списка и показано в поле "HTML цвет".


ColorMania : Color Wheel

Цветовой круг

Цветовой круг фактически представляет собой цветовую модель HSV (оттенок, насыщенность, яркость) только упрощенную. Здесь отсутствует величина яркости. Оттенок - угловая величина и меняется от 0° до 360°, т.е. представляет собой круг. Насыщенность (или контраст) линейная величина, которая меняется по направлению от центра круга к его границе. Чем дальше от центра, тем контрастнее, и наоборот. Выбрав здесь цвет, в настройках можно подрегулировать величину яркости. Чем больше значение яркости, тем светлее цветовой круг, и наоборот, чем меньше значение яркости, тем темнее цветовой круг.

При нажатии на кнопку "Обратить" выбранный ранее цвет инвертируется на обратный, т.е. значения цвета и яркости меняются на противоположные.

При нажатии на кнопку "Случайно" происходит случайный выбор цвета и цветового круга. Иногда это может потребоваться при создании чего-то креативного, необычного или фантастического, когда необходимо получить положительный толчок или направить мысли в нужное русло :)

При нажатии на кнопку "Выбрать" перед вами откроется стандартный диалог выбора цвета Windows. Он вам хорошо знаком, т.к. обычно здесь вы выбираете цвет при работе с различными редакторами.

При выборе цвета каким-либо иным способом цветовой круг автоматически подстраивается под текущие значения RGB и HSV цвета. Также это происходит при ручном изменении значений R (красный цвет), G (зеленый цвет), B (синий цвет), H (оттенок), S (насыщенность), V (яркость) в секции настроек цвета.

Как выбрать цвет

Чтобы выбрать цвет, просто кликните левой кнопкой мышки по желаемой области цветового круга. Если перемещать курсор в пределах цветового круга (при нажатой левой кнопке мышки), то и цвет будет соответственно меняться.


ColorMania : Screen Magnifier and Color Grabber

Захват цвета (увеличитель)

С помощью программы ColorMania вы можете выполнить захват цвета из любой области Рабочего стола или приложения. При этом захват цвета можно выполнить с точностью до одного пикселя, невзирая на высокие разрешения экрана. Область под курсором программа позволяет увеличить 20 раз, что даст вам возможность более точно выбрать необходимый цвет.

Как захватить цвет

Чтобы захватить цвет, нажмите на инструмент "Пипетка" левой кнопкой мышки и, удерживая её нажатой, перетащите курсор в область экрана, из которой вы хотите получить цвет. Для более точного позиционирования курсора, ориентируйтесь на область увеличения в программе. Для удобства выбора цвета, установите желаемую степень увеличения. Визирная метка показывает место в изображении, над которым в текущий момент находится курсор. Как только вы нашли необходимый цвет, отпустите левую кнопку мышки и указанный цвет будет выбран программой.

В то время пока вы перемещаете инструмент "Пипетка" по экрану, в секции захвата цвета ColorMania отображаются координаты текущего пикселя в соответствии с установленным разрешением монитора. Начало координат начинается в верхнем левом углу экрана. Координата Х проходит по горизонтали, слева направо, а координата Y проходит вертикально, сверху вниз. Программа позволяет для текущего положения курсора установить начальные значения координат (0,0). Для этого нажмите на клавиатуре сочетание клавиш [Ctrl+Alt+C]. После этого отсчет координат будет вестись относительно этой точки экрана. Таким образом можно определять линейные размеры (в пикселях) каких-либо элементов программ, частей изображений или расстояния между отдельными пикселями. Чтобы вернуть реальную точку отсчета координат, нажмите сочетание клавиш [Ctrl+Alt+X].

После того как вы отпустили левую кнопку мышки, в области увеличителя останется часть изображения, из которой вы также можете выбирать цвет. Для этого просто нажимайте на участки рисунка.

Как изменить уровень увеличения

Чтобы изменить масштаб в области увеличения, воспользуйтесь выпадающим списком, где можно выбрать один из уровней масштабирования от 1х до 20х. Для быстрого переключения уровней от 1х до 10х можно также использовать горячие клавиши [Shift+F1] ... [Shift+F10] соответственно. Дополнительно уровни масштабирования продублированы в контекстном меню программы.

Как изменить визирную метку?

В программе имеется возможность изменить вид визирной метки. Для этого воспользуйтесь контекстным меню "Масштабирование -> Визирная метка" и выберите один из пунктов:
- Крестик
- Квадратик (вокруг выбранного пикселя)
- Нет (визирная метка отсутствует)


ColorMania : Extra Useful Info

Дополнительные сведения

Настройки программы

Некоторые свои настройки программа сохраняет в реестре Windows. Это сделано для того, чтобы при следующем запуске программа отобразила сделанные вами предпочтения, оставшиеся с момента её последнего использования.

Программа запоминает следующие параметры:
- текущий главный цвет
- используемую палитру цветов
- цвет текста и шрифт в окошке предварительного просмотра
- уровень масштабирования
- вид визирной метки
- позицию окна на экране
Параметры хранятся в реестре по пути HKEY_CURRENT_USER\Software\Blacksun\ColorMania.

ColorMania как часть программы

ColorMania входит в состав программ X-Fonter и Texefex, где используется в качестве диалога выбора цвета.


ColorMania : Keyboard Shortcuts

Клавишные команды

Формат цвета
  • Ctrl-H : HTML Hex
  • Ctrl-D : Delphi Hex
  • Ctrl-B : VB Hex
  • Ctrl-R : RGB Values
  • Ctrl-K : CMYK Values
  • Ctrl-P : Photoshop Values

    • Уровень масштабирования
  • Shift-F1 : Масштаб 1х
  • Shift-F2 : Масштаб 2х
  • Shift-F3 : Масштаб 3х
  • Shift-F4 : Масштаб 4х
  • Shift-F5 : Масштаб 5х
  • Shift-F6 : Масштаб 6х
  • Shift-F7 : Масштаб 7х
  • Shift-F8 : Масштаб 8х
  • Shift-F9 : Масштаб 9х
  • Shift-F10 : Масштаб 10х
  • Ctrl-Alt-Q : Сброс масштаба

    • Координаты
  • CTRL-ALT-C : установка координат (0,0) для текущего пикселя
  • CTRL-ALT-X : сброс координат в экранные координаты

    • Разное
  • CTRL-Z : Отменить изменение цвета
  • CTRL-ALT_Z : Повторить изменение цвета
  • F1 : Открыть файл справки
  • Alt-F4 : Выход из программы

    • Copyright © 2001-2011 Blacksun Software. All Rights Reserved